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CADD 
License & version: 

1. MicroStation V8i – 08.11.07.443 – SelectSeries2 
2. Geopak  V8i – 08.11.07.615 – SelectSeries2 
3. StormCAD V8i – 08.11.02.75 
4. Bridge  V8i – 08.11.07.55 
5. Rebar  V8i – 08.11.07.57 
6. Descartes V8i – 08.11.07.427 
7. LEAP          V11.00.01.05 

 

Quad/Orthophotos Web Page Links: 
HU 

http://nris.mt.gov/nsdi/orthophotos/naip_2011.asp  
HUhttp://nris.state.mt.us/nsdi/drgpages/quadsid.htmlU 

 
Acronym help guide for MDT: 
http://mdtinfo.mdt.mt.gov/tranplan/docs/tag.pdf 
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GEOPAK 
 
Project Manager issue:  

 
COGO Points Will Not Inverse:  
Delete all .rsc files from your local drive. Run KillTask.BAT 
 

Unable to Process Shape:  
Error trying to create my superelevation shapes.  The error says “Unable to process shape on chain 
PROPOSED…..”   
Check the chain definition for overlaps, generally points defined between curves, which are NOT 
normally needed. Redefine the chain, rerun the shapes and it should work. 
 

COGO Printing Problem:  
Delete .jou file in C:\dgn & retry. 
COGO > Navigator > Chain > Describe > File > Input File Utility  

  Select Output > give name > Apply 

 
Merge GPK Does Not Preload Anything: 
Check the GPK file names in your dgn. An odd named file will cause this to happen. GPK files should be named 
JOB###.GPK where ### = 3 digit number. 



   
 

Median Line ADHOC Overlap:  
XS lines overlap on median - Both UwidthsU are required, thus causing them to overlap. 

Set one or both to zero and the slope will be extended to meet where the median line is drawn. 

 
 
Ditch Drawn into a Fill Area:  
To draw a ditch into a fill area you must first design a profile for the low points of the ditch and use it in 
the cross section generation. 

Redefinable Variables Do Not Show: 
When redefinable variables entry does not show  

in the proposed cross reference dialog box...try 

this: 

1) Create a new Proposed Cross Section RUN. 
 

2) Delete file pxspri.inp from \dgn folder, 
restart job and try again. 
 

3) Run KillTask.BAT and try again. 
 

4) Rename file C:\mdoh\U####V8.upf and try 
again. #### = your U number.  If this works the file 
you renamed may be deleted. 
 



XS Decimal Places:  
The cross sections that are produced with the new criteria files show cross section elevations and offsets 
to four decimal places. To change the project setting to ensure this is correct go to Project Manager > 
Highlight the project > File > Edit > Preferences > Distance > Change to 99.12. Click OK twice. 

  
 

XS w/o Shoulders:  
If cross section is drawn w/o shoulders then the shoulder adhoc shape is probably missing on the design 
dgn OR – existing ground symbology was not matched correctly. 

Try redrawing the shoulder adhoc lines and then redo the cross sections. 

 
 

XS Multiple Ancillary Symbols:  
Multiple (or more) occurrences of a symbol appear on the cross sections then are present on the survey 
file. The survey file may show 2 or 3 symbols, but the ancillary features show these same symbols all 
over on the cross sections. SOLUTION – Drop status on the symbol in the design file and rerun the XS. 
 

XS Taper Line Beyond Limits of Chain Error:  
If I select "ok", it does plot my cross-sections.  However, the surfacing inslope does not plot correctly; it seems to 
default to a 10-ft surfacing inslope.   
SOLUTIONS:  Recreate the chain. 
 Adjust the grading delineation adhoc lines to be within the limits of the chain. 
Other possible fixes: Redraw the shoulder line adhocs. 
 Delete other shoulder lines crossing shapes. 
 Insure shoulder lines are outside of shapes. 
 Insure chain is longer than adhoc lines. 



 
 
XS Will Not Generate:  
Cross sections generate up to a specific pattern line and then nothing…the error looks like this: 

Station = 62+00.00, Region = 1 
%XS-W-PBDS, Two adjoining PGL/PROFILE DEPENDENT shapes are not 
on either side of the PGL.  This can produce incorrect cross-sections. 
Adjoining PGL/PROFILE DEPENDENT shapes should occur only when the 
shapes straddle the PGL.  The two shapes in question intersect the 
cross-section pattern for station 62+00.00 at the coordinate: 
2030282.9376,  345118.8547 
XS-W-NOASSOSTA The projection of the point at coordinate 
2030277.9379  345118.8031 is outside the limits of chain BIKE.  This point represents 
the intersection between the current pattern and a shape with the parameters: 
baseline = BIKE, 
profile = BIKE, 
tie =    0.00, 
pgl chain =, 
This error typically occurs under one of the following circumstances: 
- Chain is of insufficient length such that the projection of the above referenced point is outside the limits 
of the chain 
- Chain is improperly stationed 
- An incorrect baseline chain is referenced by the shape 
XS-E-CNCE Cannot calculate elevation at point with coordinates 
2030277.937896, 345118.803128 
Cross-section plotted 

Check that the chain does NOT start on a curve. Extend the chain past the curve or start it before the curve. This 
should result in cross sections to be generated as expected. 
 



No XS Cells to Process:  
Receiving a message saying "There are no Cross Section Cells to process with regards to current 

settings."   
Redraw the pattern lines associated with the problem cross sections then attempt existing cross 
sections again OR draw the cross sections using stations instead of dgn file. 

  OR 
On the cross section in question 36+15.00 there are 2 existing ground line segments,  one left of cl & one 
right that are blue, there on the wrong level, the color is fine but change them to the existing ground 
level and it should run. 
 

XS Not Correct on Seeding:  
Check the file for cross section cells that are not on the correct level. Even if they are off to the side and 
have no cross section on them, they can be causing problems. Probably on Default Level. 
 

XS Annotation Decimal Places:  
Set the decimal places on the annotated cross section offsets and elevations when we run proposed 
cross sections in CoGo. 

 
 

Super Shape (any GEOPAK) Text Looks Wrong: 
When drawing super shapes the text looks funny. Under Element\text styles should be set to none as 
shown below. Geopak uses the active font which s/b set to slanted. 

  
 

  



Limits of Construction Incorrect:  
What was causing this is the cross section cells are overlapping. Redraw cross sections and set the 
margins higher to insure no overlap of XS cells. 
Another cause of limits of construction errors:  Construction lines – only display if Construction is 
checked in View Attributes. This can cause problems elsewhere too – usually if an error occurs where 
nothing is drawn. 
 

No Totals Show for the Seeding Report:  
Change the station limits to go beyond the area needed, insuring the last station needed is processed, 
but stations not needed are not processed. Like last station is 250+50.00 – Enter 250+51.00 or 
250+50.05. 
 

Multiple Microstation/Geopak Sessions: 
When doing cross sections, earthwork & other functions with V8 many designers would open multiple 
Microstation & Geopak sessions for the same project. This practice is NOT RECOMMENDED by Bentley in 
V8i and can result in unexpected results when performing some operations, such as Drop Custom 
Linestyle. 
 

Traverse Frame File Problems:  
On the points file, if there are asterisks at the end of the entry, there should be no space between them 
and the elevations. 
NOT like this… 

 
Like this… 

 
These all worked w/o spaces. 
Also, on the description file I have found if there are TABs between the point name and description then 
The description is not matched to the corresponding point in the point file – thus the description does 

not show in the macro dialog.  

Open the .des in WORD and turned on the show paragraph marks. This shows tabs also. 

You can also see it in Notepad if you use the arrows between the point & description. It will jump to tabs 

instead of one space @ a time. Replace all tabs with spaces and the macro works great.  



Insert Degree (or any) Symbol in Text:  
Use the following to insert a symbol into a true type font. 

 

 

 



Convert State Plane Coordinates to Lat. and Long: 
1. In Microstation start Geopak survey. 
2. Click Geometry > Conversion > Geodetic. 
3. Once open fill in vertical datum and units used on your project on both source system and target 

system. 
4. Click on Geographic Coordinate Systems and click Select.  
5. Click the button to right of the Source box. 
6. On top, left select Projected [northing, easting,} > North America > United States of America. 
7. Find Montana and select (MT83F for US Foot, MT83IF for International Foot, or MT83 for 

Meters) depending on what your project was surveyed in. 
8. Make sure ellipsoid name is GRS1980. (Check with survey for the latest ellipsoid.) 
9. Click OK 
10. Click the button to right of the Target box. 
11. Select Geographic {Latitude, Longitude} > North America > United States of America. 
12. Select LL83-NAD83 Lat./Long, Degrees, 
13. Check to make sure ellipsoid is GRS1980. (Unless it has changed.) 
14. Click OK 
15. Make sure Source and Target boxes contain what you picked. 

 
16. Check both Use Model Coordinate System For Source and Use Model Coordinate System For 

Target boxes.  
17. Click OK. 
18. You should be able to type in the coordinates you want to convert in the source point box. 
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MICROSTATION 
 

FILE Fixer – Attempting to Fix a Corrupt DGN File: 
SOP1 

1. Create a new dgn  
2. Reference the corrupt dgn to the new one, 
3. Turn on all the used levels that you want 
4. Fence and copy the element to the new 

dgn 
5. Compress the new file 
6. If all is well, delete the corrupt file and 

rename the new file to what it needs to 
be. 

 

SOP2 
1. Utilities > Data Cleanup 
2. Select Duplicates 
3. Action Delete 
4. Highlight all elements 
5. Click Apply. 
6. Compress file 
7. Run FileFixer (CADD support only) 
8. Attempt re-process 

Info Snap: – MDT does not support this feature in MicroStation. 

 
Lost Views: 
In MicroStation you may move a view around and lose it and can’t find it again. For example you move 
the view off of the screen too far. 
If this happens you can retrieve your view by going to the pull down menu Window and click on Tile or 
Cascade and your view will show in your screen again. If they still don’t show make sure the window you 
are using is turned on in the same pull down menu Window - Views or at the bottom near the view 
control menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Pop Set Option: 
When I start to draw an element my Tool Settings window disappears. How can it get it to stay on the 
screen while I draw an element? 
The Pop Set option has been turned on. Click on the green button and it will turn it red and back off. 
 

 
 
 
 

Location of Pop 

Set 

 



Red = Pop Set is off and the Pop Set always stays open while drawing an element. 

Green = Pop Set is on and the Pop Set will disappear when you start your command that you have 
selected like place line or place ellipse. 

Change default upf: 
1. Open .dgn using icon  
2. File > Close (Check save on close preference) 
3. User – Change to MDT even if MDT shows 
4. Open File – should be set 
5. File > Exit 
6. Double-click .dgn file – the expected .upf should be used now 

 

Attaching References:  
Always use (coincidence world) when attaching references. The reference is aligned to the active file through the 
global origins. That is, the reference file Global Origin location is lined up to the active file Global Origin. 
 

Active Annotation Scale:  
I have referenced my drawing into the sheet layout and now the dimensions and some of the text are tiny.  I tried 
changing the annotation scale, but when it looked right on the sheet layout, the other view was absurdly large.  
Use Active Annotation Scale is turned on for the references. 
There were some text place true scale and some not in the reference file. 
Turning off Active Annotation Scale on the reference should fix the problem. 

 
 

Make sure Copy Attachments is set too. 



Changing Fonts Within a Text String Problem:  
Change individual characters font within a text string. 
This can be done by placing the text with one font and then getting into the text editor. Select the text 
and highlight the character or characters to change. Click off the option of "Apply changes to all text".  
Change the font and click in the screen to accept the changes.  
 

 
 

Create a new cell: 
 Open MicroStation using any .dgn file.  

 Attach the cell library to place the cell into. 

 Browse the cell library until you find a cell similar to the one being created. 

 Highlight it and right-click. Left-click Open For Editing. This opens the cell enabling it to be changed. 

 Open the Models menu. Left-click on “copy a model”. This opens a window you can change the name of 
the cell being created. Change the name and description, click OK. Now you can change the cell and when 
you close, it will be saved under the new name. 

 
You can use the cell editor too. 
 

 

 

Create a new line type: 
Open MicroStation using any .dgn file.  
Element > line styles > custom - shows the existing 
line styles which are located in the 
W:\RESOURCES folder. 
Element > line styles > edit 
Edit > create > compound – allows creation of 
new line style. 
Change the description and name. Save the 
resource file. 
You may have to create stroke pattern or point 



files if what you need does not exist. 
 Edit > create > point 
 After creating these, save the resource file to insure they are available. 
Edit the new line style and make sure it contains the correct stroke pattern(s) and/or point files. 
When exiting the Line Style Editor save the changes. 
Then bring up the resource file to insure the line style is available and correct. 
FOR TESTING – copy a resource file from W:\resource into C:\mdoh folder. 
 Create the new line style into that file. 
 Exit and restart MicroStation – it should show the new line style in custom now. 
 

Delete part of something from a reference: 
 Fence element to clip 

 Open reference 

 Highlight reference file 

 Right-click > Clip Mask 

 Make sure Element shows in the clip Method 

 Select the Element used to clip 

 Select into the drawing 
 

Duplicate or Non-conforming Levels: 
A file showed duplicate levels. 
They have the same level numbers as RW – EXISTING and show up when using that filter. 
I didn’t find them in either the dgnlib or plane.ref. 
They were defined in the design file – this could happen if those levels existed when the file was 
created.  Example file 4051002ROMAP001.dgn 
 

Open up the Level Manager and click on the 3rd icon:    
 
This updates the levels to conform to the current standard.dgnlib which contains all level definitions. 
NOTE: This changes ALL levels to current standards and DELETES any levels that are not defined in the 
dgnlib. If you have non-standard levels you need to keep, then a manual process will be required to fix 
the levels. 
 

  



Levels only show when made current: 
Levels do not show when you click on them - only if they are made current - after that they show. 

   
Open the Level Display > Click on Type of On/Off Switch & Set to Global Display 
Right click on any level name > Set All On 
Click Type of On/Off Switch & Set to View Display – now each level should display w/single click. 
 

  



Delete Duplicate Elements (Data Cleanup): 
If you have duplicate elements in a design file and want to select or delete them you can do it by using 
the Utilities-Data Cleanup tool.  You can Select or Delete elements and use Element Type criteria or 
Match Criteria to select specific element types. Apply it and it will process your choices. If you use select, 
it will tell you at the bottom of the screen how many duplicate elements it located.  

  
 
Incorrect Symbology When Placing a Cell: 

  
Make sure the Level Overrides is NOT set in the view attributes. 
 



Symbology Override Problem: 
 Level and/or symbology shows a ghost-like element displayed when tentative on the line or text. 
 Check the override properties on that particular level:  Level manager > highlight level w/problem > 
Properties 
 Insure the symbology overrides are set OFF. 

       
 

Convert 2D to 3D file: 
 Enter keyin command: mdl load cnvdgn 
  
If you are in a 2D file the Save 2D as 3D dialog box opens, otherwise; it opens Save 3D as 2D. Enter the name of the 
new file to be created and it will create it in the directory selected. 
 

 
 



Invalid, Invisible Lines: 
 
When lines are drawn using the “Draw Ancillary Features” screen, on occasion lines are drawn that do NOT display 
and should NOT be present in the drawing. 
 

          
 
 

This element view shows the lines are part of the 
complex chain but are not displayed. 
 
 
File name to be used: 2145DIMAP008.DGN 

To show the lines:  Fence the area containing the bad lines. 
Select Drop Line Style > Select a line to display – you will see the bad line. 
Be sure to UNDO this function. 
 

The solution to removing these lines is as 
follows: 
Edit > Select All 
Drop Element > check Line Strings/Shapes > 
data click to accept the change. 
 
Select the line to delete > Delete 
 
 
 
 
 



MicroStation to Word: 
From Word > Insert > Screenshot > fence the MicroStation screen to put into Word. 

Perfect! 
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OTHER 
Print Part of a Page from a .PDF File: 

 
 Print onto a full page:  

 In Adobe Reader > Select 

 Fence the area to be printed 

 File > Print  

 Print Range > Current View 

 Page Scaling > Fit to Printer 
 
 
 
 

 

 

 

 

Set a PDF File so it Opens in the Browser: 

 
 

1) Right click on one of the 
hyperlink lines – opens the 
dialog box shown. 

2) Left click on Page Display 
Preferences 



 

3) Left click Internet category. 
4) Check on Display PDF in 

browser. 
5) Click OK. 

 
This causes PDF files to open in the 
browser, enabling the hyperlinks to work 
via the browser also. 
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