The information provided in this manual is a product of MDT and is not to be sold or otherwise distributed for profit. If this manual is copied proper acknowledgment is to be given to Bentley Systems, Incorporated for its content in this manual. There are no expressed or implied warranties concerning the accuracy, completeness, reliability or usability of this information. Further, MDT assumes no responsibility for any incorrect results or damage resulting from the use of this information. All users shall expressly hold MDT harmless from any liability or loss due to any computer or software generated problems associated with this product or manual.

StormCAD and MicroStation are registered trademark of Bentley Systems, Incorporated. Windows and Windows NT are registered trademarks of Microsoft Corporation. All other brands and products names are trademarks of their respective owners. © Bentley Systems, Incorporated.
MDT StormCAD Process

A specific setup process should be used to insure the StormCAD software works as expected on your MDT workstation.

- Notify MDT CADD Support that you want StormCAD install onto your computer
- A Help Desk Request is initiated to have ISD install the software
- The person installing StormCAD must also do the following after install:
  Start > All Programs > Bentley > StormCAD V8i > Integrate StormCAD V8i with AutoCAD, MicroStation

This places the icon needed to initiate StormCAD onto your desktop
You can right-click on this icon and rename it

- The Target must have the parameter changed to msstmdt

When starting a StormCAD drawing, use W:\SEED\HY\SEED_StormCAD.dgn as the seed file. Your project drawing may then be referenced attached to it. This is important as otherwise the Layout Tools may not work as expected.
Chapter 1

Getting Started in Bentley StormCAD V8i

QuickStart Lessons

Introducing the Workspace

Using ModelBuilder to Transfer Existing Data

Creating Models

Scenarios and Alternatives

Calculating Your Model

Presenting Your Results

Theory

Gravity Flow Diversions

About Bentley Systems
Bentley StormCAD V8i 1

Getting Started in Bentley StormCAD V8i 1

What is StormCAD V8i? 1
Municipal License Administrator Auto-Configuration 2
Starting Bentley StormCAD V8i 2
Working with StormCAD V8i Files 2
Exiting StormCAD V8i 4
Using Online Help 4
Software Updates via the Web and Bentley SELECT 8
Troubleshooting 8
Checking Your Current Registration Status 9
Differences in Terminology Between StormCAD V8i and Storm-CAD V8i for United Kingdom 9

QuickStart Lessons 11

Lesson 1: Creating a Schematic Network 12
   Part 1 - Creating a New Schematic Project File 12
   Part 2 - Laying Out the Network 13
   Part 3 - Entering Data 16
      ENTERING DATA USING FLEXTABLES 23
   Part 4 - Defining Storm Events 26
   Part 5 - Analyzing the System 29

Lesson 2 - Automatic Design 30
   Part 1 - Creating the Project File 30
   Part 2 - Defining Design Parameters 33
   Part 3 - Performing the Automatic Design 38

Lesson 3 - Scenario Management 39
   Part 1 - Creating a New Alternative 40
   Part 2 - Creating New Scenarios 43
   Part 3 - Calculating Multiple Scenarios 46

Lesson 4 - Presentation of Results 46
   Part 1 - Reports 47
   Part 2 - FlexTables 50
   Part 3 - Profiles 53
   Part 4 - Annotation 56
   Part 5 - Color Coding 65
Introducing the Workspace 73

Menus 73
- File Menu 74
- Edit Menu 76
- Analysis Menu 76
- Components Menu 77
- View Menu 78
- Tools Menu 79
- Report Menu 81
- Help Menu 81

Toolbars 83
- Layout Toolbar 83
- Standard Toolbar 85
- Edit Toolbar 86
- View Toolbar 87
- Scenarios Toolbar 88
- Compute Toolbar 88
- Tools Toolbar 89
- Help Toolbar 90
- Components Toolbar 91
- Reports Toolbar 92
- Select Toolbar 92
- Zoom Toolbar 93

Customizing StormCAD V8i Toolbars and Buttons 94
- StormCAD V8i Dynamic Manager Display 95

Customizing Managers 98

Stand-Alone 100
- The Drawing View 100
  - PANNING 100
  - ZOOMING 101
  - DRAWING STYLE 105
- Using Aerial View 106
- Using Background Layers 107
  - IMAGE PROPERTIES 113
  - SHAPEFILE PROPERTIES 115
  - DXF PROPERTIES 116

MicroStation Environment 117
- Getting Started in the MicroStation environment 119
- The MicroStation Environment Graphical Layout 121
- MicroStation Project Files 122
  - SAVING YOUR PROJECT IN MICROSTATION 123
- Bentley StormCAD V8i Element Properties 123
  - ELEMENT PROPERTIES 123
  - ELEMENT LEVELS DIALOG 124
TEXT STYLES 124

Working with Elements 124
   EDIT ELEMENTS 125
   DELETING ELEMENTS 125
   MODIFYING ELEMENTS 125
   CONTEXT MENU 125

Working with Elements Using MicroStation Commands 125
   BENTLEY STORMCAD V8/ CUSTOM MICROSTATION ENTITIES 126
   MICROSTATION COMMANDS 126
   MOVING ELEMENTS 126
   MOVING ELEMENT LABELS 127
   SNAP MENU 127
   BACKGROUND FILES 127
   IMPORT BENTLEY STORMCAD V8/ 127
   ANNOTATION DISPLAY 127
   MULTIPLE MODELS 128

Working in AutoCAD 128
The AutoCAD Workspace 129
   AUTOCAD INTEGRATION WITH STORMCAD V8/ 129
   GETTING STARTED WITHIN AUTOCAD 129
   MENUS 130
   TOOLBARS 131
   DRAWING SETUP 131
   SYMBOL VISIBILITY 131
   AUTOCAD PROJECT FILES 131
   DRAWING SYNCHRONIZATION 132
   SAVING THE DRAWING AS DRAWING*.DWG 133

Working with Elements Using AutoCAD Commands 133
   STORMCAD V8/ CUSTOM AUTOCAD ENTITIES 134
   EXPLODE ELEMENTS 134
   MOVING ELEMENTS 135
   MOVING ELEMENT LABELS 135
   SNAP MENU 135
   EDITING CONTOURS 135
   POLYGON ELEMENT VISIBILITY 135
   UNDO/REDO 136
   LAYOUT OPTIONS DIALOG 137

Using ModelBuilder to Transfer Existing Data 139

Preparing to Use ModelBuilder 139

ModelBuilder Connections Manager 142

ModelBuilder Wizard 146
   Step 1—Specify Data Source 147
   Step 2—Specify Spatial Options 149
Step 3 - Specify Element Create/Remove/Update Options 151
Step 4—Additional Options 153
Step 5—Specify Field mappings for each Table/Feature Class 156
Step 6—Build operation Confirmation 160

Reviewing Your Results 161
Multi-select Data Source Types 161
ModelBuilder Error Messages 161
Error Messages 162
Specifying Network Connectivity in ModelBuilder 163
Sample Spreadsheet Data Source 164

The GIS-ID Property 165
GIS-ID Collection Dialog Box 167
Specifying a SQL WHERE clause in ModelBuilder 167

ModelBuilder Import Procedures 168
Importing Pump Definitions Using ModelBuilder 168
Using ModelBuilder to Import Pump Curves 173
Using ModelBuilder to Import Patterns 177

Creating Models 183

Starting a Project 183
Bentley StormCAD V8/Projects 184
Setting Project Properties 185
Setting Options 186
OPTIONS DIALOG BOX - GLOBAL TAB 187
  Stored Prompt Responses Dialog Box 191
OPTIONS DIALOG BOX - PROJECT TAB 192
OPTIONS DIALOG BOX - DRAWING TAB 194
OPTIONS DIALOG BOX - UNITS TAB 196
OPTIONS DIALOG BOX - LABELING TAB 199
  Conduit Description Format Dialog Box 201
OPTIONS DIALOG BOX - PROJECTWISE TAB 201
Working with ProjectWise 202

ProjectWise and Bentley StormCAD V8i 202
Performing ProjectWise Operations from within StormCAD V8i 204
Using ProjectWise with StormCAD V8i for AutoCAD 206
ABOUT PROJECTWISE GEOSPATIAL 206
  Maintaining Project Geometry 207
Setting the Project Spatial Reference System 207
  Interaction with ProjectWise Explorer 208
Importing Data From Other Models 209
IMPORTING SUBMODELS 209
IMPORTING LANDXML FILES 210
IMPORTING DATA FROM A STORMCAD V8i DATABASE 211
Importing GEOPAK/PowerCivil Drainage Files 212
Exporting to GEOPAK/PowerCivil Drainage Files 221

**Additional 221**

IMPORTING A BENTLEY INROADS STORM AND SANITARY V8/MODEL INTO STORMCAD 222

All Links 222
Channels 225
Nodes 226
Manholes 227
All Inlets 228
Grate Inlets 229
Curb Inlets 229
Other Inlets (Unique to InRoads) 230
All Gutters 230
Uniform Gutters 230
Swale Gutters 231
Composite Gutters 231
Catchments 231
Time of Concentration 233
Design 236

INROADS DRAINAGE IMPORT 237
IMPORTING/EXPORTING MICRO DRAINAGE FILES 238

Special Considerations When Exporting to Micro Drainage 239

IMPORT / EXPORT BENTLEY MX DRAINAGE (LANDXML FORMAT) 240

LandXML Feature Additions to Support Bentley MX 240

Exporting Data 244
EXPORTING A .DXF FILE 244
EXPORTING A SUBMODEL 244
EXPORTING LANDXML 245
EXPORTING A BENTLEY INROADS STORM AND SANITARY V8/MODEL FROM STORMCAD 246

Elements and Element Attributes 250

Link Elements 250
Conduit Elements 250
Gutter Elements 251

ENTERING ADDITIONAL DATA TO LINK ELEMENTS 251
Defining the Geometry of a Link Element 252
Diversion Rating Curve Dialog Box 252
Irregular Channel Dialog Box 252

SPLIT (BIFURCATED) IRREGULAR CHANNELS 255
WHAT HAPPENS WHEN THE WATER LEVEL EXCEEDS THE TOP ELEVATION OF AN OPEN CHANNEL? 255

Catch Basins 256
INLET TYPE 256
INFLOW CAPTURE CURVE 256
Manholes 257
Transitions 257
TRANSITION DIAGRAMS 258
Outfalls 259
ADDITION OF ELEVATION VS. FLOW DATA TO AN OUTFALL 260
Elevation-Flow Curve Dialog Box 260
Catchments 261
SPECIFYING A TIME OF CONCENTRATION (TC) METHOD FOR A
CATCHMENT 261
Tc Data Collection Dialog Box 262
RATIONAL CATCHMENT COLLECTION DIALOG BOX 265
MODIFIED RATIONAL METHOD (UK) CATCHMENT COLLECTION DIA-
LOG BOX 265
POLYGON VERTICES DIALOG BOX 266
Other Tools 266
BORDER TOOL 266
TEXT TOOL 266
LINE TOOL 267
Flow-Headloss Curves 268
Flow-Headloss Curves Dialog Box 269
FLOW-HEADLOSS CURVE LIBRARY EDITOR 270
Adding Elements to Your Model 270
Connecting Elements 272
When To Use a Conduit vs. a Gutter 272
How Do I Get Rainfall from a Catchment Into the Rest of My Model? 272
Modeling Catch Basins and Manholes 273
Manipulating Elements 274
Select Elements 275
Splitting Pipes 276
Reconnect Pipes 277
Modeling Curved Pipes 277
POLYLINE VERTICES DIALOG BOX 278
Batch Pipe Split Dialog Box 279
BATCH PIPE SPLIT WORKFLOW 280
Merge Nodes in Close Proximity 281
Editing Element Attributes 282
Property Editor 282
Find Element 283
LABELING ELEMENTS 285
RELABELING ELEMENTS 285
SET FIELD OPTIONS DIALOG BOX 286

Adding Storm Data 287
Storm Data Dialog Box 288
User Defined IDF Table 290
Hydro-35 291
IDF Table Equation 292
IDF Curve Equation 293
IDF Polynomial Log Equation 294
  Global Storm Events Dialog Box 297
  User Defined IDF Table Dialog Box 298
  IDF CURVE DIALOG BOX 298
  IDF Curve Equation Input Dialog Box 298
  IDF Polynomial Log Equation Dialog Box 299

Creating Inlets 300
Inlet Catalog Dialog Box 301
Default Curb and Grate Lengths 305
  DESIGN GRATING TYPES DIALOG BOX 306
  DESIGN LENGTHS DIALOG BOX 307
  KERB CHANNEL VS CAPTURED FLOW DIALOG BOX 308
  Modeling Neenah Grates 308

Using Named Views 311

Using Selection Sets 313
  Selection Sets Manager 314
  Group-Level Operations on Selection Sets 319

Using the Network Navigator 320
  Query Parameters Dialog Box 323

Using Prototypes 324

Automatic Design 328
  Using Automatic Constraint Based Design 328
  Default Design Constraints 331

Gravity Pipe Tab 331
Node Tab 333
Inlet Tab 333
  Conduit and Inlet Catalog Templates 334

Engineering Libraries 335
  Converting Legacy Engineering Library Files 339

Conduit Catalog Dialog Box 340

Hyperlinks 343

Using Queries 351
  Queries Manager 351
  QUERY PARAMETERS DIALOG BOX 354
  Creating Queries 355
Query Builder Dialog Box 357
  USING THE LIKE OPERATOR 360
Query Examples 361
  QUERYING BY DATE 362
Using T Rex to Assign Node Elevations 363
  T Rex Wizard 363
Step 1: File Selection 363
Step 2: Completing the T Rex Wizard 364

User Data Extensions 365
  User Data Extensions Dialog Box 367
    FORMULA DIALOG BOX 371
  Sharing User Data Extensions Among Element Types 372
  Shared Field Specification Dialog Box 374
  Enumeration Editor Dialog Box 374
  User Data Extensions Import Dialog Box 376

Customization Manager 376
  Customization Editor Dialog Box 377

External Tools 378

Scenarios and Alternatives 381

Understanding Scenarios and Alternatives 381
  Advantages of Automated Scenario Management 381
  A History of What-If Analyses 382
  Distributed Scenarios 382
  Self-Contained Scenarios 383
  The Scenario Cycle 384
    385
  Scenario Attributes and Alternatives 385
  A Familiar Parallel 385
  Inheritance 386
    OVERriding Inheritance 387
    Dynamic Inheritance 387
  Local and Inherited Values 388
  Minimizing Effort through Attribute Inheritance 388
  Minimizing Effort through Scenario Inheritance 389

Scenario Example - A Water Distribution System 390
  Building the Model (Average Day Conditions) 391
  Analyzing Different Demands (Maximum Day Conditions) 391
  Another Set of Demands (Peak Hour Conditions) 392
  Correcting an Error 392
  Analyzing Improvement Suggestions 393
  Finalizing the Project 394
Advantages to Automated Scenario Management 394

**Scenarios 395**
- Scenarios Manager 396
- Base and Child Scenarios 397
- Creating Scenarios 398
  - EDITING SCENARIOS 399
- Running Multiple Scenarios at Once (Batch Runs) 399
  - Batch Run Editor Dialog Box 401

**Alternatives 401**
- Alternatives Manager 402
- Alternative Editor Dialog Box 404
- Base and Child Alternatives 405
- Creating Alternatives 405
- Editing Alternatives 406

- Active Topology Alternative 407
- Physical Alternative 408
  - PHYSICAL ALTERNATIVE FOR CONDUITS 409
    - Conduit Description Attribute 412
  - PHYSICAL ALTERNATIVE FOR MANHOLES 413
  - PHYSICAL ALTERNATIVE FOR CATCH BASINS 413
  - PHYSICAL ALTERNATIVE FOR TRANSITIONS 415
  - PHYSICAL ALTERNATIVE FOR OUTFALLS 415
- Headloss Alternatives 416
- Boundary Condition Alternatives 417
- Rainfall Runoff Alternative 418
- Rainfall Runoff Alternative for Global Rainfall 418
- Hydrologic Alternatives 418
- Hydrology Alternative for Catch Basins 418
- Hydrology Alternative for Catchments 418
- Design Alternative 419
- Gravity Pipe Tab 420
- Node Tab 422
- Inlet Tab 422
  - System Flows Alternatives 424
  - User Data Extensions Alternative 424
  - Capital Cost Alternative 424

**Calculation Options 424**

**Scenario Comparison 425**
- Scenario Comparison Options Dialog Box 428
- Scenario Comparison Collection Dialog Box 429
Calculating Your Model 431

Calculation Options Manager 431

Creating Calculation Option Sets 432
  Calculation Option Set Attributes 433
  BEND ANGLE vs. BEND LOSS CURVE DIALOG BOX 438
  GRATING PARAMETERS DIALOG BOX 439
  BEND ANGLE vs KM COLLECTION DIALOG BOX 440

Calculation Executive Summary Dialog Box 440

Calculation Detailed Summary Dialog Box 441
  Calculation Options Tab 441
  Catchment Summary Tab 443
  Conduit Summary Tab 443
  Node Summary Tab 444
  Inlet Summary Tab 445

User Notifications 445

Theory 449

Hydrologic Principles 449
  Rational Loading 450
    CATCHMENT AREAS 451
    RATIONAL COEFFICIENT 451
    COMPOSITE CATCHMENTS 451
    TIME OF CONCENTRATION 452
    SYSTEM TIME / CONTROLLING TIME / DURATION 452
    RAINFALL INTENSITY 453
    RETURN PERIOD AND FREQUENCY 454
    INTENSITY DURATIONS FREQUENCY DATA 454
    RAINFALL TABLES 455
    RAINFALL EQUATIONS THEORY 455
    BASIC ASSUMPTIONS ABOUT THE RATIONAL METHOD 455

Additional Flow Loading 456
  Known Flow Loading 456
    KNOWN FLOWS PRIOR TO STORMCAD v3 456

Location of Flows 457
  SURFACE CATCHMENT LOADS 460
  SURFACE CARRYOVER LOADS 460
  INLET APPROACH LOADS 460
  INLET CAPTURED (INTERCEPTED) LOADS 461
  INLET BYPASSED LOADS 461
  SUBSURFACE PIPED LOADS 461
  SUBSURFACE EXTERNAL LOADS 461
  SUBSURFACE TOTAL PIPED LOAD 461

The Energy Principle 462
THE ENERGY EQUATION 463
HYDRAULIC AND ENERGY GRADES 463
Hydraulic Grade 464
Energy Grade 464
HGL CONVERGENCE TEST 464
Friction Loss Methods 465
CHEZY’S EQUATION 465
KUTTER’S EQUATION 465
COLEBROOK-WHITE EQUATION 466
HAZEN-WILLIAMS EQUATION 467
DARCY-WEISBACH EQUATION 467
Swamee and Jain Equation 468
MANNING’S EQUATION 469
Flow Regime 470
PRESSURE FLOW 470
UNIFORM FLOW AND NORMAL DEPTH 470
CRITICAL FLOW, CRITICAL DEPTH, AND CRITICAL SLOPE 471
Subcritical Flow 471
Supercritical Flow 471
Gradually Varied Flow Analysis 472
SLOPE CLASSIFICATION 472
Adverse Slope 472
Horizontal Slope 473
Hydraulically Mild Slope 473
Critical Slope 473
Hydraulically Steep Slope 473
ZONE CLASSIFICATION 473
PROFILE CLASSIFICATION 474
Energy Balance 475
STANDARD STEP METHOD 476
DIRECT STEP METHOD 476
Mixed Flow Profiles 476
SEALING (SURCHARGING) CONDITIONS 477
RAPIDLY VARIED FLOW 477
Backwater Analysis 477
FREE OUTFALL 478
STRUCTURE FLOODING 478
Frontwater Analysis 478
Pipe Average Velocity 479
UNIFORM FLOW VELOCITY 479
FULL FLOW VELOCITY 479
SIMPLE AVERAGE VELOCITY 479
WEIGHTED AVERAGE VELOCITY 480
PIPE AVERAGE VELOCITY AND TRAVEL TIME 480
Capacity Analysis (Approximate Profiles) 480
FULL CAPACITY PROFILES 481
EXCESS CAPACITY PROFILES 481
Excess Capacity Profile, Case 1 (Hydraulic Grade <= Normal Depth): 481
Excess Capacity Profile, Case 2 (Normal Depth < Hydraulic Grade <= Pipe Crown) 482
Excess Capacity Profile, Case 3 (Hydraulic Grade >= Pipe Crown) 482

COMPOSITE EXCESS CAPACITY PROFILES 483

Conduit Shapes 483
CIRCULAR CHANNEL 484
TRAPEZOIDAL CHANNEL 484
ELLIPSE 485
PIPE-ARCH 486
TRIANGLE 487
RECTANGULAR CHANNEL 487
IRREGULAR OPEN CHANNEL 487

Junction Headlosses 488
STRUCTURE HEADLOSS 488

Headloss - Absolute Method 488
Headloss - Standard Method 488
Headloss - Generic Method 489
Headloss-HEC-22 Energy Method 490
Headloss - Flow-Headloss Curve Method 490

SPECIAL ASSUMPTIONS 490

Pressure Flow, Free Surface Flow, and Transitional Flow 491
Initial Headloss Coefficient 491
Correction for Pipe Diameter 491
Correction for Flow Depth 492
Correction for Relative Flow 492
Correction for Plunging Flow 493
Correction for Benching 493

Headloss - AASHTO Method 495
AASHTO Contraction Loss 496
AASHTO Bend Loss 496
AASHTO Bend Loss Original Equation 497
AASHTO Expansion Loss 498
AASHTO Correction For Non-Piped Flow 498
AASHTO Correction for Shaping 498

Manhole Head Loss Equations (AASHTO/HEC-2 Overview) 499

Open and Closed Channel Weighting Methods 499

Inlet Hydraulics 502

HEC-22 Inlet Capacity Calculations 503
UK GRATING AND KERB INLETS 503
Grating (UK) Inlets 504
Kerb (UK Inlets) 505

Flows in Gutters on Grade 507
UNIFORM GUTTER CROSS SLOPE 507
COMPOSITE GUTTER SECTION 509
Flow in Ditch or Median Section on Grade 511
Inlet Analysis 512
INLETS ON GRADE 513
Grate Inlet on Grade 514
Curb Inlet on Grade 516
Slot Inlet on Grade 518
Combination Inlet on Grade 518

INLETS IN SAG 519
Grate Inlet in Sag 519
Curb Inlet in Sag 520

WEIR FLOW 521
ORIFICE FLOW 522
TRANSITION FLOW 523

Slot Inlet in Sag 523
WEIR FLOW 523
ORIFICE FLOW 524
TRANSITIONAL FLOW 524
Combination Inlet in Sag 524
EQUAL LENGTH INLETS 524
SWEEPER INLET 525

Time of Concentration 526
Minimum Time of Concentration 528
User-Defined 528
Carter 528
Eagleson 528
Espy/Winslow 529
Federal Aviation Agency 529
Kerby/Hathaway 529
Kirpich (PA) 530
Kirpich (TN) 530
Length and Velocity 531
SCS Lag 531
TR-55 Sheet Flow 531
TR-55 Shallow Concentrated Flow 532
TR-55 Channel Flow 533

Constraint Based Automatic Design 533
Subsurface Design 533
PIPE AND SUBSURFACE NODE STRUCTURE DESIGN 534
PART FULL DESIGN 534
ALLOW MULTIPLE SECTIONS 536
LIMIT SECTION SIZE 537
PIPE MATCHING 537
OFFSET MATCHING 537
DROP STRUCTURES 537
STRUCTURE INVERT ELEVATIONS 537
DESIGN PRIORITIES 538

Inlet Design 541

Special Considerations 542
Energy Discontinuity 542
Structure Energy Grade 543
Design Considerations 543
Carrier Pipes 543
Partial Area Effects 548
Flow Balance at Junctions 557

**Modified Rational (UK) Loading 559**
Modified Rational Coefficients 559
Time of Concentration 562
UK Standard Rainfall Intensities 563
Areal Reduction Factors 566
Basic Assumptions 567

**Engineer’s Reference 567**
Rational C Coefficients 568
Headloss Coefficients for Junctions 569
Roughness Values—Manning’s Equation 570
Roughness Values—Kutter’s Equation 573
Roughness Values—Darcy-Weisbach (Colebrook-White) Equation 575
Roughness Values—Hazen-Williams Formula 576

**Presenting Your Results 581**

**Annotating Your Model 581**
Using Folders in the Element Symbology Manager 585
Annotation Properties 588
FREE FORM ANNOTATION DIALOG BOX 589

**Color Coding A Model 590**
Color Coding Legends 594

**Contours 594**
Contour Definition 596
Contour Plot 598
Contour Browser Dialog Box 599

**Using Profiles 599**
Profile Setup 602
Profile Viewer 603
Engineering Profile Viewer Dialog Box 605
ENGINEERING PROFILE OPTIONS 607

Axis Tab 607
Drawing Tab 608
Layers Tab 608
GROUND PROFILE OPTIONS 608
ANNOTATION PROPERTIES DIALOG BOX 608
LINK ANNOTATION PROPERTIES DIALOG BOX 609
Viewing and Editing Data in FlexTables 611
  FlexTables 612
  Working with FlexTable Folders 614
  FlexTable Dialog Box 615
  Opening FlexTables 617
  Creating a New FlexTable 618
  Deleting FlexTables 619
  Naming and Renaming FlexTables 619
  Editing FlexTables 619
  Sorting and Filtering FlexTable Data 623
    CUSTOM SORT DIALOG BOX 626
  Customizing Your FlexTable 627
  Element Relabeling Dialog 628
  FlexTable Setup Dialog Box 630
  Copying, Exporting, and Printing FlexTable Data 632
  Statistics Dialog Box 634
  2-Row Flextables 634

Reporting 635
  Using Standard Reports 635
    REPORTS FOR INDIVIDUAL ELEMENTS 635
    CREATING A SCENARIO SUMMARY REPORT 636
    CREATING A PROJECT INVENTORY REPORT 636
    CREATING A CONDUIT INVENTORY REPORT 636
    CREATING A DOT REPORT 636
    REPORT OPTIONS 636

Print Preview Window 638

Gravity Flow Diversions 641

Basic Concepts 641
  What Are Diversions? 641
  What Happens to the Flow at a Diversion? 646
  Why do Diversions Exist only in Gravity Systems? 647
  Is a Surcharged Gravity Pipe Considered a Pressure Pipe? 647
  How Can a User Model a Diversion? 647
  What Happens to the Diverted Flow? 648
  Are There Rules for the Diversion Targets? 649
  What Does a Diversion Look Like in the Drawing? 651
  How Does a Diversion Split the Flow Between Flow Being Piped Downstream and Flow Being Diverted? 651

Rating Curves 651
  How Many Data Points Do I Need to Describe a Rating Curve? 652
  How Can the Values for the Rating Curve be Determined? 652
What if Flow Measurements Cannot Be Obtained? 653

**Special Cases 653**
- Hydraulic Restrictions 653
- How Can Parallel Relief Sewers be Modeled? 653
- How Can Diversions be Used to Model Off-line Storage? 655
- How Should the Models be Used to Handle Basement Flooding? 655
- Modeling the Effect of Tailwater Depth on the Rating Curve 656
- Can I Divert Water Uphill? 656
- Where Can I Enter and View Data on Diversions? 656
- Diversion Profiles 656

**About Bentley Systems 659**

**Software 660**
- CivilStorm 660
- WaterGEMS 661
- WaterCAD 661
- StormCAD 662
- SewerGEMS 662
- PondPack 663
- FlowMaster 663
- CulvertMaster 663
- HAMMER 663

**Bentley Institute Press 664**

docs.bentley.com 665

**Bentley Services 666**

**Bentley Discussion Groups 667**

**Bentley on the Web 667**

**TechNotes/Frequently Asked Questions 667**

**BE Magazine 667**

**BE Newsletter 667**

**Client Server 668**

**BE Careers Network 668**

**Contact Bentley Systems 668**

**References 679**
Getting Started in Bentley StormCAD V8i

What is StormCAD V8i?

Municipal License Administrator Auto-Configuration

Starting Bentley StormCAD V8i

Working with StormCAD V8i Files

Exiting StormCAD V8i

Using Online Help

Software Updates via the Web and Bentley SELECT

Troubleshooting

Checking Your Current Registration Status

1.1 What is StormCAD V8i?

Bentley StormCAD V8i is an extremely powerful program for the design and analysis of gravity flow pipe networks.

The program can be run within MicroStation or AutoCAD, giving you all the power of those software packages' capabilities, or in Stand-Alone mode utilizing its own graphical interface. StormCAD V8i allows you to construct a graphical representation of a pipe network containing all your information, such as pipe data, inlet characteristics, watershed areas, and rainfall information. You have a choice of conveyance elements including circular pipes, pipe arches, boxes and more. Rainfall information is calculated using rainfall tables, rainfall equations, or the National Weather Service's Hydro-35 data. StormCAD also plots the resulting Intensity Duration Frequency Curves.
The gravity network is solved using the built-in numerical model, which utilizes both the direct step and standard step gradually varied flow methods. Flow calculations are valid for both pressure and varied flow situations, including hydraulic jumps, backwater, and drawdown curves. StormCAD V8i’s flexible reporting feature allows you to customize and print the model results in both a report format and as a graphical plot.

1.2 Municipal License Administrator Auto-Configuration

At the conclusion of the installation process, the Municipal License Administrator will be executed, to automatically detect and set the default configuration for your product, if possible. However, if multiple license configurations are detected on the license server, you will need to select which one to use by default, each time the product starts. If this is the case, you will see the following warning: “Multiple license configurations are available for StormCAD V8i...” Simply press OK to clear the Warning dialog, then press Refresh Configurations to display the list of available configurations. Select one and press Make Default, then exit the License Administrator. (You only need to repeat this step if you decide to make a different configuration the default in the future.)

1.3 Starting Bentley StormCAD V8i

After you have finished installing StormCAD V8i, restart your system before starting StormCAD V8i for the first time.

To start StormCAD V8i

1. Double-click on the StormCAD V8i icon on your desktop.

or

2. Click Start > All Programs > Bentley > StormCAD V8i > StormCAD V8i.

1.4 Working with StormCAD V8i Files

StormCAD V8i uses an assortment of data, input, and output files. It is important to understand which are essential, which are temporary holding places for results and which must be transmitted when sending a model to another user. In general, the model is contained in a file with the stc.mdb extension. This file contains essentially all of the information needed to run the model. This file can be zipped to dramatically reduce its size for moving the file.
The .stc file and the drawing file (.dwh, dgn, dwg or .mdb) file contain user supplied data that makes it easier to view the model and should also be zipped and transmitted with the model when moving the model.

Other files found with the model are results files. These can be regenerated by running the model again. In general these are binary files which can only be read by the model. Saving these files makes it easy to look at results without the need to rerun the model. Because they can be easily regenerated, these files can be deleted to save space on the storage media.

When archiving a model at the end of the study, usually only the *.stc.mdb, *.stc files, and the platform specific supporting files (*.dwh, *.dgn, *.dwg or *.mdb) need to be saved. The file extensions are explained below:

- .bak - backup files of the model files
- .dgn - drawing file for MicroStation platform
- .dwg - drawing file for AutoCAD platform
- .dwh - drawing file for stand alone platform
- .out - primary output file from hydraulic and water quality analyses
- stc.mdb - main model file
- .stc - display settings (e.g. color coding, annotation)
- .xml - xml files, generally libraries, window and other settings. Some modules like ModelBuilder also use .xml files to store settings independent of the main model.

**Using the Custom Results File Path Option**

When the **Specify Custom Results File Path** option (found under Tools > Options > Project Tab) is on for the project, the result files will be stored in the custom path specified when the project is closed. When the project is open, all of the applicable result files (if any) will be moved (not copied) to the temporary directory to be worked on. The result files will then be moved back to the custom directory when the project is closed.

The advantages of this are that moving a file on disk is very quick, as opposed to copying a file, which can be very slow. Also, if you have your project stored on a network drive and you specify a custom results path on your local disk, then you will avoid network transfer times as well. The disadvantages are that, should the program crash or the project somehow doesn’t close properly, then the results files will not be moved back and will be lost.
If you then wish to share these results files with another user of the model, you can use the **Copy Results To Project Directory** command (Tools > Database Utilities > Copy Results To Project Directory) to copy the results files to the saved location of the model. The user receiving the files may then use the Update Results From Project Directory command (Tools > Database Utilities > Update Results From Project Directory) to copy the results files from the project directory to their custom results file path.

### 1.5 Exiting StormCAD V8i

**To exit StormCAD V8i**

1. Click the application window's Close icon.

   ![Close Icon]

   or

   From the File menu, choose Exit.

   **Note:** If you have made changes to the project file without saving, the Project not Saved dialog box will open. Click Yes to save before exiting, No to exit without saving, or Cancel to stop the operation.

### 1.6 Using Online Help

StormCAD V8i Help menu and Help window are used to access StormCAD V8i extensive online help.

Context-sensitive online help is available. Hypertext links, which appear in color and are underlined when you pass the pointer over them, allow you to move easily between related topics.

**To open the Help window**

1. From the Help menu, choose StormCAD V8i Help.
   
   The Help window opens, and the Table of Contents displays.

   The Help window consists of two panes - the navigation pane on the left and the topic pane on the right.

2. To get help on a dialog box control or a selected element:
   
   Press <F1> and the Help window opens (unless it is already open) and shows the information about the selected element.
Subtopics within a help topic are collapsed by default. While a subtopic is collapsed only its heading is visible. To make visible a subtopic's body text and graphics you must expand the subtopic.

**To expand a subtopic**

Click the expand (+) icon to the left of the subtopic heading or the heading itself.
To collapse a subtopic

Click the collapse (-) icon to the left of the subtopic heading or the heading itself.

The navigation pane has the following tabs:

- Contents - used for browsing topics.
- Index - index of help content.
- Search - used for full-text searching of the help content.
- Favorites - customizable list of your favorite topics

To browse topics using the Contents tab

1. On the Contents tab, click the folder symbol next to any book folder (such as Getting Started, Using Scenarios and Alternatives) to expand its contents.
2. Continue expanding folders until you reach the desired topic.
3. Select a topic to display its content in the topic pane.

To display the next or previous topic according to the topic order shown in the Contents tab

To display the next topic, click the right arrow or to display the previous topic, click the left.

To use the index of help content

1. Click the Index tab.
2. In the search field, type the word you are searching for.
   or Scroll through the index using the scroll bar to find a specific entry.
3. Select the desired entry and click the Display button.
   or Double-click the desired entry.
   The content that the selected index entry is referencing displays in the topic pane.
Note: If you select an entry that has subtopics, a dialog box opens from which you can select the desired subtopic. In this case, select the subtopic and click the Display button.

To search for text in the help content

1. Click the Search tab.
2. In the search field, type the word or phrase for which you are searching.
3. Click the List Topics button.
   Results of the search display in the list box below the search field.
4. Select the desired topic and click the Display button.
   or
   Double-click the desired topic.

Search results vary based on the quality of the search criteria entered in the Search field. The more specific the search criteria, the more narrow the search results. You can improve your search results by improving the search criteria. For example, a word is considered to be a group of contiguous alphanumeric characters. A phrase is a group of words and their punctuation. A search string is a word or phrase on which you search.

A search string finds any topic that contains all of the words in the string. You can improve the search by enclosing the search string in quotation marks. This type of search finds only topics that contain the exact string in the quotation marks.

To add a help topic to a list of “favorite” help topics

1. In the Contents, Index, or Search tabs, select the desired help topic.
2. Click the Favorites tab.
   The selected help topic automatically displays in the “Current topic” field at the bottom of the tab.
3. Click the Add button.

To display a topic from your Favorites list

1. Click the Favorites tab.
2. In the list box, select the desired topic and click the Display button.
   or
   Double-click the desired topic.
   The selected topic’s content displays in the topic pane.
Online help is periodically updated and posted on Bentley's Documentation Web site, http://docs.bentley.com/ for downloading. On this site you can also browse the current help content for this product and other Bentley products.

1.7 Software Updates via the Web and Bentley SELECT

Bentley SELECT is the comprehensive delivery and support subscription program that features product updates and upgrades via Web downloads, around-the-clock technical support, exclusive licensing options, discounts on training and consulting services, as well as technical information and support channels. It’s easy to stay up-to-date with the latest advances in our software. Software updates can be downloaded from our Web site, and your version of Bentley StormCAD V8i can then be upgraded to the current version quickly and easily. Just click Check for Updates on the toolbar to launch your preferred Web browser and open our Web site. The Web site automatically checks to see if your installed version is the latest available, and if not, it provides you with the opportunity to download the correct upgrade to bring it up-to-date. You can also access our KnowledgeBase for answers to your Frequently Asked Questions (FAQs).

**Note:** Your PC must be connected to the Internet to use the Check for Updates button.

1.8 Troubleshooting

Due to the multitasking capabilities of Windows, you may have applications running in the background that make it difficult for software setup and installations to determine the configuration of your current system.

**Try these steps before contacting our technical support staff**

1. Shut down and restart your computer.

2. Verify that there are no other programs running. You can see applications currently in use by pressing Ctrl+Shift+Esc in Windows XP. Exit any applications that are running.

3. Disable any antivirus software that you are running.

   **Caution:** After you install Bentley StormCAD V8i, make certain that you restart any antivirus software you have disabled. Failure to restart your antivirus software leaves you exposed to potentially destructive computer viruses.

4. Try running the installation or uninstallation again (without running any other program first).
If these steps fail to successfully install or uninstall the product, contact Technical Support.

1.9 Checking Your Current Registration Status

After you have registered the software, you can check your current registration status by opening the About... box from within the software itself.

To view your registration information

1. Select Help > About Bentley StormCAD V8i.
2. The version and build number for Bentley StormCAD V8i display in the lower-left corner of the About Bentley StormCAD V8i dialog box.
   The current registration status is also displayed, including: user name and company, serial number, license type and check-in status, feature level, expiration date, and SELECT Server information.

1.10 Differences in Terminology Between StormCAD V8i and StormCAD V8i for United Kingdom

There are some differences in terminology between StormCAD V8i and StormCAD V8i for United Kingdom. These differences include the following:

- Catch Basin "Longitudinal Slope" input becomes "Longitudinal Gradient"
- Gutter result "Slope" becomes "Longitudinal Gradient"?
- Catch Basin" becomes "Gully" and "Catch Basins" to "Gullies"
- “Curb" becomes "Kerb"
- Catch Basin "Road Cross Slope" input becomes "Crossfall"
- Inlet Location Classification: "On Grade" becomes "On Gradient"
- Catch Basin result "Capture Efficiency" becomes "Flow Collection Efficiency"
- “Grate" becomes "Grating"
Differences in Terminology Between StormCAD V8i and StormCAD V8i for United Kingdom
QuickStart Lessons

The purpose of this chapter is to provide step-by-step lessons to familiarize you with some of the features and capabilities of StormCAD. The lessons serve as a means to get you started exploring and using the software. We have included sample files located in your Bentley\StormCAD8\Lessons directory for you to experiment with and explore. If you need help, press F1 to access our on-line help.

Each lesson is independent. You do not need to complete one to start the next. Lessons 3 and 4 can be started using files located in your Bentley\StormCAD8\Lessons directory.

**Note:** When working through the lessons using StormCAD V8i for United Kingdom, in some cases the terminology used in the lessons will be slightly different from that found in the user interface. For a list of these differences, refer to Differences in Terminology Between StormCAD V8i and StormCAD V8i for United Kingdom.
2.1 Lesson 1: Creating a Schematic Network

StormCAD is an extremely efficient tool for laying out a gravity flow sewer model. It is easy to prepare a schematic model and let StormCAD take care of the link-node connectivity.

You do not need to be concerned with assigning labels to pipes and junctions, because StormCAD will handle this automatically. When creating a scaled drawing, pipe lengths are automatically calculated from the pipe’s drawn alignment. Since this example is a schematic (not scaled) layout, you will need to enter the pipe lengths.

In this lesson, we will layout and analyze the following schematic network.

2.1.1 Part 1 - Creating a New Schematic Project File
1. Start StormCAD.
2. When the **Welcome to StormCAD** dialog appears, click the **Create New Project** button. If it does not appear, choose **File > New** from the pull-down menu.
3. Click the **File** menu and select **Save As**.
4. Enter a file name such as **Lesson.stc** for your project, and click **Save**.
5. Click the **File** menu and select **Project Properties**.
6. Enter the information as pictured below, then click **OK**.

![Project Properties dialog]

---

2.1.2 **Part 2 - Laying Out the Network**

This example is a schematic (not scaled) drawing, and the units used are US customary units. Before laying out any elements:

1. Click the **Tools** menu and select **Options**.
2. Click the **Drawing** tab and change the **Drawing Mode** to **Schematic**.
3. Click the **Units** tab and ensure that the **Default Unit System for New Project** menu is set to **US**. Click **OK**.

4. To draw the sewer network shown previously, click the **Layout** tool from the toolbar, then select **Conduit** from the submenu. Notice that the cursor is a crosshair with a square to show that you are placing catchbasins.

5. Move the cursor onto the drawing space and click once to place the catchbasin representing catchbasin **CB-1**.

6. Move the cursor to the location of the next catchbasin, **CB-2**, and click again to place the element. A conduit will automatically be drawn between the two catchbasins.

7. Place the third catchbasin, **CB-3**, in the same fashion.

---

![Diagram](image_url)
8. Right-click anywhere in the drawing pane to open a pop-up menu. This menu is used to change the element type while laying out a system. We will use it to place the outfall, **OF-1**, at the end of the next conduit. From the pop-up menu, click **Outfall** and click the drawing pane to place the outlet at the desired location.

9. Right-click again and select the **Done** command to stop laying out elements.

10. Click the **Catchment** button on the toolbar.

You can lay out catchment elements in either of two ways:
Lesson 1: Creating a Schematic Network

- Click each corner of the catchment polygon, then select **Done** from the right-click popup menu, or

- Hold down the **Ctrl** button, then click in the drawing view to define where the center of the catchment polygon will be. Drag the mouse to define the size of the catchment, then click again.

11. Lay out 3 catchments, one around each of the catch basin elements.

![Diagram](image)

### 2.1.3 Part 3 - Entering Data

There are four ways to enter and modify element data in StormCAD:

- **Properties Editor** - You may use the Select tool and double-click an element to bring up its Properties Editor.
• **FlexTables** - Click the View menu and select FlexTables, or click the FlexTables button to bring up dynamic tables that show all the editable and non-editable attributes of elements of a similar type, such as nodes and links. You can edit the data as you would in a spreadsheet.

• **ModelBuilder** - ModelBuilder allows the direct import and export of element data from outside sources such as Excel spreadsheets, GIS, Jet Databases like Microsoft Access, and many others. This is further explained in the chapter on ModelBuilder.

• **Alternative Editors** - Alternatives are used for entering data for different "What If?" situations for use in Scenario Management. This is covered extensively in the Scenarios and Alternatives chapter and a later Lesson.

**Entering Data through the Properties Editor**

To access an element's Properties Editor, double-click the element in the drawing pane with the cursor. If the Properties Editor dialog is already open, a single click will switch the editor to display the attributes for the newly highlighted element.

1. Open the **Properties Editor** for the outfall, **OF-1**.
2. Enter **94.0 ft** for the **Elevation (Ground)**.
3. Enter **83.0 ft** for the **Elevation (Invert)**. If the **Set Invert to Ground Elevation** field is marked **True**, StormCAD will automatically set the invert elevation to the ground elevation.
### Lesson 1: Creating a Schematic Network

#### 4. Finally, ensure that Free Outfall is selected from the Boundary Condition Type choice list.

<table>
<thead>
<tr>
<th>Properties - Outfall - OF-1 (20)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID: 20</td>
</tr>
<tr>
<td>Label: DF-1</td>
</tr>
<tr>
<td>Notes</td>
</tr>
<tr>
<td>GIS-IDs</td>
</tr>
<tr>
<td>Hyperlinks</td>
</tr>
<tr>
<td>Station (ft): 0+00</td>
</tr>
</tbody>
</table>

#### Additional Details

- **Active Topology**
  - Is Active?: True

- **Boundary Condition**
  - Boundary Condition Type: Free Outfall

- **Design**
  - Local Pipe Matching Constraints: False
  - Design Structure Elevation?: True
  - Desired Sump Depth (ft): 0.00

- **Physical**
  - Elevation (Ground) (ft): 94.00
  - Set Rim to Ground Elevation?: True
  - Elevation (Rim) (ft): 94.00
  - Elevation (Invert) (ft): 83.00

- **Results**
  - Calculation Messages: <Collection: 0 items>

- **Results (Hydraulic)**
  - Depth (ft): (N/A)
  - Energy Grade Line (ft): (N/A)
  - Hydraulic Grade Line (ft): (N/A)

- **Results (Lost Flow)**
  - Lost Surface CA (acres): (N/A)
  - Lost Surface Flow Time (min): (N/A)
  - Lost Surface Flow Rate (gpm): (N/A)
5. All other elements can be modified in the same way using the input data from the following tables. If a value is not specified for a particular attribute, leave the default value:

**Table 2-1: Catch Basin Input Data: Physical and Physical (Structure Losses) Sections**

<table>
<thead>
<tr>
<th>Catch Basin label</th>
<th>Elevation (Ground)</th>
<th>Elevation (Rim)</th>
<th>Elevation (Invert)</th>
<th>Headloss Method</th>
<th>Headloss Coefficient</th>
</tr>
</thead>
<tbody>
<tr>
<td>CB-1</td>
<td>99.0</td>
<td>99.0</td>
<td>89.0</td>
<td>Standard</td>
<td>0.5</td>
</tr>
<tr>
<td>CB-2</td>
<td>97.0</td>
<td>97.0</td>
<td>87.0</td>
<td>Standard</td>
<td>0.5</td>
</tr>
<tr>
<td>CB-3</td>
<td>95.0</td>
<td>95.0</td>
<td>85.0</td>
<td>Standard</td>
<td>0.5</td>
</tr>
</tbody>
</table>

Inlet data is associated with Catch basin elements. When selecting an inlet, you can choose a generic Maximum Capacity or Percent Capture inlet type, or you can define a custom inlet in the Inlets Catalog dialog. After an inlet is defined in the Inlets Catalog dialog, it can be reused for any number of catch basin elements.

6. Click the **Components** menu and select **Inlet Catalog**.

7. In the **Inlets Catalog** dialog, click the **New** button. Leave the default name of **Inlet - 1**.

8. Change the **Inlet Type** to **Grate**.

9. Enter the remaining data in the appropriate fields as shown in the screen below:
10. Click the **Close** button.

11. Click **CB-1**.

12. Change the **Inlet Type** to **Catalog Inlet**.

13. In the **Inlet** field, choose **Inlet - 1**.

14. Enter the remaining inlet data according to the values in the table below. Use the **Catalog Inlet** type and **Inlet - 1** for each catch basin.

**Table 2-2: Catch Basin Input Data: Inlet Location and Inlet Opening Sections**

<table>
<thead>
<tr>
<th>Catch Basin Label</th>
<th>Inlet Location</th>
<th>Longitudinal Slope (Inlet)</th>
<th>Manning's n (Inlet)</th>
<th>Grate Length</th>
<th>Clogging Factor</th>
</tr>
</thead>
<tbody>
<tr>
<td>CB-1</td>
<td>On Grade</td>
<td>0.020</td>
<td>0.012</td>
<td>4.0</td>
<td>20.0</td>
</tr>
<tr>
<td>CB-2</td>
<td>On Grade</td>
<td>0.020</td>
<td>0.012</td>
<td>4.0</td>
<td>20.0</td>
</tr>
<tr>
<td>CB-3</td>
<td>In Sag</td>
<td>0.020</td>
<td>N/A</td>
<td>4.0</td>
<td>20.0</td>
</tr>
</tbody>
</table>

15. Click on **CM-1**.

16. In the **Outflow Node** field, click **<Select...>**.

17. Click **CB-1** in the drawing pane to select it as the outflow node for **CM-1**.

18. Enter the remaining data for CM-1 and the other catchment elements (including outflow node assignment) using the values in the following table:

**Table 2-3: Catchment Input Data**

<table>
<thead>
<tr>
<th>Catchment Label</th>
<th>Outflow Node</th>
<th>Area</th>
<th>Rational C</th>
<th>Time of Concentration</th>
</tr>
</thead>
<tbody>
<tr>
<td>CM-1</td>
<td>CB-1</td>
<td>0.50</td>
<td>0.8</td>
<td>10</td>
</tr>
<tr>
<td>CM-2</td>
<td>CB-2</td>
<td>0.30</td>
<td>0.8</td>
<td>15</td>
</tr>
<tr>
<td>CM-3</td>
<td>CB-3</td>
<td>0.35</td>
<td>0.7</td>
<td>15</td>
</tr>
</tbody>
</table>

19. Conduits can be one of two types: User Defined or a Catalog Conduit. The attributes of User Defined conduits are edited directly. The attributes of a Catalog Conduit are associated with the definition created in the Conduit Catalog dialog. Catalog Conduits can be reused any number of times.

20. Click the **Components** menu and select **Conduit Catalog**.

21. Click the **New** button. Leave the default name of **Catalog Conduit - 1**.
22. Change the Conduit Shape to Circle.

23. Enter a Diameter of 24 in.

24. Click the ellipsis (...) button next to the Material Field. This will open the Materials Engineering Libraries.

Engineering Libraries store a number of predefined values associated with a specific attribute. The Materials Library contains various material definitions and include the customary roughness values for common materials.

25. In the Engineering Libraries dialog that appears, expand the top-level Material Libraries node, then expand the MaterialLibrary.xml node.

![Engineering Libraries dialog](image)

26. Highlight the Concrete library entry and click the Select button. You can select a number of different materials to create a list of allowable materials for the catalog conduit. You will then be able to select from the allowable materials when you define the conduit catalog in the model.
Lesson 1: Creating a Schematic Network

27. The new catalog conduit has now been defined. Click the **Close** button.

![Conduit Catalog]

28. Now we will assign the properties associated with the catalog conduit we just created to the conduits in the model. Click conduit **CO-1**.

29. Under **Conduit Type**, select **Catalog Conduit**.

30. Under **Material**, select the only available entry, **Concrete**.

31. Click **Section Size** and select **Conduit Catalog - 1**.

32. Repeat steps 28-31 for **CO-2** and **CO-3**.
Entering Data using FlexTables

It is often more convenient to enter data for similar elements into a tabular form rather than to individually click each element, enter the data through the Properties editor, and then move on to the next element.

1. Click the View menu and select FlexTables or click the FlexTables button to open the FlexTables Manager.

2. Double-click the Conduit table under the Tables - Predefined category.
Lesson 1: Creating a Schematic Network

3. The upstream and downstream inverts and the length still need to be defined for the conduits. These attributes are not in the predefined table, so we must add them. Click the **Edit** button.

![Table: Conduit Table](image)

4. In the table editor, the left pane lists the available attributes, and the right pane lists the attributes displayed in the table. Double-click the following attributes in the left pane to add them to the right pane: **Invert (Downstream)**, **Invert (Upstream)**, **Length (User Defined)**, **Set Invert to Downstream?**, and **Set Invert to Upstream?**. Click **OK**.
5. The newly added attributes are now displayed at the right side of the table. Uncheck the boxes under **Set Invert to Downstream**? and **Set Invert to Upstream**? for all three conduits and enter the remaining data as shown in the screen below.

6. **Close** the FlexTable and the FlexTables manager.
2.1.4 **Part 4 - Defining Storm Events**

The last piece of information we need to enter is the rainfall data. Rainfall data is applied to the model by creating storm data definitions and then defining global storm events using the storm data.

1. Click the **Components** menu and select **Storm Data**.
2. Click the **New** button and select **User Defined IDF Table**. A blank IDF table is created.

3. Now we must modify the return periods and durations of the table. Click the **Add/Remove Return Periods** button and select **Add Return Period**. In the **Add Return Period** dialog that appears, enter a value of 10 and click **OK**. Also add a 20 and 100 year return period.
4. Click the **Add/Remove Durations** button and select **Add Duration**. In the **Add Duration** dialog that appears, enter a value of 10 and click **OK**. Also add a 20 minute duration. Your IDF Table should now look like this:

5. Fill in the values for the IDF table using the data from the table below.

**Table 2-4: IDF Table Input Data**

<table>
<thead>
<tr>
<th>Duration</th>
<th>10 Year</th>
<th>20 Year</th>
<th>100 Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>4.2</td>
<td>6.6</td>
<td>8.6</td>
</tr>
<tr>
<td>10</td>
<td>2.3</td>
<td>4.3</td>
<td>6.3</td>
</tr>
<tr>
<td>20</td>
<td>1.6</td>
<td>2.7</td>
<td>4.7</td>
</tr>
<tr>
<td>30</td>
<td>1.0</td>
<td>1.8</td>
<td>3.8</td>
</tr>
</tbody>
</table>
6. Your Storm Data dialog should look like the screen below. Click the Close button.

7. Storm Data definitions created in the Storm Data Dialog Box need to be assigned to Global Storm Events. Global Storm Events are applied to all catchments during analysis. Click the Components menu and select Global Storm Events.

The Global Storm Events dialog consists of a table that displays a list of all of the Rainfall Runoff Alternatives and their associated global storm events. The storm event source is also displayed, showing whether the storm event was created manually for the project or if it was imported from an engineering library entry.
8. In the Global Storm Events dialog, click the Global Storm Event field and select User Defined IDF Table - 1 - 20 Year.

9. Click the Close button.

2.1.5 Part 5 - Analyzing the System

Now that all of the required input data has been entered, the model can be calculated. Before computing the model, it is a good idea to validate it first. Validation runs a diagnostic check on the network data to alert you to possible problems that may be encountered during calculation. This is the manual validation command, and it checks for input data errors. It differs in this respect from the automatic validation that StormCAD runs when the Compute command is initiated, which checks for network connectivity errors as well as many other things beyond what the manual validation checks.

1. Click the Validate button.

2. An error message appears, notifying you that problems were found during validation. Click the OK button.

3. The User Notifications manager opens, displaying a list of warnings that were generated during the validation routine. Warnings are shown in yellow, and do not prevent the model from being successfully calculated. Errors, if any are present, would be shown in red. Errors must be corrected before the model can be computed. For now, let's ignore the warnings.
4. Click the **Compute** button to calculate the model.

5. After the calculation is complete, the **Calculation Executive Summary** is displayed.

   The Calculation Executive Summary displays the scenario name, rainfall alternative, and storm event information for the analysis. It also displays some engine messages relating to convergence.

   In the lower left corner notice the yellow symbol. This indicates that warnings were generated during the calculation. A red symbol would indicate that the calculation failed due to errors. In either circumstance, you can review warnings and errors in the User Notifications dialog.

   You can generate an executive summary report by clicking the Report button in this dialog, or access a more comprehensive summary of the calculated results by clicking the Detailed Summary button.

6. Click the **Close** button.

7. Before proceeding to the next lesson, click the **Save** button.

### 2.2 Lesson 2 - Automatic Design

StormCAD will automatically design all or parts of your storm sewer system. Simply specify the ground elevations, tailwater conditions, and design constraints, and StormCAD will do the rest.

In this lesson, we will use the automatic design feature to develop a design to replace an existing undersized storm drainage system.

#### 2.2.1 Part 1 - Creating the Project File

First we must create a project file. When performing an Automatic Design, StormCAD suggests only conduit and inlet types that are contained within the Conduit and Inlet Catalogs. A new project starts with empty Conduit and Inlet Catalogs. You can populate the Inlet and Conduit Catalogs with pipes and inlets of your choosing, or you can open one of the predefined Templates we have provided. You may also create new Templates and use those in future projects.

For this lesson, we will use the predefined Template that is installed with StormCAD.

1. Click the **File** menu and select **Open**. Browse to the **Bentley/StormCAD8/Templates** folder and select **Template-US.stc** and click the **Open** button.

2. Click the **File** menu and select **Save As**. Browse to the **Bentley/StormCAD8/Lessons** folder. Type in **Lesson2.stc** for the file name and click **Save**.
3. Go through the steps as outlined in Lesson 1 to create a **schematic** project using **Manning's Formula** for friction calculations and employing the **US** unit system.

4. Once the project has been set up, use the **Layout** tool to draw the network pictured below.

![Network Diagram](image)

5. Use the **Properties** editor or **FlexTables** to enter the data provided for each element in the tables below.

**Table 2-5: Catchment Input Data**

<table>
<thead>
<tr>
<th>Catchment Label</th>
<th>Area</th>
<th>Rational C</th>
<th>Outflow Node</th>
<th>Time of Concentration</th>
</tr>
</thead>
<tbody>
<tr>
<td>CM-1</td>
<td>1.00</td>
<td>0.7</td>
<td>CB-1</td>
<td>9</td>
</tr>
<tr>
<td>CM-2</td>
<td>0.30</td>
<td>0.8</td>
<td>CB-2</td>
<td>5</td>
</tr>
<tr>
<td>CM-3</td>
<td>0.20</td>
<td>0.8</td>
<td>CB-3</td>
<td>6</td>
</tr>
</tbody>
</table>
### Table 2-6: Catch Basin Input Data: Physical and Physical (Structure Losses) Sections

<table>
<thead>
<tr>
<th>Catch Basin Label</th>
<th>Elevation (Ground)</th>
<th>Elevation (Rim)</th>
<th>Elevation (Invert)</th>
<th>Headloss Method</th>
<th>Headloss Coefficient</th>
</tr>
</thead>
<tbody>
<tr>
<td>CB-1</td>
<td>78.0</td>
<td>78.0</td>
<td>76.9</td>
<td>Standard</td>
<td>0.5</td>
</tr>
<tr>
<td>CB-2</td>
<td>82.0</td>
<td>82.0</td>
<td>76.5</td>
<td>Standard</td>
<td>0.5</td>
</tr>
<tr>
<td>CB-3</td>
<td>79.0</td>
<td>79.0</td>
<td>76.0</td>
<td>Standard</td>
<td>0.5</td>
</tr>
</tbody>
</table>

### Table 2-7: Catch Basin Input Data: Inlet Location and Inlet Opening Sections

<table>
<thead>
<tr>
<th>Catch Basin Label</th>
<th>Inlet Type</th>
<th>Inlet</th>
<th>Inlet Location</th>
<th>Longitudinal Slope (Inlet)</th>
<th>Manning's (Inlet)</th>
<th>Grate Length</th>
<th>Clogging Factor</th>
</tr>
</thead>
<tbody>
<tr>
<td>CB-1</td>
<td>Catalog Inlet</td>
<td>Inlet - 1</td>
<td>In Sag</td>
<td>N/A</td>
<td>N/A</td>
<td>3.0</td>
<td>20.0</td>
</tr>
<tr>
<td>CB-2</td>
<td>Catalog Inlet</td>
<td>Inlet - 2</td>
<td>On Grade</td>
<td>0.020</td>
<td>0.012</td>
<td>3.0</td>
<td>20.0</td>
</tr>
<tr>
<td>CB-3</td>
<td>Catalog Inlet</td>
<td>Inlet - 1</td>
<td>In Sag</td>
<td>N/A</td>
<td>N/A</td>
<td>3.0</td>
<td>20.0</td>
</tr>
</tbody>
</table>

### Table 2-8: Fall Input Data

<table>
<thead>
<tr>
<th>Outfall</th>
<th>Elevation (Ground)</th>
<th>Elevation (Invert)</th>
<th>Boundary Condition Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>OF-1</td>
<td>78.0</td>
<td>74.0</td>
<td>Free Outfall</td>
</tr>
</tbody>
</table>

### Table 2-9: Conduit Input Data

<table>
<thead>
<tr>
<th>Conduit Label</th>
<th>Has User Defined Length?</th>
<th>Length (User Defined)</th>
<th>Conduit Shape</th>
<th>Material</th>
<th>Diameter</th>
<th>Set Invert to Upstream?</th>
<th>Invert (Upstream)</th>
<th>Set Invert to Downstream?</th>
<th>Invert (Downstream)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO-1</td>
<td>True</td>
<td>250</td>
<td>Circle</td>
<td>Concrete</td>
<td>12</td>
<td>False</td>
<td>76.9</td>
<td>False</td>
<td>76.5</td>
</tr>
<tr>
<td>CO-2</td>
<td>True</td>
<td>300</td>
<td>Circle</td>
<td>Concrete</td>
<td>12</td>
<td>False</td>
<td>76.5</td>
<td>False</td>
<td>76.0</td>
</tr>
<tr>
<td>CO-3</td>
<td>True</td>
<td>200</td>
<td>Circle</td>
<td>Concrete</td>
<td>12</td>
<td>False</td>
<td>76.0</td>
<td>False</td>
<td>74.0</td>
</tr>
</tbody>
</table>
6. Click the Components menu and select Inlet Catalog. In the Inlet Catalog, define two inlets using the data from the following table:

<table>
<thead>
<tr>
<th>Inlet Label</th>
<th>Inlet Type</th>
<th>Structure Width</th>
<th>Structure Length</th>
<th>Curb Opening Height</th>
<th>Default Curb Opening Length</th>
<th>Grate Width</th>
<th>Default Grate Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inlet - 1</td>
<td>Combination</td>
<td>3.0</td>
<td>5.0</td>
<td>6.0</td>
<td>4.0</td>
<td>2.0</td>
<td>3.0</td>
</tr>
<tr>
<td>Inlet - 2</td>
<td>Grate</td>
<td>4.0</td>
<td>5.0</td>
<td>N/A</td>
<td>N/A</td>
<td>3.0</td>
<td>3.0</td>
</tr>
</tbody>
</table>

7. Using the data in the following table, create a Storm Data definition of the User Defined IDF Table type and assign it to a Global Storm Event. Use the 20 Year Return Period Storm for the Global Storm Event.

Table 2-10: User Defined IDF Table Input Data

<table>
<thead>
<tr>
<th>Duration</th>
<th>10 Year</th>
<th>20 Year</th>
<th>100 Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>4.2</td>
<td>6.6</td>
<td>8.6</td>
</tr>
<tr>
<td>10</td>
<td>2.3</td>
<td>4.3</td>
<td>6.3</td>
</tr>
<tr>
<td>20</td>
<td>1.6</td>
<td>2.7</td>
<td>4.7</td>
</tr>
<tr>
<td>30</td>
<td>1.0</td>
<td>1.8</td>
<td>3.8</td>
</tr>
</tbody>
</table>

2.2.2 Part 2 - Defining Design Parameters

Once you have entered all the input data:

1. Click the Compute button.

2. Notice the yellow Warning icon in the Calculation Executive Summary. Click the Messages button.

Notice the warnings. This is an existing system that is undersized, and your job is to fix it. Close the User Notifications Details and Calculation Executive Summary dialogs.
3. Click the **Analysis** menu and select **Alternatives**. Expand the **Design** node and double-click the **Base Design** alternative.

   ![Alternatives](image)

   We want to use StormCAD's automatic design feature to find a design that satisfies the constraints. This alternative allows us to set the design constraints that StormCAD will use to design the system. If you wish, you can use the table of elements to set local constraints for specific elements, or use the check boxes to specify certain elements you do not want to automatically design. In this example, we will design all of the pipes using the same constraints.
4. On the **Gravity Pipe** tab:
   
a. In the **Default Constraints** section, **Velocity** tab: Ensure that the **Velocity (Minimum)** value is set to **2.0** and the **Velocity (Maximum)** value is set to **15.0**.

   b. In the **Default Constraints** section, **Cover** tab: Ensure that the **Cover (Minimum)** value is set to **3.0** and the **Cover (Maximum)** value is set to **15.0**.

   c. In the **Default Constraints** section, **Slope** tab: Ensure that the **Slope (Minimum)** value is set to **0.005** and the **Slope (Maximum)** value is set to **0.100**.
5. On the Inlet tab:
   a. Ensure the Maximum Spread In Sag value is set to 12.0 ft.
   b. Ensure the Maximum Depth in Sag value is set to 8.0 in.
   c. Enter a Minimum Efficiency on Grade value of 70.0%.

6. Click Close in this dialog, and Close the Alternatives manager.

7. You must also specify which of the catalog conduits will be available for StormCAD to choose from during the design run. Click the Components menu and select Conduit Catalog.
QuickStart Lessons

8. Click on the **Label** heading to sort the available conduits by name.

9. Highlight the **15 inch Circle Concrete** conduit and make sure the **Available for Design?** checkbox is checked.

10. Repeat the above step for the **18** and **21 inch Circle Concrete** conduits to make sure they are available for design as well.

11. **Close** the **Conduit Catalog**.
2.2.3  **Part 3 - Performing the Automatic Design**

To run a Design calculation, we must change the calculation type from analysis to design.

1. Click the **Analysis** menu and select **Calculation Options**.
2. In the **Calculation Options** dialog, highlight **Base Calculation Options**.
3. In the **Properties** editor, change the **Calculation Type** to **Design**.
4. Click the **Compute** button.
5. A prompt appears, asking if you want to create a new alternative to capture the changes made by the automatic design. Click the Yes button.

6. In the New Alternative dialog, type Automatic Design and click OK.

7. Close the Calculation Executive Summary.

8. In the Calculation Options dialog, highlight Base Calculation Options.

9. In the Properties editor, change the Calculation Type to Analysis.

10. Click the Compute button.

11. In the Calculation Executive Summary, click the Messages button.

12. Notice that the new Design alternative has eliminated the flooding warning.

13. Close the User Notifications Details and Calculation Executive Summary dialogs.

14. In the Drawing pane, click on CO-1. In the Physical section of the Properties manager, note that the Section Size is 15 inches. Check the other conduits; CO-2 is 15 inches, and CO-3 is 18 inches. The automatically designed physical alternative chose larger conduits that were available to it to relieve the flooding issue and meet the design criteria.

2.3 Lesson 3 - Scenario Management

One of StormCAD's many powerful and versatile project management tools is Scenario Management. Scenarios allow you to calculate multiple "What If?" situations in a single project file. You may wish to try several designs and compare the results, or analyze an existing system using several different rainfall events and compare the generated profiles. A scenario is a group of alternatives, while alternatives are groups of actual model data. Both scenarios and alternatives are based on a parent/child relationship where child scenarios and alternatives inherit data from the parent scenarios and alternatives.

In this lesson, we will use Scenario Management to set up the scenarios needed to test four "What If?" situations for the purpose of analyzing a new drainage system design. At the end we will compare all of the results using the Scenario Comparison tool.
2.3.1  

**Part 1 - Creating a New Alternative**

For this lesson we will use an existing project file.

1. Click the **Open Existing Project** button in the **Welcome** dialog, or select **File\Open** from the pull-down menu to bring up the **Open** dialog.

2. Browse to the **Bentley/StormCAD8/Lessons** directory and open **Lesson3.stc**.

The storm drainage system is a new design that is being analyzed. We are going to test the new design under pre- and post-developed conditions (Inlet C = 0.6 and 0.9) during both a 2-year and a 10-year storm.

We could calculate the model using a 2-year rainfall event, change the C value and recalculate, change the rainfall event and do another two calculations. However, this method is time consuming, and the results will be in an unwieldy form. It is preferable to take advantage of the Scenarios and Alternatives tools included in StormCAD.
First we need to set up the required data sets (alternatives). An alternative is a group of data that describes a specific part of the model. There are nine available alternatives: Active Topology, Physical, Headloss, Boundary Conditions, Rainfall Runoff, Hydrologic, Design, System Flows, and User Data Extensions.

In this example, we need one hydrologic alternative with the pre-developed C value of 0.6, and one hydrologic alternative with the post-developed C value of 0.9. Therefore, we must set up two hydrologic alternatives using each of the C values.

3. Click the Analysis menu and select Alternatives.

4. In the Alternatives manager, expand the Hydrologic node.

In StormCAD, we can create families of alternatives. There are parent alternatives (base alternatives) and there are child alternatives. A child alternative will inherit its data from the parent. However, you can change the child's inherited data, thereby making the data local to that alternative.

Currently, there is only one Hydrologic alternative listed. The Base-Catchments alternative contains the Inlet C value of 0.6, which is associated with our base scenarios. We would like to add a child of the Base-Catchments alternative so that we can inherit most of the data, but change the Inlet C value.

5. Highlight the Base-Catchments alternative and click the New button.

6. Highlight the newly created alternative and click the Rename button, then type Inlet C = 0.9 as the new name.

7. Double click the new child alternative to open the Hydrologic alternative editor. Click the Catchment tab. The table in the alternative already contains data that was inherited from the parent alternative.
Notice the key at the bottom describing the check boxes. As the key indicates, all of our data is inherited. If you change any piece of data, the check box will become checked because that record is now local to this alternative and not inherited from the parent.

8. We want all of the values in the Rational C column to be 0.9. Right-click the **Rational C** column and select the **Global Edit** option from the menu.

9. Select **Set** from the **Operation** list box and enter **0.9** into the **Value** field. Click **OK** to set all of the rows in the Inlet C column to 0.9.

10. Click **Close** to exit the **Hydrologic** alternative editor. Click **Close** to exit the **Alternatives** manager.

You now have two Catchment alternatives. One alternative contains Inlet C values of 0.6, and one contains Inlet C values of 0.9. However, the rest of the data is the same. We must now create the scenarios that will contain the Catchment alternatives.
2.3.2 Part 2 - Creating New Scenarios

In this part of the lesson we will set up the base scenarios and create new scenarios that will contain the Hydrologic alternatives created in the previous part.

1. Click the Analysis menu and select Scenarios.
   Currently, there is only the single Base scenario. Highlight the Base scenario to view the alternatives that the scenario is comprised of in the Properties editor. Alternatives are the building blocks of a scenario. A scenario is a group of the ten alternatives and all of the calculation information needed to solve a model.
   For our example, we wish to analyze the exact same system using two different rainfall events. To do this, we must have two scenarios that are exactly the same, except with different global storm events.

2. The first step in this process is to rename the Base scenario appropriately and set the correct global storm event. Highlight the Base scenario and click the Rename button. When using multiple scenarios, it’s good to use names that are as descriptive as possible. Type New Design - 2 yr storm, C=0.6 as the scenario name. The Base scenario should already be using the 2-Year Rainfall Runoff alternative, which is what we want.

3. Highlight the New Design - 2 yr storm, C=0.6 scenario and click the New button. Select Base Scenario from the submenu.

4. Click the Rename button and type in New Design – 10 yr storm, C=0.6 as the new scenario name.
5. With the **New Design – 10 yr storm, C=0.6** scenario highlighted, click the **Rainfall Runoff** field in the **Properties** editor and select the **10-Year Rainfall** alternative.

![Properties - Scenario - New Design - 10 yr storm, C=0.6](image)

6. You now have two scenarios that are exactly the same except for the return event. Next, we need to add two more scenarios that use our new hydrologic alternative, **Inlet C = 0.9** to model the other two "What If?" situations.

![Scenarios](image)

Scenarios work in families just like alternatives, except scenarios do not inherit the data directly. A scenario is a group of alternatives, so a child scenario will inherit the parent's alternatives. To change the data in a scenario, you need to change one or more of the scenario's alternatives.
7. Highlight the **New Design - 2 yr storm, C=0.6** Scenario and click the **New** button. Select **Child Scenario**. Type in **New Design – 2 yr storm, C=0.9** as the name of the new child scenario.

8. Our new child initially consists of the same alternatives as its parent alternative. We want the Hydrologic alternative to be the new alternative we created, Inlet C = 0.9. With the new child scenario highlighted, click the **Hydrologic** field in the **Properties** editor and select the **Inlet C = 0.9** alternative.

9. Highlight the **New Design - 10 yr storm, C=0.6 Scenario** and click the **New** button. Select **Child Scenario**. Type in **New Design – 10 yr storm, C=0.9** as the name of the new child scenario.

10. With the new child scenario highlighted, click the **Hydrologic** field in the **Properties** editor and select the **Inlet C = 0.9** alternative.

We now have four scenarios. The two base scenarios are the same except for the return event. The two child scenarios are the same as their respective parents except for the Inlet C value. The next step is to calculate them.
2.3.3  **Part 3 - Calculating Multiple Scenarios**

The Scenarios manager allows you to calculate multiple scenarios at once using the Batch Run tool.

1.   Click the **Compute** button and select the **Batch Run** command.

2.   The **Batch Run** dialog lists all of the scenarios within the current project. All scenarios that have their associated checkbox checked will be calculated during the batch run. Click the **Select** button and choose **Select All** to check all of the checkboxes.

3.   Click the **Batch** button. In the **Please Confirm** prompt that appears, click **Yes**.

4.   Click **OK** in the Information prompt that confirms when the calculation has completed successfully.

2.4  **Lesson 4 - Presentation of Results**

An important feature in all modeling software is the ability to present results clearly. This lesson outlines several of StormCAD's reporting features including:

- Reports - Display and print information for any or all elements in the system.
- FlexTables - Display information in a tabular spreadsheet format.
- Profiles - Graphically show how HGL and elevation vary throughout the storm sewer.
- Element Annotation - Dynamically presents the values of user-selected variables in the drawing.
- Color Coding - Assign colors to ranges of values of a variable and apply those colors to the appropriate locations on the plan view for a quick diagnostic on how the system is working.
2.4.1 Part 1 - Reports

For this lesson we will use an existing project file.

1. Click the Open Existing Project button in the Welcome dialog, or select File\Open from the pull-down menu to bring up the Open dialog.
2. Browse to the Bentley/StormCAD8/Lessons directory and open Lesson4.stc.
3. Click the Compute button to calculate the model.
4. In the Calculation Executive Summary dialog, click the Report button. This opens a report Preview dialog that contains the information presented in the Calculation Executive Summary in a print-ready format.

All of the reports in this part of the lesson are presented in the Preview dialog. From this dialog, you can print, change print settings, export to another format, or send the report via email.

5. Close the Preview dialog.
6. In the Calculation Executive Summary, click the Details button.
7. In the Calculation Detailed Summary dialog, click the Report button. This opens a report containing all of the information from each of the tabs in the detailed summary. Close the Preview, the Calculation Detailed Summary, and the Calculation Executive Summary dialogs.

8. There are a number of pieces of information that you can add to the formatted reports using the Report Options dialog. Click the Report menu and select Report Options.

9. In this dialog, the header and footer can be fully customized and you can edit text to be displayed in the cells or select from pre-defined dynamic variables from the cell's menu. You can also modify the margins and the font used in the header and footer text. Click the Footer tab.
10. In the first row, Align **Centa-** column, choose %*(ReportTitle)* from the menu. This is a variable, such that the information will be dynamically updated to reflect the current state for whichever attribute the variable references, in this case, the report title. Click **OK**.

<table>
<thead>
<tr>
<th>Align Left</th>
<th>Align Center</th>
<th>Align Right</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title: %<em>(ProjTitle)</em></td>
<td>%<em>(ReportTitle)</em></td>
<td>Project Engineer: %<em>(Proj...</em></td>
</tr>
<tr>
<td>%<em>(ProFileName)</em></td>
<td>%<em>(Company)</em></td>
<td>%<em>(ProductInfo)</em></td>
</tr>
<tr>
<td>%<em>(DateTime)</em></td>
<td>%<em>(BentleyInfo)</em></td>
<td>%<em>(Pagination)</em></td>
</tr>
</tbody>
</table>

[Report Options (local)]
11. Click the **Report** menu and select **Project Inventory**. This report displays a list of all of the various types of elements used in the model. Scroll to the bottom to see the variable that was added in the previous step.

![Screen shot of a report](image.png)

The **Element Tables** and **Headloss Detailed Reports** are specialized FlexTables, which will be discussed in the next part of the lesson.

### 2.4.2 Part 2 - FlexTables

FlexTables are extremely powerful tools in StormCAD. These reports are not only good presentation tools, they are also very helpful in data entry and analysis. When data must be entered for a large number of elements, clicking each element and entering the data can be very tedious and time consuming.

Using the FlexTables, elements can be changed using the global edit tool or filtered to display only the desired elements. Values that are entered into the table will be automatically updated in the model. The tables can also be customized to contain only the desired data. Columns can be added or removed or you can display duplicates of the same column with different units.

1. Click the **View** menu and select **FlexTables**, or click the **FlexTables** button.
2. In the **FlexTables** manager, double-click the **Conduit Table**.

Tabular reports are dynamic tables of input values and calculated results. White columns are input values and yellow columns are non-editable calculated values. When data is entered into a table directly, the value in the model will be automatically updated. These tables can be printed or copied into a spreadsheet program.

Two very powerful features in these tables are Global Editing and Filtering. Suppose we decide that all of the conduits with a velocity exceeding 5 ft/s should be increased in diameter. It would be time consuming to go through and re-enter
every conduit diameter. Instead, we will use the Filter tool in this example to filter out the conduits with a velocity less than 5 ft/s, and the Global Edit tool to increase the diameter of just those pipes.

3. If the Diameter and Velocity attributes are not in the predefined table, we must add them. Click the Edit button. If they are already in the table, skip ahead to step 5.

4. In the table editor, the left pane lists the available attributes, and the right pane lists the attributes displayed in the table. Double-click the Diameter and Velocity (In) attributes in the left pane to add them to the right. Click OK.

5. Right click the Velocity (In) column and select Filter...Custom from the submenu.
6. In the **Query Builder**, double-click **Velocity (In)** in the **Fields** list. Click the **Greater Than (>)** operator button. Add a space and then type in 5 in the query pane.

![Query Builder](image)

7. Click **OK**. Now only the conduits whose velocity is greater than 5 ft/s are being displayed. Two visual cues allow you to see when a filter is active: the text in the lower left corner notes "3 out of 10 elements displayed" and the row headings are displayed in blue.

![Query Builder Results](image)
8. Right-click the Diameter column and select Global Edit. Leave the Operation at Set and enter a Value of 16. Click OK.

9. Turn off the filter to see all conduits again. Right-click the Velocity (In) column and select Filter (Active)...Reset. Click Yes in the Reset Filter confirmation prompt that appears.

10. Close the FlexTable and the FlexTables manager.

2.4.3 Part 3 - Profiles

A profile is a side view of a section of the calculated network that displays the ground elevation, inverts, water level, HGL (hydraulic grade line), and EGL (energy grade line).

1. Click the Compute button and close the Calculation Executive Summary.
2. Click the View menu and select Profiles.
3. In the Profiles manager, click the New button.
4. In the Profile Setup dialog, click the Select from Drawing button.
5. The Slect toolbar allows you to add elements to the selection, remove elements from the selection, or finish selecting elements and go back to the Profile Setup dialog. You can also right-click to open a submenu containing the same commands. Click on the following elements in turn: P-7, P-9, and P-8. Click Done.
6. In the **Profile Setup** dialog, the list now contains the selected conduits along with their end nodes. Click **Open Profile**.

![Profile Setup dialog](image)

<table>
<thead>
<tr>
<th></th>
<th>Label</th>
<th>User Defined Station</th>
<th>Station (ft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>I-6</td>
<td></td>
<td>0+00.000</td>
</tr>
<tr>
<td>2</td>
<td>P-7</td>
<td></td>
<td>(N/A)</td>
</tr>
<tr>
<td>3</td>
<td>I-1</td>
<td></td>
<td>2+00.131</td>
</tr>
<tr>
<td>4</td>
<td>P-9</td>
<td></td>
<td>(N/A)</td>
</tr>
<tr>
<td>5</td>
<td>I-8</td>
<td></td>
<td>3+70.735</td>
</tr>
<tr>
<td>6</td>
<td>P-8</td>
<td></td>
<td>(N/A)</td>
</tr>
<tr>
<td>7</td>
<td>O-2</td>
<td></td>
<td>4+70.801</td>
</tr>
</tbody>
</table>

7. In the **Profile** viewer, the **Ground Elevation** is represented by the **Green** line, the **HGL** is the **Blue** line, the **EGL** is the **Red** line, and the **Water Level** is the **Light Blue** area. Click the **Chart Settings** button and select **Display Annotation Labels**. This adds labels that show the element label, type, and ID.

![Profile viewer](image)
8. Click the **Chart Settings** button and select **Profile Annotation Table**. This displays a table containing more detailed results and information for the profile elements.

9. The Profile viewer provides zoom capability. Click the **Zoom** button.

10. The zoom tool allows you to draw a box around the area you want to zoom. Drawing from the top left to the bottom right zooms in and drawing from the bottom right to the top left zooms back out.

11. From the profile view, you can print it using the Print button, copy it to the Windows clipboard using the Copy button, or export the profile as a .dxf drawing using the Chart Settings > Export to DXF command.

12. **Close** the Profile viewer and the Profiles manager.

### 2.4.4 Part 4 - Annotation

Element annotation functionality allows the display of values for user-selected attributes in the drawing pane.

1. Click the **Compute** button and close the **Calculation Executive Summary**.

2. Annotation is assigned through the **Element Symbology** manager. If you are using the default workspace configuration, the Element Symbology manager is located directly below the toolbars on the left side of the dialog. If not, click the
View menu and select the **Element Symbology** command. Highlight **Conduit** and click the **New** button, then select **Annotation** from the shortcut menu that appears.

3. In the **Annotation Properties** dialog that appears, change the **Field Name** to **Flow**. In the **Prefix** field, type in **Flow:** (with a space after the colon).

4. The **X** and **Y Offset** fields allow you to define, respectively, the horizontal and vertical distance between the element and the annotation. A positive value for **X Offset** will cause the annotation to be placed to the right of the element at the distance specified; a negative value will cause the annotation to be placed to the left of the element. A positive value for **Y Offset** will cause the annotation to be placed above the element; a negative value will cause the annotation to be placed below it. Enter a value of **-5.00** feet for the **Y Offset**.
5. The Initial Height Multiplier allows you to increase the size of text used for the annotation. Change this value to 0.600. The Selection Set control allows you to apply the current annotation to only those elements contained within a previously
defined selection set. Leave this value at <All Elements>. Click the OK button.
6. In the **Element Symbology** manager, highlight **Conduit** and click the **New** button, then select **New Annotation** from the shortcut menu that appears.
7. Change the **Field Name** to **Hydraulic Grade (In)**. Enter **HGL:** (with a space after the colon) in the **Prefix** field. Change the **Y Offset** to **-7.00**. Change **Initial Height Multiplier** value to **0.600**. Click the **OK** button.

8. Note that the hydraulic grade line value is now displayed below the flow annotation. However, the two annotations slightly overlap. Highlight the **Hydraulic Grade** annotation node in the **Element Symbology** manager and click the **Edit** button.
9. In the Annotation Properties dialog that appears, highlight Hydraulic Grade Line (In) in the list pane on the left side of the dialog. Change the Y Offset to -8.00 and click the Apply button.

Note the Initial Offset and Initial Multiplier checkboxes. When these are checked, the settings for the annotation that is currently highlighted in the list pane will be applied to all of the elements with that particular annotation (in this case, all conduits). If you have manually moved some of the annotations in the drawing pane, you should clear the Initial Offset checkbox so that the new settings won’t interfere with your manually repositioned annotations.
10. You can manually move the annotations by clicking them and holding the mouse button, then dragging and releasing it. Move the annotations as necessary so that everything is visible and annotations are not overlapping.

11. In the Element Symbology manager, you can create folders to organize the various annotations for an element type. Highlight **Conduit** and click the New button, then select **New Folder** from the shortcut menu that appears.
12. Highlight the newly created folder and click the **Rename** button. Enter the name **Calculated Results**.

13. Click on the **Flow** annotation label and hold down the mouse button, then drag the mouse cursor to the **Calculated Results** folder. Your mouse cursor will change to a drag object icon. Release the mouse button to place the Flow annotation in the folder. Repeat this procedure with the **HGL** annotation.

14. The checkboxes next to each node in the Element Symbology manager list control the visibility of the associated object in the drawing pane, as follows:

   The checkbox next to the Conduit node (and the corresponding checkboxes next to each of the other element types) controls the visibility of conduit elements in the drawing pane.

   The checkbox next to the Label node controls the visibility of conduit element labels in the drawing pane.
The checkbox next to a folder controls the visibility of all annotation definitions within that folder. In the case of the Calculated Results folder, it controls the visibility of the Flow and HGL annotations for conduit elements in the drawing pane.

15. Clear the checkbox next to the Calculated Results folder. Note that both the Flow and HGL annotations disappear from the drawing pane, while the Label annotation is still displayed. Click the checkbox next to the Calculated Results folder to turn the annotations back on.

### 2.4.5 Part 5 - Color Coding

Color Coding allows you to assign colors based on ranges of values for a specified attribute to elements in the plan view. Color coding is useful in performing quick diagnostics on the network.

1. Click the Compute button, then close the Calculation Executive Summary dialog.

2. Color Coding is assigned through the Element Symbology manager. If you are using the default workspace configuration, the Element Symbology manager is located directly below the toolbars on the left side of the dialog. If not, click the View menu and select the Element Symbology command. Highlight Conduit and click the New button, then select Color Coding from the shortcut menu that appears.

3. In the Color Coding Properties dialog that appears, change the Field Name to Flow. The Selection Set control allows you to apply the current color coding to only those elements contained within a previously defined selection set. Leave this value at <All Elements>.

4. Click the Calculate Range button and select Full Range.

5. This fills in the Min. and Max. fields using the highest and lowest calculated values (over the duration of the entire simulation, not just the current time step) for the attribute specified in the Field Name menu. The Steps field lets you specify how many intermediate points are created between the minimum and maximum values defined by the Min. and Max. fields (with the min and max values each representing a point counting towards the total as well). Leave the Steps value at 5.

6. Under Color Maps, leave the Options field set to Color. Click the Initialize button. The Color Maps table is now populated with 5 rows (because there were 5 steps in the range) and a different color has been assigned to each step.
Lesson 4 - Presentation of Results

7. Click the arrow button in the Color column of the first row and select Yellow. Click the Ramp button. The three middle colors are changed to various shades of orange. The Ramp button assigns colors to the intermediate rows to create a gradient between the first and last colors in the table. Click the OK button.
You can also set up color coding to change the size of an element type in the
drawing pane according to the value of a specified attribute.

8. In the Element Symbology manager, highlight Conduit and click the New button,
then select Color Coding from the shortcut menu that appears.

9. In the Color Coding Properties dialog, change the Field Name to Hydraulic
Grade Line (In). Leave the Selection Set value at <All Elements>. Click the
Calculate Range button. Leave the Steps value at 5.
10. Under Color Maps, change the Options value to Size. Click the Initialize button. The Size values are a multiplier of the default element symbol size. In the case of link elements like conduits, the value is a multiplier of the default line weight (width). So a Size value of 5 for a conduit means that a conduit displayed at that
value will be five times wider than a default conduit. Click the OK button.
11. In the **Element Symbology** manager, you can create Theme Folders to organize the various color coding definitions for an element type. Highlight **Conduit** and click the **New** button, then select **New Folder** from the shortcut menu that appears.

12. Highlight the newly created folder and click the **Rename** button. Enter the name **Color Coding Definitions**.

13. Click on the **Flow** color coding label and hold down the mouse button, then drag the mouse cursor to the **Color Coding Definitions** folder. Your mouse cursor will change to a drag object icon. Release the mouse button to place the Flow color coding definition underneath the folder. Repeat this procedure with the **HGL** color coding definition.

14. The checkboxes next to each node in the Element Symbology manager list control the visibility of the associated object in the drawing pane, as follows:

   The checkbox next to the Conduit node (and the corresponding checkboxes next to each of the other element types) controls the visibility of conduit elements in the drawing pane.

   The checkbox next to the Label node controls the visibility of conduit element labels in the drawing pane.

   The checkbox next to a folder controls the visibility of all annotation definitions within that folder. In the case of the Color Coding folder, it controls the visibility of the Velocity and HGL color coding definitions for conduit elements in the drawing pane.

15. **Clear** the checkbox next to the **Color Coding Definitions** folder. Note that both the Flow and HGL color codings disappear from the drawing pane, leaving the conduits displayed in the default color and size. Click the checkbox next to the Color Coding Definitions folder to turn the color coding definitions back on.
This concludes the QuickStart Lessons. For more information on any of StormCAD V8i functions, you can right-click or press the Fl key to access the context-sensitive online help at any time.
Lesson 4 - Presentation of Results
Introducing the Workspace

This chapter describes the menus and toolbars that are used to control the various features and functions of StormCAD V8i. This part of the chapter discusses the following topics:

**Menus**

**Toolbars**

**Customizing StormCAD V8i Toolbars and Buttons**

It also provides details about the differences in functionality between the available user environments that are available:

**Stand-Alone**

**MicroStation Environment**

**Working in AutoCAD**

### 3.1 Menus

Menus are located at the top of StormCAD V8i stand-alone editor window and provide access to program commands, which are broken down by type of functionality.

The following menus are available:

**File Menu**

**Edit Menu**

**Analysis Menu**

**Components Menu**
### File Menu

The File menu contains the following commands:

- **New**: Creates a new project. When you select this command, a new untitled project is created.
- **Open**: Opens an existing project. When you select this command, the Open dialog box appears, allowing you to browse to the project to be opened.
- **Close**: Closes the current project without exiting the program.
- **Close All**: Closes all currently open projects.
- **Save**: Saves the current project.
- **Save As**: Saves the current project under a new project name and/or to a different directory location.
- **Save All**: Saves all currently open projects.
- **ProjectWise**: Opens a submenu containing the following commands:
  - **Open**—Open an existing StormCAD project from ProjectWise. You are prompted to log into a ProjectWise datasource if you are not already logged in.
  - **Save As**—Saves the current project to a ProjectWise datasource. You are prompted to log into a ProjectWise datasource if you are not already logged in.
  - **Change Datasource**—Lets you connect to a different ProjectWise datasource for future Open and Save As operations.

**Note:** For more information about using StormCAD with ProjectWise, see Working with ProjectWise.

- **Import**—Opens a submenu containing the following commands:
  - StormCAD Project
  - Submodel
  - LandXML
  - Micro Drainage
- GEOPAK/PowerCivil Drainage File (only available in MicroStation or PowerCivil V8i for Americas)

- **Import**: Opens a submenu containing the following commands:
  - StormCAD Database
  - Submodel
  - LandXML
  - InRoads
  - GEOPAK/PowerCivil Drainage File (only available in MicroStation or PowerCivil for Americas)
  - Bentley MX Drainage (LandXML Format)
  - Micro Drainage

- **Export**: Opens a submenu containing the following commands:
  - DXF (only available in the Stand-Alone interface)
  - Submodels
  - LandXML
  - InRoads
  - GEOPAK/PowerCivil Drainage File (only available in MicroStation or PowerCivil V8i for Americas)
  - Bentley MX Drainage (LandXML Format)
  - Micro Drainage

- **Seed**: Seed files allow you to save project settings and data as a template (the seed file has an .sts extension). You can then reuse these settings/data while creating new projects using the data from the previously saved seed file. Selecting the Seed command opens a submenu containing the following commands:
  - **New from Seed**: Allows you to create a new project using the previously saved seed file you specify.
  - **Save to Seed**: Saves the current project settings and data as a seed file for reuse in future projects.
  - **Projectwise**: Allows you to access seed files saved in ProjectWise, and to save new seed files to a ProjectWise location.
    - **New from Seed**: Allows you to create a new project using the previously saved seed file you specify.
    - **Save to Seed**: Saves the current project settings and data as a seed file for reuse in future projects.

- **Page Setup**: Defines the print settings that will be used when the current view is printed.
Menus

- **Print Preview**: Opens the Print Preview window, displaying the current view exactly as it will be printed.
- **Print**: Prints the current view.
- **Project Properties**: Opens the Project Properties dialog box, allowing you to specify project-level settings.
- **Recent Files**: When the Recent Files Visible option is selected in the Options dialog box, the most recently opened files will appear in the File menu. See [Options Dialog Box - Global Tab](#) for more information.
- **Exit**: Closes the program.

### 3.1.2 Edit Menu

The Edit menu contains the following commands:

- **Undo**: Cancels the last data input action on the currently active dialog box. Clicking Undo again cancels the second-to-last data input action, and so on.
- **Redo**: Cancels the last undo command.
- **Delete**: Deletes the currently highlighted element.
- **Select All**: Selects all of the elements in the network.
- **Invert Selection**: Selects all currently unselected elements and deselects all currently selected elements.
- **Select by Element**: Opens a submenu listing all available element types. Select one of the element types from the submenu to select all elements of that type in the model.
- **Select by Attribute**: Opens a submenu listing all available element types. Select one of the element types from the submenu to open a query builder that allows you to choose the attribute criteria that will determine what elements will be selected.
- **Clear Selection**: Deselects the currently selected element(s).
- **Clear Highlight**: Removes highlight visibility. Highlighting is created through the Network Navigator.
- **Find Element**: Lets you find a specific element by entering the element's label

### 3.1.3 Analysis Menu

The Analysis menu contains the following commands:

- **Scenarios**: Opens the Scenario Manager, which lets you create, view, and manage project scenarios.
• **Alternatives**: Opens the Alternative Manager, which lets you create, view, and manage alternatives.

• **Calculation Options**: Opens the Calculation Options Manager, which lets you create, view, and manage calculation settings for the project.

• **Calculation Summary**: Opens the calculation executive summary report, which reports a summary of the calculations performed on your model.

• **User Notifications**: Opens the User Notifications Manager, allowing you to view warnings and errors uncovered by the validation process.

• **Validate**: Runs a diagnostic check on the network data to alert you to possible problems that may be encountered during calculation. This is the manual validation command, and it checks for input data errors. It differs in this respect from the automatic validation that StormCAD runs when the compute command is initiated, which checks for network connectivity errors as well as many other things beyond what the manual validation checks.

• **Compute**: Calculates the network. Before calculating, an automatic validation routine is triggered, which checks the model for network connectivity errors and performs other validation. For more information, see Calculating Your Model. Pressing F9 also selects this command.

### 3.1.4 Components Menu

The Tools menu contains the following commands:

• **Default Design Constraints**: Opens the Default Design Constraints dialog, allowing you to specify the parameters of an automatic design calculation. For more information, see Default Design Constraints.

• **Storm Data**: Opens the Storm Data dialog box, which lets you create, edit, and delete storm data. For more information, see Storm Data Dialog Box.

• **Global Storm Events**: Opens the Global Storm Event Settings dialog box, which lets you define project-wide global storm event data. For more information, see Global Storm Events Dialog Box.

• **Inlet Catalog**: Opens the Inlet Catalog dialog box, which lets you create, edit, and view catalog inlets. Catalog inlets are an efficient way to reuse common inlet definitions. For more information, see Creating Inlets.

• **Conduit Catalog**: Opens the Conduit Catalog dialog box, which lets you create, edit, and view catalog conduits. Catalog conduits are an efficient way to reuse common physical conduit definitions. For more information, see Conduit Catalog Dialog Box.
● **Flow-Headloss Curves**: Opens the Flow-Headloss Curves dialog box, allowing you to view, edit, and manage the flow-headloss curves used in the project. For more information, see Flow-Headloss Curves.

● **Engineering Libraries**: Opens the Engineering Libraries Manager. For more information, see Engineering Libraries.

### 3.1.5 View Menu

The View menu contains the following commands:

● **Element Symbology**: Opens the Element Symbology Manager, which lets you create, view, and manage annotation and color-coding in your project.

● **Background Layers**: Opens the Background Layer Manager, which lets you create, view, and manage the background layers associated with the project.

● **Network Navigator**: Opens the Network Navigator Manager (see Using the Network Navigator), which lets you quickly navigate to and review any selection set.

● **Selection Sets**: Opens the Selection Sets Manager, which lets you create, view, and manage selection sets associated with the project.

● **Queries**: Opens the Query Manager, which lets you create SQL expressions for use with selection sets and FlexTables.

● **Prototypes**: Opens the Prototypes Manager (see Creating Prototypes), which lets you enter default values for elements in your model. Prototypes can reduce data entry requirements dramatically if a group of network elements share common data.

● **FlexTables**: Opens the FlexTables Manager, which lets you create, view, and manage the tabular reports for the project.

● **Profiles**: Opens the Profiles Manager, which lets you create, view, and manage the profiles for the project.

● **Contours**: Opens the Contours Manager (see Contours), which lets you create, view, and manage the contours for the project.

● **Named Views**: Opens the Named Views manager (see Using Named Views) where you can create, edit, and use Named Views.

● **Aerial View**: Opens the Aerial View (see Using Aerial View) navigation window.

● **Properties**: Turns the Property Editor display on or off.

● **Customizations**: Opens the Customization Manager, allowing you to view, edit, and manage your customizations.
• **Auto-Refresh**: Turns automatic updates to the main window view on or off whenever changes are made to the StormCAD V8i datastore. When selected, a check mark appears next to this menu command, indicating that automatic updates are turned on.

• **Refresh Drawing**: Updates the main window view according to the latest information contained in the StormCAD V8i datastore.

• **Zoom**: Opens a submenu containing the following commands:
  - **Zoom Extents**—Sets the view so that the entire network is visible in the drawing pane.
  - **Zoom Window**—Activates the manual zoom tool, which lets you specify a portion of the drawing to enlarge.
  - **Zoom In**—Enlarges the size of the model in the drawing pane.
  - **Zoom Out**—Reduces the size of the model in the drawing pane.
  - **Zoom Realtime**—Enables the realtime zoom tool, which lets you zoom in and out by moving the mouse while holding down the left mouse button.
  - **Zoom Center**—Opens the Zoom Center dialog box, which lets you enter drawing coordinates that will be centered in the drawing pane.
  - **Zoom to Selection**—Zooms to the currently selected element.
  - **Zoom Previous**—Resets the zoom level to the last setting.
  - **Zoom Next**—Resets the zoom level to the setting that was active before a Zoom Previous command was executed.

• **Pan**: Activates the Pan tool, which lets you move the model within the drawing pane. When you select this command, the cursor changes to a hand, indicating that you can click and hold the left mouse button and move the mouse to move the drawing.

• **Toolbars**: Opens a submenu that lists each of the available toolbars. Select one of the toolbars in the submenu to turn that toolbar on or off. For more information, see Toolbars.

• **Reset Workspace**: Resets the StormCAD V8i workspace so that the dockable managers appear in their default factory-set positions.

### 3.1.6 Tools Menu

The Tools menu contains the following commands:

• **Active Topology Selection**: Opens the Active Topology Selection toolbar, allowing you to add and remove elements from the current Active Topology Alternative.
• **ModelBuilder**: Opens the ModelBuilder Connections Manager, which lets you create, edit, and manage ModelBuilder connections to be used in the model-building/model-synchronizing process. For more information, see ModelBuilder Connections Manager.

• **TRev**: Opens the TRev Wizard dialog, allowing you to use TRev to assign node elevations automatically. For more information, see *Using TRev to Assign Node Elevations*.

• **Hyperlinks**: Lets you associate external files, such as pictures or movie files, with elements. For more information, see *Hyperlinks*.

• **User Data Extensions**: Opens the User Data Extension dialog box, which lets you add and define custom data fields. For example, you can add new fields such as the pipe installation date. For more information, see *User Data Extensions*.

• **Batch Pipe Split**: Opens the *Batch Pipe Split Dialog Box*, allowing you to perform pipe split operations on multiple pipes simultaneously.

• **Database Utilities**: Opens a submenu containing the following commands:
  
  – **Compact Database**—When you delete data from a StormCAD V8i project, such as elements or alternatives, the database store that StormCAD V8i uses can become fragmented, causing unnecessarily large data files, which impact performance substantially. Compacting the database eliminates the empty data records, thereby defragmenting the datastore and improving the performance of the file.

  **Note:** Every tenth time a file is saved, StormCAD V8i will automatically prompt you to compact the database. If you open a file without saving it, the count does not go up. If you open and save a file multiple times in the same session, the count only goes up on the first save. If you open, save, and close the file, the count goes up. Click Yes to compact the database, or no to close the prompt dialog box without compacting. Since compacting the database can take time, especially for larger models, you may want to postpone the compact procedure until a later time. You can modify how StormCAD V8i compacts the database in the *Options dialog box*. For more information, see *Options Dialog Box - Global Tab*.

  – **Synchronize Drawing**—Synchronizes the current model drawing with the project database.

  – **Update Database Cache**—Update for the open model.

• **Layout**: Opens a submenu that lists each of the available element types. Select one of the element types in the submenu to place that element in your model.
• **External Tools**: Run an existing external tool or create a new one by opening up the External Tools manager (see [External Tools](#)).

• **Options**: Opens the Options (see [Setting Options](#)) dialog box, which lets you change global settings such as display pane settings, drawing scale, units, display precision and format used, and element labeling.

### 3.1.7 Report Menu

The Report menu contains the following commands:

• **Element Tables**: Opens a submenu that lets you display FlexTables for any link or node element. These predefined FlexTables contain most of the input data and results for each instance of the selected element in the model. You can also access a DOT report from this submenu.

• **Headloss Detailed Reports**: Opens a submenu that allows you to display headloss reports of the following types:
  – AASHTO Detailed Report
  – AASHTO Summary Report
  – HEC-22 Detailed Report
  – HEC-22 Summary Report

• **Scenario Summary**: Opens the Scenario Summary Report.

• **Project Inventory**: Opens the Project Inventory Report, which contains the number of each of the various element types that are in the network.

• **Conduit Inventory**: Opens the Conduit Inventory Report, which contains the number of each kind of conduit along with the total length for each type.

• **Report Options**: Opens the Report Options dialog, allowing you to customize the appearance of the preformatted reports. See Report Options for more information.

### 3.1.8 Help Menu

The Help menu contains the following commands:

• **StormCAD Help**: Opens the online help Table of Contents.

• **Quick Start Lessons**: Opens the online help to the Quick Start Lessons Overview topic.

• **Welcome Dialog**: Opens the Welcome dialog box.

• **Check for SELECT Updates**: Opens your Web browser to the our Web site, allowing you to check for StormCAD V8i updates.
• **Bentley Institute Training**: Opens your browser to the Bentley Institute page of our website.

• **Bentley Professional Services**: Opens your browser to the Bentley Professional Services page of our website.

• **Bentley SELECT Support**: Opens your browser to the SelectServices Support page of our website.

• **Bentley Communities**: Opens your browser to the Be Communities area of our website.

• **Bentley.com**: Opens your browser to the main page of our website.

• **About StormCAD**: Opens the About StormCAD V8i dialog box, which displays copyright information about the product, registration information, and the current version number of this release.
3.2 Toolbars

Toolbars provide access to frequently used menu commands and are organized by the type of functionality offered. Many of the toolbars have additional buttons available that are not displayed by default. You can display these additional buttons by following the procedure in Adding and Removing Toolbar Buttons.

The following toolbars are available:

- **Layout Toolbar**
- **Standard Toolbar**
- **Edit Toolbar**
- **Analysis Toolbar**
- **View Toolbar**
- **Scenarios Toolbar**
- **Compute Toolbar**
- **Tools Toolbar**
- **Help Toolbar**
- **Components Toolbar**
- **Reports Toolbar**
- **Reports Toolbar**
- **Reports Toolbar**

### 3.2.1 Layout Toolbar

You use the Layout toolbar to lay out your model in the drawing pane. The Drawing toolbar provides access to the following buttons:

- **Select**: Changes your mouse cursor into a selection tool. The selection tool behavior varies depending on the direction in which the mouse is dragged after defining the first corner of the selection box, as follows:
  - If the selection is made from left-to-right, all elements that fall completely within
the selection box that is defined will be selected.

- If the selection is made from right-to-left, all elements that fall completely within the selection box and that cross one or more of the lines of the selection box will be selected.

**Layout**: Changes your mouse cursor into a network layout tool. Right-click to change the type of element and the type of link.

- **Conduit**—Lets you place a closed section element through which water moves. A conduit has a constant roughness and cross section shape along its entire length. Available conduit shapes consist of both open and closed cross sections.

- **Gutter**—Lets you place an open-section element that models overflow. A gutter accepts the inflows that are not being taken in by an inlet because of capacity constraints. In addition, a gutter also takes in the overflow from an inlet due to flooding. There can only be one gutter downstream of any element and the gutter cannot be the only way water can leave an element, there must also be a channel or a conduit. Gutters are only used for routing; no dynamic calculations are performed for gutter elements.
**Catch Basin:** Changes your mouse cursor into a catch basin element symbol. Clicking the left mouse button while this tool is active causes a catch basin element to be placed at the location of the mouse cursor.

**Manhole:** Changes your mouse cursor into a manhole element symbol. Clicking the left mouse button while this tool is active causes a manhole element to be placed at the location of the mouse cursor.

**Outfall:** Changes your mouse cursor into an outfall element symbol. Clicking the left mouse button while this tool is active causes an outfall element to be placed at the location of the mouse cursor.

**Catchment:** Changes your mouse cursor into a catchment element symbol. When this tool is active, click in the drawing pane to begin drawing a polygon that represents the catchment.

**Border:** Changes your mouse cursor into a border symbol. When the border tool is active, you can draw a simple box in the drawing pane using the mouse. For example, you might want to draw a border around the entire model.

**Text:** Changes your mouse cursor into a text symbol. When the text tool is active, you can add simple text to your model. Click anywhere in the drawing pane to display the Text Editor dialog box, which lets you enter text to be displayed in your model.

**Line:** Changes your mouse cursor into a line symbol. When this tool is active, you can draw lines and polygons in your model using the mouse.

### 3.2.2 Standard Toolbar

The Standard toolbar provides access to the following buttons:

**New:** Creates a new StormCAD V8i project. When you select this command, the Select File to Create dialog box appears, allowing you to define a name and directory location for the new project.
3.2.3 Edit Toolbar

The Edit toolbar provides access to the following buttons:

- **Undo**: Cancels your most recent action.
- **Redo**: Lets you redo the last cancelled action.
- **Delete**: Deletes the element(s) currently highlighted in the drawing pane.
- **Clear Highlight**: Removes highlight visibility. Highlighting is created through the Network Navigator.
- **Find Element**: Lets you find a specific element by choosing it from a menu.

**Open**: Opens an existing StormCAD V8i project. When this command is initialized, the Select StormCAD V8i Project to Open dialog box appears, allowing you to browse to the project to be opened.

**Close**: Closes the current project.

**Close All**: Closes all projects that are currently open.

**Save**: Saves the current project.

**Save All**: Saves all of the currently open projects.

**Print Preview**: Opens the Print Preview window, displaying the current view exactly as it will be printed. You can select whether you want the print preview to be Fit to Page or Scaled.

**Print**: Prints the current view of the network as displayed in the drawing pane. You can select whether you want the printed image to be Fit to Page or Scaled.
containing all elements in the current model.

### 3.2.4 View Toolbar

The View toolbar provides access to the following buttons, which give you easy access to many of the managers in StormCAD V8i:

- **Element Symbology**: Opens the Element Symbology Manager, which lets you create, view, and manage annotation and color-coding in your project.

- **Background Layers**: Opens the Background Layer Manager, which lets you create, view, and manage the background layers associated with the project.

- **Network Navigator**: Opens the Network Navigator Manager (see Using the Network Navigator), which lets you quickly navigate to and review any selection set.

- **Selection Sets**: Opens the Selection Sets Manager, which lets you create, view, and manage selection sets associated with the project.

- **Queries**: Opens the Query Manager, which lets you create SQL expressions for use with selection sets and FlexTables.

- **Prototypes**: Opens the Prototypes Manager (see Creating Prototypes), which lets you enter default values for elements in your model. Prototypes can reduce data entry requirements dramatically if a group of network elements share common data.

- **FlexTables**: Opens the FlexTables Manager, which lets you create, view, and manage the tabular reports for the project.

- **Profiles**: Opens the Profiles Manager, which lets you create, view, and manage the profiles for the project.

- **Contours**: Opens the Contours Manager (see Contours), which lets you create, view, and manage the contours for the project.
**Toolbars**

**Named Views**: Opens the Named Views manager (see Using Named Views) where you can create, edit, and use Named Views.

**Aerial View**: Opens the Aerial View (see Using Aerial View) navigation window.

**Properties**: Turns the Property Editor display on or off.

**Customizations**: Opens the customizations manager dialog.

### 3.2.5 Scenarios Toolbar

The Scenario toolbar provides access to the following buttons:

**Scenario List Box**: Lets you quickly change the current scenario.

**Scenarios**: Opens the Scenario Manager, which lets you create, view, and manage project scenarios.

**Alternatives**: Opens the Alternative Manager, which lets you create, view, and manage project alternatives.

**Calculation Options**: Opens the Calculation Options Manager, which lets you create different profiles for different calculation settings.

### 3.2.6 Compute Toolbar

The Compute toolbar provides access to the following buttons:

**Calculation Summary**: Opens the calculation executive summary report, which reports a summary of the calculations performed on your model. For more information, see Calculation Executive Summary Dialog Box.
**Validate:** Runs a diagnostic check on the network data to alert you to possible problems that may be encountered during calculation. This is the manual validation command, and it checks for input data errors. It differs in this respect from the automatic validation that StormCAD runs when the compute command is initiated, which checks for network connectivity errors as well as many other things beyond what the manual validation checks.

**Compute:** Calculates the network. Before calculating, an automatic validation routine is triggered, which checks the model for network connectivity errors and performs other validation. For more information, see Calculating Your Model.

**User Notifications:** Opens the User Notifications Manager, allowing you to view warnings and errors uncovered by the validation process. This button does not appear in the toolbar by default, but can be added. For more information, see Adding and Removing Toolbar Buttons.

### 3.2.7 Tools Toolbar

The Tools toolbar provides quick access to the same commands that are available in the Tools menu. The Tools toolbar provides access to the following buttons.

**Active Topology Selection:** Opens the Active Topology Selection toolbar, allowing you to add and remove elements from the current Active Topology Alternative.

**ModelBuilder:** Opens the ModelBuilder Connections Manager, which lets you create, edit, and manage ModelBuilder connections to be used in the model-building/model-synchronizing process. For more information, see ModelBuilder Connections Manager.

**TRex:** Opens the TRex Wizard dialog, allowing you to use TRex to assign node elevations automatically. For more information, see Using TRex to Assign Node Elevations.

**Hyperlinks:** Lets you associate external files, such as pictures or movie files, with elements. For more information, see Adding Hyperlinks to Elements.

**User Data Extensions:** Opens the User Data Extension dialog box, which lets you add and define custom data fields. For example, you can add new fields such as
the pipe installation date. For more information, see User Data Extensions.

**Compact Database:** When you delete data from a StormCAD V8i project, such as elements or alternatives, the database store that StormCAD V8i uses can become fragmented, causing unnecessarily large data files, which impact performance substantially. Compacting the database eliminates the empty data records, thereby defragmenting the datastore and improving the performance of the file.

**Synchronize Drawing:** Synchronizes the current model drawing with the project database.

**Update Database Cache:** Update for the open model.

**Batch Pipe Split:** Opens the Batch Split Pipe Dialog Box, allowing you to perform pipe split operations on multiple pipes simultaneously.

**Customize:** Run an existing external tool or create a new one by opening up the External Tools manager (see External Tools).

**Options:** Opens the Options (see Setting Options) dialog box, which lets you change global settings such as display pane settings, drawing scale, units, display precision and format used, and element labeling.

### 3.2.8 Help Toolbar

The Help toolbar provides quick access to the same commands that are available in the Help menu. The Help toolbar provides access to the following buttons.

**Check for Updates:** Opens your Web browser to our Web site, allowing you to check for StormCAD V8i updates.

**Training:** Opens your browser to the Bentley Institute page of the Bentley web site.

**Online Support:** Opens your browser to the Support Center of the Bentley web site.
Bentley.com: Opens your browser to Bentley's main web site.

Help: Opens the StormCAD V8i online help.

3.2.9 Components Toolbar

The Components toolbar provides quick access to the same commands that are available in the Components menu. The Components toolbar provides access to the following buttons.

Default Design Constraints: Opens the Default Design Constraints dialog, allowing you to specify the parameters of an automatic design calculation. For more information, see Default Design Constraints.

Storm Data: Opens the Storm Data dialog box, which lets you create, edit, and delete storm data. For more information, see Storm Data Dialog Box.

Global Storm Events: Opens the Global Storm Event Settings dialog box, which lets you define project-wide global storm event data. For more information, see Global Storm Events Dialog Box.

Inlet Catalog: Opens the Inlet Catalog dialog box, which lets you create, edit, and view catalog inlets. Catalog inlets are an efficient way to reuse common inlet definitions. For more information, see Creating Inlets.

Conduit Catalog: Opens the Conduit Catalog dialog box, which lets you create, edit, and view catalog conduits. Catalog conduits are an efficient way to reuse common physical pipe definitions. For more information, see Conduit Catalog Dialog Box.

Flow-Headloss Curves: Opens the Flow-Headloss Curves dialog box, allowing you to view, edit, and manage the flow-headloss curves used in the project. For more information, see Flow-Headloss Curves.

Engineering Libraries: Opens the Engineering Libraries Manager. For more information, see Working with Engineering Libraries.
3.2.10 Reports Toolbar

The Reports toolbar provides quick access to the same commands that are available in the Reports menu. The Reports toolbar provides access to the following buttons:

- **Scenario Summary**: Opens the Scenario Summary Report.
- **Project Inventory**: Opens the Project Inventory Report, which contains the number of each of the various element types that are in the network.
- **Conduit Inventory**: Opens the Conduit Inventory Report, which contains the number of each kind of conduit along with the total length for each type.
- **Report Options**: Opens the Report Options dialog, allowing you to customize the appearance of the preformatted reports. See Report Options for more information.

3.2.11 Select Toolbar

The Select toolbar provides quick access to the same select commands that are available in the Edit menu. The Select toolbar provides access to the following buttons:

- **Select By Polygon**: Lets you select elements in your model by drawing a polygon in the drawing pane. Click in the drawing pane to draw each side of the polygon, then right-click and select Done when the polygon is complete. All elements contained within the polygon will be selected.
- **Select All**: Selects all of the elements in the network.
- **Select by Element**: Opens a submenu listing all available element types. Select one of the element types from the submenu to select all elements of that type in the model.
- **Select by Attribute**: Opens a submenu listing all available element types. Select one of the element types from the submenu to open a query builder that allows you to choose the attribute criteria that will determine what elements will be selected.
Clear Selection: Deselects the currently highlighted element(s).

Invert Selection: Selects all currently unselected elements and deselects all currently selected elements.

3.2.12 Zoom Toolbar

The Zoom toolbar provides access to the zooming and panning tools. It provides access to the following buttons:

Zoom Extents: Sets the view so that the entire network is visible in the drawing pane.

Zoom Window: Activates the manual zoom tool, which lets you specify a portion of the drawing to enlarge.

Zoom In: Enlarges the size of the model in the drawing pane.

Zoom Out: Reduces the size of the model in the drawing pane.

Zoom Realtime: Enables the realtime zoom tool, which lets you zoom in and out by moving the mouse while holding down the left mouse button.

Zoom Center: Opens the Zoom Center dialog box, which lets you enter drawing coordinates that will be centered in the drawing pane.

Zoom to Selection: Zooms to the currently selected element.

Zoom Previous: Resets the zoom level to the last setting.

Zoom Next: Resets the zoom level to the setting that was active before a Zoom Previous command was executed.
**Pan**: Activates the Pan tool, which lets you move the model within the drawing pane. When you select this command, the cursor changes to a hand, indicating that you can click and hold the left mouse button and move the mouse to move the drawing.

**Refresh Drawing**: Updates the main window view according to the latest information contained in the StormCAD V8i datastore.

### 3.3 Customizing StormCAD V8i Toolbars and Buttons

Toolbar buttons represent Bentley StormCAD V8i menu commands. Toolbars can be controlled in Bentley StormCAD V8i using View > Toolbars. You can turn toolbars on and off, move the toolbar to a different location in the work space, or you can add and remove buttons from any toolbar.
To turn toolbars on

Click View > Toolbars, then click in the space to the left of the toolbar you want to turn on.

To turn toolbars off

Click View > Toolbars, then click the check mark next to the toolbar you want to turn off.

To move a toolbar to a different location in the workspace

Move your mouse to the vertical dotted line on the left side of any toolbar, then drag the toolbar to the desired location. If you move a toolbar away from the other toolbar, the toolbar becomes a floating dialog box.

To add or remove a button from a toolbar

1. Click the down arrow on the end of the toolbar you want to customize. A series of submenus appear, allowing you to select or deselect any icon in that toolbar.
2. Click Add or Remove Buttons then move the mouse cursor to the right until all of the submenus appear, as shown as follows:

3. Click the space to left of the toolbar button you want to add. A check mark is visible in the submenu and the button opens in the toolbar.

or

Click the check mark next to the toolbar button you want to remove. The button will no longer appear in the toolbar.

3.3.1 StormCAD V8i Dynamic Manager Display

Most of the features in Bentley StormCAD V8i is accessed through a system of dynamic windows called managers. For example, the look of the elements is controlled in the Element Symbology manager while animation is controlled in the EPS Results Browser manager.
The following table lists all the Bentley StormCAD V8i managers, their toolbar buttons, and keyboard shortcuts.

<table>
<thead>
<tr>
<th>Toolbar Button</th>
<th>Manager</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Folder]</td>
<td><strong>Scenarios</strong>—build a model run from alternatives.</td>
<td>&lt;Alt+1&gt;</td>
</tr>
<tr>
<td>![List]</td>
<td><strong>Alternatives</strong>—create and manage alternatives.</td>
<td>&lt;Alt+2&gt;</td>
</tr>
<tr>
<td>![Calculator]</td>
<td><strong>Calculation Options</strong>—set parameters for the numerical engine.</td>
<td>&lt;Alt+3&gt;</td>
</tr>
<tr>
<td>![Element]</td>
<td><strong>Element Symbology</strong>—control how elements look and what attributes are displayed.</td>
<td>&lt;Ctrl+1&gt;</td>
</tr>
<tr>
<td>![Background]</td>
<td><strong>Background Layers</strong>—control the display of background layers.</td>
<td>&lt;Ctrl+2&gt;</td>
</tr>
<tr>
<td>![Network]</td>
<td><strong>Network Navigator</strong>—helps you find nodes in your model.</td>
<td>&lt;Ctrl+3&gt;</td>
</tr>
<tr>
<td>![Selection]</td>
<td><strong>Selection Sets</strong>—create and manage selection sets.</td>
<td>&lt;Ctrl+4&gt;</td>
</tr>
<tr>
<td>![Query]</td>
<td><strong>Queries</strong>—create SQL expressions for use with selection sets and FlexTables.</td>
<td>&lt;Ctrl+5&gt;</td>
</tr>
<tr>
<td>![Prototype]</td>
<td><strong>Prototypes</strong>—create and manage prototypes.</td>
<td>&lt;Ctrl+6&gt;</td>
</tr>
<tr>
<td>![FlexTable]</td>
<td><strong>FlexTables</strong>—display and edit tables of elements.</td>
<td>&lt;Ctrl+7&gt;</td>
</tr>
<tr>
<td>![Profile]</td>
<td><strong>Profiles</strong>—draw profiles of parts of your network.</td>
<td>&lt;Ctrl+9&gt;</td>
</tr>
</tbody>
</table>
Introducing the Workspace

<table>
<thead>
<tr>
<th>Toolbar Button</th>
<th>Manager</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Contours</strong>—create and manage contours.</td>
<td>&lt;Ctrl+0&gt;</td>
</tr>
<tr>
<td>![Button Image]</td>
<td><strong>Properties</strong>—display properties of individual elements or managers.</td>
<td>&lt;F4&gt;</td>
</tr>
<tr>
<td>![Button Image]</td>
<td><strong>Refresh</strong>—Update the main window view according to the latest information contained in the Bentley StormCAD V8i datastore.</td>
<td>&lt;F5&gt;</td>
</tr>
<tr>
<td>![Button Image]</td>
<td><strong>User Notifications</strong>—presents error and warning messages resulting from a calculation.</td>
<td>&lt;F8&gt;</td>
</tr>
<tr>
<td>![Button Image]</td>
<td><strong>Compute.</strong></td>
<td>&lt;F9&gt;</td>
</tr>
</tbody>
</table>

When you first start Bentley StormCAD V8i, only two managers are displayed: the Element Symbology and Background Layers managers. This is the default workspace. You can display as many managers as you want and move them to any location in the Bentley StormCAD V8i workspace.
Customizing StormCAD V8i Toolbars and Buttons

**To return to the default workspace**

Click **View > Reset Workspace**.

- If you return to the default workspace, the next time you start Bentley StormCAD V8i, you will lose any customizations you might have made to the dynamic manager display.

**To open a manager**

1. Do one of the following:
   - Select the desired manager from the View menu.
   - Click a manager’s button on one of the toolbars.
   - Press the keyboard shortcut for the desired manager.

2. If the manager is not already docked, you can drag it to the top, left- or right-side, or bottom of the StormCAD V8i window to dock it. For more information on docking managers, see [Customizing Managers](#).

**Customizing Managers**

When you first start Bentley StormCAD V8i, you will see the default workspace in which a limited set of dock-able managers are visible. You can decide which managers will be displayed at any time and where they will be displayed. You can also return to the default workspace any time.

**There are four states for each manager:**

**Floating**—A floating manager sits above the Bentley StormCAD V8i workspace like a dialog box. You can drag a floating manager anywhere and continue to work.

You can also:

- Resize a floating manager by dragging its edges.
- Close a floating manager by clicking on the x in the top right-hand corner of the title bar.
- Change the properties of the manager by right-clicking on the title bar.
- Switch between multiple floating managers in the same location by clicking the manager’s tab.
- Dock the manager by double-clicking the title bar.
Docked static—A docked static manager attaches to any of the four sides of the Bentley StormCAD V8i window. If you drag a floating manager to any of the four sides of the Bentley StormCAD V8i window, the manager will attach or dock itself to that side of the window. The manager will stay in that location unless you close it or make it dynamic. A vertical pushpin in the manager’s title bar indicates its static state; click the pushpin to change the manager’s state to dynamic. When the push pin is pointing downward (vertical push pin), the manager is docked.

You can also:

• Close a docked manager by left clicking on the x in the upper right corner of the title bar.
• Change a docked manager into a floating manager by double-clicking the title bar, or by dragging the manager to the desired location (for example, away from the side of the Bentley StormCAD V8i window).
• Change a static docked manager into a dynamically docked manager by clicking the push pin in the title bar.
• Switch between multiple docked managers in the same location by clicking the manager’s tab.

Docked dynamic—A docked dynamic manager also docks to any of the four sides of the Bentley StormCAD V8i window, but remains hidden except for a single tab. Show a docked dynamic manager by moving the mouse over the tab, or by clicking the tab. When the manager is showing (not hidden), a horizontal pushpin in its title bar indicates its dynamic state.

You can also:

• Close a docked manager by left-clicking on the x in the upper right corner of the title bar.
• Change a docked dynamic manager into a docked static manager by clicking the push pin (converting it from vertical to horizontal).
• Switch between multiple docked managers in the same location by moving the mouse over the manager’s tab or by clicking the manager’s tab.
Closed—When a manager is closed, you cannot view it. Close a manager by clicking the x in the right corner of the manager’s title bar. Open a manager by selecting the manager from the View menu (for example, View > Element Symbology), or by selecting the button for that manager on the appropriate toolbar.

### 3.4 Stand-Alone

The Stand-Alone Editor is the workspace that contains the various managers, toolbars, and menus, along with the drawing pane, that make up the Bentley StormCAD V8i interface. The Bentley StormCAD V8i interface uses dockable windows and toolbars, so the position of the various interface elements can be manually adjusted to suit your preference.

#### 3.4.1 The Drawing View

You change the drawing view of your model by using the pan tool or one of the zoom tools:

- **Panning**

- **Zooming**

- **Drawing Style**

**Panning**

You can change the position of your model in the drawing pane by using the Pan tool.

**To use the Pan tool**

1. Click the Pan button on the Zoom toolbar.
   - The mouse cursor changes to the Pan icon.
2. Click anywhere in the drawing, hold down the mouse button and move the mouse to reposition the current view.

   or

   If your mouse is equipped with a mousewheel, you can pan by simply holding down the mousewheel and moving the mouse to reposition the current view.
Introducing the Workspace

or

Select View > Pan, then click anywhere in the drawing, hold down the mouse button and move the mouse to reposition the current view.

**Zooming**

You can enlarge or reduce your model in the drawing pane using one of the following zoom tools:

The current zoom level is displayed in the lower right hand corner of the interface, next to the coordinate display.

**Zoom Extents**

The Zoom Extents command automatically sets the zoom level such that the entire model is displayed in the drawing pane.

To use Zoom Extents, click Zoom Extents on the Zoom toolbar. The entire model is displayed in the drawing pane.

or

Select View > Zoom > Zoom Extents.
**Zoom Window**

The Zoom Window command is used to zoom in on an area of your model defined by a window that you draw in the drawing pane.

To use Zoom Window, click the Zoom Window button on the Zoom toolbar, then click and drag the mouse inside the drawing pane to draw a rectangle. The area of your model inside the rectangle will appear enlarged.

or

Select View > Zoom > Zoom Window, then draw the zoom window in the drawing pane.

**Zoom In and Out**

The Zoom In and Zoom Out commands allow you to increase or decrease, respectively, the zoom level of the current view by one step per mouse click.

To use Zoom In or Zoom Out, click either one on the Zoom toolbar, or select View > Zoom > Zoom In or View > Zoom > Zoom Out.

If your mouse is equipped with a mousewheel, you zoom in or out by simply moving the mousewheel up or down respectively.

**Zoom Realtime**

The Zoom Realtime command is used to dynamically scale up and down the zoom level. The zoom level is defined by the magnitude of mouse movement while the tool is active.

**Zoom Center**
Introducing the Workspace

The Zoom Center command is used to enter drawing coordinates that will be centered in the drawing pane.

1. Choose View > Zoom > Zoom Center or click the Zoom Center icon on the Zoom toolbar. The Zoom Center dialog box opens.

![Zoom Center dialog box](image)

2. The Zoom Center dialog box contains the following:

   **X**
   - Defines the X coordinate of the point at which the drawing view will be centered.

   **Y**
   - Defines the Y coordinate of the point at which the drawing view will be centered.

   **Zoom**
   - Defines the zoom level that will be applied when the zoom center command is initiated. Available zoom levels are listed in percentages of 25, 50, 75, 100, 125, 150, 200 and 400.

3. Enter the X and Y coordinates.
4. Select the percentage of zoom from the Zoom drop-down menu.
5. Click OK.

**Zoom Selection**

Enables you to zoom to specific elements in the drawing. You must select the elements to zoom to before you select the tool.

**Zoom Previous and Zoom Next**

Enables you to toggle between the previous and next zoom levels.
Zoom Previous returns the zoom level to the most recent previous setting. To use Zoom Previous, click View > Zoom > Zoom Previous or click the Zoom Previous icon from the Zoom toolbar.

Zoom Next returns the zoom level to the setting that was active before a Zoom Previous command was executed. To use Zoom Previous, click View > Zoom > Zoom Next or click the Zoom Next icon from the Zoom toolbar.

**Zoom Dependent Visibility**

Available through the Properties dialog box of each layer in the Element Symbology manager, the Zoom Dependent Visibility feature can be used to cause elements, decorations, and annotations to only appear in the drawing pane when the view is within the zoom range specified by the Minimum and Maximum Zoom values.

By default, Zoom Dependent Visibility is turned off. To turn on Zoom Dependent Visibility, highlight a layer in the Element Symbology Manager. In the Properties window, change the Enabled value under Zoom Dependent Visibility to True. The following settings will then be available:

<table>
<thead>
<tr>
<th>Enabled</th>
<th>Set to true to enable and set to false to disable Zoom Dependent Visibility.</th>
</tr>
</thead>
<tbody>
<tr>
<td>zoomDependentVisibility</td>
<td></td>
</tr>
</tbody>
</table>
**Zoom Out Limit (%)**  
The minimum zoom level, as a percent of the default zoom level used when creating the project, at which objects on the layer will appear in the drawing. The current zoom level is displayed in the lower right hand corner of the interface, next to the coordinate display. You can also set the current zoom level as the minimum by right-clicking a layer in the Element Symbology manager and selecting the Set Minimum Zoom command.

**Zoom In Limit (%)**  
The maximum zoom level, as a percent of the default zoom level used when creating the project, at which objects on the layer will appear in the drawing. The current zoom level is displayed in the lower right hand corner of the interface, next to the coordinate display. You can also set the current zoom level as the maximum by right-clicking a layer in the Element Symbology manager and selecting the Set Maximum Zoom command.

**Apply to Element**  
Set to true to apply the zoom minimums and maximums to the symbols in the drawing.

**Apply to Decorations**  
Set to true to apply the zoom minimums and maximums to flow arrows, check valves, and constituent sources in the drawing.

**Apply to Annotations**  
Set to true to apply the zoom minimums and maximums to labels in the drawing.

**Drawing Style**

Elements can be displayed in one of two styles in the Stand-Alone version; GIS style or CAD style.

Under GIS style, the size of element symbols in the drawing pane will remain the same (relative to the screen) regardless of zoom level. Under CAD style, element symbols will appear larger or smaller (relative to the drawing) depending on zoom level.

There is a default Drawing Style that is set on the Global tab of the Options dialog. The drawing style chosen there will be used by all elements by default. Changing the default drawing style will only affect new projects, not existing ones.
You can change the drawing style used by all of the elements in the project, or you can set each element individually to use either drawing style.

**To change a single element’s drawing style**

1. Double-click the element in the Element Symbology manager dialog to open the Properties manager.
2. In the Properties manager, change the value in the Display Style field to the desired setting.

**To change the drawing style of all elements**

Click the Drawing Style button in the Element Symbology manager and select the desired drawing style from the submenu that appears.

### 3.4.2 Using Aerial View

The Aerial View is a small navigation window that provides a graphical overview of your entire drawing. You can toggle the Aerial View window on or off by selecting View > Aerial View to open the Aerial View window.

A Navigation Rectangle is displayed in the Aerial View window. This Navigation Rectangle provides a you-are-here indicator showing you current zoom location respective of the overall drawing. As you pan and zoom around the drawing, the Navigation Rectangle will automatically update to reflect your current location.

You can also use the Aerial View window to navigate around your drawing. To pan, click the Navigation Rectangle to drag it to a new location. To zoom, click anywhere in the window to specify the first corner of the Navigation Rectangle, and click again to specify the second corner.

In the AutoCAD environment, see the AutoCAD online help for a detailed explanation.
In Stand-Alone environment, with Aerial View window enabled (by selecting the View > Aerial View), click and drag to draw a rectangular view box in the aerial view. The area inside this view box is displayed in the main drawing window. Alternately, any zooming or panning action performed directly in the main window updates the size and location of the view box in the Aerial View window.

The Aerial View window contains the following buttons:

**Zoom Extents**—Display the entire drawing in the Aerial View window.

**Zoom In**—Decrease the area displayed in the Aerial View window.

**Zoom Out**—Increase the area displayed in the Aerial View window.

**Help**—Opens the online help.

To resize the view box directly from the Aerial View window, click to define the new rectangular view box. To change the location of the view box, hover the mouse cursor over the current view rectangle and click to drag the view box frame to a new location.

### 3.4.3 Using Background Layers

Use background layers to display pictures behind your network in order to relate elements in your network to structures and roads depicted in the picture. You can add, delete, edit and rename background layers in the Background Layers Manager. The Background Layers manager is only available in the Stand-Alone version of StormCAD V8i. The MicroStation and AutoCAD versions each provide varying degrees of native support for inserting raster and vector files.

You can add multiple pictures to your project for use as background layers, and turn them off and on. Additionally, you can create groups of pictures in folders, so you can hide or show an entire folder or group of pictures at once.

To add or delete background layers, open the Background Layers manager choose View > Background Layers.
You can use shapefiles, AutoCAD DXF files, and raster (also called bitmap) pictures as background images for your model. The following raster image formats are supported: bmp, jpg, jpeg, jpe, jfif, gif, tif, tiff, png, and sid.

Using the Background Layer manager you can add, edit, delete, and manage the background layers that are associated with the project. The dialog box contains a list pane that displays each of the layers currently contained within the project, along with a number of button controls.

When a background layer is added, it opens in the Background Layers list pane, along with an associated check box that is used to control that layer’s visibility. Selecting the check box next to a layer causes that layer to become visible in the main drawing pane; clearing it causes it to become invisible. If the layers in the list pane are contained within one or more folders, clearing the check box next to a folder causes all of the layers within that folder to become invisible.

**Note:** When multiple background layers are overlaid, priority is given to the first one on the list.
The toolbar consists of the following buttons:

**New**
Opens a menu containing the following commands:
- **New File**—Opens a Select Background dialog box where you can choose the file to use as a background layer.
- **New Folder**—Creates a folder in the Background Layers list pane.

**Delete**
Removes the currently selected background layer.

**Rename**
Renames the currently selected layer.

**Edit**
Opens a Properties dialog box that corresponds with the selected background layer.

**Shift Up**
Moves the currently highlighted object up in the list pane.
**Shift Down**
Moves the currently highlighted object down in the list pane.

**Expand All**
Expands all of the branches in the hierarchy displayed in the list pane.

**Collapse All**
Collapses all of the branches in the hierarchy displayed in the list pane.

**Help**
Displays online help for the Background Layer Manager.

---

**To add a background layer folder**

You can create folders in Background Layers to organize your background layers and create a group of background layers that can be turned off together. You can also create folders within folders. When you start a new project, an empty folder is displayed in the Background Layers manager called Background Layers. New background layer files and folders are added to the Background Layers folder by default.

1. Choose **View > Background Layers** to open the Background Layers manager.
2. In the Background Layers manager, click the **New** button, then click **New Folder** from the shortcut menu.
   
   Or select the default Background Layers folder, then right-click and select **New > Folder** from the shortcut menu.
   
   If you are creating a new folder within an existing folder, select the folder, then click **New > New Folder**. Or right-click, then select **New > Folder** from the shortcut menu.
3. Right-click the new folder and select **Rename** from the shortcut menu.
4. Type the name of the folder, then press **<Enter>**.
To delete a background layer folder

1. Click View > Background Layers to open the Background Layers manager.
2. In the Background Layers managers, select the folder you want to delete, then click the **Delete** button.
   - You can also right-click a folder to delete, then select **Delete** from the shortcut menu.

To rename a background layer folder

1. Click View > Background Layers to open the Background Layers manager.
2. In the Background Layers managers, select the folder you want to rename, then click the **Rename** button.
   - You can also right-click a folder to rename, then select **Rename** from the shortcut menu.
3. Type the new name of the folder, then press <**Enter**>.
   - You can also rename a background layer folder by selecting the folder, then modifying its label in the Properties Editor.

To add a background layer

In order to add background layers to projects use the Background Layers manager. When you start a new project, an empty folder in the Background Layers manager called Background Layers is displayed. New background layer files and folders are added to the Background Layers folder by default.

1. Click View > Background Layers to open the Background Layers manager.
2. In the Background Layers managers, click the **New** button, then click **New File** from the shortcut menu.
   - Or right-click on the default Background Layers folder and select **New > File** from the shortcut menu.
   - To add a new background layer file to an existing folder in the Background Layer manager, select the folder, then click **New > New File**. Or right-click, then select **New > File** from the shortcut menu.
3. Navigate to the file you want to add as a background layer and select it.
   - If you select a .dxf file, the DXF Properties dialog box opens.
– If you select a .shp the ShapeFile Properties dialog box opens.
– If you select a .bmp, .jpg, .jpeg, .jpe, .jif, .gif, .tif, .tiff, .png, or .sid file, the Image Properties dialog box opens.

4. After you add the background layer, you might have to use the Pan button to move the layer within the drawing area; Zoom Extents does not center a background image.

**To delete a background layer**

• Select the background layer you want to delete, then click the **Delete** button.

• Or, right-click the background layer, then select **Delete** from the shortcut menu.

**To edit the properties of a background layer**

You can edit a background layer in two ways: you can edit its properties or its position in a list of background layers displayed in the Background Layers manager.

1. Select the background layer you want to edit.
2. Click the **Edit** button. A Properties dialog box opens.
   – You can also right-click the background layer, then select **Edit** from the shortcut menu.

**To change the position of a background layer in the list of background layers**

The order of a background layer determines its Z level and what displays if you use more than one background layer. Background layers at the top of the list display on top of the other background layers in the drawing pane; so, background layers that are lower than the top one in the list might be hidden or partially hidden by layers above them in the list.

Select the background layer whose position you want to change in the list of Background Layers manager, then click the **Shift Up** or **Shift Down** buttons to move the selected background layer up or down in the list.

**To rename a background layer**

Select the background layer you want to rename, then click the **Rename** button.

Or, right-click the background layer that you want to rename, then select **Rename** from the shortcut menu.
**Turn background layers on or off**

Turn your background layers on or off by using the check box next to the background layer file or folder than contains it in the Background Layers manager.

**Image Properties**

This dialog box opens when you are adding or editing a background-layer image other than a .dxf or .shp.

<table>
<thead>
<tr>
<th>Image Properties</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Image Filter</strong>:</td>
<td>Point</td>
<td></td>
</tr>
<tr>
<td><strong>Transparency</strong>:</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td><strong>Resolution</strong>:</td>
<td>3750 x 6000</td>
<td></td>
</tr>
<tr>
<td><strong>Unit</strong>:</td>
<td>m</td>
<td></td>
</tr>
<tr>
<td><strong>Use Compression</strong>:</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>X (Image)</th>
<th>Y (Image)</th>
<th>X (Drawing)</th>
<th>Y (Drawing)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bottom Left</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Top Left</td>
<td>0</td>
<td>5999</td>
<td>0</td>
<td>5999</td>
</tr>
<tr>
<td>Top Right</td>
<td>3749</td>
<td>5999</td>
<td>3749</td>
<td>5999</td>
</tr>
<tr>
<td>Bottom Right</td>
<td>3749</td>
<td>0</td>
<td>3749</td>
<td>0</td>
</tr>
</tbody>
</table>

**Image Filter**

Displays background images that you resize. Set this to **Point**, **Bilinear**, or **Trilinear**. These are methods of displaying your image on-screen.

- **Use Point** when the size of the image in the display, for example, a 500 x 500 pixel image at 100% is the same 500 x 500 pixels on-screen.

- **Use Bilinear** or **Trilinear** when you display your image on-screen using more or fewer pixels than your image contains, for example a 500 x 500 pixel image stretched to 800 x 800 pixels on-screen. Trilinear gives you smoother transitions when you zoom in and out of the image.
**Transparency**
Set the transparency level of the background layer. You can add transparency to any image type you use as a background and it will ignore any transparency that exists in the image before you use it as a background.

**Resolution**
Select the clarity for images that are being used as background images.

**Unit**
Select the unit that should be used.

**Use Compression**
If you check this option you can compress the image in memory so that it takes up less RAM. When checked there may be a slight color distortion in the image.

**Note:** The way the image is compressed depends on your computer’s video card. Not all video cards support this feature. If you check this option but your computer’s video card does not support image compression, the request for compression will be ignored and the image will be loaded uncompressed.

**Image Position Table**
Position the background layer with respect to your drawing.

- **X/Y Image** displays the size of the image you are using for a background and sets its position with respect to the origin of your drawing. You cannot change this data.

- **X/Y Drawing** displays where the corners of the image your are using will be positioned relative to your drawing. By default, no scaling is used. However, you can scale the image you are using by setting different locations for the corners of the image you are importing. The locations you set are relative to the origin of your Bentley StormCAD V8i drawing.
Shapefile Properties

Use the Shapefile Properties dialog box to define a shapefile background layer. In order to access the Shapefile Properties dialog box, click **New File** in the Background Layers manager, then select a `.shp` file.

![Shapefile Properties Dialog Box](image)

Use the following controls to define the properties of the background layer:

- **Filename**: Lists the path and filename of the shapefile to use as a background layer.
- **Browse**: Opens a browse dialog box, to select the file to be used as a background layer.
- **Label**: Identifies the background layer.
- **Unit**: Select the unit of measurement associated with the spatial data from the menu.
- **Transparency**: Specify the transparency level of the background layer, where 0 has the least and 100 has the most transparency.
- **Line Color**: Sets the color of the layer elements. Click the Ellipsis (…) button to open a Color palette containing more color choices.
- **Line Width**: Sets the thickness of the outline of the layer elements.
- **Fill Color**: Select the fill color.
- **Fill Figure**: Check to fill.
DXF Properties

The DXF Properties dialog box is where you define a .dxf file as the background layer. In order to open the .dxf properties, click New File In the Background Layers manager, then select a .dxf file.

Use the following controls to define the properties of the background layer:
3.5 MicroStation Environment

| **Filename** | Lists the path and filename of the .dxf file to use as a background layer. |
| **Browse**   | Click to open a dialog box to select the file to be used as a background layer. |
| **Label**    | Identifies the background layer. |
| **Unit**     | Select the unit associated with the spatial data within the shapefile, for example, if the X and Y coordinates of the shapefile represent feet, select ft from the menu. |
| **Transparency** | Specify the transparency level of the background layer, where 0 has the least transparency and 100 has the most. |
| **Line Color** | Sets the color of the layer elements. Click the Ellipsis (...) button to open a Color palette containing more color choices. Only when Default Color is not selected. |
| **Default Color** | Use the default line color included in the .dxf file or select a custom color in the Line Color field by unchecking the box. |
| **Symbol**   | Choose the symbol that is displayed for each point element in the .dxf. |
| **Size**     | Sets the size of the symbol for each point element in the .dxf. |

**Note:** All of the following MicroStation Environment documentation also applies to the PowerCivil V8i for Americas environment.

In the MicroStation environment you can create and model your network directly within your primary drafting environment. This gives you access to all of MicroStation’s powerful drafting and presentation tools, while still enabling you to perform Bentley StormCAD V8i modeling tasks like editing, solving, and data management. This relationship between Bentley StormCAD V8i and MicroStation enables extremely detailed and accurate mapping of model features, and provides the full array of output and presentation features available in MicroStation. This facility provides the most flexibility and the highest degree of compatibility with other CAD-based applications and drawing data maintained at your organization.
Bentley StormCAD V8i features support for MicroStation integration. You run Bentley StormCAD V8i in both MicroStation and stand-alone environment.

The MicroStation functionality has been implemented in a way that is the same as the Bentley StormCAD V8i base product. Once you become familiar with the stand-alone environment, you will not have any difficulty using the product in the MicroStation environment.

In the MicroStation environment, you will have access to the full range of functionality available in the MicroStation design and drafting environment. The standard environment is extended and enhanced by using MicroStation’s MDL (MicroStation Development Language) client layer that lets you create, view, and edit the native Bentley StormCAD V8i network model while in MicroStation.

MDL is a complete development environment that lets applications take full advantage of the power of MicroStation and MicroStation-based vertical applications. MDL can be used to develop simple utilities, customized commands or sophisticated commercial applications for vertical markets.

Some of the advantages of working in the MicroStation environment include:

- Lay out network links and structures in fully-scaled environment in the same design and drafting environment that you use to develop your engineering plans.
- Have access to any other third party applications that you currently use, along with any custom MDL applications.
- Use native MicroStation insertion snaps to precisely position Bentley StormCAD V8i elements with respect to other entities in the MicroStation drawing.
- Use native MicroStation commands on Bentley StormCAD V8i model entities with automatic update and synchronization with the model database.
- Control destination levels for model elements and associated label text and annotation, giving you control over styles, line types, and visibility of model elements.

**Note:** Bentley MicroStation V8i is the only MicroStation environment supported by StormCAD V8i.

Additional features of the MicroStation version includes:

- [MicroStation Project Files on page 3-122](#)
- [Bentley StormCAD V8i Element Properties on page 3-123](#)
- [Working with Elements on page 3-124](#)
- [MicroStation Commands on page 3-126](#)
- [Import Bentley StormCAD V8i on page 3-127](#)
3.5.1 Getting Started in the MicroStation environment

A Bentley MicroStation StormCAD V8i project consists of:

- **Drawing File (.DGN)**—The MicroStation drawing file contains the elements that define the model, in addition to the planimetric base drawing information that serves as the model background.

- **Model File (.stc)**—The model file contains model data specific to StormCAD V8i, including project option settings, color-coding and annotation settings, etc. Note that the MicroStation .dgn that is associated with a particular model may not necessarily have the same filename as the model’s .stc file.

- **Database File (.MDB)**—The model database file that contains all of the input and output data for the model. Note that the MicroStation .dgn that is associated with a particular model may not have the same filename as the model’s .mdb file.

When you start Bentley StormCAD V8i for MicroStation, you will see the dialog below. You must identify a new or existing MicroStation dgn drawing file to be associated with the model before you can open a Bentley StormCAD V8i model.

Either browse to an existing dgn file or create a new file using the new button on the top toolbar. Once you have selected a file, you can pick the Open button.

Once a drawing is open, you can use the StormCAD V8i Project drop down menu to create a new StormCAD V8i project, attach an existing project, import a project or open a project from ProjectWise.

There are a number of options for creating a model in the MicroStation client:
• **Create a model from scratch**—You can create a model in MicroStation. You'll first need to create a new MicroStation .dgn (refer to your MicroStation documentation to learn how to create a new .dgn). Start StormCAD V8i for MicroStation. In the first dialog, pick the New button and assign a name and path to the DGN file. Once the dgn is open, use the New command in the StormCAD V8i Project menu (Project > New). This will create a new StormCAD V8i project file and attach it to the Bentley MicroStation .dgn file. Once the file is created you can start creating StormCAD V8i elements that exist in both the StormCAD V8i data-base and in the .dgn drawing. See Working with Elements and Working with Elements Using MicroStation Commands for more details.

• **Open a previously created StormCAD V8i project**—You can open a previously created StormCAD V8i model and attach it to a .dgn file. To do this, start StormCAD V8i for MicroStation. Open or create a new MicroStation .dgn file (refer to your MicroStation documentation to learn how to create a new .dgn). Use the Project menu on the StormCAD V8i toolbar and click on the Project > "Attach Existing…" command, then select an existing StormCAD V8i.stc file. The model will now be attached to the .dgn file and you can edit, delete, and modify the StormCAD V8i elements in the model. All MicroStation commands can be used on StormCAD V8i elements.

• **Import a model that was created in another modeling application**—There are three types of files that can be imported into StormCAD V8i:
  - **StormCAD Database**—The model will be processed and imported into the active MicroStation .dgn drawing. See [Importing Data from a StormCAD V8i Database](#) for more details.
  - **Submodel**—Using the Submodel Import feature, you can import another model, or any portion thereof, into your project. See [Importing Submodels](#) for more details.
  - **LandXML**—You can import a model from a LandXML format .xml file. See [Importing LandXML Files](#) for more details.

If you want to trace the model on top of a dgn or other background file, you would load the background into the dgn first by using either File/Reference or File/Raster Manager Then you start laying out elements over top of the background.
3.5.2 The MicroStation Environment Graphical Layout

In the MicroStation environment, StormCAD V8i provides a set of extended options and functionality beyond those available in stand-alone environment. This additional functionality provides enhanced control over general application settings and options and extends the command set, giving you control over the display of model elements within MicroStation.

It is important to be aware that there are two lists of menu items when running StormCAD V8i in MicroStation:

1. MicroStation menu (File Edit Element Settings ...) which contains MicroStation commands. The MicroStation menu contains commands which affect the drawing.
2. StormCAD V8i menu (Project Edit Analysis ...) which contains StormCAD V8i commands. The StormCAD V8i menu contains commands which affect the hydraulic analysis.

It is important to be aware of which menu you are using.

Key differences between MicroStation and stand-alone environment include:

- Full element symbol editing functionality is available through the use of custom cells. All elements and graphical decorations (flow arrows, control indicators, etc.) are contained within a StormCAD V8i .cel file. To do this open the .cel file that’s in the StormCAD install directory in MicroStation (at the first, Open dialog), and then using the File>models you can select each of the StormCAD symbols and change them using normal MicroStation commands. Then when you create a new dgn and start laying out the StormCAD elements, the new symbols will be used.
- The more powerful Selection tools are in the MicroStation select menu.
- Element symbols like junction are circles that are not filled. The user must pick the edge of the circle, not inside the circle to pick a junction.
- The MicroStation background color is found in Workspace>Preferences>View Options. It can also be changed in Settings>Color Tab.
- Zooming and panning are controlled by the MicroStation zooming and panning tools. There is no StormCAD V8i zoom or pan.
- Depending on how MicroStation was set up, a single right click will simply clear the last command, while holding down the right mouse button will bring up the context sensitive menu. There are commands in that menu (e.g. rotate) that are not available in StormCAD V8i stand alone.
You can control the appearance and destination of all model elements using the Element Levels command under the View menu. For example, you can assign a specific level for all outlets, as well as assign the label and annotation text style to be applied. Element attributes are either defined by the MicroStation Level Manager, using by-level in the attributes toolbox, or by the active attributes. You can change the element attributes using the change element attributes tool, located in the change attributes toolbox, located on the MicroStation Main menu.

StormCAD V8i toolbars are turned off by default when you start. They are found under View>Toolbars and they can be turned on. By default they will be floating toolbars but they can be docked wherever the user chooses.

**Note:** Any MicroStation tool that deletes the target element (such as Trim and IntelliTrim) will also remove the connection of that element to StormCAD V8i. After the StormCAD V8i connection is removed, the element is no longer a valid StormCAD link element and will not show properties on the property grid. The element does not have properties because it is not part of the StormCAD model. It’s as if the user just used MicroStation tools to layout a rectangle in a StormCAD dgn. It’s just a dgn drawing element but has nothing to do with the storm model.

### 3.5.3 MicroStation Project Files

When using Bentley StormCAD V8i in the MicroStation environment, there are three files that fundamentally define a Bentley StormCAD V8i model project:

- **Drawing File (.DGN)**—The MicroStation drawing file contains the elements that define the model, in addition to the planimetric base drawing information that serves as the model background.

- **Model File (.stc)**—The model file contains model data specific to StormCAD V8i, including project option settings, color-coding and annotation settings, etc. Note that the MicroStation .dgn that is associated with a particular model may not have the same filename as the model’s .stc file.

- **Database File (.MDB)**—The model database file that contains all of the input and output data for the model. Note that the MicroStation .dgn that is associated with a particular model may not have the same filename as the model’s .mdb file.

To send the model to another user, all three files are required.

It is important to understand that archiving the drawing file is not sufficient to reproduce the model. You must also preserve the associated .stc and .MDB files.
Saving Your Project in MicroStation

The StormCAD V8i project data is synchronized with the current MicroStation .dgn. StormCAD V8i project saves are triggered when the .dgn is saved. This is done with the MicroStation File>Save command, which saves the .dgn, .mdb and .stc files. If you want to have more control over when the StormCAD V8i project is saved, turn off MicroStation's AutoSave feature; then you will be prompted for the .dgn.

There are two File>Save As commands in StormCAD V8i MicroStation. SaveAs in MSTN is for the dgn, and allows the user to, for example, change the dgn filename that they're working with .stc model filenames in this case stay the same. The Project's SaveAs allows the user to change the filename of the .stc and .mdb files, but it doesn't change the dgn's filename. Keep in mind that the dgn and model filenames don't have any direct correlation. They can be named the same, but they don't have to be.

3.5.4 Bentley StormCAD V8i Element Properties

Bentley StormCAD V8i element properties includes:

- Element Properties
- Element Levels Dialog
- Text Styles

Element Properties

When working in the MicroStation environment, this feature will display a dialog box containing fields for the currently selected element's associated properties. To modify an attribute, click each associated grid cell. To open the property grid, pick View>Properties from the StormCAD V8i menu.

You can also review or modify MicroStation drawing information about an element(s), such as its type, attributes, and geometry, by using the Element Information dialog. To access the Element Information dialog, click the Element Information button or click the Element menu and select the Information command. This is where the user can change the appearance for individual elements. However, in general, if StormCAD V8i color coding conflicts with MicroStation element symbology, the StormCAD V8i color will show.

To control display of elements in the selected levels, use the Level Display dialog box. To access the Level Display dialog, click the Settings menu and select the Level > Display command.

To move StormCAD V8i elements to levels other than the default (Active) level, select the elements and use the Change Element Attribute command.
If you want to freeze elements in levels, select Global Freeze from the View Display menu in the Level Display dialog.

You can create new Levels in the Level Manager. To access the Level Manager, click the Settings menu and select the Level > Manager command.

To control the display of levels, use level filters. Within MicroStation, you can also create, edit, and save layer filters to DWG files in the Level Manager. To access the Level Manager, click the Settings menu and select the Level > Manager command. Layer filters are loaded when a DWG file is opened, and changes are written back when the file is saved. To create and edit Level Filters,

**Element Levels Dialog**

This dialog allows you to assign newly created elements and their associated annotations to specific MicroStation levels.

To assign a level, use the pulldown menu next to an element type (under the Element Level column heading) to choose the desired level for that element. You can choose a separate level for each element and for each element’s associated annotation.

You cannot create new levels from this dialog; to create new levels use the MicroStation Level Manager. To access the Level Manager, click the Settings menu and select the Level > Manager command.

**Text Styles**

You can view, edit, and create Text Style settings in the MicroStation environment by clicking the MicroStation Element menu and selecting the Text Styles command to open the Text Styles dialog.

**3.5.5 Working with Elements**

Working with elements includes:

- [Edit Elements](#)
- [Deleting Elements](#)
- [Modifying Elements](#)
Edit Elements

Elements can be edited in one of two ways in the MicroStation environment:

**Properties Editor Dialog:** To access the Properties Editor dialog, click the StormCAD V8i View menu and select the Properties command. For more information about the Properties Editor dialog, see [Property Editor](#).

**FlexTables:** To access the FlexTables dialog, click the StormCAD V8i View menu and select the FlexTables command. For more information about the FlexTables dialog, see [Viewing and Editing Data in FlexTables](#).

Deleting Elements

In the MicroStation environment, you can delete elements by clicking on them using the Delete Element tool, or by highlighting the element to be deleted and clicking your keyboard’s Delete key.

*Note:* Any MicroStation tool that deletes the target element (such as Trim and IntelliTrim) will also remove the connection of that element to StormCAD V8i. After the StormCAD V8i connection is removed, the element is no longer a valid stc link and will not show properties on the property grid.

Modifying Elements

In the MicroStation environment, these commands are selected from the shift-right-click shortcut menu (hold down the Ctrl key while right-clicking). They are used for scaling and rotating model entities.

Context Menu

Certain commands can be activated by using the right-click context menu. To access the context menu, right-click and hold down the mouse button until the menu appears.

3.5.6 Working with Elements Using MicroStation Commands

Working with elements using MicroStation commands includes:

- [Bentley StormCAD V8i Custom MicroStation Entities on page 3-126](#)
- [MicroStation Commands on page 3-126](#)
- [Moving Elements on page 3-126](#)
- [Moving Element Labels on page 3-127](#)
Bentley StormCAD V8i Custom MicroStation Entities

The primary MicroStation-based Bentley StormCAD V8i element entities are all implemented using native MicroStation elements (the drawing symbols are standard MSTN objects). These elements have feature linkages to define them as StormCAD V8i objects.

This means that you can perform standard MicroStation commands (see MicroStation Commands on page 3-126) as you normally would, and the model database will be updated automatically to reflect these changes.

It also means that the model will enforce the integrity of the network topological state, which means that nodes and pipes will remain connected even if individual elements are moved. Therefore, if you delete a nodal element such as a junction, its connecting pipes will also be deleted since their connecting nodes topologically define model pipes.

Using MDL technology ensures the database will be adjusted and maintained during Undo and Redo transactions.

See “The MicroStation Environment Graphical Layout” on page 121.

MicroStation Commands

When running in the MicroStation environment, StormCAD V8i makes use of all the advantages that MicroStation has, such as plotting capabilities and snap features. Additionally, MicroStation commands can be used as you would with any design project. For example, our products’ elements and annotation can be manipulated using common MicroStation commands. To get at the MicroStation command line (called the "Key-In Browser, the user can pick Help>Key-In Browser or hit the Enter key.

Moving Elements

When using the MicroStation environment, the MicroStation commands Move, Scale, Rotate, Mirror, and Array (after right clicking on the label) can be used to move elements.

To move a node, execute the MicroStation command by either typing it at the command prompt or selecting it. Follow the MicroStation prompts, and the node and its associated label will move together. The connecting pipes will shrink or stretch depending on the new location of the node.
Moving Element Labels

When using the MicroStation environment, the MicroStation commands Move, Scale, Rotate, Mirror, and Array can be used to move element text labels.

To move an element text label separately from the element, click the element label you wish to move. The grips will appear for the label. Execute the MicroStation command either by typing it at the command prompt, by selecting it from the tool palette, or by selecting it from the right-click menu. Follow the MicroStation prompt, and the label will be moved without the element.

Snap Menu

When using the MicroStation environment, you can enable the Snaps button bar by clicking the Settings menu and selecting the Snaps > Button Bar command. See the MicroStation documentation for more information about using snaps.

Background Files

Adding MicroStation Background images different than in stand alone. You need to go to File>References>Tools>Attach. Background files to be attached with this command include .dgn, .dwg and .dxr files. Raster files should be attached using File>Raster Manager. GIS files (e.g. shapefiles) may need to be converted to the appropriate CAD or raster formats using GeoGraphics to be used as background. See MicroStation for details about the steps involved in creating these backgrounds.

Import Bentley StormCAD V8i

When running StormCAD V8i in the MicroStation environment, this command (Project>Import>StormCAD V8i database) imports a selected StormCAD V8i data (.stc) file for use in the current drawing (.dgn). You will be prompted for the StormCAD V8i filename to save. The new project file will now correspond to the drawing name, such as, CurrenDrawingName.stc. Whenever you save changes to the network model through StormCAD V8i the associated .stc data file is updated and can be loaded into StormCAD V8ior higher.

**Warning!** A StormCAD V8i/Project can only be imported to a new, empty MicroStation design model (.dgn file).

Annotation Display

Some fonts do not correctly display the full range of characters used by StormCAD V8i’s annotation feature because of a limited character set. If you are having problems with certain characters displaying improperly or not at all, try using another font.
Multiple models

You can have two or more StormCAD V8i models open in MicroStation. However, you need to open them in MicroStation, not in stc. In MicroStation choose File > Open and select the .dgn file.

3.6 Working in AutoCAD

The AutoCAD environment lets you create and model your network directly within your primary drafting environment. This gives you access to all of AutoCAD's drafting and presentation tools, while still enabling you to perform Bentley StormCAD V8i modeling tasks like editing, solving, and data management. This relationship between Bentley StormCAD V8i and AutoCAD enables extremely detailed and accurate mapping of model features, and provides the full array of output and presentation features available in AutoCAD. This facility provides the most flexibility and the highest degree of compatibility with other CAD-based applications and drawing data maintained at your organization.

Bentley StormCAD V8i features support for AutoCAD integration. You can determine if you have purchased AutoCAD functionality for your license of Bentley StormCAD V8i by using the Help > About menu option. Click the Registration button to view the feature options that have been purchased with your application license. If AutoCAD support is enabled, then you will be able to run your Bentley StormCAD V8i application in both AutoCAD and stand-alone environment.

The AutoCAD functionality has been implemented in a way that is the same as the StormCAD V8i base product. Once you become familiar with the stand-alone environment, you will not have any difficulty using the product in the AutoCAD environment.

Some of the advantages of working in the AutoCAD environment include:

- Layout network links and structures in fully-scaled environment in the same design and drafting environment that you use to develop your engineering plans. You will have access to any other third party applications that you currently use, along with any custom LISP, ARX, or VBA applications that you have developed.
- Use native AutoCAD insertion snaps to precisely position Bentley StormCAD V8i elements with respect to other entities in the AutoCAD drawing.
- Use native AutoCAD commands such as ERASE, MOVE, and ROTATE on Bentley StormCAD V8i model entities with automatic update and synchronization with the model database.
- Control destination layers for model elements and associated label text and annotation, giving you control over styles, line types, and visibility of model elements.
Caution: If you previously installed Bentley ProjectWise and turned on AutoCAD integration, you must add the following key to your system registry using the Windows Registry Editor. Before you edit the registry, make a backup copy.

```
HKEY_LOCAL_MACHINE\SOFTWARE\Bentley\ProjectWise
iDesktop Integration\XX.XX\Configuration\AutoCAD"
```

String value name: DoNotChangeCommands

Value: 'On'

To access the Registry Editor, click Start > Run, then type regedit. Using the Registry Editor incorrectly can cause serious, system-wide problems that may require you to re-install Windows to correct them. Always make a backup copy of the system registry before modifying it.

3.6.1 The AutoCAD Workspace

In the AutoCAD environment, you will have access to the full range of functionality available in the AutoCAD design and drafting environment. The standard environment is extended and enhanced by an AutoCAD ObjectARX Bentley StormCAD V8i client layer that lets you create, view, and edit the native Bentley StormCAD V8i network model while in AutoCAD.

AutoCAD Integration with StormCAD V8i

When you install StormCAD V8i after you install AutoCAD, integration between the two is automatically configured.

If you install AutoCAD after you install StormCAD V8i, you must manually integrate the two by selecting Start > All Programs > Bentley >StormCAD V8i > Integrate StormCAD V8i with AutoCAD-ArcGIS. The integration utility runs automatically. You can then run StormCAD V8i in the AutoCAD environment.

The Integrate StormCAD V8i with AutoCAD-ArcGIS command can also be used to fix problems with the AutoCAD configuration file. For example, if you have CivilStorm 2005 installed on the same system as Bentley StormCAD V8i and you uninstall or reinstall CivilStorm 2005, the AutoCAD configuration file becomes unusable. To fix this problem, you can delete the configuration file then run the Integrate StormCAD V8i with AutoCAD-ArcGIS command.

Getting Started within AutoCAD

There are a number of options for creating a model in the AutoCAD client:
• **Create a model from scratch**—You can create a model in AutoCAD. Upon opening AutoCAD a Drawing1.dwg file is created and opened. Likewise an untitled new StormCAD V8i project is also created and opened if StormCAD V8i has been loaded. StormCAD V8i has been loaded if the StormCAD V8i toolbars and docking windows are visible. StormCAD V8i can be loaded in two ways: automatically by using the “StormCAD V8i for AutoCAD” shortcut, or by starting AutoCAD and then using the command: StormCAD V8iRun. Once loaded, you can immediately begin laying out your network and creating your model using the Bentley StormCAD V8i toolbars and the StormCAD V8i file menu (See **Menus**). Upon saving and titling your AutoCAD file for the first time, your StormCAD V8i project files will also acquire the same name and file location.

• **Open a previously created Bentley StormCAD V8i project**—You can open a previously created Bentley StormCAD V8i model. If the model was created in the Stand Alone version, you must import your StormCAD V8i project while a .dwg file is open. From the StormCAD V8i menu select Project -> Import -> StormCAD V8i Database. Alternatively you can use the command: _stcImportProject. You will have the choice to import your StormCAD V8i database file (.mdb) or your StormCAD V8i project file (.stc).

• **Import a model that was created in another modeling application**—You can import a model that was created in EPANET or Bentley Water. See [Importing and Exporting Data](#) for further details.

**Menus**

In the AutoCAD environment, in addition to AutoCAD’s menus, the following Bentley StormCAD V8i menus are available:

- Project
- Edit
- Analysis
- Components
- View
- Tools
- Report
- Help

The Bentley StormCAD V8i menu commands work the same way in AutoCAD and the Stand-Alone Editor. For complete descriptions of Bentley StormCAD V8i menu commands, see [Menus](#).

Many commands are available from the right-click context menu. To access the menu, first highlight an element in the drawing pane, then right-click it to open the menu.
Toolbars

In the AutoCAD environment, in addition to AutoCAD’s toolbars, the following Bentley StormCAD V8i toolbars are available:

- Layout
- View
- Compute
- Scenarios
- Analysis
- Links

The Bentley StormCAD V8i toolbars work the same way in AutoCAD and the Stand-Alone Editor. For complete descriptions of Bentley StormCAD V8i toolbars, see Toolbars.

Drawing Setup

When working in the AutoCAD environment, you may work with our products in many different AutoCAD scales and settings. However, StormCAD V8i elements can only be created and edited in model space.

Symbol Visibility

In the AutoCAD environment, you can control display of element labels using the check box in the Drawing Options dialog box.

Note: In AutoCAD, it is possible to delete element label text using the ERASE command. You should not use ERASE to control visibility of labels. If you desire to control the visibility of a selected group of element labels, you should move them to another layer that can be frozen or turned off.

AutoCAD Project Files

When using Bentley StormCAD V8i in the AutoCAD environment, there are three files that fundamentally define a Bentley StormCAD V8i model project:

- **Drawing File (.dwg)**—The AutoCAD drawing file contains the custom entities that define the model, in addition to the planimetric base drawing information that serves as the model background.
• **Model File** (.stc)—The native Bentley StormCAD V8i model database file that contains all the element properties, along with other important model data. Bentley StormCAD V8i .etc files can be loaded and run using the Stand-Alone Editor. These files may be copied and sent to other Bentley StormCAD V8i users who are interested in running your project. This is the most important file for the Bentley StormCAD V8i model.

• **Database File** (.stc.mdb)—The model database file that contains all of the input and output data for the model.

The three files have the same base name. It is important to understand that archiving the drawing file is not sufficient to reproduce the model. You must also preserve the associated .etc and stc.mdb file.

Since the .etc file can be run and modified separately from the .dwg file using the Stand-Alone Editor, it is quite possible for the two files to get out of sync. Should you ever modify the model in the Stand-Alone Editor and then later load the AutoCAD .dwg file, the Bentley StormCAD V8i program compares file dates, and automatically use the built-in AutoCAD synchronization routine.

Click one of the following links to learn more about AutoCAD project files and Bentley StormCAD V8i:

- [Drawing Synchronization on page 3-132](#)
- [Saving the Drawing as Drawing*.dwg on page 3-133](#)

**Drawing Synchronization**

Whenever you open a Bentley StormCAD V8i-based drawing file in AutoCAD, the Bentley StormCAD V8i model server will start. The first thing that the application will do is load the associated Bentley StormCAD V8i model (.stc) file. If the time stamps of the drawing and model file are different, Bentley StormCAD V8i will automatically perform a synchronization. This protects against corruption that might otherwise occur from separately editing the Bentley StormCAD V8i model file in stand-alone environment, or editing proxy elements at an AutoCAD station where the Bentley StormCAD V8i application is not loaded.
The synchronization check will occur in two stages:

- First, Bentley StormCAD V$\text{"V8i"}$ will compare the drawing model elements with those in the server model. Any differences will be listed. Bentley StormCAD V$\text{"V8i"}$ enforces network topological consistency between the server and the drawing state. If model elements have been deleted or added in the .stc file during a StormCAD V$\text{"V8i"}$ session, or if proxy elements have been deleted, Bentley StormCAD V$\text{"V8i"}$ will force the drawing to be consistent with the native database by restoring or removing any missing or excess drawing custom entities.

- After network topology has been synchronized, Bentley StormCAD V$\text{"V8i"}$ will compare other model and drawing states such as location, labels, and flow directions.

You can run the Synchronization check at any time using the following command:

```
stcsYNCHRONIZE
```

```
stcsYNCSERVER
```

Or by selecting Tools > Database Utilities > Synchronize Drawing.

**Saving the Drawing as Drawing*.dwg**

AutoCAD uses Drawing*.dwg as its default drawing name. Saving your drawing as the default AutoCAD drawing name (for instance Drawing1.dwg) should be avoided, as it makes overwriting model data very likely. When you first start AutoCAD, the new empty drawing is titled Drawing*.dwg, regardless of whether one exists in the default directory. Since our modeling products create model databases associated with the AutoCAD drawing, the use of Drawing*.dwg as the saved name puts you at risk of causing synchronization problems between the AutoCAD drawing and the modeling files.

**Note:** If this situation inadvertently occurs (save on quit for example), restart AutoCAD, use the Open command to open the Drawing*.dwg file from its saved location, and use the Save As command to save the drawing and model data to a different name.

### 3.6.2 Working with Elements Using AutoCAD Commands

This section describes how to work with elements using AutoCAD commands, including:

- **StormCAD V$\text{"V8i"}$ Custom AutoCAD Entities**
- **Explode Elements**
- **Moving Elements**
- **Moving Element Labels**
- **Snap Menu**
- **Editing Contours**
- **Polygon Element Visibility**
- **Undo/Redo**
- **Layout Options Dialog**

**StormCAD V8i Custom AutoCAD Entities**

The primary AutoCAD-based StormCAD V8i element entities—pipes, junctions, pumps, etc.—are all implemented using ObjectARX custom objects. Thus, they are vested with a specialized model awareness that ensures that any editing actions you perform will result in an appropriate update of the model database.

This means that you can perform standard AutoCAD commands (see [Working with Elements Using AutoCAD Commands](#)) as you normally would, and the model database will be updated automatically to reflect these changes.

It also means that the model will enforce the integrity of the network topological state. Therefore, if you delete a nodal element such as a junction, its connecting pipes will also be deleted since their connecting nodes topologically define model pipes.

Using ObjectARX technology ensures the database will be adjusted and maintained during Undo and Redo transactions.

When running in the AutoCAD environment, Bentley Systems’ products make use of all the advantages that AutoCAD has, such as plotting capabilities and snap features. Additionally, AutoCAD commands can be used as you would with any design project. For example, our products’ elements and annotation can be manipulated using common AutoCAD commands.

**Explode Elements**

In the AutoCAD environment, running the AutoCAD Explode command will transform all custom entities into equivalent AutoCAD native entities. When a custom entity is exploded, all associated database information is lost. Be certain to save the exploded drawing under a separate filename.

Use Explode to render a drawing for finalizing exhibits and publishing maps of the model network. You can also deliver exploded drawings to clients or other individuals who do not own a Bentley Systems Product license, since a fully exploded drawing will not be comprised of any ObjectARX proxy objects.
Moving Elements

When using the AutoCAD environment, the AutoCAD commands Move, Scale, Rotate, Mirror, and Array can be used to move elements.

To move a node, execute the AutoCAD command by either typing it at the command prompt or selecting it. Follow the AutoCAD prompts, and the node and its associated label will move together. The connecting pipes will shrink or stretch depending on the new location of the node.

Moving Element Labels

When using the AutoCAD environment, the AutoCAD commands Move, Scale, Rotate, Mirror, and Array can be used to move element text labels.

To move an element text label separately from the element, click the element label you wish to move. The grips will appear for the label. Execute the AutoCAD command either by typing it at the command prompt, by selecting it from the tool palette, or by selecting it from the right-click menu. Follow the AutoCAD prompt, and the label will be moved without the element.

Snap Menu

When using the AutoCAD environment, the Snap menu is a standard AutoCAD menu that provides options for picking an exact location of an object. See the Autodesk AutoCAD documentation for more information.

Editing Contours

StormCAD V8i contours are only views unless you export them to native format; only native-format contours can be edited.

Polygon Element Visibility

By default, polygon elements are sent to the back of the draw order when they are drawn. If the draw order is modified, polygon elements can interfere with the visibility of other elements. This can be remedied using the AutoCAD Draw Order toolbar.

To access the AutoCAD Draw Order toolbar, right-click on the AutoCAD toolbar and click the Draw Order entry in the list of available toolbars.

By default, polygon elements are filled. You can make them unfilled (just borders visible) using the AutoCAD FILL command. After turning fill environment OFF, you must REGEN to redraw the polygons.
Undo/Redo

In the AutoCAD environment, you have two types of undo/redo available to you. From the Edit menu, you have access to Bentley StormCAD V8i undo and redo. Alternatively, you can perform the native AutoCAD undo and redo by typing at the AutoCAD command line. The implementations of the two different operation types are quite distinct.

The menu-based undo and redo commands operate exclusively on Bentley StormCAD V8i elements by invoking the commands directly on the model server. The main advantage of using the specialized command is that you will have unlimited undo and redo levels. This is an important difference, since in layout or editing it is quite useful to be able to safely undo and redo an arbitrary number of transactions.

Whenever you use a native AutoCAD undo, the server model will be notified when any Bentley StormCAD V8i entities are affected by the operation. Bentley StormCAD V8i will then synchronize the model to the drawing state. Wherever possible, the model will seek to map the undo/redo onto the model server’s managed command history. If the drawing’s state is not consistent with any pending undo or redo transactions held by the server, Bentley StormCAD V8i will delete the command history. In this case, the model will synchronize the drawing and server models.

**Note:** If you use the native AutoCAD undo, you are limited to a single redo level. The Bentley StormCAD V8i undo/redo is faster than the native AutoCAD undo/redo. If you are rolling back Bentley StormCAD V8i model edits, it is recommended that you use the menu-based Bentley StormCAD V8i undo/redo.

If you undo using the AutoCAD undo/redo and you restore Bentley StormCAD V8i elements that have been previously deleted, morphed, or split, some model state attributes such as diameters or elevations may be lost, even though the locational
Introducing the Workspace

... and topological state is fully consistent. This will only happen in situations where the Bentley StormCAD V8i command history has been deleted. In such cases, you will be warned to check your data carefully.

Layout Options Dialog

The Layout Options are associated with the Entity command layout support. You can choose Entity, pick an existing polyline, and if there are no existing nodes at the end of the pline, you will be prompted for the type of node to put at each endpoint.

![Layout Options Dialog](image)

The Allowable Entity Types toggles allow you to disallow certain line types from being available for use with the Entity command.
Working in AutoCAD
Using ModelBuilder to Transfer Existing Data

ModelBuilder lets you use your existing GIS asset to construct a new StormCAD V8i model or update an existing StormCAD V8i model. ModelBuilder supports a wide variety of data formats, from simple databases (such as Access and DBase), spreadsheets (such as Excel or Lotus), GIS data (such as shape files), to high end data stores (such as Oracle, and SQL Server), and more.

Using ModelBuilder, you map the tables and fields contained within your data source to element types and attributes in your StormCAD V8i model. The result is that a StormCAD V8i model is created. ModelBuilder can be used in any of the Bentley StormCAD V8i platforms - Stand-Alone, MicroStation mode, or AutoCAD mode.

**Note:** ModelBuilder lets you bring a wide range of data into your model. However, some data is better suited to the use of the more specialized StormCAD V8i modules. For instance, LoadBuilder offers many powerful options for incorporating loading data into your model.

ModelBuilder is the first tool you will use when constructing a model from GIS data. The steps that you take at the outset will impact how the rest of the process goes. Take the time now to ensure that this process goes as smoothly and efficiently as possible:

- [Preparing to Use ModelBuilder](#)
- [Reviewing Your Results](#)

### 4.1 Preparing to Use ModelBuilder

- **Determine the purpose of your model**—Once you establish the purpose of your model, you can start to make decisions about how detailed the model should be.
Preparing to Use ModelBuilder

- **Get familiar with your data**—ModelBuilder supports several data source types, including tabular and geometric. Tabular data sources include spreadsheets, databases, and other data sources without geometric information. Some supported tabular data source types include Microsoft Excel, and Microsoft Access files. Geometric data sources, while also internally organized by tables, include geometric characteristics such as shape type, size, and location. Some supported geometric data source types include the major CAD and GIS file types.

If you obtained your model data from an outside source, you should take the time to get acquainted with it in its native platform. For example, review spatial and attribute data directly in your GIS environment. Do the nodes have coordinate information, and do the pipes have start and stop nodes specified? If not, the best method of specifying network connectivity must be determined.

Contact those involved in the development of the GIS to learn more about the GIS tables and associated attributes. Find out the purpose of any fields that may be of interest, ensure that data is of an acceptable accuracy, and determine units associated with fields containing numeric data.

Ideally, there will be one source data table for each StormCAD V8i element type. This isn’t always the case, and there are two other possible scenarios:

- **Many tables for one element type**—In this case, there may be several tables in the datasource corresponding to a single GEMS modeling element, component, or collection. In this case each data source table must be individually mapped to the StormCAD V8i table type, or the tables must be combined into a single table from within its native platform before running ModelBuilder.

- **One table containing many element types**—In this case, there may be entries that correspond to several StormCAD V8i table types in one datasource table. You should separate these into individual tables before running ModelBuilder. The one case where a single table can work is when the features in the table are ArcGIS subtypes. ModelBuilder handles these subtypes by treating them as separate tables when setting up mappings. See [Subtypes](#) for more information.

- **Preparing your data**—When using ModelBuilder to get data from your data source into your model, you will be associating rows in your data source to elements in StormCAD V8i. Your data source needs to contain a Key/Label field that can be used to uniquely identify every element in your model. The data source tables should have identifying column labels, or ModelBuilder will interpret the first row of data in the table as the column labels. Be sure data is in a format suited for use in ModelBuilder. Where applicable, use powerful GIS and Database tools to perform Database Joins, Spatial Joins, and Update Joins to get data into the appropriate table, and in the desired format.
**Using ModelBuilder to Transfer Existing Data**

**Note:** When working with ID fields, the expected model input is the StormCAD V8i/ID. After creating these items in your StormCAD V8i model, you can obtain the assigned ID values directly from your StormCAD V8i modeling file. Before synchronizing your model, get these StormCAD V8i IDs into your data source table (e.g., by performing a database join).

- **Preparing your CAD Data**—In previous versions of StormCAD V8i, the Poly-line-to-Pipe feature was used to import CAD data into a StormCAD V8i model. In v8, CAD data is imported using ModelBuilder. When using ModelBuilder to import data from your CAD file into your model, you will be associating cells in your CAD drawing with elements in StormCAD V8i.

  Different CAD cells will be recognized as different element types and presented as tables existing in your CAD data source. It is recommended that you natively export your AutoCAD .dwg or MicroStation .dgn files first as a .dxf file, then select this .dxf as the data source in ModelBuilder. Your data source will most likely not contain a Key/Label field that can be used to uniquely identify every element in your model, so ModelBuilder will automatically generate one for you using the default "<label>". This "<label>" field is a combination of an element's cell type label, its shape type, and a numeric ID that represents the order in which it was created.

- **Build first, Synchronize later**—ModelBuilder allows you to construct a new model or synchronize to an existing model. This gives you the ability to develop your model in multiple passes. On the first pass, use a simple connection to build your model. Then, on a subsequent pass, use a connection to load additional data into your model, such as supporting pattern or collection data.

**Note:** Upon completion of your ModelBuilder run, it is suggested you use the Network Navigator to identify any connectivity or topological problems in your new model. For instance, Pipe Split Candidates can be identified and then automatically modified with the Batch Split Pipe Tool (see **Batch Pipe SplitDialog Box**). See Using the Network Navigator for more information.

- **Going Beyond ModelBuilder**—Keep in mind that there are additional ways to get data into your model. ModelBuilder can import loads if you have already assigned a load to each node. If, however, this information is not available from the GIS data, or if your loading data is in a format unrecognized by ModelBuilder (meter data, etc.), use LoadBuilder; this module is a specialized tool for getting this data into your model. In addition, with its open database format, StormCAD V8i gives you unprecedented access to your modeling data.
One area of difficulty in building a model from external data sources is the fact that unless the source was created solely to support modeling, it most likely contains much more detailed information than is needed for modeling. This is especially true with regard to the number of piping elements. It is not uncommon for the data sources to include every service line and hydrant lateral. Such information is not needed for most modeling applications and should be removed to improve model run time, reduce file size, and save costs.

4.2 ModelBuilder Connections Manager

ModelBuilder can be used in any of the Bentley StormCAD V8i platforms - Stand-Alone, MicroStation mode, or AutoCAD mode.

To access ModelBuilder: Click the Tools menu and select the ModelBuilder command, or click the ModelBuilder button.

The ModelBuilder Connections manager allows you to create, edit, and manage ModelBuilder connections to be used in the model-building/model-synchronizing process. Each item in this manager represents a "connection" which contains the set of directions for moving data between a source to a target. ModelBuilder connections are not stored in a particular project, but are stored in an external xml file, with the following path:

Windows XP: C:\Documents and Settings\<username>\Application Data\Bentley\<productname>\<productversion>

Windows Vista: C:\Users\<username>\AppData\Roaming\Bentley\<productname>\<productversion>\ModelBuilder.xml.
At the center of this window is the **Connections List** which displays the list of connections that you have defined.

There is a **toolbar** located along the top of the Connections list.
The set of buttons on the left of the toolbar allow you to manage your connections:

- **New** Create a new connection using the ModelBuilder Wizard.
- **Edit** Edit the selected connection using the ModelBuilder Wizard.
- **Rename** Rename the selected connection.
- **Duplicate** Create a copy of the selected connection.
Delete  Permanently Remove the selected connection.

Build Model  Starts the ModelBuilder build process using the selected connection. This is also referred to as "synching in" from an external data source to a model. Excluding some spatial option overrides, a build operation will update your model with new elements, components, and collections that already exist in the model. Only table types and fields that are mapped will be updated. Depending upon the configuration of synchronization options in the selected connection, if an element in your data source does not already exist in your model, it may be created. If the element exists, only the fields mapped for that table type may be updated. ModelBuilder will not override element properties not specifically associated with the defined field mappings. A Build Model operation will update existing or newly created element values for the current scenario/alternative, or you can optionally create new child scenario/alternatives to capture any data difference.

Sync Out  Starts the ModelBuilder synchronize process using the selected connection. Unless specifically overridden, a Sync Out operation will only work for existing and new elements. On a Sync Out every element in your target data source that also exists in your model will be refreshed with the current model values. If your model contains elements that aren't contained in your data source, those data rows can optionally be added to your target data file. Only those properties specified with field mappings will be synchronized out to the data source. A Sync Out operation will refresh element properties in the data source with the current model values for the current scenario/alternative.

Help  Displays online help.
After initiating a Build or Sync command, ModelBuilder will perform the selected operation. During the process, a progress-bar will be displayed indicating the step that ModelBuilder is currently working on.

When ModelBuilder completes, you will be presented with a summary window that outlines important information about the build process. We recommend that you save this summary so that you can refer to it later.

**Note:** Because the connections are stored in a separate xml file rather than with the project file, ModelBuilder connections are preserved even after Bentley StormCAD V8i is closed.

## 4.3 ModelBuilder Wizard

The ModelBuilder Wizard assists in the creation of ModelBuilder connections. The Wizard will guide you through the process of selecting your data source and mapping that data to the desired input of your model.

**Tip:** The ModelBuilder Wizard can be resized, making it easier to preview tables in your data source. In addition, Step 1 and Step 3 of the wizard offer a vertical split bar, letting you adjust the size of the list located on the left side of these pages.

There are 6 steps involved:

- **Step 1—Specify Data Source**
- **Step 2—Specify Spatial Options**
- **Step 3—Specify Element Create/Remove/Update Options**
- **Step 4—Additional Options**
- **Step 5—Specify Field mappings for each Table/Feature Class**
- **Step 6—Build operation Confirmation**
4.3.1 **Step 1—Specify Data Source**

In this step, the data source type and location are specified. After selecting your data source, the desired database tables can be chosen and previewed.

The following fields are available:

- **Data Source** type (drop-down list)—This field allows you to specify the type of data you would like to work with.

  **Note:** If your specific data source type is not listed in the Data Source type field, try using the OLE DB data source type. OLE DB can be used to access many database systems (including ORACLE, and SQL Server, to name a few).

- **Data Source** (text field)—This read-only field displays the path to your data source.

- **Browse** (button)—This button opens a browse dialog box that allows you to interactively select your data source.
**Note:** Some Data Source types expect you to choose more than one item in the Browse dialog box. For more information, see Multi-select Data Source Types.

- **Table/Feature Class** (list)—This pane is located along the left side of the form and lists the tables/feature classes that are contained within the data source. Use the check boxes (along the left side of the list) to specify the tables you would like to include.

**Tip:** The list can be resized using the split bar (located on the right side of the list).

  **Right-click to Select All or Clear the current selection in the list.**

- **Duplicate Table** (button) —The duplicate table button is located along the top of the Table/Feature Class list. This button allows you to make copies of a table, which can each be mapped to a different element type in your model. Use this in conjunction with the WHERE clause.

- **Remove Table** (button) —The remove table button can be used to remove a table from the list.

- **WHERE Clause** (field)—Allows you to create a SQL query to filter the tables. When the box is checked, only tables that meet the criteria specified by the WHERE clause will be displayed. Click the button to validate the query and to refresh the preview table.

- **Preview Pane**—A tabular preview of the highlighted table is displayed in this pane when the Show Preview check box is enabled.
Using ModelBuilder to Transfer Existing Data

Note: If both nodes and pipes are imported in the same ModelBuilder connection, nodes will be imported first regardless of the order they are listed here.

4.3.2 Step 2—Specify Spatial Options

In this step you will specify the spatial options to be used during the ModelBuilder process. The spatial options will determine the placement and connectivity of the model elements. The fields available in this step will vary depending on the data source type.

- **Specify the Coordinate Unit of your data source** (drop-down list)—This field allows you to specify the coordinate unit of the spatial data in your data source. The default unit is the unit used for coordinates.
• **Create nodes if none found at pipe endpoint** (check box)—When this box is checked, ModelBuilder will create a manhole at any pipe endpoint that: a) doesn’t have a connected node, and b) is not within the specified tolerance of an existing node. This field is only active when the Establish connectivity using spatial data box is checked. (This option is not available if the connection is bringing in only point type geometric data.)

ModelBuilder will not create pipes unless a valid start/stop node exists. Choose this option if you know that there are nodes missing from your source data. If you expect your data to be complete, then leave this option off and if this situation is detected ModelBuilder will report errors for your review. For more information see [Specifying Network Connectivity in ModelBuilder](#).

• **Establish connectivity using spatial data** (check box)—When this box is checked, ModelBuilder will connect pipes to nodes that fall within a specified tolerance of a pipe endpoint. (This option is available if the connection is bringing in only polyline type geometric data.) Use this option, when the data source does not explicitly name the nodes at the end of each pipe. For more information, see [Specifying Network Connectivity in ModelBuilder](#).

• **Tolerance** (numeric field)—This field dictates how close a node must be to a pipe endpoint in order for connectivity to be established. The Tolerance field is only available when the Establish connectivity using spatial data box is checked. (This option is available if the connection is bringing in only polyline type geometric data.) Tolerances should be set as low as possible so that unintended connections are not made. If you are not sure what tolerance to use, try doing some test runs. Use the Network Review queries to evaluate the success of each trial import.
Using ModelBuilder to Transfer Existing Data

**Note:** Pipes will be connected to the closest node within the specified tolerance.

The unit associated with the tolerance is dictated by the Specify the Coordinate Unit of your data source field.

For more information, see Specifying Network Connectivity in ModelBuilder.

### 4.3.3 Step 3 - Specify Element Create/Remove/Update Options

Because of the variety of different data sources and the way those sources were created, the user has a wide variety of options to control the behavior of ModelBuilder.

![ModelBuilder Wizard](Lesson8_7.png)

**How would you like to handle synchronization between source and destination?**

- [ ] Add objects to destination if present in source
  - [ ] Prompt before adding objects
- [ ] Remove objects from destination if missing from source
  - [ ] Prompt before removing objects
- [x] Update existing objects in destination if present in source
  - [ ] Prompt before updating objects

If an imported object refers to another object that does not yet exist in the model, should ModelBuilder:

- [x] Create referenced object automatically?
  - [ ] Prompt before creating referenced objects

**How would you like to handle synchronization between source and destination?:**
• **Add objects to destination if present in source** (check box)-When this box is checked, ModelBuilder will automatically add new elements to the model for "new" records in the data source when synching in (or vice-versa when synching out).

   This is checked by default since a user generally wants to add elements to the model (especially if this is the initial run of ModelBuilder). This should be unchecked if new elements have been added to the source file since the model was created but the user does not want them in the model (e.g. proposed piping).

   – **Prompt before adding objects** (check box)-When this box is checked, ModelBuilder will pause during the synchronization process to present a confirmation message box to the user each time an element is about to be created in the model or data-source.

• **Remove objects from destination if missing from source** (check box)-When this box is checked, ModelBuilder will delete elements from the model if they do not exist in the data source when synching in (or vice-versa when synching out). This option can be useful if you are importing a subset of elements.

   This is used if abandoned pipes have been deleted from the source file and the user wants them to automatically be removed from the model by ModelBuilder.

   – **Prompt before removing objects** (check box)-When this box is checked, ModelBuilder will pause during the synchronization process to present a confirmation message box to the user each time an element is about to be deleted from the model.

• **Update existing objects in destination if present in source** (check box) - If checked, this option allows you to control whether or not properties and geometry of existing model elements will be updated when synching in (or vice-versa when synching out). Turning this option off can be useful if you want to synchronize newly added or removed elements, while leaving existing elements untouched.

   – **Prompt before updating objects** (check box)-When this box is checked, ModelBuilder will pause during the synchronization process to present a confirmation message box to the user each time an element is about to be updated.

**If an imported object refers to another object that does not yet exist in the model, should ModelBuilder:**

• **Create referenced element automatically?** (check box)-When this box is checked, ModelBuilder will create any domain and/or support elements that are referenced during the import process.
Using ModelBuilder to Transfer Existing Data

- **Prompt before creating referenced elements** (check box)- When this box is checked, ModelBuilder will pause during model generation to present a confirmation message box to the user each time a specified referenced element could not be found, and is about to be created for the model.

"Referenced elements" refers to any support or domain element that is referenced by another element. For example, Pumps can refer to Pump Definition support-elements, Junctions can refer to Zone support-elements, and Pumps can refer to a downstream Pipe domain-element. Node domain-elements that get created as a result of being referenced during the ModelBuilder process will use a default coordinate of 0, 0.

**Note:** These options listed above apply to domain elements (pipes and nodes) as well as support elements (such as Zones or Controls).

### 4.3.4 Step 4—Additional Options

<table>
<thead>
<tr>
<th>ModelBuilder Wizard [Lesson6_7.wtg]</th>
</tr>
</thead>
<tbody>
<tr>
<td>ModelBuilder</td>
</tr>
<tr>
<td>Specify additional options</td>
</tr>
</tbody>
</table>

**How would you like to import incoming data?**

- **Current Scenario**

**Specify key field used during object mapping:**

- **GIS-ID**

**If several elements share the same GIS-ID, then apply updates to all of them?**

- **Prompt before overwriting updates**

**How would you like to handle adds/removes of elements with GIS-ID mappings on subsequent imports?**

- **Recreate elements associated with a GIS-ID that were previously deleted from the model.**
- **When removing objects from destination if missing from source, only remove objects that have a GIS-ID.**

**How would you like to import incoming data?** (drop-down list) - This refers to the scenario (and associated alternatives) into which the data will be imported. The user can import the data into the Current Scenario or a new child scenario. If the latter is selected, a new child scenario (and child alternatives) will be created for any data difference between the source and the active scenario.
Note: If there is no data change for a particular alternative, no child alternative will be created in that case.

New scenario and alternatives will be automatically labeled "Created by ModelBuilder" followed by the date and time when they were created.

- **Specify key field used during object mapping** (drop-down list) - The key field represents the field in the model and data source that contains the unique identifier for associating domain elements in your model to records in your data source. Refer to the "Key Field (Model)" topic in the next section for additional guidance on how this setting applies to ModelBuilder. ModelBuilder provides three choices for Key Field:
  - **Label** - The element "Label" will be used as the key for associating model elements with data source records. Label is a good choice if the identifier field in your data-source is unique and represents the identifier you commonly use to refer to the record in your GIS.
  - **<custom>** - Any editable text field in your model can be used as the key for associating model elements with data source records. This is a good choice if you perhaps don't use labels on every element, or if perhaps there are duplicate labels in your data source.
  - **GIS-ID** - The element "GIS-ID" field will be used as the key for associating model elements with data source elements. The GIS-ID field offers a number of advanced capabilities, and is the preferred choice for models that you plan to keep in sync with your GIS over a period of time.

Refer to the section [The GIS-ID Property](#) for more information.

The following options only apply when using the advanced GIS-ID key field option.

- **If several elements share the same GIS-ID, then apply updates to all of them?** (check box) - When using the GIS-ID option, ModelBuilder allows you to maintain one-to-many, and many-to-one relationships between records in your GIS and elements in your Model.

For example, you may have a single pipe in your GIS that you want to maintain as multiple elements in your Model because you have split that pipe into two pipes elements in the model. You may accomplish this using the native StormCAD V8i layout tools to split the pipe with a node; the newly created pipe segment will be assigned the same GIS-ID as the original pipe (establishing a one-to-many relationship). By using this option, when you later synchronize from the GIS into your model, any data changes to the single pipe record in your GIS can be cascaded to both pipes elements in your model (e.g. so a diameter change to a single record in the GIS would be reflected in both elements in the model).

- **Prompt before cascading updates** (check box) - When this box is checked, ModelBuilder will pause during model generation to present a confirmation message box to the user each time a cascading update is about to be applied.
• **How would you like to handle add/removes of elements with GIS-ID mappings on subsequent imports?** - These options are useful for keeping your GIS and Model synchronized, while maintaining established differences.

  - **Recreate elements associated with a GIS-ID that was previously deleted from the model** (check box) - By default, ModelBuilder will not recreate elements you remove from your model that are associated with a records (with GIS-ID mappings) that are still in your GIS. This behavior is useful when you want to perform GIS to model synchronizations, but have elements that exist in your GIS that you do not want in your model.

    For example, after creating your model from GIS, you may find redundant nodes when performing a Network Navigator, "Nodes in Close Proximity" network review query. You may choose to use the "Merge Nodes in Close Proximity" feature to make the correction in your model (deleting the redundant nodes from your model). Normally, when you later synchronize from your GIS to your model, missing elements would be recreated and your correction would be lost. However, StormCAD V8i now maintains the history of elements (with GIS-ID's) that were removed from your model; this option allows you to control whether or not those elements get recreated.

  - **When removing objects from destination if missing from source, only remove objects that have a GIS-ID.** (check box) - This option is useful when you have elements that are missing from your GIS that you want to keep in your model (or vice-versa).

    For example, if you build your model from your GIS (using the GIS-ID option, a GIS-ID will be assigned to newly created elements in your model. If you later add elements to your model (they will not be assigned a GIS-ID); on subsequent synchronizations, this option (if checked) will allow you to retain those model specific elements that do not exist in your GIS. For example, you may have a proposed land development project in your model that does not exist in the GIS. These elements will not have a GIS-ID because they were not imported from the GIS. If this box is checked, the new elements will not be removed on subsequent runs of ModelBuilder.
Note:  This setting only applies if the "Remove objects from destination if missing from source" option is checked.

When you do make connectivity changes to your model, it is often beneficial to make those same changes to the GIS. However, this is not always possible; and in some cases is not desirable -- given the fact that Modeling often has highly specialized needs that may not be met by a general purpose GIS.

4.3.5 Step 5—Specify Field mappings for each Table/Feature Class

In this step, data source tables are mapped to the desired modeling element types, and data source fields are mapped to the desired model input properties. You will assign mappings for each Table/Feature Class that appears in the list; Step 1 of the wizard can be used to exclude tables, if you wish.

- **Tables** (list)-This pane, located along the left side of the dialog box, lists the data source Tables/Feature Classes to be used in the ModelBuilder process. Select an item in the list to specify the settings for that item.
Note: The tables list can be resized using the splitter bar.

There are two toolbar buttons located directly above Tables list (these buttons can be a great time saver when setting up multiple mappings with similar settings).

- **Copy Mappings** (button)-This button copies the mappings (associated with the currently selected table) to the clipboard.
- **Paste Mappings** (button)-This button applies the copied mappings to the currently selected table.

**Settings Tab**-The Settings tab allows you to specify mappings for the selected item in the Tables list.

The top section of the Settings tab allows you to specify the common data mappings:

- **Table Type** (drop-down list)-This field, which contains a list of all of the StormCAD V8i element types, allows you to specify the target modeling element type that the source table/feature class represents. For example, a source table that contains pipe data should be associated with the Conduit element type.

There are three categories of Table Types: Element Types, Components, and Collections. For geometric data sources, only Element Types are available. However with tabular data sources all table types can be used. The categorized menu accessed by the [>] button assists in quicker selection of the desired table type.

- **Element Types**-This category of Table Type includes geometric elements represented in the drawing view such as conduits, catch basins, manholes, etc.
- **Components**-This category of Table Type includes the supporting data items in your model that are potentially shared among elements such as patterns, pump definitions, and controls.
- **Collections**-This category of Table Type includes table types that are typically lists of 2-columned data. For instance, if one table in your connection consists of a list of (Time From Start, Multiplier) pairs, use a Pattern collection table type selection.

- **Key Fields**- This pair of key fields allows you to control how records in your data source are associated with elements in the model. The Key Fields element mapping consists of two parts, a data-source part and a model part:

- **Key Field (Data Source)** (drop-down list)-Choose the field in your data source that contains the unique identifier for each record.
**Note:** If you plan to maintain synchronizations between your model and GIS, it is best to define a unique identifier in your data source for this purpose. Using an identifier that is unique across all tables is critical if you wish to maintain explicit pipe start/stop connectivity identifiers in your GIS.

When working with ArcGIS data sources, OBJECTID is not a good choice for Key field (because OBJECTID is only unique for a particular Feature Class).

**For one-time model builds -- if you do not have a field that can be used to uniquely identify each element -- you may use the <label> field (which is automatically generated by ModelBuilder for this purpose).**

- **Key Field (Model)** (drop-down-list) - This field is only enabled if you specified <custom> in the "Specify key field to be used in object mapping?" option in the previous step. If you specified "GIS-ID" or "Label" the field will be disabled.

If you specified <custom>, then you will be presented with a list of the available text fields for that element type. Choose a field that represents the unique alphanumeric identifier for each element in your model.

**Note:** You can define a text User Data Extensions property for use as your <custom> model key field.

The <custom> key field list is limited to read-write text fields. This is because during import, the value of this field will be assigned as new elements in your model are created. Therefore, the models internal (read-only) element ID field cannot be used for this purpose.

The following optional fields are available for Pipe element types:

- **Start/Stop** - Select the fields in a pipe table that contain the identifier of the start and stop nodes. Specify <none> if you are using the spatial connectivity support in ModelBuilder (or if you want to keep connectivity unchanged on update). For more information, see Specifying Network Connectivity in ModelBuilder.

**Note:** When working with an ArcGIS Geometric Network data source, these fields will be set to <auto> (indicating that ModelBuilder will automatically determine connectivity from the geometric network).

These fields are available for Node element types:

- **X/Y Field** - These fields are used to specify the node X and Y coordinate data. This field only applies to point table types.
Note: The Coordinate Unit setting in Step 2 of the wizard allows you to specify the units associated with these fields.

When working with ArcGIS Geodatabase, shape file and CAD data sources, these fields will be set to <auto> (indicating that ModelBuilder will automatically determine node geometry from the data source).

These optional fields are available for Pump element types:

- **Suction Element** (drop-down list)-For tables that define pump data, select a pipe label or other unique identifier to set the suction element of the Pump.
- **Downstream Edge** (drop-down list)-For tables that define pump or valve data, select a pipe label or other unique identifier to set the direction of the pump or valve.

The bottom section of the Settings tab allows you to specify additional data mappings for each field in the source.

- **Field** - Field refers to a field in the selected data source. The Field list displays the associations between fields in the database to properties in the model.
- **Property** (drop-down list)-Property refers to a Bentley StormCAD V8i property. Use the Property drop-down list to map the highlighted field to the desired property.
- **Unit** (drop-down list)-This field allows you to specify the units of the values in the database (no conversion on your part is required). This field only applies if the selected model property is unitized.

- **Preview Tab**- The Preview tab displays a tabular preview of the currently highlighted source data table when the Show Preview check box is checked.

**To map a field in your table to a particular Bentley StormCAD V8i property:**

1. In the **Field** list, select the data source field you would like to define a mapping for.
2. In the **Property** drop-down list, select the desired Bentley StormCAD V8i target model property.
3. If the property is unitized, specify the unit of this field in your data source in the **Unit** drop-down list.

**To remove the mapping for a particular field:**

1. Select the field you would like to update.
2. In the **Property** drop-down list, select <none>.
4.3.6  **Step 6—Build operation Confirmation**

In this step, you are prompted to build a new model or update an existing model.

To build a new model, click the Yes radio button under **Would you like to build the model now?**.

If you choose No, you will be returned to the ModelBuilder Manager dialog. The connection you defined will appear in the list pane. To build the model from the ModelBuilder Manager, highlight the connection and click the Build Model button.

**Create Selection Set options:** Often a user wants to view the elements that have been affected by a ModelBuilder operation. To do this, ModelBuilder can create selection sets which the user can view and use within the application.

- To create a selection set containing the elements added during the ModelBuilder, check the box next to "**Create selection set with elements added.**"
- To create a selection set containing the elements for which the properties or geometry were modified during the ModelBuilder, check the box next to "**Create selection set with elements modified.**"
4.4 Reviewing Your Results

At the end of the model building process, you will be presented with statistics, and a list of any warning/error messages reported during the process. You should closely review this information, and be sure to save this data to disk where you can refer to it later.

Note: Refer to the section titled ModelBuilder Error Messages to determine the nature of any messages that were reported.

Refer to the Using the Network Navigator and Manipulating Elements topics for information about reviewing and correcting model connectivity issues.

4.5 Multi-select Data Source Types

When certain Data Source types are chosen in Step 1 of the ModelBuilder Wizard (see Step 1—Specify Data Source), multiple items can be selected for inclusion in your ModelBuilder connection.

After clicking the Browse button to interactively specify your data source, use standard Windows selection techniques to select all items you would like to include in the connection (e.g., Ctrl+click each item you would like to include).

The following are multi-select Data Source types:

- ArcGIS Geodatabase Features
- Shape files
- DBase, HTML Export, and Paradox.

4.6 ModelBuilder Error Messages

Errors that are encountered during the ModelBuilder process will be reported in the ModelBuilder Summary.

For more information, see:

- Error Messages
### 4.6.1 Error Messages

**Note:** If you encounter these errors or warnings, we recommend that you correct the problems in your original data source and re-run ModelBuilder (when applicable).

Error messages include:

1. *Unable to assign* `<attribute>` *for element* `<element>`.  
   Be sure that the data in your source table is compatible with the expected StormCAD V8i format. For more information, see [Preparing to Use ModelBuilder](#).

2. *Unable to create* `<element type>` `<element>`.  
   This message indicates that an unexpected error occurred when attempting to create a node element.

3. *Unable to create pipe* `<element>` *possibly due to start or stop connectivity constraints*.  
   This message indicates that this pipe could not be created, because the pump or valve already has an incoming and outgoing pipe. Adding a third pipe to a pump or valve is not allowed.

4. *Unable to update pipe* `<element>` *topology; possibly due to start element connectivity constraints*.  
   This error occurs when synchronizing. For more information, see error message #3 (above).

5. *Operation terminated by user*.  
   You pressed the Cancel button during the ModelBuilder process.

6. *Unable to create* `<element>` *; pipe start and stop must be different*.  
   This message indicates that the start and stop specified for this pipe refer to the same node element.

7. *Unable to update* `<element>` *topology; pipe start and stop must be different*.  
   This message indicates that the start and stop specified for this pipe refer to the same node element.

8. *Unable to update the downstream edge for* `<element>`.  
   An unexpected error occurred attempting to set the downstream edge for this pump or valve.

9. *Nothing to do. Some previously referenced tables may be missing from your data source*.  
   These messages indicate errors which are not recoverable. Failure to correct will result in a non-processable file.
This data source has changed since this connection was created. Verify that tables/feature-classes in your data source have not been renamed or deleted.

4.7 Specifying Network Connectivity in ModelBuilder

When importing spatial data (ArcGIS Geodatabases or shapefile data contain spatial geometry data that ModelBuilder can use to establish network connectivity by connecting pipe ends to nodes, creating nodes at pipe endpoints if none are found), ModelBuilder provides two ways to specify network connectivity:

- **Explicit connectivity**—based on pipe Start node and Stop node (see Step 3 - Specify Element Create/Remove/Update Options).

- **Implicit connectivity**—based on spatial data. When using implicit connectivity, ModelBuilder allows you to specify a Tolerance, and provides a second option allowing you to Create nodes if none found (see Step 2—Specify Spatial Options).

The method that you use will vary depending on the quality of your data. The possible situations include (in order from best case to worst case):

- You have pipe start and stop information—Explicit connectivity is definitely the preferred option.

- You have some start and stop information—Use a combination of explicit and implicit connectivity (use the Spatial Data option, and specify pipe Start/Stop fields). If the start or stop data is missing (blank) for a particular pipe, ModelBuilder will then attempt to use spatial data to establish connectivity.

- You do not have start and stop information—Implicit connectivity is your only option. If your spatial data is good, then you should reduce your connectivity Tolerance accordingly.

- You do not have start and stop information, and you do not have any node data (e.g., you have GIS data that defines your pipes, but you do not have data for nodes)—Use implicit connectivity and specify the Create nodes if none found option; otherwise, the pipes cannot be created.
Specifying Network Connectivity in ModelBuilder

**Note:** If pipes do not have explicit Start/Stop nodes and “Establish connectivity using spatial data” is not checked, the pipes will not be connected to the nodes and a valid model will not be produced.

Other considerations include what happens when the coordinates of the pipe ends do not match up with the node coordinates. This problem can be one of a few different varieties:

1. **Both nodes and pipe ends have coordinates, and pipes have explicit Start/Stop nodes**—In this case, the node coordinates are used, and the pipe ends are moved to connect with the nodes.
2. **Nodes have coordinates but pipes do not have explicit Start/Stop nodes**—The nodes will be created, and the specified tolerance will be used to connect pipe ends within this tolerance to the appropriate nodes. If a pipe end does not fall within any node’s specified tolerance, a new node can be created using the **Create nodes if none found** option.
3. **Pipe ends have coordinates but there are no junctions**—New nodes must be created using the **Create nodes if none found** option. Pipe ends are then connected using the tolerance that is specified. Subsequent pipe ends could then connect to any newly added nodes if they fall within the specified tolerance.

Another situation of interest occurs when two pipes cross but aren’t connected. If, at the point where the pipes cross, there are no pipe ends or nodes within the specified tolerance, then the pipes will not be connected in the model. If you intend for the pipes to connect, then pipe ends or junctions must exist within the specified tolerance.

Refer to the Using the Network Navigator and Manipulating Elements topics for information about reviewing and correcting model connectivity issues.

### 4.7.1 Sample Spreadsheet Data Source

**Note:** Database formats (such as MS Access) are preferable to simple spreadsheet data sources. The sample below is intended only to illustrate the importance of using expected data formats.

Here are two examples of possible data source tables. The first represents data that is in the correct format for an easy transition into ModelBuilder, with no modification. The second table will require adjustments before all of the data can be used by ModelBuilder.
Table 4-1: Correct Data Format for ModelBuilder

<table>
<thead>
<tr>
<th>Label</th>
<th>Roughness_C</th>
<th>Diam_in</th>
<th>Length_ft</th>
<th>Material_ID</th>
<th>Subtype</th>
</tr>
</thead>
<tbody>
<tr>
<td>P-1</td>
<td>120</td>
<td>6</td>
<td>120</td>
<td>3</td>
<td>2</td>
</tr>
<tr>
<td>P-2</td>
<td>110</td>
<td>8</td>
<td>75</td>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>P-3</td>
<td>130</td>
<td>6</td>
<td>356</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>P-4</td>
<td>100</td>
<td>10</td>
<td>729</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

Table 4-2: Data Format Needs Editing for ModelBuilder

<table>
<thead>
<tr>
<th></th>
<th>Roughness_C</th>
<th>Diam In</th>
<th>Length_ft</th>
<th>Material</th>
<th>Subtype</th>
</tr>
</thead>
<tbody>
<tr>
<td>P-1</td>
<td>120</td>
<td>.5</td>
<td>120</td>
<td>PVC</td>
<td>Phase2</td>
</tr>
<tr>
<td>P-2</td>
<td>110</td>
<td>.66</td>
<td>75</td>
<td>DuctT</td>
<td>Lateral</td>
</tr>
<tr>
<td>P-3</td>
<td>130</td>
<td>.5</td>
<td>356</td>
<td>PVC</td>
<td>Phase1</td>
</tr>
<tr>
<td>P-4</td>
<td>100</td>
<td>.83</td>
<td>729</td>
<td>DuctT</td>
<td>Main</td>
</tr>
<tr>
<td>P-5</td>
<td>100</td>
<td>1</td>
<td>1029</td>
<td>DuctT</td>
<td>Main</td>
</tr>
</tbody>
</table>

In Data Format Needs Editing for ModelBuilder, no column labels have been specified. ModelBuilder will interpret the first row of data in the table as the column labels, which can make the attribute mapping step of the ModelBuilder Wizard more difficult unless you are very familiar with your data source setup.

Correct Data Format for ModelBuilder is also superior to Data Format Needs Editing for ModelBuilder in that it clearly identifies the units that are used for unitized attribute values, such as length and diameter. Again, unless you are very familiar with your data source, unspecified units can lead to errors and confusion.

Finally, Data Format Needs Editing for ModelBuilder is storing the Material and Subtype attributes as alphanumeric values, while ModelBuilder uses integer ID values to access this input. This data is unusable by ModelBuilder in alphanumeric format, and must be translated to an integer ID system in order to read this data.

4.8 The GIS-ID Property

All domain elements in StormCAD V8i have an editable GIS-ID property which can be used for maintaining associations between records in your source file and elements in your model. These associations can be one-to-one, one-to-many, or many-to-one.
The GIS-ID Property

ModelBuilder can take advantage of this GIS-ID property, and has advanced logic for keeping your model and GIS source file synchronized across the various model to GIS associations.

The GIS-ID is a unique field in the source file which the user selects when ModelBuilder is being set up. In contrast to using Label (which is adequate if model building is a one time operation) as the key field between the model and the source file, a GIS-ID has some special properties which are very helpful in maintaining long term updating of the model as the data source evolves over time.

In addition, StormCAD V8i will intelligently maintain GIS-ID as you use the various tools to manipulate elements (Delete, Morph, Split, Merge Nodes in Close Proximity).

- When an element with one or more GIS-IDs is deleted, ModelBuilder will not recreate it the next time a synchronization from your GIS occurs if the "Recreate elements associated with a GIS-ID that was previously deleted from the model" option is left unchecked.
- When an element with one or more GIS-IDs is morphed, the new element will preserve those GIS-IDs. The original element will be considered as "deleted with GIS-IDs", which means that it will not be recreated by default (see above).
- When a link is split, the two links will preserve the same GIS-IDs the original pipe had. On subsequent ModelBuilder synchronizations, any data-change occurring for the associated record in the GIS can be cascaded into all the split link segments (see ModelBuilder - additional options).
- When nodes in close proximity are merged, the resulting node will preserve the GIS-IDs of all the nodes that were removed. On subsequent ModelBuilder synchronizations into the model, if there are data-update conflicts between the records in the GIS associated with the merged node in the model, updates from the first GIS-ID listed for the merged node will be preserved in the model. Note that in this case, the geometry of the merged node can't be updated in the model. For synchronizations going from the model to the GIS, data-updates affecting merged-nodes can be cascaded into all the associated records in the GIS (see ModelBuilder - additional options).

To support these relationship (specifically one to many), GIS-ID are managed as a collection property (capable of holding any number of GIS identifiers).

A variety of model element(s) to GIS record(s) associations can be specified:

- If the GIS-ID collection is empty, there is no association between the GIS and this element.
- If there is a single entry, this element is associated with one record in the GIS.
• If there are multiple entries, this element is associated with multiple records in the GIS.
• More than one element in the model can have the same GIS-ID, meaning multiple records on the model are associated with a single record in the GIS.

  **Note:** You can also manually edit the GIS-ID property to review or modify the element to GIS association(s).

### 4.8.1 GIS-ID Collection Dialog Box

This dialog box allows you to assign one or more GIS-IDs to the currently selected element.

See [The GIS-ID Property](#) for more information on using GIS-IDs.

### 4.9 Specifying a SQL WHERE clause in ModelBuilder

The simplest form of a WHERE clause consists of "Column name - comparison operator - value". For example, if you want to process only pipes in your data source that are ductile iron, you would enter something like this:

```sql
Material = 'Ductile Iron'
```

String values must be enclosed in single quotes.
Column names are not case sensitive. Column names that contain a space must be enclosed in brackets:

\[\text{[Pipe Material]} = 'Ductile Iron'\]

Brackets are optional for columns names that do not contain a space.

Supported comparison operators are: <, >, <=, >=, <>, =, IN and LIKE.

Multiple logical statements can be combined by using AND, OR and NOT operators. Parentheses can be used to group statements and enforce precedence.

The * and % wildcard can be used interchangeably in a LIKE statement. A wildcard is allowed at the beginning and/or end of a pattern. Wildcards are not allowed in the middle of a pattern. For example:

\[\text{PipeKey LIKE 'P-1*'}\]

is valid, while:

\[\text{PipeKey LIKE 'P*1'}\]

is not.

4.10 Modelbuilder Import Procedures

You can use ModelBuilder to import pump definitions, pump curves, and patterns.

- Importing Pump Definitions Using ModelBuilder
- Using ModelBuilder to Import Pump Curves
- Using ModelBuilder to Import Patterns

4.10.1 Importing Pump Definitions Using ModelBuilder

Pump definition information can be extracted from an external data source using ModelBuilder.

Most of this importing is accomplished by setting up mappings under the Pump Definition Table Type. However, to import multipoint head, efficiency or speed vs. efficiency curves, the tabular values must be imported under Table Types: Pump Definition - Pump Curves, Pump Definition - Flow-Efficiency Curve, and Pump Definition - Speed-Efficiency Curve respectively.
The list of properties that can be imported under **Pump Definition** is given below. The only property in the list that is required is a **Key** or **Label**. Most of the properties are numerical values.

- BEP Efficiency
- BEP Flow
- Define BEP Max Flow?
- Design Flow
- Design Head
- GemsID (imported)
- Is Variable Speed Drive?
- Max Extended Flow
- Max Operating Flow
- Max Operating Head
- Motor Efficiency
- Notes
- Pump Definition Type (ID)
- Pump Definition Type (Label)
- Pump Efficiency
- Pump Efficiency (ID)
- Pump Efficiency (Label)
- Pump Power
- Shutoff Head
- User Defined BEP Max Flow

Those properties that are text such as Pump Efficiency and Pump Definition Type are alphanumeric and must be spelled correctly. For example **Standard (3 Point)** must be spelled exactly as shown in the **Pump Definition** drop down. Properties with a question mark above, require a **TRUE** or **FALSE** value. Those with ID next to the name are internal IDs and are usually only useful when syncing out from a model.

To import data, create a table in a data source (e.g. spreadsheet, data base), and then create columns/fields for each of the properties to be imported. In Excel for example, the columns are created by entering column headings in the first row of a sheet for each of the properties. Starting with the second row in the table, there will be one row for each pump definition to be imported.
Once the table is created in the source file, the file must be saved before it can be imported.

In the **Specify you data source** step in the wizard, the user indicates the source file name and the sheet or table corresponding to the pump definition data. In the **Specify field mappings for each table** step, the user selects **Pump Definition** as the table type, indicates the name of the pump definition in the **Key>Label** field and then maps each of the fields to be imported with the appropriate property in the Attribute drop down.

When syncing out from the model to a data table, the table must contain column headings for each of the properties to be exported. The names of the columns in the source table do not need to be identical to the property names in the model.

Importing can best be illustrated with an example. Given the data and graphs for three pump definitions shown in the graph below, the table below the graph shows the format for the pump curve definition import assuming that a standard 3 point curve is to be used for the head curve and a best efficiency curve is to be used for the efficiency curve. All three pumps are rated at 120 ft of TDH at 200 gpm.
All three pumps have 95% motor efficiency and a BEP flow of 200.

The data source is created in an Excel spreadsheet.

### Table 4-3: Format of Pump Definition Import Data

<table>
<thead>
<tr>
<th>Q, gpm</th>
<th>H (red)</th>
<th>H (green)</th>
<th>H (blue)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>180</td>
<td>200</td>
<td>160</td>
</tr>
<tr>
<td>200</td>
<td>120</td>
<td>120</td>
<td>120</td>
</tr>
<tr>
<td>400</td>
<td>40</td>
<td>0</td>
<td>20</td>
</tr>
<tr>
<td>BEPe</td>
<td>70</td>
<td>69</td>
<td>65</td>
</tr>
</tbody>
</table>

### Table 4-4: Excel Data Source Format

<table>
<thead>
<tr>
<th>Label</th>
<th>Type</th>
<th>Motor Eff</th>
<th>Design Q</th>
<th>Design H</th>
<th>Shutoff Head</th>
<th>Max Q</th>
<th>H @ Max Q</th>
<th>BEP Eff</th>
<th>BEP Q</th>
<th>Eff Type</th>
<th>Variable Speed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red</td>
<td>Standard (3 Point)</td>
<td>95</td>
<td>200</td>
<td>120</td>
<td>180</td>
<td>400</td>
<td>40</td>
<td>70</td>
<td>200</td>
<td>Best Efficiency Point</td>
<td>FALSE</td>
</tr>
<tr>
<td>Green</td>
<td>Standard (3 Point)</td>
<td>95</td>
<td>200</td>
<td>120</td>
<td>200</td>
<td>400</td>
<td>0</td>
<td>69</td>
<td>200</td>
<td>Best Efficiency Point</td>
<td>FALSE</td>
</tr>
<tr>
<td>Blue</td>
<td>Standard (3 Point)</td>
<td>95</td>
<td>200</td>
<td>120</td>
<td>160</td>
<td>400</td>
<td>20</td>
<td>65</td>
<td>200</td>
<td>Best Efficiency Point</td>
<td>FALSE</td>
</tr>
</tbody>
</table>
The data source step in ModelBuilder wizard looks like this:

![Data Source Step in ModelBuilder Wizard](image1)

The field mappings should look like the screen below:

![Field Mappings in ModelBuilder Wizard](image2)
After the import, the three pumps are listed in the Pump Definitions. The curve for the "Red" pump is shown below:

4.10.2 Using ModelBuilder to Import Pump Curves

While most pump definition information can be imported using the Pump Definition Table Type, tabular data including

1. Multipoint pump-head curves,
2. Multipoint pump-efficiency curves and
3. Multipoint speed-efficiency curves

must be imported in their own table types.

To import these curves, first set up the pump definition type either manually in the Pump Definition dialog or by importing the pump definition through ModelBuilder. The Pump definition type would be Multiple Point, the efficiency type would be Multiple Efficiency Points or the Is variable speed drive? box would be checked.
In the field mapping step of the ModelBuilder wizard, the user sets the Table Type, **Pump Definition - Pump Curve** and would use the mappings shown below:

The example below shows an example of importing a Pump Head Curve. The process and format are analogous for flow-efficiency and speed-efficiency curves.
Using ModelBuilder to Transfer Existing Data

For the pump curves shown in the figure below, the data table needed is given. Several pump definitions can be included in the single table as long as they have different labels.

![Multipoint Pump Data](image)

**Table 4-5: Pump Curve Import Data Format**

<table>
<thead>
<tr>
<th>Label</th>
<th>Flow (gpm)</th>
<th>Head (ft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>M5</td>
<td>0</td>
<td>350</td>
</tr>
<tr>
<td>M5</td>
<td>5000</td>
<td>348</td>
</tr>
<tr>
<td>M5</td>
<td>10000</td>
<td>344</td>
</tr>
<tr>
<td>M5</td>
<td>15000</td>
<td>323</td>
</tr>
<tr>
<td>M5</td>
<td>20000</td>
<td>288</td>
</tr>
<tr>
<td>M5</td>
<td>25000</td>
<td>250</td>
</tr>
<tr>
<td>M5</td>
<td>30000</td>
<td>200</td>
</tr>
<tr>
<td>H2</td>
<td>0</td>
<td>312</td>
</tr>
<tr>
<td>H2</td>
<td>2000</td>
<td>304</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>----</td>
<td>-----</td>
<td>-----</td>
</tr>
<tr>
<td>H2</td>
<td>4000</td>
<td>294</td>
</tr>
<tr>
<td>H2</td>
<td>6000</td>
<td>280</td>
</tr>
<tr>
<td>H2</td>
<td>8000</td>
<td>262</td>
</tr>
<tr>
<td>H2</td>
<td>10000</td>
<td>241</td>
</tr>
<tr>
<td>H2</td>
<td>12000</td>
<td>211</td>
</tr>
<tr>
<td>H2</td>
<td>14000</td>
<td>172</td>
</tr>
<tr>
<td>Small</td>
<td>0</td>
<td>293</td>
</tr>
<tr>
<td>Small</td>
<td>1000</td>
<td>291</td>
</tr>
<tr>
<td>Small</td>
<td>2000</td>
<td>288</td>
</tr>
<tr>
<td>Small</td>
<td>3000</td>
<td>276</td>
</tr>
<tr>
<td>Small</td>
<td>4000</td>
<td>259</td>
</tr>
<tr>
<td>Small</td>
<td>5000</td>
<td>235</td>
</tr>
<tr>
<td>Small</td>
<td>6000</td>
<td>206</td>
</tr>
</tbody>
</table>
Upon running ModelBuilder to import the table above, three pump definitions would be created. The one called “Small” is shown below.

4.10.3 Using ModelBuilder to Import Patterns

Patterns can be imported into the model from external tables using ModelBuilder. This is a two step process.

1. Description of the pattern
2. Import tabular data

In general, the steps of the import are the same as described in the ModelBuilder documentation. The only steps unique to patterns are described below. All the fields except the Key/Label fields are optional.

The source data files can be any type of tabular data including spreadsheets and database tables.

Alphanumeric fields such as those which describe the month or day of the week must be spelled exactly as used in the model (e.g. January not Jan, Saturday not Sat).

The list of model attributes which can be imported are given below.

- Label
- MONTH [January, February, …]
Modelbuilder Import Procedures

- DAY [Sunday, Monday,…]
- Pattern category type (Label) [Hydraulic, Reservoir…]
- Pattern format (Label) [Stepwise, Continuous]
- Start Time
- Starting Multiplier

The month and day are the actual month or day of week, not the word "MONTH". Labels must be spelled correctly.

To import patterns, start ModelBuilder, create a new set of instructions, pick the file type, browse to the data file and pick the tables in that file to be imported. Checking the Show Preview button enables you to view the data before importing.
Then proceed to the **Field Mapping** step of ModelBuilder to set up the mappings for the Pattern in the Pattern Table Type. **Fields** refers to the name in the source table, **Attributes** refers to the name in the model.

![ModelBuilder Wizard](image)

And the actual Pattern Curve in the Pattern Curve table type.

![ModelBuilder Wizard](image)
The tables below show the pattern definition data and the pattern curve for two step-wise curves labeled Commercial and Residential. These data must be stored in two different tables although they may be and ideally should be in the same file.)

**Table 4-6: Pattern Definition Import Data Format**

<table>
<thead>
<tr>
<th>Label</th>
<th>Category</th>
<th>Format</th>
<th>StartTime</th>
<th>StartMult</th>
</tr>
</thead>
<tbody>
<tr>
<td>Residential</td>
<td>Hydraulic</td>
<td>Stepwise</td>
<td>12:00 PM</td>
<td>0.7</td>
</tr>
<tr>
<td>Commercial</td>
<td>Hydraulic</td>
<td>Stepwise</td>
<td>12:00 PM</td>
<td>0.8</td>
</tr>
</tbody>
</table>

**Table 4-7: Pattern Curve Import Data Format**

<table>
<thead>
<tr>
<th>PatternLabel</th>
<th>TimeFromStart</th>
<th>Multiplier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Residential</td>
<td>3</td>
<td>0.65</td>
</tr>
<tr>
<td>Residential</td>
<td>6</td>
<td>0.8</td>
</tr>
<tr>
<td>Residential</td>
<td>9</td>
<td>1.3</td>
</tr>
<tr>
<td>Residential</td>
<td>12</td>
<td>1.6</td>
</tr>
<tr>
<td>Residential</td>
<td>15</td>
<td>1.4</td>
</tr>
<tr>
<td>Residential</td>
<td>18</td>
<td>1.2</td>
</tr>
<tr>
<td>Residential</td>
<td>21</td>
<td>0.9</td>
</tr>
<tr>
<td>Residential</td>
<td>24</td>
<td>0.7</td>
</tr>
<tr>
<td>Commercial</td>
<td>3</td>
<td>0.8</td>
</tr>
<tr>
<td>Commercial</td>
<td>6</td>
<td>0.85</td>
</tr>
<tr>
<td>Commercial</td>
<td>9</td>
<td>1.4</td>
</tr>
<tr>
<td>Commercial</td>
<td>12</td>
<td>1.6</td>
</tr>
<tr>
<td>Commercial</td>
<td>15</td>
<td>1.3</td>
</tr>
<tr>
<td>Commercial</td>
<td>18</td>
<td>0.9</td>
</tr>
<tr>
<td>Commercial</td>
<td>21</td>
<td>0.8</td>
</tr>
<tr>
<td>Commercial</td>
<td>24</td>
<td>0.8</td>
</tr>
</tbody>
</table>
One of the resulting patterns from this import is shown below:

Using ModeBuilder to Transfer Existing Data

Pattern Library Notes
Start Time: 12:00:00 PM
Starting Multiplier: 0.700
Pattern Format: stepwise

<table>
<thead>
<tr>
<th>Time from Start (hours)</th>
<th>Multiplier</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.000</td>
<td>0.650</td>
</tr>
<tr>
<td>6.000</td>
<td>0.000</td>
</tr>
<tr>
<td>9.000</td>
<td>1.300</td>
</tr>
<tr>
<td>12.000</td>
<td>1.600</td>
</tr>
<tr>
<td>15.000</td>
<td>1.400</td>
</tr>
<tr>
<td>18.000</td>
<td>1.300</td>
</tr>
</tbody>
</table>

Hourly Hydraulic Pattern Residential

Close Help
Creating Models

5

Starting a Project

Elements and Element Attributes

Adding Elements to Your Model

Manipulating Elements

Editing Element Attributes

Using Named Views

Using Selection Sets

Using the Network Navigator

Using Prototypes

Engineering Libraries

Hyperlinks

Using Queries

User Data Extensions

5.1 Starting a Project

When you first start Bentley StormCAD V8i, the Welcome dialog box opens.

The Welcome dialog box contains the following controls:

Quick Start Lessons Opens the online help to the Quick Start Lessons Overview topic.
### Create New Project
Creates a new StormCAD V8i project. When you click this button, an untitled Bentley StormCAD V8i project is created.

### Open Existing Project
Opens an existing project. When you click this button, a Windows browse dialog box opens allowing you to browse to the project to be opened.

### Open from ProjectWise
Open an existing StormCAD V8i project from ProjectWise. You are prompted to log into a ProjectWise datasource if you are not already logged in.

### Show This Dialog at Start
When selected, the Welcome dialog box opens whenever you start Bentley StormCAD V8i. Turn off this box if you do not want the Welcome dialog box to open whenever you start Bentley StormCAD V8i.

---

**To Access the Welcome Dialog During Program Operation**

Click the Help menu and select the Welcome Dialog command.

**To Disable the Automatic Display of the Welcome Dialog Upon Startup**

In the Welcome dialog, turn off the box labeled Show This Dialog at Start.

**To Enable the Automatic Display of the Welcome Dialog Upon Startup**

In the Welcome dialog, turn on the box labeled Show This Dialog at Start.

---

### 5.1.1 Bentley StormCAD V8i Projects

All data for a model are stored in StormCAD V8i as a project. StormCAD V8i project files have the file name extension .stc. You can assign a title, date, notes and other identifying information about each project using the Project Properties dialog box. You can have up to five StormCAD V8i projects open at one time.

**To Start a New Project**

To start a new project, choose File > New or press <Ctrl+N>. An untitled project is opened in the drawing pane.

**To Open an Existing Project**
Creating Models

To open an existing project, choose File > Open or press <Ctrl+O>. A dialog box opens allowing you to browse for the project you want to open.

To Switch Between Multiple Projects

To switch between multiple open projects, select the appropriate tab at the top of the drawing pane. The file name of the project is displayed on the tab.

5.1.2 Setting Project Properties

The Project Properties dialog box allows you to enter project-specific information to help identify the project. Project properties are stored with the project.

The dialog box contains the following text fields and controls:

- **Title**: Enter a title for the project.
- **File Name**: Displays the file name for the current project. If you have not saved the project yet, the file name is listed as “Untitledx.stc.”, where x is a number between 1 and 5 chosen by the program based on the number of untitled projects that are currently open.
- **Engineer**: Enter the name of the project engineer.
- **Company**: Enter the name of your company.
- **Date**: Click this field to display a calendar, which is used to set a date for the project.
- **Notes**: Enter additional information about the project.

To set project properties

2. Enter the information in the Project Properties dialog box and click **OK**.
5.1.3 Setting Options

You can change global settings for StormCAD V8i in the Options dialog box. Choose Tools > Options. The Options dialog box contains different tabs where you can change settings.

Click one of the following links to learn more about the Options dialog box:

- Options Dialog Box - Global Tab
- Options Dialog Box - Project Tab
- Options Dialog Box - Drawing Tab
Creating Models

- **Options Dialog Box - Units Tab**
- **Options Dialog Box - Labeling Tab**
- **Options Dialog Box - ProjectWise Tab**

### Options Dialog Box - Global Tab

The Global tab changes general program settings for the StormCAD V8i stand-alone editor, including whether or not to display the status pane, as well as window color and layout settings.

<table>
<thead>
<tr>
<th>Global</th>
<th>Project</th>
<th>Drawing</th>
<th>Units</th>
<th>Labeling</th>
<th>ProjectWise</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Backup Levels:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>Show recently used files:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>4</td>
</tr>
<tr>
<td>Compact Database After:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>10</td>
</tr>
<tr>
<td>Show Status Pane</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Welcome Page on Startup</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom Extents On Open</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use accelerated redraw</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Window Color**

- Background: [Color Picker]
- Read-only Background: [Color Picker]
- Foreground: [Color Picker]
- Read-only Foreground: [Color Picker]
- Selection: [Color Picker]

**Layout**

- Display Inactive Topology
- Auto Refresh
- Sticky Tool Palette
- Select Polygons By Edge

<table>
<thead>
<tr>
<th>Selection Handle Size In Pixels:</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection Line Width Multiplier:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Default Drawing Style for New Projects:</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The Global tab contains the following controls:

**General Settings**
### Starting a Project

<table>
<thead>
<tr>
<th>Backup Levels</th>
<th>Indicates the number of backup copies that are retained when a project is saved. The default value is 1.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Note:</strong></td>
<td>The higher this number, the more .BAK files (backup files) are created, thereby using more hard disk space on your computer.</td>
</tr>
<tr>
<td>Show Recently Used Files</td>
<td>When selected, activates the recently opened files display at the bottom of the File menu. This check box is turned on by default. The number of recently used files that are displayed depends on the number specified here.</td>
</tr>
<tr>
<td>Show Status Pane</td>
<td>When turned on, activates the Status Pane display at the bottom of the StormCAD V8i stand-alone editor. This check box is turned on by default.</td>
</tr>
<tr>
<td>Show Welcome Page on Startup</td>
<td>When turned on, activates the Welcome dialog that opens when you first start StormCAD V8i. This check box is turned on by default.</td>
</tr>
<tr>
<td>Zoom Extents On Open</td>
<td>When turned on, a Zoom Extents is performed automatically in the drawing pane.</td>
</tr>
<tr>
<td>Use accelerated redraw</td>
<td>Some video cards use &quot;triple buffering&quot;, which we do not support at this time. If you see anomalies in the drawing (such as trails being left behind from the selection rectangle), then you can shut this option off to attempt to fix the problem. However, when this option is off, you could see some performance degradation in the drawing.</td>
</tr>
<tr>
<td>Prompts</td>
<td>Opens the Stored Prompt Responses dialog, which allows you to change the behavior of the default prompts (messages that appear allowing you to confirm or cancel certain operations).</td>
</tr>
<tr>
<td>Window Color</td>
<td></td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Background Color</strong></td>
<td>Displays the color that is currently assigned to the drawing pane background. You can change the color by clicking the ellipsis (...) to open the Color dialog box.</td>
</tr>
<tr>
<td><strong>Foreground Color</strong></td>
<td>Displays the color that is currently assigned to elements and labels in the drawing pane. You can change the color by clicking the ellipsis (...) to open the Color dialog box.</td>
</tr>
<tr>
<td><strong>Read Only Background Color</strong></td>
<td>Displays the color that is currently assigned to read-only data field backgrounds. You can change the color by clicking the ellipsis (...) to open the Color dialog box.</td>
</tr>
<tr>
<td><strong>Read Only Foreground Color</strong></td>
<td>Displays the color that is currently assigned to read-only data field text. You can change the color by clicking the ellipsis (...) to open the Color dialog box.</td>
</tr>
<tr>
<td><strong>Selection Color</strong></td>
<td>Displays the color that is currently applied to highlighted elements in the drawing pane. You can change the color by clicking the ellipsis (...) to open the Color dialog box.</td>
</tr>
<tr>
<td><strong>Layout</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Display Inactive Topology</strong></td>
<td>When turned on, activates the display of inactive elements in the drawing pane in the color defined in Inactive Topology Line Color. When turned off, inactive elements will not be visible in the drawing pane. This check box is turned on by default.</td>
</tr>
<tr>
<td><strong>Inactive Topology Line Color</strong></td>
<td>Displays the color currently assigned to inactive elements. You can change the color by clicking the ellipsis (...) to open the Color dialog box.</td>
</tr>
<tr>
<td><strong>Auto Refresh</strong></td>
<td>Activates Auto Refresh. When Auto Refresh is turned on, the drawing pane automatically updates whenever changes are made to the StormCAD V8i datastore. This check box is turned off by default.</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Sticky Tool Palette</strong></td>
<td>When turned on, activates the Sticky Tools feature. When Sticky Tools is turned on, the drawing pane cursor does not reset to the Select tool after you create a node or finish a pipe run in your model, allowing you to continue dropping new elements into the drawing without re-selecting the tool. When Sticky Tools is turned off, the drawing pane cursor resets to the Select tool after you create a node. This check box is selected by default.</td>
</tr>
<tr>
<td><strong>Select Polygons By Edge</strong></td>
<td>When this box is checked, polygon elements (catchments) can only be selected in the drawing pane by clicking on their bordering line, in other words you cannot select polygons by clicking their interior when this option is turned on.</td>
</tr>
<tr>
<td><strong>Selection Handle Size In Pixels</strong></td>
<td>Specifies, in pixels, the size of the handles that appear on selected elements. Enter a number from 1 to 10.</td>
</tr>
<tr>
<td><strong>Selection Line Width Multiplier</strong></td>
<td>Increases or decreases the line width of currently selected link elements by the factor indicated. For example, a multiplier of 2 would result in the width of a selected link being doubled.</td>
</tr>
<tr>
<td><strong>Default Drawing Style</strong></td>
<td>Allows you to select GIS or CAD drawing styles. Under GIS style, the size of element symbols in the drawing pane will remain the same regardless of zoom level. Under CAD style, element symbols will appear larger or smaller depending on zoom level.</td>
</tr>
</tbody>
</table>
Stored Prompt Responses Dialog Box

This dialog allows you to change the behavior of command prompts back to their default settings. Some commands trigger a command prompt that can be suppressed by using the Do Not Prompt Again check box. You can turn the prompt back on by accessing this dialog and unchecking the box for that prompt type.

<table>
<thead>
<tr>
<th>Prompt</th>
<th>Default Response</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attach isolation valve to link?</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Options Dialog Box - Project Tab

This tab contains miscellaneous settings. You can set pipe length calculation, spatial reference, label display, and results file options in this tab.

<table>
<thead>
<tr>
<th>Global</th>
<th>Project</th>
<th>Drawing</th>
<th>Units</th>
<th>Labeling</th>
<th>ProjectWise</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geospatial Options:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Spatial Reference:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Element Labeling Options:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Element Identifier Format:</td>
<td>ID: Label</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Result Files:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Specify Custom Results File Path?:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Root Path:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Path Format:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Path:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pipe Length:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Round Pipe Length to Nearest:</td>
<td>1.0 ft</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calculate Pipe Lengths Using Node Elevations (3D Length)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hydraulic Analysis:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Friction Method:</td>
<td>Manning’s</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Conduit Description Options:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Conduit Shape:</td>
<td>Circular Pipe</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Conduit Description Format:</td>
<td>$(Shape) - $(Diameter) $(Diameter Unit)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The Project tab contains the following controls:

**Geospatial Options**
Creating Models

Spatial Reference Used for integration with Projectwise. Can leave the field blank if there is no spatial information.

Element Identifier Options

Element Identifier Format Specifies the format in which reference fields are used. Reference fields are fields that link to another element or support object (pump definitions, patterns, controls, zones, etc.).

Result Files

Specify Custom Results File Path? When checked, allows you to edit the results file path and format by enabling the other controls in this section.

Root Path Allows you to specify the root path where results files are stored. You can type the path manually or choose the path from a Browse dialog by clicking the ellipsis (...) button.

Path Format Allows you to specify the path format. You can type the path manually and use predefined attributes from the menu accessed with the [>] button.

Path Displays a dynamically updated view of the custom result file path based on the settings in the Root Path and Path Format fields.

Pipe Length

Round Pipe Length to Nearest The program will round to the nearest unit specified in this field when calculating scaled pipe length.

Calculate Pipe Lengths Using Node Elevations (3D Length) When checked, includes differences in Z (elevation) between pipe ends when calculating pipe length.

Hydraulic Analysis
Friction Method  Allows you to specify the friction method that will be used in the project.

Conduit Description Options

Conduit Shape  Allows you to specify the shape of the conduit that to be edited in the Conduit Description Format field.

Conduit Description Format  Allows you to define the format that will be used in conduit descriptions. Click the arrow button to choose from the premade attribute variables.

Options Dialog Box - Drawing Tab

This tab contains drawing layout and display settings. You can set the scale that you want to use as the finished drawing scale for the plan view output. Drawing scale is based upon engineering judgment and the destination sheet sizes to be used in the final presentation.

<table>
<thead>
<tr>
<th>Global</th>
<th>Project</th>
<th>Drawing</th>
<th>Units</th>
<th>Labeling</th>
<th>ProjectWide</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing Scale</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drawing Mode:</td>
<td></td>
<td>Scaled</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plot Scale Factor 1 in =</td>
<td></td>
<td>30.0</td>
<td>ft</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Annotation Multipliers</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Symbol Size Multiplier:</td>
<td></td>
<td>4.000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Text Height Multiplier:</td>
<td></td>
<td>4.000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Text Options:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Align Text With Pipes:</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Color Element Annotations:</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The Drawing tab contains the following controls:

**Drawing Scale**

**Drawing Mode**  Selects either Scaled or Schematic mode for models in the drawing pane.
Creating Models

**Plot Scale Factor 1 in.** Controls the scale of the plan view.

**Annotation Multipliers**

**Symbol Size Multiplier** Increases or decreases the size of your symbols by the factor indicated. For example, a multiplier of 2 would result in the symbol size being doubled. The program selects a default symbol height that corresponds to 4.0 ft. (approximately 1.2 m) in actual-world units, regardless of scale.

**Text Height Multiplier** Increases or decreases the default size of the text associated with element labeling by the factor indicated. The program automatically selects a default text height that displays at approximately 2.5 mm (0.1 in) high at the user-defined drawing scale. A scale of 1.0 mm = 0.5 m, for example, results in a text height of approximately 1.25 m. Likewise, a 1 in. = 40 ft. scale equates to a text height of around 4.0 ft.

**Text Options**

**Align Text with Pipes** Turns text alignment on and off. When it is turned on, labels are aligned to their associated pipes. When it is turned off, labels are displayed horizontally near the center of the associated pipe.

**Color Element Annotations** When this box is checked, color coding settings are applied to the element annotation.
# Options Dialog Box - Units Tab

The Units tab modifies the unit settings for the current project.

<table>
<thead>
<tr>
<th>Label</th>
<th>Unit</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Absolute Roughness</td>
<td>ft</td>
<td>Number</td>
</tr>
<tr>
<td>2 Angle</td>
<td>degree</td>
<td>Number</td>
</tr>
<tr>
<td>3 Area - Large</td>
<td>mil</td>
<td>Number</td>
</tr>
<tr>
<td>4 Background Layer Unit</td>
<td>ft</td>
<td>Number</td>
</tr>
<tr>
<td>5 Bulk Reaction Rate</td>
<td>(mg/L)</td>
<td>Number</td>
</tr>
<tr>
<td>6 Coefficient</td>
<td>gpd/capita</td>
<td>Number</td>
</tr>
<tr>
<td>7 Concentration</td>
<td>mg/L</td>
<td>Number</td>
</tr>
<tr>
<td>8 Coordinate</td>
<td>ft</td>
<td>Number</td>
</tr>
<tr>
<td>9 Cost per Unit Energy</td>
<td>$/kWh</td>
<td>Number</td>
</tr>
<tr>
<td>10 Cost per Unit Power</td>
<td>$/W</td>
<td>Number</td>
</tr>
<tr>
<td>11 Cost per Unit Volume</td>
<td>$/MG</td>
<td>Number</td>
</tr>
<tr>
<td>12 Culvert Coefficient</td>
<td>h</td>
<td>Number</td>
</tr>
<tr>
<td>13 Currency</td>
<td>$/ft</td>
<td>Number</td>
</tr>
<tr>
<td>14 Currency per Length</td>
<td>$/ft</td>
<td>Number</td>
</tr>
<tr>
<td>15 Depth</td>
<td>gpd/acre</td>
<td>Number</td>
</tr>
<tr>
<td>16 Relative Permeability</td>
<td>ft</td>
<td>Number</td>
</tr>
<tr>
<td>17 Relative Permeability - Large</td>
<td>ft</td>
<td>Number</td>
</tr>
<tr>
<td>18 Relative Permeability - Small</td>
<td>ft</td>
<td>Number</td>
</tr>
<tr>
<td>19 Relative Permeability - Large</td>
<td>ft</td>
<td>Number</td>
</tr>
<tr>
<td>20 Relative Permeability - Small</td>
<td>ft</td>
<td>Number</td>
</tr>
</tbody>
</table>

Default Unit System for New Project: **US**
The Units tab contains the following controls:

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As</td>
<td>Saves the current unit settings as a separate .xml file. This file allows you to reuse your Units settings in another project. When the button is clicked, a Windows Save As dialog box opens, allowing you to enter a name and specify the directory location of the .xml file.</td>
</tr>
<tr>
<td>Load</td>
<td>Loads a previously created Units project .xml file, thereby transferring the unit and format settings that were defined in the previous project. When the button is clicked, a Windows Load dialog box opens, allowing you to browse to the location of the desired .xml file.</td>
</tr>
<tr>
<td>Reset Defaults - SI</td>
<td>Resets the unit and formatting settings to the original factory defaults for the System International (Metric) system.</td>
</tr>
<tr>
<td>Reset Defaults - US</td>
<td>Resets the unit and formatting settings to the original factory defaults for the Imperial (U.S.) system.</td>
</tr>
<tr>
<td>Default Unit System</td>
<td>Specifies the unit system that is used globally across the project. Note that you can locally change any number of attributes to the unit system other than the ones specified here.</td>
</tr>
<tr>
<td>for New Project</td>
<td></td>
</tr>
</tbody>
</table>
Units Table

The units table contains the following columns:

- **Label**—Displays the parameter measured by the unit.

- **Unit**—Displays the type of measurement. To change the unit of an attribute type, click the choice list and click the unit you want. This option also allows you to use both U.S. customary and SI units in the same worksheet.

- **Display Precision**—Sets the rounding of numbers and number of digits displayed after the decimal point. Enter a negative number for rounding to the nearest power of 10: (-1) rounds to 10, (-2) rounds to 100, (-3) rounds to 1000, and so on. Enter a number from 0 to 15 to indicate the number of digits after the decimal point.

- **Format Menu**—Selects the display format used by the current field. Choices include:
  - **Scientific**—Converts the entered value to a string of the form "-d.ddd...E+ddd" or "-d.ddd...e+ddd", where each 'd' indicates a digit (0-9). The string starts with a minus sign if the number is negative.
  - **Fixed Point**—Abides by the display precision setting and automatically enters zeros after the decimal place to do so. With a display precision of 3, an entered value of 3.5 displays as 3.500.
  - **General**—Truncates any zeros after the decimal point, regardless of the display precision value. With a display precision of 3, the value that would appear as 5.200 in Fixed Point format displays as 5.2 when using General format. The number is also rounded. So, an entered value of 5.35 displays as 5.4, regardless of the display precision.
  - **Number**—Converts the entered value to a string of the form "-d,ddd,ddd,ddd...", where each 'd' indicates a digit (0-9). The string starts with a minus sign if the number is negative. Thousand separators are inserted between each group of three digits to the left of the decimal point.
**Note:** The conversion for pressure to ft. (or m) H20 uses the specific gravity of water at 4°C (39°F), or a specific gravity of 1. Hence, if the fluid being used in the simulation uses a specific gravity other than 1, the sum of the pressure in ft. (or m) H20 and the node elevation will not be exactly equal to the calculated hydraulic grade line (HGL).

### Options Dialog Box - Labeling Tab

The Element Labeling tab is used to specify the automatic numbering format of new elements as they are added to the network. You can save your settings to an .xml file for later use.

<table>
<thead>
<tr>
<th>Labeling Options</th>
<th>On</th>
<th>Next</th>
<th>Increment</th>
<th>Prefix</th>
<th>Digits</th>
<th>Suffix</th>
<th>Preview</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conduit</td>
<td>✔</td>
<td>1</td>
<td>1</td>
<td>P-</td>
<td>1</td>
<td>P-1</td>
<td></td>
</tr>
<tr>
<td>Gutter</td>
<td>✔</td>
<td>1</td>
<td>1</td>
<td>GU-</td>
<td>1</td>
<td>GU-1</td>
<td></td>
</tr>
<tr>
<td>Catch Basin</td>
<td>✔</td>
<td>1</td>
<td>1</td>
<td>I-</td>
<td>1</td>
<td>I-1</td>
<td></td>
</tr>
<tr>
<td>Manhole</td>
<td>✔</td>
<td>1</td>
<td>1</td>
<td>J-</td>
<td>1</td>
<td>J-1</td>
<td></td>
</tr>
<tr>
<td>Transition</td>
<td>✔</td>
<td>1</td>
<td>1</td>
<td>T-</td>
<td>1</td>
<td>T-1</td>
<td></td>
</tr>
<tr>
<td>Outfall</td>
<td>✔</td>
<td>1</td>
<td>1</td>
<td>O-</td>
<td>1</td>
<td>O-1</td>
<td></td>
</tr>
<tr>
<td>Catchment</td>
<td></td>
<td>2</td>
<td>1</td>
<td>CM-</td>
<td>1</td>
<td>CM-2</td>
<td></td>
</tr>
</tbody>
</table>

### Conduit Description Options

<table>
<thead>
<tr>
<th>Description Format</th>
<th>Description Preview</th>
</tr>
</thead>
<tbody>
<tr>
<td>Box Pipe</td>
<td>$(Shape) - $(Span) x $(R...</td>
</tr>
<tr>
<td>Circular Pipe</td>
<td>$(Shape) - $(Diameter) $...</td>
</tr>
<tr>
<td>Elliptical Pipe</td>
<td>$(Shape) - $(Span) x $(R...</td>
</tr>
<tr>
<td>Virtual</td>
<td>$(Shape)</td>
</tr>
<tr>
<td>Triangular Channel</td>
<td>$(Shape) - $(Span) x $(R...</td>
</tr>
<tr>
<td>Pipe Arch</td>
<td>$(Shape)</td>
</tr>
<tr>
<td>Catalog Conduit</td>
<td>$(Shape) - $(Catalog P...</td>
</tr>
</tbody>
</table>

### Branch Labeling Options

<table>
<thead>
<tr>
<th>Branch Number:</th>
<th>Conduit Position within Branch:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start at:</td>
<td>Start at:</td>
</tr>
<tr>
<td>Increment:</td>
<td>Increment:</td>
</tr>
</tbody>
</table>

Sample Branch Labels: 1.000, 1.001, 2.000, 2.001, 3.000...

The Element Labeling tab contains the following controls:
**Starting a Project**

**Save As**  Saves your element labeling settings to an element label project file, which is an .xml file.

**Load**  Opens an existing element label project file.

**Reset**  Assigns the correct Next value for all elements based on the elements currently in the drawing and the user-defined values set in the Increment, Prefix, Digits, and Suffix fields of the Labeling table.

**Labeling Table**  The labeling table contains the following columns:

- **Element**—Shows the type of element to which the label applies.
- **On**—Turns automatic element labeling on and off for the associated element type.
- **Next**—Type the integer you want to use as the starting value for the ID number portion of the label. Bentley StormCAD V8i generates labels beginning with this number and chooses the first available unique label.
- **Increment**—Type the integer that is added to the ID number after each element is created to yield the number for the next element.
- **Prefix**—Type the letters or numbers that appear in front of the ID number for the elements in your network.
- **Digits**—Type the minimum number of digits that the ID number has. For instance, 1, 10, and 100 with a digit setting of two would be 01, 10, and 100.
- **Suffix**—Type the letters or numbers that appear after the ID number for the elements in your network.
- **Preview**—Displays what the label looks like based on the information you have entered in the previous fields.

**Conduit Description Options**

Conduit Description is a field on conduit elements that can be automatically generated from other conduit properties. Each conduit shape has a different labeling definition. To modify each value, click on the cell in the table, then click the ellipsis button to open the Conduit Description Format dialog box.
Branch Labeling Options

The branch labeling options allow you to define how the resultant Branch IDs and Branch Element IDs are determined when you compute. These values can then be used in the Conduit Description definitions above.

Note that these values are also used in the Micro Drainage Export command to develop the pipe labels being exported to the .SWS file. (UK Only)

Conduit Description Format Dialog Box

This dialog allows you to define the format of the conduit description for the conduit shape selected in the conduit shape list of the Options labeling tab. The Append button at the top of the dialog provides access to the preformatted variables available for the associated conduit shape.

Options Dialog Box - ProjectWise Tab

The ProjectWise tab contains options for using StormCAD V8i with ProjectWise.
This tab contains the following controls:

**Default Datasource**
Displays the current ProjectWise datasource. If you have not yet logged into a datasource, this field will display <login>. To change the datasource, click the Ellipses (...) to open the Change Datasource dialog box. If you click Cancel after you have changed the default datasource, the new default datasource is retained.

**Update Server When Saving**
When this is turned on, any time you save your StormCAD V8i project locally using the File > Save menu command, the files on your ProjectWise server will also be updated and all changes to the files will immediately become visible to other ProjectWise users. This option is turned off by default.

*Note:* This option, when turned on, can significantly affect performance, especially for large, complex projects.

*Note:* These settings affect ProjectWise users only.

For more information about ProjectWise, see the Working with ProjectWise topic.

### 5.1.4 Working with ProjectWise

Bentley ProjectWise provides managed access to StormCAD V8i content within a workgroup, across a distributed organization, or among collaborating professionals. When ProjectWise is integrated with StormCAD V8i, project files can be accessed quickly, checked out for use, and checked back in directly from within StormCAD V8i.

If ProjectWise is installed on your system, StormCAD V8i automatically installs all the components necessary for you to use ProjectWise to store and share your StormCAD V8i projects.

To learn more about ProjectWise, refer to the ProjectWise online help.

**ProjectWise and Bentley StormCAD V8i**

Follow these guidelines when using StormCAD V8i with ProjectWise:
Creating Models

- Use the File > ProjectWise commands to perform ProjectWise file operations, such as Save, Open, and ChangeDatasource.
- The first time you choose one of the File > ProjectWise menu commands in your current StormCAD V8i session, you are prompted to log into a ProjectWise datasource. The datasource you log into remains the current datasource until you change it using the File > ProjectWise > ChangeDatasource command.
- Use StormCAD V8i’s File > New command to create a new project. The project is not stored in ProjectWise until you select File > ProjectWise > Save As.
- Use StormCAD V8i’s File > Open command to open a local copy of the current project.
- Use StormCAD V8i’s File > Save command to save a copy of the current project to your local computer.
- When you Close a project already stored in ProjectWise using File > Close, you are prompted to select one of the following options:
  - **Check In**—Updates the project in ProjectWise with your latest changes and unlocks the project so other ProjectWise users can edit it.
  - **Unlock**—Unlocks the project so other ProjectWise users can edit it but does not update the project in ProjectWise. Note that this will abandon any changes you have made since the last server update.
  - **Leave Out**—Leaves the project checked out so others cannot edit it and retains any changes you have made since the last server update to the files on your local computer. Select this option if you want to exit Bentley StormCAD V8i but continue working on the project later.
- In the StormCAD V8i Options dialog box, there is a ProjectWise tab with the Update server on Save check box. This option, when turned on, can significantly affect performance, especially for large, complex projects. When this is checked, any time you save your StormCAD V8i project locally using the File > Save menu command, the files on your ProjectWise server will also be updated and all changes to the files will immediately become visible to other ProjectWise users. This option is turned off by default.
- In this release of StormCAD V8i, calculation result files are not managed inside ProjectWise. A local copy of results is maintained on your computer, but to ensure accurate results you should recalculate projects when you first open them from ProjectWise.
- StormCAD V8i projects associated with ProjectWise appear in the Most Recently Used Files list (at the bottom of the File menu) in the following format: pwname://PointServer:_TestDatasource/Documents/TestFolder/Test1.prj
Performing ProjectWise Operations from within StormCAD V8i

You can quickly tell whether or not the current StormCAD V8i project is in ProjectWise or not by looking at the title bar and the status bar of the StormCAD V8i window. If the current project is in ProjectWise, “pwname://” will appear in front of the file name in the title bar, and a ProjectWise icon will appear on the far right side of the status bar, as shown below.

You can perform the following ProjectWise operations from within StormCAD V8i:

To save an open StormCAD V8i project to ProjectWise

3. In StormCAD V8i, select File > ProjectWise > Save As.
4. If you haven’t already logged into ProjectWise, you are prompted to do so. Select a ProjectWise datasource, type your ProjectWise user name and password, then click Log in.
5. In the ProjectWise Save Document dialog box, enter the following information:
   a. Click Change next to the Folder field, then select a folder in the current ProjectWise datasource in which to store your project.
   b. Type the name of your StormCAD V8i project in the Name field. We recommend that you keep the ProjectWise name the same as or as close to the StormCAD V8i project name as possible.
   c. Keep the default entries for the rest of the fields in the dialog box.
   d. Click OK.

To open a StormCAD V8i project from a ProjectWise datasource

1. Select File > ProjectWise > Open.
2. If you haven’t already logged into ProjectWise, you are prompted to do so. Select a ProjectWise datasource, type your ProjectWise user name and password, then click Log in.
3. In the ProjectWise Select Document dialog box, perform these steps:
   a. From the Folder drop-down menu, select a folder that contains StormCAD V8i projects.
   b. In the Document list box, select a StormCAD V8i project.
   c. Keep the default entries for the rest of the fields in the dialog box.
   d. Click Open.
To copy an open StormCAD V8i project from one ProjectWise datasource to another

1. Select File > ProjectWise > Open to open a project stored in ProjectWise.
2. Select File > ProjectWise > Change Datasource.
3. In the ProjectWise Log in dialog box, select a different ProjectWise datasource, then click Log in.
4. Select File > ProjectWise > Save As.
5. In the ProjectWise Save Document dialog box, change information about the project as required, then click OK.

To make a local copy of a StormCAD V8i project stored in a ProjectWise datasource

1. Select File > ProjectWise > Open.
2. If you haven’t already logged into ProjectWise, you are prompted to do so. Select a ProjectWise datasource, type your ProjectWise user name and password, then click Log in.
3. Select File > Save As.
4. Save the StormCAD V8i project to a folder on your local computer.

To change the default ProjectWise datasource

1. Start StormCAD V8i.
2. Select File > ProjectWise > Change Datasource.
3. In the ProjectWise Log in dialog box, type the name of ProjectWise datasource you want to log into, then click Log in.

To use background layer files with ProjectWise

- Using File > ProjectWise > Save As—If there are background files, you are prompted with two options: you can copy the background layer files to the project folder for use by the project, or you can remove the background references and manually reassign them once the project is in ProjectWise to other existing ProjectWise documents.
- Using File > ProjectWise > Open—This works the same as the normal ProjectWise > Open command, except that background layer files are not locked in ProjectWise for the current user to edit. The files are intended to be shared with other users at the same time.
**Starting a Project**

**To add a background layer file reference to a project that exists in ProjectWise**

- Using File > Save As—When you use File > Save As on a project that is already in ProjectWise and there are background layer files, you are prompted with two options: you can copy all the files to the local project folder for use by the project, or you can remove the background references and manually reassign them after you have saved the project locally.

**Note:** When you remove a background layer file reference from a project that exists in ProjectWise, the reference to the file is removed but the file itself is not deleted from ProjectWise.

**Using ProjectWise with StormCAD V8i for AutoCAD**

StormCAD V8i for AutoCAD maintains a one to one relationship between the AutoCAD drawing (.dwg) and the StormCAD V8i project file. When using ProjectWise with this data, we recommend that you create a Set in the ProjectWise Explorer. Included in this set should be the AutoCAD drawing (example.dwg), the StormCAD V8i database (example.stc.mdb), the StormCAD V8i project file (example.stc), and optionally for stand-alone, the stand-alone drawing setting file (example.stc.dwh).

If you use the Set and the ProjectWise Explorer for all of your check-in / check-out procedures, you will maintain the integrity of this relationship. We recommend that you do not use the default ProjectWise integration in AutoCAD, as this will only work with the .dwg file.

**About ProjectWise Geospatial**

ProjectWise Geospatial gives spatial context to Municipal Products Group product projects in their original form. An interactive map-based interface allows users to navigate and retrieve content based upon location. The environment includes integrated map management, dynamic coordinate system support, and spatial indexing tools.

ProjectWise Geospatial supports the creation of named spatial reference systems (SRSs) for 2D or 3D cartesian coordinate systems, automatic transformations between SRSs, creation of Open GIS format geometries, definition of spatial locations, association of documents and folders with spatial locations, and the definition of spatial criteria for document searching.

A spatial location is the combination of a geometry for a project plus a designated SRS. It provides a universal mechanism for graphically relating ProjectWise documents and folders.
The ProjectWise administrator can assign background maps to folders, against which the contained documents or projects will be registered and displayed. For documents such as Municipal Products Group product projects, ProjectWise Geospatial can automatically retrieve the embedded spatial location. For documents that are nonspatial, the document can simply inherit the location of the folder into which it is inserted, or users can explicitly assign a location, either by typing in coordinates, or by drawing them.

Each document is indexed to a universal coordinate system or SRS, however, the originating coordinate system of each document is also preserved. This enables search of documents across the boundary of different geographic, coordinate, or engineering coordinate systems.

Custom geospatial views can be defined to display documents with symbology mapped to arbitrary document properties such as author, time, and workflow state.

For a complete description of how to work with ProjectWise Geospatial, for example how to add background maps and coordinate systems, see the ProjectWise Geospatial Explorer Guide and the ProjectWise Geospatial Administrator Guide.

**Maintaining Project Geometry**

A spatial location is comprised of an OpenGIS-format geometry plus a Spatial Reference System (SRS). For Municipal Products Group product projects, the product attempts to automatically calculate and maintained this geometry, as the user interacts with the model. Most transformations such as additions, moves, and deletes result in the bounding box or drawing extents being automatically updated.

Whenever the project is saved and the ProjectWise server is updated, the stored spatial location on the server, which is used for registration against any background map, will be updated also. (Note the timing of this update will be affected by the "Update Server When Saving" option on the Tools-Options-ProjectWise tab.)

Most of the time the bounding box stored in the project will be correct. However, for performance reasons, there are some rare situations (e.g., moving the entire model) where the geometry can become out of date with respect to the model. To guarantee the highest accuracy, the user can always manually update the geometry by using "Compact Database" or "Update Database Cache" as necessary, before saving to ProjectWise.

**Setting the Project Spatial Reference System**

The Spatial Reference System (SRS) for a project is viewed and assigned on the Tools-Options-Project tab in the Geospatial group.
The SRS is a standard textual name for a coordinate system or a projection, designated by various national and international standards bodies. The SRS is assumed to define the origin for the coordinates of all modeling elements in the project. It is the user's responsibility to set the correct SRS for the project, and then use the correct coordinates for the contained modeling elements. This will result in the extents of the modeling features being correct with respect to the spatial reference system chosen. The SRS is stored at the project database level. Therefore, a single SRS is maintained across all geometry alternatives. The product does not manipulate or transform geometries or SRS's - it simply stores them.

The primary use of the project's SRS is to create correct spatial locations when managing a project in the ProjectWise Integration Server's spatial management system.

The SRS name comes from the internal list of spatial reference systems that ProjectWise Spatial maintains on the ProjectWise server and is also known as the "key name." To determine the SRS key name, the administrator should browse the coordinate system dictionary in the ProjectWise administrator tool (under the Coordinate Systems node of the datasource), and add the desired coordinate system to the datasource. For example, the key name for an SRS for latitude/longitude is LL84, and the key name for the Maryland State Plane NAD 83 Feet SRS is MD83F.

ProjectWise Spatial uses the SRS to re-project the project's spatial location to the coordinate system of any spatial view or background map assigned by the administrator.

If the project's SRS is left blank, then ProjectWise will simply not be updated with a spatial location for that project.

If the project's SRS is not recognized, an error message will be shown, and ProjectWise will simply not be updated with a spatial location for that project.

**Interaction with ProjectWise Explorer**

Geospatial Administrators can control whether users can edit spatial locations through the ProjectWise Explorer. This is governed by the checkbox labeled "This user is a Geospatial Administrator” on the Geospatial tab of the User properties in the ProjectWise Administrator.

Users should decide to edit spatial locations either through the ProjectWise Explorer, or through the Municipal application, but not both at the same time. The application will update and overwrite the spatial location (coordinate system and geometry) in ProjectWise as a project is saved, if the user has added a spatial reference system to the project. This mechanism is simple and flexible for users - allowing them to choose when and where spatial locations will be updated.
**5.1.5 Importing Data From Other Models**

**Importing Submodels**

**Importing LandXML Files**

**Importing Data from a StormCAD V8i Database**

**GEOPAK/PowerCivil Drainage File**

**Importing a Bentley InRoads Storm and Sanitary V8i Model into StormCAD**

**Importing/Exporting Micro Drainage Files**

**Import / Export Bentley MX Drainage (LandXML Format)**

**Importing Submodels**

Using the Submodel Import feature, you can import another model, or any portion thereof, into your project. Input data stored in the Alternatives as well as any supporting data (i.e. Patterns, etc) will also be imported. It is important to notice that existing elements in the model you want to import the submodel into (i.e. the target model) will be matched with incoming elements by using their label. Incoming input data will override existing data in the target model for any element matched by its label. That also applies to scenarios, alternatives, calculation options and supporting data. Furthermore, any element in the incoming submodel that could not be matched with any existing element by their label, will be created in the target model.

For example, the submodel you want to import contains input data that you would like to transfer in two Physical Alternatives named "Smaller Conduits" and "Larger Conduits". The target model contains only one Physical Alternative named "Larger Conduits". In that case, the input data in the alternative labeled "Larger Conduits" in the submodel will replace the alternative with the same name in the target model. Moreover, the alternative labeled "Smaller Conduits" as well as its input data will be added to the target model without replacing any existing data on it because there is no existing alternative with the same label. Notice that imported elements will be assigned default values in those existing alternatives in the target model that could not be matched.

Notice that regular models can be imported as a submodel of a larger model as their file format and extension are the same.
For more information about input data transfer, see [Exporting a Submodel](#).

The label-matching strategy used during submodel import will be applied to any set of alternatives, including Active Topology alternatives. Therefore, if no Active Topology alternative stored in the submodel matches the existing ones in the target model, the imported elements will preserve their active topology values in the alternatives created from the submodel, but they will be left as "Inactive" in those previously existing alternatives in the target model. That is because the default value for the "Is Active" attribute in active topology alternatives other than the one that is current is "False".

**Note:** User-defined data is not transferred during submodel import and export operations.

**To import a submodel**

1. Click the File menu and select Import...Submodel.
2. In the Select Submodel File to Import dialog box, select the submodel file to be imported. Click the Open button.

**Importing LandXML Files**

You can import a model from a LandXML format .xml file. LandXML is a non-proprietary data standard for the persistence of civil engineering and survey measurement data commonly used in the Land Development and Transportation Industries.

StormCAD utilizes the PipeNetworks functionality of the LandXML file. StormCAD is primarily concerned with the overall physical structure and connectivity of the pipe network; hence some of the available hydrologic and hydraulic data necessary for a hydraulic analysis is not transferred during export/import.

The following table describes the fundamental mappings between StormCAD elements and their LandXML analogs for both import and export to and from StormCAD.

**Table 5-1: LandXML to StormCAD Mappings**

<table>
<thead>
<tr>
<th>LandXML</th>
<th>StormCAD Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Struct - RectStruct</td>
<td>Manhole</td>
</tr>
<tr>
<td>Struct - CircStruct</td>
<td>Manhole</td>
</tr>
</tbody>
</table>
Table 5-1: LandXML to StormCAD Mappings

<table>
<thead>
<tr>
<th>LandXML</th>
<th>StormCAD Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Struct - Outlet</td>
<td>Outfall</td>
</tr>
<tr>
<td>Struct - Inlet</td>
<td>Catch Basin</td>
</tr>
<tr>
<td>Struct - Connection</td>
<td>Transition</td>
</tr>
<tr>
<td>Pipe</td>
<td>Conduit</td>
</tr>
</tbody>
</table>

To import a LandXML .xml file:

1. Select **File > Import > LandXML**.
2. In the **Select LandXML File to Import** dialog, browse to the LandXML file to be imported, highlight it, and click **Open**.

Importing Data from a StormCAD V8i Database

You can import a StormCAD V8i database file, which will create a new model using the data in the database.

To import a StormCAD V8i Database

1. Click the File menu, select Import, then choose StormCAD V8i Database from the submenu.
2. Browse to and highlight the stc.mdb file to import.
3. Click Open.

GEOPAK/PowerCivil Drainage File

In StormCAD V8i, support has been added to import and export GEOPAK/PowerCivil Drainage File project data. StormCAD leverages the GEOPAK/PowerCivil V8i for Americas runtime, so this support is only available in MicroStation with a GEOPAK license or in PowerCivil V8i for Americas. Import and export of GeoPAK drainage files only works in an integrated environment of StormCAD/GeoPAK/MicroStation.

A GEOPAK/PowerCivil drainage project consists of three files:

1. GPF file for drainage preferences
2. DLB file which is the drainage library
3. GDF file which contains the drainage project data
As with any independent set of applications, there is not a perfect mapping of the data from one system to the other. The differences are described below.

**Importing GEOPAK/PowerCivil Drainage Files**

**Keyin:** stormcad project importgeopak

You can create a StormCAD model by importing a GEOPAK/PowerCivil Drainage project. If you are in the same DGN file that contains the element references to the GEOPAK/PowerCivil drainage file, the geometries for the areas and links will be derived from the MicroStation elements. If not, then the geometries will be limited to whatever is available in the GDF file.

StormCAD utilizes the following mappings between GEOPAK/PowerCivil V8i for Americas for importing:
### Starting a Project

**Note:** For grate in sag, the length and width for StormCAD are computed from the grate area and perimeter.

#### Conduit Catalog

<table>
<thead>
<tr>
<th>Type</th>
<th>Rise</th>
<th>Span</th>
<th>STMC does NO I have an Arch type imported as Pipe Arch.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arch</td>
<td>Rise</td>
<td>Span</td>
<td>Rise</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Span</td>
</tr>
<tr>
<td>Box</td>
<td>Rise</td>
<td>Span</td>
<td>Rise</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Span</td>
</tr>
<tr>
<td>Circular</td>
<td>Rise</td>
<td></td>
<td>Diameter</td>
</tr>
<tr>
<td>Pipe Arch</td>
<td>Rise</td>
<td>Span</td>
<td>Top Radius</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Bottom Radius</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Corner Radius</td>
</tr>
<tr>
<td></td>
<td>Center Height (B)</td>
<td></td>
<td>Bottom Distance</td>
</tr>
<tr>
<td>Ellipse</td>
<td>Rise</td>
<td>Span</td>
<td>Rise</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Span</td>
</tr>
</tbody>
</table>
For the elements the following mappings are used:

<table>
<thead>
<tr>
<th>GeoPAK</th>
<th>STMC</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Catchments</strong></td>
<td></td>
</tr>
<tr>
<td>Drainage Area</td>
<td>Area</td>
</tr>
<tr>
<td>Base C Value</td>
<td>Rational C</td>
</tr>
<tr>
<td>Time of Cone.</td>
<td>Time of Concentration</td>
</tr>
<tr>
<td>SubArea</td>
<td></td>
</tr>
<tr>
<td>SubArea</td>
<td></td>
</tr>
<tr>
<td>C Value</td>
<td>Rational C</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Description</th>
<th>NOT INSTMC</th>
</tr>
</thead>
<tbody>
<tr>
<td>ToNode 10</td>
<td>Outflow Node</td>
</tr>
<tr>
<td>TC Method (by checkbox)</td>
<td></td>
</tr>
<tr>
<td>SheetFlow</td>
<td></td>
</tr>
<tr>
<td>FHA Method</td>
<td></td>
</tr>
<tr>
<td>FHA : Length</td>
<td></td>
</tr>
<tr>
<td>FHA : n Value</td>
<td></td>
</tr>
<tr>
<td>FHA : Slope</td>
<td></td>
</tr>
<tr>
<td>FAA Method</td>
<td></td>
</tr>
<tr>
<td>FAA : Length</td>
<td></td>
</tr>
<tr>
<td>FAA : n Value</td>
<td></td>
</tr>
<tr>
<td>FAA : Slope</td>
<td></td>
</tr>
<tr>
<td>Seelye Method</td>
<td></td>
</tr>
<tr>
<td>Seelye : Length</td>
<td></td>
</tr>
<tr>
<td>Seelye : Slope</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Components</th>
<th>NOT INSTMC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shallow Flow</td>
<td></td>
</tr>
<tr>
<td>Inter K</td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td></td>
</tr>
<tr>
<td>Slope</td>
<td></td>
</tr>
<tr>
<td>Concentrated Flow</td>
<td></td>
</tr>
<tr>
<td>TR-55 Shallow Concentrated Flow</td>
<td></td>
</tr>
<tr>
<td>TR-55 Channel Flow</td>
<td></td>
</tr>
</tbody>
</table>

| Concentrated Flow            |            |
| Continuity Method            |            |
| TR-55 Channel Flow           |            |
| Continuity : Length          |            |
| Velocity                     |            |
| Kirpich Method               |            |
| Kirpich : Length             |            |
| Kirpich : Height             |            |
| above outlet                 |            |

| NOT INSTMC                   |            |
|                             |            |
|                             |            |
|                             |            |
Starting a Project
### Nodes

<table>
<thead>
<tr>
<th>Item ID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pay Item</td>
<td>Criteria File</td>
</tr>
<tr>
<td>Prof ile Type</td>
<td>On Grade and Sag</td>
</tr>
<tr>
<td>Library Item</td>
<td>(Reference Field)</td>
</tr>
<tr>
<td>Max By Pass Elevat on</td>
<td>Source :User Supplied : Elevat on</td>
</tr>
<tr>
<td>Vertical Alignment</td>
<td>Vertical Alignment</td>
</tr>
<tr>
<td>Match Invert</td>
<td>Match Invert</td>
</tr>
<tr>
<td>Vertical Alignment</td>
<td>Match SoftFit</td>
</tr>
<tr>
<td>Vertical Alignment</td>
<td>Match Surface Vertical</td>
</tr>
<tr>
<td>Allow Drop Manhole Vertica l</td>
<td>Allow Drop</td>
</tr>
<tr>
<td>e</td>
<td>on</td>
</tr>
<tr>
<td>MinFixed Drop?</td>
<td>e</td>
</tr>
<tr>
<td>Vertical Alignment</td>
<td>Match Centerline</td>
</tr>
<tr>
<td>Minimum Depth</td>
<td>Maximu m Depth</td>
</tr>
<tr>
<td>Add Sump Depth?</td>
<td>Sump Depth</td>
</tr>
<tr>
<td>Discharge Is Supplied</td>
<td>Discharge? Supplied Discharge Is Disable</td>
</tr>
<tr>
<td>Inlet calculations ?</td>
<td>Inlet</td>
</tr>
<tr>
<td>capacity</td>
<td>NOT INSTM C</td>
</tr>
</tbody>
</table>

---

**Creating Models**

<table>
<thead>
<tr>
<th>Item ID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notes</td>
<td>NOT INSTM C (User Defined Field)</td>
</tr>
<tr>
<td>Note</td>
<td>Design: Pipe Matching: Allow Drop</td>
</tr>
<tr>
<td>Pipe Matching: Allow Drop Inverts Structure = FALSE</td>
<td>Note: Design: Pipe Matching: Crowns</td>
</tr>
<tr>
<td>Node: Design: Pipe Matching: e on</td>
<td>Node: Design: Pipe Matching: e on</td>
</tr>
<tr>
<td>Node: Design: Min Fixed Drop?</td>
<td>Node: Design: Matchline Offset</td>
</tr>
<tr>
<td>Node: Design: e on (Invert)</td>
<td>Node: Design: Matchline Offset</td>
</tr>
<tr>
<td>Node: Design: (Invert)</td>
<td>Node: Design: Matchline Offset</td>
</tr>
<tr>
<td>Node: Design: e on</td>
<td>Node: Design: Matchline Offset</td>
</tr>
<tr>
<td>Node: Design: e on</td>
<td>Node: Design: Matchline Offset</td>
</tr>
<tr>
<td>Node: Design: e on</td>
<td>Node: Design: Matchline Offset</td>
</tr>
<tr>
<td>Node: Design: e on</td>
<td>Node: Design: Matchline Offset</td>
</tr>
</tbody>
</table>

---

**Bentley SormCAD V8i** 5-217
.... starting a Project

Spread Source (Referenced)
Spread:

a-

Catch Basin:Depressed Guter?= TRUE

Slope

Catch Basin:Gutter Cross Slope

Width

Catch Basin:Gutter Width

Roughness

Composite Spread Collection

a-

NOT INSTMC

LongitidinalSlope

NOT IN STMC (User Notification)
LongitudinalSlope

Maximum Pond Depth

Maximum Depth In Sag

Specify LocalInlet

Maximum Pond Width

Maximum Spread In Sag

Constraints? Specify

Derived: Corresponding inlet type dimension

Structure Wid th

Derived: Corresponding inlet type dimension

Structure Length

Defined Equation;
Equations x Loss Reduction

NOT INSTMC NOT
INSTMC

Absolute Loss

Headlo;;Method:

Supplied K - Outlet Velocity

Absolute Headless

Supplied K - Change in Velocity

Method: Sta nda rd

LocalInlet Constraints?

HeadlessMethod: Generic
None

5-218

Absolute Headless

Headless Coeff icien t (Sta nda rd)
Headless Coefficient (Upstream)

STMC doesn't have NONE option.but set to Absolute.
With Absolute Headless = 0

Bentley stormCAD V8i


Note: For junction loss equations and reduction, the StonnCAD method will be set to Absolute with a loss value of 0.

<table>
<thead>
<tr>
<th>Pieces</th>
<th>Roughness</th>
<th>Trench Details</th>
<th>Manholes</th>
<th>NOT INSTMC</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>a</td>
<td>b</td>
<td>c</td>
<td></td>
</tr>
<tr>
<td></td>
<td>d</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of Barrels</td>
<td></td>
<td>Number of Barrels</td>
<td>Material</td>
<td>Material</td>
</tr>
<tr>
<td>Material</td>
<td></td>
<td>Conduit Description</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Design Size?</td>
<td></td>
<td>Is Design Conduit?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Design Barrels?</td>
<td></td>
<td>Is Design Conduit?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Minimum Rise</td>
<td></td>
<td>Base Design Field: Allow Multiple barrels?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum Rise</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Minimum Slope</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum Slope</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Minimum Velocity</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum Velocity</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Starting a Project

Ditch Type: Fixed Geometry

Ditch Width

Side Slope Ratio

Left

Right

Ditch Bottom Width

Left Side Slope

Right Side Slope

Ditch Type: Cross Section Based

Number of Cross Sections

Width of Cross Sections

NOT INSTMC- User Notification

Outlet

Fix Tailwater At:

Fixed Tailwater At:

Tailwater Elevation

Soffit

Uniform Depth

Critical Depth

Boundary Condition Type:

Crown

Boundary Condition Type:

Free Outfall

Boundary Condition Type:

Free Outfall

Boundary Condition Type:

Elevation

User Defined

(Tailwater)
Creating Models

For miscellaneous project options:

Other values that may not necessarily map directly into StormCAD are brought in as User Defined Attributes. Some of these attributes include Network Name, Pay Items and Pay Item Descriptions. These attributes can be used in FlexTables, Queries and Reports in StormCAD V8i.

**Exporting to GEOPAK/PowerCivil Drainage Files**

Keyin: stormcad project exportgeopak

You can create update a GEOPAK/PowerCivil Drainage File library and drainage file using this command. If the StormCAD project was created using GEOPAK/PowerCivil V8i for Americas import, you will be prompted if you want to synchronize back to those files. Otherwise, you can create these files from scratch.

Note that you are prompted for two files, first is the DLB or Drainage Library in GEOPAK, second is the GDF or GEOPAK drainage file. There are also no MicroStation elements created from this export command, only the file data is written.

The mapping is the inverse of that described above.

**Additional**

Keyin: stormcad project importgeopaklibrary
Keyin: stormcad project exportgeopaklibrary

There are two additional commands available as keyins only. You can import and export only library data (storm data, conduits catalogs and inlet catalogs) using these commands.

Importing a Bentley InRoads Storm and Sanitary V8i Model into StormCAD

The following tables describe how various InRoads element attributes are mapped to their StormCAD counterparts.

All Links

<table>
<thead>
<tr>
<th></th>
<th>InRoads</th>
<th>StormCAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>PipeID</td>
<td>Label</td>
</tr>
<tr>
<td></td>
<td>PipeID is a string</td>
<td>Start Node</td>
</tr>
<tr>
<td>2</td>
<td>Upstream ID</td>
<td>Start Node is set to ID of the node</td>
</tr>
<tr>
<td></td>
<td>A Upstream ID = &lt;Some Node ID&gt;</td>
<td>Create and reference a Catchbasin w/100% capture</td>
</tr>
<tr>
<td></td>
<td>B Upstream ID = FREE_ENT</td>
<td>Create and reference a transition node with dimensions equivalent to the largest pipe.*** On export to InRoads, this StormCAD transition node data will be lost</td>
</tr>
<tr>
<td></td>
<td>C Upstream ID = &lt;Some Pipe ID&gt;</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Downstream ID</td>
<td>Stop Node</td>
</tr>
<tr>
<td></td>
<td>A Downstream ID = &lt;Some Node ID&gt;</td>
<td>Stop Node is set to ID of the node</td>
</tr>
<tr>
<td></td>
<td>B Downstream ID = FREE_ENT</td>
<td>Create and reference an Outfall w/ a Boundary Condition set to Free Outfall.*** On export, if a SIMCLink has any outfall downstream,</td>
</tr>
<tr>
<td></td>
<td>C Downstream ID = &lt;Some Pipe ID&gt;</td>
<td>Create and reference a transition node with dimensions equivalent to the largest pipe.*** On export to InRoads, this StormCAD transition node data will be lost</td>
</tr>
</tbody>
</table>
### InRoads

<table>
<thead>
<tr>
<th>Pipe ID</th>
<th>Upstream ID</th>
<th>Downstream ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>P71</td>
<td></td>
<td>P74</td>
</tr>
<tr>
<td>T</td>
<td></td>
<td>T</td>
</tr>
</tbody>
</table>

### StormCAD

<table>
<thead>
<tr>
<th>Invert</th>
<th>EitherUserInput</th>
<th>Derived</th>
<th>Invert (Downstream)</th>
<th>Invert (Upstream)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>4</strong></td>
<td><strong>Invert</strong></td>
<td><strong>Derived</strong></td>
<td></td>
<td><strong>Sets the upstream invert, and then make “Set Invert to Upstream?” = False.</strong></td>
</tr>
<tr>
<td><strong>1</strong></td>
<td><strong>Invert Out</strong></td>
<td><strong>Derived</strong></td>
<td></td>
<td><strong>Sets the downstream invert, and then make “Set Invert to Downstream?” = False.</strong></td>
</tr>
</tbody>
</table>
### InRoads vs. StormCAD

<table>
<thead>
<tr>
<th>6</th>
<th>Plan length</th>
<th>StormCAD</th>
<th><strong>InRoads</strong></th>
<th>StormCAD</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Horizontal center to center measurement along length of polygons including bends.</td>
<td>length (Scaled)</td>
<td></td>
<td>Equiv to plan length, measured based on the x,y end node coordinates and bend in the drawing. Unless user defined length is opted for, this is the length StormCAD uses in calculations.</td>
</tr>
<tr>
<td>7</td>
<td>Pipe length</td>
<td>StormCAD</td>
<td>StormCAD</td>
<td>Measured from the outside of the structure</td>
</tr>
<tr>
<td>8</td>
<td>Slope</td>
<td>StormCAD</td>
<td>StormCAD</td>
<td>Either user input or derived.</td>
</tr>
<tr>
<td>9</td>
<td>Roughness</td>
<td>StormCAD</td>
<td>StormCAD</td>
<td>Manning's n coeff.</td>
</tr>
<tr>
<td>10</td>
<td>Material</td>
<td>StormCAD</td>
<td>StormCAD</td>
<td>InRoads library reference. Upon selection, roughness value is set/updated.</td>
</tr>
<tr>
<td>11</td>
<td>Structure Status</td>
<td>StormCAD</td>
<td>StormCAD</td>
<td>User can declare a link as fixed in size or resizable.</td>
</tr>
</tbody>
</table>

| A | Fixed | Design Conduit? = False |
| B | Resize | Design Conduit? = True, Design Start Invert? = True, Design Stop Invert? = True? On import, other design options are not explicitly set. On export, the InRoads attribute Resize takes on the value of Design Conduit?, the other StormCAD design specifications are lost during round trip. |
## Channels

<table>
<thead>
<tr>
<th></th>
<th>InRoads</th>
<th>StormCAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 A</td>
<td>Channel Type: V-Shaped</td>
<td>Conduit Type = User Defined Conduit</td>
</tr>
<tr>
<td></td>
<td>InRoads: Triangular channel shape. Note that for V-Shaped only one side slope can be Vertical.</td>
<td>Conduit Shape = Trapezoidal Channel</td>
</tr>
<tr>
<td></td>
<td>StormCAD will model V-shaped as a Trapezoidal Channel shape in StormCAD. Span will be derived. If an InRoads side slope is Vertical, then the corresponding side slope in StormCAD is set with value of infinity. <strong>On export, InRoads V-shaped will be reverse engineered in a similar fashion.</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Left Side Slope</td>
<td>Rise, Span</td>
</tr>
<tr>
<td></td>
<td>Right Side Slope</td>
<td></td>
</tr>
<tr>
<td>12 A</td>
<td>Channel Type: Trapezoidal</td>
<td>Conduit Type = User Defined Conduit</td>
</tr>
<tr>
<td></td>
<td>InRoads: Trap. channel shape. Note that for Trapezoidal shape, both side slopes can be Vertical.</td>
<td>Conduit Shape = Trapezoidal Channel</td>
</tr>
<tr>
<td></td>
<td>Left Side Slope</td>
<td>If an InRoads side slope is User Value, the value maps directly. If it is Vertical, then both the corresponding side slopes are set with value of infinity. <strong>On export, InRoads V-shaped will be reverse engineered in a similar fashion.</strong></td>
</tr>
<tr>
<td></td>
<td>Right Side Slope</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bottom Width</td>
<td>Bottom Width</td>
</tr>
<tr>
<td></td>
<td>Maximum Depth</td>
<td>Rise</td>
</tr>
<tr>
<td>12 C</td>
<td>Channel Type: Rectangular</td>
<td>Conduit Catalog Reference</td>
</tr>
<tr>
<td></td>
<td>InRoads: Rectangular channel shape.</td>
<td>A Conduit Catalog instance will be created for each uniquely defined set of Rectangular channel dimensions.</td>
</tr>
<tr>
<td></td>
<td>Bottom Width</td>
<td>Span</td>
</tr>
<tr>
<td></td>
<td>Maximum Depth</td>
<td>Rise</td>
</tr>
</tbody>
</table>
### Starting a Project

Nodes

<table>
<thead>
<tr>
<th></th>
<th>InRoads</th>
<th>StormCAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>12</td>
<td>Connection Point</td>
<td>StormCAD implicitly supports inside only, N/A</td>
</tr>
<tr>
<td>13</td>
<td>Angle</td>
<td>Deflection angle of node centerline relative to the active horizontal alignment, Bend Angle, Maps to the downstream pipe's &quot;Bend Angle (Calculated)&quot; in StormCAD.</td>
</tr>
<tr>
<td>14</td>
<td>Elevation/Rim Elevation</td>
<td>Top elevation of the node, Rim Elevation, &quot;Set Invert to Ground?&quot; not touched.</td>
</tr>
<tr>
<td>15</td>
<td>Maximum Depth</td>
<td>elevation difference between top/rim and sump/invert, Elevation (Invert), Infer a StormCAD node's invert elevation based on InRoads fields: Max Depth and Depth below Invert.</td>
</tr>
<tr>
<td>16</td>
<td>Depth below Invert</td>
<td>depth of the node below the lowest invert elevation of adjoining structures, Top Height, UDX field maps directly for round trip data preservation.</td>
</tr>
<tr>
<td>17</td>
<td>Top Height</td>
<td>The amount of vault that is dipped from the vault's top, Top Height (UDX)</td>
</tr>
</tbody>
</table>
## Manholes

<table>
<thead>
<tr>
<th>34</th>
<th>Manhole Type</th>
<th>Pick one of 3 structure shape types.</th>
<th>TBD</th>
<th>Manhole UDX Field needed</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Manhole Type = Circular</td>
<td>Structure Type = Circular Structure</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Size: W</td>
<td>W refers to diameter dimension.</td>
<td>Diameter</td>
<td></td>
</tr>
<tr>
<td>B</td>
<td>Manhole Type = Box</td>
<td>Structure Type = Box Structure</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Size: W</td>
<td>W refers to diameter dimension.</td>
<td>Width</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Size: L</td>
<td>W refers to diameter dimension.</td>
<td>length</td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>Manhole Type = Cone</td>
<td>Structure Type = Circular Structure?</td>
<td>Only lengths imported into StormCAD.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Size: W</td>
<td>W refers to diameter dimension.</td>
<td>Width</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Size: H</td>
<td>W refers to diameter dimension.</td>
<td>RimElevation</td>
<td></td>
</tr>
<tr>
<td>35</td>
<td>User-Specified Headloss</td>
<td>Boolean</td>
<td>Absolute Headloss</td>
<td></td>
</tr>
<tr>
<td>36</td>
<td>Headloss</td>
<td>elevation</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### All Inlets

<table>
<thead>
<tr>
<th></th>
<th>InRoads</th>
<th>StormCAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>18</td>
<td><strong>Vault Size:</strong>[ ] Structure Length: Length also considered the diameter of circular shaped inlet structures: Curb Opening and Median Drop.</td>
<td>StormCAD Profiling references these Catalog Inlet dimensions.</td>
</tr>
<tr>
<td>19</td>
<td><strong>Vault Size:</strong>[ ] Structure width. Applies only to Box shaped structures: Grate, Combo, catchpit.</td>
<td>StormCAD Profiling references these Catalog Inlet dimensions. Assume a default value for InRoads Inlet Types not supporting this?</td>
</tr>
<tr>
<td>21</td>
<td><strong>A Orientation = Perpendicular to Alignment</strong></td>
<td>Placement Offset, ConnectionPoint, Angle Data preserved through UDX fields.</td>
</tr>
<tr>
<td>21</td>
<td><strong>B Orientation = Parallel to Alignment</strong></td>
<td>Placement Offset, ConnectionPoint, Angle Data preserved through UDX fields.</td>
</tr>
<tr>
<td>23</td>
<td><strong>C Orientation = Angle</strong> User defined angle.</td>
<td>CloggingFactor Maps directly to Catch Basin attribute.</td>
</tr>
<tr>
<td>24</td>
<td><strong>A Location = On-Grade</strong></td>
<td>OnGrade</td>
</tr>
<tr>
<td>24</td>
<td><strong>B Location = Sump</strong></td>
<td>InSag</td>
</tr>
<tr>
<td></td>
<td><strong>Sump: Stand Height</strong> For In Sags Inlets, user can declare the height of the top edge of the inlet above the existing ground surface</td>
<td>Stored as UDX field.</td>
</tr>
</tbody>
</table>
## Grate Inlets

<table>
<thead>
<tr>
<th>Class and Inlet Type</th>
<th>Inlet Type</th>
<th>Inlet Type</th>
<th>Catalog Inlet Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grate size: L</td>
<td>Inlet Type = Grate</td>
<td>Inlet Type = Grate</td>
<td>Catalog Inlet Type = Grate</td>
</tr>
<tr>
<td></td>
<td>Physical grate length opening dimension. Applicable to all inlet types except Curb Opening.</td>
<td></td>
<td>Default Grate Length, Grate Length</td>
</tr>
<tr>
<td>Grate size: W</td>
<td>Grate Width</td>
<td>Grate Width</td>
<td>Within the Catalog Inlet definition.</td>
</tr>
</tbody>
</table>

## Curb Inlets

<table>
<thead>
<tr>
<th>Inlet Type = Curb Opening</th>
<th>Inlet Type = Curb only.</th>
<th>Inlet Type = Curb</th>
<th>Catalog Inlet Type = Curb</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening Length</td>
<td>Specific to a Curb Opening type, the physical length of the curb opening.</td>
<td>Default Curb Opening Length, Curb Opening Length</td>
<td>Maps to both the Inlet Catalog field ‘Default Curb Opening Length’ and the Catch Basin attribute ‘Curb Opening Length’</td>
</tr>
<tr>
<td>Depression</td>
<td>InRoads Inlet attribute. Applies to Curb Opening and Combination Inlet types only.</td>
<td>Local Depression</td>
<td>Catalog Inlet attribute that applies to Curb Opening and Combination Inlet types only.</td>
</tr>
</tbody>
</table>

25 C Inlet Type = Combination | Grate and Curb. | Inlet Type = Combination | Catalog Inlet Type = Combination |
## Starting a Project

### Other Inlets (Unique to InRoads)

<table>
<thead>
<tr>
<th>#</th>
<th>Type</th>
<th>Inlet Type</th>
<th>Inlet Type when Culvert is connected</th>
<th>Mapped to Grate in StormCAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>25</td>
<td>D</td>
<td>Median Drop</td>
<td>Grate</td>
<td>Grate</td>
</tr>
<tr>
<td>25</td>
<td>E</td>
<td>Catchpit</td>
<td>Grate</td>
<td>Grate</td>
</tr>
</tbody>
</table>

### All Gutters

<table>
<thead>
<tr>
<th>#</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>26</td>
<td>Roughness</td>
<td>Manning's n coeff</td>
</tr>
<tr>
<td>27</td>
<td>Location</td>
<td>Inlet Location</td>
</tr>
<tr>
<td>28</td>
<td>Bypass Interceptor ID</td>
<td>Gutter: Stop Node</td>
</tr>
</tbody>
</table>

**CatchBasin attribute. Roughness coeff for the roadway, StormCAD assumes road cross slope and gutter cross slope has same roughness.**

### Uniform Gutters

<table>
<thead>
<tr>
<th>#</th>
<th>Gutter Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>33</td>
<td>Uniform</td>
<td>When InRoads Gutter type is Uniform you define the Depression Width of the Curb Opening</td>
</tr>
</tbody>
</table>

**Catalog Inlet attribute. Applies to Curb Opening and Combination Inlet types only.**

<table>
<thead>
<tr>
<th>#</th>
<th>Gutter Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>33</td>
<td>Depression</td>
<td>When InRoads Gutter type is Uniform you define the Depression Width of the Curb Opening</td>
</tr>
</tbody>
</table>

**Catalog Inlet attribute. Applies to Curb Opening and Combination Inlet types only.**

<table>
<thead>
<tr>
<th>#</th>
<th>Gutter Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>33</td>
<td>Depression</td>
<td>InRoads Gutter attribute only applicable when Upstream Inlet type = Curb Opening and Gutter Type = Uniform or Composite</td>
</tr>
</tbody>
</table>

**If Depression is 0, then StormCAD sets ‘Depressed Gutter’ = False. Otherwise set value of True, and derives values for StormCAD attributes ‘Gutter Cross Slope’ and ‘Gutter Width’. For InRoads Inlet Types other than Curb or Combo, ‘Depressed Gutter’ = False.**
### Swale Gutters

<table>
<thead>
<tr>
<th>33</th>
<th>B</th>
<th>Gutter Type = Shallow Swale</th>
<th>When inRoads Gutter type is Shallow Swale you can define side slope.</th>
<th>User defined attribute in StormCAD.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Side Slope</td>
<td>InRoads Gutter attribute only applicable when Upstream Inlet type = Curb Opening and Gutter Type = Uniform or Composite.</td>
<td>User defined attribute in StormCAD.</td>
</tr>
</tbody>
</table>

### Composite Gutters

<table>
<thead>
<tr>
<th>33</th>
<th>C</th>
<th>Gutter Type = Composite</th>
<th>Set &quot;Depressed Gutter?&quot; = True.</th>
</tr>
</thead>
</table>

### Catchments

![InRoads and StormCAD Screenshot](image)

Bentley StormCAD V8i
<table>
<thead>
<tr>
<th>AreaID</th>
<th>Their Area ID is a string</th>
<th>Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>38</td>
<td></td>
<td>In StormCAD, two different catchments can drain to same outflow node. Should set this up in InRoads and try to import it into StormCAD.</td>
</tr>
<tr>
<td>39</td>
<td>Attached To</td>
<td>OutflowNode</td>
</tr>
<tr>
<td>40</td>
<td>Computational Method</td>
<td>Choice of hydrological method.</td>
</tr>
<tr>
<td></td>
<td>Attached To</td>
<td>N/A</td>
</tr>
<tr>
<td></td>
<td>Computational Method</td>
<td>N/A</td>
</tr>
<tr>
<td></td>
<td>Modified Rational</td>
<td>StormCAD generates user notifications if attempt to import Areas of this type. Still brings in the area, but just as a Rational type.</td>
</tr>
<tr>
<td></td>
<td>SCSUnit Hydrograph</td>
<td>Use Scaled Area?</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Set value of scaled area.</td>
</tr>
<tr>
<td>41</td>
<td>Area</td>
<td>Area(Scaled)</td>
</tr>
<tr>
<td>42</td>
<td>Runoff Coefficient</td>
<td>Rationale</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Maps to a user defined value of Rational Coefficient</td>
</tr>
<tr>
<td>43</td>
<td>Concentration</td>
<td>Time of Concentration</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Maps to a user defined value</td>
</tr>
<tr>
<td>44</td>
<td>Intensity</td>
<td>N/A</td>
</tr>
<tr>
<td>45</td>
<td>Boundary</td>
<td>Boundary feature</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Maps to a user defined value</td>
</tr>
</tbody>
</table>

**InRoads**

![StormCAD](image)

**StormCAD**

![Boundary Type](image)
Time of Concentration

InRoads

StormCAD

Illi

Mt4:1

fi:1
<table>
<thead>
<tr>
<th></th>
<th>nmeof Concentration</th>
<th>Note that only one Tc Method can be used.</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>FAA</td>
<td>StormCAD has hard coded value for FAA Coeff.</td>
</tr>
<tr>
<td>B</td>
<td>Kirpich</td>
<td>Kirpich coefficient maps well</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FAA Coefficient</th>
<th>Rational Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>N/A</td>
<td>Rational Method</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>length</th>
<th>Overland Flow length</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slope</td>
<td>Slope</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Kirpich</th>
<th>Kirpich(TN)</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Kirpich</th>
<th>Tc Multiplier</th>
</tr>
</thead>
<tbody>
<tr>
<td>length</td>
<td>Hydraulic length</td>
</tr>
<tr>
<td>Slope</td>
<td>Slope</td>
</tr>
<tr>
<td>Method</td>
<td>Overland Flow</td>
</tr>
<tr>
<td>--------</td>
<td>---------------</td>
</tr>
<tr>
<td>Open Channel Flow</td>
<td>Overland Row-&gt;Open ChannelRow</td>
</tr>
<tr>
<td>Length</td>
<td></td>
</tr>
<tr>
<td>Velocity</td>
<td></td>
</tr>
<tr>
<td>Shallow Concentrated Flow</td>
<td>Overland Row-&gt;Shallow Concentrated Row</td>
</tr>
<tr>
<td>Length</td>
<td></td>
</tr>
<tr>
<td>Slope</td>
<td></td>
</tr>
<tr>
<td>k</td>
<td>intercept coefficient for Shallow Concentrated Row method.</td>
</tr>
<tr>
<td>IsPaved?</td>
<td></td>
</tr>
<tr>
<td>UDXfield?</td>
<td></td>
</tr>
<tr>
<td>Kinematic Wave Equation</td>
<td>Overland Row-&gt;Kinematic Wave Equation</td>
</tr>
<tr>
<td>Length</td>
<td></td>
</tr>
<tr>
<td>Slope</td>
<td></td>
</tr>
<tr>
<td>Roughness</td>
<td></td>
</tr>
<tr>
<td>Tolerance</td>
<td></td>
</tr>
<tr>
<td>Entire Path</td>
<td>Overland Row-&gt;Entire Path is really a hybrid of the other 3 Tc Methods</td>
</tr>
<tr>
<td>Length</td>
<td></td>
</tr>
<tr>
<td>Slope</td>
<td></td>
</tr>
<tr>
<td>Kinematic Part</td>
<td></td>
</tr>
<tr>
<td>Shallow Part</td>
<td></td>
</tr>
</tbody>
</table>
Starting a Project

Design
### InRoads Drainage Import

This dialog allows you to import optional InRoads files and an InRoads Drainage Database. The dialog consists of the following controls:

**Project Configuration**: Allows you to select a project configuration.

<table>
<thead>
<tr>
<th>Design Equation</th>
<th>Options-&gt;Drainage Options attribute</th>
<th>Hydraulic Analysis</th>
<th>Tools-&gt;Options-&gt;Projecttab</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Mannings</td>
<td>Mannings</td>
<td>Darcy/Colebrooke Darcy-Weisbach Darcy option maps, but KV is not yet a calc option in StormCAD</td>
</tr>
<tr>
<td>B</td>
<td>Darcy/Colebrooke Kinematic Viscosity</td>
<td>N/A</td>
<td>HEC-22 Benchign Method Node attribute</td>
</tr>
<tr>
<td>46</td>
<td>Flat or Depressed Floor</td>
<td>No Bench</td>
<td>Set each node to have bench type = half.</td>
</tr>
<tr>
<td></td>
<td>Half Bench</td>
<td>Half</td>
<td>Set each node to have bench type = full.</td>
</tr>
<tr>
<td></td>
<td>Full Bench</td>
<td>Full</td>
<td></td>
</tr>
<tr>
<td>47</td>
<td>Minimum Height</td>
<td>N/A</td>
<td>In the Design Alternative Editor set 'Limit section size' = True and set 'Maximum Rise' value</td>
</tr>
<tr>
<td>48</td>
<td>Maximum Height</td>
<td>Maximum Rise</td>
<td>In the Design Alternative Editor, set the 'Velocity (Minimum)' field</td>
</tr>
<tr>
<td>49</td>
<td>Minimum Velocity</td>
<td>Velocity (Minimum)</td>
<td>In the Design Alternative Editor, set the 'Velocity (Minimum)' field</td>
</tr>
<tr>
<td>50</td>
<td>Maximum Velocity</td>
<td>Velocity (Maximum)</td>
<td>In the Design Alternative Editor, set the 'Velocity (Maximum)' field</td>
</tr>
<tr>
<td>52</td>
<td>Depth to Height Ratios</td>
<td>Collection</td>
<td>N/A no equivalent</td>
</tr>
<tr>
<td>53</td>
<td>Channel Minimum Velocity</td>
<td>Velocity (Minimum)</td>
<td>In the Design Alternative Editor, set the 'Velocity (Minimum)' field</td>
</tr>
<tr>
<td>54</td>
<td>Channel Maximum Velocity</td>
<td>Velocity (Maximum)</td>
<td>In the Design Alternative Editor, set the 'Velocity (Maximum)' field</td>
</tr>
<tr>
<td>55</td>
<td>Channel Maximum Barrels</td>
<td>N/A</td>
<td>StormCAD does not explicitly support culvert design parameters</td>
</tr>
<tr>
<td>56</td>
<td>Culvert Maximum Headwater</td>
<td>N/A</td>
<td></td>
</tr>
<tr>
<td>57</td>
<td>Culvert Maximum Outlet Velocity</td>
<td>N/A</td>
<td></td>
</tr>
<tr>
<td>58</td>
<td>Culvert Inlet Control</td>
<td>N/A</td>
<td></td>
</tr>
<tr>
<td>59</td>
<td>Inlet Curb Height</td>
<td>N/A</td>
<td>StormCAD does not explicitly support global inlet design constraints</td>
</tr>
<tr>
<td>60</td>
<td>Inlet Curb Opening Height</td>
<td>N/A</td>
<td></td>
</tr>
<tr>
<td>61</td>
<td>Inlet Curb Length</td>
<td>N/A</td>
<td></td>
</tr>
<tr>
<td>62</td>
<td>Inlet Orifice Depth</td>
<td>N/A</td>
<td></td>
</tr>
</tbody>
</table>
• **Preferences**: Click the button to open a browse dialog that allows you to select the Preferences file (.xin) to be imported. Click the arrow button to open a submenu containing the following commands:
  
  – **Open**: Open a browse dialog that allows you to select the Preferences file (.xin) to be imported.
  
  – **Open from ProjectWise**: Opens a ProjectWise login screen that allows you to choose the ProjectWise datasource and log in information to access a file stored in a ProjectWise data source.

• **Structures**: Click the button to open a browse dialog that allows you to select the Structures file (.dat) to be imported. Click the arrow button to open a submenu containing the following commands:
  
  – **Open**: Open a browse dialog that allows you to select the Structures file (.dat) to be imported.
  
  – **Open from ProjectWise**: Opens a ProjectWise login screen that allows you to choose the ProjectWise datasource and log in information to access a file stored in a ProjectWise data source.

• **Rainfall Data**: Click the button to open a browse dialog that allows you to select the Rainfall Data file (.idf) to be imported. Click the arrow button to open a submenu containing the following commands:
  
  – **Open**: Open a browse dialog that allows you to select the Rainfall Data file (.idf) to be imported.
  
  – **Open from ProjectWise**: Opens a ProjectWise login screen that allows you to choose the ProjectWise datasource and log in information to access a file stored in a ProjectWise data source.

• **InRoads Drainage Database**: Click the button to open a browse dialog that allows you to select the InRoads Drainage Database file (.sdb) to be imported. Click the arrow button to open a submenu containing the following commands:
  
  – **Open**: Open a browse dialog that allows you to select the InRoads Drainage Database file (.sdb) to be imported.
  
  – **Open from ProjectWise**: Opens a ProjectWise login screen that allows you to choose the ProjectWise datasource and log in information to access a file stored in a ProjectWise data source.

**Importing/Exporting Micro Drainage Files**

You can import a network from a Micro Drainage formatted file .SWS. This is an open ASCII file format that is used by Micro Drainage WinDES software.
A .SWS file consists of 100 lines (variables) per pipe definition. The following table describes the fundamental mapping between StormCAD elements and their .SWS file analogs for both import and export to and from StormCAD.

<table>
<thead>
<tr>
<th>Variable No.</th>
<th>Label</th>
<th>StormCAD Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>kRoughness</td>
<td>Conduit-&gt;Mannings</td>
</tr>
<tr>
<td>1</td>
<td>Pipe Number</td>
<td>Conduit-&gt;Label</td>
</tr>
<tr>
<td>2</td>
<td>Length</td>
<td>Conduit-&gt;Length</td>
</tr>
<tr>
<td>4</td>
<td>Area</td>
<td>Catchment-&gt;Area</td>
</tr>
<tr>
<td>5</td>
<td>Diameter or Section Number</td>
<td>Conduit-&gt;Diameter</td>
</tr>
<tr>
<td>17</td>
<td>Upstream Invert Level</td>
<td>Conduit-&gt;Invert(Upstream)</td>
</tr>
<tr>
<td>21</td>
<td>Upstream Cover Level</td>
<td>Manhole-&gt;Invert(Upstream)</td>
</tr>
<tr>
<td>24</td>
<td>Downstream Invert Level</td>
<td>Manhole-&gt;Invert(Downstream)</td>
</tr>
<tr>
<td>25</td>
<td>Downstream Cover Level</td>
<td>Manhole-&gt;Elevation(Ground)</td>
</tr>
<tr>
<td>26</td>
<td>Upstream manhole number</td>
<td>Upstream Node Label</td>
</tr>
<tr>
<td>27</td>
<td>Downstream manhole number</td>
<td>Downstream Node Label</td>
</tr>
<tr>
<td>30</td>
<td>Upstream manhole diameter</td>
<td>Manhole-&gt;Diameter (Structure Type = Circular)</td>
</tr>
<tr>
<td>31</td>
<td>Downstream manhole diameter</td>
<td>Manhole-&gt;Diameter (Structure Type = Circular)</td>
</tr>
<tr>
<td>32</td>
<td>Upstream manhole width</td>
<td>Manhole-&gt;Width (Structure Type = Box Structure)</td>
</tr>
<tr>
<td>33</td>
<td>Downstream manhole width</td>
<td>Manhole-&gt;Width (Structure Type = Box Structure)</td>
</tr>
<tr>
<td>40</td>
<td>Constant = 3000</td>
<td>3000</td>
</tr>
<tr>
<td>41</td>
<td>Upstream easting</td>
<td>Upstream Manhole-&gt;X</td>
</tr>
<tr>
<td>42</td>
<td>Upstream northing</td>
<td>Upstream Manhole-&gt;Y</td>
</tr>
<tr>
<td>43</td>
<td>Downstream easting</td>
<td>Downstream Manhole-&gt;X</td>
</tr>
<tr>
<td>44</td>
<td>Downstream northing</td>
<td>Downstream Manhole-&gt;Y</td>
</tr>
<tr>
<td></td>
<td>Manhole Cover Type (enumerated - values to be announced)</td>
<td>Manhole-&gt;Structure Type</td>
</tr>
</tbody>
</table>

Special Considerations When Exporting to Micro Drainage

- Micro Drainage only handles manholes and pipe structures, so on export StormCAD V8i converts inlets and transitions to manholes.
• When a model has multiple catchments pointing towards the same node, StormCAD V8i exports only one and ignores the rest.
• Gutters are not supported by Micro Drainage, thus they are not exported.
• Network branches will not be exported if the pipe's start and stop node are specified incorrectly (if the downstream node is specified as the start node rather than the stop node).

Import / Export Bentley MX Drainage (LandXML Format)

Note Bentley MX Drainage import/export is the same as the LandXML import/export (see Importing LandXML Files and Exporting LandXML) with the following additional properties read and written.

LandXML Feature Additions to Support Bentley MX

Custom Attributes

LandXML supports "extra" data to be added to the file via a Feature element. A feature element may contain any number of properties. These properties are defined below for each of our different Element Types in StormCAD.

Example of a custom attribute in LandXML:

For a "carryoverflow" custom attribute, the data should be written like this:

<Feature code="Bentley Drainage">

<Property label="carryoverflow" value="0.005"/>
</Feature>

<table>
<thead>
<tr>
<th>Catchments</th>
<th>StormCAD Property</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>LandXML (MX) Custom Attribute</strong></td>
<td><strong>Rational C</strong></td>
</tr>
<tr>
<td><strong>rational</strong>: A unitless number between 0 and 1 (inclusive). This represents the proportion of rainfall on a catchment that becomes runoff. Note that this should be a composite of the runoff coefficients for all pervious and impervious regions within the catchment.</td>
<td></td>
</tr>
<tr>
<td><strong>timeofconcentration</strong>: The user-defined or calculated time of concentration for the catchment. Since LandXML doesn’t support time units, we should always use minutes as the unit.</td>
<td><strong>Time of Concentration (min)</strong></td>
</tr>
<tr>
<td><strong>outflownode</strong>: The label (string) of the node element that the catchment drains to.</td>
<td><strong>Outflow Node</strong></td>
</tr>
<tr>
<td><strong>OutflowNetwork</strong>: This is important as their may be multiple networks in the xml file, verify that the catchment outflows to the correct node and network.</td>
<td></td>
</tr>
<tr>
<td><strong>Note</strong>: if the area attribute is set, then the area is set to this value along with the user defined flag set to true. Otherwise the area is derived from the geometry.</td>
<td><strong>Area</strong></td>
</tr>
</tbody>
</table>

**Sample:**

```xml
<Watershed name="I-4 Catchment" area="13939.2000047138">
  <PntList2D>577.824884792627 260.035263474254 587.824884792627 260.035263474254 587.824884792627 270.035263474254 577.824884792627 270.035263474254</PntList2D>
  <Feature code="Bentley Drainage">
    <Property label="TimeOfConcentration" value="5.000000"/>
    <Property label="PerviousPercentage" value="0.000000"/>
    <Property label="PerviousRationalC" value="1.000000"/>
    <Property label="PerviousRoughnessC" value="0.150000"/>
  </Feature>
</Watershed>
```
Starting a Project

<Property label="PerviousConnection" value="Pipe"/>
<Property label="ImperviousPercentage" value="100.000000"/>
<Property label="ImperviousRationalC" value="1.000000"/>
<Property label="ImperviousRoughnessC" value="0.017000"/>
<Property label="ImperviousConnection" value="Inlet"/>
<Property label="OutflowNetwork" value="Network 1"/>
<Property label="OutflowNode" value="SEP-1"/>
</Feature>
</Watershed>

<table>
<thead>
<tr>
<th>All Nodes</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>externalarea</td>
<td>Uses to model flows from an external (i.e. not included in the model) catchment. In StormCAD this is the product of the external catchment’s area and composite runoff coefficient.</td>
</tr>
<tr>
<td>externaltc</td>
<td>Time of concentration for the external catchment</td>
</tr>
<tr>
<td>additionalflow</td>
<td>Additional flow applied to the pipe network, Use LandXML file’s flow unit. In MX (and StormCAD this is a property of the node. Note that there is no time of concentration for this attribute, although there is in MX, but I think that in the export to an SWS file we set this up as a “base flow” – i.e. a constant flow which is regardless of changes in rainfall intensity.</td>
</tr>
</tbody>
</table>

Sample:

<Struct name="I-6" elevRim="320.78" elevSump="315.015" oID="4" desc="">
  <Center>482.332197956321 483.378080544981</Center>
  <InletStruct />
  <Feature code="Bentley Drainage">
    <Property label="externalarea" value="43560.000147306" />
    <Property label="externaltc" value="5" />
  </Feature>
</Struct>
<Property label="additionalflow" value="3" />

</Feature>

<Invert refPipe="P-4" elev="315.015" flowDir="in"/>

<Invert refPipe="P-8" elev="315.015" flowDir="out"/>

<Invert refPipe="P-9" elev="315.015" flowDir="in"/>

</Struct>

### Inlets:

<table>
<thead>
<tr>
<th>All</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>slopeSurf: in StormCAD if the Inlet is OnGrade, this is the Longitudinal Slope in percent</td>
<td>Longitudinal Slope</td>
</tr>
<tr>
<td>gutterslope: if the inlet has a gutter, this is the slope in percent</td>
<td>Gutter Cross Slope</td>
</tr>
<tr>
<td>gutterwidth: if the inlet has a gutter, this is the width</td>
<td>Gutter Width</td>
</tr>
<tr>
<td>carryoverflow: also known as “bypass flow”</td>
<td>Flow (Total Bypassed)</td>
</tr>
<tr>
<td>losscoeff: unitless</td>
<td>Headloss Coefficient</td>
</tr>
</tbody>
</table>

Inlet Capacity: If this value is present in the XML file the catch basin is set to Maximum Capacity Type and the value is assigned as the maximum capacity.

Blockage Factor: If this factor is present, StormCAD will multiply the inlet capacity value to it to produce the Maximum Capacity.

#### Circular Inlets:
- Diameter

#### Rectangular Inlets:
- Length
- Width

<table>
<thead>
<tr>
<th>Pipes</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>numberofbarrels: (only written if &gt; 1)</td>
<td>Number of Barrels</td>
</tr>
<tr>
<td>Length: If this value is present, it sets the pipe length and user defined value to true, otherwise the default is to base the length off of geometry.</td>
<td>Length</td>
</tr>
</tbody>
</table>

#### Gully connection pipes:
These are written in the same format as any other pipe. The "<Pipe name=" attribute needs to be "Gully Connection Pipe <gully number>". Gully pipes in MX connect directly to a pipe. Since both StormCAD and the LandXML format require a node connection at both ends of a pipe, the gully pipe definition in this file format will connect to the upstream node.

Depending on the sump of the upstream node and the invert elevations of the gully pipe, StormCAD may issue a warning if the invert is lower than the sump.

### 5.1.6 Exporting Data

You can export your model as a DXF drawing or to LandXML format. You can also export any portion of your model as a submodel. Click one of the following links to learn more:

- Exporting a .DXF File
- Exporting a Submodel
- Exporting LandXML

#### Exporting a .DXF File

You can export your StormCAD model as a .DXF file if you plan to edit the file in AutoCAD or another program. When you export a .DXF file, you export only the graphical (vector) representation of the model. The DXF file is an ASCII file.

**To export the current project to a .DXF file:**

1. Select **File > Export > DXF**.
2. Type the name of the DXF file, then click **Save**.

You may now open the DXF file in another program.

#### Exporting a Submodel

You can export any portion of a model as a submodel for import into other projects. Input data is also stored in the file that is created in the process of Exporting a Submodel. This input data will be imported following a label-matching strategy for any element, alternative, scenario, calculation option or supporting data in the submodel. For more information about input data transfer, see **Importing Submodels**.
Creating Models

Note: User-defined data is not transferred during submodel import and export operations.

To export a submodel

1. In the drawing view, highlight the elements to be exported as a submodel. To highlight multiple elements, hold down the Shift key while clicking elements.
2. Click the File menu and select Export...Submodel.
3. In the Select Submodel File to Export dialog box, specify the directory to which the file should be saved, enter a name for the submodel and click the Save button.

Exporting LandXML

You can export a model to LandXML format. See Importing LandXML Files for information about the data that will be exported.

To export the current project to a LandXML .xml file:

1. Select File > Export > LandXML.
2. Type the name of the xml file, then click Save.

You may now open the .xml file in another program.
Exporting a Bentley InRoads Storm and Sanitary V8i Model from StormCAD

If a StormCAD model has been calculated, when exporting to InRoads, the design or calculated data will be exported to the design tables in the InRoads database as described in the StormCAD Export to InRoads Design (Calculated) Data Map that follows:

<table>
<thead>
<tr>
<th>InRoads</th>
<th>StormCAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fillets</td>
<td></td>
</tr>
<tr>
<td>Design</td>
<td></td>
</tr>
<tr>
<td>Flow Downstream</td>
<td>Flow (Total Out)</td>
</tr>
<tr>
<td>Bypass to Downstream</td>
<td>Flow (Total bypassed)</td>
</tr>
<tr>
<td>Inlet Efficiency</td>
<td>Capture Efficiency (Calculated)</td>
</tr>
<tr>
<td>Capacity</td>
<td>Flow (Total Intercepted)</td>
</tr>
<tr>
<td>Spread</td>
<td>Gutter Spread</td>
</tr>
<tr>
<td>Water Depth in Gutter</td>
<td>Gutter Depth</td>
</tr>
<tr>
<td>Analysis Size</td>
<td></td>
</tr>
<tr>
<td>Grate Width</td>
<td>Structure Width (same as input data)</td>
</tr>
<tr>
<td>Grate Length</td>
<td>Grate Length</td>
</tr>
<tr>
<td>Frequency</td>
<td>Global Storm Event Return Period</td>
</tr>
<tr>
<td>Flow</td>
<td></td>
</tr>
<tr>
<td>Contributing Area</td>
<td>Inlet Drainage Area</td>
</tr>
<tr>
<td>Sum of Upstream Areas</td>
<td>StormCAD stores the System CA (sum of average Rational C Coefficient * Area). It does not store the sum of Areas. This value will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td>Drainage Basin Runoff</td>
<td>Flow (Total Surface)</td>
</tr>
<tr>
<td>Bypass from Upstream</td>
<td>Carryover Rational Flow + Carryover Fixed Flow</td>
</tr>
<tr>
<td>Sum Injected Flow</td>
<td>System Fixed Flow</td>
</tr>
<tr>
<td>Time of Concentration Computations</td>
<td></td>
</tr>
<tr>
<td>Time To Inlet</td>
<td>Time of Concentration (Catchment)</td>
</tr>
<tr>
<td>Time from Upstream</td>
<td>System Flow Time</td>
</tr>
<tr>
<td>Intensity</td>
<td>System Intensity</td>
</tr>
<tr>
<td>Frequency</td>
<td>Global Storm Event Return Period</td>
</tr>
<tr>
<td>Runoff Coefficient</td>
<td>Inlet C</td>
</tr>
<tr>
<td>SumofC *A</td>
<td>SystemCA</td>
</tr>
<tr>
<td>EGL HGL</td>
<td></td>
</tr>
<tr>
<td>Head Loss</td>
<td>Headloss</td>
</tr>
<tr>
<td>HGL</td>
<td>Hydraulic Grade Line (in)</td>
</tr>
<tr>
<td>EGL</td>
<td>Energy Grade Line (In)</td>
</tr>
</tbody>
</table>
### Manholes

<table>
<thead>
<tr>
<th>Storm Flow</th>
<th>System Fixed Flow</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum Injected Flow</td>
<td>StormCAD stores the System CA (sum of average Rational C Coefficient * Area). It does not store the sum of Areas. This value will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td>Sum of Upstream Areas</td>
<td>System Flow Time</td>
</tr>
<tr>
<td>Time of Concentration Computations</td>
<td>SystemCAD</td>
</tr>
<tr>
<td>Time of Concentration</td>
<td>Flow Downstream</td>
</tr>
<tr>
<td>Largest Upstream Pipe</td>
<td>Flow (TotalOut)</td>
</tr>
<tr>
<td>Flow Downstream</td>
<td>N/A</td>
</tr>
<tr>
<td>Analysis Size</td>
<td>Structure Width (same as input data)</td>
</tr>
<tr>
<td>Width</td>
<td>Structure Length (same as input data)</td>
</tr>
<tr>
<td>Length</td>
<td>Head Loss</td>
</tr>
<tr>
<td>EGL/HGL</td>
<td>Headloss</td>
</tr>
<tr>
<td>Head Loss</td>
<td>Hydraulic Grade Line (in)</td>
</tr>
<tr>
<td>HGL</td>
<td>Energy Grade Line (in)</td>
</tr>
<tr>
<td>EGL</td>
<td></td>
</tr>
</tbody>
</table>
# starting a Project

<table>
<thead>
<tr>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Storm Flow</strong></td>
<td></td>
</tr>
<tr>
<td>Contributing Area</td>
<td>Drainage basins cannot be directly connected to a pipe in StormCAD. This field will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td>Sum of Upstream Areas</td>
<td>StormCAD stores the System CA (sum of average Rational C Coefficient * Area). It does not store the sum of Areas. This value will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td>Drainage Basin RImoff</td>
<td>Drainage basins cannot be directly connected to a pipe in StormCAD. This field will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td>Bypass from Upstream</td>
<td>Bypass flow is tracked at the Catch Basin (Inlet) element in StormCAD. This field will be set to zero when exporting.</td>
</tr>
<tr>
<td><strong>Time of Concentration Computations</strong></td>
<td></td>
</tr>
<tr>
<td>Time to Pipe</td>
<td>Drainage basins cannot be directly connected to a pipe in StormCAD. This field will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td>System Flow Time</td>
<td>System Flow Time</td>
</tr>
<tr>
<td>System Intensity</td>
<td>System Intensity</td>
</tr>
<tr>
<td>Global Storm Event</td>
<td>Global Storm Event</td>
</tr>
<tr>
<td><strong>Design</strong></td>
<td></td>
</tr>
<tr>
<td>Flow Status</td>
<td>If Excess Capacity (Full Flow) &lt; 0 then FULL otherwise PARTIAL</td>
</tr>
<tr>
<td>Flow Regime</td>
<td>If flow Number &lt; T then SubCritical otherwise SuperCritical</td>
</tr>
<tr>
<td>Flow Rate</td>
<td>Flow</td>
</tr>
<tr>
<td>Capacity</td>
<td>Capacity (Full Flow)</td>
</tr>
<tr>
<td>Velocity</td>
<td>Velocity (Average)</td>
</tr>
<tr>
<td>Depth of Flow</td>
<td>(Depth (In) + Depth (Out)) / 2</td>
</tr>
<tr>
<td>Critical Depth</td>
<td>Depth (Critical)</td>
</tr>
<tr>
<td>Froude Number</td>
<td>Froude Number</td>
</tr>
<tr>
<td>Depth to Height (d/D)</td>
<td>Normal Depth / Rise</td>
</tr>
<tr>
<td><strong>Analysis Size</strong></td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>Dependent on Pipe Shape</td>
</tr>
<tr>
<td>Height</td>
<td>Dependent on Pipe Shape</td>
</tr>
<tr>
<td>Frequency</td>
<td>Global Storm Event Return Period</td>
</tr>
<tr>
<td>HGL/EGL</td>
<td></td>
</tr>
<tr>
<td>Head Loss</td>
<td>Headless</td>
</tr>
<tr>
<td>EntranceHGL</td>
<td>Hydraulic Grade Line (In)</td>
</tr>
<tr>
<td>ExitHGL</td>
<td>Hydraulic Grade Line (Out)</td>
</tr>
<tr>
<td>EntranceEGL</td>
<td>Energy Grade Line (In)</td>
</tr>
<tr>
<td>ExitEGL</td>
<td>Energy Grade Line (Out)</td>
</tr>
<tr>
<td>Channels</td>
<td></td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Flow</strong></td>
<td><strong>Contributing Area</strong></td>
</tr>
<tr>
<td></td>
<td>Drainage basins cannot be directly connected to a pipe in StormCAD. This field will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td><strong>Sum of Upstream Areas</strong></td>
<td>StormCAD stores the System CA (sum of average Rational C Coefficient * Area). It does not store the sum of Areas. This value will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td><strong>Drainage Basin Runoff</strong></td>
<td>Drainage basins cannot be directly connected to a pipe in StormCAD. This field will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td><strong>Bypass from Upstream</strong></td>
<td>Bypass flow is tracked at the Catch Basin (Inlet) element in StormCAD. This field will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td><strong>Sum Injected Flow</strong></td>
<td>System Fixed Flow</td>
</tr>
<tr>
<td><strong>Time of Concentration Computations</strong></td>
<td>System Flow Time</td>
</tr>
<tr>
<td><strong>Time to Channel</strong></td>
<td>Drainage basins cannot be directly connected to a pipe in StormCAD. This field will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td><strong>Intensity</strong></td>
<td>System Intensity</td>
</tr>
<tr>
<td><strong>Frequency</strong></td>
<td>Global Storm Event</td>
</tr>
<tr>
<td><strong>Runoff Coefficient</strong></td>
<td>Drainage basins cannot be directly connected to a pipe in StormCAD. This field will be set to zero when exporting to InRoads.</td>
</tr>
<tr>
<td><strong>Sum of C*A</strong></td>
<td>System CA</td>
</tr>
<tr>
<td><strong>Design</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Flow Rate</strong></td>
<td>Flow</td>
</tr>
<tr>
<td><strong>Velocity</strong></td>
<td>Velocity (Average)</td>
</tr>
<tr>
<td><strong>Depth of Flow</strong></td>
<td>(Depth (In) * Depth (Out))/2</td>
</tr>
<tr>
<td><strong>Critical Depth</strong></td>
<td>Depth (Critical)</td>
</tr>
<tr>
<td><strong>Top Width</strong></td>
<td>Dependent on Channel Shape</td>
</tr>
<tr>
<td><strong>Analysis Size</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Width</strong></td>
<td>Dependent on Channel Shape</td>
</tr>
<tr>
<td><strong>Frequency</strong></td>
<td>Global Storm Event Return Period</td>
</tr>
<tr>
<td><strong>HGL</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Head Loss</strong></td>
<td>Headloss</td>
</tr>
<tr>
<td><strong>Entrance HGL</strong></td>
<td>Hydraulic Grade Line (In)</td>
</tr>
<tr>
<td><strong>Exit HGL</strong></td>
<td>Hydraulic Grade Line (Out)</td>
</tr>
</tbody>
</table>

No design data is written for culverts.
5.2 Elements and Element Attributes

Link Elements
Catch Basins
Manholes
Transitions
Outfalls
Catchments
Other Tools

5.2.1 Link Elements

Link elements connect the other elements to form the storm network. The link elements are the conveyance elements that carry flow through the network to its eventual discharge point at an outlet. You can add either of the following link elements to your model, depending on the link element's location within the network:

- Conduits
- Gutters

When you click the Layout tool on the Layout toolbar, you select the type of link element to add (conduit or gutter), then select an element. You can place multiple elements with different kinds of connections using the Layout tool.

Conduit Elements

The shape parameters (rise, span, diameter, etc...) of a conduit can be delineated in one of 2 ways by setting the Conduit Type attribute as follows.

- **User Defined Conduit** -When this conduit type is selected, the shape parameters of the conduit are entered locally on the conduit level, making it easier to try various shapes, sizes and materials when calibrating or designing without having to go through the process of setting up the various components in the engineering libraries. Irregular channel shapes are only available if this conduit type is selected.
Creating Models

- **Catalog Conduit** - When this conduit type is selected, the user can select from a list of pre-defined conduit types from the engineering libraries. Note that the Section Sizes available for selection in the property grid are filtered by the Conduit Shape and the Material Fields. Pipe Arch shapes are only available if this Conduit Type is selected.

<table>
<thead>
<tr>
<th>Conduit Type</th>
<th>Conduit Shape</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catalog Conduit</td>
<td>Circle</td>
</tr>
<tr>
<td></td>
<td>Pipe Arch</td>
</tr>
<tr>
<td></td>
<td>Ellipse</td>
</tr>
<tr>
<td></td>
<td>Box</td>
</tr>
<tr>
<td></td>
<td>Trapezoidal</td>
</tr>
<tr>
<td></td>
<td>Triangular</td>
</tr>
<tr>
<td></td>
<td>Rectangular</td>
</tr>
<tr>
<td>User Defined</td>
<td>Circular</td>
</tr>
<tr>
<td></td>
<td>Default</td>
</tr>
<tr>
<td></td>
<td>12 in</td>
</tr>
<tr>
<td></td>
<td>n = 0.013</td>
</tr>
<tr>
<td></td>
<td>Box</td>
</tr>
<tr>
<td></td>
<td>Elliptical</td>
</tr>
<tr>
<td></td>
<td>Irregular</td>
</tr>
<tr>
<td></td>
<td>Virtual</td>
</tr>
</tbody>
</table>

**Gutter Elements**

The purpose of a gutter element is to dictate where flow bypassed by the inlet at the start node is emptied at the stop node. The physical properties (cross-slope, roughness, etc...) of the gutter are associated with the bounding nodes. They are not directly associated with the gutter element, as gutters are not necessarily uniform, and the calculated spread and depth in the gutter are based on the gutter characteristics at the inlet opening. Hence, spread and depth are also presented at the catch basin.

The gutter slope value is derived from the start and stop ground elevations and the scaled length of the gutter. This attribute is primarily informational and does not affect the calculations. However, if the slope is negative a warning message is generated.

**Entering Additional Data to Link Elements**

There are several dialog boxes that are available from the Property Editors that let you enter additional data for link elements.
Defining the Geometry of a Link Element

Irregular Channel Dialog Box

Defining the Geometry of a Link Element

You define the geometry of a link element by entering the location and angle of bends for the selected link element. You enter X vs. Y points that plot the shape of the polyline that represents the element in the Polyline Vertices dialog box.

To define the geometry of a link element:

1. Click a link element in your model to display the Property Editor, or right-click a link element and select Properties from the shortcut menu.
2. In the Geometry section of the Property Editor, click the Ellipses (...) button next to the Geometry field.
3. In the Polyline Vertices dialog box, click the New button to add a new row to the table.
4. Type values for X and Y points for each row in the table.
5. To remove rows from the table, click the Delete button.
6. Click OK.

Polyline Vertices Dialog Box

This dialog box contains the X vs. Y table that allows you to define any number of points that plot the shape of the polyline representing the selected link element. The dialog box contains the following controls:

- **New**: This button creates a new row in the table.
- **Delete**: This button deletes the currently highlighted row from the table.

Diversion Rating Curve Dialog Box

This dialog allows you to define the rating curve using Upstream Flow vs. Diverted Flow points. The rating curve determines the flow into the associated conduit. At each upstream flow point, you define how much of the flow is diverted.

Irregular Channel Dialog Box

This dialog box allows you to enter Station vs. Elevation (Relative) data for the cross-sectional shape of an irregular channel conduit element.
The dialog box contains the station vs. elevation table along with the following controls:

- **New**: This button creates a new row in the station-elevation table.
- **Delete**: This button deletes the currently highlighted row from the station-elevation table.
- **Report**: Opens a print preview window containing a report that details the input data for this dialog box.
- **Help**: Opens the online help topic for this dialog.

The table may contain the following columns:

- **Station**: This field allows you to define the cross-sectional distance at the current curve point. You can enter these in any order that defines the conduit (e.g., from left-to-right, from right-to-left, with an upstream or downstream perspective). This column will be available for any Roughness Type that is selected.

- **Elevation (Relative)**: This field allows you to define the height above the channel invert at that cross section point. This value can be a negative number. Note that the elevation defined here is used purely to define the shape of the section, and it is not meant to represent a real elevation. In the calculations, StormCAD uses the irregular section shape defined here, as well as the Invert (Upstream) and Invert (Downstream) properties of the conduit. To do this, StormCAD sets the lowest point on the irregular section equal to the invert elevation at the upstream and downstream ends of the conduit, and the elevation of other points in the irregular section are adjusted accordingly. This column will be available for any Roughness Type that is selected.

  **Note**: The lowest Elevation (Relative) in the collection is assumed to be the invert elevation from which all other Elevation (Relative) values are measured.

- **Manning's n**: This field allows you to define the roughness value of the section between the current curve point and the next. This column is available when the Horizontal Segment Roughness Type is selected.

When the Bank Channel Roughness Type is selected the following additional controls will become available:
• **Left Bank Station:** Select the station point that marks the end of the left bank. The left bank is measured from the first station-elevation point in the table to the selected point.

• **Left Bank Manning's n:** Enter the Manning's n value for the left bank or click the ellipsis button to open the Engineering Library and choose a predefined Manning's n value.

• **Right Bank Station:** Select the station point that marks the beginning of the right bank. The right bank is measured from the selected point to the last station-elevation point in the table.

• **Right Bank Manning's n:** Enter the Manning's n value for the right bank or click the ellipsis button to open the Engineering Library and choose a predefined Manning's n value.

• **Channel Manning's n:** Enter the Manning's n value for the channel (the area between the left and right banks) or click the ellipsis button to open the Engineering Library and choose a predefined Manning's n value.

![Elevation Diagram](image)
Split (Bifurcated) Irregular Channels

In some irregular channels, there are local high points in the cross sections such that the flow is actually split into two parallel but unequal channels. When the flow is very shallow, it will only occur in the channel with the lowest elevation. When the flow is very deep, it will flow in both channels. When the flow is moderate, it is assumed that the high point between the two channels is an island, not a levee, and flow will pass on both sides of the island and not be blocked as it would be if the high point was a levee.

What Happens When the Water Level Exceeds the Top Elevation of an Open Channel?

StormCAD does not model channel overflow, so when the hydraulic grade line (HGL) exceeds the channel top elevation during a calculation, the sides of the channel are extended vertically upwards so the calculation can proceed. However, when the calculation is complete a User Notification message will appear to inform users that the channel has overtopped. The HGL computed in this case will not be realistic, and it will be necessary for users to increase the channel capacity and re-compute in order to obtain realistic HGL results.
5.2.2 **Catch Basins**

Catch basins convey surface water into a storm sewer pipe system. A catch basin (a.k.a., storm drain inlet, curb inlet) is an inlet to the storm drain system that typically includes a grate or curb inlet where stormwater enters the catch basin and a sump to capture sediment, debris and associated pollutants. They are also used in combined sewer watersheds to capture floatables and settle some solids.

When you click the catch basin element on the Layout toolbar, your mouse cursor changes into a catch basin element symbol. Clicking in the drawing pane while this tool is active causes a catch basin element to be placed at the location of the mouse cursor.

**Inlet Type**

The inflow to a catch basin does not all enter the basin. The flow that actually enters the basin is referred to as its "capture."

A catch basin may:

- Capture all of the flow up to a "maximum capacity," and you specify the maximum flow.
- Capture a percentage of all flow that reaches the inlet, and you specify the percentage captured.
- According to the properties of a user-defined catalog inlet.

Any inflow that is not captured goes to a gutter. If there is no gutter, the inflow that is not captured is lost from the system.

**Inflow Capture Curve**

The Inflow Capture Curve dialog box allows you to define Flow to Inlet vs. Flow Captured tables for inlets. The dialog box contains the flow vs. capture table along with the following controls:

**New:** This button creates a new row in the flow vs. capture table.
Delete: This button deletes the currently highlighted row from the flow vs. capture table.

5.2.3 Manholes

Manholes are placed in a sewer system to provide access for inspection, maintenance, and emergency service. Manholes should be placed at sewer junctions (i.e., tees, wyes, and crosses), upstream terminal ends of sewers, and locations where there is a change in sewer grade or direction. Manholes are locations where loads enter the gravity portion of the sewer system.

When you click the manhole element on the Layout toolbar, your mouse cursor changes into a manhole element symbol. Clicking in the drawing pane while this tool is active causes a manhole element to be placed at the location of the mouse cursor.

5.2.4 Transitions

Transition elements, also known as junction chambers, are locations where upstream flows in a gravity system combine (see Transition Diagrams). No loads enter the sewer at these points.

When you click the transition element on the Layout toolbar, your mouse cursor changes into a transition element symbol. Clicking in the drawing pane while this tool is active causes a transition element to be placed at the location of the mouse cursor.
Elements and Element Attributes

Transition Diagrams

'Transition' element between circular pipe type conduits

Ground
5.2.5 **Outfalls**

Outfalls represent the ultimate termination points in a sanitary sewer network.

When you click the outfall element on the Layout toolbar, your mouse cursor changes into a outfall element symbol. Clicking in the drawing pane while this tool is active causes a outfall element to be placed at the location of the mouse cursor.
**Adding Elevation vs. Flow Data to an Outfall**

You can add an Elevation-Flow (E-Q) curve to an outfall in StormCAD. An Elevation-Flow (E-Q) curve represents the tailwater elevation at an outfall for various outflows. This can be used, for example, to simulate a discharge into a downstream channel where the relationship between water level and flow is known without modeling the channel explicitly.

**To add an Elevation vs. Flow curve to an outfall:**

1. Click an outfall in your model to display the Property Editor, or right-click an outfall and select Properties from the shortcut menu.
2. In the Boundary Condition section of the Property Editor, select Elevation-Flow Curve in the Boundary Condition Type field. The Elevation-Flow Curve field becomes available.
3. Click the Ellipses (...) button next to the Elevation-Flow Curve field.
4. In the Elevation-Flow Curve dialog box, each row in the table represents a point on the Elevation-Flow curve. Type values for Elevation and Flow for each row. Click the New button to add a row or press the Tab key to advance to the next field in the table.
5. To delete a row from the table, select the row then click Delete.
6. Close the dialog box.

**Elevation-Flow Curve Dialog Box**

The dialog box contains the elevation vs. flow table and the following buttons:

- **New**: This button creates a new row in the curve table.

- **Delete**: This button deletes the currently highlighted row from the curve table.

- **Report**: This button opens a print preview window containing a report that details the input data for this dialog box.

The table contains the following columns:

- **Outlet Elevation**: This field allows you to define the elevation of the curve point.
- **Outlet Flow**: This field allows you to define the flow for the curve point.
5.2.6 *Catchments*

Catchments represent the area drained by a stream, lake or other body of water in a sewer or stormwater system.

When you click the catchment element on the Layout toolbar, your mouse cursor changes into a catchment element symbol. Catchment elements are polygons. Clicking in the drawing pane while this tool is active causes one point of the catchment polygon to be placed at the location of the mouse cursor. Continue clicking to define the other points that make up the polygon to define the shape fo the catchment. To finish placing the catchment, right-click and select Done.

If the shape of the catchment is not important, such as in a schematic drawing, you can place a generic catchment by holding down the Ctrl button after clicking once, then moving the mouse cursor to define the size of the catchment, then clicking again to place it.

**Specifying a Time of Concentration (Tc) Method for a Catchment**

You can add Time of Concentration (Tc) Methods to a catchment in your model. StormCAD supports 13 different methods, which are listed below. You define the TC Method in the TC Data Collection dialog box. You can define both single and multiple flow segments for a catchment.

Some types of Tc equations can apply to flow segments within a multiple-segment Tc calculation. Other Tc methods are equations intended to model the entire average subarea flow distance and slope in one single flow segment. When combining multiple flow segments to compute Tc, it is up to you to only combine Tc methods that can be modeled in combination with multiple flow segments.

**To define the Tc Method for a catchment:**

1. Click a catchment in your model to display the Property Editor, or right-click a catchment and select Properties from the shortcut menu.
2. In the Runoff section of the Property Editor, select Modified Rational Method in the Runoff Method field. The Tc (hours) field becomes available.
3. Click the Ellipses (...) button next to the Tc (hours) field. The Tc Data Collection dialog box appears.
4. Click New, then select a Tc Method from the submenu.
5. Different fields become available depending on which Tc Method you select. For each Tc Method, type values in the appropriate fields.

6. Click OK to close the dialog box and save your Tc Collection data (time of concentration in hours) in the Property Editor.

**Tc Data Collection Dialog Box**

This dialog box allows you to define the Time of Concentration method. Both single and multiple flow segments can be modeled in this dialog box.

The dialog box contains the Tc Method display pane, which lists all of the methods currently assigned to the catchment, a control section that allows you to edit the attributes associated with the method currently highlighted in the table, and the following buttons:

- **New**: Displays a submenu that allows you to specify the Tc method to be created.

- **Delete**: Deletes the currently highlighted method from the table.

- **Report**: Opens a print preview window containing a report that details the input data for this dialog box.

StormCAD supports the following 13 methods, which are listed along with the required input data for each:

- **User Defined Tc**—The user-defined time of concentration (Tc) is a method that allows the direct input of the Tc rather than using an equation to calculate it. This method would be used when the Tc needs to be calculated using a methodology that is not supported by StormCAD V8i, or when a quick estimate of Tc is sufficient for the analysis.
  - **User Defined Tc**—Lets you explicitly define the Tc, rather than have it calculated for you using one of the other methods.

- **Carter**—This method requires the following input data:
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
  - **Slope**—Lets you define the slope of the catchment section.

- **Eagleson**—This method requires the following input data:
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
- **Manning's n**—Lets you enter the Manning's roughness value of the catchment section.
- **Hydraulic Radius**—Lets you define the hydraulic radius of the catchment section.
- **Slope**—Lets you define the slope of the catchment section.

- **Espey/Winslow**—This method requires the following input data:
  - **Channel Factor**—Lets you define the Espey channelization factor of the catchment section.
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
  - **Slope**—Lets you define the slope of the catchment section.
  - **Impervious**—Lets you define the percentage of impervious area of the catchment section.

- **FAA Equation**—This method requires the following input data:
  - **Overland Flow Length**—Lets you define the length of the overland pipe flow of the catchment section.
  - **Rational Method C**—Lets you define the rational C coefficient of the catchment section.
  - **Slope**— Lets you define the slope of the catchment section.

- **Kerby/Hathaway**—This method requires the following input data:
  - **Manning's n**—Lets you enter the Manning's roughness value of the catchment section.
  - **Slope**—Lets you define the slope of the catchment section.
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.

- **Kirpich PA**—This method requires the following input data:
  - **Tc Multiplier**—Lets you define the time-of-concentration adjustment multiplier.
  - **Slope**—Lets you define the slope of the catchment section.
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.

- **Kirpich TN**—This method requires the following input data:
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
  - **Slope**—Lets you define the slope of the catchment section.
- **Te Multiplier**—Lets you define the time-of-concentration adjustment multiplier.

- **Length and Velocity**—This method requires the following input data:
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
  - **Velocity**—Lets you define the velocity of flow in the catchment section.

- **SCS Lag**—This method requires the following input data:
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
  - **CN**—Lets you define the SCS runoff curve number of the catchment section.
  - **Slope**—Lets you define the slope of the catchment section of the catchment section.

- **TR-55 Sheet Flow**—This number represents the sheet flow time computed for each column of sheet flow data. This method requires the following input data:
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
  - **Manning's n**—Lets you enter the Manning's roughness value of the catchment section.
  - **Slope**—Lets you define the slope of the catchment section.
  - **2 yr. 24 hr. Depth**—Depth of 2 year 24 hour storm.
  - **TR-55 Shallow Conc.**—This number represents the sheet flow time computed for each column of shallow concentrated flow data. This method requires the following input data:
    - **Hydraulic Length**—Lets you define the flow length of the catchment section.
    - **Is Paved**—Lets you specify whether the catchment section is paved or unpaved.
    - **Slope**—Lets you define the slope of the catchment section.

- **TR-55 Channel Flow**—This number represents the channel flow time computed for each column of channel flow data. This method requires the following input data:
  - **Flow Area**—Lets you define the flow area of the catchment section.
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
  - **Manning's n**—Lets you enter the Manning's roughness value of the catchment section.
  - **Slope**—Lets you define the slope of the catchment section.
Creating Models

- **Wetted Perimeter**—Lets you define the wetted perimeter of the catchment section.

- **UK Standard**—This method requires the following input data:
  - **Hydraulic Length**—Lets you define the flow length of the catchment section.
  - **Slope**—Lets you define the slope of the catchment section.

**Rational Catchment Collection Dialog Box**

This dialog allows you to specify a composite rational C coefficient for the catchment. It consists of a Area vs. Rational C table in which you can define multiple Rational C values for different areas of the catchment.

- **New**: Creates a new row in the table.
- **Delete**: Deletes the currently highlighted row from the table.
- **Report**: Opens a print preview window containing a report that details the input data for this dialog box.

**Modified Rational Method (UK) Catchment Collection Dialog Box**

This dialog allows you to specify the modified rational method properties for the catchment. It consists of a table in which you can define multiple Antecedent Wetness, Percent Impervious area, and Soile Index values for different areas of the catchment.

- **New**: Creates a new row in the table.
- **Delete**: Deletes the currently highlighted row from the table.
- **Report**: Opens a print preview window containing a report that details the input data for this dialog box.
**Polygon Vertices Dialog Box**

This dialog box lets you define X vs. Y points that plot the shape of the polygon that represents the selected element. The dialog box contains the X vs. Y table that allows you to define any number of points and the following buttons:

- **New**—Creates a new row in the table.
- **Delete**—Deletes the currently highlighted row from the table.

### 5.2.7 Other Tools

Although StormCAD V8i is primarily a modeling application, some additional drafting tools can be helpful for intermediate calculations and drawing annotation. MicroStation and AutoCAD provide a tremendous number of drafting tools. Bentley StormCAD V8i itself (including Stand-Alone) provides the following graphical annotation tools:

- Border tool
- Text tool
- Line tool.

You can add, move, and delete graphical annotations as you would with any network element (see [Manipulating Elements on page 5-274](#)).

**Border Tool**

The Border tool adds rectangles to the drawing pane. Examples of ways to use the Border tool include drawing property lines and defining drawing boundaries.

**To Draw a Border in the Drawing View**

1. Click the **Border** tool in the **Layout** toolbox.
2. Click in the drawing to define one corner of the border.
3. Drag the mouse cursor until the border is the shape and size you want, then click.

**Text Tool**

The text tool adds text to the drawing pane. Examples of ways to use the Text tool include adding explanatory notes, titles, or labels for non-network elements. The size of the text in the drawing view is the same as the size of labels and annotations. You can define the size of text, labels, and annotation in the **Drawing** tab of the **Tools > Options** dialog.
To Add Text to the Drawing View

1. Click the Text tool in the Layout toolbox.
2. Click in the drawing to define where the text should appear.
3. In the Text Editor dialog, type the text as it should appear in the drawing view, then click OK. Note that text will be in a single line (no carriage returns allowed). To add multiple lines of text, add each line separately with the Text tool.

To Rotate Existing Text in the Drawing View

1. Click the Select tool in the Layout toolbox.
2. Right-click the text and select the Rotate command.
3. Move the mouse up or down to define the angle of the text, then click when done.

To Edit Existing Text in the Drawing View

1. Click the Select tool in the Layout toolbox.
2. Right-click the text and select the Edit Text command.
3. Make the desired changes in the Text Editor dialog that appears, then click OK.

Line Tool

The Line tool is used to add lines and polylines (multi segmented lines) to the drawing pane. Bentley StormCAD V8i can calculate the area inside a closed polyline. Examples of ways to use the Line tool include drawing roads or catchment outlines.

To Draw a Line or Polyline in the Drawing View

1. Click the Line tool in the Layout toolbox.
2. Click in the drawing to define where the line should begin.
3. Drag the mouse cursor and click to place the line, or to place a bend if you are drawing a polyline.
4. Continue placing bends until the line is complete, then right-click and select Done.

To Close an Existing Polyline in the Drawing View

1. Click the Select tool in the Layout toolbox.
2. Right-click the polyline and select the Close command.
To Calculate the Area of a Closed Polyline

1. Click the Select tool in the Layout toolbox.
2. Right-click the polyline and select the Enclosed Area command.

To Add a Bend to an Existing Line or Polyline

1. Click the Select tool in the Layout toolbox.
2. Right-click at the location along the line or polyline where the bend should be placed and select the Bend > Add Bend command.

To Remove Bends from an Existing Line or Polyline

1. Click the Select tool in the Layout toolbox.
2. Right-click the bend to be removed and select the Bend > Remove Bend command. To remove all of the bends from a polyline (not a closed polyline), right-click the polyline and select the Bend > Remove All Bends command.

5.3 Flow-Headloss Curves

Flow-Headloss curves can be applied to an catch basin, manhole, or transition node element.

To assign a Flow-Headloss curve to a node element (catch basin, manhole, or transition):

1. Double-click the node element in your model to display the Property Editor, or right-click a node and select Properties from the shortcut menu.
2. In the Physical (Structure Losses) section of the Property Editor, select Flow-Headloss Curve as the Headloss Method. The Flow-Headloss Curve field becomes available.
3. Click the <Select...> list item in the Flow-Headloss Curve field.
4. In the Flow-Headloss Curves Dialog Box, all of the Flow-Headloss Curves that have been created for the model are listed in the left pane. Create a new Curve by clicking the New button.
5. The data for each Flow-Headloss Curve is displayed in the table on the right. Each row in the table represents a data point on the Flow-Headloss Curve curve. Type values for the Flow and Headloss for each row. Click the New button to add a row or press the Tab key to advance to the next field in the table.
6. Perform the following optional steps:
   a. To delete a row from the table, select the row then click Delete.
   b. To view a report on the curve, click Report.

7. Click OK to close the dialog box and save your curve data in the Property Editor.

5.3.1 Flow-Headloss Curves Dialog Box

This dialog box allows you to enter flow vs. headloss data for a catch basin, manhole, or transition element.

The dialog box contains the Flow vs. Headloss table along with the following controls:

- New: This button creates a new Flow-Headloss Curve.
- Duplicate: Creates a copy of the currently selected Flow-Headloss Curve.
- Delete: This button deletes the currently highlighted Flow-Headloss Curve.
- Rename: This button allows you to rename the currently highlighted Flow-Headloss Curve.
- Report: Opens a print preview window containing a report that details the input data for this dialog box.

- Synchronization Options: Clicking this button opens a submenu containing the following commands:
  - Browse Engineering Library—Opens the Engineering Library manager dialog, allowing you to browse the Flow-Headloss Curve Library.
  - Synchronize From Library—Lets you update a flow-headloss curve previously imported from a Flow-Headloss Curve Library. The updates reflect changes that have been made to the library since it was imported.
5.4 Adding Elements to Your Model

StormCAD V8i provides several ways to add elements to your model. They include:

- **Synchronize To Library**—Lets you update an existing Flow-Headloss Curve Library using current flow-headloss curves that were initially imported but have since been modified.
- **Import From Library**—Lets you import a flow-headloss curve from an existing Flow-Headloss Curve Library.
- **Export To Library**—Lets you export the current flow-headloss curve to an existing Flow-Headloss Curve Library.

The table contains the following columns:

- **Flow**: This field allows you to define the flow at the current curve point.
- **Headloss**: This field allows you to define the headloss for the current curve point.

**Flow-Headloss Curve Library Editor**

This dialog allows you to define and edit flow-headloss curves entries in the flow-headloss curve engineering library.

Click the New button to add a new row to the table; click the delete button to remove the currently highlighted row.

The table contains the following columns:

- **Flow**: This field allows you to define the flow at the current curve point.
- **Headloss**: This field allows you to define the headloss for the current curve point.
• Adding individual elements
• Adding elements using the layout tool
• Replacing an element with another element.

**To add individual elements to your model**

1. Click an element symbol on the Layout toolbar. The mouse cursor changes to the element symbol you selected.
2. Click in the drawing pane to add the element to your model.
3. Click again to add another element of the same type to your model.
4. To add a different element, click on the desired element symbol in the Layout toolbar, then click in the drawing pane.
5. To stop adding elements, right-click in the drawing pane to display a shortcut menu, then click **Done**.

**To add elements using the layout tool**

The layout tool is used to quickly add new elements to your model without having to select a new element button on the Layout toolbar. When the layout tool is active, you can right-click in the drawing pane to select different elements and pipes to add to the model.

1. Click the **Layout** tool on the **Layout** toolbar.
2. Right-click in the drawing pane, then select the type of element you want to add from the shortcut menu. The shortcut menu displays only those element types that are compatible with your pipe selection.
3. Click in the drawing pane to add the element.
4. Click again to add another of the same element type. The elements you add will automatically be connected by pipes.
5. To change the element, right-click and select a different element from the shortcut menu.
6. To stop adding elements using the Layout tool, right-click anywhere in the drawing pane and click **Done**.
5.5 Connecting Elements

When building your model, you must consider these rules of connectivity:

- A network needs at least one outfall to end the network.
- Gutters cannot be the only link exiting a catch basin, or the catch basin is considered hydraulically disconnected.

<table>
<thead>
<tr>
<th>Element</th>
<th>Permissible Upstream Elements</th>
<th>Permissible Downstream Elements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catchment</td>
<td>None</td>
<td>Catch basin, manhole</td>
</tr>
<tr>
<td>Manhole</td>
<td>Via a gutter: None</td>
<td>Via a gutter: None</td>
</tr>
<tr>
<td></td>
<td>Via a conduit: Manhole, catch basin, transition, catchment</td>
<td>Via a conduit: Manhole, catch basin, transition, outfall</td>
</tr>
<tr>
<td>Catch basin</td>
<td>Via a gutter: Catch basin</td>
<td>Via a gutter: Catch basin, outfall</td>
</tr>
<tr>
<td></td>
<td>Via a conduit: Manhole, transition, catchment</td>
<td>Via a conduit: Manhole, catch basin, transition, outfall</td>
</tr>
<tr>
<td>Outfall</td>
<td>Via a gutter: Catch basin</td>
<td>Via a gutter: None</td>
</tr>
<tr>
<td></td>
<td>Via a conduit: Manhole, catch basin, transition</td>
<td>Via a conduit: None</td>
</tr>
</tbody>
</table>

5.5.1 When To Use a Conduit vs. a Gutter

Gutters are used in StormCAD V8i only to model the water which exceeds the capacity of in catch basin inlet and must flow through a surface gutter to the next catch basin. A StormCAD V8i gutter can only receive water from a catch basin.

A conduit can refer to any prismatic channel or pipe that conveys flow. The cross section of a conduit must remain constant from one end to the next.

5.5.2 How Do I Get Rainfall from a Catchment Into the Rest of My Model?

To get rainfall to move from a catchment into the rest of your model, you must specify an Outflow Node.
To set the outflow node for a catchment:

1. If the Property Editor is not open, click View > Properties (F4) to open it.
2. Click the catchment for which you want to set an outflow node.
3. In the Catchment section of the Property Editor, click the Outflow Node field to enable the selection drop-down.
4. Click Select if you want to select the outflow node from the model, or select the outflow node from the drop-down list.

5.5.3 **Modeling Catch Basins and Manholes**

Catch basins and manholes can be modeled as one element or they can be modeled as two separate elements. There can be a significant distance and elevation change between the actual catch basin and manhole being modeled, or the lateral between them may be oversized. These factors will influence your decision as to whether the real-world situation would be more accurately modeled using one or two elements.
The diagrams below show an example of the relationship between manholes and catchbasins.

5.6 Manipulating Elements

You can manipulate elements in your model in any one of the following ways:

- Select elements—Manually select individual elements, manually select multiple elements, select all elements, or select all elements of a single element type
- Move elements—Move elements in the drawing pane.
- Delete elements—Remove elements from the model.
• Split pipes—Split an existing pipe into two new pipes by adding a new node element along the existing pipe.
• Reconnect pipes—Disconnect an existing pipe from an existing node element and attach it to another existing node element.

5.6.1 Select Elements

The following element selection options are available:

To manually select an element

Click the element. Selected elements appear in red.

Note: You can change the selection color in the Options dialog box, which is accessible by selecting Tools > Options.

To manually select multiple elements

Click the first element, then click additional elements while holding down Shift or Ctrl.

To select elements by drawing a polygon

1. Select Edit > Select By Polygon.
2. Click in the drawing pane near the elements you want to select, then drag the mouse to draw the first side of the polygon.
3. Click again to finish drawing the first side of the polygon and drag the mouse to begin drawing the next side of the polygon.
4. Repeat step 3 until the polygon is complete, then right-click and select Done.

To select all elements

To select all of the elements in your model, select Edit > Select All.

To select all elements of the same type

To select all elements of the same type (for example, all junction chambers), select Edit > Select by Element, then click the desired element type.

All elements of the selected type appear in red, including connecting pipes.
To clear selected elements

Click the Select tool then click any blank space in the drawing pane.

or

Click Edit > Clear Selection.

or

Press the Esc key.

You can also clear a selected element by clicking a different element.

To move an element in the model

1. Click the Select tool on the Layout toolbar.
2. Select the element(s) you want to move, then drag it to its new location. Pipe connections move with the element.

To delete an element

Select the element, then press Delete.

or

Select Edit > Delete.

5.6.2 Splitting Pipes

You may encounter a situation in which you need to add a new element in the middle of an existing pipe.

To split an existing pipe

1. Select the desired element symbol on the Layout toolbar.
2. In the drawing pane, place the cursor over the pipe you want to split and click.
3. You are prompted to confirm that you want to split the pipe.
If you choose to split the pipe, the element will be inserted and two new pipes will be created with the same characteristics as the original pipe (lengths are split proportionally).

If you choose not to split the pipe, the new element will be placed on top of the pipe without connecting to anything.

If you accidentally split a pipe, this action can be undone by selecting Edit > Undo.

You can also split an existing pipe with an existing element. To do this, drag the element into position along the pipe to be split, then right-click the node and select Split <Pipe Label> from the shortcut menu (where <Pipe Label> is the name of the pipe to be split).

### 5.6.3 Reconnect Pipes

In certain circumstances, you may wish to disconnect a pipe from a node without deleting and redrawing the pipe in question. For example, if the model was built from a database and the Establish By Spatial Data option was used to determine pipe connectivity, pipes may have been connected to the wrong nodes.

**To disconnect and reconnect a pipe:**

1. Right-click the pipe to be disconnected close to the end of the pipe nearest the end that you want disconnected.
2. The pipe is now connected to the junction that it will remain connected to and your mouse cursor. Hover the mouse cursor over the junction to which you would like to connect the pipe and click the left mouse button. The pipe will now be connected to this junction.

### 5.6.4 Modeling Curved Pipes

You can model curved pipes in StormCAD V8i by using the Bend command, which is available by right-clicking in the Drawing Pane when placing a link element.

StormCAD V8i does not account for any additional head loss due to the curvature because in most cases the increased head loss is negligible. If you feel the extra head loss is significant, it is possible to increase the Manning's $n$ value to account for such losses.
To model a curved pipe

1. Select the desired link element using the Layout button on the Layout toolbar.

2. Place the first segment of the curved pipe in your model, then right click and select Bend from the shortcut menu.

3. Repeat Step 2 for each segment in the curved pipe. Be sure to insert bends to clearly show the curved alignment.

4. When the curved pipe is complete, right click and select the next downstream element.

Polyline Vertices Dialog Box

This dialog box contains the X vs. Y table that allows you to define any number of points that plot the shape of the polyline representing the selected link element. The dialog box contains the following controls:

- **New**
  - This button creates a new row in the table.

- **Delete**
  - This button deletes the currently highlighted row from the table.
5.6.5 **Batch Pipe Split Dialog Box**

The Batch Pipe Split dialog allows you to split pipes with neighboring nodes that are found within the specified tolerance.

![Batch Pipe Split Dialog Box](image)

**Choose Features to Process** Allows you to specify which pipes to include in the split operation. The following options are available:

- **All**: All pipes in the model that have a neighboring node within the specified tolerance will be split by that junction.

- **Selection**: Only the pipes that are currently selected in the drawing pane will be split by a neighboring junction that lies within the specified tolerance.

- **Selection Set**: Only those pipes that are contained within the selection set specified in the drop down list will be split by a neighboring junction that lies within the specified tolerance.

**Allow splitting with inactive nodes** When this box is checked, nodes that are marked Inactive will not be ignored during the split operation.

**Tolerance** This value is used to determine how close a pipe must be to a node in order for the pipe to be split by that junction.

Pipes will be split by every junction that falls within the specified tolerance. To prevent unwanted pipe splits, first use the Network Navigator’s “Network Review > Pipe Split Candidates” query to verify that the tolerance you intend to use for the Batch Split operation will not include nodes that you do not want involved in the pipe split operation.
To use the Network Navigator to assist in Batch Pipe Split operations

1. Open the Network Navigator.
2. Click the [>] button and select the Network Review…Pipe Split Candidates query.
3. In the Query Parameters dialog box, type the tolerance you will be using in the pipe split operation and click OK.
4. In the Network Navigator, highlight nodes in the list that you do not want to be included in the pipe split operation and click the Remove button.
5. Open the Batch Pipe Split dialog.
6. Click the Selection button.
7. Type the tolerance you used in the Network Review query and click OK.

Batch Pipe Split Workflow

We recommend that you thoroughly review and clean up your model to ensure that the results of the batch pipe split operation are as expected.

**Note:** Cleaning up your model is something that needs to be done with great care. It is best performed by someone who has good familiarity with the model, and/or access to additional maps/personnel/information that will allow you to make the model match the real world system as accurately as possible.

We provide a number of Network Navigator queries that will help you find "potential" problems (see Using the Network Navigator).

1. Review and clean up your model as much as possible prior to running the "batch split" operation. Run the "duplicate pipes" and "nodes in close proximity" queries first. (Click the View menu and select Queries. In the Queries dialog expand the Queries-Predefined tree. The Duplicate Pipes and Nodes in Close Proximity queries are found under the Network Review folder.)
2. Next, use the network navigator tool to review "pipe split candidates" prior to running batch split.
   a. Using the network navigator tool, run the "pipe split candidates" query to get the list of potential batch split candidate nodes. Take care to choose an appropriate tolerance (feel free to run the query multiple times to settle on a tolerance that works best; jot down the tolerance that you settle on, you will want to use that same tolerance value later when you perform the batch split operation).
   b. Manually navigate to and review each candidate node and use the "network navigator" remove tool to remove any nodes that you do not want to process from the list.
c. After reviewing the entire list, use the network navigator "select in drawing" tool to select the elements you would like to process.

d. Run the batch split tool. Choose the "Selection" radio button to only process the nodes that are selected in the drawing. Specify the desired tolerance, and press OK to proceed.

5.6.6 **Merge Nodes in Close Proximity**

This dialog allows you to merge together nodes that fall within a specified tolerance of one another.

To access the dialog, right-click one of the nodes to be merged and select the **Merge nodes in close proximity** command.

The dialog consists of the following controls:

**Node to keep**: Displays the node that will be retained after the merge operation.

**Tolerance**: Allows you to define the tolerance for the merge operation. Nodes that fall within this distance from the “Node to keep” will be available in the “Nodes to merge” pane.

**Refresh**: Refreshes the nodes displayed in the “Nodes to merge” pane. Click this button after making a change to the tolerance value to update the list of nodes available for the merge operation.

**Select nodes to merge**: Toggle this button on to select the nodes that are selected in the “Nodes to merge” pane in the drawing pane.
Nodes to merge: This pane lists the nodes that fall within the specified tolerance of the “Node to keep”. Nodes whose associated boxes are checked will be merged with the Node to keep when the Merge operation is initiated.

Merge: Performs the merge operation using the nodes whose boxes are checked in the “Nodes to merge” list.

Close: Closes the dialog without performing the merge operation.

5.7 Editing Element Attributes

You edit element properties in the Property Editor, one of the dock-able managers in StormCAD V8i.

To edit element properties:

Double-click the element in the drawing pane. The Property Editor displays the attributes of the selected element.

or

Select the element whose properties you want to edit, then select View > Properties or click the Properties button on the Analysis toolbar.

5.7.1 Property Editor

The Property Editor is a contextual dialog box that changes depending on the status of other dialog boxes. For example, when a network element is highlighted in the drawing pane, the Property Editor displays the attributes and values associated with that element. When one of the manager dialog boxes is active, the Property Editor displays the properties pertaining to the currently highlighted manager element.

Attributes displayed in the Property Editor are grouped into categories. An expanded category can be collapsed by clicking the minus (-) button next to the category heading. A collapsed category can be expanded by clicking the plus (+) button next to the category heading.

For the most efficient data entry in Text Box style fields, instead of clicking on the Field, click on the label to the left of the field you want to edit, and start typing. Press Enter to commit the value, then use the Up/Down keyboard arrows to navigate to the next field you want to edit. You can then edit the field data without clicking the label first; when you are finished editing the field data, press the Enter key, and proceed to the next field using the arrow keys, and so on.
Find Element

The top section of the Property Editor contains the Find Element tool. The Find Element tool is used to:

- Quickly find a recently-created or added element in your model. The Element menu contains a list of the most recently-created and added elements. Click an element in the Element menu to center the drawing pane around that element and highlight it.

- Find an element in your model by typing the element label or ID in the Element menu then clicking the Find button or pressing Enter. The drawing pane centers around the highlighted element.

- Find all elements of a certain type by using an asterisk (*) as a wild-card character. For example, if you want to find all of the pipes in your model, you type co* (this is not case-sensitive) then click the Find button. The drawing pane centers around and highlights the first instance of a pipe in your model, and lists all pipes in your model in the Element menu. For more information about using wildcards, see Using the Like Operator.

- * and # are wildcard characters. If the element(s) you are looking for contains one or more of those characters, you will need to enclose the search term in brackets: [ and ].

- If Find returns multiple results then Network Navigator automatically opens.
The following controls are included:

**Element**
Type an element label or ID in this field then click the Find button to quickly locate it in your model. The element selected in this menu will be centered in the drawing pane when the Zoom To command is initiated, at the magnification level specified by the Zoom Level menu. The drop-down menu lists recently-created or added elements, elements that are part of a selection set, and that are part of the results from a recent Find operation.

**Find**
Zooms the drawing pane view to the element typed or selected in the Element menu at the magnification level specified in the Zoom Level menu.

**Help**
Displays online help for the Property Editor.

**Zoom Level**
Specifies the magnification level at which elements are displayed in the drawing pane when the Zoom To command is initiated.

**Navigate Upstream**
Click this button to move to the next upstream element in the network. This button is only active when the currently highlighted element has an upstream element. If there are more than one upstream elements, a submenu will open allowing you to select the one you want.

**Navigate Downstream**
Click this button to move to the next downstream element in the network. This button is only active when the currently highlighted element has a downstream element. If there are more than one downstream elements, a submenu will open allowing you to select the one you want.

**Add to Selection**
When this box is checked, elements will be added to the current selection as you use the Navigate Upstream and Navigate Downstream elements.
Creating Models

**Customization Profile**  This menu allows you to select the active customization profile (if any have been defined). Customization profiles allow you to turn on/off the visibility of various properties in the Property Grid.

**Customize**  Click this button to open the Customization Manager, which allows you to turn on/off the visibility of various properties in the Property Grid. This button is only available when a previously created customization profile is currently selected in the Customization Profile menu.

**Categorized**  Displays the fields in the Property Editor in categories. This is the default.

**Alphabetic**  Displays the fields in the Property Editor in alphabetical order.

**Property Pages**  Displays the property pages.

**Definition bar**  The space at the bottom of the Properties editor is where the selected field is defined.

**Labeling Elements**

When elements are placed, they are assigned a default label. You can define the default label using the **Labeling** tab of the **Tools > Options** dialog.

You can also relabel elements that have already been placed using the Relabel command in the element FlexTables.

**Relabeling Elements**

You can relabel elements from within the Property Editor.
To relabel an element

1. Select the element in the Drawing Pane then, if the Property Editor is not already displayed, select View > Properties.
2. In the General section of the Property Editor, click in the Label field, then type a new label for the element.

Set Field Options Dialog Box

The Set Field Options dialog box is used to set the units for a specific attribute without affecting the units used by other attributes or globally.

To use the Set Field Options dialog box, right-click any numerical field that has units, then select Units and Formatting.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value</td>
<td>Displays the value of the currently selected item.</td>
</tr>
<tr>
<td>Unit</td>
<td>Displays the type of measurement. To change the unit, select the unit you want to use from the drop-down list. With this option you can use both U.S. customary and S.I. units in the same worksheet.</td>
</tr>
<tr>
<td>Display Precision</td>
<td>Sets the rounding of numbers and number of digits displayed after the decimal point. Enter a negative number for rounding to the nearest power of 10: (-1) rounds to 10, (-2) rounds to 100, (-3) rounds to 1000, and so on. Enter a number from 0 to 15 to indicate the number of digits after the decimal point.</td>
</tr>
</tbody>
</table>
**Format**

Selects the display format used by the current field.

Choices include:

- **Scientific**—Converts the entered value to a string of the form "-d.ddd...E+ddd" or "-d.ddd...e+ddd", where each 'd' indicates a digit (0-9). The string starts with a minus sign if the number is negative.

- **Fixed Point**—Abides by the display precision setting and automatically enters zeros after the decimal place to do so. With a display precision of 3, an entered value of 3.5 displays as 3.500.

- **General**—Truncates any zeros after the decimal point, regardless of the display precision value. With a display precision of 3, the value that would appear as 5.200 in Fixed Point format displays as 5.2 when using General format. The number is also rounded. So, an entered value of 5.35 displays as 5.4 regardless of the display precision.

- **Number**—Converts the entered value to a string of the form "-d,ddd,ddd,ddd...", where each 'd' indicates a digit (0-9). The string starts with a minus sign if the number is negative. Thousand separators are inserted between each group of three digits to the left of the decimal point.

**5.8 Adding Storm Data**

A storm data definition is a single rainfall curve that represents one rainfall event for a given recurrence interval. The rainfall curve can be represented in one of five ways:

- User Defined IDF Table
- Hydro-35
- IDF Table Equation
- IDF Curve Equation
- IDF Polynomial Log Equation
- UK Standard
Adding Storm Data

Once the storm data definition is created it is applied to the model by assigning it to a Global Storm Event. This will apply the storm event to the current scenario. This storm event will then be applied to all catchments during analysis.

Storm Data definitions are created in the Storm Data Dialog Box.

Storm Events are then applied to the model in the Global Storm Events Dialog Box.

For background on rainfall data, see the Modeling Rainfall chapter in Stormwater Conveyance Modeling and Design. This book is published by and available from Bentley Institute Press.

5.8.1 Storm Data Dialog Box

The Storm Event dialog box allows you to create, edit, and delete the Storm Data definitions that will make up the Global Storm Events that are applied to the model.

A storm data definition can be created in any of the following ways, both from within the Storm Data dialog box:

- You can manually create a storm data definition by clicking the New button and selecting one of the five methods in the Storm Data dialog.
- You can import storm data definitions from a text file.
- You can import a storm data definition from the associated Storm Event Group engineering library. To do so, click the Engineering Libraries button and select Import From Library in the Storm Data dialog.

The dialog box contains a list pane on the left, a tabbed input data area on the upper right, and a graph pane on the lower right, and includes the following controls:

- **New**: Creates a new storm data definition that uses an automatically created label.
  - **User Defined IDF Table**—Adds a new storm event to the list pane of the type User Defined IDF Table.
  - **Hydro-35**—Adds a new storm event to the list pane of the type Hydro-35.
  - **IDF Table Equation**—Adds a new storm event to the list pane of the type IDF Table Equation.
  - **IDF Curve Equation**—Adds a new storm event to the list pane of the type IDF Curve Equation.
- **IDF Polynomial Log Equation**—Adds a new storm event to the list pane of the type IDF Polynomial Log Equation
- **UK Standard**—Adds a new storm event to the list pane of the type UK Standard.

**Delete**: Deletes the currently highlighted storm data definition.

**Rename**: Lets you rename the currently highlighted storm data definition.

**Report**: Lets you generate a preformatted report that contains the input data associated with the currently highlighted storm data definition.

**Import**: Opens a browse dialog, allowing you to select a text file from which to import storm definition data.

**Engineering Libraries**: Clicking this button opens a submenu containing the following commands:

- **Browse Engineering Library**—Opens the Engineering Library manager dialog, allowing you to browse the Storm Event Groups Library.
- **Synchronize From Library**—Lets you update a set of storm data definitions previously imported from a Storm Event Groups Library. The updates reflect changes that have been made to the library since it was imported.
- **Synchronize To Library**—Lets you update an existing Storm Event Groups Library using current storm data definitions that were initially imported but have since been modified.
- **Import From Library**—Lets you import a storm data definition from an existing Storm Event Groups Library.
- **Export To Library**—Lets you export the current storm data definitions to an existing Storm Event Groups Library.

The fields and controls that appear in the tabbed area depend on which definition type is currently highlighted in the list pane on the left.
User Defined IDF Table

When you create a definition of the User Defined IDF Table definition type, a default IDF Table is created with all values set to 0. You can add or remove Durations and Return Periods using the buttons above the table.

When editing a definition of the User Defined IDF Table definition type, the tabbed area of the dialog contains the following controls:

**IDF Storm Event Input Tab**

- **Add/Remove Return Periods**: Opens a submenu containing the following commands:
  - *Add Return Period*—Adds a column to the table for the specified return period. When you select this command an Add Return Period dialog will open, allowing you to type the return period in years for the new column.
  - *Add Range*—Adds columns to the table for multiple return periods that are specified in the Add Multiple Return Periods dialog that opens when this command is selected.
  - *Delete <Return Period>*—A Delete command will be added to the submenu for each return period (column) in the table. Use the Delete command to remove the undesired column from the table.

- **Add/Remove Durations**: Opens a submenu containing the following commands:
  - *Add Duration*—Adds a row to the table for the specified duration. When you select this command an Add Duration dialog will open, allowing you to type the duration in minutes (by default, you may select another unit to use) for the new row.
  - *Add Range*—Adds rows to the table for multiple durations that are specified in the Add Multiple Durations dialog that opens when this command is selected.
  - *Delete <Duration>*—A Delete command will be added to the submenu for each duration (row) in the table. Use the Delete command to remove the undesired row from the table.

**Notes Tab**

This tab contains a text field that allows you to enter descriptive notes that will be associated with the currently highlighted storm data definition.
Library Tab

This tab displays information about the storm data definition that is currently highlighted in the list pane. If the storm data definition is derived from an engineering library, the synchronization details can be found here. If the storm data definition was created manually for this project, the synchronization details will display the message Orphan (local), indicating that the storm data definition was not derived from a library entry.

Hydro-35

When editing a definition of the Hydro-35 definition type, the tabbed area of the dialog contains the following controls:

IDF Storm Event Input Tab

Data Tables: When you create a definition of the Hydro-35 definition type, the dialog will display 2 tables in the tabbed area:

- The upper table is the input table. It includes input fields for depth for the 2 year and 100 year return periods at 5, 15, and 60 minutes.
- The lower table is the non-editable results table. The results table displays the rainfall intensity values for the 2, 5, 10, 25, 50 and 100 year return periods at durations of 5, 10, 15, 30 and 60 minutes.

Notes Tab

This tab contains a text field that allows you to enter descriptive notes that will be associated with the currently highlighted storm data definition.

Library Tab

This tab displays information about the storm data definition that is currently highlighted in the list pane. If the storm data definition is derived from an engineering library, the synchronization details can be found here. If the storm data definition was created manually for this project, the synchronization details will display the message Orphan (local), indicating that the storm data definition was not derived from a library entry.
IDF Table Equation

The IDF Table Equation definition type calculates the storm data using the following equation:

\[ i = \frac{a \cdot R_p^m}{(b + D)^n} \]

Where

- \( i \) = rainfall intensity
- \( D \) = rainfall duration
- \( R_p \) = return period
- \( a, b, m, n \) = rainfall equation coefficients

When editing a definition of the IDF Table Equation type, the tabbed area of the dialog contains the following controls:

IDF Storm Event Input Tab

**Equation Duration Unit**: Specify the unit to be used for duration (D) value in the equation.

**Equation Intensity Unit**: Specify the unit to be used for intensity (i) value in the equation.

- \( a \): Specify the value to be used for the a coefficient in the equation.
- \( m \): Specify the value to be used for the m coefficient in the equation.
- \( b \): Specify the value to be used for the b coefficient in the equation.
- \( n \): Specify the value to be used for the n coefficient in the equation.

**Results Table**: This table displays the calculated rainfall intensity values for the 2, 3, 5, 10, 25, 50, 100, 200, and 500 year return periods at durations of 5, 10, 15, 20, 30, 40, 50, 60, 80, 100, and 120 minutes.

Notes Tab

This tab contains a text field that allows you to enter descriptive notes that will be associated with the currently highlighted storm data definition.

Library Tab
This tab displays information about the storm data definition that is currently highlighted in the list pane. If the storm data definition is derived from an engineering library, the synchronization details can be found here. If the storm data definition was created manually for this project, the synchronization details will display the message Orphan (local), indicating that the storm data definition was not derived from a library entry.

IDF Curve Equation

The IDF Table Equation definition type calculates the storm data using the following equation:

\[ i = \frac{a}{(b + D)^n} \]

Where

- \( i \) = rainfall intensity
- \( D \) = rainfall duration
- \( a, b, n \) = rainfall equation coefficients

When editing a definition of the IDF Table Equation type, the tabbed area of the dialog contains the following controls:

IDF Storm Event Input Tab

**Equation Duration Unit**: Specify the unit to be used for duration (D) value in the equation.

**Equation Intensity Unit**: Specify the unit to be used for intensity (i) value in the equation.

**Add Button**: Adds another Return Period row to the table. When you click this button an Add Return Period dialog appears, allowing you to specify the return period for the new row.

**Delete Button**: Removes the currently highlighted Return Period row from the table.

**a (log)**: Specify the value to be used for the a coefficient in the equation for the associated return period.

**b**: Specify the value to be used for the b coefficient in the equation for the associated return period.

**n**: Specify the value to be used for the n coefficient in the equation for the associated return period.
Adding Storm Data

**Results Table:** This table displays the calculated rainfall intensity values for the each of the return periods in the table at durations of 5, 10, 15, 20, 30, 40, 50, 60, 80, 100, and 120 minutes.

**Notes Tab**

This tab contains a text field that allows you to enter descriptive notes that will be associated with the currently highlighted storm data definition.

**Library Tab**

This tab displays information about the storm data definition that is currently highlighted in the list pane. If the storm data definition is derived from an engineering library, the synchronization details can be found here. If the storm data definition was created manually for this project, the synchronization details will display the message Orphan (local), indicating that the storm data definition was not derived from a library entry.

**IDF Polynomial Log Equation**

The IDF Polynomial Log Equation definition type calculates the storm data using the following equation:

\[ i = a + b \cdot (\ln D) + c \cdot (\ln D)^2 + d \cdot (\ln D)^3 \]

**Where**

- \( i \) = rainfall intensity
- \( D \) = rainfall duration
- \( a, b, c, d \) = rainfall equation coefficients

When editing a definition of the IDF Polynomial Log Equation type, the tabbed area of the dialog contains the following controls:

**IDF Storm Event Input Tab**

**Equation Duration Unit:** Specify the unit to be used for duration (D) value in the equation.

**Equation Intensity Unit:** Specify the unit to be used for intensity (i) value in the equation.
Add Button: Adds another Return Period row to the table. When you click this button an Add Return Period dialog appears, allowing you to specify the return period for the new row.

Delete Button: Removes the currently highlighted Return Period row from the table.

a (log): Specify the value to be used for the a coefficient in the equation for the associated return period.

b (log): Specify the value to be used for the b coefficient in the equation for the associated return period.

c (log): Specify the value to be used for the c coefficient in the equation for the associated return period.

d (log): Specify the value to be used for the d coefficient in the equation for the associated return period.

Results Table: This table displays the calculated rainfall intensity values for each of the return periods in the table at durations of 5, 10, 15, 20, 30, 40, 50, 60, 80, 100, and 120 minutes.

Notes Tab

This tab contains a text field that allows you to enter descriptive notes that will be associated with the currently highlighted storm data definition.

Library Tab

This tab displays information about the storm data definition that is currently highlighted in the list pane. If the storm data definition is derived from an engineering library, the synchronization details can be found here. If the storm data definition was created manually for this project, the synchronization details will display the message Orphan (local), indicating that the storm data definition was not derived from a library entry.

To Import a comma or space delimited ASCII text file:

1. Click Import in the Storm Data dialog, and select the location and name of the file containing the rainfall table in ASCII format to import. You may see a prompt warning you that any existing storm data will be overwritten - if you do not want this, click Cancel.

2. Select Open to import the ASCII text file, or Cancel to exit without saving the changes.
Note: When importing an ASCII text file, the following format is assumed: The first line of the imported text file contains the return periods. The first entry in each succeeding line of the file contains the storm duration. All other entries represent rainfall intensities, which are assumed to be in the current display unit (i.e. in/hr, mm/hr, etc.).

An example in comma separated format is given below for return periods of 1, 2, 5, 10, 20, 50 and 100 years, and durations of 5, 15, 30 and 60 minutes):

\[1 , 2 , 5 , 10 , 20 , 50 , 100\]
\[5 , 47.0 , 63 , 87 , 103 , 125 , 157 , 183\]
\[15 , 29.7 , 39.5 , 54 , 63 , 76 , 95 , 110\]
\[30 , 20.8 , 27.5 , 37.1 , 43.5 , 52 , 64 , 75\]
\[60 , 14.0 , 18.4 , 24.5 , 28.6 , 34.0 , 41.8 , 48.1\]

When editing a definition of the Hydro-35 definition type, the tabbed area of the dialog contains the following controls:

**UK Standard**

**Storm Event Input Tab**

To define the storm, enter the following information:

- **UK Standard Location**: Select the location to be used.
- **R**: Define the ratio. The ratio designates the scalability of a small design storm to a larger design storm for the same land parcel.
- **M5-60**: Define the cumulative rainfall depth total that should be estimated from the maps to the nearest 0.5 mm.

When the above data has been entered, StormCAD will calculate and populate the non-editable results table. The results table displays the rainfall intensity values for the 2, 5, 10, 25, 50 and 100 year return periods at durations of 5, 10, 15, 30 and 60 minutes.

**Notes Tab**

This tab contains a text field that allows you to enter descriptive notes that will be associated with the currently highlighted storm data definition.

**Library Tab**
This tab displays information about the storm data definition that is currently highlighted in the list pane. If the storm data definition is derived from an engineering library, the synchronization details can be found here. If the storm data definition was created manually for this project, the synchronization details will display the message Orphan (local), indicating that the storm data definition was not derived from a library entry.

### 5.8.2 Global Storm Events Dialog Box

Global Storm Events contain project-wide storm data derived from the Storm Data definitions created in the Storm Data Dialog Box. Global Storm Events are applied to all catchments during analysis. Global storm events are associated with Rainfall Runoff alternatives.

You define project-wide global storm events in the Global Storm Events dialog box.

**To add a global storm event:**

1. Select Components > Global Storm Events.
2. In the Global Storm Events dialog box, each row in the table represents a Rainfall Runoff alternative. In the Global Storm Event column, select the storm data definition from the submenu or click the **Ellipses (...)** button to display the Storm Data dialog box, where you can create a new storm data definition.
3. The rest of the data is automatically added to the table based on the settings of the selected storm event. Click **Close**.

The dialog box contains a table with the following columns:

- **Alternative:** Displays the name of the Rainfall Runoff alternative that is used by the current scenario.
- **Global Storm Event:** Lists all of the storm data definitions that have been created for the current project in the Storm Data dialog box, which is accessible by clicking the ellipsis button.
- **Storm Event Source:** Displays the location of the library file for storm data definitions that are derived from an engineering library entry. Displays the message Orphan (local) if the event was created for this project and does not reference a library storm.
5.8.3 User Defined IDF Table Dialog Box

This dialog allows you to define intensity-duration-frequency tables. These tables are stored in the Storm Event Groups Engineering Library, and can be used to define Global and local Storm Events (see Adding Storm Data for more information).

The dialog contains the following controls:

Return Event: Lets you enter the return event, a value that reflects the average time between similar storm events.

IDF Curve: Opens the IDF Curve Dialog Box, which allows you to define time vs. intensity curves that describe the current storm event.

IDF Curve Dialog Box

This dialog allows you to define time vs. intensity points to create IDF curves that are used with User Defined IDF Tables.

The table consists of the following columns:

Time: Lets you enter the time for the associated intensity value.

Intensity: Lets you enter the intensity for the associated time.

5.8.4 IDF Curve Equation Input Dialog Box

This dialog allows you to define the return event and the a, b, and n coefficients that describe the storm using the following equation:

\[ i = \frac{a}{(b + D)^n} \]
Where

\[ i = \text{rainfall intensity} \]

\[ D = \text{rainfall duration} \]

\[ a, b, n = \text{rainfall equation coefficients} \]

Enter the **Return Event** and the values for the \(a\), \(b\), and \(n\) coefficients. Click the **New** button to add a row to the table, and **Delete** to remove the currently highlighted row.

### 5.8.5 IDF Polynomial Log Equation Dialog Box

The IDF Polynomial Log Equation definition type calculates the storm data using the following equation:

\[ i = a + b \cdot (\ln D) + c \cdot (\ln D)^2 + d \cdot (\ln D)^3 \]

Where

\[ i = \text{rainfall intensity} \]

\[ D = \text{rainfall duration} \]
Creating Inlets

5.9 Creating Inlets

You have the following three options when assigning an inlet type to a catch basin element:

Maximum Capacity: When using this inlet type, any flow up to the specified maximum inflow that reaches the inlet will be captured and added to the total flow for the associated catch basin element.

Percent Capture: When using this inlet type, only the specified percentage of flow that reaches the inlet will be captured and added to the total flow for the associated catch basin element.

Catalog Inlet: This option allows you to select an inlet that was previously created in the Inlet Catalog Dialog Box, or to access the Inlet Catalog dialog box and create a new inlet.
To assign an inlet type to a catch basin element:

1. Double-click the catch basin to highlight it in the in the drawing pane and open the Properties dialog for that catchment.

2. Under the Inlet section, click the Inlet Type field and select either Maximum Capacity, Percent Capture, or Catalog Inlet. 
   a. If you select Maximum Capacity, enter a value in the Maximum Inflow field to define the upper limit of inflow that will be captured by the inlet. Skip the following steps.
   b. If you select Percent Capture, enter a value in the Capture Efficiency field to define the percentage of inflow that will be captured by the inlet. Skip the following steps.
   c. If you select Catalog Inlet, continue on with the next step.

3. Click the Inlet field and select a previously defined Inlet definition or choose the <Select..> command to open the Inlet Catalog dialog and create a new one. For more information about creating inlet definitions in the Inlet Catalog Dialog Box topic.

5.9.1 Inlet Catalog Dialog Box

The Inlet Catalog dialog box allows you to create, edit, and delete inlet definitions that can then be assigned to catchment elements in your model.

The following inlet types are available from this dialog:

- Combination
- Kerb
- Ditch
- Grating
- Slot
- Flow to Inlet vs. Flow Captured
- Kerb Channel Depth vs. Captured Flow
- Kerb (UK)
- Grating (UK)

You can also import an inlet definition from the Inlet Libraries Engineering Library, and export inlet definitions to the Engineering Library for later use.

The dialog box contains a list pane on the left and a tabbed input data area on the right, and includes the following controls:
New: Creates a new inlet definition in the list pane on the left.

Duplicate: Copies the currently highlighted inlet definition.

Delete: Deletes the currently highlighted inlet definition.

Rename: Lets you rename the currently highlighted inlet definition.

Report: Lets you generate a preformatted report that contains the input data associated with the currently highlighted inlet definition.

Synchronization Options: Clicking this button opens a submenu containing the following commands:

- **Browse Engineering Library**—Opens the Engineering Library manager dialog, allowing you to browse the Inlet Libraries.
- **Synchronize From Library**—Lets you update a set of inlet definitions previously imported from one of the Inlet Libraries. The updates reflect changes that have been made to the library since it was imported.
- **Synchronize To Library**—Lets you update one of the existing Inlet Libraries using current inlet definitions that were initially imported but have since been modified.
- **Import From Library**—Lets you import a inlet definition from one of the existing Inlet Libraries.
- **Export To Library**—Lets you export the current inlet definitions to one of the existing Inlet Libraries.
- **Connect to Library**—Lets you create a connection between the inlet catalog and the specified engineering library.

The fields and controls that appear in the tabbed area depend on which inlet type is chosen. Not all fields will be available for all inlet types.

**Inlet Tab**

- Structure Width: Define the width of the inlet structure. This field is available for all inlet types.
• Structure Length: Define the length of the inlet structure. This field is available for all inlet types.
• Kerb Opening Height: Define the height of the kerb opening. This field is available for Kerb and Combination inlet types.
• Default Kerb Opening Length: Define the default length of the kerb opening. This field is available for Kerb and Combination inlet types.
• Local Depression: Define the depth of the gutter depression at the inlet, if any. This field is available for Kerb and Combination inlet types.
• Depression Width: Define the width of the gutter depression at the inlet, if any. This field is available for Kerb and Combination inlet types.
• Throat Type: Choose the throat type. The throat type defines the shape of kerb opening. This field is available for Kerb and Combination inlet types.
• Throat Angle: Define the angle of the inlet throat. This field is only available when the Inclined Throat Type is chosen. This field is available for Kerb and Combination inlet types.
• Grating Type: Choose the grating type. This field is available for Combination, Ditch, and Grating inlet types.
• Grating Width: Define the width of the grating. This field is available for Combination, Ditch, and Grating inlet types.
• Default Grating Length: Define the default length of the grating. This field is available for Combination, Ditch, and Grating inlet types.
• Slot Width: Define the default width of the slot. This field is available for Slot inlet type.
• Default Slot Length: Define the default length of the slot. This field is available for Slot inlet type.
• Flow to Inlet vs. Flow Captured Table: This table is only available when the Flow to Inlet vs. Flow Captured Inlet type is selected. It allows you to define the amount of Flow Captured at various Flow to Inlet points. Click the New button to add a new row to the table. Click the Delete button to remove the currently highlighted row from the table.
Creating Inlets

- Kerb Channel vs. Captured Flow Table: This table is only available when the Kerb Channel Depth vs. Captured Flow Inlet type is selected. It allows you to define the amount of Captured Flow at various Kerb Channel Depth values. Click the New button to add a new row to the table. Click the Delete button to remove the currently highlighted row from the table.

- Default Kerb Opening Length: Define the opening length; this length is the Li dimension in the following diagram:

![Diagram of Angled Kerb Inlet]

Design Tab

This tab contains a list of allowable design lengths. When performing a design analysis, the program will only be able to select inlets of one of lengths specified here. To add a new length to the list, click the New button and type in the length. To remove a length from the list, highlight it and click the Delete button.

Notes Tab

This tab contains a text field that allows you to enter descriptive notes that will be associated with the currently highlighted inlet definition.

Library Tab

This tab displays information about the inlet definition that is currently highlighted in the list pane. If the inlet definition is derived from an engineering library, the synchronization details can be found here. If the inlet definition was created manually for this project, the synchronization details will display the message Orphan (local), indicating that the inlet definition was not derived from a library entry.
To create a new Inlet:

1. Click the New button above the list pane.
2. Type a name for the inlet.
3. Choose an Inlet Type from the Inlet Type field in the tabbed section to the right.
4. Type in input data in the input fields in the tabbed section to the right. The available fields will vary according to the Inlet Type that is chosen.
5. Click Close when you have finished defining the inlet parameters.

To import an inlet from the Engineering Library:

1. Click the Synchronization Options button and select Import From Library from the submenu.
2. Expand the Inlet Libraries node to view all of the existing Inlet Libraries. There will be the default Inlets Library, along with any additional custom libraries you've created.
3. Expand the desired library to view all of the inlet definitions within that library. Click on the inlet definitions to view their properties on the right side of the dialog.
4. When you have chosen the desired inlet definition click the Select button. The new inlet will appear in the list pane.

To access the Inlet Catalog

In Stand-Alone and Microstation, click the Components menu and select the Inlet Catalog command.

In AutoCAD mode, click the StormCAD menu, then select Components > Inlet Catalog.

Default Curb and Grate Lengths

When you assign a catalog inlet to a catch basin, StormCAD V8i will assign the default curb and grate length values for that catalog inlet (as defined in the Default Curb Opening Length and Default Grate Length fields) to the catch basin’s curb opening length and grate length respectively. However, you can also manually change the values for the catch basin so that it the catalog inlet values and catch basin values are not in sync. When you perform an analysis computation run, the value in the catch basin attribute is used. When you do a design run, the value of the catch basin attribute is initially used, but then that catch basin attribute can be changed during design to one of the available curb opening lengths listed in the design tab of the refer-enced catalog inlet.
Design Grating Types Dialog Box

This dialog allows you to define the grating type classification(s) for entries in the Inlet Engineering Library.

![Design Grating Types Dialog Box](image)

The following controls are available:

- **New**: Creates a new row in the table.
- **Delete**: Deletes the currently highlighted row from the table.
Design Lengths Dialog Box

This dialog allows you to define the design lengths for Kerb-type inlets in the Inlet Engineering Library.

The following controls are available:

- **New**: Creates a new row in the table.
- **Delete**: Deletes the currently highlighted row from the table.
Creating Inlets

**Kerb Channel Vs Captured Flow Dialog Box**

This dialog allows you to define the kerb channel depth vs captured flow curve for inlet engineering library entries.

![Kerb Channel Vs Captured Flow Dialog Box](image)

The following controls are available:

- **New**: Creates a new row in the table.
- **Delete**: Deletes the currently highlighted row from the table.

### 5.9.2 Modeling Neenah Grates

The Neenah Foundry Company (Neenah, Wisconsin - http://www.nfco.com) produces an extensive range of storm water inlets/catch basins, commonly referred to as 'Neenah grates'.

These Neenah grates are not currently included in the default StormCAD Engineering Libraries, but in StormCAD V8 it is quite straightforward for users to add them as required.

**To Model a Neenah Grate for On Grade Inlets:**

1. Click the **Components** menu, then select **Inlets**.
2. In the Inlets Catalog dialog, click **New**. Type a name for the new inlet.
Creating Models

Note: We suggest using the Neenah catalog number, and the transverse and longitudinal slopes that the curve capacity values will correspond too).

Unlike the in HEC-22 calculations, there is no general relationship available for Neenah grate capacity versus longitudinal slope, so each Neenah grate is entered in StormCAD as a Kerb Channel Depth vs. Captured Flow curve which is specific to a particular transverse and longitudinal slope.

3. Next click Inlet Type and select Kerb Channel Depth vs. Captured Flow. Enter the below ground Structure Width and Structure Length.

4. Now refer to the Neenah technical information to find the K value associated with this grate (for the appropriate transverse and longitudinal slopes).

5. For this example, for a longitudinal slope of 2% and a tranverse slope of 5%, use a K value of 16. Then a depth versus captured flow relationship can be determined using the equation: 

\[ Q = K \cdot D^{(5/3)} \]

So:

**Table 5-3: Depth vs. Flow Values**

<table>
<thead>
<tr>
<th>Depth (ft)</th>
<th>Flow (cfs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>0.05</td>
<td>0.11</td>
</tr>
<tr>
<td>0.10</td>
<td>0.34</td>
</tr>
<tr>
<td>0.15</td>
<td>0.68</td>
</tr>
<tr>
<td>0.20</td>
<td>1.09</td>
</tr>
<tr>
<td>0.25</td>
<td>1.59</td>
</tr>
<tr>
<td>0.30</td>
<td>2.15</td>
</tr>
</tbody>
</table>
### Table 5-3: Depth vs. Flow Values

<table>
<thead>
<tr>
<th>Depth (ft)</th>
<th>Flow (cfs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.35</td>
<td>2.78</td>
</tr>
<tr>
<td>0.40</td>
<td>3.47</td>
</tr>
<tr>
<td>0.45</td>
<td>4.23</td>
</tr>
<tr>
<td>0.50</td>
<td>5.04</td>
</tr>
</tbody>
</table>

6. Now this relationship can be copied and pasted into the Kerb Channel Depth vs. Captured Flow area of the Inlet editor. To do this, copy the data to the windows clipboard, then in StormCAD, select the top right cell in Kerb Channel Depth vs. Captured Flow grid and press Ctrl+V to paste.

**Note:** Make sure the units used in the Inlet editor match the units used in determining the Depth vs. Captured Flow relationship.

This inlet is now set up and ready to use in the current StormCAD project. To make it available for use in other projects, click on the Synchronization Options button and select Export to Library.

**To Model a Neenah Grate for In Sag Inlets:**

For rectangular grates in sag, it is generally possible to enter a Neenah grate as a standard **Grate Inlet Type**.

However, please note that the StormCAD uses the HEC-22 methodology for computing capacity, which does not always produce capacities that correspond to capacities given by Neenah Foundary (since some discharge coefficients are slightly different).

The designer should verify that they are satisfied with the calculated capacity in these cases.
For non-rectangular grates, the designer should compute, or request from Neenah Foundry, a Kerb Channel Depth vs. Captured Flow relationship for the grate and then enter that in StormCAD using a procedure similar to the procedure outlined for Inlets On Grade above.

Note that the capacities of grate inlets in sag are not a function of the transverse of longitudinal slopes, so one Kerb Channel Depth vs. Captured Flow curve per grate is sufficient for all transverse and longitudinal slopes.

### 5.10 Using Named Views

The Named View dialog box is where you can store the current views X and Y coordinates. When you set a view in the drawing pane and add a named view, the current view is saved as the named view. You can then center the drawing pane on the named view with the **Go To View** command.

Choose View > Named Views to open the Named View dialog box.
The toolbar contains the following controls:

**New**
Contains the following commands:
- **Named View**—Opens a Named View Properties box to create a new named view.
- **Folder**—Opens a Named Views Folder Properties box to enter a label for the new folder.

**Delete**
Deletes the named view or folder that is currently selected.

**Rename**
Rename the currently selected named view or folder.

**Go to View**
Centers the drawing pane on the named view.

**Shift Up and Shift Down**
Moves the selected named view or folder up or down.

**Expand All or Collapse All**
Expands or collapses the named views and folders.

**Help**
Displays online help for Named Views.
5.11 Using Selection Sets

Selection sets are user-defined groups of network elements. They allow you to predefine a group of network elements that you want to manipulate together. You manage selection sets in the Selection Sets Manager.

StormCAD V8i contains powerful features that let you view or analyze subsets of your entire model. You can find these elements using the Network Navigator (see Using the Network Navigator). The Network Navigator is used to choose a selection set, then view the list of elements in the selection set or find individual elements from the selection set in the drawing.

In order to use the Network Navigator, you must first create a selection set. There are two ways to create a selection set:

- From a selection of elements—You create a new selection set in the Selection Sets Manager, then use your mouse to select the desired elements in the drawing pane.
- From a query—Create a query in the Query Manager, then use the named query to find elements in your model and place them in the selection set.

The following illustration shows the overall process.

You can perform the following operations with selection sets:

- To view elements in a Selection Set on page 5-316
- To Create a Selection Set from a Selection on page 5-317
- To create a Selection Set from a Query on page 5-317
- To add elements to a Selection Set on page 5-318
- To remove elements from a Selection Set on page 5-319
5.11.1 Selection Sets Manager

The Selection Sets Manager is used to create, edit, and navigate to selection sets. The Selection Sets Manager consists of a toolbar and a list pane, which displays all of the selection sets that are associated with the current project.

To open Selection Sets, click the View menu and select the Selection Sets command, press <Ctrl+4>, or click the Selection Sets button on the View toolbar.
The toolbar contains the following buttons:

**New**

Contains the following commands:

- **Create from Selection**—Creates a new static selection set from elements you select in your model.
- **Create from Query**—Creates a new dynamic selection set from existing queries.

**Delete**

Deletes the selection set that is currently highlighted in the list pane. This command is also available from the short-cut menu, which you can access by right-clicking an item in the list pane.

**Duplicate**

Copies the Selection Set that is selected.
Using Selection Sets

**Edit**
- When a selection-based selection set is highlighted and you click this button, it opens the Selection Set Element Removal dialog box, which edits the selection set. This command is also available from the short-cut menu, which you can access by right-clicking an item in the list pane.
- When a query-based selection set is highlighted and you click this button, it opens the Selection By Query dialog box, which adds or removes queries from the selection set. This command is also available from the short-cut menu, which you can access by right-clicking an item in the list pane.

**Rename**
Renames the selection set that is currently highlighted in the list pane. This command is also available from the short-cut menu, which you can access by right-clicking an item in the list pane.

**Select In Drawing**
Selects all the elements in the drawing pane that are part of the currently selected selection sets. This command is also available from the short-cut menu, which you can access by right-clicking an item in the list pane.

**Help**
Displays online help for the Selection Sets Manager.

You can view the properties of a selection in the Property Editor by right-clicking the selection set in the list pane and selecting **Properties** from the shortcut menu.

**To view elements in a Selection Set**

You use the Network Navigator to view the elements that make up a selection set.

1. Open the Network Navigator by selecting View > Network Navigator or clicking the Network Navigator button on the View toolbar.
Tip: You can double-click an element in the Network Navigator to select and center it in the Drawing Pane.

To Create a Selection Set from a Selection

You create a new selection set by selecting elements in your model.

1. Select all of the elements you want in the selection set by either drawing a selection box around them or by holding down the Ctrl key while clicking each one in turn.
2. When all of the desired elements are highlighted, right-click and select Create Selection Set.
3. Type the name of the selection set you want to create, then click OK to create the new selection set. Click Cancel to close the dialog box without creating the selection set.
4. Alternatively, you can open the Selection Set manager and click the New button and select Create from Selection. Bentley StormCAD V8i prompts you to select one or more elements.

Create Selection Set Dialog Box

This dialog box opens when you create a new selection set. It contains the following field:

**New selection set name**  Type the name of the new selection set.

To create a Selection Set from a Query

You create a dynamic selection set by creating a query-based selection set. A query-based selection set can contain one or more queries, which are valid SQL expressions.

1. In the Selection Sets Manager, click the New button and select Create from Query. The Selection by Query dialog box opens.
2. Available queries appear in the list pane on the left; queries selected to be part of the selection set appear in the list pane on the right. Use the arrow buttons in the middle of the dialog to add one or all queries from the Available Queries list to the Selected Queries list, or to remove queries from the Selected list.
   - You can also double-click queries on either side of the dialog box to add them to or remove them from the selection set.

Selection by Query Dialog Box

The Selection by Query dialog box is used to create selection sets from available queries. The dialog box contains the following controls:
### Using Selection Sets

<table>
<thead>
<tr>
<th>Table Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Available Queries</strong></td>
<td>Contains all the queries that are available for your selection set. The Available Columns list is located on the left side of the dialog box.</td>
</tr>
<tr>
<td><strong>Selected Queries</strong></td>
<td>Contains queries that are part of the selection set. To add queries to the Selected Queries list, select one or more queries in the Available Queries list, then click the Add button [&gt;] .</td>
</tr>
<tr>
<td><strong>Query Manipulation Buttons</strong></td>
<td>Select or clear queries to be used in the selection set:</td>
</tr>
<tr>
<td></td>
<td>- [ &gt; ] Adds the selected items from the Available Queries list to the Selected Queries list.</td>
</tr>
<tr>
<td></td>
<td>- [ &gt;&gt; ] Adds all of the items in the Available Queries list to the Selected Queries list.</td>
</tr>
<tr>
<td></td>
<td>- [ &lt; ] Removes the selected items from the Selected Queries list.</td>
</tr>
<tr>
<td></td>
<td>- [ &lt;&lt; ] Removes all items from the Selected Queries list.</td>
</tr>
</tbody>
</table>

**Note:** You can select multiple queries in the Available Queries list by holding down the Shift key or the Control key while clicking with the mouse. Holding down the Shift key provides group selection behavior. Holding down the Control key provides single element selection behavior.

### To add elements to a Selection Set

You can add a single or multiple elements to a static selection set.

1. Right-click the element to be added, then select **Add to Selection Set** from the shortcut menu.
2. In the Add to Selection Set dialog box, select the selection set to which you want to add the element.
3. Click **OK** to close the dialog box and add the element to the selected selection set. Click **Cancel** to close the dialog box without creating the selection set.
To add a group of elements to a static selection set all at once

1. Select all of the elements to be added by either drawing a selection box around them, or by holding down the Ctrl key while clicking each one in turn.
2. When all of the desired elements are highlighted, right-click and select Add to Selection Set.
3. In the Add to Selection Set dialog box, select the selection set to which you want to add the element.
4. Click OK to close the dialog box and add the element to the selected selection set. Click Cancel to close the dialog box without creating the selection set.

To Add To Selection Set Dialog Box

This dialog box opens when you select the Add to Selection Set command. It contains the following field:

Add to: Selects the selection set to which the currently highlighted element or elements will be added.

To remove elements from a Selection Set

You can easily remove elements from a static selection set in the Selection Set Element Removal dialog box.

1. Display the Selection Sets Manager by selecting View > Selection Sets or clicking the Selection Sets button on the View toolbar.
2. In the Selection Sets Manager, select the desired selection set then click the Edit button.
3. In the Selection Set Element Removal dialog box, find the element you want to remove in the table. Select the element label or the entire table row, then click the Delete button.
4. Click OK.

Selection Set Element Removal Dialog Box

This dialog opens when you click the edit button from the Selection Sets manager. It is used to remove elements from the selection set that is highlighted in the Selection Sets Manager when the Edit button is clicked.

5.11.2 Group-Level Operations on Selection Sets

You can perform group-level deletions and reporting on elements in a selection set by using the Select In Drawing button in the Selection Sets Manager.
Note: While it is not possible to directly edit groups of elements in a selection set, you can use the Next button in the Network Navigator to quickly navigate through each element in the selection set and edit its properties in the Property Editor.

To delete multiple elements from a selection set

1. Open the Selection Sets Manager by selecting View > Selection Sets or clicking the Selection Sets button on the View toolbar.

2. In the Selection Sets Manager, highlight the selection set that contains elements you want to delete.

3. Click the Select In Drawing button in the Selection Sets Manager to highlight all of the selection set’s elements in the drawing pane.
   – If there is only one selection set listed in the Selection Sets manager, you don’t have to highlight it before clicking the Select In Drawing button.

4. Shift-click (hold down the Shift key and click the left mouse button) any selected elements that you do not want to delete.

5. Right-click and select Delete. The highlighted elements in the selection set are deleted from your model.

To create a report on a group of elements in a selection set

1. Open the Selection Sets Manager by selecting View > Selection Sets or clicking the Selection Sets button on the View toolbar.

2. In the Selection Sets Manager, highlight the selection set that contains elements you want to report on.

3. Click the Select In Drawing button in the Selection Sets Manager to highlight all of the selection set’s elements in the drawing pane.
   – If there is only one selection set listed in the Selection Sets manager, you don’t have to highlight it before clicking the Select In Drawing button.

4. Shift-click (hold down the Shift key and click the left mouse button) any selected elements that you do not want to include in the report.

5. Right-click and select Report. A report window displays the report.

5.12 Using the Network Navigator

The Network Navigator consists of a toolbar and a table that lists the Label and ID of each of the elements contained within the current selection. The selection can include elements highlighted manually in the drawing pane, elements contained within a selection set, or elements returned by a query.
To open the Network Navigator, click the View menu and select the Network Navigator command, press <Ctrl+3>, or click the Network Navigator button on the View toolbar.

The following controls are included in Network Navigator:

**Query Selection List**

- **Choose the element sets to use in the query.**
- **Once a query is selected, it can be executed when you click the > icon.**

- **If there is already a Query listed in the list box, it can be run when the Execute icon is clicked.**

**Execute**

- **Click to run the selected query.**

**Previous**

- **Zooms the drawing pane view to the selected element at the magnification level specified in the Zoom Level menu.**

**Zoom To**

- **Chooses the element below the currently selected one in the list.**
Using the Network Navigator

Next

Specifies the magnification level at which elements are displayed in the drawing pane when the Zoom To command is initiated.

Copy

Copies the elements to the Windows clipboard.

Remove

Removes the selected element from the list.

Select In Drawing

Selects the listed elements in the drawing pane and performs a zoom extent based on the selection.

Highlight

When this toggle button is on, elements returned by a query will be highlighted in the drawing pane to increase their visibility.

Refresh Drawing

Refreshes the current selection.

Help

Opens StormCAD V8i Help.

Zoom Level

This menu lets you specify the magnification level at which elements are displayed in the drawing pane when the Zoom To command is initiated.
5.12.1 Query Parameters Dialog Box

The Query Parameters dialog appears when you perform a Network Trace > Upstream or a Network Trace > Downstream query. The network trace query will find all elements that are upstream or downstream of the element chosen in this dialog.

To perform an Upstream Network Trace:

1. In the Network Navigator, click the Query Selection List button and select Network Trace > Upstream.
2. In the Query Parameters dialog, click the Downstream Node field and choose Select...
3. In the drawing pane, click the downstream element. The trace query will find all elements that are upstream of the element chosen here.
4. Click OK.

To perform a Downstream Network Trace:

1. In the Network Navigator, click the Query Selection List button and select Network Trace > Downstream.
2. In the Query Parameters dialog, click the Upstream Node field and choose Select...
3. In the drawing pane, click the upstream element. The trace query will find all elements that are downstream of the element chosen here.
4. Click OK.
5.13 **Using Prototypes**

Prototypes allow you to enter default values for elements in your network. These values are used while laying out the network. Prototypes can reduce data entry requirements dramatically if a group of network elements share common data.

For example, if a section of the network contains all 12-inch pipes, use the Prototype manager to set the Pipe Diameter field to 12 inches. When you create a new pipe in your model, its diameter attribute will default to 12 inches.

You can create prototypes in either of the following ways:

- From the Prototypes manager: The Prototypes manager consists of a toolbar and a list pane, which displays all of the elements available in StormCAD V8i.
- From the Drawing Pane: Right-click an element to use the settings and attributes of that element as the current prototype.

**Note:** Changes to the prototypes are not retroactive and will not affect any elements created prior to the change.

If a section of your system has distinctly different characteristics than the rest of the system, adjust your prototypes before laying out that section. This will save time when you edit the properties later.

**To open the Prototypes manager**

Choose View > Prototypes

or

Press <Ctrl+6>

or

Click the Prototypes icon ![Prototypes icon](image.png) from the View toolbar.

The Prototypes manager opens.
The list of elements in the Prototypes manager list pane is expandable and collapsible, once you’ve created additional prototypes. Click on the Plus sign to expand an element and see its associated prototypes. Click on the Minus sign to collapse the element.

Each element in the list pane contains a default prototype; you cannot edit this default prototype. The default prototypes contain common values for each element type; if you add elements to your model without creating new prototypes, the data values in the default prototypes appear in the Property Editor for that element type.
The toolbar contains the following icons:

**New**
- Creates a new prototype of the selected element.

**Delete**
- Deletes the prototype that is currently selected in the list pane.

**Rename**
- Renames the prototype that is currently selected in the list pane.

**Make Current**
- Makes the prototype that is currently highlighted in the list pane the default for that element type. When you make the current prototype the default, every new element of that type that you add to your model in the current project will contain the same common data as the prototype.

**Report**
- Opens a report of the data associated with the prototype that is currently highlighted in the list pane.

**Expand All**
- Opens all the Prototypes.

**Collapse All**
- Closes all the Prototypes.

**Help**
- Displays online help for the Prototypes Manager.
To create Prototypes in the Prototypes Manager

1. Open your StormCAD V8i project or start a new project.
2. Choose View > Prototypes or press <Ctrl+6>.
   The Prototypes Manager opens.

3. Select the element type for which you want to create a prototype, then click New.
   The list expands to display all the prototypes that exist for that element type.
   Each element type contains a default prototype, which is not editable, and any prototypes that you have created. The current set of default values for each element type is identified by the Make Current icon.

4. Double-click the prototype you just created. The Property Editor for the element type opens.
5. Edit the attribute values in the Property Editor as required.
6. To make the new prototype the default, click the Make Current button in the Prototypes Manager.
   The icon next to the prototype changes to indicate that the values in the prototype will be applied to all new elements of that type that you add to your current project.
7. Perform the following optional steps:
   – To rename a prototype, select the prototype in the list and click the Rename button.
To delete a prototype, select the prototype in the list and click the **Delete** button.

To view a report of the default values in the prototype, select the prototype in the list and click the **Report** button.

**To create a Prototype from the Drawing View**

1. Right-click the element you want to act as the current prototype for newly created elements of that type.
2. Select **Create Prototype** from the context menu.
3. Enter a name for the new prototype in the **Create New Prototype** dialog that appears.
4. Click **OK**.

### 5.14 Automatic Design

StormCAD allows you to design many parts of the sewer network, including gravity piping and structures. The design is flexible enough to allow you to specify the elements to be designed, from a single pipe size to the entire system.

Pipes and structures are designed to consider several constraints, such as allowable ranges of slope, velocity, and cover. In general, the design algorithm attempts to minimize excavation, which is typically the most expensive part of installing sewer piping and structures.

Changes suggested to the model by an automatic design calculation will be saved to the Physical Alternative that you specify. This Physical Alternative should be uniquely created just for the automatic design to avoid overwriting the data in your other Physical Alternatives.

#### 5.14.1 Using Automatic Constraint Based Design

StormCAD can automatically size conduits, set node invert elevations and determine the size of inlets to pass a design storm while meeting user-specified constraints. To use this feature: set up the model for analysis, specify which elements are to be sized and the sizes available for use in the design, indicate the constraints to be met, and set the scenario’s **Calculation Type** (found in the calculation options) to **Design** as opposed to Analysis.
Creating Models

**Note:** Automated conduit sizing only relates to closed conduits such as circular and elliptical pipes and box conduits, not open channels.

The detailed steps are provided below:

1. Create a StormCAD model with all the elements to be designed. Make initial estimates of the decision variables such as conduit size and invert elevations. Run the model to make sure that it is complete and will calculate without fatal errors.

2. Create a list of candidate conduit section sizes in the Conduit Catalog (click the **Components** menu and select **Conduit Catalog**). These candidate conduits should have the same conduit shape and material as the pipe in the original model. There must be at least one conduit in the Conduit Catalog with the same shape (e.g. circular) and material (e.g. PVC) as the conduit being designed. While the user can construct this list manually, it is generally recommended to build it using the **Import from Library** command and then picking the shape and material from the list in the library, then deleting those sizes that should not be considered in design.

3. In the case of inlet sizing for catch basins, StormCAD can automatically design the inlet opening length for the inlet at any catch basin element in the network. However, there are three different Inlet Types in StormCAD: Percent Capture, Maximum Capacity and Catalog Inlet. Of these, only Catalog Inlets have a configurable opening length, therefore, in order for StormCAD to design opening length, the **Inlet Type** must be set to **Catalog Inlet**, and an Inlet must be selected. It may be necessary to add a new inlet to **Inlet Catalog** (click the **Component** menu and select **Inlet Catalog**), or import one or more from the **Engineering Libraries**.

StormCAD will select an opening length for a particular inlet from the list of **Design Lengths** associated with that inlet in the Inlet Catalog. The Design Lengths may be viewed or edited by clicking on the **Design** tab in the Inlet Catalog. The design algorithm will determine the minimum available inlet length that meets the design constraints.

StormCAD will not select a different Catalog Inlet during the design run, it will only select a different opening length for the inlet specified.

4. Go to the Design Alternative (click the Analysis menu and select Alternatives) and set up the options for the run. There are three decisions that need to be made for conduits in terms of which properties should be adjusted during design:

   - **Design Conduit**?
   - **Design Start Invert**?
   - **Design End Invert**?
Checking any of these boxes means that these properties will be adjusted during design. ("Design Conduits" means the software should determine the size of the conduit.) Unchecking them means that the values set in the initial model will be maintained.

For nodes, the choices are:

- **Design Structure Elevations?**
- **Allow Drop Structure?**

**Note:** If you do not want to the Start (Upstream) and/or Stop (Downstream) invert elevations to change during the design, you must set the Design Start Invert? and/or Design Stop Invert? property to False.

For catch basin inlets, the choice is:

- **Design Inlet Opening?**

5. Next set up the design constraints.

For conduits, if you pick Simple as the type, the Minimum and Maximum Velocity need to be specified (or the defaults kept). If Table is selected, you can vary the constraints based on pipe Rise. If you do not want to use velocity constraints, set the Minimum to zero and Maximum to a large number.

For inverts, decide whether to match Inverts or Crowns or specify an offset through the structure.

For inlets, specify the Maximum Spread in Sag and the maximum Depth in Sag.

**Note:** If you set up constraints under Default Design Constraints (click the Components menu and select Default Design Constraints), these constraints will be used for any new Design Alternative as well as the alternative associated with the current scenario.

You can modify the constraints for just an individual element by checking Specify Local Pipe (Inlet) Constraints box associated with that element.

6. You can specify some additional options under the Extended Design portion of the alternative manager. In some cases, the pipes must be designed to carry the design flow at less than 100% full (100% Full is the default). You can check Partly Full Design and specify the design percent as either a constant (Simple) or a tabular list as a function of conduit rise.

**Note:** The design percentage is defined as a percentage of full depth.

You can also allow for multiple parallel pipe barrels or limit the maximum section size by specifying maximum rise.
7. Create a new calculation option (click the Analysis menu and select Calculation Options) with the Calculation Type set to Design (as opposed to Analysis).

8. Create a new scenario using the desired Design Alternative and Calculation Options. Make that scenario the current scenario and start the design by picking Compute.

9. When the design starts, it will indicate the (current) Physical Alternative in which the results will be stored. If the user wants the results stored there, pick Yes. If the user wants the new design properties stored in another Physical Alternative, this is the place to specify that alternative by picking No. That Physical Alternative is associated with the current scenario.

### 5.14.2 Default Design Constraints

Pipe diameters, invert elevations, node structures, and inlets can be all designed with the same set of design constraints. You also have the option to adjust these values individually for each pipe or structure.

The Default Design Constraints dialog is divided into the three following tabs:

- Gravity Pipe
- Node
- Inlet

**Gravity Pipe Tab**

The Gravity Pipe tab allows you to enter default constraints to be used for the design of pipes when performing a calculation run in design mode. The dialog is divided into the following sections:

- Default Constraints
- Extended Design

**Default Constraints Section**

In this section, there is a Velocity tab, a Cover tab, and a Slope tab. You can specify the following default constraints to be used for the design of gravity pipes:

- **Velocity Tab**: The Velocity tab consists of the following controls:
  - **Velocity Constraints Type**—When Simple is chosen, a single minimum and maximum Velocity value is selected. When Table is chosen, you can specify multiple Rise vs Velocity (Minimum) vs Velocity (Maximum) points in tabular format.
– **Velocity (Minimum)**–Specify the minimum allowable velocity value. This control is only available when the Velocity Constraint Type is set to Simple.

– **Velocity (Maximum)**–Specify the maximum allowable velocity value. This control is only available when the Velocity Constraint Type is set to Simple.

**• Cover Tab:** The Cover tab consists of the following controls:

– **Cover Constraints Type**–When Simple is chosen, a single minimum and maximum Cover value is selected. When Table is chosen, you can specify multiple Rise vs Cover (Minimum) vs Cover (Maximum) points in tabular format.

– **Cover (Minimum)**–Specify the minimum allowable cover value. This control is only available when the Cover Constraint Type is set to Simple.

– **Cover (Maximum)**–Specify the maximum allowable cover value. This control is only available when the Cover Constraint Type is set to Simple.

**• Slope Tab:** The Slope tab consists of the following controls:

– **Slope Constraints Type**–When Simple is chosen, a single minimum and maximum Slope value is selected. When Table is chosen, you can specify multiple Rise vs Slope (Minimum) vs Slope (Maximum) points in tabular format.

– **Slope (Minimum)**–Specify the minimum allowable slope value. This control is only available when the Slope Constraint Type is set to Simple.

– **Slope (Maximum)**–Specify the maximum allowable slope value. This control is only available when the Slope Constraint Type is set to Simple.

**Extended Design Section**

This section lets you specify if the following design parameters are to be used. If they are to be used, you can also specify the associated default value. The Extended Design section is split into three tabs:

**• Part Full Design Tab:** The Part Full Design tab consists of the following controls:

– **Is Part Full Design?**–When checked, allows you to specify thePercent Full target to be used by the design algorithm.

– **Percent Full Constraint Type**–Allows you to specify how the Percent Full constraints are defined. When Simple is chosen, a single Percentage Full value is selected. When Table is chosen, you can specify multiple Rise vs Percent Full points in tabular format.

– **Percentage Full**–Specify the Percent Full value to be used when the Is Part Full Design? box is checked. This control is only available when the Percent Full Constraint Type is set to Simple.
• **Number of Barrels Tab:** The Number of Barrels tab consists of the following controls:
  
  – **Allow Multiple Barrels**—When checked, allows the design algorithm to use more than one identical section in parallel, up to the specified Maximum Number of Barrels.
  
  – **Maximum Number of Barrels**—The maximum number of identical sections allowed to be used in parallel when the Allow Multiple Barrels? box is checked.

• **Section Size Tab:** The Section Size tab consists of the following controls:
  
  – **Limit Section Size**—When checked, limits the pipe section height to the specified Maximum Rise value during the design process.
  
  – **Maximum Rise**—The maximum rise a section height is allowed to be used in the design when the Limit Section Size? box is checked.

**Node Tab**

This tab lets you specify the design constraints to be used by default for all gravity structures when performing calculations in design mode. During an automatic design, the program will adjust the elevations of the pipes adjacent to the structure according to the structure’s matching constraints. The two choices for matching are Inverts and Crowns. Additionally, the downstream pipe can be offset from the upstream pipe(s) by a specified amount. This value is called the Matchline Offset. Optionally, the program supports the design of drop structures. In some situations, drop structures can minimize pipe cover depths while maintaining adequate hydraulic performance.

**Inlet Tab**

This tab lets you specify the design constraints to be used for all inlets when performing a calculation run in design mode. During an automatic design, the program will adjust the length of the inlet in order to meet the design constraints.

• For an inlet in sag, the Default In Sag Design Constraints consist of maintaining the gutter spread and water depth under a given value.

• For an inlet on a grade, the Default on Grade Design Constraints consist of ensuring that at least a given percentage of the gutter flow is intercepted.

**Default In Sag Design Constraints Section**

This section lets you specify the design constraints to be used for all inlets located in sag when performing calculations in design mode. During an automatic design, the program will adjust the length of the inlet in order to meet both design constraints:
• Maximum Spread in Sag—The maximum allowed spread of water at the inlet, measured from the curb.
• Maximum Depth in Sag—The maximum depth of water allowed at the inlet.

Default On Grade Design Constraints

This section lets you specify the design constraints to be used for all inlets located on a grade when performing a calculation run in design mode. During an automatic design, the program will adjust the length of the inlet in order to meet a minimum inlet efficiency, or percentage of gutter flow intercepted by the inlet, that you specify.

5.14.3 Conduit and Inlet Catalog Templates

When performing an Automatic Design, StormCAD suggests only conduit and inlet types that are contained within the Conduit and Inlet Catalogs. A new project starts with empty Conduit and Inlet Catalogs. You can populate the Inlet and Conduit Catalogs with pipes and inlets of your choosing, or you can open one of the predefined Templates we have provided. The templates can be found in the Bentley/StormCAD8/Templates folder. There is a template for US units and one for SI units.

Warning! The predefined templates are Read-Only files. Do not modify the read-only setting on these files.

You may also create new Templates and use those in future projects. To create a new template, populate the inlet and conduit catalogs with the desired data and save the project to the template folder. To use the new template, simply open it and save it as a new file name to use it for a new project.
5.15 **Engineering Libraries**

Engineering Libraries are powerful and flexible tools that you use to manage specifications of common materials, objects, or components that are shared across projects. Some examples of objects that are specified through engineering libraries include constituents, pipe materials, patterns, and pump definitions.

You can modify engineering libraries and the items they contain by using the Engineering Libraries command in the Components menu.

You work with engineering libraries and the items they contain in the Engineering Libraries dialog box, which contains all of the project’s engineering libraries. Individual libraries are compilations of library entries along with their attributes.

By default, each project you create in StormCAD V8i uses the items in the default libraries. In special circumstances, you may wish to create custom libraries to use with one or more projects. You can do this by copying a standard library or creating a new library.

When you change the properties for an item in an engineering library, those changes affect all projects that use that library item. At the time a project is loaded, all of its engineering library items are synchronized to the current library. Items are synchronized based on their label. If the label is the same, then the item’s values will be made the same.
The default libraries that are installed with Bentley StormCAD V8i are editable. In addition, you can create a new library of any type and can then create new entries of your own definition.

- Library types are displayed in the Engineering Library manager in an expanding/collapsing tree view.
- Library types can contain categories and subcategories, represented as folders in the tree view.
- Individual library entries are contained within the categories, subcategories, and folders in the tree view.
- Libraries, categories, folders, and library entries are displayed in the tree view with their own unique icons. You can right-click these icons to display submenus with different commands.

**Note:** The data for each engineering library is stored in an XML file in your Bentley StormCAD V8i program directory. We strongly recommend that you edit these files only using the built-in tools available by selecting Tools > Engineering Libraries.

**Working with Engineering Libraries**

When you select a library entry in the tree view, the attributes and attribute values associated with the entry are displayed in the editor pane on the right side of the dialog box.

Right-clicking a Library icon in the tree view opens a shortcut menu containing the following commands:

**Create Library**

Creates a new engineering library of the currently highlighted type.

**Add Existing Library**

Adds an existing engineering library that has been stored on your hard drive as an .xml file to the current project.
Creating Models

**Working with Categories**

Right-clicking a Category icon in the tree view opens a shortcut menu containing the following commands:

- **Add Item** Creates a new entry within the current library.
- **Add Folder** Creates a new folder under the currently highlighted library.
- **Save As** Saves the currently highlighted category as an .xml file that can then be used in future projects.
- **Remove** Deletes the currently highlighted category from the library.

**Working with Folders**

Right-clicking a Folder icon in the tree view opens a shortcut menu containing the following commands:

- **Add Item** Creates a new entry within the current folder.
- **Add Folder** Creates a new folder under the currently highlighted folder.
- **Rename** Renames the currently highlighted folder.
- **Delete** Deletes the currently highlighted folder and its contents.

**Working with Library Entries**

Right-clicking a Library Entry icon in the tree view opens a shortcut menu containing the following commands:

- **Rename** Renames the currently highlighted entry.
- **Delete** Deletes the currently highlighted entry from the library.
Engineering Libraries Dialog Box

The Engineering Libraries dialog box contains an explorer tree-view pane on the left, a library entry editor pane on the right, and the following icons above the explorer tree view pane:

**New**

Opens a submenu containing the following commands:

- **Create Library**—Creates a new engineering library.
- **Add Existing Library**—Adds an existing engineering library that has been stored on your hard drive as an .xml file to the current project.
- **ProjectWise Add Existing Library**—Opens the ProjectWise login screen, allowing you to access an existing library from a ProjectWise data source.

**Edit**

Opens a submenu containing the following commands:

- **Save As**—Allows you to save the currently highlighted library entry to another location and/or as another file name.
- **ProjectWise Save As**—Allows you to save the currently highlighted library entry to another ProjectWise data source and/or as another file name.
- **ProjectWise Check Out**—Opens the ProjectWise login screen, allowing you to check out the currently highlighted library entry from a ProjectWise data source.

**Remove**

Removes the currently highlighted engineering library from the current project.

**Rename**

Renames the currently highlighted engineering library.

---

Sharing Engineering Libraries On a Network
You can share engineering libraries with other StormCAD V8i users in your organization by storing the engineering libraries on a network drive. All users who will have access to the shared engineering library should have read-write access to the network folder in which the library is located.

To share an engineering library on a network, open the Engineering Libraries in StormCAD V8i and create a new library in a network folder to which all users have read-write access.

### 5.15.1 Converting Legacy Engineering Library Files

You can convert your legacy format engineering library files (.hlb) to the .xml format used in StormCAD V8i using the WaterObjects.Net.EngineeringLibraryConverter.exe utility. This utility can be found in your Bentley/StormCAD8 folder.

The utility consists of the following controls:

- **Product**: Select whether the .hlb file to be converted is a SewerGEMS, WaterGEMS, or StormCAD engineering library file.
- **Library Type**: Select the type of engineering library you are converting.
- **HLB Library File**: Enter the path of the .hlb file to be converted, or click the Browse button to find it using a Windows browse dialog.
- **Material Library**: Enter the path of the material.hlb file. This control is only available when the Library Type being converted is a Section Size library.
- **Use SI Label**: Check this box if the library being converted uses System International (SI) units.
- **Destination Root**: Enter the path where the converted .xml file should be created, or click the Browse button to browse to the location.
- **Convert**: Click this button to perform the conversion.
- **Close**: Closes the utility dialog.
Conduit Catalog Dialog Box

Note: Rainfall Table Files (*.tbl) created in StormCAD 5.6 are not supported in StormCAD V8. To import the rainfall data contained in these files, it is necessary to import the *.tbl file into a StormCAD 5.6 project, save the project, then open the 5.6 project in V8. Once open in V8, the storm data can be saved to the Engineering Libraries for reuse.

If StormCAD 5.6 is not available, the *.tbl file should be forwarded to Bentley Tech Support for import to StormCAD V8.

To convert an .hlb Engineering Library file to an .xml Engineering Library file

2. In the Classic Engineering Library Converter Utility dialog that appears, select StormCAD from the Product menu.
3. Choose the Library Type that is stored in the .hlb file to be converted.
4. Click the Browse button next to the HLB Library File field and find the .hlb file to be converted.
5. If the Library Type you are converting is a Section Size library:
   a. Click the Browse button next to the Material Library field and find the material.hlbg file associated with the Section Size .hlb file to be converted.
   b. Place a check in the Use SI Label box if the Section Size library file uses SI units.
6. Click the Browse button next to the Destination Root field and browse to the directory where you want the new .xml engineering library file to be created.
7. Click the Convert button.

5.16 Conduit Catalog Dialog Box

This dialog box allows you to create, edit, and view catalog conduits. Catalog conduits are an efficient way to reuse common physical conduit definitions.

The dialog box contains a toolbar, a Conduit Catalog list pane, and two tabs. The toolbar contains the following buttons:

- **New**: Creates a new entry in the Conduit Catalog List Pane.
- **Delete**: Deletes the entry that is currently highlighted in the Conduit Catalog List Pane.
**Rename:** Lets you rename the entry that is currently highlighted in the Conduit Catalog List Pane.

**Report:** Lets you generate a preformatted report that contains the input data associated with the entry that is currently highlighted in the Conduit Catalog List Pane.

**Synchronize:** Clicking this button opens a submenu containing the following commands:

- **Browse Engineering Library**—This command opens the Engineering Library manager dialog, allowing you to browse the Conduit Catalog Library.
- **Synchronize From Library**—This command allows you to update a conduit catalog that was previously imported from a Conduit Catalog Engineering Library to reflect changes that have been made to the library since it was imported.
- **Synchronize To Library**—This command allows you to update an existing Conduit Catalog Engineering Library using current Conduit Catalog entries that were initially imported but have since been modified.
- **Import From Library**—This command allows you to import catalog entries from an existing Conduit Catalog Engineering Library.
- **Export To Library**—This command allows you to export the current catalog entries to an existing Conduit Catalog Engineering Library.

The following table describes the rest of the controls in the Conduit Catalog dialog box.

**Conduit Catalog List Pane:** Located on the left side of the dialog box, displays a list of all of the catalog conduits that have been defined in the current project. Highlighting a catalog conduit in this list causes the Cross Section Shape and Roughness Sections to display the associated information with the highlighted conduit.

**Cross Section Shape**
Conduit Catalog Dialog Box

Located in the top-right corner of the Conduit Catalog tab, contains controls that allow you to define the size and shape of the catalog conduit that is currently highlighted in the List Pane. The controls that appear change according to the Cross Section Type that is selected.

**Cross Section Type:** Lets you define the type of cross section for the currently highlighted catalog conduit.

**Diameter:** Lets you define the diameter of the conduit. This field is only available for Circular catalog conduits.

**<Section Type> Rise:** Lets you define the rise (height) of the catalog conduit. This field is available for all cross section types except Circular.

**<Section Type> Span:** Lets you define the span (width) of the catalog conduit. This field is available for all cross section types except Circular.

**Full Area:** Lets you define the full area of the conduit. This field is only available for Pipe-Arch catalog conduits. See Conduit Shapes for a diagram of this conduit shape and the associated measurements.

**Bottom Radius:** Lets you define the bottom radius of the conduit. This field is only available for Pipe-Arch catalog conduits. See Conduit Shapes for a diagram of this conduit shape and the associated measurements.

**Bottom Distance:** Lets you define the bottom distance of the conduit. This field is only available for Pipe-Arch catalog conduits. See Conduit Shapes for a diagram of this conduit shape and the associated measurements.

**Corner Radius:** Lets you define the corner radius of the conduit. This field is only available for Pipe-Arch catalog conduits. See Conduit Shapes for a diagram of this conduit shape and the associated measurements.

**Top Radius:** Lets you define the top radius of the conduit. This field is only available for Pipe-Arch catalog conduits. See Conduit Shapes for a diagram of this conduit shape and the associated measurements.

**Bottom Width:** Lets you define the bottom width of the conduit. This field is only available for Trapezoidal Channel catalog conduits. See Conduit Shapes for a diagram of this conduit shape and the associated measurements.

**Left Side Slope:** Lets you define the left side slope of the conduit. This field is only available for Trapezoidal Channel catalog conduits. See Conduit Shapes for a diagram of this conduit shape and the associated measurements.

**Right Side Slope:** Lets you define the right side slope of the conduit. This field is only available for Trapezoidal Channel catalog conduits. See Conduit Shapes for a diagram of this conduit shape and the associated measurements.

**Roughness**
Located in the bottom-right corner of the Conduit Catalog tab, lets you define the roughness attributes of the catalog conduits currently highlighted in the List Pane. The controls that are available change depending on the Roughness Type selected.

**Roughness Type:** Lets you specify which of the available roughness methods to be applied to the catalog conduit currently highlighted in the List Pane. The other controls available in section are dependent on the selection made in this box.

**Friction Method:** Lets you specify which of the available friction methods to be applied to the catalog conduit currently highlighted in the List Pane. The other controls available in section are dependent on the selection made in this box.

**Material:** Lets you enter a material label. This field is informational only, and will not affect the roughness properties of the associated catalog entry.

**Manning's n:** Lets you define the roughness value for the catalog conduit. This field is available only when the Roughness Type is Single Manning's n.

**Depth vs. Manning's Table:** Lets you define a depth vs. roughness curve for the catalog conduit. This field is available only when the Roughness Type is Manning's n-Depth Curve.

**Manning's vs. Discharge Table:** Lets you define a flow vs. roughness curve for the catalog conduit. This field is available only when the Roughness Type is Manning's n-Flow.

**Library Tab**

Displays information pertaining to the catalog entry that is currently highlighted in the List Pane, including:

- ID
- Label
- Modified Date
- Library Source
- Library Modified Date
- Synchronization Status

**5.17 Hyperlinks**

The Hyperlinks feature is used to associate external files, such as pictures or movie files, with elements. You can Add, Edit, Delete, and Launch hyperlinks from the Hyperlinks manager.
To use hyperlinks, choose Tools > Hyperlinks. The Hyperlinks dialog box opens. The dialog box contains a toolbar and a tabular view of all your hyperlinks.

The toolbar contains the following icons:

**New**  Creates a new hyperlink. Opens the Add Hyperlink dialog box.

**Delete**  Deletes the currently selected hyperlink.

**Edit**  Edits the currently selected hyperlink. Opens the Edit Hyperlink dialog box.

**Launch**  Launches the external file associated with the currently selected hyperlink.

The table contains the following columns:

<table>
<thead>
<tr>
<th>Element Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pipe</td>
<td>B-22</td>
</tr>
<tr>
<td>Junction</td>
<td>J-77</td>
</tr>
<tr>
<td>Junction</td>
<td>J-68</td>
</tr>
</tbody>
</table>
Creating Models

**Element**
Displays the label of the element associated with the hyperlink.

**Link**
Displays the complete path of the hyperlink.

**Description**
Displays a description of the hyperlink, which you can optionally enter when you create or edit the hyperlink.

Once you have created Hyperlinks, you can open the Hyperlinks dialog box from within a Property dialog box associated with that Hyperlink.

![Hyperlinks dialog box]

Click the ellipsis (...) in the Hyperlinks field and the Hyperlinks dialog box opens.

**Add Hyperlink Dialog Box**

New hyperlinks are created in this dialog box.

![Add Hyperlink dialog box]

The Add Hyperlinks dialog box has the following controls:

**Element Type**
Select an element type from the drop-down list.
Hyperlinks

Element
Select an element from the drop-down list of specific elements from the model. Or click the ellipse to select an element from the drawing.

Link
Click the ellipse (...) to browse your computer and locate the file to be associated with the hyperlink. You can also enter the path of the external file by typing it in the Link field.

Description
Create a description of the hyperlink.

Edit Hyperlink Dialog Box
You edit existing hyperlinks in the Edit Hyperlink dialog box.

The Edit Hyperlinks dialog box contains the following controls:

Link
Defines the complete path of the external file associated with the selected hyperlink. You can type the path yourself or click the ellipse (...) to search your computer for the file.

Once you have selected the file, you can test the hyperlink by clicking Launch.

Description
Accesses an existing description of the hyperlink or type a new description.
To Add a Hyperlink


2. Click New to add a hyperlink. The Add Hyperlink dialog box opens.

3. Select the element type to associate an external file.

4. Click the ellipsis (...) to select the element in the drawing to associate with the hyperlink.

5. Click the ellipsis (...) to browse to the external file you want to use, select it and then click Open. This will add it to the Link field.
6. Add a description of your Hyperlink.

7. Click OK.

You can add more than one associated file to an element using the hyperlink feature, but you must add the associations one at a time.
To Edit a Hyperlink


   ![Hyperlinks dialog box](image)

2. Select the element to edit and click Edit. The Edit Hyperlink dialog box opens.

   ![Edit Hyperlink dialog box](image)

3. Click the ellipsis (...) to browse to a new file to associate with the hyperlink.

4. Add a description.

5. Click OK
To Delete a Hyperlink


2. Select the element you want to delete.

3. Click Delete.

To Launch a Hyperlink

Hyperlinks can be launched from the Hyperlinks dialog box, the Add Hyperlink dialog box, and from the Edit Hyperlink dialog box. Launch in order to view the image or file associated with the element, or to run the program associated with the element.


2. Select the element and click on the Hyperlinks icon. The hyperlink will launch.
5.18 Using Queries

A query in Bentley StormCAD V8i is a user-defined SQL expression that applies to a single element type. You use the Query Manager to create and store queries; you use the Query Builder dialog box to construct the actual SQL expression.

Queries can be one of the following three types:

• **Project queries**—Queries you define that are available only in the Bentley StormCAD V8i project in which you define them.

• **Shared queries**—Queries you define that are available in all Bentley StormCAD V8i projects you create. You can edit shared queries.

• **Predefined queries**—Factory-defined queries included with Bentley StormCAD V8i that are available in all projects you create. You cannot edit predefined queries.

You can also use queries in the following ways:

• Create dynamic selection sets based on one or more queries. For more information, see [To create a Selection Set from a Query](#).

• Filter the data in a FlexTable using a query. For more information, see [Sorting and Filtering FlexTable Data](#).

• You can use predefined queries in the Network Navigator. See [Using the Network Navigator](#) for more details.

For more information on how to construct queries, see [Creating Queries](#).

### 5.18.1 Queries Manager

The Queries manager is a docking manager that displays all queries in the current project, including predefined, shared, and project queries. You can create, edit, or delete shared and project queries from within the Queries Manager, as well as use it to select all elements in your model that are part of the selected query.
To open the Queries manager, click the View menu and select the Queries command, press <Ctrl+5>, or click the Queries button on the View toolbar.

The Queries manager consists of a toolbar and a tree view, which displays all of the queries that are associated with the current project.
The toolbar contains the following icons:

**New**

Contains the following commands:

- **Query**—Creates a new SQL expression as either a project or shared query, depending on which item is highlighted in the tree view.
- **Folder**—Creates a folder in the tree view, allowing you to group queries. You can right-click a folder and create queries or folders in that folder.

**Delete**

Deletes the currently-highlighted query or folder from the tree view. When you delete a folder, you also delete all of the queries it contains.

**Rename**

Renames the query or folder that is currently highlighted in the tree view.

**Edit**

Opens the Query Builder dialog box, allowing you to edit the SQL expression that makes up the currently-highlighted query.
Using Queries

**Expand All**
Opens all the Queries within all of the folders.

**Collapse All**
Closes all the Query folders.

**Select in Drawing**
Opens a submenu containing the following options:

- **Select in Drawing**—Selects the element or elements that satisfy the currently highlighted query.

- **Add to Current Selection**—Adds the element or elements that satisfy the currently highlighted query to the group of elements that are currently selected in the Drawing Pane.

- **Remove from Current Selection**—Removes the element or elements that satisfy the currently highlighted query from the group of elements that are currently selected in the Drawing Pane.

**Help**
Displays online help for the Query Manager.

---

**Query Parameters Dialog Box**

Some predefined queries require that a parameter be defined. When one of these queries is selected, the Query Parameters dialog box will open, allowing you to type the parameter value that will be used in the query. For example, when the Pipe Split Candidates query is used the Query Parameters dialog will open, allowing the Tolerance parameter to be defined.
5.18.2 Creating Queries

A query is a valid SQL expression that you construct in the Query Builder dialog box. You create and manage queries in the Query Manager. You also use queries to filter FlexTables and as the basis for a selection set.

To create a query from the Query manager

1. Choose View > Queries or click the Queries icon on the View toolbar, or press <CTRL+5>.
2. Perform one of the following steps:
   a. To create a new project query, highlight Queries - Project in the list pane, then click the New button and select Query.
   b. To create a new shared query, highlight Queries - Shared in the list pane, then click the New button and select Query.

   Note: You can also right-click an existing item or folder in the list pane and select New > Query from the shortcut menu.

3. In the Select Element Type dialog box, select the desired element type from the drop-down menu. The Query Builder dialog box opens.
4. All input and results fields for the selected element type appear in the Fields list pane, available SQL operators and keywords are represented by buttons, and available values for the selected field are listed in the Unique Values list pane. Perform the following steps to construct your query:
   a. Double-click the field you wish to include in your query. The database column name of the selected field appears in the preview pane.
   b. Click the desired operator or keyword button. The SQL operator or keyword is added to the SQL expression in the preview pane.
   c. Click the Refresh button above the Unique Values list pane to see a list of unique values available for the selected field. Note that the Refresh button is disabled after you use it for a particular field (because the unique values do not change in a single query-building session).
   d. Double-click the unique value you want to add to the query. The value is added to the SQL expression in the preview pane.

   Note: You can also manually edit the expression in the preview pane.
   e. Click the Validate button above the preview pane to validate your SQL expression. If the expression is valid, the word “VALIDATED” is displayed in the lower right corner of the dialog box.
f. Click the **Apply** button above the preview pane to execute the query. If you didn’t validate the expression, the Apply button validates it before executing it.

g. Click **OK**.

5. Perform these optional steps in the Query Manager:
   - To create a new folder in the tree view, highlight the existing item or folder in which to place the new folder, then click the **New** button and select **Folder**. You can create queries and folders within folders.
   - To delete an existing query or folder, click the **Delete** button. When you delete a folder, you also delete all of its contents (the queries it contains).
   - To rename an existing query or folder, click the **Rename** button, then type a new name.
   - To edit the SQL expression in a query, select the query in the list pane, then click the **Edit** button. The Query Builder dialog box opens.
   - To quickly select all the elements in the drawing pane that are part of the currently highlighted query, click the **Select in Drawing** button.

**Example Query**

To create a query that finds all pipes with a diameter greater than 8 inches and less than or equal to 12 inches you would do the following:

1. In the **Queries** dialog, click the **New** button and select **Query**.
2. In the **Queries - Select Element Type** dialog, select **Pipe** and click **OK**.
3. In the **Query Builder** dialog, click the () (Parentheses) button.
4. Double-click **Diameter** in the **Fields** list.
5. Click the > (Greater Than) button.
6. Click the **Refresh** button above the **Unique Values** list. Double-click the value **8**.
7. In the Preview Pane, click to the right of the closing parenthesis.
8. Click the **And** button.
9. Click the () (Parentheses) button.
10. Double-click **Diameter** in the **Fields** list.
11. Click the <= (Less Than or Equal To) button.
12. Double-click the value **12** in the **Unique Values** list.
The final query will look like this:

\[(\text{Physical Pipe Diameter} > 8) \text{ AND } (\text{Physical Pipe Diameter} <= 12)\]

See [Using the Like Operator](#) for more examples of query usage and syntax.

**Query Builder Dialog Box**

You construct the SQL expression that makes up your query in the Query Builder dialog box. The Query Builder dialog box is accessible from the Query manager and from within a FlexTable.

The top part of the dialog box contains all the controls you need to construct your query: a list pane displaying all available attributes for the selected element type, an SQL control panel containing available SQL keywords and operators, and list view that displays all the available values for the selected attribute. The bottom part of the dialog box contains a preview pane that displays your SQL expression as you construct it.

See [Using the Like Operator](#) for some examples of query usage and syntax.
All the dialog box controls are described in the following table.

**Fields**
Lists all input and results fields applicable to the selected element type. This list displays the labels of the fields while the underlying database column names of the fields become visible in the preview pane when you add them to the expression. Double-click a field to add it to your SQL expression.

**SQL Controls**
These buttons represent all the SQL operators and controls that you can use in your query. They include =, >, <, __, ?*, <=, >=, <>, And, Like, and Or. Click the appropriate button to add the operator or keyword to the end of your SQL expression, which is displayed in the preview pane.

**Unique Values**
When you click the Refresh button, this list displays all the available unique values for the selected field. Double-click a value in the list to add it to the end of your SQL expression, which is displayed in the preview pane. If you select a different field, you must click the Refresh button again to update the list of unique values for the selected field. When you first open the Query Builder dialog box, this list is empty.

**Refresh**
Updates the list of unique values for the selected field. This button is disabled after you use it for a particular field.

**Copy**
Copies the entire SQL expression displayed in the preview pane to the Windows clipboard.
| **Paste** | Pastes the contents of the Windows clipboard into the preview pane at the location of the text cursor. For example, if your cursor is at the end of the SQL expression in the preview pane and you click the **Paste** button, the contents of your clipboard will be added to the end of the expression. |
| **Validate on OK** | Turn on to validate the SQL expression in the preview pane. If the expression is not valid, a message appears. When you turn on and your SQL expression passes validation, the word “VALIDATED” appears in the lower right corner of the dialog box. |
| **Apply** | Executes the query. The results of the query are displayed at the bottom of the Query Builder dialog box in the form “x of x elements returned.” |
| **Preview Pane** | Displays the SQL expression as you add fields, operators and/or keywords, and values to it. |
| **Action** | Allows you to select the operation to be performed on the elements returned by the query defined in the Preview pane. The following choices are available: |
| | • **Create New Selection**—Creates a new selection containing the elements returned by the query. |
| | • **Add to Current Selection**—Adds the elements returned by the query to the current selection. |
| | • **Remove from Current Selection**—Removes the elements returned by the query from the current selection. |

This control is only available when the Query Builder is accessed from the command Edit > Select By Attribute.
Using the Like Operator

The Like operator compares a string expression to a pattern in an SQL expression.

Syntax

\textit{expression} Like “\textit{pattern}”

The Like operator syntax has these parts:

<table>
<thead>
<tr>
<th>Part</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>\textit{expression}</td>
<td>SQL expression used in a WHERE clause.</td>
</tr>
<tr>
<td>\textit{pattern}</td>
<td>String or character string literal against which \textit{expression} is compared.</td>
</tr>
</tbody>
</table>

You can use the Like operator to find values in a field that match the pattern you specify. For \textit{pattern}, you can specify the complete value (for example, \texttt{Like “Smith”}), or you can use wildcard characters to find a range of values (for example, \texttt{Like “Sm*”}).

In an expression, you can use the Like operator to compare a field value to a string expression. For example, if you enter \texttt{Like “C*”} in an SQL query, the query returns all field values beginning with the letter C. In a parameter query, you can prompt the user for a pattern to search for.

The following example returns data that begins with the letter P followed by any letter between A and F and three digits:

Like “P[A-F]###”

\textbf{Note:} If you receive a Query Syntax Error message notifying you that the query has too few parameters, check the field name you entered for typos. This message is triggered when the field name is not recognized.
The following table shows how you can use Like to test expressions for different patterns.

<table>
<thead>
<tr>
<th>Kind of match</th>
<th>Pattern</th>
<th>Match (returns True)</th>
<th>No match (returns False)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple characters</td>
<td>a*a</td>
<td>aa, aBa, aBBBa</td>
<td>aBC</td>
</tr>
<tr>
<td></td>
<td><em>ab</em></td>
<td>abc, AABB, Xab</td>
<td>aZb, bac</td>
</tr>
<tr>
<td>Special character</td>
<td>a[*]a</td>
<td>a*a</td>
<td>aaa</td>
</tr>
<tr>
<td>Multiple characters</td>
<td>ab*</td>
<td>abcdefg, abc</td>
<td>cab, aab</td>
</tr>
<tr>
<td>Single character</td>
<td>a?a</td>
<td>aaa, a3a, aBa</td>
<td>aBBBBa</td>
</tr>
<tr>
<td>Single digit</td>
<td>a#a</td>
<td>a0a, a1a, a2a</td>
<td>aaa, a10a</td>
</tr>
<tr>
<td>Range of characters</td>
<td>[a-z]</td>
<td>f, p, j</td>
<td>2, &amp;</td>
</tr>
<tr>
<td>Outside a range</td>
<td>![a-z]</td>
<td>9, &amp;, %</td>
<td>b, a</td>
</tr>
<tr>
<td>Not a digit</td>
<td>![0-9]</td>
<td>A, a, &amp;, ~</td>
<td>0, 1, 9</td>
</tr>
<tr>
<td>Combined</td>
<td>a![lb-m]#</td>
<td>An9, az0, a99</td>
<td>abc, aj0</td>
</tr>
</tbody>
</table>

**Query Examples**

In order to get all elements of a given type whose label starts with a given letter(s) (e.g. J-1###), one could do a query such as:

```
Label LIKE 'J-1*'  
```

In this case, the query would return elements with labels like J-1, J-100, J-101, but not J-01, J-001.

In order to get all elements of a given type whose label ends with a given letter(s) (e.g. ###100), one could do a query such as:

```
Label LIKE '*100' 
```

In this case, the query would return elements with labels like J-100, J-10100, J-AA100, but not J-1000, J-100A.

In order to get all elements of a given type whose label contains a given letter(s) (e.g. #-1#), one could do a query such as:
Using Queries

Label LIKE '*-1*

In this case, the query would return elements with labels like J-10, J-101, Node-10A, but not J10, J-20, J101.

In order to get all elements of a given type whose label ends with a single digit, one could do a query such as:

Label LIKE 'J-#'

In this case, the query would return elements with labels like J-1, J-2, J-3, but not J-10, J-A1, J1.

In order to get all elements of a given type whose label ends with a single character, one could do a query such as:

Label LIKE 'J-1?'

In this case, the query would return elements with labels like J-1A, J-10, J-11, but not J-1, J-1AA, J1A.

There are more complicated patterns that can be included by using the LIKE operator. For example:

In order to get all elements of a given type whose label ends with a non-digit character, one could do a query such as:

Label LIKE 'J-*[!0-9]'

In this case, the query would return elements with labels like J-1a, J-2B, J-3E, but not J-A0, J1A, J-10.

In order to get all elements of a given type whose label starts with a letter in a given range (e.g. J..M) and ends with a digit, one could do a query such as:

Label LIKE '[J-M]-*#'

In this case, the query would return elements with labels like J-1, K-B2, MA-003, but not J-0A, N-A1, M11.

**Querying by Date**

To query a field name against a date, enclose the date in # symbols, as in the example below:

Field_name < #1/2/1925#
5.19 Using TRex to Assign Node Elevations

The TRex Terrain Extractor was designed to expedite the elevation assignment process by automatically assigning elevations to the model features according to the elevation data stored within DXF Point or Contour files, LandXML files, and shapefiles.

The TRex Terrain Extractor can quickly and easily assign elevations to any or all of the nodes in the model. All that is required is a valid source file of one of the above types containing the elevation data. Data input for TRex consists of:

1. Specify the field in the source file from which elevation data will be extracted.
2. Specify the measurement unit associated with the source file (feet, meters, etc.).
3. Select the model features to which elevations should be applied; all model features or a selection set of features can be chosen.

TRex then interpolates an elevation value for each specific point occupied by a model feature. The final step of the wizard displays a list of all of the features to which an elevation was applied, along with the elevation values for those features. These elevation values can then be applied to a new physical properties alternative, or an existing one.

5.19.1 TRex Wizard

The TRex Wizard steps you through the process of automatically assigning elevations to specified nodes based on data from a DXF, XML, or SHP file.

Step 1: File Selection

The DXF, XML, or SHP (contour shapefile) file containing the source data is specified.

This step of the wizard contains the following controls:

- **Data Source Type**—This menu allows you to choose the type of file that contains the input data you will use.
- **File**—This field displays the path where the DXF, XML, or SHP file is located. Use the browse button to find and select the desired file.
- **Spatial Reference**—Click the Ellipsis (...) next to this field to open the Spatial Reference Properties dialog box, allowing you to specify the spatial reference being used by the elevation data file.
- **Select Elevation Field**—Select the elevation unit.
Using TRex to Assign Node Elevations

- **X-Y Units**—This menu allows the selection of the measurement unit type associated with the X and Y coordinates of the elevation data file.

- **Z Units**—This menu allows the selection of the measurement unit type associated with the Z coordinates of the elevation data file.

- **Spatial Reference**—Click the Ellipsis (...) next to this field to open the Spatial Reference Properties dialog box, allowing you to specify the spatial reference being used by the StormCAD V8i model file.

- **Also update inactive elements**—Check this box to include inactive elements in the elevation assignment operation. When this box is unchecked, elements that are marked Inactive will be ignored by TRex.

- **All**—When this button is selected, TRex will attempt to assign elevations to all nodes within the StormCAD V8i model.

- **Selection**—When this button is selected, TRex will attempt to assign elevations to all currently highlighted nodes.

- **Selection Set**—When this is selected, the Selection Set menu is activated. When the Selection Set button is selected, TRex will assign elevations to all nodes within the selection set that is specified in this menu.

**Step 2: Completing the TRex Wizard**

The results of the elevation extraction process are displayed and the results can be applied to a new or existing physical alternative.

- **Results Preview Pane**—This tabular pane displays the elevations that were calculated by TRex. The table can be sorted by label by clicking the Label column heading and by elevation by clicking the Elevation column heading. You can filter the table by right-clicking a column in the table and selecting the Filter...Custom command. You can also right-click any of the values in the elevation column to change the display options.

- **Use Existing Alternative**—When this is selected, the results will be applied to the physical alternative that is selected in the Use Existing Alternative menu. This menu allows the selection of the physical alternative to which the results will be applied.

- **New Alternative**—When this is selected, the results will be applied to a new physical alternative. First, the currently active physical alternative will be duplicated, then the results generated by TRex will be applied to the newly created alternative. The name of this new alternative must be supplied in the New Alternative text field.
• **Parent Alternative**—Select an alternative to duplicate from the menu, or select <None> to create a new Base alternative.

• **Export Results**—This exports the results generated by TRex to a tab or comma-delimited text file (.TXT). These files can then be re-used by StormCAD V8i or imported into other programs.

Click **Finish** when complete, or **Cancel** to close without making any changes.

## 5.20 User Data Extensions

User data extensions are a set of one or more attribute fields that you can define to hold data to be stored in the model. User data extensions allow you to add your own data fields to your project. For example, you can add a field for keeping track of the date of installation for an element or the type of area serviced by a particular element.

**Note:** The user data does not affect the hydraulic model calculations. However, their behavior concerning capabilities like editing, annotating, sorting and database connections is identical to any of the standard pre-defined attributes.

User data extensions exhibit the same characteristics as the predefined data used in and produced by the model calculations. This means that user data extensions can be imported or exported through database and shapefile connections, viewed and edited in the Property Editor or in FlexTables, included in tabular reports or element detailed reports, annotated in the drawing, color coded, and reported in the detailed element reports.

**Note:** The terms “user data extension” and “field” are used interchangeably here. In the context of the User Data Extension feature, these terms mean the same thing.

You define user data extensions in the User Data Extensions dialog box.

**To define a user data extension**

1. Select **Tools > User Data Extensions**.

2. In the list pane on the left, select the element type for which you want to define a new attribute field.

3. Click the **New** button to create a new user data extension. A user data extension with a default name appears under the element type. You can rename the new field if you wish.

4. In the properties pane on the right, enter the following:
   - Type the name of the new field. This is the unique identifier for the field. The name field in the Property Editor is the name of the column in the data source.
– Type the label for the new field. This is the label that will appear next to the field for the user data extension in the Property Editor for the selected element type. This is also the column heading if the data extension is selected to appear in a FlexTable.

– Click the Ellipses (...) button in the Category field, then use the drop-down menu in the Select Category dialog box to select an existing category in which the new field will appear in the Property Editor. To create a new category, simply type the category name in the field.

– Type a number in the Field Order Index field. This is the display order of fields within a particular category in the Property Editor. This order also controls the order of columns in Alternative tables. An entry of 0 means the new field will be displayed first within the specified category.

– Type a description for the field. This description will appear at the bottom of the Property Editor when the field is selected for an element in your model. You can use this field as a reminder about the purpose of the field.

– Select an alternative from the drop-down menu in the Alternative field. This is the alternative that you want to extend with the new field.

– Select a data type from the drop-down menu in the Data Type field.

  - If you select **Enumerated**, an Ellipses (...) button appears in the Default Value field. Enumerated user data extensions are fields that present multiple choices.

  – Enter the default value for the new field. If the data type is **Enumerated**, click the Ellipses (...) button to display the Enumeration Editor dialog box, where you define enumerated members.

5. Perform the following optional steps:

– To import an existing User Data Extension XML File, click the **Import** button, then select the file you want to import. User Data Extension XML Files contain the file name extension .xml or .udx.xml.

– To export existing user data extensions, click the **Export to XML** button, then type the name of the udx.xml file. All user data extensions for all element types defined in the current project are exported.

– To share the new field among two or more element types, select the user data extension in the list pane, then click the **Sharing** button or right-click and select **Sharing**. In the Shared Field Specification dialog box, select the check box next to the element or elements that will share the user data extension. The icon next to the user data extension changes to indicate that it is a shared field. For more information, see **Sharing User Data Extensions Among Element Types on page 5-372**.

– To delete an existing user data extension, select the user data extension you want to delete in the list pane, then click the **Delete** button, or right-click and select **Delete**.
Creating Models

- To rename the display label of an existing user data extension, select the user data extension in the list pane, click the Rename button or right-click and select Rename, then type the new display label.
- To expand the list of elements and view all user data extensions, click the Expand All button.
- To collapse the list of elements so that no user data extensions are displayed, click the Collapse All button.

6. Click OK to close the dialog box and save your user data extensions. The new field(s) you created will appear in the Property Editor for every instance of the specified element type in your model.

5.20.1 User Data Extensions Dialog Box

The User Data Extensions dialog box displays a summary of the user data extensions associated with the current project. The dialog box contains a toolbar, a list pane displaying all available StormCAD V8i element types, and a property editor.
The toolbar contains the following controls:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Import" /></td>
<td>Import</td>
<td>Merges the user data extensions in a saved User Data Extension XML file (.udx.xml or .xml) into the current project. Importing a User Data Extension XML file will not remove any of the other data extensions defined in your project. User data extensions that have the same name as those already defined in your project will not be imported.</td>
</tr>
<tr>
<td><img src="image" alt="Export to XML" /></td>
<td>Export to XML</td>
<td>Saves existing user data extensions for all element types in your model to a User Data Extension XML file (.udx.xml) for use in a different project.</td>
</tr>
<tr>
<td><img src="image" alt="Add Field" /></td>
<td>Add Field</td>
<td>Creates a new user data extension for the currently highlighted element type.</td>
</tr>
<tr>
<td><img src="image" alt="Share" /></td>
<td>Share</td>
<td>Shares the current user data extension with another element type. When you click this button, the Shared Field Specification dialog box opens. For more information, see <a href="#">Sharing User Data Extensions</a> Among Element Types on page 5-372.</td>
</tr>
<tr>
<td><img src="image" alt="Delete Field" /></td>
<td>Delete Field</td>
<td>Deletes the currently highlighted user data extension.</td>
</tr>
<tr>
<td><img src="image" alt="Rename Field" /></td>
<td>Rename Field</td>
<td>Renames the display label of the currently highlighted user data extension.</td>
</tr>
<tr>
<td><img src="image" alt="Expand All" /></td>
<td>Expand All</td>
<td>Expands all of the branches in the hierarchy displayed in the list pane.</td>
</tr>
<tr>
<td><img src="image" alt="Collapse All" /></td>
<td>Collapse All</td>
<td>Collapses all of the branches in the hierarchy displayed in the list pane.</td>
</tr>
</tbody>
</table>
The property editor section of the dialog contains following fields, which define your new user data extension:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>The unique identifier for the field. The name field in the Property Editor is the name of the column in the data source.</td>
</tr>
<tr>
<td>Label</td>
<td>The label that will appear next to the field for the user data extension in the Property Editor for the selected element type. This is also the column heading if the data extension is selected to appear in a FlexTable.</td>
</tr>
<tr>
<td>Category</td>
<td>The section in the Property Editor for the selected element type in which the new field will appear. You can create a new category or use an existing category. For example, you can create a new field for junctions and display it in the Physical section of that element's Property Editor.</td>
</tr>
<tr>
<td>Field Order Index</td>
<td>The display order of fields within a particular category in the Property Editor. This order also controls the order of columns in Alternative tables. An entry of 0 means the new field will be displayed first within the specified category.</td>
</tr>
<tr>
<td>Field Description</td>
<td>The description of the field. This description will appear at the bottom of the Property Editor when the field is selected for an element in your model. You can use this field as a reminder about the purpose of the field.</td>
</tr>
<tr>
<td>Alternative Referenced By</td>
<td>Selects an existing alternative to extend with the new field. Displays all the element types that are using the field. For example, if you create a field called &quot;Installation Date&quot; and you set it up to be shared, this field will show the element types that share this field. So for example, if you set up a field to be shared by junctions and catch basins, the Referenced By field would show &quot;Manhole, Catch Basin&quot;.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Units</strong></td>
<td><strong>Data Type</strong></td>
</tr>
<tr>
<td></td>
<td>Specifies the data type for the user data extension. Click the down arrow in the field then select one of the following data types from the drop-down menu:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Integer</strong>—Any positive or negative whole number.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Real</strong>—Any fractional decimal number (for example, 3.14). It can also be unitized with the provided options.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Text</strong>—Any string (text) value up to 255 characters long.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Long Text</strong>—Any string (text) up to 65,526 characters long.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Date/Time</strong>—The current date. The current date appears by default in the format month/day/year. Click the down arrow to change the default date.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Boolean</strong>—True or False.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Enumerated</strong>—When you select this data type, an Ellipses button appears in the Default Value field. Click the Ellipses (...) button to display the Enumeration Editor dialog box, where you can add enumerated members and their associated values. For more information, see Enumeration Editor Dialog Box on page 5-374.</td>
</tr>
<tr>
<td></td>
<td>- Real (Formula)—Allows you to define a formula to populate the data value.</td>
</tr>
<tr>
<td><strong>Default Value</strong></td>
<td>The default value for the user data extension. The default value must be consistent with the selected data type. If you chose Enumerated as the data type, click the Ellipses (...) button to display the Enumeration Editor.</td>
</tr>
<tr>
<td><strong>Dimension</strong></td>
<td>Specifies the unit type. Click the drop-down arrow in the field to see a list of all available dimensions. This field is available only when you select <strong>Real</strong> as the Data Type.</td>
</tr>
<tr>
<td><strong>Storage Unit</strong></td>
<td>Specifies the storage units for the field. Click the drop-down arrow in the field to see a list of all available units; the units listed change depending on the Dimension you select. This field is available only when you select <strong>Real</strong> as the Data Type.</td>
</tr>
<tr>
<td><strong>Numeric Formatter</strong></td>
<td>Selects a number format for the field. Click the drop-down arrow in the field to see a list of all available number formats; the number formats listed change depending on the Dimension you select. For example, if you select <strong>Flow</strong> as the Dimension, you can select Flow, Flow - Pressurized Condition, Flow Tolerance, or Unit Load as the Numeric Formatter. This field is available only when you select <strong>Real</strong> as the Data Type.</td>
</tr>
</tbody>
</table>
**Formula Dialog Box**

This dialog allows you to define formulas for use with the Real (Formula) User Data Extension type.

You construct the formula using the available fields, operators, and functions. All the dialog box controls are described in the following table.

<table>
<thead>
<tr>
<th>Fields</th>
<th>Lists all input and results fields applicable to the selected element type. This list displays the labels of the fields while the underlying database column names of the fields become visible in the preview pane when you add them to the formula. Double-click a field to add it to your formula.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operators</td>
<td>These buttons represent all of the operators that can be used in the formula. Click the appropriate button to add the operator to the end of your formula, which is displayed in the preview pane. Besides the common options for options for adding, subtracting, multiplying and dividing values, there are also ( ) which allows for more complex formulas, and the caret (^) which is used for raising a value to the power of a value</td>
</tr>
</tbody>
</table>
**Available Match Functions**

Lists mathematical functions that can be used in the formula. If you hover over a function it will describe the number of required parameters and a brief description of what the function does.

**Copy**

Copies the entire formula displayed in the preview pane to the Windows clipboard.

**Paste**

Pastes the contents of the Windows clipboard into the preview pane at the location of the text cursor. For example, if your cursor is at the end of the formula in the preview pane and you click the Paste button, the contents of your clipboard will be added to the end of the formula.

**Preview Pane**

Displays the formula as you add fields, operators, and functions to it.

---

### 5.20.2 *Sharing User Data Extensions Among Element Types*

You can share user data extensions across multiple element types in StormCAD V8i. Shared user data extensions are displayed in the Property Editor for all elements types that share that field.

The icons displayed next to the user data extensions in the User Data Extensions dialog box change depending on the status of the field:

- **Indicates a new unsaved user data extension.**
- **Indicates a user data extension that has been saved to the data source.**
- **Indicates a user data extension that is shared among multiple element types but has not been applied to the data source.**
- **Indicates a user data extension that is shared among multiple element types and that has been applied to the data source.** Fields with this icon appear in the Property Editor for any elements of the associated element types that appear in your model.

Observe the following rules when sharing user data extensions:
Creating Models

- You can select any number of element types with which to share the field. The list is limited to element types that support the Alternative defined for the Field. For example, the Physical Alternative may only apply to five of the element types. In this case, you will only see these five items listed in the Alternative drop-down menu.

- You cannot use the sharing feature to move a field from one element type to another. Validation is in place to ensure that only one item is selected and if it is the same as the original, default selection. If it is not, a message appears telling you that when sharing a field, you must select at least two element types, or select the original element type.

- To unshare a field that is shared among multiple element types, right-click the user data extension you want to keep in the list pane, then select Sharing. Clear all the element types that you do not want to share the field and click OK. If you leave only one element type checked in the Shared Field Specification dialog box, it must be the original element type for which you created the user data extension.
  - The fields that were located under the tank and pipe element type root nodes will be removed completely.
  - You can also unshare a field by using the Delete button or right-clicking and selecting Delete. This will unshare and delete the field.

**To share a user data extension**

1. Open the User Data Extensions dialog box by selecting **Tools > User Data Extensions**.

2. In the list pane, create a new user data extension to share or select an existing user data extension you want to share, then click the Sharing button.

3. In the Shared Field Specification dialog box, select the check box next to each element type that will share the user data extension.

4. Click OK.

5. The icon next to the user data extension in the list pane changes to indicate that it is a shared field.
5.20.3 **Shared Field Specification Dialog Box**

Select element types to share a user data extension in the Shared Field Specification dialog box. The dialog box contains a list of all possible element types with check boxes.

Select element types to share the current user data extension by selecting the check box next to the element type. Clear a selection if you no longer want that element type to share the current field.

5.20.4 **Enumeration Editor Dialog Box**

The Enumeration Editor dialog box opens when you select **Enumerated** as the Data Type for a user data extension, then click the **Ellipses (...)** button in the Default Value field. Enumerated fields are fields that contain multiple selections - you define these as members in the Enumeration Editor dialog box.
For example, suppose you want to identify pipes in a model of a new subdivision by one of the following states: Existing, Proposed, Abandoned, Removed, and Retired. You can define a new user data extension with the label “Pipe Status” for pipes, and select Enumerated as the data type. Click the Ellipses (...) button in the Default Value field in the Property Editor for the user data extension to display the Enumeration Editor dialog box. Then enter five members with unique labels (one member for each unique pipe status) and enumeration values in the table. After you close the User Data Extensions dialog box, the new field and its members will be available in the Property Editor for all pipes in your model. You will be able to select any of the statuses defined as members in the new Pipe Status field.

You can specify an unlimited number of members for each user data extension, but member labels and values must be unique. If they are not unique, an error message appears when you try to close the dialog box.

The dialog box contains a table and the following controls:

- **New**—Adds a new row to the table. Each row in the table represents a unique enumerated member of the current user data extension.
- **Delete**—Deletes the current row from the table. The enumerated member defined in that row is deleted from the user data extension.
Define enumerated members in the table, which contains the following columns:

- **Enumeration Member Display Label**—The label of the member. This is the label you will see in StormCAD V8i wherever the user data extension appears (Property Editor, FlexTables, etc.).
- **Enumeration Value**—A unique integer index associated with the member label. StormCAD V8i uses this number when it performs operations such as queries.

### 5.20.5 User Data Extensions Import Dialog Box

The Import dialog box opens after you initiate an Import command and choose the xml file to be imported. The Import dialog displays all of the domain elements contained within the selected xml file. Uncheck the boxes next to a domain element to ignore them during import.

### 5.21 Customization Manager

The Customization Manager allows you to create customization profiles that define changes to the default user interface. Customization profiles allow you to turn off the visibility of properties in the Properties Editor.

Customization Profiles can be created for a single project or shared across projects. There are also a number of predefined profiles.

The Customization Manager consists of the following controls:
Creating Models

New
This button opens a submenu containing the following commands:

• Folder: This command creates a new folder under the currently highlighted node in the list pane.
• Customization: This command creates a new customization profile under the currently highlighted node in the list pane.

Delete
This button deletes the currently highlighted folder or customization profile.

Rename
This button allows you to rename the currently highlighted folder or customization profile.

Edit
Opens the Customization Editor dialog allowing you to edit the currently highlighted customization profile.

Help
Opens the online help.

5.21.1 Customization Editor Dialog Box

This dialog box allows you to edit the customization profiles that are created in the Customization Manager. In the Customization editor you can turn off the visibility of various properties in the Property Grid.

You can turn off any number of properties and/or entire categories of properties in a single customization profile.

To remove a property from the property grid:

1. Select the element type from the pulldown menu.
2. Find the property you want to turn off by expanding the node of the category the property is under.
3. Uncheck the box next to the property to be turned off.
4. Click OK.
To turn off all of the properties under a category:

1. Select the element type from the pulldown menu.
2. Uncheck the box next to the category to be turned off.
3. Click OK.

5.22 External Tools

Use the External Tool Manager to manage custom menu commands, which are then located in the Tools menu for quick accessibility.

Click Tools>External Tools to create a custom menu command from any executable file. Executable file types include:

- .exe
- .com
- .pif
- .bat
- .cmd

The External Tool Manager consists of the following elements:

- **External Tool List Pane**—This pane lists the external tools that have been created. All of the tools listed in this pane will be displayed in the Tools > External Tools menu.
Creating Models

- **New**—Creates a new external tool in the list pane.
- **Delete**—Deletes the currently highlighted tool.
- **Rename**—Allows you to rename the currently highlighted tool.
- **Command**—This field allows you to enter the full path to the executable file that the tool will initiate. Click the ellipsis button to open a Windows Open dialog to allow you to browse to the executable.
- **Arguments**—This optional field allows you to enter command line variables that are passed to the tool or command when it is activated. Click the > button to open a submenu containing predefined arguments. Arguments containing spaces must be enclosed in quotes. The available arguments are:
  - **Project Directory**—This argument passes the current project directory to the executable upon activation of the tool. The argument string is %(ProjDir).
  - **Project File Name**—This argument passes the current project file name to the executable upon activation of the tool. The argument string is %(ProjFileName).
  - **Project Store File Name**—This argument passes the current project datastore file name to the executable upon activation of the tool. The argument string is %(ProjStoreFileName).
  - **Working Directory**—This argument passes the current working directory to the executable upon activation of the tool. The argument string is %(ProjWorkDir).
- **Initial Directory**—Specifies the initial or working directory of the tool or command. Click the > button to open a submenu containing predefined directory variables. The available variables are:
**External Tools**

**Project Directory** - This variable specifies the current project directory as the Initial Directory. The variable string is `%ProjDir`.

**Working Directory** - This variable specifies the current working directory as the Initial Directory. The variable string is `%ProjWorkDir`.

- **Test** - This button executes the external tool using the specified settings.
Understanding Scenarios and Alternatives

Scenario Example - A Water Distribution System

Scenarios

Alternatives

6.1 Understanding Scenarios and Alternatives

Scenarios and alternatives allow you to create, analyze, and recall an unlimited number of variations of your model. In Bentley StormCAD V8i, scenarios contain alternatives to give you precise control over changes to the model.

Scenario management can dramatically increase your productivity in the "What If?" areas of modeling, including calibration, operations analysis, and planning.

6.1.1 Advantages of Automated Scenario Management

In contrast to editing or copying data, automated scenario management using inheritance gives you significant advantages:

- A single project file makes it possible to generate an unlimited number of "What If?" conditions without becoming overwhelmed with numerous modeling files and separate results.
- The software maintains the data for all the scenarios in a single project so it can provide you with powerful automated tools for directly comparing scenario results where any set is available at any time.
- The Scenario/Alternative relationship empowers you to mix and match groups of data from existing scenarios without having to re-declare any data.
• You do not have to re-enter data if it remains unchanged in a new alternative or scenario, avoiding redundant copies of the same data. It also enables you to correct a data input error in a parent scenario and automatically update the corrected attribute in all child scenarios.

These advantages may not seem compelling for small projects, however, as projects grow to hundreds or thousands of network elements, the advantages of true scenario inheritance become clear. On a large project, being able to maintain a collection of base and modified alternatives accurately and efficiently can be the difference between evaluating optional improvements or ignoring them.

### 6.1.2 A History of What-If Analyses

The history of what-if analyses can be divided into two periods: Distributed Scenarios and Self Contained Scenarios.

### 6.1.3 Distributed Scenarios

Traditionally, there have only been two possible ways of analyzing the effects of change on a software model:

• Change the model, recalculate, and review the results
• Create a copy of the model, edit that copy, calculate, and review the results.

Although either of these methods may be adequate for a relatively small system, the data duplication, editing, and re-editing become very time-consuming and error-prone as the size of the system and the number of possible conditions increase. Also, comparing conditions requires manual data manipulation, because all output must be stored in physically separate data files.
6.1.4 **Self-Contained Scenarios**

Effective scenario management tools need to meet these objectives:

- Minimize the number of project files the modeler needs to maintain.
- Maximize the usefulness of scenarios through easy access to things such as input and output data, and direct comparisons.
Understanding Scenarios and Alternatives

- Maximize the number of scenarios you can simulate by mixing and matching data from existing scenarios (data reuse).
- Minimize the amount of data that needs to be duplicated to consider conditions that have a lot in common.

The scenario management feature in StormCAD V8i successfully meets all of these objectives. A single project file enables you to generate an unlimited number of What If? conditions; edit only the data that needs to be changed and quickly generate direct comparisons of input and results for desired scenarios.

6.1.5 The Scenario Cycle

The process of working with scenarios is similar to the process of manually copying and editing data but without the disadvantages of data duplication and troublesome file management. This process allows you to cycle through any number of changes to the model, without fear of overwriting critical data or duplicating important information. It is possible to directly change data for any scenario, but an audit trail of scenarios can be useful for retracing the steps of a calibration series or for understanding a group of master plan updates.

**Figure 6-2: Self Contained Scenarios**

![Diagram of the Scenario Cycle](image)

Build Model (Base Scenario) → Calculate Scenario → Edit Scenario → Review Results → Add Scenario
### 6.1.6 Scenarios and Alternatives

**6.1.7 Scenario Attributes and Alternatives**

- **Attribute**—An attribute is a fundamental property of an object and is often a single numeric quantity. For example, the attributes of a pipe include diameter, length, and roughness.

- **Alternative**—An alternative holds a family of related attributes so pieces of data that you are most likely to change together are grouped for easy referencing and editing. For example, a physical properties alternative groups physical data for the network's elements, such as elevations, sizes, and roughness coefficients.

- **Scenario**—A scenario has a list of referenced alternatives (which hold the attributes) and combines these alternatives to form an overall set of system conditions that can be analyzed. This referencing of alternatives enables you to easily generate system conditions that mix and match groups of data that have been previously created. Scenarios do not actually hold any attribute data—the referenced alternatives do.

### 6.1.8 A Familiar Parallel

Although the structure of scenarios may seem a bit difficult at first, if you have ever eaten at a restaurant, you should be able to understand the concept. A meal (scenario) is comprised of several courses (alternatives), which might include a salad, an entrée, and a dessert. Each course has its own attributes. For example, the entrée may have a meat, a vegetable, and a starch. Examining the choices, we could present a menu as in the following figure:
The restaurant does not have to create a new recipe for every possible meal (combination of courses) that could be ordered. They can just assemble any meal based on what the customer orders for each alternative course. Salad 1, Entrée 1, and Dessert 2 might then be combined to define a complete meal.

Generalizing this concept, we see that any scenario references one alternative from each category to create a big picture that can be analyzed. Different types of alternatives may have different numbers and types of attributes, and any category can have an unlimited number of alternatives to choose from.

**Figure 6-3: Generic Scenario Anatomy**

![Diagram of scenario anatomy](image)

### 6.1.9 Inheritance

The separation of scenarios into distinct alternatives (groups of data) meets one of the basic goals of scenario management: maximizing the number of scenarios you can develop by mixing and matching existing alternatives. Two other primary goals have also been addressed: a single project file is used, and easy access to input data and calculated results is provided in numerous formats through the intuitive graphical interface.

In order to meet the objective of minimizing the amount of data that needs to be duplicated, and in order to consider conditions that have a lot of common input, you use inheritance.

In the natural world, a child inherits characteristics from a parent. This may include such traits as eye-color, hair color, and bone structure.
**Overriding Inheritance**

A child can override inherited characteristics by specifying a new value for that characteristic. These overriding values do not affect the parent and are therefore considered local to the child. Local values can also be removed at any time, reverting the characteristic to its inherited state. The child has no choice in the value of his inherited attributes, only in local attributes.

For example, a child has inherited the attribute of blue eyes from his parent. If the child puts on a pair of green tinted contact lenses to hide his natural eye color, his natural eye color is overridden locally, and his eye color is green. When the tinted lenses are removed, the eye color reverts to blue, as inherited from the parent.

**Dynamic Inheritance**

Dynamic inheritance does not have a parallel in the genetic world. When a parent's characteristic is changed, existing children also reflect the change. Using the eye-color example, this would be the equivalent of the parent changing eye color from blue to brown and the children's eyes instantly inheriting the brown color also. Of course, if the child has already overridden a characteristic locally, as with the green lenses, his eyes will remain green until the lenses are removed. At this point, his eye color will revert to the inherited color, now brown.

This dynamic inheritance has remarkable benefits for applying wide-scale changes to a model, fixing an error, and so on. If rippling changes are not desired, the child can override all of the parent's values, or a copy of the parent can be made instead of a child.
6.1.10 **Local and Inherited Values**

Any changes that are made to the model belong to the currently active scenario and the alternatives that it references. If the alternatives happen to have children, those children will also inherit the changes unless they have specifically overridden that attribute. The following figure demonstrates the effects of a change to a mid-level alternative. Inherited values are shown as gray text, local values are shown as black text.

A Mid-level Hierarchy Alternative Change

<table>
<thead>
<tr>
<th>Alternative Hierarchy</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition 1</td>
<td>100</td>
</tr>
<tr>
<td>Condition 2</td>
<td>100</td>
</tr>
<tr>
<td>Condition 3</td>
<td>190</td>
</tr>
<tr>
<td>Condition 4</td>
<td>150</td>
</tr>
<tr>
<td>Condition 5</td>
<td>150</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Alternative Hierarchy</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition 1</td>
<td>100</td>
</tr>
<tr>
<td>Condition 2</td>
<td>100</td>
</tr>
<tr>
<td>Condition 3</td>
<td>200</td>
</tr>
<tr>
<td>Condition 4</td>
<td>200</td>
</tr>
<tr>
<td>Condition 5</td>
<td>150</td>
</tr>
</tbody>
</table>

6.1.11 **Minimizing Effort through Attribute Inheritance**

Inheritance has an application every time you hear the phrase, "just like x except for y." Rather than specifying all of the data from x again to form this new condition, we can create a child from x and change y appropriately. Now we have both conditions with no duplicated effort.

We can even apply this inheritance to our restaurant analogy as follows. Inherited values are shown as gray text, local values are shown as black text.

**Note:** Salad 3 could inherit from Salad 2, if we prefer: "Salad 3 is just like Salad 2, except for the dressing."

<table>
<thead>
<tr>
<th>Salad Alternative Hierarchy</th>
<th>Attribute: Vegetables</th>
<th>Attribute: Dressing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Salad 1</td>
<td>Lettuce &amp; Carrots</td>
<td>No Dressing</td>
</tr>
<tr>
<td>Salad 2</td>
<td>Lettuce &amp; Carrots</td>
<td>Thousand Island</td>
</tr>
<tr>
<td>Salad 3</td>
<td>Lettuce &amp; Carrots</td>
<td>Blue Cheese</td>
</tr>
</tbody>
</table>

- "Salad 2 is just like Salad 1, except for the dressing."
- "Salad 3 is just like Salad 1, except for the dressing."
Note: If the vegetable of the day changes (from green beans to peas), only Entrée 1 needs to be updated, and the other entrées will automatically inherit the vegetable attribute of "Peas" instead of "Green Beans."

<table>
<thead>
<tr>
<th>Entree Alternative Hierarchy</th>
<th>Attribute: Mea t</th>
<th>Attribute: Starch</th>
<th>Attribute: Vegetable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entrée 1</td>
<td>Beef</td>
<td>Baked Potato</td>
<td>Green Beans</td>
</tr>
<tr>
<td>Entrée 2</td>
<td>Chicken</td>
<td>Rice</td>
<td>Green Beans</td>
</tr>
<tr>
<td>Entrée 3</td>
<td>Fish</td>
<td>Rice</td>
<td>Green Beans</td>
</tr>
</tbody>
</table>

- "Entrée 2 is just like Entrée 1, except for the meat and the starch."
- "Entrée 3 is just like Entrée 2, except for the meat."

Note: Dessert 3 has nothing in common with the other desserts, so it can be created as a "root" or base alternative. It does not inherit its attribute data from any other alternative.

<table>
<thead>
<tr>
<th>Dessert Alternative Hierarchy</th>
<th>Attribute: Bakery Item</th>
<th>Attribute: Topping</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dessert 1</td>
<td>Apple Pie</td>
<td>No Topping</td>
</tr>
<tr>
<td>Dessert 2</td>
<td>Apple Pie</td>
<td>Ice Cream</td>
</tr>
<tr>
<td>Dessert 3</td>
<td>Chocolate Cake</td>
<td>Whipped Cream</td>
</tr>
</tbody>
</table>

- "Dessert 2 is just like Dessert 1, except for the topping."

6.1.12 Minimizing Effort through Scenario Inheritance

Just as a child alternative can inherit attributes from its parent, a child scenario can inherit which alternatives it references from its parent. This is essentially the phrase “just like x except for y”, but on a larger scale.

Using the meal example, consider a situation where you go out to dinner with three friends. The first friend orders a meal and the second friend orders the same meal with a different dessert. The third friend orders a different meal and you order the same meal with a different salad.

The four meal scenarios could then be presented as follows (inherited values are shown as gray text, local values are shown as black text).

- "Meal 2 is just like Meal 1, except for the dessert." The salad and entrée alternatives are inherited from Meal 1.
- "Meal 3 is nothing like Meal 1 or Meal 2." A new base or root is created.
6.2 Scenario Example - A Water Distribution System

A water distribution system where a single reservoir supplies water by gravity to three junction nodes.

Figure 6-4: Example Water Distribution System

Although true water distribution scenarios include such alternative categories as initial settings, operational controls, water quality, and fire flow, the focus here is on the two most commonly changed sets of alternatives: demands and physical properties. Within these alternatives, the concentration will be on junction baseline demands and pipe diameters.
6.2.1 Building the Model (Average Day Conditions)

During model construction, only one alternative from each category is going to be considered. This model is built with average demand calculations and preliminary pipe diameter estimates. You can name the scenario and alternatives, and the hierarchies look like the following (showing only the items of interest):

<table>
<thead>
<tr>
<th>Demand Alternative Hierarchy</th>
<th>J-1</th>
<th>J-2</th>
<th>J-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Day</td>
<td>100 gpm</td>
<td>500 gpm</td>
<td>100 gpm</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Physical Alternative Hierarchy</th>
<th>P-1</th>
<th>P-2</th>
<th>P-3</th>
<th>P-4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preliminary Pipes</td>
<td>8 inches</td>
<td>6 inches</td>
<td>6 inches</td>
<td>6 inches</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Scenario Hierarchy</th>
<th>Demand Alternative</th>
<th>Physical Alternative</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg. Day</td>
<td>Average Day</td>
<td>Preliminary Pipes</td>
</tr>
</tbody>
</table>

6.2.2 Analyzing Different Demands (Maximum Day Conditions)

In this example, the local planning board also requires analysis of maximum day demands, so a new demand alternative is required. No variation in demand is expected at J-2, which is an industrial site. As a result, the new demand alternative can inherit J-2’s demand from Average Day while the other two demands are overridden.

<table>
<thead>
<tr>
<th>Demand Alternative Hierarchy</th>
<th>J-1</th>
<th>J-2</th>
<th>J-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Day</td>
<td></td>
<td>100 gpm</td>
<td>500 gpm</td>
</tr>
<tr>
<td>Maximum Day</td>
<td>200 gpm</td>
<td>500 gpm</td>
<td>200 gpm</td>
</tr>
</tbody>
</table>

Now we can create a child scenario from Average Day that inherits the physical alternative but overrides the selected demand alternative. As a result, we get the following scenario hierarchy:

<table>
<thead>
<tr>
<th>Scenario Hierarchy</th>
<th>Demand Alternative</th>
<th>Physical Alternative</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg. Day Max. Day</td>
<td>Average Day Maximum Day</td>
<td>Preliminary Pipes Preliminary Pipes</td>
</tr>
</tbody>
</table>
Since no physical data (pipe diameters) have been changed, the physical alternative hierarchy remains the same as before.

### 6.2.3 Another Set of Demands (Peak Hour Conditions)

Based on pressure requirements, the system is adequate to supply maximum day demands. Another local regulation requires analysis of peak hour demands with slightly lower allowable pressures. Since the peak hour demands also share the industrial load from the Average Day condition, Peak Hour can be inherited from Average Day. In this instance, Peak Hour could also inherit from Maximum Day.

<table>
<thead>
<tr>
<th>Demand Alternative Hierarchy</th>
<th>J-1</th>
<th>J-2</th>
<th>J-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Day</td>
<td>100 gpm</td>
<td>500 gpm</td>
<td>100 gpm</td>
</tr>
<tr>
<td>Maximum Day</td>
<td>200 gpm</td>
<td>500 gpm</td>
<td>200 gpm</td>
</tr>
<tr>
<td>Peak Hour</td>
<td>250 gpm</td>
<td>500 gpm</td>
<td>250 gpm</td>
</tr>
</tbody>
</table>

Another scenario is also created to reference these new demands, as shown below:

<table>
<thead>
<tr>
<th>Scenario Hierarchy</th>
<th>Demand Alternative</th>
<th>Physical Alternative</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg. Day</td>
<td>Average Day</td>
<td>Preliminary Pipes</td>
</tr>
<tr>
<td></td>
<td>Maximum Day</td>
<td>Preliminary Pipes</td>
</tr>
<tr>
<td></td>
<td>Peak Hour</td>
<td>Preliminary Pipes</td>
</tr>
</tbody>
</table>

No physical data was changed, so the physical alternatives remain the same.

### 6.2.4 Correcting an Error

This analysis results in acceptable pressures until it is discovered that the industrial demand is not actually 500 gpm—it is 1,500 gpm. However, due to the inheritance within the demand alternatives, only the Average Day demand for J-2 needs to be updated. The changes effect the children. After the single change is made, the demand hierarchy is as follows:

<table>
<thead>
<tr>
<th>Demand Alternative Hierarchy</th>
<th>J-1</th>
<th>J-2</th>
<th>J-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Day</td>
<td>100 gpm</td>
<td>1,500 gpm</td>
<td>100 gpm</td>
</tr>
<tr>
<td>Maximum Day</td>
<td>200 gpm</td>
<td>1,500 gpm</td>
<td>200 gpm</td>
</tr>
<tr>
<td>Peak Hour</td>
<td>250 gpm</td>
<td>1,500 gpm</td>
<td>250 gpm</td>
</tr>
</tbody>
</table>

Notice that no changes need to be made to the scenarios to reflect these corrections. The three scenarios can now be calculated as a batch to update the results.
When these results are reviewed, it is determined that the system does not have the ability to adequately supply the system as it was originally thought. The pressure at J-2 is too low under peak hour demand conditions.

### 6.2.5 Analyzing Improvement Suggestions

To counter the headloss from the increased demand load, two possible improvements are suggested:

- A much larger diameter is proposed for P-1 (the pipe from the reservoir). This physical alternative is created as a child of the Preliminary Pipes alternative, inheriting all the diameters except P-1’s, which is overridden.
- Slightly larger diameters are proposed for all pipes. Since there are no commonalities between this recommendation and either of the other physical alternatives, this can be created as a base (root) alternative.

These changes are then incorporated to arrive at the following hierarchies:

<table>
<thead>
<tr>
<th>Physical Alternative Hierarchy</th>
<th>P-1</th>
<th>P-2</th>
<th>P-3</th>
<th>P-4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preliminary Pipes</td>
<td>8 inches</td>
<td>6 inches</td>
<td>6 inches</td>
<td>6 inches</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Scenario Hierarchy</th>
<th>Demand Alternative</th>
<th>Physical Alternative</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg. Day</td>
<td>Average Day</td>
<td>Preliminary Pipes</td>
</tr>
<tr>
<td>Max. Day</td>
<td>Maximum Day</td>
<td>Preliminary Pipes</td>
</tr>
<tr>
<td>Peak</td>
<td>Peak Hour</td>
<td>Larger P-1</td>
</tr>
<tr>
<td>Peak, Big P-1</td>
<td>Peak Hour</td>
<td>Larger All Pipes</td>
</tr>
<tr>
<td>Peak, All Big Pipes</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This time the demand alternative hierarchy remains the same since no demands were changed. The two new scenarios (Peak, Big P-1, Peak, All Big Pipes) can be batch run to provide results for these proposed improvements.
6.2.6 **Finalizing the Project**

It is decided that enlarging P-1 is the optimum solution, so new scenarios are created to check the results for average day and maximum day demands. Notice that this step does not require handling any new data. All of the information to be modeled is already present in the alternatives.

<table>
<thead>
<tr>
<th>Scenario Hierarchy</th>
<th>Demand Alternative</th>
<th>Physical Alternative</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg. Day</td>
<td>Average Day</td>
<td>Preliminary Pipes</td>
</tr>
<tr>
<td></td>
<td>Maximum Day</td>
<td>Preliminary Pipes</td>
</tr>
<tr>
<td>Max. Day</td>
<td>Peak Hour</td>
<td>Preliminary Pipes</td>
</tr>
<tr>
<td></td>
<td>Peak Hour</td>
<td>Larger P-1</td>
</tr>
<tr>
<td>Big, P-1</td>
<td>Peak Hour</td>
<td>Larger P-1</td>
</tr>
<tr>
<td></td>
<td>Average Day</td>
<td>Larger All Pipes</td>
</tr>
<tr>
<td></td>
<td>Average Day</td>
<td>Larger P-1</td>
</tr>
</tbody>
</table>

Also note that it would be equally effective in this case to inherit the Avg. Day, Big P-1 scenario from Avg. Day (changing the physical alternative) or to inherit from Peak, Big P-1 (changing the demand alternative). Max. Day, Big P-1 could inherit from either Max. Day or Peak, Big P-1.

Neither the demand nor physical alternative hierarchies were changed in order to run the last set of scenarios, so they remain the same.

<table>
<thead>
<tr>
<th>Demand Alternative Hierarchy</th>
<th>J-1</th>
<th>J-2</th>
<th>J-3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Day</td>
<td>100 gpm</td>
<td>1,500 gpm</td>
<td>100 gpm</td>
</tr>
<tr>
<td>Maximum Day</td>
<td>200 gpm</td>
<td>1,500 gpm</td>
<td>200 gpm</td>
</tr>
<tr>
<td>Peak Hour</td>
<td>250 gpm</td>
<td>1,500 gpm</td>
<td>250 gpm</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Physical Alternative Hierarchy</th>
<th>P-1</th>
<th>P-2</th>
<th>P-3</th>
<th>P-4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preliminary Pipes</td>
<td>8 inches</td>
<td>6 inches</td>
<td>6 inches</td>
<td>6 inches</td>
</tr>
<tr>
<td>Larger P-1</td>
<td>18 inches</td>
<td>6 inches</td>
<td>6 inches</td>
<td>6 inches</td>
</tr>
<tr>
<td>Larger All Pipes</td>
<td>12 inches</td>
<td>12 inches</td>
<td>12 inches</td>
<td>12 inches</td>
</tr>
</tbody>
</table>

6.2.7 **Advantages to Automated Scenario Management**

In contrast to the old methods of scenario management (editing or copying data), automated scenario management using inheritance gives you significant advantages:

- A single project file makes it possible to generate an unlimited number of **What If?** conditions without becoming overwhelmed with numerous modeling files and separate results.
The software maintains the data for all the scenarios in a single project, so it can provide you with powerful automated tools for directly comparing scenario results, and any set of results is available at any time.

The Scenario/Alternative relationship empowers you to mix and match groups of data from existing scenarios without having to re-declare any data.

You do not have to re-enter data if it remains unchanged in a new alternative or scenario using inheritance, thus avoiding redundant copies of the same data. Inheritance also enables you to correct a data input error in a parent scenario and automatically update the corrected attribute in all child scenarios.

To learn more about using scenario management in StormCAD V8i, load one of the sample projects and explore the scenarios already defined. For context-sensitive help, press F1 or the Help button.

### 6.3 Scenarios

A Scenario contains all the input data (in the form of Alternatives), calculation options, results, and notes associated with a set of calculations. Scenarios let you set up an unlimited number of “What If?” situations for your model, and then modify, compute, and review your system under those conditions.

You can create an unlimited number of scenarios that reuse or share data in existing alternatives, submit multiple scenarios for calculation in a batch run, switch between scenarios, and compare scenario results—all with a few mouse clicks.
6.3.1 **Scenarios Manager**

The Scenario Manager allows you to create, edit, and manage an unlimited number of scenarios. There is one built-in default scenario—the Base scenario. If you want, you only have to use this one scenario. However, you can save yourself time by creating additional scenarios that reference the alternatives needed to perform and recall the results of each of your calculations.

The Scenario Manager consists of a hierarchical tree view and a toolbar. The tree view displays all of the scenarios in the project. If the Property Editor is open, clicking a scenario in the list causes the alternatives that make up the scenario to open. If the Property Editor is not open, you can display the alternatives and scenario information by selecting the desired scenario and right-clicking on Properties.
| New Scenario | Opens a submenu containing the following commands:  
|              | • **Child Scenario**—creates a new Child scenario from the currently selected Base scenario.  
|              | • **Base Scenario**—creates a new Base scenario.  |
| Delete       | Removes the currently selected scenario, greyed out on the menu bar when Base Scenario is active.  |
| Rename       | Renames the currently selected scenario.  |
| **Compute Scenario** | Opens a submenu containing the following command:  
|              | • **Scenario**—calculates the currently selected scenario.  |
| Make Current | Causes the currently selected scenario to become the active one and displays it in the drawing pane.  |
| Expand All   | Opens all scenarios within all folders in the list.  |
| Collapse All | Closes all of the folders in the list.  |
| Help         | Displays online help for the Scenario Manager.  |

**Note:** When you delete a scenario, you are not losing data records because scenarios never actually hold calculation data records (alternatives do). The alternatives and data records referenced by that scenario exist until you explicitly delete them. By accessing the Alternative Manager, you can delete the referenced alternatives and data records.

### 6.3.2 **Base and Child Scenarios**

There are two types of scenarios:

- **Base Scenarios**—Contain all of your working data. When you start a new project, you begin with a default base scenario. As you enter data and calculate your model, you are working with this default base scenario and the alternatives it references.
• **Child Scenarios**—Inherit data from a base scenario or other child scenarios. Child scenarios allow you to freely change data for one or more elements in your system. Child scenarios can reflect some or all of the values contained in their parent. This is a very powerful concept, giving you the ability to make changes in a parent scenario that will trickle down through child scenarios, while also giving you the ability to override values for some or all of the elements in child scenarios.

  **Note:** The calculation options are not inherited between scenarios but are duplicated when the scenario is first created. The alternatives and data records, however, are inherited. There is a permanent, dynamic link from a child back to its parent.

### 6.3.3 Creating Scenarios

You create new scenarios in the Scenario Manager. A new scenario can be a Base scenario or a Child scenario.

**To create a new scenario**

1. Select **Analysis > Scenarios** to open the Scenario Manager, or click ![Scenario Manager](scenario_manager.png).

2. Click **New** and select whether you want to create a Base Scenario or a Child Scenario. When creating a Child scenario, you must first select the scenario from which the child is derived in the Scenario Manager tree view.
By default, a new scenario comprises the Base Alternatives associated with each alternative type.

3. Double-click the new scenario to edit its properties in the Property Editor.

4. Close when finished.

**Editing Scenarios**

Scenarios can be edited in two places:

- The *Scenario Manager* lists all of the project’s scenarios in a hierarchical tree format and displays the Base/Child relationship between them.
- The *Property Editor* displays the alternatives that make up the scenario that is currently selected in the Scenario Manager, along with the scenario label, any notes associated with the scenario, and the calculation options profile that is used when the scenario is calculated.

**To edit a scenario**

1. Select *Analysis > Scenarios* to open the Scenario Manager, or click .
2. Double-click the scenario you want to edit to display its properties in the Properties Editor.
3. You can then edit the Scenario Label, Notes, Alternatives, and Calculation Options.
4. When finished, close the editor.

**6.3.4 Running Multiple Scenarios at Once (Batch Runs)**

Performing a batch run allows you to set up and run calculations for multiple scenarios at once. This is helpful if you want to perform a large number of calculations or manage a group of smaller calculations as a set. It can be run at any time. The list of selected scenarios for the batch run remain with your project until you change it.
To perform a batch run

1. Select Analysis > Scenarios to open the Scenario Manager, or click .
2. Click to open the Compute list and then select Batch Run. This will open the

   ![Batch Run Editor](image)

   Batch Run Editor.

3. Check the scenarios you want to run, then click Batch.
4. A Please Confirm dialog box opens to confirm running the selected scenarios as a batch. Click Yes to run.
5. When the batch is completed an Information box opens. Click OK.
6. Select a calculated scenario from the Scenario toolbar list to see the results throughout the program.
Note: When the batch run is completed, the scenario that was current stays current, even if it was not calculated.

6.3.5 **Batch Run Editor Dialog Box**

The Batch Run Editor dialog box contains the following controls:

- **Batch**
  - Start the batch run of the selected scenarios.

- **Select**
  - Display a menu containing the following commands:
    - **Select All**: Select all scenarios listed.
    - **Clear Selection**: Clear all selected scenarios.

- **Close**
  - Close the Batch Run Editor dialog box.

- **Help**
  - Display context-sensitive help for the Batch Run Editor dialog box.

6.4 **Alternatives**

Alternatives are the building blocks behind scenarios. They are categorized data sets that create scenarios when placed together. Alternatives hold the input data in the form of records. A record holds the data for a particular element in your system.
Scenarios are composed of alternatives as well as other calculation options, allowing you to compute and compare the results of various changes to your system. Alternatives can vary independently within scenarios and can be shared between scenarios.

Scenarios allow you to specify the alternatives you want to analyze. In combination with scenarios, you can perform calculations on your system to see the effect of each alternative. Once you have determined an alternative that works best for your system, you can permanently merge changes from the preferred alternative to the base alternative.

When you first set up your system, the data that you enter is stored in the various base alternative types. If you want to see how your system behaves, for example, by increasing the diameter of a few select pipes, you can create a child alternative. You can make another child alternative with even larger diameters and another with smaller diameters. The number of alternatives that can be created is unlimited.

### 6.4.1 Alternatives Manager

The Alternative Manager allows you to create, view, and edit the alternatives that make up the project scenarios. The dialog box consists of a pane that displays folders for each of the alternative types which can be expanded to display all of the alternatives for that type and a toolbar.
### The toolbar consists of the following

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Creates a new Alternative.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the currently selected alternative.</td>
</tr>
<tr>
<td>Edit</td>
<td>Opens the Alternative Editor dialog box for the currently selected alternative.</td>
</tr>
<tr>
<td>Merge Alternative</td>
<td>Moves all records from one alternative to another.</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames the currently selected alternative.</td>
</tr>
<tr>
<td>Report</td>
<td>Generates a report of the currently selected alternative.</td>
</tr>
<tr>
<td>Expand All</td>
<td>Displays the full alternative hierarchy.</td>
</tr>
<tr>
<td>Collapse All</td>
<td>Collapses the alternative hierarchy so that only the top-level nodes are visible.</td>
</tr>
<tr>
<td>Help</td>
<td>Displays online help for the Alternative Manager.</td>
</tr>
</tbody>
</table>
6.4.2 Alternative Editor Dialog Box

This dialog box presents in tabular format the data that makes up the alternative being edited. Depending on the alternative type, the dialog box contains a separate tab for each element that possesses data contained in the alternative.

![Alternative Editor Dialog Box](image)

The Alternative Editor displays all of the records held by a single alternative. These records contain the values that are active when a scenario referencing this alternative is active. They allow you to view all of the changes that you have made for a single alternative. They also allow you to eliminate changes that you no longer need.

There is one editor for each alternative type. Each type of editor works similarly and allows you to make changes to a different aspect of your system. The first column contains check boxes, which indicate the records that have been changed in this alternative.

If the check box is selected, the record on that line has been modified and the data is local, or specific, to this alternative.

If the check box is cleared, it means that the record on that line is inherited from its higher-level parent alternative. Inherited records are dynamic. If the record is changed in the parent, the change is reflected in the child. The records on these rows reflect the corresponding values in the alternative's parent.
Note: As you make changes to records, the check box automatically becomes checked. If you want to reset a record to its parent's values, clear the corresponding check box.

Many columns support Global Editing (see Globally Editing Data), allowing you to change all values in a single column. Right-click a column header to access the Global Edit option.

The check box column is disabled when you edit a base alternative.

6.4.3 Base and Child Alternatives

There are two kinds of alternatives: Base alternatives and Child alternatives. Base alternatives contain local data for all elements in your system. Child alternatives inherit data from base alternatives, or even other child alternatives, and contain data for one or more elements in your system. The data within an alternative consists of data inherited from its parent and the data altered specifically by you (local data).

Remember that all data inherited from the base alternative are changed when the base alternative changes. Only local data specific to a child alternative remain unchanged.

6.4.4 Creating Alternatives

New alternatives are created in the Alternative Manager dialog box. A new alternative can be a Base scenario or a Child scenario. Each alternative type contains a Base alternative in the Alternative Manager tree view.
To create a new Alternative

1. Select Analysis > Alternatives to open the Alternative Manager, or click .
2. To create a new Base alternative, select the type of alternative you want to create, then click the New button.
3. To create a new Child alternative, right-click the Base alternative from which the child will be derived, then select New > Child Alternative from the menu.
4. Double-click the new alternative to edit its properties.
5. Click Close when finished.

6.4.5 Editing Alternatives

You edit the properties of an alternative in its own alternative editor. The first column in an alternative editor contains check boxes, which indicate the records that have been changed in this alternative.

- If the box is checked, the record on that line has been modified and the data is local, or specific, to this alternative.
- If the box is not checked, it means that the record on that line is inherited from its higher-level parent alternative. Inherited records are dynamic. If the record is changed in the parent, the change is reflected in the child. The records on these rows reflect the corresponding values in the alternative’s parent.

To edit an existing alternative, you can use one of two methods:

- Double-click the alternative to be edited in the Alternative Manager or

- Select the alternative to be edited in the Alternative Manager and click Edit

In either case, the Alternative Editor dialog box for the specified alternative opens, allowing you to view and define settings as desired.
6.4.6

Active Topology Alternative

The Active Topology Alternative allows you to temporarily remove areas of the network from the current analysis. This is useful for comparing the effect of proposed construction and to gauge the effectiveness of redundancy that may be present in the system.

For each tab, the same setup applies—the tables are divided into four columns. The first column displays whether the data is Base or Inherited, the second column is the element ID, the third column is the element Label, and the fourth column allows you to choose whether or not the corresponding element is Active in the current alternative.

To make an element Inactive in the current alternative, clear the check box in the **Is Active?** column that corresponds to that element’s Label.

Creating an Active Topology Child Alternative

When creating an active topology child alternative, you may notice that the elements added to the child scenario become available in your model when the base scenario is the current scenario.
To create an active topology alternative so that the elements added to the child scenario do not show up as part of the base scenario

1. Create a new StormCAD V8i project.
2. Open the Property Editor.
3. Open the Scenario Manager and make sure the Base scenario is current (active).
4. Create your model by adding elements in the drawing pane.
5. Create a new child scenario and a new child active topology alternative:
   a. In the Scenario Manager, click the New button and select Child Scenario from the submenu.
   b. The new Child Scenario is created and can be renamed.
   c. In the Alternatives Manager, open Active Topology, select the Base Active Topology, right-click to select New, then Child Alternative.
   d. Rename the new Child Alternative.
6. In the Scenario Manager, select the new child scenario then click Make Current to make the child scenario the current (active) scenario.
7. Add new elements to your model. These elements will be active only in the new child alternative.
8. To verify that this worked:
   a. In the Scenario Manager, select the base scenario then click Make Current to make the base scenario the current (active) scenario. The new elements are shown as inactive (they are grayed out in the drawing pane).
   b. In the Scenario Manager, select the new child scenario then click Make Current to make the child scenario the current (active) scenario. The new elements are shown as active.

Note: If you add new elements in the base scenario, they will show up in the child scenario.

6.4.7 Physical Alternative

Each type of network element has a specific set of physical properties that are stored in a physical properties alternative, as listed below:

Physical Alternative for Conduits
Physical Alternative for Manholes
Physical Alternative for Catch Basins
Physical Alternative for Transitions

Physical Alternative for Outfalls

Physical Alternative for Conduits

The physical alternative editor for conduits is used to create various data sets for the physical characteristics of conduits. The following columns are available:

**ID**: Displays the unique identifier for each element in the alternative.

**Label**: Displays the label for each element in the alternative.

**Has User Defined Length?**: Lets you specify whether the channel has a user-defined or schematic length.

**Length (User Defined)**: Lets you define the length of each channel in the alternative that has a user—defined length.

**Material**: Lets you enter the name of the material used. Alternatively, clicking the Ellipsis (...) button opens the Material Engineering Library, allowing you to select a pre-defined material. If a pre-defined material is chosen, the roughness value will change accordingly.

**Manning's n**: Lets you define the Manning's roughness value for the associated conduits. This attribute is only available when Manning's is chosen as the Hydraulic Analysis Friction Method on the Project tab of the project Options (Tools > Options).

**Darcy-Weisbach e**: Lets you define the Darcy-Weisbach roughness value of each gutter in the alternative. This attribute is only available when Darcy-Weisbach is chosen as the Hydraulic Analysis Friction Method on the Project tab of the project Options (Tools > Options).

**Hazen-Williams C**: Lets you define the Hazen-Williams roughness value of each gutter in the alternative. This attribute is only available when Hazen-Williams is chosen as the Hydraulic Analysis Friction Method on the Project tab of the project Options (Tools > Options).

**Kutter's n**: Lets you define the Kutter's roughness value of each gutter in the alternative. This attribute is only available when Kutters is chosen as the Hydraulic Analysis Friction Method on the Project tab of the project Options (Tools > Options).

**Set Invert to Upstream?**: Lets you automatically set the upstream pipe invert to the elevation of the upstream node.

**Invert (Upstream)**: Lets you define the upstream pipe invert.
**Set Invert to Downstream?**: Lets you automatically set the downstream pipe invert to the elevation of the downstream node.

**Invert (Downstream)**: Lets you define the downstream pipe invert.

**Number of Barrels**: Lets you specify the number of hydraulically identical conduit barrels that make up the conduit.

**Use Local Conduit Description?**: When this box is checked, you can define your own conduit description for the associated conduit. See the Conduit Description Attribute topic for more details.

**Conduit Description**: Displays the Conduit Description. The Conduit Description field is a special field which can automatically consolidate several conduit properties into one field. For more information, see the Conduit Description Attribute topic.

**Has User Defined Bend Angle?**: When this box is checked, you can define a bend angle for the conduit in the Bend Angle (User Defined) field.

**Bend Angle (User Defined)**: Lets you specify a bend angle for the associated conduit. This field is only available when the Has User Defined Bend Angle? box is checked.

**Conduit Type**: Allows you to specify whether the conduit is a User Defined or Catalog Conduit. If User Defined is selected here, any of the conduit shapes will be available. If Catalog Conduit is selected, only those shapes defined in the Conduit Catalog will be available. See Conduit Catalog Dialog Box for more details.

**Conduit Shape**: Allows you to select the shape of the conduit. The options available here will vary depending on the Conduit Type you have chosen. Your selection here will determine which dimension attributes will be available. Click the ellipsis button to access the Conduit Catalog Dialog Box.

**Rise**: Lets you define the rise (height) of the associated conduit.

**Span**: Lets you define the span (width) of the associated conduit.

**Diameter**: Lets you define the diameter of the associated conduits. This column is only available for circular and virtual conduits.

**Section Size**: Allows you to select from the section sizes that are available for the selected Conduit Shape. This field is only available for conduits whose Conduit Type is Catalog Conduit.

**Left Bank Station**: Allows you to select which of the station points defined in the Irregular Channel Section dialog should be defined as the Left bank.

**Right Bank Station**: Allows you to select which of the station points defined in the Irregular Channel Section dialog should be defined as the Right bank.
**Channel Weighting Method:** Allows you to select the weighting roughness method used for the associated open irregular channel conduit.

**Irregular Channel Section:** Allows you to access the Irregular Channel dialog, where you can define the cross sectional station vs. depth points for the associated irregular channel.

**Bottom Width:** Lets you define the base width of the associated conduits. This column is only available for conduits that have a Trapezoidal or Virtual Conduit Shape.

**Right Side Slope:** Lets you define the right side slope of the associated conduits. This column is only available for conduits that have a Trapezoidal or Virtual Conduit Shape.

**Left Side Slope:** Lets you define the left side slope of the associated conduits. This column is only available for conduits that have a Trapezoidal or Virtual Conduit Shape.

**Is Diversion Link?:** When this box is checked, the flow into the associated conduit is determined based on a rating curve, which is defined in the Diversion Rating Curve dialog.

**Diversion Rating Curve:** Opens the Diversion Rating Curve dialog, allowing you to define the rating curve using Upstream Flow vs. Diverted Flow points. This field is only available when Is Diversion Link? has been checked.

**Roughness Type:** Allows you to select the method by which roughness data is applied to the conduit.

**Left Bank Manning's n:** Lets you specify the Manning's roughness value for the left bank of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Channel Manning's n:** Lets you specify the Manning's roughness value for the channel of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Right Bank Manning's n:** Lets you specify the Manning's roughness value for the right bank of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Left Bank C:** Lets you specify the Hazen-Williams roughness value for the left bank of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.
Alternatives

**Channel C**: Lets you specify the Hazen-Williams roughness value for the channel of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Right Bank C**: Lets you specify the Hazen-Williams roughness value for the right bank of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Left Bank C**: Lets you specify the Darcy-Weisbach roughness value for the left bank of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Channel e**: Lets you specify the Darcy-Weisbach roughness value for the channel of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Right Bank e**: Lets you specify the Darcy-Weisbach roughness value for the right bank of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Left Bank Kutter's n**: Lets you specify the Kutter's roughness value for the left bank of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Channel Kutter's n**: Lets you specify the Kutter's roughness value for the channel of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Right Bank Kutter's n**: Lets you specify the Kutter's roughness value for the right bank of each conduit in the alternative. This column is only available for conduits that have a Trapezoidal Channel, Virtual, or Irregular Channel Conduit Shape.

**Conduit Description Attribute**

The Conduit Description field is a special field which can automatically consolidate several conduit properties into one field. This makes it easy to set up concise reports that contain conduits with different shapes and properties.

For example, a box shaped conduit with rise and span, as well as a circular shaped conduit with a diameter. In this example, the single conduit description field can be used in place of the Conduit Shape, Diameter, Rise, Span and Material fields. To set the format of the automatically generated Conduit Descriptions, go to **Tools > Options > Project tab** and set the options in the **Conduit Description Options** section.

You can also enter your own local conduit descriptions for a conduit by checking the **Use Local Conduit Description?** attribute.
Physical Alternative for Manholes

The physical alternative editor for manholes is used to create various data sets for the physical characteristics of manholes. The following columns are available:

**ID:** Displays the unique identifier for each element in the alternative.

**Label:** Displays the label for each element in the alternative.

**Bolted Cover:** Indicates that the associated manhole has a bolted cover. If the manhole cover is bolted, then the hydraulic grade line is not reset to the rim elevation at the downstream end of the upstream pipes in the case of a flooding situation (the calculated HGL being higher than the rim elevation).

**Width:** Displays the width of each box manhole in the alternative. **Length:** Displays the length of each box manhole in the alternative. **Diameter:** Displays the diameter of each circular manhole in the alternative.

**Structure Type:** Indicates whether the manhole is circular or box shaped. Clicking a field displays a list box that allows you to switch between the two.

**Set Rim to Ground Elevation:** Enables or disables a data entry shortcut. If the box is checked, the manhole rim elevation is set equal to the ground elevation automatically.

**Elevation (Rim):** Lets you define the top elevation of a manhole structure. This elevation is typically flush with the ground surface. However in some cases, the rim elevation may be slightly below the ground surface elevation (sunk) or slightly above the ground surface elevation (raised).

**Elevation (Ground):** Displays the ground elevation for each node in the alternative.

**Elevation (Invert):** Lets you define the elevation at the bottom of the manhole.

Physical Alternative for Catch Basins

The physical alternative editor for catch basins is used to create various data sets for the physical characteristics of catch basins. The following columns are available:

**ID:** Displays the unique identifier for each element in the alternative.

**Label:** Displays the label for each element in the alternative.

**Inlet:** Allows you to choose a predefined inlet from the Inlets Catalog dialog. Clicking the ellipsis (...) button opens the Inlets Catalog dialog.
**Capture Efficiency**: The amount of total flow, expressed as a percentage, that is captured by the catch basin element.

**Maximum Inflow**: Lets you define the maximum inflow for catch basins of the Maximum Inflow Inlet Type.

**Inlet Type**: Indicates whether the catch basin is a Percent Capture, Catalog Inlet, or Maximum Inflow type. Clicking a field activates a list box allowing you to switch between the three.

**Mannings n (Inlet)**: Enter the roughness factor for the roadway.

**Longitudinal Slope (Inlet)**: Enter the slope of the roadway in the direction of flow.

**Inlet Location**: Allows you to specify whether the inlet is located in sag or on grade.

**Slot Length**: Enter the length of the Slot inlet.

**Clogging Factor**: Enter a value to indicate how much of the grate is clogged. This factor reduces the inlet efficiency by decreasing the effective area of the grate opening.

**Grate Length**: Enter the length of the inlet grate.

**Curb Opening Length**: Enter the length of the clear opening in the face of the curb.

**Gutter Width**: Enter the horizontal width of the gutter.

**Gutter Cross Slope**: Enter the transverse slope of the gutter.

**Depressed Gutter?**: Check this box if the gutter slope differs from the road cross slope. If this box is not checked, the gutter cross slope will be equal to the road cross slope.

**Road Cross Slope**: Enter the transverse slope of the road.

**Side Slope (Ditch)**: Enter the slope of the ditch sides.

**Bottom Width (Ditch)**: Enter the width at the bottom of the ditch.

**Width**: Displays the width of each box catch basin in the alternative.

**Length**: Displays the length of each box catch basin in the alternative.

**Diameter**: Displays the diameter of each circular catch basin in the alternative.
**Structure Type:** Indicates whether the catch basin is circular or box shaped or is a transition node. Clicking a field activates a list box that allows you to switch between the three.

**Set Rim to Ground Elevation:** Enables or disables a data entry shortcut. If the box is checked, the catch basin rim elevation is set equal to the ground elevation automatically.

**Elevation (Rim):** Lets you define the top elevation of a catch basin structure. This elevation is typically flush with the ground surface. In some cases, the rim elevation may be slightly below the ground surface elevation (sunk) or slightly above the ground surface elevation (raised).

**Elevation (Ground):** Clicking the Ellipsis (…) button in this field opens the Surface Depth-Area Curve editor, allowing you to define the surface depth area curve for each element in the alternative that uses the Surface Depth-Area Curve Surface Storage Type.

**Elevation (Invert):** Lets you define the area in which ponding occurs at the currently selected element. It is available only when the Surface Storage Type attribute is set to Ponded Area.

**Physical Alternative for Transitions**

The physical alternative editor for transitionrs is used to create various data sets for the physical characteristics of transitions. The following columns are available:

**ID:** Displays the unique identifier for each transition element in the alternative.

**Label:** Displays the label for each transition element in the alternative.

**Elevation (Top):** Lets you set the top elevation of the transition element.

**Set Top to Ground Elevation?:** When this box is checked, the Elevation (Top) will be set to the value for the Elevation (Ground).

**Transition Length:** Enter the length of the chamber.

**Elevation (Ground):** Lets you set the ground elevation of the transition element.

**Elevation (Invert):** Lets you set the bottom elevation of the transition element.

**Physical Alternative for Outfalls**

The physical alternative editor for outfalls is used to create various data sets for the physical characteristics of outfalls. The following columns are available:

**ID:** Displays the unique identifier for each element in the alternative.
6.4.8 **Headloss Alternatives**

The headloss alternative editor allows you to define headloss properties for manhole, catch basin, and transition elements. The following columns are available for all three element types:

**ID**: Displays the unique identifier for each element in the alternative.

**Label**: Displays the label for each element in the alternative.

**HEC-22 Benching Method**: Select which correction factor for benching will be used. This field is only used when the Headloss Method is set to HEC-22 Energy.

**Absolute Headloss**: Enter the desired value for headloss at the structure. This method ensures that the headloss across the structure will be equal to the value entered here regardless of the actual flows or geometry of the structure. This field is only used when the Headloss Method is set to Absolute.

**Headloss Method**: Select the method to be used to calculate the headlosses through the associated structure. The option chosen here determines which of the parameter fields will become available.

**Flow-Headloss Curve**: Specify the previously defined Flow-Headloss curve to be applied to the node, or create a new one by choosing the <Select...> option to access the Flow-Headloss Curves dialog.

**AASHTO Shaping Method**: Select the correction factor for shaping used in the calculation of headloss using the AASHTO method. This field is only used when the Headloss Method is set to AASHTO.

**Headloss Coefficient (Standard)**: Enter the headloss coefficient for the structure. The headloss across the structure will be equal to this number multiplied by the exit conduit velocity head. This field is only used when the Headloss Method is set to Standard.
**Headloss Coefficient (Upstream):** This field is only used when the Headloss Method is set to Generic. The Generic method computes the structure headloss by multiplying the velocity head of the exit pipe by the user-defined Headloss (Downstream) value and then subtracting the velocity head of the governing upstream pipe multiplied by the value entered in this field.

**Headloss Coefficient (Downstream):** This field is only used when the Headloss Method is set to Generic. The Generic method computes the structure headloss by multiplying the velocity head of the exit pipe by the value entered in this field and then subtracting the velocity head of the governing upstream pipe multiplied by the user-defined Headloss Coefficient (Upstream) value.

### 6.4.9 Boundary Condition Alternatives

The boundary condition alternative allows you to define boundary condition settings for outfall elements. The following columns are available:

**ID:** Displays the unique identifier for each element in the alternative.

**Label:** Displays the label for each element in the alternative.

**Elevation-Flow Curve:** Displays the label of the Elevation-Flow Curve that has been assigned to an outfall that is using the Elevation-Flow curve Boundary Condition Type.

**Elevation (Tailwater):** Lets you enter the user defined tailwater value. This column is only available for elements that use the User Defined Tailwater Boundary Condition Type.

**Boundary Condition Type:** Lets you specify the type of boundary condition to be used at the associated outfall element. The following choices are available:

- **Free Outfall**—For a free outfall control, it is assumed that the downstream discharge conditions do not directly affect the hydraulic response of the structure. This is equivalent to assuming that the downstream TW elevation never rises above the controlling structure outfall invert of the structure.

- **User Defined Tailwater**—This type of boundary condition allows you to directly enter a tailwater value.

- **Elevation Flow Curve**—For this type of boundary condition, an elevation-flow table is specified to simulate at the outfall a channel or outlet structure where flow rate varies over time.

- **Crown**—This condition should be used when the pipe discharges to an outlet where the water surface elevation is equal to the elevation of the top of the pipe.
6.4.10 **Rainfall Runoff Alternative**

The rainfall runoff alternative allows you to define runoff data for catchment, pond, and wet well elements, as listed below:

**Rainfall Runoff Alternative for Global Rainfall**

The rainfall runoff alternative for global rainfall displays information about global storm events in your project. The following fields are available:

- **Alternative**: Displays the label for the alternative that is currently being edited.
- **Global Storm Event**: Lists all of the rainfall curves that have been defined for the current project in the Storm Events dialog box, which is accessible by clicking the **Ellipsis (...)** button.
- **Storm Event Source**: Displays the location of the library file for storm events that are derived from an engineering library entry.
- **Maximum Storm Intensity**: Displays the maximum intensity of the storm as defined by the currently selected storm event.

6.4.11 **Hydrologic Alternatives**

The hydrology alternative allows you to define hydrologic settings for catchments and catch basins. The following columns are available:

**Hydrology Alternative for Catch Basins**

- **ID**: Displays the unique identifier for each element in the alternative.
- **Label**: Displays the label for each element in the alternative.
- **Flow (Additional Carryover)**: Flow (CA or related time) from a gutter flowing to the inlet.

**Hydrology Alternative for Catchments**

- **ID**: Displays the unique identifier for each element in the alternative.
- **Label**: Displays the label for each element in the alternative.
- **Tc Data Collection**: Clicking the **Ellipsis (...)** button in this field opens the Tc Data Collection editor, allowing you to define the Tc data for each catchment in the alternative that uses the SCS Unit Hydrograph Runoff Method.
**Rational C**: Enter the rational coefficient C value.

**Time of Concentration**: Lets you define the time of concentration for each of the catchments in the alternative that use SCS Unit Hydrograph Method. This column is only available for catchments that use the SCS Unit Hydrograph Runoff Method.

**Use Scaled Area?**: When this box is checked, the catchment area is derived from the area of the element in the drawing view in a schematic drawing. When the box is unchecked, the area is user-defined.

**Area**: Lets you define the area of the associated catchments. This column is only available for catchments using the Unit Hydrograph Runoff Method.

**Outflow Node**: Lets you specify the element to which flow from the catchment outfalls.

**Rational Catchment Collection**: Opens the Rational Catchment Collection dialog, allowing you to define the C values for the catchment.

### 6.4.12 Design Alternative

The Design Alternative Editor allows you to edit the pipe, node and inlet constraints governing the design of the system. It also allows you to specify which gravity elements you want designed, and the extent to which you want them designed.

For example, you may want to design a particular pipe. However, you may also want to design the downstream invert elevation to meet a particular velocity, cover, and slope constraint.

The tabbed dialog for each particular type of element follows the same general format. The top of the dialog box contains several fields where the design constraints can be entered. The constraints entered in these fields are applied to every element in the table on the bottom of the dialog, except the elements that are specified to contain local values. This system allows you to rapidly enter the values that govern most of the elements in the table, and then manually override the constraints for those elements that are exceptions to the majority. The following attributes are available in this section:

Pipe diameters, invert elevations, node structures, and inlets can be all designed with the same set of design constraints. You also have the option to adjust these values individually for each pipe or structure.

The Default Design Constraints dialog is divided into the three following tabs:

- **Gravity Pipe**
• Node
• Inlet

Gravity Pipe Tab

The Gravity Pipe tab allows you to enter default constraints to be used for the design of pipes when performing a calculation run in design mode. The dialog is divided into the following sections:

• Default Constraints
• Extended Design

Default Constraints Section

In this section, there is a Velocity tab, a Cover tab, and a Slope tab. You can specify the following default constraints to be used for the design of gravity pipes:

• Velocity Tab: The Velocity tab consists of the following controls:
  – Velocity Constraints Type—When Simple is chosen, a single minimum and maximum Velocity value is selected. When Table is chosen, you can specify multiple Rise vs Velocity (Minimum) vs Velocity (Maximum) points in tabular format.
  – Velocity (Minimum)—Specify the minimum allowable velocity value. This control is only available when the Velocity Constraint Type is set to Simple.
  – Velocity (Maximum)—Specify the maximum allowable velocity value. This control is only available when the Velocity Constraint Type is set to Simple.

• Cover Tab: The Cover tab consists of the following controls:
  – Cover Constraints Type—When Simple is chosen, a single minimum and maximum Cover value is selected. When Table is chosen, you can specify multiple Rise vs Cover (Minimum) vs Cover (Maximum) points in tabular format.
  – Cover (Minimum)—Specify the minimum allowable cover value. This control is only available when the Cover Constraint Type is set to Simple.
  – Cover (Maximum)—Specify the maximum allowable cover value. This control is only available when the Cover Constraint Type is set to Simple.

• Slope Tab: The Slope tab consists of the following controls:
  – Slope Constraints Type—When Simple is chosen, a single minimum and maximum Slope value is selected. When Table is chosen, you can specify multiple Rise vs Slope (Minimum) vs Slope (Maximum) points in tabular format.
– **Slope (Minimum)**– Specify the minimum allowable slope value. This control is only available when the Slope Constraint Type is set to Simple.

– **Slope (Maximum)**– Specify the maximum allowable slope value. This control is only available when the Slope Constraint Type is set to Simple.

**Extended Design Section**

This section lets you specify if the following design parameters are to be used. If they are to be used, you can also specify the associated default value. The Extended Design section is split into three tabs:

- **Part Full Design Tab**: The Part Full Design tab consists of the following controls:
  - **Is Part Full Design?**– When checked, allows you to specify the Percent Full target to be used by the design algorithm.
  - **Percent Full Constraint Type**– Allows you to specify how the Percent Full constraints are defined. When Simple is chosen, a single Percentage Full value is selected. When Table is chosen, you can specify multiple Rise vs Percent Full points in tabular format.
  - **Percentage Full**– Specify the Percent Full value to be used when the Is Part Full Design? box is checked. This control is only available when the Percent Full Constraint Type is set to Simple.

- **Number of Barrels Tab**: The Number of Barrels tab consists of the following controls:
  - **Allow Multiple Barrels?**– When checked, allows the design algorithm to use more than one identical section in parallel, up to the specified Maximum Number of Barrels.
  - **Maximum Number of Barrels**– The maximum number of identical sections allowed to be used in parallel when the Allow Multiple Barrels? box is checked.

- **Section Size Tab**: The Section Size tab consists of the following controls:
  - **Limit Section Size?**– When checked, limits the pipe section height to the specified Maximum Rise value during the design process.
  - **Maximum Rise**– The maximum rise a section height is allowed to be used in the design when the Limit Section Size? box is checked.
**Node Tab**

This tab lets you specify the design constraints to be used by default for all gravity structures when performing calculations in design mode. During an automatic design, the program will adjust the elevations of the pipes adjacent to the structure according to the structure's matching constraints. The two choices for matching are Inverts and Crowns. Additionally, the downstream pipe can be offset from the upstream pipe(s) by a specified amount. This value is called the Matchline Offset. Optionally, the program supports the design of drop structures. In some situations, drop structures can minimize pipe cover depths while maintaining adequate hydraulic performance.

**Inlet Tab**

This tab lets you specify the design constraints to be used for all inlets when performing a calculation run in design mode. During an automatic design, the program will adjust the length of the inlet in order to meet the design constraints.

- For an inlet in sag, the Default In Sag Design Constraints consist of maintaining the gutter spread and water depth under a given value.
- For an inlet on a grade, the Default on Grade Design Constraints consist of ensuring that at least a given percentage of the gutter flow is intercepted.

**Default In Sag Design Constraints Section**

This section lets you specify the design constraints to be used for all inlets located in sag when performing calculations in design mode. During an automatic design, the program will adjust the length of the inlet in order to meet both design constraints:

- **Maximum Spread in Sag**—The maximum allowed spread of water at the inlet, measured from the curb.
- **Maximum Depth in Sag**—The maximum depth of water allowed at the inlet.

**Default On Grade Design Constraints**

This section lets you specify the design constraints to be used for all inlets located on a grade when performing a calculation run in design mode. During an automatic design, the program will adjust the length of the inlet in order to meet a minimum inlet efficiency, or percentage of gutter flow intercepted by the inlet, that you specify.

The lower section of the dialog allows you to specify local data. In order to specify that an element contain local data, place a check mark in the column labeled Specify Local Constraints on the same row as the element. When the check mark appears, the yellow columns that display the global design constraints defined in the top of the dialog will turn white on the row of the element that is being modified. This means
that you can now change the design constraint values for this particular element. If you click the check mark again, the opposite happens. The columns containing the constraints turn yellow and revert to the global values entered in the top of the dialog. The following tabs are available:

Additional check boxes are available to specify exactly what you want the software to design:

**For Conduits**

- **Design Conduit?**: Check this box if you want the program to design the conduit based on the constraints you define.
- **Design Start Invert?**: Check this box if you want the program to design the upstream invert based on the constraints you define.
- **Design Stop Invert?**: Specify if the program should design the downstream invert based on the constraints given in the model.
- **Specify Local Pipe Constraint?**: If this box is checked, you can enter local values to replace the default values. If it is not checked, the program will automatically use the default constraints.

**For Nodes**

- **Design Structure Elevation?**: Check this box if you want to allow the structure's sump elevation to be adjusted during an automatic design. When this box is checked, the Desired Sump Depth field becomes editable.
- **Desired Sump Depth**: This field becomes editable when the Design Structure Elevation? box is checked. The sump depth is the distance below the lowest pipe invert.
- **Local Pipe Matching Constraints?**: If this box is checked, you can enter local values to replace the default values. If it is not checked, the program will automatically use the default constraints.

**For Inlets**

**Design Inlet Opening?**: Check this box if you want to allow the Inlet Opening to be adjusted during the automatic design.

**Specify Local Inlet Constraints?**: If this box is checked, you can enter local values to replace the default values. If it is not checked, the program will automatically use the default constraints.
For inlets in sag, the inlet length selected in an automatic design will be the smallest length that will generate a spread and a depth at the curb less than the maximums specified. For inlets on grade, the inlet length selected is the smallest length that will generate an inlet efficiency larger than the minimum specified.

6.4.13 System Flows Alternatives

The system flows alternative allows you to specify additional and known flow, along with other contributing sources of water that are not part of the model. System flows

**ID:** Displays the unique identifier for each element in the alternative.

**Label:** Displays the label for each element in the alternative.

**Flow (Known):** Used to identify a known flow into the piped system.

**Flow (Additional):** Flow added directly to the piping system at the catch basin.

**External Tc:** The time of concentration for an external source not included in the model.

**External CA:** The rational contributing area of an external source not included in the model.

6.4.14 User Data Extensions Alternative

The User Data Alternative allows you to edit the data defined in the User Data Extension command for each of the network element types. The User Data Alternative editor contains a tab for each type of network element.

6.4.15 Capital Cost Alternative

StormCAD 5.6 had a simple capital cost estimate tool. There is currently no equivalent tool in StormCAD V8i, but if you import a StormCAD 5.6 model into StormCAD V8i the capital cost data is preserved and a Capital Cost alternative will be visible.

6.5 Calculation Options

Each scenario is associated with a set of calculation options. Calculation options are stored in a discrete Calculation Options Profile.
For more information on Calculation Options Profiles, see Creating Calculation Option Sets and Calculation Option Set Attributes.

6.6 Scenario Comparison

The scenario comparison tool enables you to compare input values between any two scenarios to identify differences quickly. While Bentley StormCAD V8i users have previously had the capability to open a child scenario or alternative and compare it with its parent, this tool greatly extends that capability in that you can compare any two scenarios or alternatives (not necessarily parent-child) and very easily detect differences.

The scenario comparison tool can be started by picking Tools > Scenario Comparison or by selecting the Scenario Comparison button from the toolbar . If the button is not visible, it can be added using the "Add or Remove Buttons" drop down from the Tools toolbar (see Customizing the Toolbars on page 2-41).

On first opening the scenario comparison tool, the dialog below opens which gives an overview of the steps involved in using the tool. Pick the New button (leftmost).

![Scenario Comparison dialog](image)
This opens a dialog which allows you to select which two scenarios will be compared.

![Scenario Comparison](image)

The scenario manager button next to each selection gives you the ability to see the tree view of scenarios. Chose OK to begin the scenario comparison tool. This initially displays a list of alternatives and calculation options, with the ones with identical properties displayed with a yellow background and those with different properties displayed with a pink background. The background color can be changed from pink to any other color by selecting the sixth button from the left and then selecting the desired color.

The dialog below shows that the Rainfall Runoff alternative is different between the scenarios. There is a second tab for Calculation Options which shows if the calculation options are different between scenarios.

![Scenario Comparison Comparison](image)

This display can also be copied to the clipboard using the Copy button.
The alternatives that have differences are also shown in the left pane with a red mark as opposed to the green check indicating that there are no differences.

```
System Design Using 100-yr Storm vs. 2-Year Storm

Alternatives
- Active Topology
- Physical
- Headloss
- Boundary Condition
- Rainfall Runoff
    - Differences - 4/5/2010 8:38 AM
- Hydrologic
- Design
- System Flows
- User Data Extensions

Calculation Options
- Gradually Varied Flow Solver
    - Differences - 4/5/2010 8:38 AM
```

To obtain more detailed information on differences, highlight one of the alternatives and select the green and white Compute arrow at the top of pane (fourth button).

This initially returns a summary of the comparison which indicates the time when the comparison was run, which scenarios were involved and number of elements and attributes for which there were differences.
By picking "Differences" in the left pane for the alternative of interest, you can view the differences. In this display, only the elements and properties that are different are shown with a pink background. In the example below, only the Global Storm Event has differences. There are separate tables for each element type that had differences.

Using the buttons on top of the right pane, when Differences is selected, you can create a selection set of the elements with differences or highlight those elements in the drawing. This is very useful for finding elements with differences in a large model.

### 6.6.1 Scenario Comparison Options Dialog Box

This dialog box allows you to select the color used to highlight differences between the scenarios being compared in the Scenario Comparison tool.

To choose another color, click the ellipsis button, select the new color from the palette, and click OK.
### 6.6.2 Scenario Comparison Collection Dialog Box

Some of the Differences types (such as load) may include collections of data (multiple loads within a single load Collection). By clicking the ellipsis button next to one of these collections you can open this dialog, which displays a table that breaks down the collection by the individual pieces of data.

<table>
<thead>
<tr>
<th>Demand Collection</th>
<th>Demand (Base) Year 2000 Conditions (gpm)</th>
<th>Demand (Base) Year 2020 Conditions (gpm)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>36.40</td>
<td>47.32</td>
</tr>
</tbody>
</table>
Scenario Comparison
Calculating Your Model

Click one of the following links to learn how to calculate your model and work with StormCAD V8i calculation features:

- Calculation Options Manager
- Creating Calculation Option Sets
- Calculation Executive Summary Dialog Box
- Calculation Detailed Summary Dialog Box
- User Notifications

### 7.1 Calculation Options Manager

You create calculation option sets in the Calculation Options Manager. The Calculation Options Manager consists of a list pane that displays all of the calculation option sets associated with the current project, and a toolbar that contains some common commands.

To display the Calculation Options Manager, select Analysis > Calculation Options.

The Calculation Options manager allows you to create option sets that contain various calculation settings. The dialog box contains a list pane that displays all of the option sets currently contained in the project, along with a toolbar.

The toolbar contains the following buttons:

- ![New](image) **New**: Creates a new calculation option set. Define the attributes for the set in the Property Editor.

- ![Duplicate](image) **Duplicate**: Creates a copy of the currently selected calculation option set.
Creating Calculation Option Sets

Delete: Deletes the currently highlighted option set.

Rename: Lets you rename the currently highlighted calculation option set.

Help: Displays online help for the Calculation Options manager.

If the Property Editor is open, highlighting a option set in the list causes the settings that make up the set appear there. If the Property Editor is not open, you can display the settings that make up the set by highlighting the desired set and clicking the Properties button in the Calculation Options Manager.

7.2 Creating Calculation Option Sets

Calculation option sets contain attributes that define how your model is calculated in StormCAD V8i. You create calculation option sets in the Calculation Options Manager. You can create several calculation option sets with different attributes depending on the requirements of your project.

StormCAD V8i contains a default calculation option set called "Base Calculation Options." If you do not create additional calculation option sets, StormCAD V8i will use this default set whenever you calculate your model.

Creating a Calculation Option Set

1. Open the Calculation Options Manager by selecting Analysis > Calculation Options.
2. Click the New button. A new set appears in the list with a default name.
3. Type a new name for the set.
4. Double-click the new set to display its attributes in the Property Editor. Edit the attributes as required.

Editing a Calculation Option Set

You edit the attributes of a calculation option set in the Property Editor.

If you select a calculation option set while the Property Editor is open, the attributes for that set appear there. If the Property Editor is not open, you can display the attributes of the calculation option set by double-clicking the set in the Calculation Options Manager.
Deleting a Calculation Option Set

1. Open the Calculation Options Manager by selecting **Analysis > Calculation Options**.
2. Select the set you want to delete.
3. Press the Delete key, click the Delete button in the Calculation Options Manager, or right-click the set and select **Delete** from the shortcut menu.

Renaming a Calculation Option Set

1. Open the Calculation Options Manager by selecting **Analysis > Calculation Options**.
2. Select the set you want to rename.
3. Click the Rename button or right-click and select **Rename** from the shortcut menu.
4. Type a new name for the set, then press **Enter**.

7.2.1 **Calculation Option Set Attributes**

A Calculation Options Set contains the information described in the following table.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Label</td>
<td>Lets you specify a name for the options set.</td>
</tr>
<tr>
<td>Notes</td>
<td>Lets you enter descriptive text to be associated with the current calculation option set.</td>
</tr>
<tr>
<td>Calculation Type</td>
<td>Allows you to choose between an Analysis or Design calculation type.</td>
</tr>
<tr>
<td><strong>AASHTO</strong></td>
<td></td>
</tr>
<tr>
<td>Bend Angle vs. Bend Loss Curve</td>
<td>Opens the Bend Angle vs Bend Loss Curve dialog, allowing you to modify the default curve.</td>
</tr>
<tr>
<td>Expansion, Ke</td>
<td>Adjustment coefficient used in AASHTO equation to account for expansion of the flow on the exit from incoming pipe.</td>
</tr>
</tbody>
</table>
### Table 7-1: Calculation Option Set Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contraction, Kc</td>
<td>Adjustment coefficient used in the AASHTO equation to account for contraction of the flow on the entrance in the outlet pipe.</td>
</tr>
<tr>
<td>Shaping Adjustment, Cs</td>
<td>Adjustment coefficient used in the AASHTO equation for junction headloss calculation to account for partial diameter inlet shaping (equivalent to Half and Full in HEC-22). If inlet shaping is used then the headloss is decreased by this factor (50% default).</td>
</tr>
<tr>
<td>Non Piped Flow Adjustment, Cn</td>
<td>If non-piped flow accounts for 10% or more of the total structure outflow, a correction factor is applied to the total loss. By default, this value is a 30% increase in headloss (a factor of 1.3) as documented in the AASHTO manual, but can be changed by the user.</td>
</tr>
<tr>
<td>Maximum Network Traversals</td>
<td>This is the maximum number of iterations that will be performed to achieve the closest approximation of the desired network results.</td>
</tr>
<tr>
<td>Flow Convergence Test</td>
<td>This value is taken as the maximum relative change in discharge occurring at the system outlet between two successive network solutions. In rational hydrology, system discharge is a function of travel time and hydraulics through the system. Therefore, it is necessary to iterate until the system balances, or a maximum number of trials has occurred.</td>
</tr>
</tbody>
</table>

#### Analysis

This is the maximum number of iterations that will be performed to achieve the closest approximation of the desired network results.

#### Generic Structure Loss

This value is taken as the maximum relative change in discharge occurring at the system outlet between two successive network solutions. In rational hydrology, system discharge is a function of travel time and hydraulics through the system. Therefore, it is necessary to iterate until the system balances, or a maximum number of trials has occurred.
### Table 7-1: Calculation Option Set Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Governing Upstream Pipe Selection Method</td>
<td>On this tab, you can change the methodology for selecting the upstream pipe when computing the headloss for a structure using the Generic Headloss Method. The three methodologies are described below.</td>
</tr>
<tr>
<td></td>
<td>• Pipe With Maximum QV – If this item is selected, the program will use the non-plunging upstream pipe with the largest flow times velocity to calculate the upstream velocity head used in the generic headloss equation.</td>
</tr>
<tr>
<td></td>
<td>• Pipe With Minimum Bend Angle - If this item is selected, the program will use the upstream pipe with the smallest bend angle to calculate the upstream velocity head used in the generic headloss equation. The methodology should be used when you want to assume that the upstream pipe most closely aligned with the downstream pipe is the one that is the most hydraulically significant.</td>
</tr>
<tr>
<td></td>
<td>• Pipe With Maximum Velocity Head – If this item is selected, the program will use the nonplunging upstream pipe with the largest velocity head to calculate the upstream velocity head used in the generic headloss equation. Note that if this method is used, pipes with very small flows may be selected as the governing pipe, even though they are not hydraulically significant.</td>
</tr>
<tr>
<td></td>
<td>The methodology that is selected here will be used for all structures that employ the generic headloss method.</td>
</tr>
</tbody>
</table>

### HEC-22

| Elevations Considered Equal Within (m)        | The maximum elevation distance that pipes entering a node can be separated by and still be considered to be at the same elevation.                                                                                                 |
| Consider Non-Piped Plunging Flow               | If this value is set to True, plunging correction factor for non-piped flow will be applied during the calculation.                                                                                                           |
| Flat Submerged                                 | Benching correction coefficient used for a flat submerged transition structure.                                                                                                                                              |
| Flat Unsubmerged                               | Benching correction coefficient used for a flat unsubmerged transition structure.                                                                                                                                            |
### Table 7-1: Calculation Option Set Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Depressed Submerged</td>
<td>Benching correction coefficient used for a depressed submerged transition structure.</td>
</tr>
<tr>
<td>Depressed Unsubmerged</td>
<td>Benching correction coefficient used for a depressed unsubmerged transition structure.</td>
</tr>
<tr>
<td>Half Bench Submerged</td>
<td>Benching correction coefficient used for a half bench submerged transition structure.</td>
</tr>
<tr>
<td>Half Bench Unsubmerged</td>
<td>Benching correction coefficient used for a half bench unsubmerged transition structure.</td>
</tr>
<tr>
<td>Full Bench Submerged</td>
<td>Benching correction coefficient used for a full bench submerged transition structure.</td>
</tr>
<tr>
<td>Full Bench Unsubmerged</td>
<td>Benching correction coefficient used for a full bench unsubmerged transition structure.</td>
</tr>
</tbody>
</table>

### Hydraulics

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flow Profile Method</td>
<td>Allows you to choose between a backwater and capacity analysis flow profile method.</td>
</tr>
<tr>
<td>Number of Flow Profile Steps</td>
<td>The gradually varied flow profile divides each pipe into internal segments prior to calculation of the hydraulic grade. The default value of profile steps is five, and it is recommended that the value entered here be at least five for accuracy. Increasing this number will increase the accuracy of the hydraulic grade calculation, but will increase the calculation time.</td>
</tr>
<tr>
<td>Hydraulic Grade Convergence Test (m)</td>
<td>The value entered here is taken as the maximum absolute change between two successive iterations of hydraulic grade at any junction or inlet in the system. For a given discharge, the upstream propagation of headlosses through pipes will continue until two successive calculations change by an absolute difference of less than this test value. The Hydraulic Grade Convergence Test value is used in the standard step gradually varied flow profiling algorithm. The calculations is assumed to converge to the solution when the two successive depth iterations are within this absolute test value.</td>
</tr>
</tbody>
</table>
### Table 7-1: Calculation Option Set Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Velocity Method</td>
<td>This section allows you to pick the method used to calculate the average travel time velocity. The following four options are available:</td>
</tr>
<tr>
<td></td>
<td>• Actual Uniform Flow Velocity</td>
</tr>
<tr>
<td></td>
<td>• Full Flow Velocity</td>
</tr>
<tr>
<td></td>
<td>• Simple Average Velocity</td>
</tr>
<tr>
<td></td>
<td>• Weighted Average Velocity</td>
</tr>
<tr>
<td>Minimum Structure Headloss (m)</td>
<td>This section allows you to specify a minimum structure headloss. If the system calculates a structure headloss that is lower than this value, the value specified in the Minimum Headloss field will be used. This option applies to all structure headloss methods except for the Absolute Method. Absolute headlosses will not be overridden, even if they are less than the value specified in this option.</td>
</tr>
<tr>
<td>Structure Loss Mode</td>
<td>Choose either Hydraulic Grade or Energy Grade as the basis for the hydraulic calculations.</td>
</tr>
<tr>
<td>Liquid Label</td>
<td>Label which describes the type of liquid used in the simulation. This field is only available when the Friction Method is set to Darcy-Weisbach on the Project tab of the project Options.</td>
</tr>
<tr>
<td>Liquid Kinematic Viscosity (ft²/s)</td>
<td>The ratio of the liquid’s dynamic, or absolute, viscosity to its mass density. This field is only available when the Friction Method is set to Darcy-Weisbach on the Project tab of the project Options.</td>
</tr>
</tbody>
</table>

#### Hydrology

- **Minimum Time of Concentration (min)**: The Minimum Time of Concentration. Time of concentration is defined as the amount of time it takes for water to travel from the farthest point in the watershed to an inlet.

#### Inlets

- **Neglect Side Flow?**: Allows you to choose whether to neglect side flow. If you select True for this option, only frontal views will be included in the inlet calculations.
### Table 7-1: Calculation Option Set Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active Components for Combination Inlets In Sag</td>
<td>This section gives you the choice of whether to use both curb and grate openings or the grate or curb opening only for combination inlets in sag.</td>
</tr>
<tr>
<td>Active Components for Combination Inlets On Grade</td>
<td>This section gives you the choice of whether to use both curb and grate openings or the grate or curb opening only for combination inlets on grade.</td>
</tr>
<tr>
<td>Grating Parameters (UK)</td>
<td>Click the ellipsis button to open the Grating Parameters (UK) dialog, which allows you to define the grating parameters for the various grate types.</td>
</tr>
<tr>
<td>Ignore Travel Time in Carrier Pipes?</td>
<td>When this property is set to True, StormCAD will ignore the travel time in carrier pipes (pipes with no subcatchment connected to their upstream node) when computing system time at the node immediately downstream of the carrier pipe.&quot;</td>
</tr>
<tr>
<td>Correct for Partial Area Effects?</td>
<td>If False, StormCAD will always adopt the largest system time from all incoming flows. If True, when two or more rational flows enter a single node, StormCAD will adopt the system time that produces the largest rational flow. A larger 'partial area' flow will be carried downstream until the 'total area' flows exceeds it.</td>
</tr>
<tr>
<td>Bend Angle vs Km Collection</td>
<td>Click the ellipsis button to open the Grating Parameters (UK) dialog, which allows you to define the head loss coefficient (Km) as it varies by bend angle. This property is used in the UK Standard method.</td>
</tr>
<tr>
<td>Modified Rational Method (UK)</td>
<td></td>
</tr>
<tr>
<td>Runoff Rotuing Coefficient</td>
<td>The routing coefficient used in the Modified Rational Method (UK) This factor will apply to all catchments using the Modified Rational Method (UK) to compute runoff.</td>
</tr>
</tbody>
</table>

### Bend Angle vs. Bend Loss Curve Dialog Box

This dialog allows you to define a curve of the bend angles and associated bend loss coefficients (Kb) that are used in the calculation of headloss in the AASHTO headloss method.
Click the New button to add a row to the table. Click the Delete button to remove the currently selected row. Click the Report button to generate a preformatted report containing the data that makes up the curve.

For each point in the curve, specify the Bend Loss Coefficient associated with the specified Bend Angle.

<table>
<thead>
<tr>
<th>Bend Angle (degrees)</th>
<th>Bend Loss Coefficient, Kb</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>15.00</td>
<td>0.190</td>
</tr>
<tr>
<td>30.00</td>
<td>0.350</td>
</tr>
<tr>
<td>45.00</td>
<td>0.470</td>
</tr>
<tr>
<td>60.00</td>
<td>0.560</td>
</tr>
<tr>
<td>75.00</td>
<td>0.640</td>
</tr>
<tr>
<td>90.00</td>
<td>0.700</td>
</tr>
</tbody>
</table>

**Grating Parameters Dialog Box**

This dialog box allows you to enter grating parameters for the various grating types.

The dialog box contains the Grating Type vs. Grating Parameter table, along with the following controls:

- **New**: This button creates a new row in the Grating Type vs. Grating Parameter table.

- **Delete**: This button deletes the currently highlighted row from the Grating Type vs. Grating Parameter table.
Report: Opens a print preview window containing a report that details the input data for this dialog box.

The Grating Type vs Grating Parameter allows you to define the parameters to use for each grating type (P, Q, R, S, and T).

Bend Angle vs Km Collection Dialog Box

This dialog box allows you to enter bend angle vs. Km coefficient data, which is used in the UK Standard method.

The dialog box contains the Bend Angle vs. Bend Loss Coefficient values, along with the following controls:

New: This button creates a new row in the bend angle vs. bend loss coefficient table.

Delete: This button deletes the currently highlighted row from the bend angle vs. bend loss coefficient table.

Report: Opens a print preview window containing a report that details the input data for this dialog box.

7.3 Calculation Executive Summary Dialog Box

The Calculation Executive Summary dialog box opens automatically after you compute a model. This dialog box reports a summary of the calculations performed on your model. You can also see this report by clicking Analysis > Calculation Summary.

Click Details... for more information about the calculation (see Calculation Detailed Summary Dialog Box), Messages... to open the User Notifications dialog to view any calculation warnings or errors (User Notifications Manager), Report to open the report viewer, or Close to close the dialog box.

The Executive Summary dialog box displays the following information:

Label: Displays the name of the currently selected scenario.
Rainfall Alternative Label: Displays the currently selected rainfall alternative.

Global Storm Event: Displays the current global storm event.

Return Event: Displays the recurrence period of the global storm event.

7.4 Calculation Detailed Summary Dialog Box

The Calculation Detailed Summary dialog box provides a detailed reports of the calculations performed on your model. You can open this dialog box by calculating your model and clicking Detailed Summary in the Calculation Executive Summary dialog box. You can also see this report by clicking Analysis > Calculation Summary > Details.

Click the tabs in the Calculation Detailed Summary dialog box to review the details of the report:

- Calculation Options Tab
- Conduit Summary Tab
- Catchment Summary Tab
- Node Summary Tab
- Inlet Summary Tab

7.4.1 Calculation Options Tab

This tab displays the current settings in the Property Editor for calculation options. To change this, click Analysis > Calculation Options and change the settings in the Property Editor.

The Calculation Options tab displays the following information:

- Maximum Network Traversals: This is the maximum number of iterations that will be performed to achieve the closest approximation of the desired network results.

- Flow Convergence Test: This value is taken as the maximum relative change in discharge occurring at the system outlet between two successive network solutions. In rational hydrology, system discharge is a function of travel time and hydraulics through the system. Therefore, it is necessary to iterate until the system balances, or a maximum number of trials has occurred.
**Calculation Detailed Summary Dialog Box**

**Neglect Side Flow?:** Allows you to choose whether to neglect side flow. If you select True for this option, only frontal views will be included in the inlet calculations.

**Neglect Gutter Slope for Side Flow?:** If this option is True, StormCAD will neglect the gutter cross slope and always use the road cross slope for side flow calculations. If this option is False, and the grate width is less than the gutter width, StormCAD will use the gutter slope for side flow calculations. (Note: StormCAD 5.6 and earlier always used the road cross slope for side flow calculations).

**Active Components for Combination Inlets In Sag:** This section gives you the choice of whether to use both curb and grate openings or the grate or curb opening only for combination inlets in sag.

**Active Components for Combination Inlets on Grade:** This section gives you the choice of whether to use both curb and grate openings or the grate or curb opening only for combination inlets on grade.

**Flow Profile Method:** Allows you to choose between a backwater and capacity analysis flow profile method.

**Number of Flow Profile Steps:** The gradually varied flow profile divides each pipe into internal segments prior to calculation of the hydraulic grade. The default value of profile steps is five, and it is recommended that the value entered here be at least five for accuracy. Increasing this number will increase the accuracy of the hydraulic grade calculation, but will increase the calculation time.

**Hydraulic Grade Convergence Test:** The value entered here is taken as the maximum absolute change between two successive iterations of hydraulic grade at any junction or inlet in the system. For a given discharge, the upstream propagation of headlosses through pipes will continue until two successive calculations change by an absolute difference of less than this test value.

**Hydraulic Grade Convergence Test:** The value is used in the standard step gradually varied flow profiling algorithm. The calculations is assumed to converge to the solution when the two successive depth iterations are within this absolute test value.

**Average Velocity Method:** This section allows you to pick the method used to calculate the average travel time velocity. The following four options are available:

- Actual Uniform Flow Velocity
- Full Flow Velocity
- Simple Average Velocity
- Weighted Average Velocity
**Minimum Structure Headloss:** This section allows you to specify a minimum structure headloss. If the system calculates a structure headloss that is lower than this value, the value specified in the Minimum Headloss field will be used.

This option applies to all structure headloss methods except for the Absolute Method. Absolute headlosses will not be overridden, even if they are less than the value specified in this option.

**Minimum Time of Concentration:** The Minimum Time of Concentration. Time of concentration is defined as the amount of time it takes for water to travel from the farthest point in the watershed to an inlet.

### 7.4.2 Catchment Summary Tab

This tab displays a table of data about catchments in your model. You cannot modify the table, it is read-only. To edit a catchment, select it in the Drawing Pane and edit its attributes in the Property Editor.

The Catchment Summary tab displays the following information:

- **Label:** Displays the label of each catchment in your model.
- **Area:** Displays the catchment size.
- **Time of Concentration:** Displays the time of concentration for the catchment.
- **Rational C:** Displays the rational C value for the catchment.
- **Catchment CA:** Displays the CA value for the catchment.
- **Catchment Intensity:** Displays the intensity of the rainfall at the catchment.
- **Catchment Rational Flow:** Displays the amount of rational flow at the catchment.

### 7.4.3 Conduit Summary Tab

This tab displays a table of calculations for conduits in your model. You cannot modify the table, it is read-only. To edit a conduit, select it in the Drawing Pane and edit its attributes in the Property Editor.

The Conduit Summary tab displays the following information:

- **Label:** Displays the label of each element in your model.
**Conduit Description:** Displays the Conduit Description. The Conduit Description field is a special field which can automatically consolidate several conduit properties into one field. For more information, see the Conduit Description Attribute topic.

**Conduit Shape:** Displays the shape of the conduit.

**Branch ID:** Branch identifier for the conduit, determined during engine parsing.

**Subnetwork Outfall:** Most downstream element of the conduit's subnetwork outfall.

**Flow:** Total flow through the conduit during the calculation.

**Velocity (Average):** The average velocity of flow through the conduit over the duration of the run.

**Hydraulic Grade Line (In):** Hydraulic Grade Line at the upstream end of the conduit.

**Hydraulic Grade Line (Out):** Hydraulic Grade Line at the downstream end of the conduit.

**Depth (In):** Depth at the upstream end of the conduit.

**Depth (Out):** Depth at the downstream end of the conduit.

### 7.4.4 Node Summary Tab

This tab displays a table of calculations for nodes in your model. Nodes include catch basins, manholes, and transitions. You cannot modify the table, it is read-only. To edit a node, select it in the Drawing Pane and edit its attributes in the Property Editor.

The Node Summary tab displays the following information:

**Label:** Displays the label of each node in your model.

**Element Type:** Displays the kind of node being reported on.

**Subnetwork Outfall:** Most downstream outfall for the node's gravity subnetwork.

**Flow (Total Surface):** Summation of all surface catchment inflows draining to the inlet.

**Flow (Total Out):** Sum of flows at the downstream side of the structure.

**Elevation (Ground):** Ground elevation for the node.

**Elevation (Invert):** Invert elevation for the node.
Energy Grade Line (In): Energy grade line at the upstream side of the node.

Energy Grade Line (Out): Energy grade line at the downstream side of the node.

7.4.5 Inlet Summary Tab

This tab displays a table of data about inlets in your model. You cannot modify the table, it is read-only. To edit an inlet, use the Inlets Catalog dialog, accessible from the Components menu.

The Inlet Summary tab displays the following information:

Label: Displays the label of each gutter in your model.

Inlet Type: Displays the type of inlet (Maximum Capacity, Percent Capture, or Catalog Inlet).

Inlet Type (Inlet): Displays which of the inlet catalog types the associated catalog inlet belongs to.

Inlet: Displays the Catalog Inlet label for the inlet.

Flow (Captured): Total amount of flow intercepted by the inlet.

Flow (Total Bypassed): Total amount of flow that bypassed the inlet and was not captured.

Bypass Target: The downstream inlet that bypassed flow is directed towards.

Capture Efficiency: Ratio of captured flow to total flow.

Kerb Channel Depth: Depth of water at the inlet.

Gutter Spread: Spread of water at the inlet, measured from the curb.

7.5 User Notifications

User notifications are messages about your model. These messages can warn you about potential issues with your model, such as slopes that might be too steep or elements that slope in the wrong direction. These messages also point you to errors in your model that prevent Bentley StormCAD V8i from solving your model.

The User Notifications dialog box displays warnings and error messages that are turned up by Bentley StormCAD V8i’s validation routines. If the notification references a particular element, you can zoom to that element by either double-clicking the notification, or right-clicking it and selecting the Zoom To command.
User Notifications

- Warnings are denoted by an orange icon and do not prevent the model from calculating successfully.
- Errors are denoted by a red icon, and the model will not successfully calculate if errors are found.

The User Notifications dialog box consists of a toolbar and a tabular view containing a list of warnings and error messages.

![User Notifications dialog box]

- [Image of User Notifications dialog box]

The table shows detailed notifications, including element types, IDs, and descriptions of issues, such as disconnected elements or negative pressures.
Calculating Your Model

The toolbar consists of the following buttons:

**Details**
Displays the User Notification Details dialog box, which includes information about any warning or error messages.

**Save**
Saves the user notifications as a comma-delimited .csv file. You can open the .csv file in Microsoft Excel or Notepad.

**Report**
Displays a User Notification Report.

**Copy**
Copies the currently highlighted warning or error message to the Windows clipboard.

**Zoom To**
If the warning or error message is related to a specific element in your model, click this button to center the element in question in the drawing pane.

**Help**
Displays online help for User Notifications.

User Notifications displays warnings and error messages in a tabular view. The table includes the following columns:

**Message ID**
The message ID associated with the corresponding message.

**Scenario**
The scenario associated with the corresponding message. This column will display “Base” unless you ran a different scenario.

**Element Type**
The element type associated with the corresponding message.
### User Notifications

**Element ID**  
The element ID associated with the corresponding message.

**Label**  
If the notification is caused by a specific element, this column displays the label of the element associated with the corresponding message.

**Message**  
The description associated with the corresponding message.

**Time (hours)**  
If the user notification occurred during a specific time step, it is displayed. Otherwise, this column is left blank.

**Source**  
The validation routine that triggered the corresponding message.

**To view user notifications**

1. Compute your model. If there are any.
2. If needed, open the User Notification manager by going to **Analysis > User Notifications** <F8>.
3. Or, if the calculation fails to compute because of an input error, when your model is finished computing, Bentley StormCAD V8i prompts you to view user notifications to validate the input data.
   
   You must fix any errors identified by red circles before Bentley StormCAD V8i can compute a result.

   Errors identified by orange circles are warnings that do not prevent the computation of the model.

4. In the User Notifications manager, if a notification pertains to a particular element, you can double-click the notification to magnify and display the element in the center of the drawing pane.

5. Use the element label to identify the element that generates the error and use the user notification message to edit the element’s properties to resolve the error.
This appendix provides an overview of the methods that StormCAD uses to perform the hydrologic and hydraulic computation within the program.

The basic process of computation for StormCAD proceeds as follows:

- Surface loads are generated and gutter/inlet computations are performed.
- Intercepted loads are routed downstream through the piping network.
- Headlosses are computed upstream through the piping network.

There is a strong inter-dependency between load routing and hydraulic grade computation. The pipe profiles have an effect on travel times (which affect rational loads), and the loads have a direct effect on the pipes’ hydraulic characteristics. Because of this close relationship, the calculation process is an iterative procedure, repeating until convergence is achieved or until the maximum number of iterations has been exhausted.

**Note:** All or portions of a storm system may be selected for automatic design. This preliminary design can be used to set pipe and structure elevations, as well as to size the pipes and inlet lengths.

StormCAD offers several ways to enter and compute flows, and even has the flexibility to model flows that do not necessarily originate from a rainfall event. The three basic types of loading that can be modeled by StormCAD are:

### 8.1 Hydrologic Principles

- Rational Loading
- Additional Loading
- Known Loading
Each of these loads are combined to give the total flow at any point within the storm sewer system, thus making it possible to easily combine loads from different sources, such as rational loading from a parking lot combined with additional loading from an industrial discharge.

\[ Q_T = Q_R + Q_A + Q_K \]

Where:

- \( Q_T \) = Total Load (cubic meters/second, cubic feet/second)
- \( Q_R \) = Rational Load (cubic meters/second, cubic feet/second)
- \( Q_A \) = Additional Load (cubic meters/second, cubic feet/second)
- \( Q_K \) = Known Load (cubic meters/second, cubic feet/second)

### 8.1.1 Rational Loading

The analysis of storm sewers is usually based on testing the ability of the piping system to appropriately handle peak flows without flooding roadways or scouring the pipes. The rational method is a popular method for estimating peak flows, based on the size and runoff coefficient of a watershed, and the intensity of the storm event.

The fundamental rational formula is:

\[ Q = CiA \]

Where:

- \( Q \) = Peak load (\( m^3/s \), \( ft^3/s \))
- \( C \) = Rational coefficient (unitless)
- \( i \) = Rainfall intensity (m/s, ft/s)
- \( A \) = Watershed area (\( m^2 \), \( ft^2 \))

Other forms of the rational method are commonly used which incorporate values in different units to make the order of magnitude of parameters more suitable for hand calculations. For example, the rational formula is often used with watershed area in acres and rainfall intensity in inches per hour. However, using this formula as-is can result in common mistakes, such as omitting the required unit conversion from acre-inches per hour to cubic feet per second (1.008). Conversions such as these are automatically performed within StormCAD to give you the most accurate results possible.
**Catchment Areas**

A catchment is the geographical area that "catches" the rainfall and directs it towards a common discharge point within the storm collection network.

**Rational Coefficient**

The rational C coefficient is the parameter that is the most open to engineering judgment. It is a unitless number between 0.0 and 1.0 that relates the rate of rainfall over a catchment to the rate of discharge from that catchment. A value of 0.0 implies that none of the rainfall is discharged from the catchment, while a value of 1.0 implies that all of the rainfall is immediately discharged from the catchment.

The coefficient is highly dependent on land use and slope approaching 1.0 for impervious ground covers, such as pavement. For some common C values for various types of land cover and slope, see the Engineer's Reference section at the end of this appendix.

**Composite Catchments**

Most catchments are comprised of more than one type of ground cover. For example, a roadside drainage inlet may accept flow from the paved roadway, the curbside grass, and a nearby wooded area. To account for the effects of each of these areas, multiply each corresponding sub-catchment area and rational coefficient, then add the values to obtain the total CA (C·A) for the entire catchment.

\[
CA_T = \sum_{i=1}^{n} (C_i \cdot A_i)
\]

Where:  
- \(CA_T\) = Total catchment CA (ha, acre)  
- \(C_i\) = Individual sub-catchment rational coefficients (unitless)  
- \(A_i\) = Individual sub-catchment areas (ha, acre)
Note: Since the rational coefficient is unitless, CA values have units of area. A weighted value for the rational coefficient can be determined by dividing the catchment's total CA by the total catchment area. Rather than tracking area and weighted rational coefficients separately, rational loads are often described solely by using the total CA value. Since the C coefficient and area are multiplied together in the rational formula anyway, there is no adverse effect of this simplification on flow determination.

Time of Concentration

Some locations within a catchment are hydraulically closer to the discharge point than others. In other words, it may start raining right now, but it could be several minutes (or even hours) before the water that lands on some parts of the catchment arrive at the discharge point. Rational method hydrology is based on contributing flow from the entire catchment area. The time that it takes for water to go from the most hydraulically remote area to reach the discharge point is the governing time to be used in the Rational Method. This is called the time of concentration.

Note: There are numerous methods for calculating the time of concentration, based on various federal and local regulations, as well as scientific publications. Although calculation methods vary significantly, they are all based on similar factors such as ground cover, ground slope, and travel distance.

System Time / Controlling Time / Duration

Similar to a time of concentration, a system time (or controlling time) is the amount of time it takes for all contributing parts of the storm sewer to reach a given location. This includes a catchment's time of concentration, and pipe travel times. When combining rational loads, the controlling time is the greatest of the individual loads' system times. This system time is used as the duration of the storm when determining peak intensity, and therefore peak flow.

To avoid unreasonably low storm durations and unreasonably high rainfall intensities, many regulatory agencies impose minimum storm durations, typically 5 or 10 minutes. StormCAD allows you to specify a minimum storm duration and uses this as the controlling time when the computed time is too low. In these cases, StormCAD carries the computed system time throughout the system, but continues to calculate intensity based on the minimum allowed time (until the system time rises above the minimum).
For example, consider a catchment at I-1 with a time of concentration of 4 minutes, and a minimum allowable duration of 5 minutes:

I-1 Catchment time of concentration: 4.0 minutes
StormCAD computes flow based on: 5.0 minutes
P-1 Pipe travel time: 0.5 minutes
J-1 System time (4.0 + 0.5): 4.5 minutes
StormCAD computes flow based on: 5.0 minutes
P-2 Pipe travel time: 1.0 minutes
O-1 System time (4.5 + 1.0): 5.5 minutes
StormCAD computes flow based on: 5.5 minutes
This 5.5 minutes is used as the duration in the intensity vs. duration equation used to calculate $i$ in determining the flow using:

$$ Q = i \Sigma (CA) $$

See Flow Balance at Junctions for more information.

**Rainfall Intensity**

Rainfall intensity is the measure of how "hard" it is raining. The harder it rains, the higher the intensity. Intensity is defined as the volume of rainfall that falls for a given time period divided by that time. For any given rainfall storm event, on average the longer the storm lasts, the lower the overall intensity will be.

This is consistent with what we would intuitively expect. Any given storm may rain hard for a short period of time, but it builds to that intensity and falls from that intensity over a period of time.
Return Period and Frequency

The return period and frequency are statistical descriptors of the severity of a storm event. The return period is the expected length of time between two rainfall events that exceed a specific magnitude. Frequency, or exceedance probability, is the inverse of the return period. As you might expect, the higher the return period, the more infrequent the storm event, and the higher the intensity of the rainfall.

For example, a storm with a 5-year return period represents an event that is expected to be exceeded once every five years (on average). The frequency is 1/5, which means that there is a 20% probability of a storm exceeding that magnitude occurring in any given year. Note that the return period does not mean that two storm events exceeding a given magnitude will not occur in the same year, nor does it guarantee that a storm event exceeding this magnitude will occur within any given five year span. It just means that these storms will occur at an average rate of once every five years.

Intensity Durations Frequency Data

The intensity of a rainfall event is directly related to the duration and return period of the storm. Often this data is presented in the form of Intensity-Duration-Frequency (IDF) curves, as in the example graph below:

StormCAD applies rainfall data in one of two other forms:
Rainfall Tables

Creating rainfall tables is a simple matter of picking values from a set of rainfall curves, and entering them into the table. For duration values that do not correspond directly to values entered in the table, intensities are linearly interpolated or extrapolated.

Rainfall Equations Theory

IDF curves can generally be fit to equations with good accuracy. If you do not have an appropriate equation from your local regulating agency, a rainfall table may be more suitable.

The most common form of these equations is:

\[ i = \frac{a}{(b + D)^n} \]

Where:

- \( i \) = rainfall intensity (in/hr.)
- \( D \) = rainfall duration (min.)
- \( a, b, n \) = rainfall equation coefficients

Basic Assumptions about the Rational Method

There are several assumptions that form the basis for rational method hydrology:

- Drainage areas are smaller than 300 acres (120 hectares).
- Peak flow occurs when the entire catchment is contributing.
- Rainfall intensity is uniform over a duration of time equal to or greater than the time of concentration.
- Rational coefficients are independent of the intensity of the rainfall.
8.1.2 Additional Flow Loading

Additional flows are fixed loads that are not subject to peaking or other fluctuations like rational loads. Additional flows are propagated directly downstream, and combine as the simple sum of the individual additional loads, including additional loads specified at an inlet.

**Note:** Negative additional loads are permissible and behave just as any positive additional load. They lower the total load by the fixed amount. The one exception to this occurs when the total load drops below zero. If the total load does drop below zero, an “empty” load is propagated downstream (a load with a rational CA of zero, a known flow of zero, etc.).

8.1.3 Known Flow Loading

Known flows are a special type of fixed load. Known flows remain constant as they progress downstream, and combine directly as a simple sum similar to additional loads. The overwrite behavior of known loads is special. When another known load is specified at a downstream inlet, the local known load replaces the upstream known load, rather than the local known load adding directly to the upstream known load. If the local known flow is left equal to 0, the upstream flow is propagated downstream without being overwritten. A non-zero flow input at any inlet will be used regardless of the magnitude of the combined incoming known flow loads.

**Known Flows Prior to StormCAD v3**

The additive behavior of known flows at the confluence of two or more storm sewer branches was changed in Version 3.0 of StormCAD. Prior to Version 3.0, the program would add the incoming known flows at an inlet and then compare these loads against the user input known flow loading at the confluence, using the greater of the two values. In other words, it was possible for a user to input a known flow at a confluence inlet, but the input flow would be overridden if it was lower than the sum of the incoming upstream known flows.

This implementation was revisited during development of version 3.0 and it was decided that the most useful and expected behavior is to use the input known flow in all cases.
8.1.4 *Location of Flows*

Although the type of flow is indicative of its origin (for example a rational flow probably comes from a catchment area), StormCAD allows flow to be added from several source locations. StormCAD also tracks flows and flow types as they progress through the system, making it easy to control and observe storm sewer flows.

Flow (and related) results are broken down into different groups in StormCAD. The groups are:

- **System Flows** - total flows in the subsurface (conduit) network, on the downstream side of a catch basin, manhole or transition node. The system flows are equal to the sum of the Local and Upstream flows.

- **Local Flows** - flows that occur at the catch basin where the result is reported. For example the Local Rational Flow at catch basin is the 'rational flow' (i.e. catchment runoff computed using the Rational Method) generated by catchments that discharge directly to that catch basin.

- **Upstream Flows** - total flows in the subsurface (conduit) network, on the upstream side of a catch basin, manhole or transition node.

- **Intercepted Flows** - flows that are intercepted or captured by the inlet at a catch basin node.

- **Bypass Flows** - flows that are not intercepted by the inlet at a catch basin node, and continue on downstream via a gutter element

- **Carryover Flows** - flows at an inlet that were bypassed, via a gutter, from the inlet upstream.

- **Total Inlet Flows** - the sum of the Local and Carryover flows that reach an inlet via the surface network. In other words, the total flow that reaches an inlet.

In addition, StormCAD breaks flows down into different flow types. The types are:

- **Rational Flow** - catchment runoff computed using the Rational Method

- **Additional Subsurface Flow** - flow added directly to the subsurface (conduit) network. This can represent a fixed inflow from a known source, such as an industrial discharge

- **Additional Carryover Flow** - additional flow in the surface (gutter) network. This can represent gutter flow that bypassed an upstream inlet, where that upstream inlet is not included in the current StormCAD model
- **Additional Flow** - the sum of Additional Subsurface and Additional Carryover flows after they have mixed together in the subsurface (conduit) network

- **Known Flow** - a flow where the total flow rate is known at various points in the system. A known flow downstream will overwrite (not add to) a known flow upstream. This can be used to represent flows derived from flow monitoring results.

- **Fixed Flow** - the sum of Additional and Known flows.
The major locations of load input and reporting are as follows:
• Surface Catchment Loads
• Surface Carryover Loads
• Inlet Approach Loads
• Inlet Captured (Intercepted) Loads
• Inlet Bypassed Loads
• Subsurface Piped Loads
• Subsurface External Loads
• Subsurface Total Piped Loads

Although input flow loads such as surface catchment loads and subsurface external loads are only editable for inlets, calculated loads, such as subsurface total piped load, are computed for all nodes.

**Note:** See also: Flow Balance at Junctions on page 8-557.

### Surface Catchment Loads

The surface catchment load includes rational loading (areas, rational coefficients, and time of concentration) from the local catchment.

**Note:** This load may also include an additional load representing a fixed flow that contributes to the gutter flow approaching the inlet (similar to subsurface external loads). Note that supplementary rational gutter loads that are not part of the StormCAD system can be accounted for simply as another sub-catchment area and C coefficient.

### Surface Carryover Loads

Surface carryover loads are loads that have been bypassed from upstream gutter inlets. Note that the term "upstream" in this case refers to the directionality of the gutter network, which does not necessarily correspond to the directionality of the subsurface piped network. In fact, carryover loads may even come from inlets that are part of a separate pipe network. Note that carryover loads are assumed to have the same time of concentration as the surface catchment load. The times of concentration from their original catchments are not considered.

### Inlet Approach Loads

The inlet approach load is the sum of the surface catchment load and the surface carryover loads. This represents the total flow that is in the gutter or ditch immediately before it is captured or bypassed.
Inlet Captured (Intercepted) Loads

The load intercepted by a surface inlet is calculated based on the HEC-22 methodology, the inlet maximum capacity curve, or capture curve, depending on which type of inlet is used. This represents the load that is actually captured by the inlet and enters the subsurface structure. The captured load is assumed to have the same proportions of load (rational and additional) as the approach load. Inlet captured loads are represented as a percentage of the inlet approach load.

Inlet Bypassed Loads

An inlet's bypassed load is the part of the approach load that is not intercepted by the surface inlet. This load is assumed to have the same proportion of load (rational and additional) as the approach load. Bypassed loads may be directed to any other inlet in any pipe network, or may be lost. Lost flows are accumulated and accounted for at outlets, but never contribute to subsurface piped flow.

Subsurface Piped Loads

Subsurface piped loads are those that enter a subsurface structure from upstream pipes. These loads combine in accordance with each load component's behavior. This means that rational loads are normalized to a common time, additional loads are summed directly, and so on. Because of rational load normalization, a node's total upstream flow may be less than the sum of each pipe's total flow.

Subsurface External Loads

Subsurface external loads are user-entered loads that represent flows entering the pipe network at and below an inlet, such as a roof or footing drain or another storm sewer branch. These loads are not used to analyze or design the inlet structure, but are used in analyzing or designing the pipe network.

Subsurface Total Piped Load

The total piped load is the total load leaving a node, and is calculated by summing all of the contributing loads: intercepted surface load, subsurface piped loads, and subsurface external loads. For nodes where there are no surface loads or external loads entering, the total piped load is equal to the sum of subsurface piped loads (upstream).
8.1.5 The Energy Principle

The first law of thermodynamics states that for any given system, the change in energy is equal to the difference between the heat transferred to the system and the work done by the system on its surroundings during a given time interval.

The energy referred to in this principle represents the total energy of the system minus the sum of the potential, kinetic, and internal (molecular) forms of energy, such as electrical and chemical energy. The internal energy changes are commonly disregarded in water distribution analysis because of their relatively small magnitude.

In hydraulic applications, energy is often represented as energy per unit weight, resulting in units of length. Using these length equivalents gives engineers a better feel for the resulting behavior of the system. When using these length equivalents, the state of the system is expressed in terms of head. The energy at any point within a hydraulic system is often represented in three parts:

Pressure Head: \( \frac{p}{\gamma} \)

Elevation Head: \( z \)

Velocity Head: \( \frac{v^2}{2g} \)

Where

\( p \) = Pressure (N/m², lb./ft.²)

\( \gamma \) = Specific weight (N/m³, lb./ft.³)

\( z \) = Elevation (m, ft.)

\( v \) = Velocity (m/s, ft./sec.)

\( g \) = Gravitational acceleration constant (m/s², ft./sec.²)

These quantities can be used to express the headloss or head gain between two locations using the energy equation (for more information, see The Energy Equation on page 8-463).
Note: The headloss result on a node and pipe is delta HGL when the Structure Loss Mode calculation option is set to HGL, and delta EGL when the Structure Loss Mode calculation option is set to EGL.

The Energy Equation

In addition to pressure head, elevation head, and velocity head, there may also be head added to the system, by a pump for instance, and head removed from the system due to friction. These changes in head are referred to as head gains and headlosses, respectively. Balancing the energy across two points in the system, you then obtain the energy equation:

\[
\frac{p_1}{\gamma} + z_1 + \frac{V_1^2}{2g} + h_p = \frac{p_2}{\gamma} + z_2 + \frac{V_2^2}{2g} + h_L
\]

Where

- \( p \) = Pressure (N/m², lb./ft.²)
- \( g \) = Specific weight (N/m³, lb./ft.³)
- \( z \) = Elevation at the centroid (m, ft.)
- \( V \) = Velocity (m/s, ft./sec.)
- \( g \) = Gravitational acceleration constant (m/s², ft./sec.²)
- \( h_p \) = Head gain from a pump (m, ft.)
- \( h_L \) = Combined headloss (m, ft.)

The components of the energy equation can be combined to express two useful quantities, which are the hydraulic grade and the energy grade.

Hydraulic and Energy Grades

Hydraulic and energy grades includes:

- [Hydraulic Grade on page 8-464](#)
- [Energy Grade on page 8-464](#)
Hydraulic Grade

The hydraulic grade is the sum of the pressure head \((p/g)\) and elevation head \((z)\). The hydraulic head represents the height to which a water column would rise in a piezometer. The plot of the hydraulic grade in a profile is often referred to as the hydraulic grade line, or HGL.

Energy Grade

The energy grade is the sum of the hydraulic grade and the velocity head \((V^2/2g)\). This is the height to which a column of water would rise in a pitot tube. The plot of the hydraulic grade in a profile is often referred to as the energy grade line, or EGL. At a lake or reservoir, where the velocity is essentially zero, the EGL is equal to the HGL, as can be seen in the following figure.

HGL Convergence Test

In full network calculation this value is taken as the maximum absolute change between two successive solves of hydraulic grade at any junction or inlet in the system. This test is used to optimize the performance of system solutions. It minimizes the number and extent of hydraulic grade line computations in the upstream direction. For a given discharge, the upstream propagation of headlosses through pipes will continue until two successive calculations change by an absolute difference of less than this test value.

The HGL Convergence Test value is also used in the standard step gradually varied flow profiling algorithm. If two successive depth iterations are within this absolute test value, the step is solved.
**Friction Loss Methods**

Friction loss methods include:

- **Chezy’s Equation on page 8-465**
- **Kutter’s Equation**
- **Colebrook-White Equation on page 8-466**
- **Hazen-Williams Equation on page 8-467**
- **Darcy-Weisbach Equation on page 8-467**
- **Manning’s Equation on page 8-469**

**Chezy’s Equation**

Chezy’s equation is rarely used directly, but it is the basis for several other methods, including Manning’s equation. Chezy’s equation is:

\[
Q = C \cdot A \cdot \sqrt{R} \cdot S
\]

Where
- \( Q \) = Discharge in the section (\( m^3/s \), cfs)
- \( C \) = Chezy’s roughness coefficient (\( m^{1/2}/s \), ft.\(^{1/2}/\text{sec.} \))
- \( A \) = Flow area (\( m^2 \), ft.\(^2 \))
- \( R \) = Hydraulic radius (m, ft.)
- \( S \) = Friction slope (m/m, ft./ft.)

**Kutter’s Equation**

Kutter’s equation can be used to determine the roughness coefficient in Chezy’s formula, and is most commonly used for sanitary sewer analysis. Kutter’s equation is as follows:

\[
C = \frac{k_1 + \frac{k_2}{S} + \frac{k_3}{n}}{1 + \frac{n}{\sqrt{R}} \cdot \left( k_1 + \frac{k_2}{S} \right)}
\]
Hydrologic Principles

Where

\[ C = \text{Chezy’s roughness coefficient (m}^{1/2}/\text{s, ft.}^{1/2}/\text{sec.)} \]
\[ S = \text{Friction slope (m/m, ft./ft.)} \]
\[ R = \text{Hydraulic radius (m, ft.)} \]
\[ n = \text{Kutter’s roughness (unitless)} \]
\[ k_1 = \text{Constant (23.0 for SI, 41.65 for US)} \]
\[ k_2 = \text{Constant (0.00155 for SI, 0.00281 for US)} \]
\[ k_3 = \text{Constant (1.0 for SI, 1.811 for US)} \]

Colebrook-White Equation

The Colebrook-White equation is used to iteratively calculate for the Darcy-Weisbach friction factor:

Free Surface:

\[
\frac{1}{\sqrt{f}} = -2\log \frac{k}{k_1 2.0 R} + \frac{2.51}{R \sqrt{f}^{1/4}}
\]

Full Flow (Closed Conduit):

\[
\frac{1}{\sqrt{f}} = -2\log \frac{k}{k_1 3.7 D} + \frac{2.51}{R \sqrt{f}^{1/4}}
\]

Where

\[ f = \text{Friction factor (unitless)} \]
\[ k = \text{Darcy-Weisbach roughness height (m, ft.)} \]
\[ \text{Re} = \text{Reynolds Number (unitless)} \]
\[ R = \text{Hydraulic radius (m, ft.)} \]
\[ D = \text{Pipe diameter (m, ft.)} \]
Hazen-Williams Equation

The Hazen-Williams Formula is frequently used in the analysis of pressure pipe systems (such as water distribution networks and sewer force mains). The formula is as follows:

\[ Q = k \cdot C \cdot A \cdot R^{0.63} \cdot S^{0.54} \]

Where

- \( Q \) = Discharge in the section (\( m^3/s \), cfs)
- \( C \) = Hazen-Williams roughness coefficient (unitless)
- \( A \) = Flow area (\( m^2 \), ft.\(^2\))
- \( R \) = Hydraulic radius (m, ft.)
- \( S \) = Friction slope (m/m, ft./ft.)
- \( k \) = Constant (0.85 for SI units, 1.32 for US units).

Darcy-Weisbach Equation

Because of non-empirical origins, the Darcy-Weisbach equation is viewed by many engineers as the most accurate method for modeling friction losses. It most commonly takes the following form:

\[ h_L = f \frac{L V^2}{D 2g} \]

Where

- \( h_L \) = Headloss (m, ft.)
- \( f \) = Darcy-Weisbach friction factor (unitless)
- \( D \) = Pipe diameter (m, ft.)
- \( L \) = Pipe length (m, ft.)
- \( V \) = Flow velocity (m/s, ft./sec.)
- \( g \) = Gravitational acceleration constant (m/s\(^2\), ft./sec.\(^2\))

For section geometries that are not circular, this equation is adapted by relating a circular section’s full-flow hydraulic radius to its diameter:

\[ D = 4R \]
Hydrologic Principles

Where

\[ R = \text{Hydraulic radius (m, ft.)} \]
\[ D = \text{Diameter (m, ft.)} \]

This can then be rearranged to the form:

\[ Q = A \cdot 8g \cdot \frac{R \cdot S}{f} \]

Where

\[ Q = \text{Discharge (m}^3/\text{s, cfs)} \]
\[ A = \text{Flow area (m}^2, \text{ft}^2) \]
\[ R = \text{Hydraulic radius (m, ft.)} \]
\[ S = \text{Friction slope (m/m, ft./ft.)} \]
\[ f = \text{Darcy-Weisbach friction factor (unitless)} \]
\[ g = \text{Gravitational acceleration constant (m/s}^2, \text{ft./sec}^2) \]

The Swamee and Jain equation can then be used to calculate the friction factor. For more information, see Swamee and Jain Equation on page 8-468.

Swamee and Jain Equation

\[ f = \frac{1.325}{\ln \left( \frac{\varepsilon}{D} \right) + \frac{5.74}{R_e^{0.9}} + 0.15} \]

Where

\[ f = \text{Friction factor (unitless)} \]
\[ \varepsilon = \text{Roughness height (m, ft.)} \]
\[ D = \text{Pipe diameter (m, ft.)} \]
\[ R_e = \text{Reynolds Number (unitless)} \]
The friction factor is dependent on the Reynolds number of the flow, which is dependent on the flow velocity, which is dependent on the discharge. As you can see, this process requires the iterative selection of a friction factor until the calculated discharge agrees with the chosen friction factor.

**Manning’s Equation**

**Note:** Manning’s roughness coefficients are the same as the roughness coefficients used in Kutter’s equation.

Manning’s equation, which is based on Chezy’s equation, is one of the most popular methods in use today for free surface flow. For Manning’s equation, the roughness coefficient in Chezy’s equation is calculated as:

\[
C = k \cdot \frac{R^{1/6}}{n}
\]

Where

- **C** = Chezy’s roughness coefficient (m\(^{1/2}\)/s, ft.\(^{1/2}\)/sec.)
- **R** = Hydraulic radius (m, ft.)
- **n** = Manning’s roughness (s/m\(^{1/3}\))
- **k** = Constant (1.00 m\(^{1/3}\)/m\(^{1/3}\), 1.49 ft.\(^{1/3}\)/ft.\(^{1/3}\))

Substituting this roughness into Chezy’s equation, you obtain the well-known Manning’s equation:

\[
Q = \frac{k}{n} \cdot A \cdot R^{2/3} \cdot S^{1/2}
\]

Where

- **Q** = Discharge (m\(^3\)/s, cfs)
- **k** = Constant (1.00 m\(^{1/3}\)/s, 1.49 ft.\(^{1/3}\)/sec.)
- **n** = Manning’s roughness (unitless)
- **A** = Flow area (m\(^2\), ft.\(^2\))
- **R** = Hydraulic radius (m, ft.)
- **S** = Friction slope (m/m, ft./ft.)
8.0.1 Flow Regime

The hydraulic grade in a flow section depends heavily on the tailwater conditions, pipe slope, discharge, and other conditions. The basic flow regimes that a pipe may experience include:

- Pressure Flow
- Uniform (Normal) Flow
- Critical Flow
- Subcritical Flow
- Supercritical Flow

Based on the gradually varied flow analysis, different portions of any given pipe may be under different flow regimes.

Pressure Flow

When a pipe is surcharged, headlosses are simply based on the full barrel area and wetted perimeter. Because these characteristics are all functions of the section shape and size, friction loss calculations are greatly simplified by pressurized conditions.

Uniform Flow and Normal Depth

Uniform flow refers to a hydraulic condition where the discharge and cross-sectional area, and therefore the velocity, are constant throughout the length of the channel or pipe. For a pipe flowing full, all that this requires is that the pipe be straight and have no contractions or expansions. For a non-full section, however, there are a few additional points of interest:

In order for the cross-sectional area to remain the same, the depth of flow must be constant throughout the length of the channel. This requires that the friction slope equal the constructed slope. This depth is called normal depth.

Since the hydraulic grade line parallels the invert of the section and the velocity does not change, the energy grade line is parallel to both the hydraulic grade line and the section invert under uniform flow conditions.

In prismatic channels, flow conditions will typically approach normal depth if the channel is sufficiently long.
Critical Flow, Critical Depth, and Critical Slope

Critical flow occurs when the specific energy of the section is at a minimum. This condition is defined by the situation where:

\[
\frac{A^3}{T} = \frac{Q^2}{g}
\]

Where:

- \( A \) = Area of flow \((m^2, ft^2)\)
- \( T \) = Top width of flow \((m, ft)\)
- \( Q \) = Section Discharge \((m^3/s, ft^3/s)\)
- \( g \) = Gravitational acceleration \((m/s^2, ft/s^2)\)

This is a relatively simple computation for simple geometric shapes, but can require iterative calculation for more complex shapes (such as arches). Some sections may even have several valid critical depths, making numerical convergence more difficult.

Critical depth refers to the depth of water in a channel for which the specific energy is at its minimum. Critical slope refers to the slope at which the critical depth of a pipe would be equal to the normal depth.

Subcritical Flow

Subcritical flow refers to any flow condition where the Froude number is less than 1.0. For this condition, the depth is above critical depth, and the velocity is below the critical depth velocity.

Supercritical Flow

Supercritical flow refers to any condition where the Froude number, or the ratio of internal forces to gravity forces, is greater than 1.0. For this condition, the depth is below critical depth, and the velocity is above the critical depth velocity.
8.0.2  Gradually Varied Flow Analysis

For free surface flow, depth rarely remains the same throughout the length of a channel or pipe. Starting from a boundary control depth, the depth changes gradually, increasing or decreasing until normal depth is achieved (if the conduit is sufficiently long). The determination of a boundary control depth depends on both the tailwater condition and the hydraulic characteristics of the conduit. The areas of classification for gradually varied flow analysis are:

- Slope Classification
- Zone Classification
- Profile Classification

Slope Classification

The constructed slope of a conduit is a very important factor in determining the type of gradually varied flow profile that exists. Slopes fall into one of five types, all of which are handled by the program:

- Adverse Slope
- Horizontal Slope
- Hydraulically Mild Slope
- Critical Slope
- Hydraulically Steep Slope

Any pipe can qualify as only one of these slope types for a given discharge. For differing flows, though, a pipe may change between qualifying as a mild, critical, and steep slope. These slopes do not relate to just the constructed slope, but to the constructed slope relative to the critical slope for the given discharge.

Adverse Slope

Adverse slope occurs when the upstream invert elevation of a pipe is actually below the downstream invert elevation. Normal depth is undefined for adverse slopes, since no amount of positive flow would result in a rising friction slope. Most flow conditions for adverse sloping pipes are subcritical.

Pipes are typically not designed to be adverse, so most situations with adverse slopes are due to construction errors or other unusual circumstances. Adverse pipes may cause some concern beyond the hydraulic capacity of the system, because stagnant water, excessive clogging, and other non-desirable conditions may result.
Horizontal Slope

As the name suggests, a horizontal slope results when a pipe's upstream and downstream invert elevations are the same. Normal depth for a horizontal pipe is theoretically infinite, although critical depth may still be computed. Like adverse slopes, most flow conditions for horizontal pipes are subcritical.

Hydraulically Mild Slope

A hydraulically mild slope is a condition where the constructed slope is less than the critical slope. For this condition, the section's normal depth is above critical depth, and the flow regime is usually subcritical.

Critical Slope

A pipe or channel may have exactly the same slope as the critical slope for the discharge it carries. This is a very uncommon occurrence, but it is possible and the program does calculate it appropriately. Critical depth is an inherently unstable surface, so flow is most likely to be subcritical for these slopes.

Hydraulically Steep Slope

A hydraulically steep slope is a condition where the constructed slope is greater than the critical slope. For this condition, the section's normal depth is below critical depth, and the flow regime is usually supercritical. However, high tailwater conditions may cause flow to be subcritical.

Zone Classification

There are three zones that are typically used to classify gradually varied flow:

Zone 1 is where actual flow depth is above both normal depth and critical depth.

Zone 2 is where actual flow depth is between normal depth and critical depth.

Zone 3 is where actual flow depth is below both normal depth and critical depth.
Profile Classification

The gradually varied flow profile classification is simply a combination of the slope classification and the zone classification. For example, a pipe with a hydraulically mild slope and flow in zone 1 would be considered a Mild-1 profile (M1 for short). The program will analyze most profile types, but will not analyze certain flow profile types that occur rarely in conventional sewer system such as H3, M3, and S3.
**Energy Balance**

Even for gradually varied flow, the solution is still a matter of balancing the energy between the two ends of a pipe segment. The energy equation as it relates to each end of a segment is as follows (note that the pressures for both ends are zero, since it is free surface flow):

\[
Z_1 + \frac{V_1^2}{2g} = Z_2 + \frac{V_2^2}{2g} + H_L
\]

Where:

- \( Z_1 \) = Hydraulic grade at upstream end of the segment (m, ft)
- \( V_1 \) = Velocity at the upstream end (m/s, ft/s)
- \( Z_2 \) = Hydraulic grade at the downstream end of the segment (m, ft)
- \( V_2 \) = Velocity at the downstream end (m/s, ft/s)
- \( H_L \) = Loss due to friction - other losses assumed to be zero (m, ft)
- \( g \) = Gravitational acceleration constant \((m/s^2, ft/s^2)\)

The friction loss is computed based on the average rate of friction loss along the segment and the length of the segment. This relationship is as follows:

\[
H_L = S_{\text{Avg}} \cdot \Delta x = \frac{S_1 + S_2}{2} \Delta x
\]

Where:

- \( H_L \) = Loss across the segment (m, ft)
- \( S_{\text{Avg}} \) = Average friction slope (m/m, ft/ft)
- \( S_1 \) = Friction slope at the upstream end of the segment (m/m, ft/ft)
- \( S_2 \) = Friction slope at the downstream end of the segment (m/m, ft/ft)
- \( \Delta x \) = Length of the segment being analyzed (m, ft)
The conditions at one end of the segment are known through asinversion or from a previous calculation step. Since the friction slope is a function of velocity, which is a function of depth, the depth at the other end of the segment can be found through iteration. There are two primary methods for this iterative solution, the Standard Step method and the Direct Step method.

**Note:** Because it generates better resolution within the changing part of the profile, the gravity flow algorithm of StormCAD and SewerCAD primarily use the direct step method to compute gradually varied flow profiles.

### Standard Step Method

The standard step method of gradually varied flow energy balance involves dividing the channel into segments of known length and solving for the unknown depth at one end of the segment, starting with a known or assumed depth at the other end. The standard step method is the most popular method of determining the flow profile because it can be applied to any channel, not just prismatic channels.

**Note:** Because it generates better resolution within the changing part of the profile, the gravity flow algorithm of StormCAD and SewerCAD primarily use the direct step method to compute gradually varied flow profiles. The Standard Step Method is never used.

### Direct Step Method

The direct step method is based on the same basic energy principles as the standard step method, but takes a slightly different approach towards the solution. Instead of assuming a segment length and solving for the depth at the end of the segment, the direct step method assumes a depth and then solves for the segment length.

**Note:** Because it generates better resolution within the changing part of the profile, the gravity flow algorithm of StormCAD and SewerCAD use the direct step method to compute gradually varied flow profiles.

### Mixed Flow Profiles

Although the hydraulic slope of a pipe will be the same throughout its length, a pipe may contain several different profile types. The transitions that may be encountered include:

- Sealing (Surcharging) Conditions
- Rapidly Varied Flow (Hydraulic Jumps)
Sealing (Surcharging) Conditions

There may be conditions such that part of the section is flowing full, while part of the flow remains open. These conditions are called sealing conditions, and the sections are analyzed in separate parts. For sealing conditions, the portion of the section flowing full is analyzed as pressure flow, and the remaining portion is analyzed with gradually varied flow techniques.

Rapidly Varied Flow

Rapidly varied flow is turbulent flow resulting from the abrupt and pronounced curvature of flow streamlines into or out of a hydraulic control structure. Examples of rapidly varied flow include hydraulic jumps, bends, and bridge contractions.

The hydraulic phenomenon that occurs when the flow passes rapidly from supercritical to subcritical flow is called a hydraulic jump. The most common occurrence of this within a gravity flow network occurs when there is a steep pipe discharging into a particularly high tailwater, as shown in the following figure.

![Hydraulic Jump Diagram]

There are significant losses associated with hydraulic jumps, due to the amount of mixing and hydraulic turbulence that occurs. These forces are also highly erosive, so engineers typically try to prevent jumps from occurring in gravity flow systems, or at least try to predict the location of these jumps in order to provide adequate channel, pipe, or structure protection. The program does not perform any specific force analyses that seek to precisely locate the hydraulic jump, nor does it identify the occurrence of jumps that might happen as flows leave a steep pipe and enter a mild pipe. Rather it performs analyses sufficient to compute grades at structures.

Backwater Analysis

The classic solution of gravity flow hydraulics is via a backwater analysis. This type of analysis starts at the network outlet under free discharge, submerged, or tailwater control, and proceeds in an upstream direction.
Steep pipes tend to "interrupt" the backwater analysis, and reset the hydraulic control to critical depth at the upstream end of the steep pipe. A frontwater analysis may be needed for a steep profile (such as an S2), with the backwater analysis recommencing from the upstream structure.

**Free Outfall**

This program lets you define the tailwater condition at the outlet as either Free Outfall, Crown Elevation or User-Specified.

For a pipe with a hydraulically steep slope, the Free Outfall condition will yield a starting depth equal to normal depth in the pipe. For a pipe with a hydraulically mild slope, the Free Outfall condition will yield a starting depth equal to critical depth. When an outlet has multiple incoming pipes, the Free Outfall condition yields a starting elevation equal to the lowest of the individual computed elevations.

The Crown condition should be used when the pipe discharges to an outlet where the water surface elevation is equal to the elevation of the top of the pipe.

**Structure Flooding**

Flooding at manholes in SewerCAD and inlets in StormCAD occurs whenever the elevation of water is above the structure rim elevation. When this occurs, the backwater analysis will continue by resetting the hydraulic grade to the structure rim elevation or ground elevation, whichever is higher. However, if a structure is defined with a bolted cover, the hydraulic grade is not reset to the rim elevation.

In actual flooding situations, flows may be diverted away from the junction structure and out of the system, or attenuated due to surcharged storage. In this program, even though the governing downstream boundary for the next conduit is artificially lowered to prevent the propagation of an incorrect backwater, the peak discharges at the structure are conserved and are not reduced by the occurrence of flooding at a junction.

**Frontwater Analysis**

The program will perform a frontwater analysis in a steep pipe operating under supercritical flow, since these pipes are typically entrance controlled. The hydraulic control is at the upstream end of the conduit, and the gradually varied flow analysis will proceed in a downstream direction until either the normal depth is achieved, a hydraulic jump occurs, or the end of the pipe is encountered.

The program's algorithm is fundamentally based on backwater analysis. As a result, a continuous frontwater analysis is not performed through two or more consecutive steep pipes.
Note: This is a performance trade-off that has little impact in evaluating performance of the collection system in most situations. The asinversion of critical depth at the upstream end results in a conservative depth in all cases, and is exactly correct at the point of the steep run furthest upstream.

Pipe Average Velocity

Several common methods for computing a pipe's average velocity are available:

• Uniform Flow Velocity
• Full Flow Velocity
• Simple Average Velocity
• Weighted Average Velocity

Uniform Flow Velocity

The uniform flow velocity of a pipe is obtained by calculating the velocity in the pipe at normal depth. If the normal depth corresponds to a surcharged condition, the full flow velocity is used instead.

Full Flow Velocity

The full flow velocity corresponds to the velocity when the pipe is flowing full. The flow area is equal to the entire cross-sectional area of the pipe.

Simple Average Velocity

The simple average velocity is computed by:

\[ V_a = \frac{V_u + V_d}{2} \]

The Simple Average Velocity method does not account for any depth changes between the two ends of the pipe as the weighted average velocity method does.
**Weighted Average Velocity**

To compute the weighted average velocity, the simple average velocity of each profile segment is considered and given a weight based on its length:

\[
V_a = \sum_{i=1}^{n} \left( \frac{V_{ui} + V_{di}}{2} \right) \cdot \left( \frac{L_i}{L_t} \right)
\]

- \(V_a\) = Average velocity for the pipe (m/s, ft/s)
- \(V_{ui}\) = Upstream velocity for segment i (m/s, ft/s)
- \(V_{di}\) = Downstream velocity for segment i (m/s, ft/s)
- \(L_i\) = Length of the profile segment i (m, ft)
- \(L_t\) = Total length of the pipe (m, ft)

**Pipe Average Velocity and Travel Time**

The travel time though each pipe is computed as:

\[
t = \frac{L}{V}
\]

Where:

- \(t\) = Time of travel through the pipe (s)
- \(V\) = Average velocity though the pipe (m/s, ft/s)
- \(L\) = Length of the pipe (m, ft)

**Capacity Analysis (Approximate Profiles)**

Traditionally, gravity pipe analyses and designs have not included the calculation-intensive process of estimating a gradually varied flow profile. With this program, you have the option of determining discharge using gradually varied flow, or using the more traditional Capacity Analysis option. Capacity analysis still uses a backwater approach, with the profile type for a pipe being primarily dependent on the pipe’s full flow capacity and downstream hydraulic grade.

The capacity analysis is advantageous over the gradually varied flow analysis in terms of processing time. If you are dealing with a relatively large network and you wish to arrive quickly at reasonable approximation then the capacity analysis is the way to go. The gradually varied flow algorithms are more rigorous and generate solutions that more closely reflect reality.
There are two basic approximate profile cases: the Full Capacity Profile and the Excess Capacity Profile.

**Full Capacity Profiles**

Full capacity profiles occur when the pipe's actual discharge is greater than or equal to the pipe's full flow capacity. In these cases, the downstream depth is taken as the greater of the actual downstream hydraulic grade or the free discharge tailwater elevation. The free discharge tailwater depth is commonly approximated as halfway between the crown of the pipe and the pipe's critical depth (in accordance with the U.S. Federal Highway Administration's HDS-5).

Starting from the tailwater elevation, the pipe's full flow friction slope is used to determine the hydraulic grade at the upstream end of the profile.

**Excess Capacity Profiles**

Excess capacity profiles occur when the full flow capacity of the pipe is greater than the actual flow in the pipe. For these profiles, there are three basic tailwater conditions:

- **Case 1** - Hydraulic grade downstream less than or equal to normal depth.
- **Case 2** - Hydraulic grade downstream greater than normal depth, and less than or equal to pipe crown.
- **Case 3** - Hydraulic grade downstream greater than or equal to pipe crown.

**Excess Capacity Profile, Case 1 (Hydraulic Grade <= Normal Depth):**

If the downstream depth in the pipe is at or below the pipe's normal depth, normal depth is assumed for the pipe's entire length.
**Excess Capacity Profile, Case 2 (Normal Depth < Hydraulic Grade <= Pipe Crown)**

When the hydraulic grade is above the pipe’s normal depth but below the top of the pipe, a friction slope of zero is assumed until it either intersects the pipe’s normal depth or reaches the end of the pipe.

![Diagram showing excess capacity profile, Case 2](image)

**Excess Capacity Profile, Case 3 (Hydraulic Grade >= Pipe Crown)**

If the hydraulic grade is above the pipe crown, the hydraulic grade continues upstream following the pipe’s full flow friction slope. This slope will continue until it either intersects the pipe crown or reaches the end of the pipe.
Note: If the full friction slope intersects the crown of the pipe, the profile will continue with a Case 2 profile analysis.

Composite Excess Capacity Profiles

An excess capacity profile may actually be a composite of two more simple profiles. Consider the case below, where the tailwater is above the crown of the pipe. In this case, the profile begins as a Case 3 profile. Where the full flow friction slope intersects the crown of the pipe, the profile changes to a Case 2 profile, following a flat slope until it reaches normal depth. Where normal depth is intersected, a Case 1 profile begins, extending all the way to the upstream end of the pipe.

8.0.1 Conduit Shapes

The supported conduit shapes are shown in the figures below. Each shape is parameterized by one, two, or more characteristic dimensions as shown in the reference figure. In this model, a conduit is taken to be a prismatic (constant-shaped) conveyance segment that is defined by a single shape. Conduits do not have to be closed sections, so prismatic design channels can be modeled using conduit elements.

The allowable conduit shapes include:

- Circular Channel
- Trapezoidal Channel
- Ellipse
Hydrologic Principles

Pipe-Arch

Triangle

Rectangular Channel

Irregular Open Channel

Circular Channel

Trapezoidal Channel
Ellipse
Hydrologic Principles

Pipe-Arch

$h$

$Rr$

$Y_1$

Span

Rise

B

Y
**Junction Headlosses**

Junction headlosses includes the following:

- **Structure Headloss on page 8-488**
- **Special Assumptions on page 8-490**

**Structure Headloss**

When water flows through a junction structure, there are headlosses associated with mixing, change of direction, and so forth. This section deals with the computation of these losses based on the following popular methods:

- Absolute
- Standard
- HEC-22 Energy
- Generic
- Flow-Headloss Curve

Structure headlosses are used to determine the hydraulic grade to use as the tailwater condition for upstream pipes during the backwater analysis. With the exception of the HEC-22 Energy method, the headloss through the structure is assumed to be the same for each incoming pipe.

**Headloss - Absolute Method**

The absolute method is the simplest of the headloss methods. The structure headloss becomes an editable value, which is then used during calculations. No computations relating to velocity, confluence angle, or other factors are needed.

**Headloss - Standard Method**

The standard method calculates structure headloss based on the exit pipe's velocity. The exit velocity head is multiplied by a user-entered coefficient to determine the loss:

\[ h_s = K \cdot \frac{V_o^2}{2g} \]

Where:

- \( h_s \) = Structure headloss (ft, m)
• $V_O$ = Exit pipe velocity (ft/s, m/s)
• $g$ = Gravitational acceleration constant (ft/s2, m/s2)
• $K$ = Headloss coefficient (unitless)

For suggested coefficient values for various structure configurations, see the Typical Headloss Coefficient table at the end of this chapter.

**Headloss - Generic Method**

The generic method computes the structure headloss by multiplying the velocity head of the exit pipe by the user-entered downstream coefficient and then subtracting the velocity head of the governing upstream pipe multiplied by the user-entered upstream coefficient.

$$h_s = K_0 \cdot \frac{V_o^2}{2g} - K_1 \cdot \frac{V_1^2}{2g}$$

Where:
• $h_s$ = Structure headloss (ft, m)
• $V_o$ = Exit pipe velocity (ft/s, m/s)
• $K_0$ = Downstream coefficient (unitless)
• $V_1$ = Governing upstream pipe velocity (ft/s, m/s)
• $K_1$ = Upstream coefficient (unitless)
• $g$ = Gravitational acceleration constant (ft/s2, m/s2)

If there are multiple upstream pipes entering the junction then the program must choose one of the pipes to use in the calculation. The pipe that is chosen is considered the governing upstream pipe. The governing upstream pipe is selected based on one of the following methodologies:

• The upstream pipe with the maximum flow times velocity
• The upstream pipe with the maximum velocity head
• The upstream pipe with the minimum bend angle

The default method for selecting the governing upstream pipe is to choose the pipe with the maximum flow times velocity. However, the user can select one of the other options through the generic structure loss options.
Headloss-HEC-22 Energy Method

Similar to the standard method, the HEC-22 Energy method (from the FHWA’s Urban Drainage Design Manual, Hydraulic Engineering Circular No. 22) correlates structure headloss to the velocity head in the outlet pipe using a coefficient. Experimental studies have determined that this coefficient can be approximated by:

\[ K = K_0 C_D C_d C_Q C_p C_B \]

Where:

- \( K \) = Adjusted headloss coefficient
- \( K_0 \) = Initial headloss coefficient based on relative junction size
- \( C_D \) = Correction factor for the pipe diameter
- \( C_d \) = Correction factor for flow depth
- \( C_Q \) = Correction for relative flow
- \( C_p \) = Correction for plunging flow
- \( C_B \) = Correction factor for benching

Headloss - Flow-Headloss Curve Method

In this method, the user defines a curve where a given flow rate causes a resultant headloss.

Special Assumptions

The HEC-22 Energy method documentation is written with a limited range of applicability. Many of the equations are written on the basis of pipe diameter, structure diameter, and so on. Since StormCAD and SewerCAD offer non-circular pipes and non-circular structures, this creates the need for some interpretation of the term "diameter."

In some cases, the intent of the methodology is to compare the size of one pipe to another pipe, or to the size of a structure. In these cases an equivalent diameter is used, which is computed from the full area of the pipe or structure. Equivalent diameter is the diameter of a circle with the area equal to the area of the examined pipe or structure.

In other cases, the intent of the methodology is to compare depths within the structure. For these cases, the rise (height) of the pipes is used in place of "diameter."
Pressure Flow, Free Surface Flow, and Transitional Flow

Throughout the documentation for HEC-22 Energy losses, you will see references to "pressure flow", "free surface flow", and "transitional flow".

Pressure flow (submerged flow) is assumed to be any condition for which the depth of water above the outlet pipe invert is greater than 3.2 times the height of the outlet pipe.

Free surface flow (unsubmerged flow) is assumed to be any condition for which the depth of water above the outlet pipe invert is less than the height of the pipe.

Transitional flow is any condition between pressure flow and free surface flow.

Initial Headloss Coefficient

The initial headloss coefficient, which is based on relative junction size, is calculated as:

$$K_o = 0.1 \left( \frac{b}{D_e} \right) \left( 1 - \sin \theta \right) + 1.4 \left( \frac{b}{D_e} \right)^{0.15} \sin \theta$$

Where:

- $\theta$ = Deflection angle between inflow and outflow pipes
- $b$ = Equivalent diameter of the structure (m, ft)
- $D_e$ = Equivalent diameter of the outlet pipe (m, ft)

Note: The angle used in this equation is a deflection angle, so a straight run has a deflection angle of 180°. The bend angle in this case is 0°.

Correction for Pipe Diameter

The correction factor due to differences in pipe size is calculated only for pressure flow situations. For non-pressure situations, a value of 1.0 is used.

$$C_D = \left( \frac{D_o}{D_i} \right)^3$$

Where:

- $D_o$ = Outlet pipe rise (m, ft)
Hydrologic Principles

- \( D_i = \) Inflow pipe rise (m, ft)

**Correction for Flow Depth**

The correction factor for flow depth is used only in cases of free surface flow or transitional flow. For pressure flow, a value of 1.0 is used.

\[
C_d = 0.5 \left( \frac{d_{aho}}{D_e} \right)^{0.6}
\]

Where
- \( d_{aho} = \) Water depth in the structure (m, ft)
- \( D_e = \) Outlet pipe rise (m, ft)

**Correction for Relative Flow**

The correction factor for relative flow is calculated only when the invert elevation for the pipe in question is approximately equal to the invert elevation of the outlet pipe and at least one other pipe. Otherwise, a value of 1.0 is used.

\[
C_Q = \left( 1 - 2 \sin \theta \right) \left( 1 - \frac{Q_i}{Q_o} \right)^{0.75} + 1
\]

Where:
- \( \theta = \) Deflection angle between inflow and outflow pipes
- \( Q_i = \) Flow in the inflow pipe (m³/s, cfs)
- \( Q_o = \) Flow in the outflow pipe (m³/s, cfs)
Note: The term "approximately equal" is quite a vague definition for when to use relative flow corrections. StormCAD and SewerCAD enable you to change the tolerance for "approximately equal" elevations so that you can use your judgment to fine-tune the HEC-22 methodology.

Correction for Plunging Flow

The correction factor for plunging flow accounts for the effect that flow plunging into a junction from another inflow pipe has on the inflow pipe for which the headloss is calculated. It is calculated only when vertical distance from the invert of the plunge pipe to the center of the outflow pipe is greater than the depth in the structure relative to the outlet pipe invert. Otherwise a value of 1.0 is used.

\[
C_p = 1 + 0.2 \left( \frac{h}{D_o} \right) \left( \frac{h - d_{aho}}{D_o} \right)
\]

Where:
- \(C_p\) = Vertical distance from invert of the plunge pipe to the center of the outflow pipe (m, ft)
- \(D_o\) = Outflow pipe rise (m, ft)
- \(d_{aho}\) = Water depth in the junction relative to the outflow pipe invert (m, ft)

Correction for Benching

The correction factor for structure benching is similar to the shaping correction factor used in the AASHTO structure loss method. The correction accounts for smoother transitions from the inflow pipe to the outflow pipe based on the presence (or lack) of shaping in the bottom of the structure.
The following figure represents the four types of benching:

By default, the program uses the values documented in HEC-22 (and presented in the following table) for pressure and free surface flow, but the user can change these values. For transitional flow, the program interpolates from the table linearly, based on the actual ratio of depth in the access hole to the height of the outflow pipe.
Table 8-1: Correction for Benching

<table>
<thead>
<tr>
<th>Bench Type</th>
<th>Correction factor, CB</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Pressure*</td>
</tr>
<tr>
<td>Flat Floor</td>
<td>1.00</td>
</tr>
<tr>
<td>Depressed Floor</td>
<td>1.00</td>
</tr>
<tr>
<td>Half Bench</td>
<td>0.95</td>
</tr>
<tr>
<td>Full Bench</td>
<td>0.75</td>
</tr>
</tbody>
</table>

* pressure flow \[ \frac{d_{aho}}{D_e} > 3.2 \]

** free surface flow \[ \frac{d_{aho}}{D_e} < 1.0 \]

\( d_{aho} \) is the water depth in the structure above an outlet pipe invert and \( D_e \) is the outlet pipe diameter.

**Headloss - AASHTO Method**

The AASHTO method (as defined in the AASHTO Model Drainage Manual) for structure headloss is based on power-loss methodologies. This method can be summarized by the following equation:

\[
    h_s = \left( h_c + h_b + h_e \right) \cdot C_n \cdot C_s
\]

Where:

- \( h_s \) = Structure headloss (m, ft)
- \( h_c \) = Contraction loss (m, ft)
- \( h_b \) = Bend loss (m, ft)
- \( h_e \) = Expansion loss (m, ft)
- \( C_n \) = Correction factor for non-piped flow (unitless)
- \( C_s \) = Correction factor for shaping (unitless).
AASHTO Contraction Loss

The contraction loss is due to flow transitioning from large-area, low-velocity flow to small-area, high-velocity flow, such as flow exiting a structure and entering a downstream pipe. This loss is calculated based on the exit pipe's velocity and a contraction coefficient, as follows:

\[ h_c = K_c \frac{V_o^2}{2g} \]

Where:

- \( h_c \) = Contraction loss (m, ft)
- \( K_c \) = Contraction coefficient (unitless)
- \( V_o \) = Exit pipe velocity (m/s, ft/s)
- \( g \) = Gravitational acceleration constant (m/s², ft/s²)

The contraction coefficient defaults to the AASHTO documented value of 0.25, but can be changed by the user in the Calculation Options.

AASHTO Bend Loss

\[ h_b = \frac{V_o^2}{2g} - \sum \left[ \frac{(1 - K_i) Q_i V_i^2}{Q_o \frac{2g}{2g}} \right] \]

Where:

- \( h_b \) = Bend loss (m, ft)
- \( V_o \) = Outflow pipe velocity (m/s, ft/s)
- \( Q_o \) = Outflow pipe velocity (m³/s, cfs)
- \( V_i \) = Inflow pipe velocity (m/s, ft/s)
- \( Q_i \) = Inflow pipe flow (m³/s, cfs)
- \( g \) = Gravitational acceleration constant (m/s², ft/s²)
- \( K_i \) = Bend factor
Note: The previous equation is a generalized version of the equation as it appears in the AASHTO manual.

The program automatically computes a bend factor based on the angles at which the pipes come together. The program's default bend factors are based on Figure 13-12 of the AASHTO manual, but these values, as with other AASHTO coefficients and corrections, can be changed by the user.

See “Headloss Coefficients for Junctions” on page 13-706.

AASHTO Bend Loss Original Equation

The structure bend loss is computed for each incoming pipe using the following equation from the AASHTO manual. Losses are computed for each incoming pipe, and the greatest value is used.

\[ h_b = K_i \cdot \frac{V_0^2}{2g} \]

Where:

- \( h_b \) = Bend loss (m, ft)
- \( K_i \) = Bend loss coefficient (unitless)
- \( V_0 \) = Incoming pipe's velocity (m/s, ft/s)
- \( g \) = Gravitational acceleration constant (m/s², ft/s²)

The AASHTO manual also documents another bend loss method shown in the following equation. The authors of the AASHTO manual agree that either equation is acceptable. Because of the following equation’s tendency to compute negative bend losses in certain cases, we decided to use the above equation exclusively within this program.

\[ H_{i_2} = \frac{Q_4 V_4^2 - Q_1 V_1^2 - Q_2 V_2^2 + KQ_q V_1^2}{2gQ_4} \]
AASHTO Expansion Loss

Expansion losses are encountered when small-area, high-velocity flow meets a large-area, low-velocity flow, such as a pipe discharging into a structure. To compute this loss, the following equation is used:

\[ h_e = K_e \cdot \frac{V_s^2}{2g} \]

Where:

- \( h_e \) = Expansion loss (m, ft)
- \( K_e \) = Expansion coefficient (unitless)
- \( V_s \) = Most significant incoming pipe's velocity (m/s, ft/s)
- \( g \) = Gravitational acceleration constant (m/s², ft/s²)

The most significant pipe is the pipe that has the greatest product of velocity and discharge, omitting any pipes that have a discharge less than 10% of the structure's outflow. The expansion coefficient defaults to the AASHTO documented value of 0.35, but can be changed by the user.

AASHTO Correction For Non-Piped Flow

If non-piped flow accounts for 10% or more of the total structure outflow, a correction factor is applied to the total loss. By default, this value is a 30% increase in headloss (a factor of 1.3) as documented in the AASHTO manual, but can be changed by the user in the Calculation Options.

AASHTO Correction for Shaping

If the bottom of the structure is shaped to facilitate smoother transitions from inflow pipes to the discharge pipe, a correction factor can be applied to the total loss. By default, this value is a 50% reduction (a factor of 0.5) as documented in the AASHTO manual, but can be changed by the user in the Calculation Options.

Related Topics

- See “Open and Closed Channel Weighting Methods” on page 499.
- See “Note to HEC-2, WSP-2, and WSPRO Users” on page 130.
- See “Rating Table Setup Dialog Box” on page 122.
- See “Rating Curve Setup Dialog Box” on page 123.
• See “Cross Section Report Setup Dialog Box” on page 124.
• See “Cross Section Dialog Box” on page 125.
• See “Irregular Section Editor Dialog Box” on page 126.

Manhole Head Loss Equations (AASHTO/HEC-2 Overview)

The ’HEC-22’ headloss method used in StormCAD V8i is based on the FHWA’s Urban Drainage Design Manual, Hydraulic Engineering Circular No. 22 (HEC-22) energy-loss methodology. This method computes an adjusted headloss coefficient by multiplying the initial headloss coefficient by correction factors for diameter, flow depth, relative flow, plunging flow and benching (Structure Headloss). This adjusted headloss coefficient is then multiplied by the velocity head in the outlet pipe to determine the total junction headloss. This is the method outlined in the current edition of the HEC-22 document (HEC-22, Second Edition, August 2001).

The `AASHTO' headloss method used in StormCAD V8i was originally implemented based on the 1991 version of the AASHTO Model Drainage Manual. This method determines the total junction headloss by adding the contraction, bend and expansion losses at a junction, then applying correction factors for non-piped flow and shaping if applicable (Headloss - AASHTO Method). More recently, the AASHTO Model Drainage Manual has dropped this method in favor of the method described in HEC-22, Second Edition (August 2001). However for compatibility with earlier versions of StormCAD V8i, and also with the various state and regional drainage authorities who continue to use the original AASHTO headloss method, the `AASHTO' headloss method in StormCAD V8i is still based on the 1991 version of the AASHTO Model Drainage Manual.

8.0.1 Open and Closed Channel Weighting Methods

Bentley StormCAD V8i uses the following weighting methods:

• Pavlovskii’s Method—The Pavlovskii method may be used for open channel as well as closed top irregular channels.

\[ n = \sqrt{\frac{\sum_{1}^{N} \left( P_n h_n^2 \right)}{P}} = \sqrt{\frac{P h_1^2 + P h_2^2 + \ldots + P h_N^2}{P}} \]  

(8.1)
Hydrologic Principles

Where

\[ n \] = Roughness coefficient

\[ P \] = Weighted perimeter

Subscripts represents subdivisions of one given section

- **Horton’s Method**—The Horton composite roughness equation is normally used for solving closed top irregular channels such as custom arches or cunnette conduit sections. This equation is also applied in certain specific situations to open channels where steep banks or wide flat floodplains are encountered.

\[
n = \frac{1}{P} \left( \frac{P_N n_N}{1.5} \right)^{2/3} \left( P n^{1.5} + P n^{1.5} + \ldots + P n^{1.5} \right)^{2/3} \]

\[ \frac{\bar{L}}{L} \]

(8.2)

Where

\[ n \] = Roughness coefficient

\[ P \] = Wetted perimeter

Subscripts represents subdivisions of one given section

- **Colebatch Method**—The Colebatch equation is normally used for open, irregular channels such as natural floodplains.

\[
n = \frac{1}{A} \left( \frac{A_N n_N}{1.5} \right)^{2/3} \left( A n^{1.5} + A n^{1.5} + \ldots + A n^{1.5} \right)^{2/3} \]

\[ \frac{\bar{L}}{L} \]

(8.3)

Where

\[ n \] = Roughness coefficient

\[ A \] = Flow area

Subscripts represents subdivisions of one given section
- **Cox Method**—The Cox equation is normally used for open, irregular channels such as natural floodplains.

\[
n = \sum_{i=1}^{N} \left( A_i n_i \right) = \frac{A_1 n_1 + A_2 n_2 + \ldots + A_N n_N}{A}
\]  

(8.4)

Where:
- \( n \) = Roughness coefficient
- \( A \) = Flow area

Subscripts represents subdivisions of one given section

- **Lotter Method**—The Lotter equation is normally used for open, irregular channels such as natural floodplains.

\[
n = \sum_{i=1}^{N} \left( \frac{P R_i^{5/3}}{P R_N^{5/3}} \right) = \frac{PR^{5/3}}{A}
\]  

\[
= \sum_{i=1}^{N} \left( \frac{P R_i^{5/3}}{n_1} + \frac{P R_2^{5/3}}{n_2} + \ldots + \frac{P R_N^{5/3}}{n_N} \right)
\]  

(8.5)
Where

\[ n \] = Roughness coefficient  \\
\[ P \] = Wetted perimeter  \\
\[ R \] = Hydraulic radius

Subscripts represents subdivisions of one given section

- **Improved Lotter Method**—This method uses a combination of the Horton and Lotter equations. Because both methods are based on Manning’s conveyance equations, it is recommended that you use Manning’s friction method for irregular channels.

Improved Lotter Method uses a weighted roughness method for solving uniform flow equations unlike most standard step backwater programs (HEC-2, WSP-2, and WSPRO), which use a segmented conveyance method. Improved Lotter weighted roughness method is more general and, unlike the step backwater programs, can be used for both open channel sections and closed sections. Improved Lotter Method will produce results similar to the segmented conveyance method (HEC-2, WSP-2, WSPRO) except for the following two cases:

Sections containing steep vertical segments or flat shallow submerged overbanks intersected by water surface. The segmented conveyance method (HEC-2, WSP-2, and WSPRO) tends to underestimate effective roughness, and in many instances the effective weighted roughness will be actually lower than any of the input segment roughnesses. Bentley StormCAD V8i’s weighted roughness method avoids underestimating effective roughness by combining adjacent segments using Horton's equation in a manner similar to the method applied for subdivided main channels with banks steeper than 5H:1V as documented in Section 2.3 of the HEC-2 User's Manual (September, 1990). Unlike HEC-2, Improved Lotter Method does not confine this correction to the main channel, but will make this adjustment at any location in the section. Improved Lotter Method also dynamically adjusts its flatness and steepness checks ensuring that computed roughness values will always be higher than the minimum input value encountered over the wetter flow area. For these situations, Improved Lotter Method yields a higher effective weighted roughness for the total section than the segmented conveyance method.

### 8.1 Inlet Hydraulics

Bentley StormCAD V8i considers the following inlet hydraulic principles:

- [HEC-22 Inlet Capacity Calculations on page 8-503](#)
- [Flows in Gutters on Grade on page 8-507](#)
8.1.1 HEC-22 Inlet Capacity Calculations

Note: Pavement drainage requires consideration of gutter flow and inlet capacity. The design of these elements is dependent on storm frequency and the allowable spread of storm water on the pavement surface.

The primary methodology used by Bentley StormCAD V8i to perform pavement drainage and inlet computations is described in Chapter 4 of the HEC-22 manual: Urban Drainage Design Manual, 1996. This chapter is included as Pavement Drainage on page 6-183. Related charts can be found in Engineer’s Reference on page 8-307. Most of the information presented in HEC-22 Chapter 4 was originally published in the 2nd edition, August 2001 Pub No FHWA-NHI-01-021FHWA, and AASHTO’s Model Drainage Manual, 1991.

This section presents an overview of the HEC-22 methodology used by Bentley StormCAD V8i. For more information, refer to Pavement Drainage on page 6-183 or the HEC-22 documentation.

Note: UK Grating and Kerb inlet capacity calculations follow the methodology set out in HA102/00 - Spacing of Road Gullies (November 2000). See “UK Grating and Kerb Inlets” for more information.

UK Grating and Kerb Inlets

StormCAD V8i offers two inlet types that are specifically designed for use in the United Kingdom - "Grating (UK)" and "Kerb (UK)". These inlet capacities for these inlet types are calculated in accordance with the methodology set out in the Design Manual for Roads and Bridges, Volume 4, Section 2, Part 3 : HA 102/00 - Spacing of Road Gullies (Highways Agency, 2000).
**Grating (UK) Inlets**

The flow collection efficiency for a 'Grating (UK)' inlet type is given by:

\[ \eta = 100 - G_d(Q/H) \]

*Where:*

- \( \eta \) = efficiency (\%)
- \( G_d \) = the grating parameter design value (see below)
- \( Q \) = the flow rate approaching the grating (m\(^2\)/s)
- \( H \) = the water depth against the kerb (m)

The flow rate, \( Q \), and the water depth, \( H \), are calculated in accordance with the procedures described in *Flows in Gutters on Grade*.

The grating parameter, \( G \) (s/m\(^2\)) is given by:

\[ G = \frac{69C_b}{A_g^{0.75} \sqrt{p}} \]

*Where:*

- \( C_b \) = grating bar pattern coefficient (equals 1.75 for transverse bars and 1.5 for other bar alignments, i.e. longitudinal, diagonal and bars curved in plan)
- \( A_g \) = the area (in m\(^2\)) of the smallest rectangle parallel to the kerb that just includes all the grating slots
- \( p \) = the waterway area (grate opening area) as a percentage of the grating area, \( A_g \)

The grating parameter for use in design, \( G_d \), is determined using the table below:

<table>
<thead>
<tr>
<th>Grating Type</th>
<th>P</th>
<th>Q</th>
<th>R</th>
<th>S</th>
<th>T</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range if ( G ) (s/m(^2))</td>
<td>( \leq 30 )</td>
<td>30.1 - 45</td>
<td>45.1 - 60</td>
<td>60.1 - 80</td>
<td>80.1 - 110</td>
</tr>
<tr>
<td>Design value ( G_d )</td>
<td>30</td>
<td>45</td>
<td>60</td>
<td>80</td>
<td>110</td>
</tr>
</tbody>
</table>

The design method is intended to be applied over a range of efficiencies between 100\% and 50\%. Below 50\% the method become increasingly conservative.
For 'Grating (UK)' inlets on grade, if the efficiency is below about 60% the inlet is not very efficient and the design should be reconsidered.

For 'Grating (UK)' inlets in sag, the same equation is used as for inlets on grade. However, by definition, sag inlets should capture all flow directed to them, so the efficiency of grating inlets in sag should be greater than 95% for effective drainage. If the grating inlet in sag is less than 100% efficient, any flow that isn't captured is either directed down a connected gutter link, or, if there is no gutter, is lost from the system.

For inlets in sag, it is recommended that a 'Grate' inlet type is used (as opposed to the 'Grating (UK)' inlet type). The 'Grate' inlet type uses the HEC-22 methodology which treats the inlet in sag as either a weir or orifice (depending on the water depth), and should give more accurate results. For more information, see Grate Inlet in Sag.

**Kerb (UK Inlets)**

The flow collection efficiency of a 'Kerb (UK)' inlet type is given by:

$$\eta = 100 - \frac{36.1Q}{L_iH^{1.5}}$$

Where:

- $Q$ = the flow rate in the kerb channel just upstream of the gully (m$^3$/s)
- $H$ = The water depth against the kerb (m)
- $L_i$ = the length of the opening in the line of the kerb provided by the inlet (m)

The flow rate, $Q$, and the water depth, $H$, are calculated in accordance with the procedures described in Flows in Gutters on Grade.
Inlet Hydraulics

The opening length, \( L_i \), is entered by the user. In the case of straight kerb inlet, \( L_i \) simply equals the length of the kerb opening. For angled kerb inlets, \( L_i \) is longer than the kerb opening as shown in the figure below.

![Plan view diagram]

Source: (Highways Agency, 2000)

For 'Kerb (UK)' inlets on grade, if the efficiency is below about 60% the inlet is not very efficient and the design should be reconsidered.

For 'Kerb (UK)' inlets in sag, the same equation is used as for inlets on grade. However, by definition, sag inlets should capture all flow directed to them, so the efficiency of kerb inlets in sag should be greater than 95% for effective drainage. If the kerb inlet in sag is less than 100% efficient, any flow that isn't captured is either directed down a connected gutter link, or, if there is no gutter, is lost from the system.
Note: For inlets in sag, it is recommended that a “Curb’ inlet type is used (as opposed to the ‘Kerb (UK)’ inlet type). The ‘Curb’ inlet type uses the HEC-22 methodology which treats the inlet in sag as either a weir or orifice (depending on the water depth), and should give more accurate results. For more information, see Curb Inlet in Sag

8.1.2 Flows in Gutters on Grade

Flows in gutters on grade includes:

- Uniform Gutter Cross Slope on page 8-507
- Composite Gutter Section on page 8-509

Uniform Gutter Cross Slope

In the case of a uniform cross-slope (gutter slope \( S_w \) equal to pavement slope \( S_x \)), the relationship between the gutter flow \( Q \) and the flow spread \( T \) is obtained by applying the Manning’s equation, assuming normal flow:

\[
Q = \frac{K_c}{n} S_x^{1.67} S_L^{0.5} T^{2.67}
\]

(8.6)
Where

\[ Q \quad = \quad \text{Flow rate (m}^3/\text{sec., ft}^3/\text{sec.)} \]

\[ K_c \quad = \quad 0.376 \text{ SI, 0.56 U.S. customary} \]

\[ n \quad = \quad \text{Manning’s coefficient} \]

\[ S_x \quad = \quad \text{Pavement cross-slope (m/m, ft/ft)} \]

\[ S_L \quad = \quad \text{Longitudinal pavement slope (m/m, ft/ft)} \]

\[ T \quad = \quad \text{Width of flow—spread (m, ft)} \]

**Figure 8-2: Uniform Gutter Cross Slope**

The flow depth along the curb is:

\[ d = TS_x \quad \text{(8.7)} \]

Where \[ d \quad = \quad \text{Depth of flow at curb (m, ft)} \]

The coefficient \( E \), as well as the variables \( Q_w \) and \( Q_s \), are introduced as:

\[ Q_w = E_0 Q \quad \text{(8.8)} \]

\[ Q_s = Q - Q_w = (1 - E_0)Q \quad \text{(8.9)} \]

\[ E_0 = 1 - (1 - W_g/T)^{2.67} \quad \text{(8.10)} \]
Where

\[ Q = \] Total pavement flow (m³/sec., ft³/sec.)
\[ Q_w = \] Frontal flow—portion of the flow over the grate width (m³/sec., ft³/sec.)
\[ E_0 = \] Ratio of flow above the grate to total flow
\[ Q_s = \] Side flow—flow outside the grate width (m³/sec., ft³/sec.)
\[ W_g = \] Grate width (m, ft)

**Composite Gutter Section**

![Diagram of Composite Gutter Section](image)

**Figure 8-3: Composite Gutter Section**

In the case of a composite gutter section, the coefficient \( E_0 \), as well as the variables \( Q_w \) and \( Q_s \), are defined as:

\[ Q_w = E_0Q \]  \hspace{1cm} (8.11)

\[ Q_s = Q - Q_w = (1 - E_0)Q \]  \hspace{1cm} (8.12)
Where

- \( Q \) = Total pavement flow (m\(^3\)/sec., ft\(^3\)/sec.)
- \( Q_w \) = Frontal flow—portion of the flow in the depressed gutter (m\(^3\)/sec., ft\(^3\)/sec.)
- \( E_0 \) = Ratio of flow in the depressed gutter to total flow
- \( Q_s \) = Side flow—flow outside the depressed gutter (m\(^3\)/sec., ft\(^3\)/sec.)

\( E_0 \) can then be derived from Manning’s equation as:

\[
E_0 = \frac{1}{1 + \frac{S_w}{S_x}} + \frac{S_w/S_x}{(1/\beta) - 1} + \frac{2.67}{\alpha} - \frac{1}{\beta}
\]

(8.13)

Where
- \( S_w \) = Gutter cross-slope (m/m, ft/ft)
- \( W \) = Width of depressed gutter—or grate, if it is smaller (m, ft)

The continuously depressed gutter is also sometimes defined by a gutter depression, \( a \), defined as:

\[
S_w = S_x + \frac{a}{1000W} \quad \text{SI Units}
\]

(8.14)

\[
S_w = S_x + \frac{a}{12W} \quad \text{U.S. Customary Units}
\]

(8.15)

Where
- \( a \) = Gutter depression (mm, in)

Gutter depression is the depression of the gutter relative to the street cross-slope projection. It is also identified as a continuously depressed gutter because the gutter is depressed along its full length.
The discharge $Q$ in a ditch or median section is expressed as:

$$Q = \frac{K_c \beta d + \frac{z_1 + z_2}{2} d^{\frac{1}{3}} \left(1 + \frac{2}{S_L} \right)^{\frac{1}{2}}}{n \beta d + d \left(\sqrt{1 + \frac{z_1^2}{2}} + \sqrt{1 + \frac{z_2^2}{2}}\right)}$$

(8.16)

Where

- $Q$ = Discharge rate ($m^3/sec., ft^3/sec.$)
- $K_c$ = 1.0 SI, 1.486 U.S. customary
- $n$ = Manning’s coefficient
- $B$ = Ditch width (m, ft)
- $d$ = Water depth (m, ft)
- $z_1, z_2$ = Ratio $H:V$ for ditch side slopes (m/m, ft/ft)
- $S_L$ = Ditch longitudinal slope (m/m, ft/ft)

The ratio $E_0$ of frontal flow (over the grate) to total flow is:

$$E_0 = \frac{W}{B + d \frac{z_1 + z_2}{2}}$$

(8.17)

Where

- $W$ = Grate width (m, ft)
8.1.4 Inlet Analysis

Inlets are divided into 4 categories, as illustrated in the following figure:

![Diagram of inlet types](image)

- a. Grate Inlet
- b. Curb Opening Inlet
- c. Combination Inlet
- d. Slotted Drain Inlet

**Figure 8-5: Inlet Types**

For details on each type of inlet, refer to the HEC-22 Manual, Chapter 4 (see Pave-
ment Drainage on page 6-183).
Note: Do not confuse gutter depression and local depression:

The gutter depression is the depression of the gutter relative to the pavement normal cross-slope named a on the figure below, which shows a gutter and inlet cross section. It is also referred to as a continuously depressed gutter.

The local depression is the depression at the location of the inlet (a' in the figure below). It does not exist in the gutter upstream or downstream of the inlet. It is measured from the gutter slope.

Figure 8-6: Continuous Gutter Depression and Local Depression

Figure 9.6 illustrates the concept of local depression versus gutter depression used by HEC-22, with:

\[ a_{\text{total}} = a + a' \]  \hspace{1cm} (8.18)

Where

- \( a \) = Gutter depression (mm, in)
- \( a' \) = Local depression (mm, in)
- \( a_{\text{total}} \) = Total depression at location of inlet (mm, in)

Inlets on Grade

Inlets located on a grade \( (S_L > 0) \) are characterized by an efficiency, \( E \), for a given set of conditions:

\[ E = \frac{Q_i}{Q} \]  \hspace{1cm} (8.19)
Where  

- **E** = Inlet efficiency (unitless)
- **Q** = Total gutter flow (m³/sec., ft³/sec.)
- **Qᵢ** = Intercepted flow (m³/sec., ft³/sec.)

The flow that is not intercepted is called carryover or bypass flow. It is defined as follows:

\[
Q_b = Q - Q_i
\]  
\(8.20\)

Where  

- **Qₜ** = Bypass flow (m³/sec., ft³/sec.)

### 8.1.5 Grate Inlet on Grade

![Grate Inlet](image)

**Figure 8-7: Grate Inlet**

As previously defined, the total gutter flow, **Q**, is composed of a frontal flow **Q₟** and a side flow **Qₛ**.

The ratio **Rᵢ** of frontal flow intercepted to total frontal flow is expressed as:

\[
Rᵢ = 1 - Kcf (V - V₀)
\]  
\(8.21\)

Where  

- **Kcf** = 0.295 SI, 0.090 U.S. customary
- **V** = Average velocity in gutter (m/sec., ft/sec.)
- **V₀** = Gutter velocity at which splash-over first happens (m/sec., ft/sec.)
Theory

Note: If \( V < V_0 \), then \( R_f = 1 \) (all the frontal flow is intercepted).

Also, \( R_f \) cannot exceed 1.0. The splash-over velocity, \( V_0 \) is a function of the grate type and the grate length, \( L \).

The frontal flow intercepted, \( Q_{wi} \), is:

\[ Q_{wi} = R_f Q_w \]

The ratio \( R_s \) of side flow intercepted to side flow is expressed as:

\[ R_s = 1 / \left( 1 + \frac{K_{cs} V^{1.8}}{S_L^{2.3}} \right) \]

(8.22)

Where \( K_{cs} = 0.0828 \) SI, 0.15 U.S. customary

\( L = \) Grate length (m, ft)

The side flow intercepted, \( Q_{si} \), is therefore:

\[ Q_{si} = R_s Q_s \]

(8.23)

The total flow intercepted is:

\[ Q_i = Q_{wi} + Q_{si} \]

(8.24)

Where \( Q_i \) = Total flow intercepted (m\(^3\)/sec., ft\(^3\)/sec.)

The bypass flow is then:

\[ Q_b = Q - Q_i \]

(8.25)

Where \( Q_b \) = Bypass flow (m\(^3\)/sec., ft\(^3\)/sec.)

The efficiency of the grate is expressed as:

\[ E = R_f E_0 + R_s (1 - E_0) \]

(8.26)
Or,

\[ E = \frac{Q_i}{Q} \quad (8.27) \]

### 8.1.6 Curb Inlet on Grade

![Diagram of Curb Inlet](image)

**Figure 8-8: Curb Inlet**

The curb opening length \( L_T \) that would be required to intercept 100\% of a flow \( Q \) on a pavement with a uniform cross slope is computed as:

\[ L_T = K_c Q^{0.42} S^0.3 \left( \frac{1}{h S_x} \right)^{0.6} \quad (8.28) \]

Where

- \( L_T \) = Curb opening length required to intercept 100\% of gutter flow
- \( K_c \) = 0.817 SI, 0.60 U.S. customary

In order to account for a locally or continually depressed gutter, an equivalent cross slope, \( S_e \), is computed.

\[ S_e = S_x + S_w E_o \]

where:

- \( E_o \) = ratio of flow in the depressed section to gutter flow
- \( S'_w \) = cross slope of the gutter measured from the cross slope of the pavement, \( S_x \)
- \( a \) = gutter depression (in)
Figure 8-9: Composite Gutter Section

$S'_w$ is calculated as:

$$S'_w = \frac{a_{total}}{1000W} \text{ SI Units}$$  (8.29)

$$S'_w = \frac{a_{total}}{12W} \text{ U.S. Customary Units}$$  (8.30)

Where

- $S'_w$ = Gutter cross-slope at inlet location—measured from pavement cross-slope (m/m, ft/ft)
- $S_w$ = Gutter cross-slope upstream of inlet—does not account for local depression (m/m, ft/ft)
- $a_{total}$ = Total depression at inlet location—including local and continuous gutter depression (mm, in)
- $W$ = Larger of the gutter width and local-depression width (m, ft)

The curb opening length $L_T$ that would be required to intercept 100% of a flow $Q$ on a pavement with a composite cross slope at the location of the inlet is:

$$L_T = K_T Q^{0.42} S_L^{0.3} \frac{1}{\xi n S_e} ^{0.6}$$  (8.31)

The efficiency $E$ of a curb opening shorter than the required length for total interception is:
\[ E = 1 - \frac{1}{L} \left( 1 - \frac{L^{1.8}}{L_T^{1.8}} \right) \]  

(8.32)

Where  \( L \) = Curb opening length (m, ft)

### 8.1.7 Slot Inlet on Grade

![Figure 8-10: Slot Inlet](image)

The efficiency of a Slotted Inlet on Grade with an opening width greater than or equal to 45 mm (1.75 in) is calculated using the same equations as for a curb opening inlet of the same length.

### 8.1.8 Combination Inlet on Grade

![Figure 8-11: Combination Inlet](image)

HEC-22 distinguishes two cases:
• The grate and the curb opening are placed side by side. In this case, the flow interception by the curb opening is negligible, and the capacity of the combination inlet is identical to that of the grate alone.

• The curb opening is extended upstream of the grate in order to intercept debris that could otherwise clog the grate inlet. The flow intercepted by the combination inlet is calculated as the flow intercepted by the curb opening upstream of the grate inlet, plus the portion of the remaining flow intercepted by the grate.

**Inlets in Sag**

*Note:* Inlets in sag location operate as weirs at low water depth and as orifices at higher depth.

Grate inlets alone are not recommended, as clogging of the grate is likely to occur.

In contrast with inlets on grade, the efficiency of an inlet located in sag is always assumed to be 1.0 (or 100%).

### 8.1.9 Grate Inlet in Sag

![Grate Inlet](image)

**Figure 8-12: Grate Inlet**

The flow $Q_w$ intercepted by a grate inlet operating as a weir is:

$$Q_w = C_w 2Wd^{1.5} + C_w Ld^{1.5}$$

(8.33)
Inlet Hydraulics

Where

\[ \begin{align*}
W &= \text{Width of the grate (m, ft)} \\
L &= \text{Length of the grate (m, ft)} \\
C_W &= \text{Weir Coefficient (1.66 SI, 3.0 U.S. customary)} \\
d1 &= \text{Flow depth at middle of grate (m, ft)} \\
d2 &= \text{Flow depth at side of grate opposite the curb (m, ft)}
\end{align*} \]

The flow \( Q_{io} \) intercepted by a grate inlet operating as an orifice is:

\[ Q = 0.67AgP(2gd)^{1/2} \]  \hspace{1cm} (8.34)

Where

\[ \begin{align*}
Q &= \text{Capacity of the grate operating as an orifice (cfs, m}^3\text{s)} \\
A &= \text{Clear opening area of grate (ft}^2, \text{m}^2) \\
d &= \text{Average depth of flow over grate (ft, m)} \\
g &= \text{Acceleration due to gravity (ft/s}^2, \text{m/s}^2)
\end{align*} \]

The intercepted flow \( Q_i \) is conservatively calculated at any flow depth by using the lesser of the intercepted flows computed using the weir or orifice equation:

\[ Q_i = \min(Q_{iw}, Q_{io}) \]  \hspace{1cm} (8.35)

This accounts for the three stages: weir flow, orifice flow and transitional flow.

8.1.10 Curb Inlet in Sag

Figure 8-13: Curb Inlet
Curb inlets are divided into 3 categories, based on their throat geometry: horizontal (most common), vertical, and inclined, as defined in the figure below.

![Diagram of curb inlets: a. Horizontal Throat, b. Inclined Throat, c. Vertical Throat]

**Figure 8-14: Curb Inlet Throat Types**

Where

- $h$ = Height of curb-opening inlet (m, ft)
- $d_i$ = Water depth at lip of curb (m, ft)
- $d_o$ = Effective head, measured from center of orifice throat (m, ft)
- $\Theta$ = Throat angle for inclined-throat inlets

**Weir Flow**

A curb inlet in a sag, without a locally or continuously depressed gutter, operates as a weir for depths at curb (measured from the normal cross slope) that are less than or equal to the curb opening height.

This condition can be expressed as:

$$d \leq h$$  \hspace{1cm} (8.36)

Where $d$ = Depth at curb—i.e., $d = TS_x$ (m, ft)

In the case of a depressed curb opening (local depression) or a continuously depressed gutter, the previous condition becomes:
Inlet Hydraulics

\[ d + \frac{d_{\text{total}}}{1000} \xi h \]  
U.S. Customary SI Units \hspace{1cm} (8.37)

Where \[ d \] = Total depression, measured at inlet (mm, in)
\[ D \] = Depth at curb, measured from normal cross-slope (m, ft)

The intercepted flow \( Q_{iw} \) by a curb-opening inlet operating as a weir, with a locally or continuously depressed gutter, is:

\[ Q_{iw} = C_{w1}(L + 1.8W) d^{1.5} \]  
(8.38)

Where \[ C_{w1} \] = Weir coefficient (1.25 SI, 2.3 U.S. customary)
\[ L \] = Curb-opening length (m, ft)
\[ W \] = Lateral width of depression (m, ft)

However, if \( L \) is greater than or equal to 3.6 m (12 ft), then the following equation is used, which is the same as the equation for curb-opening inlets without depression:

\[ Q_{iw} = C_{w2}Ld^{1.5} \]  
(8.39)

Where \[ C_{w2} \] = Weir coefficient (1.6 SI, 3.0 U.S. customary)

**Orifice Flow**

A curb inlet in a sump operates as an orifice for depths at the lip of a curb opening that are greater than 1.4 times the curb opening height:

\[ d_i \geq 1.4h \]  
(8.40)

The intercepted flow \( Q_{io} \) by a curb-opening inlet (depressed or undepressed) operating as an orifice is:

\[ Q_{io} = C_{o}hL(2gd_o)^{0.5} \]  
(8.41)

which is also expressed as:
Theory

\[ Q_{io} = C \cdot h \cdot L \cdot g \cdot \frac{d}{L} - \frac{h}{2} \cdot \sin \left( \frac{d}{h} \right)^{0.5} \]  

(8.42)

Where \( \Theta = 90^\circ \) for horizontal-throat inlets, \( 0^\circ \) for vertical-throat inlets

**Transition Flow**

At depths between 1.0 and 1.4 times the opening height, the flow is in a transition stage.

This intercepted flow \( Q_i \) is calculated conservatively in this depth range as:

\[ Q_i = \min(Q_{iw}, Q_{io}) \]  

(8.43)

### 8.1.11 Slot Inlet in Sag

Slot inlet in sag includes:

- [Weir Flow on page 8-521](#)
- [Orifice Flow on page 8-524](#)
- [Transitional Flow on page 8-524](#)

**Weir Flow**

Slotted inlets located in sag operate as weirs to water depths, \( d \) (measured at the curb from the normal cross slope), of about 0.06 m (0.2ft).

The intercepted flow \( Q_{iw} \) is expressed as:

\[ Q_{iw} = C_w \cdot L \cdot d^{1.5} \]  

(8.44)

Where \( C_w = \) Weir coefficient—varies with flow depth and slot length (typically 1.4 SI, 2.48 U.S. customary)

\( d = \) Water depth at curb, measured from normal cross slope (m, ft)

\( L = \) Slot length (m, ft)
Orifice Flow

At water depths (measured at the curb) greater than about 0.12 m (0.4 ft), slotted inlets perform as orifices.

The intercepted flow $Q_{io}$ is expressed as:

$$Q_{io} = 0.8W(2gd)^{0.5} \quad (8.45)$$

Where $W$ = Slot width (m, ft)
$d$ = Water depth at slot (m, ft)

Transitional Flow

At depths between 0.06 m (measured at the slot from the normal cross slope) and 0.12 m, the flow is in a transition stage.

The intercepted flow $Q_i$ is conservatively calculated in this depth range as:

$$Q_i = \min(Q_{iw}, Q_{io}) \quad (8.46)$$

8.1.12 Combination Inlet in Sag

According to HEC-22, combination inlets are considered advisable for use in sags where hazardous ponding occurs.

Equal Length Inlets

Equal length inlets refer to a grate inlet placed along the side of a curb-opening inlet of identical length. At lower flow depths, the grate inlet is operating as a weir and the interception capacity of the curb is negligible (unless the grate is clogged, in which case the curb is intercepting some flow). The flow $Q_{iw}$ intercepted by the combination is then:

$$Q_{iw} = C_wPd^{1.5} \quad (8.47)$$

Where $C_w$ = Weir coefficient (typically 1.66 SI, 3.0 U.S. customary)
$P$ = Perimeter of grate, disregarding side along curb (m, ft)
$d$ = Flow depth at curb (m, ft)
At higher flow depths, both the grate inlet and the curb-opening inlet are operating as orifices.

**Note:** The clear opening area of the grate depends on the opening ratio of the grate (HEC-22 defines an opening ratio for each grate type), as well as the clogging factor you specify.

The flow $Q_{io}$ intercepted by the combination inlet operating as an orifice is:

$$Q_{io} = C_o A_g (2gd)^{0.5} + C_o h L (2gd_o)^{0.5}$$

(8.48)

Where

- $C_o$ = Orifice coefficient ($C_o = 0.67$)
- $A_g$ = Clear opening of grate (m$^2$, ft$^2$)
- $g$ = Gravitational acceleration (9.81 m/sec$^2$, 32.16 ft/sec$^2$)
- $h$ = Height of curb-opening inlet (m, ft)
- $d_o$ = Head, measured from the center of the orifice throat (m, ft)

**Sweeper Inlet**

A sweeper inlet refers to a grate inlet placed at the downstream end of a longer curb opening inlet. A sweeper inlet is more efficient than an equal length combination inlet in intercepting debris.

Note that since the HEC-22 manual is not very explicit about this type of inlet in sag, some assumptions were made in order to define the flows for this inlet.

The flow $Q_i$ intercepted by a sweeper inlet is the sum of the flow $Q_{ic}$ as calculated above for an equal length combination inlet of length L (where L is the length of the grate) and the flow $Q_{ic}$ intercepted by the additional length L (upstream of the grate) of the curb opening.

$$Q_i = Q_{io} + Q_{ic}$$

(8.49)

**RELATED TOPICS**

- See “Gauged (Time versus Depth)” on page 522.
- See “Synthetic Rainfall Distributions” on page 527.
- See “Bulletins 70/71” on page 533.
8.2 Time of Concentration

The time of concentration \((T_c)\) is found by summing the time for each individual flow segment within the drainage area. Both single and multiple flow segments are modeled with the \(T_c\) calculator.

\[ T_c = \sum_{i=1}^{n} T_i \]

\[ T_i = \frac{L_i}{V_i} \]

\((8.50)\) \hspace{1cm} \((8.51)\)
Each

\[ L_i = \text{Length of flow segment } i \]

\[ V_i = \text{Average velocity through segment } i \]

The \( T_c \) equations provided in Bentley StormCAD V8i can be categorized into two broad categories:

- Equations that solve for velocity, then use velocity to solve for the travel time through a flow segment
- Equations that directly solve for the travel time through a flow segment—in these cases, Bentley StormCAD V8i back solves for velocity and includes it in the output report

**Note:** Some types of \( T_c \) equations can apply to flow segments within a multiple-segment \( T_c \) calculation (see preceding diagram). Other \( T_c \) methods are equations intended to model the entire average subarea flow distance and slope in one single flow segment. When combining multiple flow segments to compute \( T_c \), it is up to you to only combine \( T_c \) methods that can be modeled in combination with multiple flow segments.

There are 13 different methods for computing the time for an individual flow segment. Each of the 13 methods has different data input requirements:

- User-Defined
- Carter
- Eagleson
- Espey/Winslow
- Federal Aviation Agency
- Kerby/Hathaway
- Kirpich (PA)
- Kirpich (TN)
- Length and Velocity
- SCS Lag
- TR-55 Sheet Flow
- TR-55 Shallow Concentrated Flow
- TR-55 Channel Flow
8.2.1 Minimum Time of Concentration

Certain hydrologic methods for computing runoff hydrographs require the time of concentration to be greater than some minimum value. For example the TR-55 methodology dictates that the minimum $T_c$ to be used is 0.1 hr.

The minimum $T_c$ is used in lieu of the calculated $T_c$ whenever the calculated $T_c$ is smaller than the minimum.

8.2.2 User-Defined

The user-defined time of concentration ($T_c$) is a method that allows the direct input of the $T_c$ rather than using an equation to calculate it. This method would be used when the $T_c$ needs to be calculated using a methodology that is not supported by Bentley StormCAD V8i, or when a quick estimate of $T_c$ is sufficient for the analysis.

8.2.3 Carter

$$T_c = 1.7L_m^{0.6}S_m^{-0.3}$$

(8.52)

Where

- $T_c$ = Time of concentration (hr.)
- $L_m$ = Flow length (mi)
- $S_m$ = Slope (ft/mi)

8.2.4 Eagleson

$$T_c = 0.0001852L_f R^{-2/3} S_f^{-1/2}$$

(8.53)
Where \( T_c \) = Time of concentration (hr.)

\( L_f \) = Flow length (ft)

\( n \) = Manning’s n

\( R \) = Hydraulic radius (ft)

\( S_f \) = Slope (ft/ft)

### 8.2.5 Espey/Winslow

\[
T_c = 0.52 \phi L_f^{0.29} S_f^{-0.145} I_p^{-0.6}
\]

Where \( T_c \) = Time of concentration (hr.)

\( \phi \) = Espey Channelization factor

\( L_f \) = Flow length (ft)

\( S_f \) = Slope (ft/ft)

\( I_p \) = Impervious area (%)

### 8.2.6 Federal Aviation Agency

\[
T_c = 0.03(1.1 - C) L^{0.5} / S^{0.333}
\]

Where \( T_c \) = Time of concentration (hr.)

\( C \) = Rational C coefficient

\( L \) = Length of overland pipe flow (ft)

\( S \) = Slope (%)

### 8.2.7 Kerby/Hathaway
\[ T_c = 0.01377L_f^{0.47}n^{0.47}S_f^{-0.235} \]  

(8.56)

Where  
- \( T_c \) = Time of concentration (hr.)  
- \( L_f \) = Flow length (ft)  
- \( n \) = Manning’s \( n \)  
- \( S_f \) = Slope (ft/ft)

### 8.2.8 Kirpich (PA)

\[ T_c = 0.00002167L_f^{0.77}S_f^{-0.5}M_t \]  

(8.57)

Where  
- \( T_c \) = Time of concentration (hr.)  
- \( L_f \) = Flow length (ft)  
- \( S_f \) = Slope (ft/ft)  
- \( M_t \) = \( T_c \) Multiplier (\( T_c \) adjustment)

### 8.2.9 Kirpich (TN)

\[ T_c = 0.00013L_f^{0.77}S_f^{-0.385}M_t \]  

(8.58)

Where  
- \( T_c \) = Time of concentration (hr.)  
- \( L_f \) = Flow length (ft)  
- \( S_f \) = Slope (ft/ft)  
- \( M_t \) = \( T_c \) Multiplier (\( T_c \) adjustment)
8.2.10  **Length and Velocity**

\[ T_c = \left( \frac{L_f}{V} \right) \left( \frac{1 \text{ hr.}}{3600 \text{ sec.}} \right) \]  

(8.59)

Where:
- \( T_c \) = Time of concentration (hr.)
- \( L_f \) = Flow length (ft)
- \( V \) = Velocity (ft/sec.)

8.2.11  **SCS Lag**

**Note:** There is a factor of 0.6 built into this equation (in the constant 0.0000877) to convert this equation from a lag time to a time of concentration.

\[ T_c = 0.0000877L_f^{0.8} \left( \frac{1000}{\text{CN}} - 9 \right)^{0.7} S_f^{-0.5} \]  

(8.60)

Where:
- \( T_c \) = Time of concentration (hr.)
- \( L_f \) = Flow length (ft)
- \( \text{CN} \) = SCS curve number
- \( S_f \) = Slope (ft/ft)

8.2.12  **TR-55 Sheet Flow**

This number represents the sheet flow time computed for each column of sheet flow data. Flow time for sheet flow is computed as:

\[ T = \frac{0.007(nL)^{0.8}}{(P_2)^{0.5} S_f^{0.4}} \]  

(8.61)
8.2.13 TR-55 Shallow Concentrated Flow

This number represents the sheet flow time computed for each column of shallow concentrated flow data. Flow velocity for this flow time is computed as:

Unpaved Surfaces

\[ V = 16.1345 S_f^{0.5} \]  \hspace{1cm} (8.62)

Paved Surfaces

\[ V = 20.3282 S_f^{0.5} \]  \hspace{1cm} (8.63)

Where \( V \) = Average velocity (ft/sec.)

\( S_f \) = Slope of hydraulic grade line (ft/ft)

\[ T_c = \left( \frac{L_f}{V} \right) \left( \frac{1 \text{ hr.}}{3600 \text{ sec.}} \right) \]  \hspace{1cm} (8.64)

Where \( T_c \) = Time of concentration (hr.)

\( L_f \) = Flow length (ft)

\( V \) = Average velocity (ft/sec.)
8.2.14 TR-55 Channel Flow

This number represents the channel flow time computed for each column of channel flow data. Flow velocity for this flow time is computed as:

\[ T_c = \left( \frac{L_f}{V} \right) \left( \frac{1 \text{ hr.}}{3600 \text{ sec.}} \right) \]  \hspace{1cm} (8.65)

where

\[ V = \frac{1.49 R^{2/3} S_f^{1/2}}{n} \] \hspace{1cm} (8.66)

Where

- \( T_c \) = Time of concentration (hr.)
- \( L_f \) = Flow length (ft)
- \( V \) = Average velocity (ft/sec.)
- \( R \) = Hydraulic radius (ft)
- \( S_f \) = Average slope (ft/ft)
- \( n \) = Manning’s roughness value

8.3 Constraint Based Automatic Design

The Constraint Based Automatic Design section consists of the following topics:

Subsurface Design

Inlet Design

8.3.1 Subsurface Design

The Subsurface Design section consists of the following topics:

- Pipe and Subsurface Node Structure Design
- Part Full Design
- Limit Section Size
• **Pipe Matching**
• **Offset Matching**
• **Drop Structures**
• **Structure Invert Elevations**
• **Design Priorities**

**Pipe and Subsurface Node Structure Design**

This program allows you to automatically design gravity piping and structures. The design is flexible enough to allow you to specify the elements to be designed, from a single pipe size to the entire system, or anything in between.

The design algorithm adjusts invert elevations and the section size of the pipe to meet several constraints, such as allowable ranges of slope, velocity and cover. In general, the design algorithm attempts to minimize pipe size and excavation, which is typically the most expensive part of installing sewer piping and structures.

Some of the other things that are considered include:

• Pipe Matching
• Offset Matching
• Drop Structures
• Structure invert Elevations

The designed pipe will be the smallest available section size from the Engineering Library that meets the constraints and has a capacity greater than its discharge. In a situation where there are no pipe sizes with adequate capacity, the largest available size will be used.

**Part Full Design**

Pipes are designed such that the capacity is greater than the calculated discharge. For standard designs, this capacity is based on full pipe, normal depth - that is, the flow in the pipe when the depth is 100% of the pipe rise.

With partially full design, the designed capacity of the pipe is for a design depth that is only a portion of the pipe rise. In other words, a pipe that is designed for 50% full will be selected based on a depth of half of the pipe's rise.

For example, consider a circular pipe with the following characteristics:

Slope = 0.01 m/m

Roughness n = 0.013
Required flow = 100 l/s

The following table presents several typical section sizes, with their capacities at various depths.

**Table 8-3: Flow Capacities**

<table>
<thead>
<tr>
<th>Nominal Diameter</th>
<th>100% Full</th>
<th>80% Full</th>
<th>50% Full</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Depth (mm)</td>
<td>Capacity (l/s)</td>
<td>Depth (mm)</td>
</tr>
<tr>
<td>300 mm</td>
<td>300</td>
<td>101</td>
<td>240</td>
</tr>
<tr>
<td>375 mm</td>
<td>375</td>
<td>183</td>
<td>300</td>
</tr>
<tr>
<td>450 mm</td>
<td>450</td>
<td>297</td>
<td>360</td>
</tr>
</tbody>
</table>

Depending on the selected percent-full, the smallest available pipe could be for any of the bold values above. Obviously, if the design percentage were something different, an even larger section may be required.

Hydraulically, the capacity at a percentage of pipe rise is generally not equal to that percentage of the full pipe capacity. As can be seen in the table above, 80%-full capacity does not equal 80% of the 100%-full capacity.

For sections that are vertically symmetrical, 50% full is a special case where the wetted perimeter and area are both half that of full flow. This means that the hydraulic radius and velocity are the same for half-full and full flow, resulting in a highly special condition where the 50%-full capacity is actually equal to one half of the 100%-full capacity.
Allow Multiple Sections

Situations may be encountered where the desired capacity cannot be met with a single pipe, due to a limiting maximum section rise, a lack of larger available pipes, or other restrictions. For these situations, the pipe can be designed with multiple barrels. All barrels will have the same physical characteristics.

Multiple barrels will only be used if the design cannot be met by a single available section size, and the pipe allows multiple sections for design. In these cases, the design will increase the number of barrels and attempt to find a section size that meets the capacity, continuing until the capacity is met or the maximum number of barrels is reached.

For example, consider a circular pipe with the following characteristics:

- Slope = 0.01 m/m
- Roughness n = 0.013
- Required flow = 750 l/s
- Maximum Design Section Rise = 700 mm

Assume that the design is for 100% full capacity, allowing up to three barrels of the following section sizes:

<table>
<thead>
<tr>
<th>Diameter (mm)</th>
<th>1 Barrel</th>
<th>2 Barrels</th>
<th>3 Barrels</th>
</tr>
</thead>
<tbody>
<tr>
<td>300</td>
<td>101</td>
<td>No</td>
<td>202</td>
</tr>
<tr>
<td>375</td>
<td>183</td>
<td>No</td>
<td>366</td>
</tr>
<tr>
<td>450</td>
<td>297</td>
<td>No</td>
<td>595</td>
</tr>
<tr>
<td>525</td>
<td>449</td>
<td>No</td>
<td>897</td>
</tr>
<tr>
<td>600</td>
<td>641</td>
<td>No</td>
<td>1281</td>
</tr>
</tbody>
</table>

For these conditions, the selected design would use two 525 mm barrels - the smallest section size within the least number of barrels to meet the capacity criteria.
Limit Section Size

There may be situations in design where it is desired to limit the size of the designed pipe. This may be done to avoid conflicts with obstructions or other utilities, for example. For these situations, the program enables you to limit the maximum section rise that will be selected. A smaller size will be used if possible. If none of the available design sections have a small enough rise, the smallest one will be used.

Pipe Matching

When pipes meet at a structure, it is often desirable to have the pipes at approximately the same elevation. To do this, the program allows you to design your pipes to match inverts or crowns. This means that when the design is done (if a valid design was found), all of the designed pipes entering a structure will have the same invert elevation or crown elevation.

Offset Matching

If an offset value is specified, it represents the desired drop across the structure. The design incorporates this offset, resulting in upstream pipes that are higher than the downstream pipe by the specified offset. Note that all designed upstream pipes will have the same invert or crown elevation.

For example, an offset of 0.1 meter could result in a downstream pipe with an invert of 100.0 meters, and several upstream pipes with invert elevations at 100.1 meters.

Drop Structures

Drop structures are structures at which the incoming pipes are not all at the same elevation, nor do any of them necessarily match the downstream pipe. Including these structures may help to reduce excavation, since the entire upstream system does not need to be as deep.

The program will only use drop structures if you have chosen to allow them, and if a pipe's maximum slope constraint cannot be met. Otherwise, the upstream system will be designed as needed to maintain the desired slope and velocity constraints, which may require significantly lower pipe elevations.

Structure Invert Elevations

The program can adjust structure invert elevations to account for the invert elevations of newly designed pipes, and any desired additional invert depth.

For example, if a structure is to be adjusted with a invert depth of 0.5 meters and the lowest pipe invert is 100.0 meters, the structure invert elevation would be set to 99.5 meters.
**Design Priorities**

Unfortunately, it is not always possible to automate a design that meets all desired constraints. With this in mind, there are certain priorities that are considered when the automated design is performed. These priorities are in place to try to minimize the effect on existing portions of the system while providing appropriate capacity in the designed pipes.

While this sequence does not go into complete detail regarding the design process, it does indicate the general priorities for the automated design. The priorities, of course, only deal with elements that are being designed. If a pipe has fixed inverts or is not to be designed at all, some or all of these criteria obviously do not apply.

**A Designed Pipe Should Fit within Adjacent Existing Structures**

If a pipe connects to an existing structure, the pipe rise should be completely within the existing structure. The only time this may be violated is if there are no available section sizes that would not violate that condition (i.e., the existing structure height is so small that all available pipes have rises too big). In this very unlikely condition, the smallest available section size will be selected, with the invert elevation placed at the bottom of the structure.

**A Designed Pipe Should Not Have a Crown Above an Adjacent Designed Structure**

Where pipe inverts are fixed, it is possible that the required section size would cause the pipe crown to be higher than the top elevation of an adjacent designed structure. If all available pipe section rises are greater than the depth of the pipe invert, the smallest pipe size will be chosen.
**Note:** This situation will only be encountered in situations where the structure's top elevation is set equal to the ground elevation - otherwise, the structure will be designed with a higher top elevation.

Pipe Capacity Should Be Greater Than the Discharge

If the pipe is not limited by adjacent structures, the pipe should be sized such that the design capacity is greater than the calculated discharge in the pipe. The design capacity may be based on one or more pipes, flowing full or part-full, depending on user-set design options. If site restrictions or available section limitations result in a situation where no sections meet the required capacity, the largest available size and number of barrels will be chosen.

**Downstream Pipes Should Be at Least as Large as Upstream Pipes**
Designs typically avoid sizing downstream pipes smaller than upstream pipes, regardless of differing slope and velocity requirements. One of the primary reasons for this is debris that passes through the upstream pipe could become caught in the connecting structure, clogging the sewer.

Good Design (Downstream Pipe’s Diameter ≥ Upstream Pipe Diameter)

Bad Design (Downstream Pipe’s Diameter < Upstream Pipe Diameter)

**Pipe Matching Criteria Downstream Should Be Met**

Whenever possible, the designed pipe should have its downstream invert set such that the pipe meets the matching criteria, such as matching inverts or crowns. Note that because of higher design priorities, such as the pipe fitting within existing structures, the matching criteria may not always be met.

**Minimum Cover Constraint Should Be Met**
Pipe inverts should be set such that the upstream and downstream crowns of the pipe are below the ground elevation by at least the amount of the minimum cover. Note that higher design priorities, such as existing structure locations and matching criteria, may prevent the minimum cover constraint from being met.

**Pipe Matching Criteria Upstream Should Be Met**

The upstream invert of the designed pipe should be set to meet the matching criteria of the upstream structure. Higher design priorities, such as minimum cover constraints, may result in a pipe that does not match upstream as desired.

**Maximum Slope Constraint Should Be Met**

Wherever possible, the designed pipe should not exceed the desired maximum slope. In some situations, elevation differences across the system may result in a case where a drop structure can be used to offset pipes. This is used instead of a pipe that is too steep, or instead of upstream piping that would require much more excavation. Note that the maximum slope constraint may be violated if higher priority design considerations, such as existing structure location or pipe matching criteria, governs.

**Other Constraints and Considerations**

There are many degrees of freedom when designing a piping system. Several constraints that are not mentioned above, such as minimum velocity constraints and minimum slope constraints, may also result in adjustments to the designed pipe. Other constraints may be too limiting, such as maximum cover constraint and maximum velocity, resulting in designed pipes that could violate too many other constraints.

This wide range of choices and priorities emphasizes the need for careful review of any automated design by a professional. It is not always possible to meet every desired condition, so it is very much the responsibility of the engineer to make final judgments and decisions regarding the best design for the client.

### 8.3.2 Inlet Design

The length of any inlet can be automatically designed. The available design lengths (standard lengths) for a given inlet are defined in the inlet library, and can easily be changed. The design algorithm uses the same equations used in analysis to determine the minimum available inlet length that meets the design constraints.

**Designing Inlets on Grade**
Since gutter width and spread are independent of the inlet characteristics, inlets on grade are designed simply to meet the minimum efficiency. If the minimum efficiency cannot be met with any of the lengths, StormCAD will choose the largest of the available lengths.

**Designing Inlets in Sag**

When designing inlets in sag, the objective is to keep gutter spread and depth below desired maximum levels. StormCAD will choose the minimum available inlet length that meets these constraints. In a case where the constraints cannot be met with any of the available lengths, StormCAD will choose the largest inlet length possible.

### Special Considerations

There are a few special considerations that should be realized when analyzing a sewer system. These are conditions where special assumptions need to be made, or where calculations may seem counter-intuitive at first glance. These considerations include:

- Energy Discontinuity
- Structure Energy Grade
- Design Considerations
- Carrier Pipes
- Partial Area Effects
- Flow Balance At Junctions

#### 8.0.1 **Energy Discontinuity**

The program by default uses hydraulic grade as the basis for its hydraulic computations. Energy grade at any given point is then computed by adding the velocity head to the hydraulic grade. Because of this standard practice, energy discontinuities may occasionally occur, such as when pipe size decreases in the downstream direction, or pipe slope increases.

If you want the calculations to be based on the energy grade line you can change it with the Structure Loss Mode Calculation Option.

Flow discontinuities can also be responsible for energy discontinuities. Since a structure is analyzed based on a different system time than a pipe, a direct comparison of energy grades is not reasonable.
8.0.2 Structure Energy Grade

The energy grade line (EGL) at the upstream side of a structure is computed based on the characteristics of the structure and its upstream pipes. The reported EGL is generally reported as the lowest EGL of all non-plunging upstream pipes, based on normalized flow values. If there are no non-plunging pipes upstream, the structure's upstream EGL is taken as the higher of the structure's downstream EGL and upstream hydraulic grade line (HGL).

In situations where the structure's upstream EGL is lower than its downstream EGL or upstream HGL, the highest value governs. This rare condition may indicate that the presumed headloss in the structure is not significant enough to produce the expected energy loss. The modeler may accept this as a minor limitation of the hydraulic theory, or may choose to use different structure headloss methods or values.

The reported upstream velocity and velocity head for the structure are based on the difference between the structure's upstream EGL and HGL.

8.0.3 Design Considerations

As with any automated design, the program's design is intended only as a preliminary step. It will select pipe sizes and pipe invert elevations based on the input provided, but no computer program can match the skills that an experienced engineer has. The modeler should always review any automated design, and should make any changes required to adjust, improve, and otherwise polish the system.

8.0.4 Carrier Pipes

When using either the Rational Method or Modified Rational Method, StormCAD has an option to ignore the time of flow through long lengths of carrier pipes (i.e. pipes with no contributing sub-catchment) when calculating the system time / time of concentration (see also Calculation Options). This allows modelers to eliminate the flow reductions that would otherwise occur as a result of the increased system time.
Special Considerations

**Note:** This definition of the term Carrier Pipe should not be confused with its use to describe a non porous pipe.

The following diagrams show different configurations of carrier and non carrier pipes in a simple network, and their effect on flow.

The diagram above shows how the system time or time of concentration (ToC) changes through a network when there are no carrier pipes. At a minimum the ToC increases by the pipe travel time at each node in the network (it may increase by more if a downstream catchment has a larger time of concentration).
At the junction of branch 2 with branch 1, the longer of the two ToC's is used for the downstream pipe. This is one of the basic principles of Rational Method hydraulics.

In the diagram above the time in pipe of the carrier pipe is ignored when calculating the flow for the following pipe, so the running ToC for the downstream node of the carrier pipe is the same as the upstream node.
Special Considerations

The next pipe downstream is not a carrier pipe. The ToC at its downstream node therefore includes the previously ignored travel time in the carrier pipe.

Key:
- Carrier Pipe
- Subcatchment

Consecutive Carrier Pipes
In the diagram above the ToC does not increase in the consecutive carrier pipes.

In the diagram above the ToC does not increase in the consecutive carrier pipes. At the junction branch 1 has the highest carrier ToC (10.2 minutes), but branch 2 has the highest running ToC (10.9 minutes). Therefore the carrier pipes downstream of the junction use the carrier ToC from branch 1 (10.2 minutes).

For the first non carrier and subsequent pipes (including any subsequent carrier pipes) the ToC is taken from the running ToC of branch 2. This is calculated as $10.9 + 0.6 + 0.8 + 0.3 = 12.6$ minutes.

Note: the above diagrams are intended to explain the effect of carrier pipes on the node ToC's so subcatchments areas and the resulting flows have not been shown.

**Summary**

The rules for system time (time of concentration) in carrier and non-carrier pipe cases are when the 'Ignore Travel Time in Carrier Pipes' calculation option is set to TRUE are:
• When calculating the running ToC for the nodes, the pipe travel time is ignored for carrier pipes.

• The running ToC for the downstream node of the carrier pipe is the same as the upstream node.

• If the downstream pipe from a carrier pipe is not a carrier pipe, the running ToC will include the 'time in pipe' from the previous carrier pipe(s).

• If there are several incoming pipes, and none of them are carrier pipes, then the highest incoming ToC is used as the ToC for the outgoing pipe.

• If there are several incoming pipes and all of them are carrier pipes, and the outgoing pipe is a carrier, then the highest carrier pipe ToC is used as the ToC for the outgoing pipe.

• If there are several incoming pipes and they are a mixture of carrier and non carrier pipes, and the outgoing pipe is a carrier pipe, then the highest running ToC is used for the ToC for the outgoing pipe.

8.0.5 Partial Area Effects

The rational method typically assumes that peak flow occurs at the time when the whole upstream catchment area contributes to the flow. However it is possible that a 'partial area' can deliver higher peak flows than the total upstream area - for example when a large impervious area with a small time of concentration is connected to a network downstream of a small pervious area with a large time of concentration. StormCAD has an option to correct for 'Partial Area' effects (see also Calculation Options) as described below.

For any inlet node, the final combined system rational flow should not be smaller than the single maximum rational flow from contributing sources, these contributing sources include:

A. Incoming and tributary pipes

B. Captured surface inflow from catchments and gutters

C. The inflows (rational portion) from diversions

D. External rational flows

If the calculation option is enabled and there are multiple rational flow sources entering a node, the model will check all incoming flows to find out the largest rational flow from the sources. This identified maximum flow is called the "partial area flow". The combined rational flow is calculated by the normal procedure and then is compared with the partial area flow. If the partial area flow is smaller than the combined rational flow, the combined rational flow will be used. If the combined rational flow is smaller than the partial area flow, the partial area flow is used as the new system rational flow at this point.
Note: In the current release of StormCAD the other properties, such as the system CA, system flow time, etc. are not updated to reflect partial area flows.

When a partial area flow is used it also serves as a minimum rational flow for the downstream elements. The downstream elements still follow the normal calculation procedure and the calculated rational flow will be compared with any upstream partial area flows. If the normal calculation procedure results in a flow that is smaller than the partial area flow, that flow is replaced by the partial area flow.

The following examples illustrate the "Correct for Partial Area Effects" calculation option.

**Tributary inflows**

"Correct for Partial Area Effects" = TRUE:
"Correct for Partial Area Effects" = FALSE:

Catchments
"Correct for Partial Area Effects" = TRUE:

"Correct for Partial Area Effects" = FALSE:

External flow

"Correct for Partial Area Effects" = TRUE:
Special Considerations

(The large flow used is the external rational flow)
"Correct for Partial Area Effects" = FALSE:

Gutter
Special Considerations

"Correct for Partial Area Effects" = TRUE:

\[ I_{CM-t} = 1.91 \text{ ft}^3/\text{s} \]

\[ 10.60 \text{ ft}^3/\text{s} \]

\[ 10.61 \text{ ft}^3/\text{s} \]

\[ 0.01 \text{ ft}^3/\text{s} \]
"Correct for Partial Area Effects" = FALSE:

![Diagram of water flow and diversion](image)

Diversion
Special Considerations

"Correct for Partial Area Effects" = TRUE:

1.91 tP/s
CM-1

-2
1.91 ft³/s
P-2

CM-2

D
10.61 ft³/s

-3
5.31 ft³/s
P-3

-4
5.31 ft³/s
P-4

CO-1
5.31

P-4
5.31
"Correct for Partial Area Effects" = FALSE:

8.0.6  Flow Balance at Junctions

Because of the use of rational method hydrology, flow discontinuities may be noticed. This is a condition where the sum of the inflows does not equal the sum of the outflows. The main reason for this is that the rational method is only concerned with peak flows and has a high dependence on duration (system time). As the system time changes, the intensity changes and has a direct effect on the rate of flow in the system.

The most common cause of confusion with this discontinuity stems from rational loads that are tracked through a long piping system without any other loads entering the network. At the inlet of origin, the time of concentration may be relatively small, resulting in a high intensity and a large peak discharge. As the load travels through the pipes, the system time becomes larger, so the intensity lowers. This results in smaller discharge values, so the peak flow at the outlet may be significantly smaller than the peak flow at the original inlet.
This may seem counter-intuitive at first, with questions like "Where did the rest of the flow go?" coming to mind. In reality, the rest of the flow was not lost, but an attempt to balance peak flows is not valid. Picture standing at the top of a hill with a bucket of water. If you empty the entire bucket into the gutter in one second, then the peak rate of discharge at the top of the hill is one bucket per second. Racing to the bottom of the hill, you can observe the flow and see that the peak flow is much less than one bucket per second. However, the flow lasts longer than one second. There was no water lost, but the peak was lower.

StormCAD does not simply add flow at a junction node; rather, it takes into account the attenuation of peak flow as one moves downstream by keeping track of upstream catchment properties and decreasing the peak intensity according to the time of concentration and travel.

The flow out of a catchment is:

\[ Q = Cia \]

Where:

- \( Q \) = Flow
- \( C \) = Coefficient
- \( i \) = Intensity
- \( a \) = Area

And the flow out of a junction is:

\[ Q_{out} = \sum Cia + \sum Q_{known} \]

One would think therefore that flow in equals flow out. However, the intensity \( i \) used for determining the flow into the manhole will be higher than the intensity of the flow leaving the manhole.

This intensity is calculated using the longest possible flow travel time in order to generate the most conservative value for peak flow. For example, say a catchment empties into a catch basin and has a **Time of Concentration** of 10 minutes. On the other hand the travel time of the piped flow getting to the catch basin is 12 minutes. The rational flow generated at the catch basin will be generated based on the intensity associated with the 12 minute duration. This way you are assured that the whole system is contributing to the flow and hence you are using the most conservative peak flow value at that point.

If you do not wish to have this flow attenuation taken into account, you should specify **Known** or **Additional** flows at the catch basins.
8.1 **Modified Rational (UK) Loading**

The modified rational method is based on the standard rational method (see [Rational Loading](#)), but is modified to improved the accuracy of the peak flow calculations when applied to typical urban catchments in the UK.

The modified rational (UK) formula used in StormCAD is:

\[
Q = 2.78 \left( C_v C_R i A \right)
\]

Where:  
- \(Q\) = peak discharge (L/s)  
- \(C_v\) = volumetric runoff coefficient (unitless)  
- \(C_R\) = routing coefficient (unitless)  
- \(i\) = average rainfall intensity during the time of concentration (mm/hr)  
- \(A\) = contributing catchment area (ha)

**Note:** The modified rational method (UK) used in StormCAD to compute peak flows should not be confused with the hydrograph method of the same name used in other parts of the world to compute a trapezoidal runoff hydrograph.

8.1.1 **Modified Rational Coefficients**

The volumetric runoff coefficient, \(C_v\) is defined as the proportion of the rainfall on the catchment which appears as surface runoff in the storm drainage system.

The typical value of \(C_v\) (when used in conjunction with impervious areas alone) ranges from around 0.6 on catchments with rapidly draining soils to around 0.9 on catchments with heavy soils, with the average value usually around 0.75.
**Modified Rational (UK) Loading**

Alternatively, $Cv$ can be calculated using the following formula:

$$
Cv = \frac{PR}{100}
$$

Where:

$$PR = 0.829 \times PIMP + 25.0 \times SOIL + 0.078 \times UCWI - 20.7$$

And:
- $PR$ = Percentage runoff from the total catchment area (%)
- $PIMP$ = Percentage of catchment area covered by impervious surfaces intended to drain to the storm sewer (%)
- $SOIL$ = Soil type, which takes the value 0.15, 0.3, 0.4, 0.45 or 0.5 according to the five soil types 1 to 5 respectively, as found on UK soil maps
- $UCWI$ = Antecedent wetness condition (mm). For design, $UCWI$ can be determined from the chart below, which shows recommended design values (plotted against standard average annual rainfall (SAAR))
The routing coefficient $C_R$ should vary with the peakedness of the rainfall profile and the shape of a time area diagram generated for the catchment, however, for the purposes of design, a value of 1.3 is recommended.
8.1.2 Time of Concentration

The time of concentration is defined as:

\[ t_c = t_e + t_f \]

Where:
- \( t_c \) = time of concentration (mins)
- \( t_e \) = time of entry (mins)
- \( t_f \) = time of flow through pipe (mins)

The time of entry can be computed using this formula:

\[ t_e = 7.44 \text{LENGTH}^{0.133} \text{SLOPE}^{-0.274} \]

Where:
- LENGTH = sub-catchment overland flow length (m)
- SLOPE = sub-catchment slope (%)

However, the data sets used to determine this equation were biased towards small events, so the equation above is not suitable for larger return periods.

As a result, the following values are typically recommended for design:

<table>
<thead>
<tr>
<th>Design Return Period</th>
<th>Time of entry (minutes)</th>
</tr>
</thead>
<tbody>
<tr>
<td>5 Years</td>
<td>3-6</td>
</tr>
<tr>
<td>2 Years</td>
<td>4-7</td>
</tr>
<tr>
<td>1 Year</td>
<td>4-8</td>
</tr>
<tr>
<td>1 Month</td>
<td>5-10</td>
</tr>
</tbody>
</table>

The time of concentration is used to determine the duration of the storm when determining the average rainfall intensity and therefore peak flow.
8.1.3 **UK Standard Rainfall Intensities**


The calculation sequence is as follows (note: the naming convention 'MT-D' represents the depth of rainfall in mm occurring in a duration D, usually measured in hours unless specified otherwise, with a return period of T years).

1. **Calculation of M5-60 min and the ratio r, where:**
   \[ r = \frac{M5-60 \text{ min}}{M5-2 \text{ days}} = 1.06 \cdot \left(\frac{M5-60 \text{ min}}{M5-48 \text{ hrs}}\right) \]

2. **Calculation of M5-D for various durations, D**

3. **Calculation of MT-D for various return periods, T**

Values of M5-60 and the ratio r are obtained from maps available in Report No 28 (Department of Environment, National Water Council, Standing Technical Committee, 1981) and elsewhere. The typical range for the ratio r is between 0.1 and 0.45, while the typical range for M5-60 is between 12 mm and 24 mm.

\[
\ln M5-D = \ln(D) + \ln\left(1.06 \cdot \frac{M5-60 \text{ min}}{48r}\right) + \ln\left(\frac{721}{1 + 15D}\right) \cdot \ln\left(\frac{48r}{1.06}\right)
\]

For return periods greater than 5 years, the general equation linking rainfall depths for a specific duration is:

\[
MT-D = \exp(Cr \cdot (\ln(T) - 1.5)) \cdot M5-D
\]

where Cr is a constant that varies according to geographical location, as well as the value of M5-D itself, as given by the following formula:

\[
Cr = J_0 + J_1 \cdot M5-D + J_2 \cdot (M5-D)^2
\]
The values for $J_0$, $J_1$, and $J_2$ are stored within StormCAD, and are determined by the location index entered into the software (options are 'England and Wales' or 'Scotland and Northern Ireland'). They are reproduced in the table below:

<table>
<thead>
<tr>
<th>Geographical location</th>
<th>Range of M5-D</th>
<th>Location index</th>
<th>$J_0$</th>
<th>$J_1$</th>
<th>$J_2$</th>
</tr>
</thead>
<tbody>
<tr>
<td>England and Wales</td>
<td>0-10</td>
<td></td>
<td>$1.699 \times 10^{-4}$</td>
<td>$2.800 \times 10^{-6}$</td>
<td>$1.14000 \times 10^{-9}$</td>
</tr>
<tr>
<td></td>
<td>10-30</td>
<td></td>
<td>1644</td>
<td>5831</td>
<td>-134300</td>
</tr>
<tr>
<td></td>
<td>30-75</td>
<td>1</td>
<td>2644</td>
<td>-1621</td>
<td>3150</td>
</tr>
<tr>
<td></td>
<td>75-150</td>
<td></td>
<td>2718</td>
<td>-1947</td>
<td>6187</td>
</tr>
<tr>
<td></td>
<td>&gt;150</td>
<td></td>
<td>1454</td>
<td>-194</td>
<td>114</td>
</tr>
<tr>
<td>Scotland and N Ireland</td>
<td>0-13</td>
<td></td>
<td>1648</td>
<td>8330</td>
<td>-304700</td>
</tr>
<tr>
<td></td>
<td>13-25</td>
<td></td>
<td>2349</td>
<td>-771</td>
<td>-17250</td>
</tr>
<tr>
<td></td>
<td>25-50</td>
<td>2</td>
<td>2502</td>
<td>-2109</td>
<td>12130</td>
</tr>
<tr>
<td></td>
<td>50-150</td>
<td></td>
<td>2274</td>
<td>-1208</td>
<td>3220</td>
</tr>
<tr>
<td></td>
<td>&gt;150</td>
<td></td>
<td>1460</td>
<td>-202</td>
<td>120</td>
</tr>
</tbody>
</table>

(Department of Environment, National Water Council, Standing Technical Committee, 1981)

For return periods of less than five years, an empirical relationship is used:

$$MT - D = Z2 (M5 - D)$$
Where $Z_2$ is taken from the following tables:

**Relationship between rainfall of return period T(MT) and M5 – England and Wales (ratio Z2)**

<table>
<thead>
<tr>
<th>M5 Rainfall mm</th>
<th>M1</th>
<th>M2</th>
<th>M3</th>
<th>M4</th>
<th>M5</th>
<th>M10</th>
<th>M20</th>
<th>M50</th>
<th>M100</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>0.62</td>
<td>0.79</td>
<td>0.89</td>
<td>0.97</td>
<td>1.02</td>
<td>1.19</td>
<td>1.36</td>
<td>1.56</td>
<td>1.79</td>
</tr>
<tr>
<td>10</td>
<td>0.61</td>
<td>0.79</td>
<td>0.90</td>
<td>0.97</td>
<td>1.03</td>
<td>1.22</td>
<td>1.41</td>
<td>1.65</td>
<td>1.91</td>
</tr>
<tr>
<td>15</td>
<td>0.62</td>
<td>0.80</td>
<td>0.90</td>
<td>0.97</td>
<td>1.03</td>
<td>1.24</td>
<td>1.44</td>
<td>1.70</td>
<td>1.99</td>
</tr>
<tr>
<td>20</td>
<td>0.64</td>
<td>0.81</td>
<td>0.90</td>
<td>0.97</td>
<td>1.03</td>
<td>1.24</td>
<td>1.45</td>
<td>1.73</td>
<td>2.03</td>
</tr>
<tr>
<td>25</td>
<td>0.66</td>
<td>0.82</td>
<td>0.91</td>
<td>0.97</td>
<td>1.03</td>
<td>1.24</td>
<td>1.44</td>
<td>1.72</td>
<td>2.01</td>
</tr>
<tr>
<td>30</td>
<td>0.68</td>
<td>0.83</td>
<td>0.91</td>
<td>0.97</td>
<td>1.03</td>
<td>1.22</td>
<td>1.42</td>
<td>1.70</td>
<td>1.97</td>
</tr>
<tr>
<td>40</td>
<td>0.70</td>
<td>0.84</td>
<td>0.92</td>
<td>0.97</td>
<td>1.02</td>
<td>1.19</td>
<td>1.38</td>
<td>1.64</td>
<td>1.89</td>
</tr>
<tr>
<td>50</td>
<td>0.72</td>
<td>0.85</td>
<td>0.93</td>
<td>0.98</td>
<td>1.02</td>
<td>1.17</td>
<td>1.34</td>
<td>1.58</td>
<td>1.81</td>
</tr>
<tr>
<td>75</td>
<td>0.76</td>
<td>0.87</td>
<td>0.93</td>
<td>0.98</td>
<td>1.02</td>
<td>1.14</td>
<td>1.28</td>
<td>1.47</td>
<td>1.64</td>
</tr>
<tr>
<td>100</td>
<td>0.78</td>
<td>0.88</td>
<td>0.94</td>
<td>0.98</td>
<td>1.02</td>
<td>1.13</td>
<td>1.25</td>
<td>1.40</td>
<td>1.54</td>
</tr>
<tr>
<td>150</td>
<td>0.78</td>
<td>0.88</td>
<td>0.94</td>
<td>0.98</td>
<td>1.01</td>
<td>1.12</td>
<td>1.21</td>
<td>1.33</td>
<td>1.45</td>
</tr>
<tr>
<td>200</td>
<td>0.78</td>
<td>0.88</td>
<td>0.94</td>
<td>0.98</td>
<td>1.01</td>
<td>1.11</td>
<td>1.19</td>
<td>1.30</td>
<td>1.40</td>
</tr>
</tbody>
</table>

**Relationship between rainfall of return period T(MT) and M5 – Scotland and Northern Ireland (ratio Z2)**

<table>
<thead>
<tr>
<th>M5 Rainfall mm</th>
<th>M1</th>
<th>M2</th>
<th>M3</th>
<th>M4</th>
<th>M5</th>
<th>M10</th>
<th>M20</th>
<th>M50</th>
<th>M100</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>0.67</td>
<td>0.82</td>
<td>0.91</td>
<td>0.98</td>
<td>1.02</td>
<td>1.17</td>
<td>1.35</td>
<td>1.62</td>
<td>1.86</td>
</tr>
<tr>
<td>10</td>
<td>0.68</td>
<td>0.82</td>
<td>0.91</td>
<td>0.98</td>
<td>1.03</td>
<td>1.19</td>
<td>1.39</td>
<td>1.69</td>
<td>1.97</td>
</tr>
<tr>
<td>15</td>
<td>0.69</td>
<td>0.83</td>
<td>0.91</td>
<td>0.97</td>
<td>1.03</td>
<td>1.20</td>
<td>1.39</td>
<td>1.70</td>
<td>1.98</td>
</tr>
<tr>
<td>20</td>
<td>0.70</td>
<td>0.84</td>
<td>0.92</td>
<td>0.97</td>
<td>1.02</td>
<td>1.19</td>
<td>1.38</td>
<td>1.66</td>
<td>1.93</td>
</tr>
<tr>
<td>25</td>
<td>0.71</td>
<td>0.84</td>
<td>0.92</td>
<td>0.98</td>
<td>1.02</td>
<td>1.18</td>
<td>1.37</td>
<td>1.64</td>
<td>1.89</td>
</tr>
<tr>
<td>30</td>
<td>0.72</td>
<td>0.85</td>
<td>0.93</td>
<td>0.98</td>
<td>1.02</td>
<td>1.18</td>
<td>1.36</td>
<td>1.61</td>
<td>1.85</td>
</tr>
<tr>
<td>40</td>
<td>0.74</td>
<td>0.86</td>
<td>0.93</td>
<td>0.98</td>
<td>1.02</td>
<td>1.17</td>
<td>1.34</td>
<td>1.56</td>
<td>1.77</td>
</tr>
<tr>
<td>50</td>
<td>0.75</td>
<td>0.87</td>
<td>0.94</td>
<td>0.98</td>
<td>1.02</td>
<td>1.16</td>
<td>1.30</td>
<td>1.52</td>
<td>1.72</td>
</tr>
<tr>
<td>75</td>
<td>0.77</td>
<td>0.88</td>
<td>0.94</td>
<td>0.98</td>
<td>1.02</td>
<td>1.14</td>
<td>1.27</td>
<td>1.45</td>
<td>1.62</td>
</tr>
<tr>
<td>100</td>
<td>0.78</td>
<td>0.88</td>
<td>0.94</td>
<td>0.98</td>
<td>1.02</td>
<td>1.13</td>
<td>1.24</td>
<td>1.40</td>
<td>1.54</td>
</tr>
<tr>
<td>150</td>
<td>0.79</td>
<td>0.89</td>
<td>0.94</td>
<td>0.98</td>
<td>1.02</td>
<td>1.11</td>
<td>1.20</td>
<td>1.33</td>
<td>1.45</td>
</tr>
<tr>
<td>200</td>
<td>0.80</td>
<td>0.89</td>
<td>0.95</td>
<td>0.99</td>
<td>1.01</td>
<td>1.10</td>
<td>1.18</td>
<td>1.30</td>
<td>1.40</td>
</tr>
</tbody>
</table>

(Department of Environment, National Water Council, Standing Technical Committee, 1981)

Once the rainfall depths are calculated according the procedure above, average intensity is computed by:

$$Average\ Intensity = \frac{Rainfall\ Depth}{Duration}$$
Note: StormCAD will compute average intensities for a range of storm durations and return frequencies. To accommodate small inlet time of entry values, the smallest storm duration calculated is 2 minutes.

8.1.4 Areal Reduction Factors

The intensities computed using the procedure outlined in "UK Standard Rainfall Intensities" are considered to occur at a single point in space. Where the rainfall occurs over a large area, it may be necessary to take into account the areal variation of rainfall by computing an Areal Reduction Factor. This factor can be determined from following formula (duration D in hours):

\[ \text{Areal Reduction Factor} = 1 - f_1 \times D^{-f_2} \]

Where \( f_1 \) and \( f_2 \) can be found from the following table based upon drainage area of the catchment:

<table>
<thead>
<tr>
<th>Size of area, AT (Km²)</th>
<th>f₁</th>
<th>f₂</th>
</tr>
</thead>
<tbody>
<tr>
<td>AT&lt;20</td>
<td>0.0394 ( AT^{0.354} )</td>
<td>0.40-0.0208 ( \ln (4.6 - \ln AT) )</td>
</tr>
<tr>
<td>20≤AT&lt;100</td>
<td>0.0394 ( AT^{0.354} )</td>
<td>0.40-0.00382 ( (4.6 - \ln AT)^2 )</td>
</tr>
</tbody>
</table>

(Department of Environment, National Water Council, Standing Technical Committee, 1981)

Therefore, the resulting adjusted Rainfall Intensity of a generic storm is MT-D is:

\[ \text{Adjusted Intensity} = \text{Average Point Intensity} \times \text{Areal Reduction Factor} \]

Areal reduction factors are applied to intensity values used to calculation the catchment runoff, and also the system flow. Currently no attempt is made to reduce the inlet bypass/carryover flow intensities in StormCAD. This is likely to result in conservative (high) values for gutter flow and inlet bypass/carryover, however the differences are not likely to be significant - particularly in smaller urban catchments where the areal reduction factor is generally greater than 0.9.

Rainfall Tables
If the procedure outlined in "UK Standard Rainfall Intensities" is unsuitable, tables of average rainfall intensities for various storm durations and return events can be entered manually into StormCAD.

See also:

- Rational Loading
- Rainfall Intensity
- Return Period and Frequency
- Intensity Durations Frequency Data
- Rainfall Tables

### 8.1.5 Basic Assumptions

The Modified Rational Method has been tested on urban catchments up to 150 hectares in area with times of concentration up to about 30 minutes and outfall pipe diameters of up to around 1 metre. The catchments tested had reasonably uniform slopes and impervious area distributions. These tests have shown that the method is as accurate as other more sophisticated urban runoff methods for calculating peak runoff.

(Department of Environment, National Water Council, Standing Technical Committee, 1981)

The accuracy of the method for conditions outside those described above is unknown, and therefore the method can't be positively recommended in those cases.

### 8.2 Engineer’s Reference

- [Rational C Coefficients](#)
- [Headloss Coefficients for Junctions](#)
- [Roughness Values—Manning’s Equation](#)
- [Roughness Values—Kutter’s Equation](#)
- [Roughness Values—Darcy-Weisbach (Colebrook-White) Equation](#)
- [Roughness Values—Hazen-Williams Formula](#)
### 8.2.1 Rational C Coefficients

#### Table 8-5: Rational Coefficients for Common Land Uses

<table>
<thead>
<tr>
<th>Area (1)</th>
<th>Description</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Business</td>
<td>Downtown</td>
<td>0.70 - 1.95</td>
</tr>
<tr>
<td></td>
<td>Neighborhood</td>
<td>0.50 - 0.70</td>
</tr>
<tr>
<td>Residential</td>
<td>Single family</td>
<td>0.30 - 0.50</td>
</tr>
<tr>
<td></td>
<td>Multi-unit detached</td>
<td>0.40 - 0.60</td>
</tr>
<tr>
<td></td>
<td>Multi-unit attached</td>
<td>0.60 - 0.75</td>
</tr>
<tr>
<td></td>
<td>Suburban resident</td>
<td>0.25 - 0.40</td>
</tr>
<tr>
<td></td>
<td>Apartment</td>
<td>0.50 - 0.70</td>
</tr>
<tr>
<td>Residential</td>
<td>1.2-acre lot or more</td>
<td>0.30 - 0.45</td>
</tr>
<tr>
<td>Industrial</td>
<td>Light</td>
<td>0.50 - 0.80</td>
</tr>
<tr>
<td></td>
<td>Heavy</td>
<td>0.60 - 0.90</td>
</tr>
<tr>
<td>Parks and Cemeteries</td>
<td></td>
<td>0.10 - 0.25</td>
</tr>
<tr>
<td>Playgrounds</td>
<td></td>
<td>0.20 - 0.40</td>
</tr>
<tr>
<td>Unimproved</td>
<td></td>
<td>0.10 - 0.30</td>
</tr>
<tr>
<td>Pavement</td>
<td>Asphalt/Concrete</td>
<td>0.70 - 0.95</td>
</tr>
<tr>
<td></td>
<td>Brick</td>
<td>0.70 - 0.85</td>
</tr>
<tr>
<td>Drives and walks</td>
<td></td>
<td>0.75 - 0.85</td>
</tr>
<tr>
<td>Lawns, sandy soils</td>
<td>Flat 2%</td>
<td>0.05 - 0.10</td>
</tr>
<tr>
<td></td>
<td>Average 2% to 7%</td>
<td>0.10 - 0.15</td>
</tr>
<tr>
<td></td>
<td>Steep &gt; 7%</td>
<td>0.15 - 0.20</td>
</tr>
<tr>
<td>Lawns, heavy soils</td>
<td>Flat 2%</td>
<td>0.13 - 0.17</td>
</tr>
<tr>
<td></td>
<td>Average 2% to 7%</td>
<td>0.18 - 0.22</td>
</tr>
<tr>
<td></td>
<td>Steep &gt; 7%</td>
<td>0.25 - 0.35</td>
</tr>
<tr>
<td>Railroad yard</td>
<td></td>
<td>0.20 - 0.40</td>
</tr>
<tr>
<td>Roofs</td>
<td></td>
<td>0.70 - 0.95</td>
</tr>
</tbody>
</table>

Many local, county, and state agencies have C coefficient tables for their locale.
**Headloss Coefficients for Junctions**

These are typical headloss coefficients used in the standard method for estimating headloss through manholes and junctions.

**Table 8-6: Typical Headloss Coefficients**

<table>
<thead>
<tr>
<th>Type of Manhole</th>
<th>Diagram</th>
<th>Headloss Coefficient</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trunkline only with no bend at the junction</td>
<td><img src="image1" alt="Diagram" /></td>
<td>0.5</td>
</tr>
<tr>
<td>Trunkline only with 45° bend at the junction</td>
<td><img src="image2" alt="Diagram" /></td>
<td>0.6</td>
</tr>
<tr>
<td>Trunkline only with 90° bend at the junction</td>
<td><img src="image3" alt="Diagram" /></td>
<td>0.8</td>
</tr>
</tbody>
</table>
### Table 8-6: Typical Headloss Coefficients

<table>
<thead>
<tr>
<th>Type of Manhole</th>
<th>Diagram</th>
<th>Headloss Coefficient</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trunkline with one lateral</td>
<td><img src="image1" alt="Diagram" /></td>
<td>Small 0.6&lt;br&gt;Large 0.7</td>
</tr>
<tr>
<td>Two roughly equivalent entrance lines with angle &lt; 90° between lines</td>
<td><img src="image2" alt="Diagram" /></td>
<td>0.8</td>
</tr>
<tr>
<td>Two roughly equivalent entrance lines with angle &gt; 90° between lines</td>
<td><img src="image3" alt="Diagram" /></td>
<td>0.9</td>
</tr>
<tr>
<td>Three or more entrance lines</td>
<td><img src="image4" alt="Diagram" /></td>
<td>1.0</td>
</tr>
</tbody>
</table>

#### 8.0.1 Roughness Values—Manning’s Equation

Commonly used roughness values for different materials are:
### Table 8-7: Manning’s Coefficients \( n \) for Closed Metal Conduits

<table>
<thead>
<tr>
<th>Channel Type and Description</th>
<th>Minimum</th>
<th>Normal</th>
<th>Maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brass, smooth</td>
<td>0.009</td>
<td>0.010</td>
<td>0.013</td>
</tr>
<tr>
<td>Steel; Lockbar and welded</td>
<td>0.010</td>
<td>0.012</td>
<td>0.014</td>
</tr>
<tr>
<td>Steel; Riveted and spiral</td>
<td>0.013</td>
<td>0.016</td>
<td>0.017</td>
</tr>
<tr>
<td>Cast iron; Coated</td>
<td>0.010</td>
<td>0.013</td>
<td>0.014</td>
</tr>
<tr>
<td>Cast iron; Uncoated</td>
<td>0.011</td>
<td>0.014</td>
<td>0.016</td>
</tr>
<tr>
<td>Wrought iron; Black</td>
<td>0.012</td>
<td>0.014</td>
<td>0.015</td>
</tr>
<tr>
<td>Wrought iron; Galvanized</td>
<td>0.013</td>
<td>0.016</td>
<td>0.017</td>
</tr>
<tr>
<td>Corrugated metal; Subdrain</td>
<td>0.017</td>
<td>0.019</td>
<td>0.021</td>
</tr>
<tr>
<td>Corrugated metal; Storm Drain</td>
<td>0.021</td>
<td>0.024</td>
<td>0.030</td>
</tr>
</tbody>
</table>

### Table 8-8: Manning’s Coefficients \( n \) for Closed Non-Metal Conduits

<table>
<thead>
<tr>
<th>Channel Type and Description</th>
<th>Minimum</th>
<th>Normal</th>
<th>Maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lucite</td>
<td>0.008</td>
<td>0.009</td>
<td>0.010</td>
</tr>
<tr>
<td>Glass</td>
<td>0.009</td>
<td>0.010</td>
<td>0.013</td>
</tr>
<tr>
<td>Cement; Neat, surface</td>
<td>0.010</td>
<td>0.011</td>
<td>0.013</td>
</tr>
<tr>
<td>Cement; Mortar</td>
<td>0.011</td>
<td>0.013</td>
<td>0.015</td>
</tr>
<tr>
<td>Concrete; Culvert, straight and free of debris</td>
<td>0.010</td>
<td>0.011</td>
<td>0.013</td>
</tr>
<tr>
<td>Concrete; Culvert with bends, connections, and some debris</td>
<td>0.011</td>
<td>0.013</td>
<td>0.014</td>
</tr>
<tr>
<td>Concrete; Finished</td>
<td>0.011</td>
<td>0.012</td>
<td>0.014</td>
</tr>
<tr>
<td>Concrete; Sewer with manholes, inlet, etc., straight</td>
<td>0.013</td>
<td>0.015</td>
<td>0.017</td>
</tr>
<tr>
<td>Concrete; Unfinished, steel form</td>
<td>0.012</td>
<td>0.013</td>
<td>0.014</td>
</tr>
</tbody>
</table>
### Table 8-8: Manning’s Coefficients n for Closed Non-Metal Conduits

<table>
<thead>
<tr>
<th>Channel Type and Description</th>
<th>Minimum</th>
<th>Normal</th>
<th>Maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete; Unfinished, smooth wood form</td>
<td>0.012</td>
<td>0.014</td>
<td>0.016</td>
</tr>
<tr>
<td>Concrete; Unfinished, rough wood form</td>
<td>0.015</td>
<td>0.017</td>
<td>0.020</td>
</tr>
<tr>
<td>Wood; Stave</td>
<td>0.010</td>
<td>0.012</td>
<td>0.014</td>
</tr>
<tr>
<td>Wood; Laminated, treated</td>
<td>0.015</td>
<td>0.017</td>
<td>0.020</td>
</tr>
<tr>
<td>Clay; Common drainage tile</td>
<td>0.011</td>
<td>0.013</td>
<td>0.017</td>
</tr>
<tr>
<td>Clay; Vitrified sewer</td>
<td>0.011</td>
<td>0.014</td>
<td>0.017</td>
</tr>
<tr>
<td>Clay; Vitrified sewer with manholes, inlet, etc.</td>
<td>0.013</td>
<td>0.015</td>
<td>0.017</td>
</tr>
<tr>
<td>Clay; Vitrified subdrain with open joint</td>
<td>0.014</td>
<td>0.016</td>
<td>0.018</td>
</tr>
<tr>
<td>Brickwork; Glazed</td>
<td>0.011</td>
<td>0.013</td>
<td>0.015</td>
</tr>
<tr>
<td>Brickwork; Lined with cement mortar</td>
<td>0.012</td>
<td>0.013</td>
<td>0.016</td>
</tr>
<tr>
<td>Sanitary sewers coated with sewage slimes, with bends and connections</td>
<td>0.012</td>
<td>0.013</td>
<td>0.016</td>
</tr>
<tr>
<td>Paved invert, sewer, smooth bottom</td>
<td>0.016</td>
<td>0.019</td>
<td>0.020</td>
</tr>
<tr>
<td>Rubble masonry, cemented</td>
<td>0.018</td>
<td>0.025</td>
<td>0.030</td>
</tr>
</tbody>
</table>
### 8.0.2 Roughness Values—Kutter’s Equation

#### Table 8-9: Roughness Values—Kutter’s Equation

<table>
<thead>
<tr>
<th>Channel Type and Description</th>
<th>Minimum</th>
<th>Normal</th>
<th>Maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brass, smooth</td>
<td>0.009</td>
<td>0.010</td>
<td>0.013</td>
</tr>
<tr>
<td>Steel; Lockbar and welded</td>
<td>0.010</td>
<td>0.012</td>
<td>0.014</td>
</tr>
<tr>
<td>Steel; Riveted and spiral</td>
<td>0.013</td>
<td>0.016</td>
<td>0.017</td>
</tr>
<tr>
<td>Cast iron; Coated</td>
<td>0.010</td>
<td>0.013</td>
<td>0.014</td>
</tr>
<tr>
<td>Cast iron; Uncoated</td>
<td>0.011</td>
<td>0.014</td>
<td>0.016</td>
</tr>
<tr>
<td>Wrought iron; Black</td>
<td>0.012</td>
<td>0.014</td>
<td>0.015</td>
</tr>
<tr>
<td>Wrought iron; Galvanized</td>
<td>0.013</td>
<td>0.016</td>
<td>0.017</td>
</tr>
<tr>
<td>Corrugated metal; Subdrain</td>
<td>0.017</td>
<td>0.019</td>
<td>0.021</td>
</tr>
<tr>
<td>Corrugated metal; Storm Drain</td>
<td>0.021</td>
<td>0.024</td>
<td>0.030</td>
</tr>
</tbody>
</table>

#### Table 8-10: Kutter’s Coefficients n for Closed Non-Metal Conduits

<table>
<thead>
<tr>
<th>Channel Type and Description</th>
<th>Minimum</th>
<th>Normal</th>
<th>Maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lucite</td>
<td>0.008</td>
<td>0.009</td>
<td>0.010</td>
</tr>
<tr>
<td>Glass</td>
<td>0.009</td>
<td>0.010</td>
<td>0.013</td>
</tr>
<tr>
<td>Cement; Neat, surface</td>
<td>0.010</td>
<td>0.011</td>
<td>0.013</td>
</tr>
<tr>
<td>Cement; Mortar</td>
<td>0.011</td>
<td>0.013</td>
<td>0.015</td>
</tr>
<tr>
<td>Concrete; Culvert, straight and free of debris</td>
<td>0.010</td>
<td>0.011</td>
<td>0.013</td>
</tr>
<tr>
<td>Concrete; Culvert with bends, connections, and some debris</td>
<td>0.011</td>
<td>0.013</td>
<td>0.014</td>
</tr>
<tr>
<td>Concrete; Finished</td>
<td>0.011</td>
<td>0.012</td>
<td>0.014</td>
</tr>
<tr>
<td>Concrete; Sewer with manholes, inlet, etc., straight</td>
<td>0.013</td>
<td>0.015</td>
<td>0.017</td>
</tr>
</tbody>
</table>
Table 8-10: Kutter’s Coefficients n for Closed Non-Metal Conduits (Cont’d)

<table>
<thead>
<tr>
<th>Channel Type and Description</th>
<th>Minimum</th>
<th>Normal</th>
<th>Maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete; Unfinished, steel form</td>
<td>0.012</td>
<td>0.013</td>
<td>0.014</td>
</tr>
<tr>
<td>Concrete; Unfinished, smooth wood form</td>
<td>0.012</td>
<td>0.014</td>
<td>0.016</td>
</tr>
<tr>
<td>Concrete; Unfinished, rough wood form</td>
<td>0.015</td>
<td>0.017</td>
<td>0.020</td>
</tr>
<tr>
<td>Wood; Stave</td>
<td>0.010</td>
<td>0.012</td>
<td>0.014</td>
</tr>
<tr>
<td>Wood; Laminated, treated</td>
<td>0.015</td>
<td>0.017</td>
<td>0.020</td>
</tr>
<tr>
<td>Clay; Common drainage tile</td>
<td>0.011</td>
<td>0.013</td>
<td>0.017</td>
</tr>
<tr>
<td>Clay; Vitrified sewer</td>
<td>0.011</td>
<td>0.014</td>
<td>0.017</td>
</tr>
<tr>
<td>Clay; Vitrified sewer with manholes, inlet, etc.</td>
<td>0.013</td>
<td>0.015</td>
<td>0.017</td>
</tr>
<tr>
<td>Clay; Vitrified subdrain with open joint</td>
<td>0.014</td>
<td>0.016</td>
<td>0.018</td>
</tr>
<tr>
<td>Brickwork; Glazed</td>
<td>0.011</td>
<td>0.013</td>
<td>0.015</td>
</tr>
<tr>
<td>Brickwork; Lined with cement mortar</td>
<td>0.011</td>
<td>0.013</td>
<td>0.015</td>
</tr>
<tr>
<td>Sanitary sewers coated with sewage slimes, with bends and connections</td>
<td>0.012</td>
<td>0.013</td>
<td>0.016</td>
</tr>
<tr>
<td>Paved invert, sewer, smooth bottom</td>
<td>0.016</td>
<td>0.019</td>
<td>0.020</td>
</tr>
<tr>
<td>Rubble masonry, cemented</td>
<td>0.018</td>
<td>0.025</td>
<td>0.030</td>
</tr>
</tbody>
</table>
8.0.3 Roughness Values—Darcy-Weisbach (Colebrook-White) Equation

Table 8-11: Darcy-Weisbach Roughness Heights $k$ for Closed Conduits

<table>
<thead>
<tr>
<th>Pipe Material</th>
<th>$k$ (mm)</th>
<th>$k$ (ft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Glass, drawn brass, copper (new)</td>
<td>0.0015</td>
<td>0.000005</td>
</tr>
<tr>
<td>Seamless commercial steel (new)</td>
<td>0.004</td>
<td>0.000013</td>
</tr>
<tr>
<td>Commercial steel (enamel coated)</td>
<td>0.0048</td>
<td>0.000016</td>
</tr>
<tr>
<td>Commercial steel (new)</td>
<td>0.045</td>
<td>0.00015</td>
</tr>
<tr>
<td>Wrought iron (new)</td>
<td>0.045</td>
<td>0.00015</td>
</tr>
<tr>
<td>Asphalted cast iron (new)</td>
<td>0.12</td>
<td>0.0004</td>
</tr>
<tr>
<td>Galvanized iron</td>
<td>0.15</td>
<td>0.0005</td>
</tr>
<tr>
<td>Cast iron (new)</td>
<td>0.26</td>
<td>0.00085</td>
</tr>
<tr>
<td>Wood stave (new)</td>
<td>0.18 ~ 0.9</td>
<td>0.0006 ~ 0.003</td>
</tr>
<tr>
<td>Concrete (steel forms, smooth)</td>
<td>0.18</td>
<td>0.0006</td>
</tr>
<tr>
<td>Concrete (good joints, average)</td>
<td>0.36</td>
<td>0.0012</td>
</tr>
<tr>
<td>Concrete (rough, visible, form marks)</td>
<td>0.60</td>
<td>0.002</td>
</tr>
<tr>
<td>Riveted steel (new)</td>
<td>0.9 ~ 9.0</td>
<td>0.003 ~ 0.03</td>
</tr>
<tr>
<td>Corrugated metal</td>
<td>45</td>
<td>0.15</td>
</tr>
</tbody>
</table>
## 8.0.4 Roughness Values—Hazen-Williams Formula

### Table 8-12: Hazen-Williams Coefficients

<table>
<thead>
<tr>
<th>Pipe Material</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asbestos cement</td>
<td>140</td>
</tr>
<tr>
<td>Brass</td>
<td>130 – 140</td>
</tr>
<tr>
<td>Brick Sewer</td>
<td>100</td>
</tr>
<tr>
<td>Cast iron; New, unlined</td>
<td>130</td>
</tr>
<tr>
<td>Cast iron; 10 yr. old</td>
<td>107 – 113</td>
</tr>
<tr>
<td>Cast iron; 20 yr. old</td>
<td>89 – 100</td>
</tr>
<tr>
<td>Cast iron; 30 yr. old</td>
<td>75 – 90</td>
</tr>
<tr>
<td>Cast iron; 40 yr. old</td>
<td>64 – 83</td>
</tr>
<tr>
<td>Concrete or concrete lined; Steel forms</td>
<td>140</td>
</tr>
<tr>
<td>Concrete or concrete lined; Wood forms</td>
<td>120</td>
</tr>
<tr>
<td>Concrete or concrete lined; Centrifugally spun</td>
<td>135</td>
</tr>
<tr>
<td>Copper</td>
<td>130 – 140</td>
</tr>
<tr>
<td>Galvanized iron</td>
<td>120</td>
</tr>
<tr>
<td>Glass</td>
<td>140</td>
</tr>
<tr>
<td>Lead</td>
<td>130 – 140</td>
</tr>
<tr>
<td>Plastic</td>
<td>140 – 150</td>
</tr>
<tr>
<td>Steel; Coal tar enamel, lined</td>
<td>145 – 150</td>
</tr>
<tr>
<td>Steel; New, unlined</td>
<td>140 – 150</td>
</tr>
<tr>
<td>Steel; Riveted</td>
<td>110</td>
</tr>
<tr>
<td>Tin</td>
<td>130</td>
</tr>
<tr>
<td>Vitrified clay (good condition)</td>
<td>110 – 140</td>
</tr>
<tr>
<td>Wood stave (average condition)</td>
<td>120</td>
</tr>
</tbody>
</table>
Presenting Your Results

9.1 Annotating Your Model

You can annotate any of the element types in Bentley StormCAD V8i using the Element Symbology manager.
To work with annotations, open the Element Symbology manager. Choose View > Element Symbology or press <Ctrl+1> to open.

Use the Element Symbology manager to control the way that elements and their associated labels are displayed.
The dialog box contains a pane that lists each element type along with the following icons:

**New**
Opens a submenu containing the following commands:

- **New Annotation**—Opens the Annotation Properties dialog box, allowing you to define annotation settings for the highlighted element type.
- **New Color Coding**—Opens the Color Coding Properties dialog box, allowing you to define annotation settings for the highlighted element type.
- **Add Folder**—Creates a folder under the currently highlighted element type, allowing you to manage the various color coding and annotation settings that are associated with an element. You can turn off all of the symbology settings contained within a folder by clearing the check box next to the folder. When a folder is deleted, all of the symbology settings contained within it are also deleted.

**Delete**
Deletes the currently highlighted Color Coding or Annotation Definition or folder.

**Rename**
Renames the currently highlighted object.

**Edit**
Opens a Properties dialog box that corresponds with the selected background layer.
Annotate: Opens a shortcut menu containing the following options:
- **Refresh Annotation**—If you change an annotation's prefix or suffix in the Property Editor, or directly in the database, selecting this command refreshes the annotation.
- **Update Annotation Offset**—If you have adjusted the Initial X or Y offsets, selecting this command resets all annotation Initial X or Y offsets to their default location (or new default location).
- **Update Annotation Height**—If you've adjusted the height multiplier, selecting this command resets all annotation height multipliers to their default values.

Shift Up: Moves the currently highlighted object up in the list pane.
Shift Down Moves the currently highlighted object down in the list pane.

Drawing Style Opens a menu containing the following commands:

- CAD Style—Displays currently highlighted element in CAD Style. Objects displayed in CAD style will appear smaller when zoomed out and larger when zoomed in.
- GIS Style—Displays currently highlighted element in GIS style. Objects displayed in GIS style will appear to remain the same size regardless of zoom level.

This button is only available in the Stand-Alone version (not in MicroStation or AutoCAD).

Tree Opens a menu containing the following commands:

- Expand All—Expands each branch in the tree view pane.
- Collapse All—Collapses each branch in the tree view pane.

Help Displays online help for the Element Symbology Manager.

### 9.1.1 Using Folders in the Element Symbology Manager

Use folders in the Element Symbology manager to create a collection of color coding and/or annotation that can be turned on or off at the same time.
**Adding Folders**

Use element symbology folders to control whether related annotations and/or color coding displays. To create a folder in the Element Symbology manager:

1. Click **View > Element Symbology**.
2. In the Element Symbology manager, right-click an element and select **New > Folder**.
   
   Or, select the element to which you want to add the folder, click the **New** button, then select **New Folder**.
3. Name the folder.
4. You can drag and drop existing annotations and color coding into the folder you create, and you can create annotations and color coding within the folder by right-clicking the folder and selecting **New > Annotation** or **New > Color Coding**.
5. Use the folder to collectively turn on and off the annotations and color coding within the folder.

**Deleting Folders**

Click **View > Element Symbology**. In the Element Symbology manager, right-click the theme folder you want to delete, then select **Delete**.

Or, select the folder you want to delete, then click the **Delete** button.

**Renaming Folders**

Click **View > Element Symbology**. In the Element Symbology manager, right-click the theme folder you want to rename, then select **Rename**.

Or, select the folder you want to rename, then click the **Rename** button.

**To add an annotation**

1. Click **View > Element Symbology**.
2. In the Element Symbology manager, right-click an element and select **New > Annotation**.
   
   Or, select the element where you want to add the annotation, click the **New** button, and select **New Annotation**.
3. The Annotation Properties dialog box opens. Select the annotation you want in the Field Name menu.
4. If needed, set a Prefix or Suffix. Anything you type as a prefix is added directly to the beginning of the label and anything you type as a suffix is added to the end (you may want to include spaces as part of your prefix and suffix).
Note: If you add an annotation that uses units, you can type “%u” in the prefix or suffix field to display the units in the drawing pane.

5. Select the initial X- and Y- offset for the annotation. Offset is measured from the center of the node or polygon or midpoint of the polyline.

6. If needed, set an initial height multiplier. Use a number greater than 1 to make the annotation larger and a number between 0 and 1 to make the annotation smaller. If you use a negative number, the annotation is flipped (rotated 180 degrees).

7. If you have created selection sets, you can apply your annotation only to a particular selection set by selecting that set from the Selection Set menu. If you have not created any selection sets, then the annotation is applied to all elements of the type you are using.

8. After you finish defining your annotation, click Apply and then OK to close the Annotation Properties dialog box and create your annotation. In order to close the dialog box without creating an annotation click Cancel.

To delete an annotation

Click View > Element Symbology. In the Element Symbology manager, right-click an annotation you want to delete, then select Delete.

Or, select the annotation you want to delete, then click the Delete button.

To edit an annotation

Click View > Element Symbology. In the Element Symbology manager, right-click the annotation you want to edit, then select Edit.

Or, select the annotation you want to edit, then click the Edit button and the Annotation Properties dialog box will open where you can make changes.

Rename an annotation

Click View > Element Symbology. In the Element Symbology manager, right-click the annotation you want to rename, then select Rename.

Or, select the annotation you want to rename, then click the Rename button.
9.1.2 **Annotation Properties**

Use the Annotation Properties dialog box to define annotation settings for each element type.

**Field Name**
Specify the attribute that is displayed by the annotation definition.

**Free Form**
This field is only available when <Free Form Annotation> is selected in the Field Name list. Click the ellipsis button to open the Free Form Annotation dialog box.

**Prefix**
Specify a prefix that is displayed before the attribute value annotation for each element to which the definition applies.

**Suffix**
Specify a suffix that is displayed after the attribute value annotation for each element to which the definition applies.

**Selection Set**
Specify a selection set to which the annotation settings will apply. If the annotation is to be applied to all elements, select the <All Elements> option in this field. <All Elements> is the default setting.

**Initial Offset Checkbox**
When this box is checked, changes made to the X and Y Offset will be applied to current and subsequently created elements. When the box is unchecked, only subsequently created elements will be affected.

**Note:** If you add an annotation that uses units, you can type “%u” in the prefix or suffix field to display the units in the drawing pane.
Initial X Offset
Displays the initial X-axis offset of the annotation in feet. Sets the initial horizontal offset for an annotation. Set this at the time you create the annotation. Clicking OK will cause the new value to be used for all subsequent elements that you place. Clicking Apply will cause the new value to be applied to all elements.

Initial Y Offset
Displays the initial Y-axis offset of the annotation in feet. Sets the initial vertical offset for an annotation. Set this at the time you create the annotation. Clicking OK will cause the new value to be used for all subsequent elements that you place. Clicking Apply will cause the new value to be applied to all elements.

Initial Multiplier Checkbox
When this box is checked, changes made to the Height Multiplier will be applied to current and subsequently created elements. When the box is unchecked, only subsequently created elements will be affected.

Initial Height Multiplier
Sets the initial size of the annotation text. Set this at the time you create the annotation. Clicking OK will cause the new value to be used for all subsequent elements that you place. Clicking Apply will cause the new value to be applied to all elements.

Free Form Annotation Dialog Box
The Free Form Annotation dialog box allows you to type custom annotations for an element type.
To create an annotation, type the text as you want it to appear in the drawing. You can add element attributes to the text string by clicking the Append button and selecting the attribute from the categorized list.

### 9.2 Color Coding A Model

Use color coding to help you quickly see what's going on in your model or to change the color and/or size of elements based on the value of data that you select, such as flow or element size.

To work with color coding, go to View > Element Symbology > New Color Coding to open the Color Coding Properties dialog box.

The dialog box consists of the following controls:

#### Properties

**Field Name**
Select the attribute by which the color coding is applied.

**Selection Set**
Apply a color coding to a previously defined selection set.

**Calculate Range**
Automatically finds the minimum and maximum values for the selected attribute and enters them in the appropriate Min. and Max fields.
**Minimum**
Define the minimum value of the attribute to be color coded.

**Maximum**
Define the maximum value of the attribute to be color coded.

**Steps**
Specify how many rows are created in the color maps table when you click Initialize. When you click Initialize, a number of values equal to the number of Steps are created in the color maps table. The low and high values are set by the Min and Max values you set.

**Color Map Options**
Select whether you want to use color coding, sizing, or both to code and display your elements.

Map colors to value ranges for the attribute being color coded. The following buttons are found along the top of the table:

- **New**—Creates a new row in the Color Maps table.

- **Delete**—Deletes the currently highlighted row from the Color Maps table.

- **Initialize**—Finds the range of values for the specified attribute, divides it into equal ranges based on the number of Steps you have set, and assigns a color to each range.

- **Ramp**—Generates a gradient range between two colors that you specify. Pick the color for the first and last values in the list, then Bentley StormCAD V8i automatically sets intermediate colors for the other values. For example, picking red as the first color and blue as the last color produces varying shades of purple for the other values.

- **Invert**—Reverse the order of the colors/sizes used in the Color Map table.
**Above Range Color** Displays the color that is applied to elements whose value for the specified attribute fall outside the range defined in the color maps table. This selection is available if you choose Color or Color and Size from the Options list.

**Above Range Size** Displays the size that is applied to elements whose value for the specified attribute fall outside the range defined in the color maps table. This selection is available if you choose Size or Color and Size from the Options list.

**To add color coding, including element sizing**

1. Click View > Element Symbology.
2. In the Element Symbology manager, right-click an element and select New > Color Coding.
   Or, select the element you want to add the color coding, click the New button, and select New Color Coding.
3. The Color Coding Properties dialog box opens. Select the properties you want to color code from the Field Name and Selection Set menus. Once you’ve selected the Field Name, more information opens.
4. In the Color Maps Options menu, select whether you want to apply color, size, or both to the elements you are coding.
   a. Click Calculate Range. This automatically sets the maximum and minimum values for your coding. These values can be set manually.
   b. Click Initialize. This automatically creates values and colors in the Color Map. These values can be set manually.
5. After you finish defining your color coding, click Apply and then OK to close the Color Coding Properties dialog box and create your color coding, or Cancel to close the dialog box without creating a color coding.
6. Click Compute to compute your network.
7. To see the network color coding and/or sizing change over time:
   a. Click Analysis > EPS Results Browser, if needed, to open the EPS Results Browser dialog box.
   b. Click Play to use the EPS Results Browser to review your color coding over time.

**To delete a color coding definition**
Click **View > Element Symbology**. In the Element Symbology manager, right-click the color coding you want to delete, then select **Delete**.

Or, select the color coding you want to delete, then click the **Delete** button.

**To edit a color coding definition**

Click **View > Element Symbology**. In the Element Symbology manager, right-click the color coding you want to edit, then select **Edit**.

Or, select the color coding you want to edit, then click the **Edit** button.
To rename a color coding definition

Click View > Element Symbology. In the Element Symbology manager, right-click the color coding you want to rename, then select Rename.

Or, select the color coding you want to rename, then click the Rename button.

9.2.1 Color Coding Legends

You can add color coding legends to the drawing view. A legend displays a list of the colors and the values associated with them for a particular color coding definition.

To add a color coding legend

Right-click the color coding definition in the Element Symbology dialog and select the Insert Legend command.

To move a color coding legend

1. Click the legend in the drawing view to highlight it.
2. Click and hold onto the legend grip (the square in the center of the legend), then drag the legend to the new location.

To resize a color coding legend

1. Right-click the legend in the drawing view and select the Scale command.
2. Move the mouse to resize the legend and click the left mouse button to accept the new size.

To remove a color coding legend

Right-click the color coding definition in the Element Symbology dialog and select the Remove Legend command.

To refresh a color coding legend

Right-click the color coding definition in the Element Symbology dialog and select the Refresh Legend command.

9.3 Contours

Using StormCAD V8i you can visually display calculated results for many attributes using contour plots.
The Contours dialog box is where all of the contour definitions associated with a project are stored. Choose View > Contours to open the Contours dialog box.

The dialog box contains a list pane that displays all of the contours currently contained within the project, along with a toolbar.

- **New** Opens the Contour Definition dialog box, allowing you to create a new contour.

- **Delete** Deletes the currently selected contour.

- **Rename** Renames the currently selected contour.

- **Edit** Opens the Contour Definition dialog box, where you can modify the settings of the currently selected contour.

- **Export** Clicking this button opens a submenu containing the following commands:
  - **Export to Shapefile** - Exports the contour to a shapefile, opening the Export to File Manager to select the shapefile.
  - **Export to DXF** - Exports the contour as a .dxf drawing.
  - **Export to Native Format** - Opens the DXF Properties dialog box, allowing you to add it to the Background Layers Manager.
Contours

View Contour Browser
Opens the Contour Browser dialog, allowing you to display detailed contour results for points in the drawing view.

Refresh
Regenerates the contour.

Shift Up
Moves the currently selected contour up in the list pane.

Shift Down
Moves the currently selected contour down in the list pane.

Help
Displays online help for the Contours.

9.3.1 Contour Definition

The Contour Definition dialog box contains the information required to generate contours for a calculated network.
**Contour**

**Field**
Select the attribute to apply the contour.

**Selection Set**
Apply an attribute to a previously defined selection set or to one of the following predefined options:
- **All Elements** - Calculates the contour based on all elements in the model, including spot elevations.
- **All Elements Without Spots** - Calculates the contour based on all elements in the model, except for spot elevations.

**Minimum**
Lowest value to be included in the contour map. It may be desirable to use a minimum that is above the absolute minimum value in the system to avoid creating excessive lines near a pump or other high-differential portions of the system.

**Maximum**
Highest value for which contours will be generated.

**Increment**
Step by which the contours increase. The contours created will be evenly divisible by the increment and are not directly related to the minimum and maximum values. For example, a contour set with 10 minimum, 20 maximum, and an increment of 3 would result in the following set: [12, 15, 18] not [10, 13, 16, 19].

**Index Increment**
Value for which contours will be highlighted and labeled. The index increment should be an even multiple of the standard increment.

**Smooth Contours**
The Contour Smoothing option displays the results of a contour map specification as smooth, curved contours.

**Line Weight**
The thickness of contour lines in the drawing view.

**Label Height Multiplier**
The size of the label text in the drawing view.
**Contours**

**Color by Range**

Contours are colored based on attribute ranges. Use the Initialize button to create five evenly spaced ranges and associated colors.

- **New**—Creates a new row in the list.
- **Delete**—Deletes the currently highlighted row in the list.
- **Initialize**—This button, located to the right of the Contour section, will initialize the Minimum, Maximum, Increment, and Index Increment values based on the actual values observed for the elements in the selection set.

**Tip:** Initialization can be accomplished by clicking the Initialize button to automatically generate values for the minimum, maximum, increment, and index increment to create an evenly spaced contour set.

- **Ramp**—Automatically generate a gradient range between two colors that you specify. Pick the color for the first and last values in the list and the program will select colors for the other values.
- **Invert**—Reverses the list.

**Color by Index**

The standard contours and index contours have separately controlled colors that you can make the contours more apparent.

**9.3.2 Contour Plot**

The Contour Plot window displays the results of a contour map specification as accurate, straight-line contours.

View the changes in the mapped attribute over time by using the animation feature. Choose Analysis > EPS Results Browser and click the **Play** button to automatically advance through the time step increments selected in the Increment bar.
The plot can be printed or exported as a .DXF file. Choose File > Export > DXF to export the plot.

**Tip:** Although the straight-line contours generated by this program are accurate, smooth contours are often more desirable for presentation purposes. You can smooth the contours by clicking Options and selecting Smooth Contours.

**Note:** Contour line index labels can be manually repositioned in this view before sending the plot to the printer. The Contour Plot Status pane displays the Z coordinate at the mouse cursor.

### 9.3.3 Contour Browser Dialog Box

The Contour Browser dialog box displays the X and Y coordinates and the calculated value for the contour attribute at the location of the mouse cursor in the drawing view.

### 9.4 Using Profiles

A profile is a graph that plots a particular attribute across a distance, such as ground elevation along a section of piping. As well as these side or sectional views of the ground elevation, profiles can be used to show other characteristics, such as hydraulic grade, pressure, and constituent concentration.
Using Profiles

You define profiles by selecting a series of adjacent elements. To create or use a profile, you must first open the Profiles manager. The Profiles manager is a dockable window where you can add, delete, rename, edit, and view profiles.

The Profiles dialog box is where you can create, view, and edit profile views of elements in the network.

The dialog box contains a list pane that displays all of the profiles currently contained within the project, along with a toolbar.

<table>
<thead>
<tr>
<th>Profiles</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image.png" alt="image" /></td>
</tr>
</tbody>
</table>

**Label**

- **1-1 to Outlet**
- **1-4 to 1-6**

**New**

Opens the Profile Setup dialog box, where you can select the elements to be included in the new profile from the drawing view.

**Delete**

Deletes the currently selected profile.
**Rename**  Renames the currently selected profile.

**Edit**  Opens the Profile Setup dialog box, where you can modify the settings of the currently selected profile.

**View Profile**  Opens a submenu containing the following commands:
- Profile: Opens the Profile viewer, allowing you to view the currently selected profile.
- Engineering Profile: Opens the Engineering Profile Viewer, allowing you to view the currently selected Engineering Profile.

**Help**  Displays online help for Profiles.
9.4.1 Profile Setup

Setting up a profile is a matter of selecting the adjacent elements on which the profile is based. When you click on New in the Profiles dialog box the following dialog box opens.

The Profile Setup dialog box includes the following options:

**Label**
Displays the list of elements that define the profile.

**User Defined Station**
Checking this box makes the Station field editable for the associated element, allowing you to define the station.

**Station**
Displays the station for the associated element. This field is non-editable unless the User Defined Station box is checked.

**Select From Drawing**
Selects and clears elements for the profile.
**Reverse**
Reverses the profile, so the first node in the list becomes the last and the last node becomes the first.

**Remove All**
Removes all elements from the profile.

**Remove All Previous**
Removes all elements that appear before the selected element in the list. If the selected element is a pipe, the associated node is not removed.

**Remove All Following**
Removes all elements that appear after the selected element in the list. If the selected element is a pipe, the associated node is not removed.

**Open Profile**
Closes the Profile Setup dialog box and opens the Profile Series Options dialog box.

### 9.4.2 Profile Viewer

This dialog box displays the profile view of the profile run that is plotted from the Profile Manager. It consists of the profile display pane and the following controls:

**Zoom Window:** Lets you magnify or reduce the display of a section of the graph. To zoom or magnify an area, select the Zoom Window tool, click to the left of the area you want to magnify, then drag the mouse to the right, across the area you want to magnify, so that the area you want to magnify is contained within the marquee that the Zoom Window tool draws. After you have selected the area you want to magnify, release the mouse button to stop dragging. To zoom out, or reduce the magnification, drag the mouse from right to left across the magnified image.

**Zoom Extents:** Magnifies the profile so that the entire graph is displayed.

**Chart Settings:** Opens a submenu containing the following commands:

- **Display Annotation Labels:** Lets you display or hide labels for the elements in your profile plot.
- **Profile Annotation Table:** Lets you display or hide the profile element annotation table.
- **HGL:** Lets you display or hide the line representing hydraulic grade line in the profile plot.
- **EGL:** Lets you display or hide the line representing energy grade line in the profile plot.
- **Legend:** Lets you display or hide the profile plot legend.
- **Axis Options**: Opens the Axis Options dialog.
- **Chart Options**: Opens the Chart Options dialog box, letting you view and modify the display settings for the current profile plot. For more information, see Chart Options Dialog Box.

**Warning!** Never delete or rename any of the series entries on the Series Tab of the Chart Options dialog box. These series were specifically designed to enable the display of the Profile Plots.

- **Export to DXF**: Exports the profile view as a dxf file.

**Print**: Prints the current view of the profile to your default printer. If you want to use a printer other than your default, use Print Preview to change the printer and print the profile.

**Print Preview**: Opens a print preview window containing the current view of the profile. You can use the Print Preview dialog box to select a printer and preview the output before you print it.

**Note**: Do not change the print preview to grayscale, as doing so might hide some elements of the display.

**Copy**:Copies the contents of the Profile Viewer dialog box as an image to the Windows clipboard, from where you can paste it into another application, such as Microsoft® Word® or Adobe® Photoshop®.

**Zoom Extents**: Magnifies the profile so that the entire graph is displayed.

**Zoom**: Lets you magnify or reduce the display of a section of the graph. To zoom or magnify an area, select the Zoom Window tool, click to the left of the area you want to magnify, then drag the mouse to the right, across the area you want to magnify, so that the area you want to magnify is contained within the marquee that the Zoom Window tool draws. After you have selected the area you want to magnify, release the mouse button to stop dragging. To zoom out, or reduce the magnification, drag the mouse from right to left across the magnified image.
9.4.3  Engineering Profile Viewer Dialog Box

This dialog box displays the profile view of the profile run that is plotted from the Profile Manager. It consists of the profile display pane and the following controls:

**Zoom Window**

- Lets you magnify or reduce the display of a section of the graph. To zoom or magnify an area, select the Zoom Window tool, click to the left of the area you want to magnify, then drag the mouse to the right, across the area you want to magnify, so that the area you want to magnify is contained within the marquee that the Zoom Window tool draws. After you have selected the area you want to magnify, release the mouse button to stop dragging.
- To zoom out, or reduce the magnification, drag the mouse from right to left across the magnified image.

**Zoom Extents**

- Magnifies the profile so that the entire graph is displayed.
**Chart Settings**

Opens a submenu containing the following commands:

- **Display Annotation Labels**: Lets you display or hide labels for the elements in your profile plot.
- **Profile Annotation Table**: Lets you display or hide the profile element annotation table.
- **HGL**: Lets you display or hide the line representing hydraulic grade line in the profile plot.
- **EGL**: Lets you display or hide the line representing energy grade line in the profile plot.
- **Legend**: Lets you display or hide the profile plot legend.
- **Axis Options**: Opens the Axis Options dialog.
- **Chart Options**: Opens the Chart Options dialog box, letting you view and modify the display settings for the current profile plot. For more information, see [Chart Options Dialog Box on page 8-471](#).

**Warning!** Never delete or rename any of the series entries on the Series Tab of the Chart Options dialog box. These series were specifically designed to enable the display of the Profile Plots.

- **Export to DXF**: Exports the profile view as a dxf file.

**Print**

Prints the current view of the profile to your default printer. If you want to use a printer other than your default, use Print Preview to change the printer and print the profile.

**Print Preview**

Opens a print preview window containing the current view of the profile. You can use the Print Preview dialog box to select a printer and preview the output before you print.

**Note**: Do not change the print preview to grayscale, as doing so might hide some elements of the display.
Copy

Copies the contents of the Profile Viewer dialog box as an image to the Windows clipboard, from where you can paste it into another application, such as Microsoft® Word® or Adobe® Photoshop®.

Zoom Extents

Magnifies the profile so that the entire graph is displayed.

Zoom

Lets you magnify or reduce the display of a section of the graph. To zoom or magnify an area, select the Zoom Window tool, click to the left of the area you want to magnify, then drag the mouse to the right, across the area you want to magnify, so that the area you want to magnify is contained within the marquee that the Zoom Window tool draws. After you have selected the area you want to magnify, release the mouse button to stop dragging. To zoom out, or reduce the magnification, drag the mouse from right to left across the magnified image.

Engineering Profile Options

This dialog allows you to change various display options for engineering profiles. It is divided into the following tabs:

Axis Tab

This tab contains the following controls:

- **Scale**: Allows you to define the horizontal and vertical scale of the engineering profile view.
- **Direction**: Allows you to choose the direction in which elements are displayed in the engineering profile view.
- **Axis Labeling**: Allows you to choose where to place the labels along the axis of the engineering profile view.
- **Automatic Scaling**: When this box is checked the scaling is handled automatically and the Minimum and Maximum fields are not editable. When this box is not checked you can define the Minimum and Maximum fields.
- **Minimum**: The left-most station. When Automatic Scaling is checked this field is not editable.
• **Maximum**: The right-most station. When Automatic Scaling is checked this field is not editable.

• **Increment**: The length between intermediate values.

**Drawing Tab**

This tab contains the following controls:

• **Text Height Multiplier**: Increases or decreases the size of the text by the factor indicated.

• **Ground Elevation Line Width**: This field allows you to define the width of the ground elevation line in the engineering profile view.

• **Structure Line Width**: This field allows you to define the width of structure lines in the engineering profile view.

• **HGL Line Width**: This field allows you to define the width of the hydraulic grade line in the engineering profile view.

• **EGL Line Width**: This field allows you to define the width of the energy grade line in the engineering profile view.

**Layers Tab**

This tab allows you to select the color and/or change the visibility of the various elements of the profile view. Uncheck the *Is Visible* box to turn the corresponding element off in the engineering profile view. Click the *Layer Color* to access the color menu to change the color of the corresponding element in the engineering profile view.

**Ground Profile Options**

This dialog allows you to define the line representing ground elevation in the engineering profile view.

By default, the Elevation Data Type is set to Automatic. If you change it to Ground Elevation/Depth Curve, you can use the Station vs. Elevation table to define the ground elevation. Click the New button to add a row to the table or Delete to remove the currently highlighted row. Click the Import button to import ground elevation data from a Tab-delimited text file.

**Annotation Properties Dialog Box**

This dialog allows you to modify the settings of the profile annotation for nodes. The following controls are available:

• **Horizontal Justification**: This control allows you to select the horizontal (left-to-right) placement of the annotation over the annotated element.
• **Vertical Justification**: This control allows you to select the vertical (up-and-down) placement of the annotation over the annotated element.

• **Rotation**: This control allows you to enter the angle of rotation of the annotation over an annotated element.

• **Show Leader Line**: When this box is checked, a line is drawn between the annotation and the associated element.

• **Show Leader Arrow**: When this box is checked, an arrow is drawn pointing to the associated element.

**Link Annotation Properties Dialog Box**

This dialog allows you to modify the settings of the profile annotation for links. The following controls are available:

• **Align Text With Pipes**: When this box is checked the annotation will align with the angle of the corresponding pipe.

• **Horizontal Justification**: This control allows you to select the horizontal (left-to-right) placement of the annotation over the annotated element.

• **Vertical Justification**: This control allows you to select the vertical (up-and-down) placement of the annotation over the annotated element.

• **Rotation**: This control allows you to enter the angle of rotation of the annotation over an annotated element.

• **Show Leader Line**: When this box is checked, a line is drawn between the annotation and the associated element.

• **Show Leader Arrow**: When this box is checked, an arrow is drawn pointing to the associated element.

**Text Properties**

This dialog allows you to modify the settings of the profile annotation for the axis labels. The following controls are available:

• **Text**: This field displays the text of the label. This field is not editable.

• **Horizontal Justification**: This control allows you to select the horizontal (left-to-right) placement of the label annotation.

• **Vertical Justification**: This control allows you to select the vertical (up-and-down) placement of the label annotation.

• **Rotation**: This control allows you to enter the angle of rotation of the label annotation.
**Annotation Properties**

Use the Annotation Properties dialog box to define annotation settings for your engineering profiles.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Specify the attribute that is displayed by the annotation definition.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Free Form</td>
<td>This field is only available when &lt;Free Form Annotation&gt; is selected in the Field Name list. Click the ellipsis button to open the Free Form Annotation dialog box.</td>
</tr>
<tr>
<td>Selection Set</td>
<td>Specify a selection set to which the annotation settings will apply. If the annotation is to be applied to all elements, select the &lt;All Elements&gt; option in this field. &lt;All Elements&gt; is the default setting.</td>
</tr>
<tr>
<td>Initial Offset Checkbox</td>
<td>When this box is checked, changes made to the X and Y Offset will be applied to current and subsequently created elements. When the box is unchecked, only subsequently created elements will be affected.</td>
</tr>
<tr>
<td>X Offset</td>
<td>Displays the initial X-axis offset of the annotation in feet. Sets the initial horizontal offset for an annotation. Set this at the time you create the annotation. Clicking OK will cause the new value to be used for all subsequent elements that you place. Clicking Apply will cause the new value to be applied to all elements.</td>
</tr>
<tr>
<td>Y Offset</td>
<td>Displays the initial Y-axis offset of the annotation in feet. Sets the initial vertical offset for an annotation. Set this at the time you create the annotation. Clicking OK will cause the new value to be used for all subsequent elements that you place. Clicking Apply will cause the new value to be applied to all elements.</td>
</tr>
</tbody>
</table>
**Initial Multiplier Checkbox**

When this box is checked, changes made to the Height Multiplier will be applied to current and subsequently created elements. When the box is unchecked, only subsequently created elements will be affected.

**Height Multiplier**

Sets the initial size of the annotation text. Set this at the time you create the annotation. Clicking OK will cause the new value to be used for all subsequent elements that you place. Clicking Apply will cause the new value to be applied to all elements.

## 9.5 Viewing and Editing Data in FlexTables

Using FlexTables you can view input data and results for all elements of a specific type in a tabular format. You can use the standard set of FlexTables or create customized FlexTables to compare data and create reports.

You can view all elements in the project, all elements of a specific type, or any subset of elements. Additionally, to ease data input and present output data for specific elements, FlexTables can be:

- Filtered
- Globally edited
- Sorted.

If you need to edit a set of properties for all elements of a certain type in your network, you might consider creating a FlexTable and making your changes there rather than editing each element one at a time in sequence.

FlexTables can also be used to create results reports that you can print, save as a file, or copy to the Windows clipboard for copying into word processing or spreadsheet software.

To work with FlexTables, select the FlexTables manager or go to **View > FlexTables** <Ctrl+7> to open the FlexTables manager if it is closed.
9.5.1 FlexTables

Using the FlexTables manager you can create, manage, and delete custom tabular reports. The dialog box contains a list pane that displays all of the custom FlexTables currently contained within the project, along with a toolbar.
The toolbar contains the following icons:

**New**
Opens a menu containing the following commands:

- **FlexTable**—Creates a new tabular report and opens the FlexTable Setup dialog box, where you can define the element type that the FlexTable displays and the columns that are contained in the table.

- **2-Row FlexTable**—Creates a new two-row tabular report and opens the FlexTable Setup dialog box, where you can define the columns that are contained in the table. 2-Row FlexTables can only be created for the Conduit element type. See [2-Row Flextables](#) for more information.

- **Folder**—Creates a folder in the list pane in order to group custom FlexTables.

**Delete**
Deletes the currently selected FlexTable.

**Rename**
Renames the currently selected FlexTable.
### 9.5.2 Working with FlexTable Folders

You can add, delete, and rename folders in the FlexTable manager to organize your FlexTables into groups that can be turned off as one entity. You can also create folders within folders. When you start a new project, Bentley StormCAD V8i displays two items in the FlexTable manager: Tables - Project (for project-level FlexTables) and Tables - Shared (for FlexTables shared by more than one Bentley StormCAD V8i project). You can add new FlexTables and FlexTable folders to either item or to existing folders.

**To add a FlexTable folder**

1. Click **View > FlexTables** or ![FlexTables](image) to open the FlexTables manager.
2. In the FlexTable manager, select either Tables - Project or Tables - Shared, then click the New button.
   - If you are creating a new folder within an existing folder, select the folder, then click the New button.
3. Click **New Folder** from the menu.
4. Right-click the new folder and click **Rename** or click **Ren**.
5. Type the name of the folder, then press **<Enter>**.

**To delete a FlexTable folder**

1. Click **View > FlexTables** to open the FlexTables manager.
2. In the FlexTables manager, select the folder you want to delete, then click the Delete button.
   – You can also right-click a folder to delete, then select **Delete** from the shortcut menu.

**To rename a FlexTable folder**

1. Click **View > FlexTables** to open the FlexTables manager.
2. In the FlexTables manager, select the folder you want to rename, then click the Rename button.
   – You can also right-click a folder to rename, then select **Rename** from the shortcut menu.
3. Type the new name of the folder, then press **Enter**.
   – You can also rename a FlexTable folder by selecting the folder, then modifying its label in the Properties Editor.

**9.5.3 FlexTable Dialog Box**

FlexTables are displayed in the FlexTable dialog box. The dialog box contains a toolbar, the rows and columns of data in the FlexTable, and a status bar.

The toolbar contains the following buttons:
## Viewing and Editing Data in FlexTables

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Export</strong></td>
<td>Export to a Tab Delimited file .txt or a Comma Delimited File .csv.</td>
</tr>
<tr>
<td><strong>Copy</strong></td>
<td>Copy the contents of the selected table cell, rows, and/or columns for the purpose of pasting into a different row or column or into a text editing program such as Notepad.</td>
</tr>
<tr>
<td><strong>Paste</strong></td>
<td>Paste the contents of the Windows clipboard into the selected table cell, row, or column. Use this with the Copy button.</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td>Opens the FlexTable Setup dialog box, so you can make changes to the format of the currently selected table.</td>
</tr>
</tbody>
</table>
**Zoom To**
Zooms into and centers the drawing pane on the currently selected element in the FlexTable.

**Report**
Report Current Time Step or Report in XML.

**Selection Set**
Opens a submenu containing the following commands:
- **Create Selection Set**—Creates a new static selection set (a selection set based on selection) containing the currently selected elements in the FlexTable.
- **Add to Selection Set**—Adds the currently selected elements in the FlexTable to an existing selection set.
- **Remove From Selection Set**—Removes the currently selected elements from the selection set.
- **Relabel**—Opens an Element Relabeling box where you can Replace, Append, or Renumber.

**Select in Drawing**
Opens a submenu containing the following commands:
- **Select In Drawing**—Selects the currently highlighted element(s) in the drawing pane.
- **Add to Selection**—Adds the currently highlighted element(s) to the group that is currently highlighted in the drawing pane.
- **Remove From Selection**—Removes the currently highlighted element(s) from the group that is currently highlighted in the drawing pane.

### 9.5.4 Opening FlexTables
You open FlexTables from within the FlexTable manager.
To open FlexTables

1. Click View > FlexTables or click the FlexTables button on the View toolbar to open the FlexTables manager.

2. Perform one of the following steps:
   - Right-click the FlexTable you want to open, then select Open.
   - Select the FlexTable you want to open, then click the Open button.
   - Double-click the FlexTable you want to open.

9.5.5 Creating a New FlexTable

You can create project-level or shared FlexTables.

- Project-level FlexTables are available only for the project in which you create them.
- Shared tables are available in all projects.

To create a new FlexTable

Project-level and shared FlexTables are created the same way:

1. Click View > FlexTables or click the FlexTables button on the View toolbar to open the FlexTables manager.

2. In the FlexTables manager, right-click Tables - Project or Tables - Shared, then select New > FlexTable.
   - Or, select Tables - Project or Tables - Shared, click the New button, then select FlexTable.

3. The Table Setup dialog box opens.

4. Select the Table Type to be created.

5. Filter the table by element type.

6. Select the items to be included by double-clicking on the item or select the item and click the Add arrow to move to the Selected Columns pane.

7. Click OK.

8. The table displays in the FlexTables manager; you can type to rename the table or accept the default name.
9.5.6 Deleting FlexTables

Click View > FlexTables to open the FlexTables manager. In the FlexTables manager, right-click the FlexTable you want to delete, then select Delete.

Or, select the FlexTable you want to delete, then click the Delete button. You cannot delete predefined FlexTables.

Note: You cannot delete predefined FlexTables.

9.5.7 Naming and Renaming FlexTables

You name and rename FlexTables in the FlexTable manager.

To rename FlexTables

1. Click View > FlexTables or click the FlexTables button on the View toolbar to open the FlexTables manager.
2. Perform one of the following steps:
   - Right-click the FlexTable you want to rename, then select Rename.
   - Select the FlexTable you want to rename, then click the Rename button.
   - Click the FlexTable you want to rename, to select it, then click the name of the FlexTable.

Note: You cannot rename predefined FlexTables.

9.5.8 Editing FlexTables

You can edit a FlexTable to change the columns of data it contains or the values in some of those columns.

Editable columns: Columns that contain data you can edit are displayed with a white background. You can change these columns directly in the FlexTable and your changes are applied to your model when you click OK.

The content in the FlexTable columns can be changed in other areas, such as in a Property Editor or managers.

If you make a change that affects a FlexTable outside the FlexTable, the FlexTable is updated automatically to reflect the change.
Non-editable columns: Columns that contain data you cannot edit are displayed with a yellow background and correspond to model results calculated by the program and composite values.

The content in these columns can be changed in other areas, for example a Property Editor or by running a computation.

If you make a change that affects a FlexTable outside the FlexTable, the FlexTable is updated automatically to reflect the change.

To edit a FlexTable

1. Click View > FlexTables to open the FlexTables manager, then you can:
   - Right-click the FlexTable, then select Edit.
   - Double-click the FlexTable to open it, then click Edit.
   - Click the FlexTable to select it, then click the Edit button.

2. The Table dialog box opens.

3. Use the Table dialog box to include and exclude columns and change the order in which the columns appear in the table.

4. Click OK after you finish making changes to save your changes and close the dialog box; or click Cancel to close the dialog box without making changes.

Editing Column-Heading Text

To change the text of a column heading:

1. Click View > FlexTables to open the FlexTables manager.

2. In the FlexTables manager, open the FlexTable you want to edit.

3. Right-click the column heading and select Edit Column Label.

4. Type the new name for the label and click OK to save those changes and close the dialog box or Cancel to exit without making any changes.

Changing Units, Format, and Precision in FlexTables
To change the units, format, or precision in a column of a FlexTable:

1. Click View > FlexTables to open the FlexTables manager.
2. In the FlexTables manager, open the FlexTable you want to edit.
3. Right-click the column heading and select Units.
4. Make the changes you want and click OK to save those changes or Cancel to exit without making any changes.

Navigating in Tables

The arrow keys, <Ctrl+End>, <Page Up>, <Page Down>, and <Ctrl+arrow> keys navigate to different cells in a table.
Globally Editing Data

Using FlexTables, you can globally edit all of the values in an entire editable column. Globally editing a FlexTable column can be more efficient for editing properties of an element than using the Properties Editor or managers to edit each element in your model individually.

Operation

Select the type of edit to perform:

- **Set**: Changes each of the entries in the column to the value in the Value box.
- **Add**: Adds the value in the Value box to each of the entries in the column.
- **Divide**: Divides each of the entries in the column by the value in the Value box.
- **Multiply**: Multiplies each of the entries in the column by the value in the Value box.
- **Subtract**: Subtracts the value in the Value box from each of the entries in the column.

Value

Type the value that will be used in the chosen Operation to edit the entries of the column.

Where

When the Table has an active filter, the SQL Query used by the filter is displayed in this pane.

To globally edit the values in a FlexTable column

1. Click **View > FlexTables** to open the FlexTables manager.
2. In the FlexTables manager, open the FlexTable you want to edit and find the column of data you want to change.
If necessary, you might need to first create a FlexTable or edit an existing one to make sure it contains the column you want to change.

3. Right-click the column heading and select **Global Edit**.
4. In the **Operation** field, select what you want to do to data in the column: Add, Divide, Multiply, Set, or Subtract.

   **Note:** The **Operation field is only available for numeric data**.

5. In the **Global Edit** field, type or select the value.

### 9.5.9 Sorting and Filtering FlexTable Data

You can sort and filter your FlexTables to focus on specific data or present your data in one of the following ways:

**To sort the order of columns in a FlexTable**

You can sort the order of columns in a FlexTable in two ways:

- Edit the FlexTable; open the Table dialog box and change the order of the selected tables using the up and down arrow buttons.
  
The top-most item in the Selected Columns pane appears furthest to the left in the resulting FlexTable.

- Open the FlexTable, click the heading of the column you want to move, then click again and drag the column to the new position. You can only move one column at a time.

**To sort the contents of a FlexTable**

1. Open the FlexTable to be edited.
2. Right-click a column heading to rank the contents of the column.
3. Select **Sort** then choose.
   - **Sort Ascending**—Sorts alphabetically from A to Z, from top to bottom. Sorts numerically from negative to positive, from top to bottom. Sorts selected check boxes to the top and cleared ones to the bottom.
   - **Sort Descending**—Sorts alphabetically from Z to A, from top to bottom. Sorts numerically from positive to negative, from top to bottom. Sorts cleared check boxes to the top and selected ones to the bottom.
   - **Custom**—Select one or more sort keys
   - **Reset**—Back to the original sorting order
To filter a FlexTable

Filter a FlexTable by creating a query.

1. Open the FlexTable to be filtered.
2. Right-click the column heading to filter and select **Filter**.
   
   Select **Custom** to open the Query Builder dialog box.
3. All input and results fields for the selected element type appear in the Fields list pane, available SQL operators and keywords are represented by buttons, and available values for the selected field are listed in the Unique Values list pane. Perform the following steps to construct your query:
   
a. Double-click the field to include in your query. The database column name of the selected field appears in the preview pane.

b. Click the desired operator or keyword button. The SQL operator or keyword is added to the SQL expression in the preview pane.

c. Click the **Refresh** button above the Unique Values list pane to see a list of unique values available for the selected field. The **Refresh** button becomes disabled after you use it for a particular field.

d. Double-click the unique value you want to add to the query. The value is added to the SQL expression in the preview pane.

e. Click **Apply** above the preview pane to validate your SQL expression. If the expression is valid, the window “Query Successful” opens. Click **OK**. The word **VALIDATED** will be at the bottom of the window.
f. Click OK.

The FlexTable displays columns of data for all elements returned by the query and the word “FILTERED” is displayed in the FlexTable status bar.

The status pane at the bottom of the Table window always shows the number of rows displayed and the total number of rows available (for example, 10 of 20 elements displayed).

If you change the values for an attribute that is being sorted or filtered, the sort or filter operation needs to be reapplied. To do this, use the Apply Sort/Filter command accessible from the right-click context menu.

To reset a filter

1. Right-click the column heading you want to filter.
2. Select Filter.
3. Click Reset.
4. Click **Yes** to reset the active filter.

**To reapply a sort or filter operation**

1. Right-click the column heading for the sort or filter operation you want reapplied.
2. Select Apply Sort/Filter.

**Custom Sort Dialog Box**

You can sort elements in the table based on one or more columns in ascending or descending order. For example, the following table is given:

<table>
<thead>
<tr>
<th>Slope (ft./ft.)</th>
<th>Depth (ft.)</th>
<th>Discharge (cfs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.001</td>
<td>1</td>
<td>4.11</td>
</tr>
<tr>
<td>0.002</td>
<td>1</td>
<td>5.81</td>
</tr>
<tr>
<td>0.003</td>
<td>1</td>
<td>7.12</td>
</tr>
<tr>
<td>0.001</td>
<td>2</td>
<td>13.43</td>
</tr>
<tr>
<td>0.002</td>
<td>2</td>
<td>19.00</td>
</tr>
<tr>
<td>0.003</td>
<td>2</td>
<td>23.27</td>
</tr>
</tbody>
</table>
A custom sort is set up to sort first by Slope, then by Depth, in ascending order. The resulting table would appear in the following order:

<table>
<thead>
<tr>
<th>Slope (ft./ft.)</th>
<th>Depth (ft.)</th>
<th>Discharge (cfs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.001</td>
<td>1</td>
<td>4.11</td>
</tr>
<tr>
<td>0.001</td>
<td>2</td>
<td>13.43</td>
</tr>
<tr>
<td>0.002</td>
<td>1</td>
<td>5.81</td>
</tr>
<tr>
<td>0.002</td>
<td>2</td>
<td>19.00</td>
</tr>
<tr>
<td>0.003</td>
<td>1</td>
<td>7.12</td>
</tr>
<tr>
<td>0.003</td>
<td>2</td>
<td>23.27</td>
</tr>
</tbody>
</table>

### 9.5.10 Customizing Your FlexTable

There are several ways to customize tables to meet a variety of output requirements:

- **Changing the Report Title**—When you print a table, the table name is used as the title for the printed report. You can change the title that appears on your printed report by renaming the table.

- **Adding/Removing Columns**—You can add, remove, and change the order of columns from the Table Setup dialog box.

- **Drag/Drop Column Placement**—With the Table window open, select the column heading of the column that you would like to move and drag the column to its new location.

- **Resizing Columns**—With the Table open, click the vertical separator line between column headings. Notice that the cursor changes shape to indicate that you can resize the column. Drag the column separator to the left or right to stretch the column to its new size.

- **Changing Column Headings**—With the Table window open, right-click the column heading that you wish to change and select **Edit Column Label**.
9.5.11 **Element Relabeling Dialog**

This dialog is where you perform global element relabeling operations for the Label column of the FlexTable.

The element relabeling tool allows you to perform three types of operations on a set of element labels: Replace, Renumber, and Append. The active relabel operation is chosen from the list box in the Relabel Operations section of the Relabel Elements dialog box. The entry fields for entering the information appropriate for the active relabel operation appear below the Relabel Operations section. The following list presents a description of the available element relabel operations.

- **Replace**—This operation allows you to replace all instances of a character or series of characters in the selected element labels with another piece of text. For instance, if you selected elements with labels P-1, P-2, P-12, and J-5, you could replace all the Ps with the word Pipe by entering P in the Find field, Pipe in the Replace With field, and clicking the Apply button. The resulting labels are Pipe-1, Pipe-2, Pipe-12, and J-5. You can also use this operation to delete portions of a label. Suppose you now want to go back to the original labels. You can enter Pipe in the Find field and leave the Replace With field blank to reproduce the labels P-1, P-2, P-12, and J-5. There is also the option to match the case of the characters when searching for the characters to replace. This option can be activated by checking the box next to the Match Case field.

- **Renumber**—This operation allows you to generate a new label, including suffix, prefix, and ID number for each selected element. For example, if you had the labels P-1, P-4, P-10, and Pipe-12, you could use this feature to renumber the elements in increments of five, starting at five, with a minimum number of two digits for the ID number field. You could specify a prefix P- and a suffix -Z1 in the Prefix and Suffix fields, respectively. The prefix and suffix are appended to the front and back of the automatically generated ID number. The value of the new ID
for the first element to be relabeled, 5, is entered in the Next field. The value by which the numeric base of each consecutive element is in increments, 5, is entered in the Increment field. The minimum number of digits in the ID number, 2, is entered in the Digits field. If the number of digits in the ID number is less then this value, zeros are placed in front of it. Click the Apply button to produce the following labels: P-05-Z1, P-10-Z1, P-15-Z1, and P-20-Z1.

- **Append**—This operation allows you to append a prefix, suffix, or both to the selected element labels. Suppose that you have selected the labels 5, 10, 15, and 20, and you wish to signify that these elements are actually pipes in Zone 1 of your system. You can use the append operation to add an appropriate prefix and suffix, such as P- and -Z1, by specifying these values in the Prefix and Suffix fields and clicking the Apply button. Performing this operation yields the labels P-5-Z1, P-10-Z1, P-15-Z1 and P-20-Z1. You can append only a prefix or suffix by leaving the other entry field empty. However, for the operation to be valid, one of the entry fields must be filled in.

The Preview field displays an example of the new label using the currently defined settings.
9.5.12 **FlexTable Setup Dialog Box**

The Table Setup dialog box is where you can customize tables through the following options:

![Image of the Table Setup dialog box]

**Table Type**

Specifies the type of elements that appear in the table. It also provides a filter for the attributes that appear in the Available Columns list. When you choose a table type, the available list only contains attributes that can be used for that table type. For example, only manhole attributes are available for a manhole table.

If you choose Network Elements, attributes for all network elements will appear and a read-only table will be generated. This table can be sorted upstream or downstream for full network reporting.
Available Columns
Contains all the attributes that are available for your table design. The Available Columns list is located on the left side of the Table Setup dialog box. This list contains all of the attributes that are available for the type of table you are creating. The attributes displayed in yellow represent non-editable attributes, while those displayed in white represent editable attributes. Click the Arrow button [>] to open a submenu that contains all of the available fields grouped categorically.

Selected Columns
Contains attributes that appear in your custom designed FlexTable. When you open the table, the selected attributes appear as columns in the table in the same order that they appear in the list. You can drag and drop or use the up and down buttons to change the order of the attributes in the table. The Selected Columns list is located on the right-hand side of the Table Setup dialog box. To add columns to the Selected Columns list, select one or more attributes in the Available Columns list, then click the Add button [>].

Add and Remove Buttons
Select or clear columns to be used in the table and arrange the order the columns appear. The Add and Remove buttons are located in the center of the Table Setup dialog box.

- [ > ] Adds the selected items from the Available Columns list to the Selected Columns list.
- [ >> ] Adds all of the items in the Available Columns list to the Selected Columns list.
- [ < ] Removes the selected items from the Selected Columns list.
- [ << ] Removes all items from the Selected Columns list.

To rearrange the order of the attributes in the Selected Columns list, select the item to be moved, then click the up or down button.
9.5.13 Copying, Exporting, and Printing FlexTable Data

You can output your FlexTable several ways:

- Copy FlexTable data using the clipboard
- Export FlexTable data as a text file
- Create a FlexTable report.
To copy FlexTable data using the clipboard

You can copy your FlexTable data using the clipboard and paste it into another Windows application, such as a word-processing application as tab-delimited text.

1. Click **View > FlexTables** to open the FlexTables manager.
2. In the FlexTables manager, open the FlexTable you want to use.
3. Click **Copy**. The contents of the FlexTable are copied to the Windows clipboard.

   **Caution:** Make sure you paste the data you copied before you copy anything else to the Windows clipboard. If you copy something else to the clipboard before you paste your FlexTable data, your FlexTable data will be lost from the clipboard.

4. Paste <Ctrl+v> the data into other Windows software, such as your word-processing application.

To export FlexTable data as a text file

You can export the data in a FlexTable as tab- or comma-delimited ASCII text for use in other applications, such as Notepad, spreadsheet, or word processing software.

1. Click **View > FlexTables** to open the FlexTables manager.
2. In the FlexTables manager, open the FlexTable you want to use.
3. Click **Export to File**.
4. Select either **Tab Delimited** or **Comma Delimited**.
5. When prompted, set the path and name of the .txt file you want to create.

To create a FlexTable report

Create a FlexTable Report if you want to print a copy of your FlexTable and its values.

1. Click **View > FlexTables** to open the FlexTables manager.
2. In the FlexTables manager, open the FlexTable you want to use.

   **Note:** Instead of Print Preview, you can click Print to print the report without previewing it.

3. Click **Report** and select one of the options. A print preview of the report displays to show what your report will look like.
Note: You cannot edit the format of the report.

9.5.14 Statistics Dialog Box

The Statistics dialog box displays statistics for the elements in a FlexTable. You can right-click any unitized input or output column and choose the Statistics command to view the count, maximum value, mean value, minimum value, standard deviation, and sum for that column.

9.5.15 2-Row FlexTables

2-row Flextables are a special tabular report that displays two rows for each conduit contained within the table. The combined rows are as follows:

- **-Node- Upstream Downstream**
  - First Row - Upstream Node Label
  - Second Row - Downstream Node Label

- **-Depth- Upstream Downstream**
  - First Row - Computed depth for the upstream node
  - Second Row - Computed depth for the downstream node

- **-EGL- Upstream Downstream**
  - First Row - Computed EGL for the upstream node
  - Second Row - Computed EGL for the downstream node

- **-HGL- Upstream Downstream**
  - First Row - Computed HGL for the upstream node
  - Second Row - Computed HGL for the downstream node

- **-Invert- Upstream Downstream**
  - First Row - Invert elevation of the upstream node
  - Second Row - Invert elevation of the downstream node
• -X- Upstream Downstream
  – First Row - X coordinate for the upstream node
  – Second Row - X coordinate for the downstream node
• -Y- Upstream Downstream
  – First Row - Y coordinate for the upstream node
  – Second Row - Y coordinate for the downstream node
• -Section Discharge Capacity
  – First Row - Section discharge
  – Second Row - Section capacity

Note: Sorting and Filtering operations are not available for the combined fields listed above.

9.6 Reporting

Use reporting to create printable content based on some aspect of your model, such as element properties or results.

You need to compute your model before you can create reports about results, such as the movement of water in your network. You can also create reports about input data without computing your model, such as conduit diameters. (To compute your model, after you set up your elements and their properties, click Compute.)

You can access reports by:

• Clicking the Report menu.
• Right-clicking any element, then selecting Report.

9.6.1 Using Standard Reports

There are several standard reports available. To access the standard reports, click the Report menu, then select the report.

Reports for Individual Elements

You can create reports for specific elements in your network by computing the network, right-clicking the element, then selecting Report. You cannot format the report, but you can print it by clicking the Print icon.
Creating a Scenario Summary Report

To create a report that summarizes your scenario, click Report > Scenario Summary. The report dialog box opens and displays your report. You cannot format the report, but you can print it by clicking the Print button.

Creating a Project Inventory Report

To create a report that provides an overview of your network, click Report > Project Inventory. The report dialog box opens and displays your report. You cannot format the report, but you can print it by clicking the Print button.

Creating a Conduit Inventory Report

To create a report that lists the total lengths of conduit by diameter and material type, click Report > Conduit Inventory. The report dialog opens and displays the Conduit Inventory report.

You can copy rows, columns, or the entire table to the clipboard by highlighting the desired rows and/or columns and clicking Ctrl+C.

Creating A DOT Report

The DOT report presents data about the conduits in your model. The report displays the following read-only attributes for each conduit in the model:

- Upstream and Downstream Node
- Upstream Inlet Area
- Upstream Inlet C
- Upstream CA
- Upstream and Downstream Ground Elevation
- Upstream and Downstream HGL
- Section Discharge Capacity
- Length
- Average Velocity

To create a DOT report, click Report > Element Data > DOT Report.

Report Options

The Report Options dialog box offers control over how a report is displayed.
Presenting Your Results

Load factory default settings to current view. Click to restore the default settings to the current view.

Load global default settings to current view. Click to view the stored global settings as local settings.

Save current view settings to global settings. Click to set the current report options as the global default.

The header and footer can be fully customized and you can edit text to be displayed in the cells or select a pre-defined dynamic variable from the cell’s menu.

- % (Company) - The name specified in the project properties.
- % (DateTime) - The current system date and time.
- % (BentleyInfo) - The standard Bentley company information.
- % (BentleyName) - The standard Bentley company name information.
- % (Pagination) - The report page out of the maximum pages.
- % (ProductInfo) - The current product and its build number.
- % (ProjDirectory) - The directory path where the project file is stored.
- % (ProjEngineer) - The engineer specified in the project properties.
- % (ProjFileName) - The full file path of the current project.
- % (ProjStoreFileName) - The full file path of the project.
Print Preview Window

- % (ProjTitle) - The name of the project specified in the project properties.
- % (ReportTitle) - The name of the report.
- % (Image) - Allows you to browse to and attach an image to the report header.
- % (AcademicLicense) - Adds text string: Licensed for Academic Use Only.
- % (HomeUseLicense) - Adds text string: Licensed for Home Use Only.
- % (ActiveScenarioLabel) - The label of the currently active scenario.

You can also select fonts, text sizes, and customize spacing, as well as change the default margins in the Default Margins tab.

9.7 Print Preview Window

The Print Preview window can be used to print documents, such as reports and graphs. You can see the current view of the document as it will be printed and define the print settings.

The following controls are available in the Print Preview window:

- **Print**
  - Select to print the document.

- **Page Settings**
  - Opens the Page Setup dialog, allowing you to change printing options such as paper size and page orientation.

- **Copy**
  - Copy the document to paste into another program.

- **Find**
  - Search for words in the document. To find a word, click Find, in the Find dialog box, type the word you want to find, then click Find Next. Words that are found are highlighted in the print preview; click Find Next to continue searching the document.

- **Single/Multiple Page View**
  - Displays the document as a single page or multiple pages in the preview pane.

- **Zoom In/Out**
  - Enlarge or reduce the display of the document in the print preview window; it does not change the appearance of the printed document.
**Zoom Combo**
Select the zoom percentage used to display the document.

**Previous Page**
Display the previous page in the document.

**Next Page**
Display the next page in the document.

**Current Page Number**
Display the current page number and the total pages in the current chart. You can type the page number you want to display, and press <Enter> to display it.

**Backward/Forward**
Display the page that was previously displayed. Backward and Forward are based on your navigation in the document and not on the page order of the document. For example, if you navigated from page 2 directly to page 6, clicking **Backward** would display page 2 again; if you then clicked **Forward**, page 6 would display again.
10.1 Basic Concepts

• What Are Diversions?
• What Happens to the Flow at a Diversion?
• Why do Diversions Exist only in Gravity Systems?
• Is a Surcharged Gravity Pipe Considered a Pressure Pipe?
• How Can a User Model a Diversion?
• What Happens to the Diverted Flow?
• Are There Rules for the Diversion Targets?
• What Does a Diversion Look Like in the Drawing?
• How Does a Diversion Split the Flow Between Flow Being Piped Downstream and Flow Being Diverted?

10.1.1 What Are Diversions?

Most system structures (e.g., manholes, wet wells) have only a single outlet pipe, because of the tree-like structure of gravity storm and sanitary sewer systems. However, in certain situations, there can be more than one way for water to leave a node, and in some cases leave the sewer system altogether. A node with more than one outflow pipe is called a diversion node.
Basic Concepts
10.1.2 \textbf{What Happens to the Flow at a Diversion?}

To model overflows and diversion, lay out a conduit between the node from which the flow is to be diverted and the target of the diversion. Designate the “from” node as the start (upstream) node, and the target node which the flow is diverted to as the stop (downstream) node.

In the new conduit’s properties, set the \textbf{Is Diversion Link?} property to \textbf{True}. The \textbf{Diversion Rating Curve} field will then become available. Define the rating curve to establish the proportions of upstream flows that become diverted through the diversion link. Note that flow through the diversion link is entirely based on the data in the rating curve and the system flow in the bounding start node; all physical properties of the conduit are ignored.

As an example, assume there is a diversion link between nodes CB-1 and CB-2.

Assume node CB-1 has the following System Characteristics:

- System CA = 1.2 acres
- System Flow Time = 10 min
- System Intensity = 3 inches/hr
- System Rational Flow = 3.6 cfs
- System Additional Flow = 2 cfs
- Flow (Total Out) = 5.6 cfs

Now assume based on the Diversion Rating Curve associated with the diversion link that for Flow (Total Out), 20\% of the flow is diverted through the rating curve. StormCAD does not simply send 20\% of 5.6 cfs through the diversion link. StormCAD conserves the CA as follows:

- Diverted CA = 1.2 * 0.2 = 0.24 acres
- Diverted Additional Flow = 2 * 0.2 = 0.4 cfs

At CB-2, there is a System Flow Time of 12 minutes, and a System Intensity of 2.8 inches/hour.

Therefore the contribution of flow to the catch basin from the diversion link would be as follows:

Rational Flow of 0.672 cfs (0.24 acres * 2.8 inches/hour)

plus

Additional Flow of 0.4 cfs
equals 1.072 cfs.

10.1.3 Why do Diversions Exist only in Gravity Systems?

Pressure flow systems can have multiple loops. Thus, the flow split at any pressure node can be calculated directly from the continuity and energy equations. However, in gravity systems, the calculation of the quantity of water going in each direction is considerably more complicated, necessitating a special diversion node, or a hydraulic solution, such as Bentley's CivilStorm, that solves the full Saint Venant hydraulic equations.

10.1.4 Is a Surcharged Gravity Pipe Considered a Pressure Pipe?

A gravity pipe is a pipe that can flow less than full, while a pressure pipe must always be full. In terms of diversions, a gravity pipe that is full, or surcharged, is still treated as a gravity pipe.

10.1.5 How Can a User Model a Diversion?

A diversion is modeled as a conduit element (signifying the physical link between the diversion node and the diversion target). Lay out the diversion link as you would any other conduit, then set the Is Diversion property of the conduit to True, and enter a rating curve for the diversion (which describes the relationship between flow to the diversion node versus diverted flow). During a calculation, flow will then be diverted to the downstream node of the diversion link.
10.1.6 **What Happens to the Diverted Row?**

The diverted flow can either leave the system completely, as in an overflow; or return to the system at a downstream node, as in the case of a parallel relief sewer. In the latter instance, the downstream node, referred to as the diversion target, can be located either in the same network (tree-shaped layout) or in another subnetwork altogether.

![Diagram of diversion to lower point in the network](image1)

![Diagram of diversion to another subnetwork](image2)

Diversion to lower point in the network

Diversion to another subnetwork
10.1.7 Are There Rules for the Diversion Targets?

If the diversion target is not an overflow, it must be located downstream of the diversion or in a separate subnetwork, such that water cannot be circulated back to the upstream side of the diversion through a loop. Looping flow back upstream of the diversion creates a mathematical anomaly that prevents the model from solving properly.
Users should ensure that diversion targets are valid, however the program will validate your choice before computation and warn you of any errors. In validating diversion targets, downstream nodes are defined as the nodes between the diversion and the outlet, as well as all nodes in branches that merge into downstream nodes. The most important thing is that the diversion does not create a loop in the system.

If there are two diversions in series, the target node for the upstream diversion must be upstream of the target node for the downstream diversion. A diversion can divert flow to any node in another network, as long as the target network is downstream from the diversion network. A diversion network is considered to be upstream from a target network if any node in the diversion network is diverting flow to a node in the target network.
10.1.8 **What Does a Diversion Look Like in the Drawing?**

When the Is Diversion Link? property is set to True on a conduit, the conduit is automatically annotated with the symbol shown below to signify that this conduit is a diversion.

![Diversion Symbol]

10.1.9 **How Does a Diversion Split the Flow Between Flow Being Piped Downstream and Flow Being Diverted?**

While in theory it is possible to hydraulically determine the flow split given tailwater conditions and detailed descriptions of the hydraulic characteristics of the diversion, most users do not have that kind of data available. Instead, users enter rating curves describing how the diversion structure splits the flow.

10.2 **Rating Curves**

A rating curve for a diversion determines the amount of flow that is diverted given the total flow into the diversion. A rating curve is a function, shown as a table or a graph, such that for any inflow value there is only one value for diverted flow. The diverted flow must always be nonnegative and less than or equal to the total upstream flow.

- [How Many Data Points Do I Need to Describe a Rating Curve?](#)
- [How Can the Values for the Rating Curve be Determined?](#)
- [What if Flow Measurements Cannot Be Obtained?](#)
### 10.2.1 How Many Data Points Do I Need to Describe a Rating Curve?

The model uses linear interpolation and extrapolation to calculate diversions. If the flow is diverted proportionately over the entire range of flows, then only two points are needed to describe the rating curve. If the rating curve has a great deal of curvature, significantly more points are needed to adequately represent the curve to the model. Some typical rating curves are described below and shown in the figure below:

- Proportional split (e.g. parallel relief sewer)
- All flow diverted (e.g. downstream blockage, power outage at pump station)
- Threshold flow with excess diverted (e.g. weir, regulator)
- Initial throttling of flow (e.g. vortex regulator)

![Typical Rating Curves](image)

### 10.2.2 How Can the Values for the Rating Curve be Determined?

The most accurate way to determine the values for the rating curve is to take field measurements of two of the three possible flows (upstream, direct, and diverted flow) at the diversion for a range of upstream flows. Because it is best to make these measurements for as wide a range of flows as possible, it is recommended to conduct the testing during wet weather periods.
### 10.2.3 What if Flow Measurements Cannot Be Obtained?

In the absence of flow measurements, the manufacturers of some diversion structures may be able to provide a table of flow capacity, or minor loss k-values, for various sizes and settings of the control device (e.g. valve, regulator, weir, orifice, vortex controller). Otherwise, some reasonable estimates must be made and possibly adjusted during calibration.

### 10.3 Special Cases

**Hydraulic Restrictions**

**How Can Parallel Relief Sewers be Modeled?**

**How Can Diversions be Used to Model Off-line Storage?**

**How Should the Models be Used to Model Off-line Storage?**

**Modeling the Effect of Tailwater Depth on the Rating Curve**

**Can I Divert Water Uphill?**

**Where Can I Enter and View Data on Diversions?**

**Divergence Profiles**

#### 10.3.1 Hydraulic Restrictions

If a hydraulic restriction causes an overflow upstream, should the diversion be at the location of the restriction or the overflow? The answer is that the diversion should be located at the point of overflow, or where the flow actually leaves the collection system.

#### 10.3.2 How Can Parallel Relief Sewers be Modeled?

There are several ways to model such situations:

- **Identical Pipes** - This case is modeled explicitly in Haestad Methods software. In this case, you do not need to use diversions. To model a sewer reach with multiple equivalent pipes, set the "Number of sections" field to the number of parallel equivalent pipe barrels.
• **Equivalent Pipe** - If the sections of the parallel pipes do not have the same diameter, you can determine the diameter of the equivalent pipe using Mannings equation, as follows:

\[
D_e = \left( D_1^{8/3} + D_2^{8/3} \right)^{3/8}
\]

where

- \(D_e\) = diameter of equivalent pipe
- \(D_1\) = diameter of first parallel pipe
- \(D_2\) = diameter of second parallel pipe

For example, to determine the equivalent diameter of a 12- and 16-inch pipe in parallel, the equation becomes:

\[
D_e = \left( 12^{8/3} + 16^{8/3} \right)^{3/8} = 18.4 \text{ in.}
\]

• **Diversion** - The two pipes can also be modeled as a pipe in the system with a second pipe diverting flow to a downstream node. In this case you will generally use the larger pipe as the direct flow pipe and the smaller one as the diversion. The flow split should be proportional to the diameters to the 8/3 power. This relationship is given by the following equation:

\[
\frac{Q_2}{Q_t} = \left( \frac{D_2^{8/3}}{D_1^{8/3} + D_2^{8/3}} \right)
\]

where

- \(Q_2\) = diverted flow
- \(Q_t\) = total upstream flow
- \(D_1\) = diameter of direct flow pipe
- \(D_2\) = diameter of diversion pipe
For example, if the parallel pipes have diameters of 16- and 12-inches, and the diversion is the 12-inch pipe, then the fraction of flow split into the 12-inch pipe is:

$$\frac{Q_2}{Q_1} = \frac{12^{8/3}}{16^{8/3} + 12^{8/3}} = 0.37$$

and the rating curve is given by:

<table>
<thead>
<tr>
<th>Table 10-1: Rating Curve</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upstream Flow (gpm)</td>
</tr>
<tr>
<td>Diverted Flow (gpm)</td>
</tr>
<tr>
<td>0</td>
</tr>
<tr>
<td>1000</td>
</tr>
</tbody>
</table>

10.3.3 **How Can Diversions be Used to Model Off-line Storage?**

Steady state methodologies (such as the Rational Method for hydrology or Extreme Flow Factor loading for a sanitary sewer) are based solely on rates of flow, not volumes of flow. In order to determine volume of storage, you need to multiply flow rate by the duration of the flow rate. If sizing of storage is the primary purpose for using the analysis, then Bentley CivilStorm or Bentley PondPack may be a more appropriate model.

10.3.4 **How Should the Models be Used to Handle Basement Flooding?**

To the extent that basement flooding can be represented by a rating curve, the gravity flow models can predict the rate of flooding. However, in most cases, the volume of water flowing into a basement is small compared with the total flow in the pipe, and you are only interested in knowing whether or not basement flooding is occurring. Therefore, it may be more useful to simply monitor the hydraulic grade line (HGL) in the vicinity of suspected basement flooding. If the HGL exceeds a threshold value, then basement flooding is likely to occur. This threshold value needs to be determined based on experience with the system.
10.3.5 **Modeling the Effect of Tailwater Depth on the Rating Curve**

There is only a single rating curve for any diversion in a given run. If there are different rating curves for different tailwater depths, then you can utilize the Scenario Manager to set up multiple rating curves based on the range of tailwater depths, run the different scenarios simultaneously, and compare the results.

10.3.6 **Can I Divert Water Uphill?**

The model allows you to divert flow uphill, such as in the case of flow that is diverted via a pump. If uphill diversions are not desired, you need to check that the invert, or sump, of the diversion target node is at a lower elevation than the invert of the diversion. It is your responsibility to determine if such a diversion is physically possible, as in the case of a pumped diversion or one that activates only when a manhole or wet well is surcharged.

10.3.7 **Where Can I Enter and View Data on Diversions?**

Data on diversions is considered to be physical data, and is therefore stored within a Scenario under the current Physical Alternative on the Conduit tab.

10.3.8 **Diversion Profiles**

When you generate a profile plot of a diversion conduit, the displayed HGL and EGL values are approximated between the $HGL (Out)$ and $EGL (Out)$ values of the connecting upstream node through the downstream invert elevation of the diversion conduit.
Bentley Systems, Incorporated provides software for the lifecycle of the world’s infrastructure. The company’s comprehensive portfolio for the building, plant, civil, and geospatial vertical markets spans architecture, engineering, construction (AEC) and operations. Bentley is the leading provider of AEC software to the Engineering News-Record Design 500 and major owner-operators. For more information, visit the Bentley Web site at http://docs.bentley.com/.

Haestad Methods offers software solutions to civil engineers throughout the world for analyzing, modeling, and designing all sorts of hydrologic and hydraulic systems, from municipal water and sewer systems to stormwater ponds, open channels, and more. With point-and-click data entry, flexible units, and report-quality output, Haestad Methods is the ultimate source for your modeling needs.

In addition to the ability to run in Stand-Alone mode with a CAD-like interface, many of our products can be totally integrated within MicroStation and/or AutoCAD. These programs also share numerous powerful features, such as scenario management, unlimited undo/redo, customizable tables for editing and reporting, customizable GIS, database and spreadsheet connection, and annotation.

Be sure to contact us or visit our Web site at http://www.bentley.com to find out about our latest software, books, training, and open houses.

Click one of the following links to learn more:

- [Software](http://docs.bentley.com)
- [Bentley Services](http://docs.bentley.com)
- [Bentley Discussion Groups](http://docs.bentley.com)
- [Bentley on the Web](http://docs.bentley.com)
- [TechNotes/Frequently Asked Questions](http://docs.bentley.com)
11.1 Software

Bentley Systems software includes:

- CivilStorm
- WaterGEMS
- WaterCAD
- StormCAD
- SewerGEMS
- PondPack
- FlowMaster
- CulvertMaster
- HAMMER

11.1.1 CivilStorm

CivilStorm revolutionizes municipal stormwater management. Whether your concern is a stormwater master plan, localized flooding, GASB34 requirements, water quality BMPs, NPDES permitting, or just simply being able to do faster and smarter designs every day, CivilStorm fits your needs. It is the only commercially available software package that lets you analyze all your system elements in one package. CivilStorm also gives you the ability to perform analyses using either the SWMM algorithm or CivilStorm's own implicit solution of full Saint-Venant equations.

CivilStorm provides numerical solutions for the toughest interconnected pipe, pond, and open channel networks, and provides stunning graphics and reporting tools for visualizing your storm systems in action.

Use CivilStorm For:

- Comprehensive Stormwater Master Plans
• Watershed-Based Master Planning
• Analysis of Open-channel, Closed-conduit and Combination systems
• Floodplain Studies
• Complex Flow Regime Analysis
• Water Quality Assessments
• Integrated Stormwater Quantity and Quality Assessments
• NPDES Permitting

CivilStorm can be run in a MicroStation integrated interface, a Stand-Alone graphical user interface, or an AutoCAD integrated interface.

11.1.2 WaterGEMS

WaterGEMS brings the concept of water modeling and GIS integration to the next level. It is the only water-distribution modeling software that provides full, completely seamless integration with GIS applications. Now the combined functionality of WaterCAD and GIS can be utilized simultaneously, synthesizing the distinct advantages of each application to create a modeling tool with an unprecedented level of freedom, power, efficiency, and usability.

You can create, display, edit, run, map, and design water models from within the GIS environment, and view the results of the simulations as native GIS maps or with traditional Haestad Methods modeling tools. These abilities, in conjunction with the cross-product functionality provided by the core Unified Data and Object Model architecture, provide a powerful cutting-edge solution for your modeling projects.

WaterGEMS works within your choice of environments: ArcView, ArcEdit, ArcInfo, AutoCAD, or the standalone WaterGEMS Modeler interface.

11.1.3 WaterCAD

WaterCAD is the definitive model for complex pressurized-pipe networks, such as municipal water-distribution systems. You can use WaterCAD to perform a variety of functions, including steady-state and extended-period simulations of pressure networks with pumps, tanks, control valves, and more.

WaterCAD’s abilities also extend into public safety and long-term planning issues, with extensive water quality features, automated fire protection analyses, comprehensive scenario management, and enterprise-wide data-sharing capabilities.

WaterCAD is available with your choice of a stand-alone graphical user interface and/or an AutoCAD-integrated interface.
11.1.4 **StormCAD**

StormCAD is a highly efficient model for the design and analysis of storm sewer collection systems. From graphical layout and intelligent network connectivity to flexible reports and profiles, StormCAD covers all aspects of storm-sewer modeling.

Surface inlet networks are independent of pipe connectivity and inlet hydraulics conform to FHWA HEC-22 methodologies. Gradually varied flow algorithms and a variety of popular junction-loss methods are the foundation of StormCAD’s robust gravity piping computations, which handle everything from surcharged pipes and diversions to hydraulic jumps.

11.1.5 **SewerGEMS**

SewerGEMS revolutionizes municipal stormwater management. Whether your concern is a stormwater master plan, localized flooding, GASB34 requirements, water quality BMPs, NPDES permitting, or just simply being able to do faster and smarter designs every day, SewerGEMS fits your needs. It is the only commercially available software package that lets you analyze all your system elements in one package. SewerGEMS also gives you the ability to perform analyses using either the SWMM algorithm or SewerGEMS’s own implicit solution of full Saint-Venant equations.

SewerGEMS provides numerical solutions for the toughest interconnected pipe, pond, and open channel networks, and provides stunning graphics and reporting tools for visualizing your storm systems in action.

Use SewerGEMS For:

- Comprehensive Stormwater Master Plans
- Watershed-Based Master Planning
- Analysis of Open-channel, Closed-conduit and Combination systems
- Floodplain Studies
- Complex Flow Regime Analysis
- Water Quality Assessments
- Integrated Stormwater Quantity and Quality Assessments
- NPDES Permitting
11.1.6 PondPack

PondPack is a comprehensive, Windows-based hydrologic modeling program that analyzes a tremendous range of situations, from simple sites to complex networked watersheds. PondPack analyzes pre- and post-developed watershed conditions and estimates required storage ponds. PondPack performs interconnected pond routing, and also computes outfall rating curves with tailwater effects, multiple outfalls, pond infiltration, and pond-detention times.

PondPack builds customized reports organized by categories, automatically creating section and page numbers, tables of contents, and indexes. You can quickly create an executive summary for an entire watershed or build an elaborate drainage report showing any or all report items. Graphical displays, such as watershed diagrams, rainfall curves, and hydrographs, are fully compatible with other Windows software.

11.1.7 FlowMaster

FlowMaster is an efficient program for the design and analysis of a wide variety of hydraulic elements, such as pressure pipes, open channels, weirs, orifices, and inlets. FlowMaster’s Hydraulics Toolbox can create rating tables and performance curves for any variables, using popular friction methods. Inlet calculations follow the latest FHWA guidelines, and weighting of irregular section roughness can be based on any popular techniques.

11.1.8 CulvertMaster

CulvertMaster helps engineers design new culverts and analyze existing culvert hydraulics, from single-barrel crossings to complex multibarrel culverts with roadway overtopping. CulvertMaster computations use HDS No. 5 methodologies, allowing you to solve for whatever hydraulic variables you do not know, such as culvert size, peak discharge, and headwater elevation. Output capabilities include comprehensive detailed reports, rating tables, and performance curves.

11.1.9 HAMMER

HAMMER is the premier software in the world for analyzing hydraulic transients, surge control devices, and water hammer effects. HAMMER models any hydraulic element, transient source or surge protection devices, including:

- Transients for flow, head, or entrained vapor
- Pressurized pipelines and networks
- Ingress of contaminants into pipe networks
- Surcharged sewers or storage tunnels
- Pump start and shut down scenarios
- Flow shifting via pumps or valves
- Power or pump failure
- Rapid valve closure
- Catastrophic pipe or pump breaks

HAMMER can easily import steady-state model results from industry-standard models such as WaterCAD, WaterGEMS, EPANET, or EXTRAN (for line filling). Users can also build their own models using the advanced graphical interface or robust database connections.

11.2 Bentley Institute Press

Bentley Institute Press provides civil engineering professionals with affordable, quality reference and textbooks dedicated to the practical application of engineering theory to hydraulics and hydrology. Bentley Institute Press publications include:

References and Textbooks: Authored by industry-recognized experts, Bentley Institute Press offers a complete line of reference books for use in both academic and professional settings.

Independent Papers: Bentley Institute Press also provides funding for engineers to write case studies of their projects, with potential publication in a variety of industry journals and magazines.

Books from Bentley Institute Press:

*Advanced Water Distribution Modeling and Management*, first edition
  Haestad, Walski, Chase, Savic, Grayman, Beckwith, and Koelle

*Computer Applications in Hydraulic Engineering*, fifth edition
  Haestad, Walski, Barnard, Durrans, and Meadows

*Floodplain Modeling Using HEC-RAS*, first edition
  Haestad, Dyhouse, Hatchett, and Benn

  Haestad

*Stormwater Conveyance Modeling and Design*, first edition
  Haestad and Durrans
11.3 **docs.bentley.com**

**docs.bentley.com** is your repository of product help files and books. You can browse through online help for specific information or download it to ensure you have the most recent help available on your computer. Also through this site, many product books are available as free, downloadable PDFs, or can be purchased pre-bound with a credit card.
11.4 **Bentley Services**

There are a variety of Bentley Services, including Bentley SELECT® priority services, one-on-one consulting, training programs, MicroStation resellers, as well as your local technical support provider.

<table>
<thead>
<tr>
<th>Region</th>
<th>Support Email</th>
</tr>
</thead>
<tbody>
<tr>
<td>U.S./Canada/Latin America</td>
<td><a href="mailto:support@bentley.com">support@bentley.com</a></td>
</tr>
<tr>
<td>Europe/Middle East/Africa</td>
<td><a href="mailto:support@bentley.nl">support@bentley.nl</a></td>
</tr>
<tr>
<td>Asia/Pacific</td>
<td><a href="mailto:support@bentley.com.au">support@bentley.com.au</a></td>
</tr>
</tbody>
</table>

**Bentley SELECT®**

Bentley SELECT® is the comprehensive delivery and support subscription program that features product updates and upgrades via Web downloads and MySELECT CD, around-the-clock technical support, exclusive licensing options, discounts on training and consulting services, as well as technical information and support channels. For more detailed information go online at [http://www.bentley.com](http://www.bentley.com) and click the Support link.

**Bentley Professional Services**

Bentley Professional Services is a team of project managers, technical managers, application specialists, and developers organized regionally and assigned by skill sets. By adding their extensive knowledge to your project, they provide customized services on a one-to-one basis to help you maximize your investment in Bentley technology. For more information visit [http://www.bentley.com/Services/](http://www.bentley.com/Services/) and click the Bentley Professional Services link.

**Bentley Institute**

The Bentley Institute manages professional training programs to ensure consistent, high quality, user training for a variety of Bentley products and for varying levels of application experience.

Bentley Institute training is developed to maximize your productivity by using examples relevant to your day-to-day project efforts. Training is developed concurrently with software applications to provide knowledge of the latest tools and features. Additionally, all Bentley Institute faculty meet rigorous certification requirements.
To access the Bentley Institute home page directly from StormCAD V8i, choose Help > Bentley Institute Training, or visit http://www.bentley.com/Training/.

11.5 Bentley Discussion Groups

Meet other users of Bentley products, exchange ideas, and discuss a wide range of technical subjects in Bentley's discussion groups. They can be accessed via most common discussion group newsreaders or Web browsers and are a good source of how-to tips, technical information, and programming techniques from Bentley employees and professionals who use our products.

A current list of discussion groups as well as helpful information regarding them can be found at http://communities.bentley.com.

11.6 Bentley on the Web

Visit Bentley on the web at http://www.bentley.com/. Here you will find links to products, services, industries, events and training, community information, and the latest corporate news announcements pertaining to Bentley Systems, Incorporated, your global provider of collaborative software solutions.

11.7 TechNotes/Frequently Asked Questions

TechNotes, FAQs and other technical support information are available online at Bentley's StormCAD V8i Technical Support page.

11.8 BE Magazine

The BE Magazine is a quarterly e-magazine focused on the Bentley community of users. It serves as a showcase for Bentley users and their work improving the world's infrastructure.

Each issue is an open forum for the world community of architecture, engineering, and construction professionals and owner-operators. Visit http://www.be.org and click the BE Magazine link to subscribe or to view the magazine online.

11.9 BE Newsletter

The BE Newsletter is an email newsletter covering industry news, Bentley updates and events, technical tips, and more. Visit http://www.be.org and click the BE Magazine link to subscribe or to view the newsletter online.
11.10 Client Server

*Client Server* is an online newsletter for Bentley SELECT subscribers. This online resource is filled with the latest technical news and information.

Archives of *Client Server* provide an abundant resource of technical information in the form of book excerpts, case studies, commentary and analysis, and productivity tips. For more detailed information go online to [http://www.bentley.com](http://www.bentley.com) and click the Support link.

11.11 BE Careers Network

The BE (Bentley Empowered) Careers Network is a program dedicated to supporting accredited academic institutions by providing the latest releases of Bentley products, as well as world-renowned support, online communities, and the latest engineering news and information. For details about the BE Careers Network go online at [http://www.becareers.org/](http://www.becareers.org/).

11.12 Contact Bentley Systems

Contact Bentley Systems if you want product information, to upgrade your software, or need technical support.

**Sales**

Bentley Systems’ professional staff is ready to answer your questions. Please contact your sales representative for any questions regarding Bentley Systems’ latest products and prices.

Toll-free U.S. Phone: 800-727-6555  
Worldwide Phone: +1-203-755-1666  
Fax: +1-203-597-1488  
Email: sales@bentley.com

**Technical Support**

We hope that everything runs smoothly and you never have a need for our technical support staff. However, if you do need support, our highly-skilled staff offers their services seven days a week and may be contacted by phone, fax, email, and the Internet. For information on the various levels of support that we offer, contact our sales team today and request information on our Bentley SELECT program, or visit our Web site.
When calling for support, in order to assist our technicians in troubleshooting your problem, please be in front of your computer and have the following information available:

- Your computer’s operating system.
- Name and build number of the Bentley Systems software you are calling about. The build number can be determined by clicking Help > About Bentley StormCAD V8i. The build number is the number in brackets located in the lower-left corner of the dialog box that opens.
- A note of exactly what you were doing when you encountered the problem.
- Any error messages or other information displayed on your screen.

When emailing or faxing for support, please provide the following details, in addition to the above, to enable us to provide a more timely and accurate response:

- Company name, address, and phone number
- A detailed explanation of your concerns
- If you are emailing us, the Bentley StormCAD V8i.log files located in the product directory (e.g., C:\Documents and Settings\<user directory>\Application Data\Bentley\StormCAD V8\8).

:Available 24 hours a day, seven days a week. You can contact our technical support team at:

Phone: +1-203-755-1666
Fax: +1-203-597-1488
Support: http://selectservices.bentley.com

**Addresses**

Internet: http://www.bentley.com
Email: sales@bentley.com

Toll-free U.S. Phone: 800-727-6555
Worldwide Phone: +1-203-755-1666
Fax: +1-203-597-1488
Mail: Bentley Systems, Incorporated
Haestad Methods Solutions Center
Suite 200W
27 Siemon Company Drive
Watertown, CT 06795
Glossary

Alternative: A categorized data set that create scenarios when placed together. Alternatives hold the input data in the form of records. A record holds the data for a particular element in your system.

Aquifer: A sub-surface groundwater area used to model the vertical movement of water infiltrating from the subcatchments which lie above them. Aquifers also permit the infiltration of groundwater into the conveyance system, or exfiltration of surface water from the conveyance system, depending on the hydraulic gradient that exists.

Backflow: The backing up of water through a conduit or channel in the direction opposite to normal flow.

Basin: An area having a common outlet for its surface runoff.

Batch Run: A set of multiple scenarios that are computed together. This is helpful if you want to queue a large number of calculations, or manage a group of smaller calculations as a set.

bmp: File name extension for bitmap image files, which can be used as background layers in StormCAD V8i.

Branch: In StormCAD V8i, a series of connected elements. The StormCAD V8i calculation engine includes a heuristic routine that decomposes a network into its component branches, and each branch is solved independently using an implicit solver. Each branch comprises a series of connected elements. Elements with the same branch ID are solved together.

Capacity (Design): The carrying capacity of the conduit under design conditions. When the pipe is designed to flow part full, the design capacity will be less than the full flow capacity.

Capacity (Full Flow): The carrying capacity of the conduit under the filled condition computed with the friction slope equal to the constructed slope.
Captured Flow: The portion of the inlet flow which actually drains into the catch basin. The captured flow is dependent on the inlet capacity of the catch basin.

Catalog Conduits: User-defined re-usable data sets that define common physical characteristics of conduits.

Catch basin: The geographical area that "catches" the rainfall and directs it towards a common discharge point within the storm collection network.

Catchment: The area drained by a stream, lake or other body of water in a sewer or stormwater system.

Channel: A channel refers to a channel that changes geometry from the upstream cross section to the downstream cross section. Channels can be used to model natural streams or swales which are not prismatic in cross section. Channels must have a cross section element at each end and properties are interpolated along the channel.

CN: SCS Curve Number

Collection: Bentley StormCAD V8i uses the term Collection to identify some fields where you enter a set of data instead of a single value. To use this feature, click the field in which the word Collection appears, then click the Ellipsis (...) button to open a dialog box into which you enter data.

Composite Hydrograph: A graph of the total flow over time from multiple defined fixed/unit loads, hydrographs, and pattern loads.

Conduit: An open- or closed-section element through which water moves. A conduit has a constant roughness and cross section shape along its entire length. In Bentley StormCAD V8i, a conduit can refer to any prismatic channel or pipe that conveys flow. The cross section of a conduit must remain constant from one end to the next.

DD: Excess duration rainfall.

Diurnal Curve: A pattern that relates to the changes in loads over the course of the day, reflecting times when people are using more or less water than average.

Drag: Dragging is an action you perform with the mouse to select items in the drawing pane. Click in the drawing pane, hold down the mouse button, and move the mouse to form a rectangle around the elements you want to select. After you have formed the rectangle around the items you want to select, let go of the mouse button.
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>dwh:</td>
<td>File name extension for the binary format file used by the StormCAD V8i Stand-Alone mode only. The .dwh file contains the drawing.</td>
</tr>
<tr>
<td>dxf:</td>
<td>File name extension for Data Exchange File format image files, which can be used as background layers in StormCAD V8i. Dxf files store vector data for drawings typically produced in CAD programs.</td>
</tr>
<tr>
<td>Dynamic Manager:</td>
<td>A dialog box that can be displayed floating above the workspace or attached (docked) to any one of the sides of the workspace.</td>
</tr>
<tr>
<td>Dynamic selection set:</td>
<td>A selection created by running a query.</td>
</tr>
<tr>
<td>English:</td>
<td>E-Q-TWU.S. customary units, such as inch or acre</td>
</tr>
<tr>
<td>Element Symbology:</td>
<td>Refers to the way in which elements and their associated labels are displayed in Bentley StormCAD V8i. You use the Element Symbology manager to manage element annotations and color coding.</td>
</tr>
<tr>
<td>Element Table:</td>
<td>A read-only, predefined FlexTable that you can use to review data about a specific element type. There is one predefined table for every element available in Bentley StormCAD V8i.</td>
</tr>
<tr>
<td>Extended Period Simulation:</td>
<td>A calculation type where the model is analyzed over a specified duration of time.</td>
</tr>
<tr>
<td>FlexTable:</td>
<td>A customizable table that lets you view input data and results for all elements of a specific type in a tabular format. You can use the standard set of FlexTables or create your own FlexTables to compare data and create reports.</td>
</tr>
<tr>
<td>Flow (Additional):</td>
<td>The sum of Additional Subsurface and Additional Carryover flows after they have mixed together in the subsurface (conduit) network.</td>
</tr>
<tr>
<td>Flow (Bypass):</td>
<td>Flows that are not intercepted by the inlet at a catch basin node, and continue on downstream via a gutter element.</td>
</tr>
<tr>
<td>Flow (Carryover):</td>
<td>Flows at an inlet that were bypassed, via a gutter, from the inlet upstream.</td>
</tr>
<tr>
<td>Flow (Known):</td>
<td>Similar to Additional Flow except that a local inlet input will overwrite any accumulations (see Flow (Additional)).</td>
</tr>
</tbody>
</table>
Flow (System): Total flows in the subsurface (conduit) network, on the downstream side of a catch basin, manhole or transition node. The system flows are equal to the sum of the Local and Upstream flows.

Freeboard: The difference between the top of dam elevation and the water surface elevation.

gif: File name extension for Graphic Image Format image files, which can be used as background layers in StormCAD V8i.

GIS: Geographic information system

Global Storm Event: In StormCAD V8i, project-wide storm events, usually applied to catchments that do not use local rainfall. Project-wide global storm events are typically associated with Hydrology alternatives.

Gutter: An open-section element that models overflow. Gutters are used in StormCAD V8i only to model the water which exceeds the capacity of in catch basin inlet and must flow through a surface gutter to the next catch basin. A StormCAD V8i gutter can only receive water from a catch basin.

Hydrograph: A graph of discharge versus time.

Hyetograph: A graphical representation of rainfall intensity with respect to time.

Hyperlink: In Bentley StormCAD V8i, a link to an external file, such as an image or movie file, for the purpose of associating the file with a specific element.

I₀: Initial abstraction

ICPM: Interconnected pond modeling

IDF/I-D-F: Intensity-Duration-Frequency

Infiltration: Water that enters the system from the ground through defective pipes, pipe joints, connections, or manhole walls

Inflow: Inflow is specified at a manhole or wet well as the total amount of wet weather inflow. Together with the infiltration along the pipes, the inflow forms the wet weather part of the sewer load.

Inflow Collection: A collection of any combination of fixed, hydrograph, or pattern inflows for an element.
**Inlet flow:** Flows added to the manholes and wet wells in your model, including user input hydrographs and flows from other sources, such as pumps.

**jpg:** File name extension for image files produced using the Joint Photographic Experts Group (JPEG) standard. JPEG files, which can also have the file name extension jpeg, can be used as background layers in StormCAD V8i.

**Junction Chamber:** A structure in which flow can be mixed or split. In combined sewers systems, flow can be split between that going to treatment and that going to an overflow. Also referred to as a transition.

**K_e:** Entrance loss coefficient

**K_r:** Reverse flow loss coefficient

**Land Uses:** Categories of activities or land surface characteristics that are assigned to catchment elements. Examples of land use activities are residential, commercial, industrial, and undeveloped.

**Manhole:** Element that provides access to the system for inspection and maintenance. Manholes are usually installed where there is a change in horizontal (plan-view) pipe direction or pipe slope, where several pipes join, or where the pipe size changes.

**Max Rise:** The rise represents the maximum height of the conduit, either the max depth of the channel or top depth of a closed pipe.

Depending on whether the conduit is open or closed the hydraulic grade line exhibits different behaviour when it exceeds the depth of the conduit.

If the conduit is an open channel, when the HGL exceeds the banks, the channel is assumed to be extended. If the conduit is closed, when the HGL exceeds its depth the conduit goes under pressure flow, and the computation will proceed accordingly. At this point the depth will equal the rise.

**mdb:** File name extension for StormCAD V8i database files. The .mdb file contains all modeling data, and includes everything needed to perform a calculation. This file is an open access database format file and can be viewed and edited.
MrSID: File name extension for Multi-resolution Seamless Image Database format raster image files, which can be used as background layers in StormCAD V8i.

Orifice Coefficient: For stormwater openings, an orifice coefficient of 0.60 is often used.

Outfall: The ultimate termination points in a network.

Overflow: The flow lost when the water surface elevation at a manhole or other type of node is above the rim elevation or user-specified overtopping elevation.

Pattern: A series of multipliers which describe how the base load varies over time.

Pattern Load: A single average base load and a series of dimensionless multipliers used to delineate how the load varies over time.

Pattern Setup: In StormCAD, a pattern setup allows you to match unit sanitary (dry weather) loads with appropriate loading patterns. Each scenario can use a different pattern setup, thus allowing you to model different loading alternatives for different extended period simulations.

png: File name extension for Portable Network Graphic format image files, which can be used as background layers in StormCAD V8i.

Pollutograph: A plot of time vs. concentration or mass rate.

Profile: A graph that plots a particular attribute across a distance, such as ground elevation along a section of piping. As well as these side or sectional views of the ground elevation, profiles can be used to show other characteristics, such as hydraulic grade, pressure, and constituent concentration.

Pump: A structure in a wastewater system designed to add the energy (head) necessary to overcome elevation differences and head losses.

Q: Flow

Query: A SQL expression you build in Bentley StormCAD V8i to filter a FlexTable or create a selection set.

Scenario: A set of input data (in the form of alternatives), calculation options, results, and notes associated with a set of calculations. Scenarios let you set up an unlimited number of "What If?" situations for your model, and then modify, compute, and review your system under those conditions.
Selection Sets: User-defined groups of network elements that let you
predefine a group of elements to manipulate together.

shp: File name extension for shapefiles, which you can import
as background layers for your model.

SI: International System of units or metric units.

Static selection set: A selection set created by selecting a group of elements
in your model.

Storm Event: In StormCAD V8i, a single rainfall curve that represents
one rainfall event for a given recurrence interval.

tiff: File name extension for Tagged Image File Format raster
image files, which can be used as background layers in
StormCAD V8i. The extension .tif is also used for these
types of files.

Transition: A structure in which flow can be mixed or split. In
combined sewers systems, flow can be split between that
going to treatment and that going to an overflow. Also
known as a junction chamber.

Unit Hydrograph: A time versus flow curve.

User data extensions: A set of one or more attribute fields that you can define to
hold data to be stored in the model. User data extensions
allow you to add your own data fields to your project.

User Notifications: Messages that appear after you compute your model.
These messages can help you troubleshoot errors in your


Symbols

%u 587

A

AASHTO 499 about
dialog box 9
accelerated redraw 188
active topology 407
Active Topology Alternative 407
active topology alternative 407
active topology child alternative 407
add a background layer 111
add a background layer folder 110
add a FlexTable folder 614
add a help topic 7
add or remove a button 95
Add To Selection Set dialog box 319
Adding and Removing Toolbar Buttons 94
Adding Annotations 586
adding annotations 586
adding color coding 592
Adding Color-Coding 592
adding elements 270
Adding Folders 586
address
  See contacting Bentley Systems. 669
Addresses 669
Advantages of Automated Scenario Management 381
alternative 385
Alternative Editor Dialog Box 404
Alternative Editor dialog box 404
Alternative Manager 402, 407
Alternatives 401
alternatives 381, 402, 671
  base 405
  child 405
  creating 405
  editing 406
  merge 402
  overview 381, 401
analyzing improvement suggestions 393
Annotating Your Model 581
annotation properties 588, 610
Annotation Properties dialog box 588, 610
annotations 581, 582, 588, 610
  \%u 587
  adding 586
  deleting 587
  displaying units 587
  editing 587
  renaming 587
Attribute 385
Attribute Inheritance 388
attributes
  editing 282
  scenario 385
AutoCAD 117, 118, 128, 129
  commands 126, 134
  drawing synchronization 132
  entities 126, 134
  integrating with SewerGEMS 129
  undo/redo 136
AutoCAD Mode 117
AutoCAD mode 118, 128, 129
  graphical layout 121
  menus 130
  project files 131
  toolbars 131
Autodesk 117, 128
automated scenario management 381
Average Day Conditions 391

B

backflow 671
background layer 111, 112
background layer files
  using with ProjectWise 205
background layer folder 110, 111
Background Layer manager 108
Background Layers 107
background layers 108
  deleting 112
dxf files 116
  editing 112
  image compression 114
  shapefiles 115
  supported image types 108
base alternative 402
Base alternatives 405
base alternatives 405
Base and Child Scenarios 397
Base Scenarios 397
batch pipe split 280
batch run 399, 400, 671
Batch Run Editor Dialog Box 401
Batch Run Editor dialog box 401
Batch Runs 399
batch runs 399
Batch Split Pipe dialog box 279
BE Careers Network 668
BE Magazine 667
BE Newsletter 667
Bend command 277
Bentley discussion groups 667
Bentley Institute 666
Bentley Institute Press 664
Bentley Professional Services 666
Bentley SELECT 8, 666
Bentley services 666
Bentley Systems 659
about us 659
addresses 668
contacting 668
e-mail addresses 669
program update 8
Web site 669
Bernoulli equation 463
Bifurcated 255
Border tool 266
border tool 266
browse topics 6
build number 9
bypass flow 514

C

C coefficient 467
CAD 105
carryover 514
Carter 528
catalog pipes 672
change the position of a background layer 112
changing the drawing view 100
Changing Units, Format, and Precision in FlexTables 620
Chezy’s equation 465, 469
child alternative
  creating active topology 407
Child Scenarios 398
child scenarios 398
clearing element selection 276
Client Server 668
Colebatch 500
Colebrook-White
  equation 466
collapse a subtopic 6
collection 672
color coding 590
  adding 592
  deleting 593
  editing 593
  renaming 594
color coding legend 594
Color Coding Your Model 590
Color-Coding Properties dialog box 594
column headings
  editing for FlexTables 620
combination inlet in sag 524
combination inlet on grade 518
commands (AutoCAD mode) 126, 134
composite cross slope 517
composite gutter section 509
composite hydrograph 672
conduit shapes 483
conduits 672
connection
  synchronization 132, 133
Connections manager 142
connectivity
  explicit 163
  implicit 163
constructing a query 356, 625
contacting Bentley Systems
  email 669
  fax 669
  hours 669
  mail 669
  technical support 668
  telephone 669
continuously depressed gutter 510
contour 596, 597, 598
  smoothing 597, 598
Contour Browser 596, 599
Contour Manager 595
Contour Plot 598
Contours 594
contours 135
Controlling Toolbars 94
copy FlexTable data 633
copying
   FlexTables 633
Copying, Exporting, and Printing FlexTable Data 632
Correct Data Format 165
correcting an error 392
cox 501
create a FlexTable report 633
create a new Alternative 406
create a new FlexTable 618
create a new scenario 398
create an active topology alternative 408
Create Selection Set dialog box 317
Creating a New FlexTable 618
Creating a Project Inventory Report 636
creating a query 355
Creating a Scenario Summary Report 636
Creating Alternatives 405
creating alternatives 405
Creating an Active Topology Child Alternative 407
creating dynamic 317
creating queries 356, 625
creating reports 635
Creating Scenarios 398
creating selection sets 317
CulvertMaster 663
curb inlet in sag 520
curb opening 517, 519
curved pipes 277
custom AutoCAD entities 126, 134
custom results path 3
custom sort 626
Customization Editor 377
customize
drawing 131
customizing
   FlexTables 627
Customizing Managers 98
customizing toolbars and buttons 94
Customizing Your FlexTable 627
Darcy Weisbach
   Colebrook-White equation 466
   equation 467, 468

data
   organization 401
Data Format Needs Editing 165
data source tables 164
data types for user data extensions 370
date 362
decimal point 286
default units 196
default workspace 98
defining user data extensions 365
delete a background layer 112
delete a background layer folder 111
delete a FlexTable folder 615
deleting
   FlexTables 619
Deleting Annotions 587
deleting annotations 587
Deleting Background Layers 112
deleting background layers 112
deleting color coding 593
deleting elements 276
Deleting FlexTables 619
Deleting Folders 586
deleting groups of elements in a selection set 319
display a topic 7
display format 287
Display Precision 286
display precision 286
display topics 6
displaying multiple projects 185
Distributed Scenarios 382, 383
ditch 511
Diversion 646
docked dynamic manager 99
docked static manager 99
dragging 672
drawing
   setup (AutoCAD mode) 131
   synchronization (AutoCAD mode) 132
drawing scale 194
drawing style 105
DWG 132
DXF Properties 116
DXF Properties dialog box 116, 317, 319
Dynamic Inheritance 387
dynamic inheritance 387
dynamic managers 673

E

Eagleson 528
edit a FlexTable 620
edit a scenario 399
Edit Hyperlink dialog box 346
edit the properties of a background layer 112
inging
   FlexTables 619
      numerous elements at once 622
Editing Alternatives 406
inging alternatives 406
ing annotations 587
ing color coding 593
ing column headings
   FlexTables 620
Editing Column-Heading Text 620
ing element attributes 282
Editing FlexTables 619
Editing Scenarios 399
ing scenarios 399
ing units
   FlexTables 621
EGL 464
element
deleing 125
modify 125
moving 126, 135
element label project files 199
element labeling settings 199
element relabeling 628
element symbology 673
Element Symbology Manager 582
   using folders in 585
Element Symbology manager 581
element symbols 105
element tables 673
elements 250
   adding in the middle of a pipe 276
adding to your model 270
clearing selection of 276
deleting 274
editing attributes 282
globally editing data in numerous elements 622
moving 274
overview 250
selecting 274
selecting all 275
selecting all of the same type 275
selecting by polygon 275
viewing in selection sets 316
email 669
e-mail address 669
energy
equation 463
grade line 464
principle 462
engineering libraries 336, 338
overview 335
sharing on a network 338
working with 336
engineering libraries dialog box 338
English units 673
entering data 282
entities
in AutoCAD 126, 134
enumerated user data extensions 374
Enumeration Editor dialog box 374
equal length inlets 524
errors 446
Espey/Winslow 529
existing projects 184
exit WaterGEMS 4
expand a subtopic 5
explicit connectivity 163
explode elements (AutoCAD mode) 134
export FlexTable data 633
exporting
FlexTables 633 exporting
FlexTables 632 extended period
simulation 673
External CA 424
External Tc 424
FAA time of concentration 529
fax 669
Federal Aviation Agency 529
filter
  resetting 625
filter a FlexTable 624
filtering a FlexTable 624
finalizing the project 394
Find 283
finding elements 283
Fixed Point 287
FlexTable Dialog Box 615
FlexTable dialog box 615
FlexTable Setup Dialog Box 630
FlexTable Setup dialog box 630
FlexTables 611, 673
  copying 632
  copying data 633
  creating 618
  customizing 627
  deleting 619
  editing 619
  editing column headings 620
  editing globally 622
  editing units 621
  exporting 632
  exporting data 633
  filtering 624
  global editing 622
  navigating in 621
  opening 617
  ordering columns 623
  printing 632, 633
  renaming 619
  reports 633
  saving as text 633
  shortcut keys 621
  sorting column order 623
FlexTables Manager 612
  folders in 614
FlexTables manager 612
floating manager 98
FlowMaster 663
folders
in Element Symbology Manager 585
in FlexTables Manager 614
format
  unit 286
Free Form 589
freeboard 674
frontal flow 511

G

General 287
general settings 187
Geometric data source 140
Getting Started in Bentley WaterGEMS 1, 431
GIS 674
GIS style 105
GIS-ID 165, 167
global edit 623
global edit FlexTable column 622
global editing
  FlexTables 622
global settings 186
Global tab 187
globally editing data 622
grade line energy
  464 hydraulic
  464
graphical layout
  AutoCAD 121
grate 519
grate inlet in sag 519
grate inlet on grade 514
gutter depression 510, 513
gutter flow 503, 507

H

Haestad Methods
  program update 8
Haestad Press 664
Haestad.log 669
Haestad.log 669
Hazen-Williams equation 467
HEC-22 499, 503
help files and books 665
HGL 464
history of what-if analyses 382
horizontal 521
horton’s 500
hydraulic grade line 464
hydrograph 674
hyperlinks 343, 674

image compression 114
Image Filter 113
Image Properties Dialog Box 113
Image Properties dialog box 113
implicit connectivity 163
import 168, 173, 177, 238
Import dialog box 376
improved Lotter 502
inclined 521
independent papers 664
individual elements
adding to your model 270
infiltration 674
inflow 674
inflow collection 674
Inflow Collection Editor 674
Inheritance 386
inheritance 386, 388
dynamic 387
overriding 387
inlet capacity 503
inlet flow 675
inlets in sag 519
inlets on grade 513
InRoads 222, 246
InRoads Drainage Database 237
installation 2
integrating AutoCAD with SewerGEMS 129

K

Kerby/Hathaway 529
Kirpich (PA) 530
Kirpich (TN) 530
KnowledgeBase 8
Kutter’s 465
labeling elements 285
layout
  AutoCAD 121
layout settings 189
layout tool 270
legend 594
length and velocity 531
library types 336
license 2
Like operator 360
Line tool 267
line tool 266
Local and Inherited Values 388
local and inherited values 388
local depression 513
losses
  friction 467
Lotter 501

mail 669
manholes 675
Manning’s equation 469
Maximum Day Conditions 391
median section 511
merge 281
  merge
    alternatives 402
Merge nodes in close proximity 281
Micro Drainage 238
Microstation Mode 117
minimum time of concentration 528
ModelBuilder 168, 173, 177
  supported formats 139
    using 139
ModelBuilder Connections manager 142
ModelBuilder wizard 146
move
  elements 126, 135
  labels 127, 135
move a toolbar 95
moving elements 276
moving toolbars 95
multiple elements
  selecting 275
multiple projects
  maximum number of 184
Municipal License Administrator 2

N

named views 311
Naming and Renaming FlexTables 619
native 135
navigating in a FlexTables 621
Navigating in Tables 621
network connectivity 163
network navigator 280
network review 280
Number 287

O

open a manager 98
open channel weighting methods 499
open FlexTables 618
open Help 4
open the registration dialog box 9
Opening FlexTables 617
Opening Managers 98
opening managers 98
operation 623
options 186
Options Dialog Box
  ProjectWise settings 201
Options dialog box 187, 192
ordering
  FlexTable columns 623
organize data 401
orifice flow 520, 522, 524
output
  tables 611
overflow 676
Overriding Inheritance 387
overriding inheritance 387
Pan tool 100
  panning 100
    using a mousewheel to 100
parent scenario 398
patterns 177
pavement drainage 503
Pavlovskii’s 499
Peak Hour Conditions 392
pipes
  modeling with curves 277
  splitting 276
polygons
  used to select elements 275
Polyline Vertices dialog box 278
PondPack
  build number 9
  installation 2
  upgrade 8
  upgrades and updates 2
  version number 9
PowerCivil 117
PowerCivil V8i for Americas 117
predefined queries 351
Presenting Your Results 581
pressure
  head 463, 464
Print Preview 638
print preview
  FlexTables 633
Print Preview Window 638
printing
  FlexTables 633
printing FlexTables 632
project queries 351
profile 676
profile setup 602
profiles 599
Profiles manager 600
Program Maintenance Dialog Box 8
project
  files 122, 131, 132
project inventory 636
Project Properties dialog box 185
Project tab 192
projects 184
ProjectWise 202
  closing projects 203
  general guidelines for using 202
  using background layer files with 205
  viewing status 204
ProjectWise options 201
properties
  editing 282
Property Editor 282
  using Find Element 283
prototypes 324
publications 664
pump curves 173
pump definitions 168

Q

Q 676
queries 351, 356, 625
  creating 355
    in FlexTables 624
  predefined 351
  project 351
  shared 351
    using Like operator in 360
Queries Manager 351
query 362
Query Builder dialog box 357
Query Parameters 354

R

ranking
  FlexTable columns 623
reconnect 277
redo 136
references and textbooks 664
relabeling elements 285
removing elements from selection sets 319
rename a background layer 112
rename a background layer folder 111
rename a FlexTable folder 615
rename FlexTables 619
renaming
FlexTables 619
renaming annotations 587
Renaming Folders 586
report options 636
Reporting 635
reporting
   on a group of elements in a selection set 319
reports 635
   FlexTables 633
   scenario 636
   standard 635
reset
   FlexTable filter 625
reset a filter 625
Reset Workspace 98
roughness
   Chezy’s equation 465
   Colebrook-White equation 466
   Darcy-Weisbach equation 467
   Hazen-Williams equation 467
   Manning’s equation 469
roughness height 466, 468
rounding of numbers 286
Running Multiple Scenarios at Once 399

S

save
   as drawing *.DWG 133
saving FlexTables as text 633
Scenario 385
Scenario Attributes and Alternatives 385
scenario example 390
Scenario Inheritance 389
Scenario Management 394
   Example 390
Scenario Manager 396, 401
scenario summary 636
Scenarios 395
scenarios 381, 676
   advantages of using 381
   attribute inheritance 388
   attributes 385
   base 397
   batch run 399
   creating new 398
editing 399
inheritance 386
local and inherited values in 388
overview 381, 384, 395
Scientific 287
SCS lag 531
search for text 7
seed 75
selecting all elements 275
selecting an element 275
selecting elements
  all of the same type 275
  by polygon 275
selecting multiple elements 275
Selection Set Element Removal dialog box 319
selection sets 313, 314, 317, 319, 677
  adding a group of elements to 319
  adding elements to 318
  creating 317
  creating from queries 317
  group-level operations 319
  in FlexTables 617
  removing elements from 319
  viewing elements in 316
Selection Sets Manager 314
Self-Contained Scenarios 383
Self-Contained scenarios 383
Set Field Options dialog box 286
setting options 186
setup 131
Shapefile Properties 115
Shapefile Properties dialog box 115
Shared Field Specification dialog box 374
shared queries 351
sharing engineering libraries on a network 338
shortcut keys
  FlexTables 621
SI 286, 677
slot inlet in sag 523
slotted-inlet on grade 518
smoothing contours 597
snap menu (AutoCAD mode) 127, 135
Software 665
software
  upgrades 8
Software Updates via the Web and Bentley SELECT 8
sort columns in FlexTable 623
sort contents of FlexTable 623
  sorting
    FlexTable columns 623
Sorting and Filtering FlexTable Data 623
spatial data 163
Spatial Reference System 207
Split 255
split 276
splitting pipes 276
SRS 207
Stand-Alone Editor 100
standard reports 635
start WaterGEMS 2
Starting Bentley WaterGEMS 2
starting Bentley WaterGEMS 2
starting projects 184
statistics 634
Stored Prompt Responses dialog box 191
StormCAD 662
support 668
  addresses 669
  hours 669
Swamee and Jain equation 469
sweeper inlet 525
SWG file 132
symbol
  visibility (AutoCAD mode) 131
synchronize (AutoCAD mode) 132

T

Table
  Properties 630
    Type 630
  setup 630
tables
  column headings 620
  editing FlexTables 619
  units 621
tabular report 611
Technical Support 668
technical support 667, 668
text 127, 135
Text tool 266
text tool 266
The Scenario Cycle 384
theme folders
    renaming 586
theme groups
    deleting 586
time of concentration 526
    Carter 528
    Eagleson 528
    equation 526
    Espey/Winslow 529
    Federal Aviation Agency 529
    Kerby/Hathaway 529
    Kirpich (PA) 530
    Kirpich (TN) 530
    length and velocity 531
    minimum 528
    SCS lag 531
    TR-55 channel flow 533
    TR-55 shallow concentrated flow 532
    TR-55 sheet flow 531
    user-defined 528
    TR-55 channel flow 533
        equations 533
    TR-55 shallow concentrated flow 532
    TR-55 sheet flow 531
    transition flow 523
    transitional flow 520, 524
    Troubleshooting 8
    troubleshooting 445
        knowledge database 8
turn toolbars off 95
turn toolbars on 95
turning toolbars off 95

U

U.S. customary 286
Understanding Scenarios and Alternatives 381
undo/redo operations in AutoCAD 136
uniform gutter cross slope 507
Unit 286
unit hydrograph 677
unit of measurement 286
units 196
    displaying in annotations 587
    editing for FlexTables 621
units and formatting 286
updates 2
updating PondPack via the Web 8
upgrade
  PondPack 8
upgrades 2
use the index 6
user data extensions 365, 677
data types 370
  enumerated 374
User Data Extensions dialog box 367
user notifications 445, 448, 677
User Notifications Manager 445, 448
Using Folders in the Element Symbology Manager 585
Using Profiles 599
Using Standard Reports 635
using with SewerGEMS 202

V

velocity
  head 464
version number 9
vertical 521
view
  tabular 611
Viewing and Editing Data in FlexTables 611
viewing elements in a selection set 316
views 135
visibility of symbols 131

W

warnings 446
WaterCAD 661
custom AutoCAD entities 126, 134
WaterCAD in AutoCAD 117, 128
WaterCAD Managers 98
WaterGEMS 661
WCD file 122
Web updates 8
Website 669
weir flow 520, 521, 523
Welcome dialog 183
Welcome dialog box 183
What-If 382
white
table columns 619
window color settings 188
Working with FlexTable Folders 614
Working with WTG Files 2
World Wide Web
   See Web. 8

Y

yellow
table cells 620

Z

Zoom 103
Zoom Center dialog box 102
Zoom Dependent Visibility 104
Zoom Extents 101
Zoom Factor 103
Zoom In 102
Zoom Out 102
Zoom Previous
   Zoom Next 103
Zoom Realtime 102
Zoom Window 102
zooming 100