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2 Introduction 
 

GEOPAK is a comprehensive civil software package for the design and production of 
complex computer generated plan sets for roadway and site projects. Geopak is fully 
integrated with Microstation CAD software to allow for user interactive design.  

 

 
 

This manual is intended to cover the Road tasks for Geopak Roadway Designer Projects 
and does not cover Geopak Proposed XS methods.  
 
It is REQUIRED that users taking this class have taken the Introduction to Microstation 
class and have established a good understanding of Microstation commands and its overall 
funcionality.  
 
Users are also REQUIRED to have a basic understanding of Road Design concepts and 
practices and be familiar with the components of Horizontal Alignments, Vertical Profiles, 
Cross Sections and be familiar with the basic Design Criteria for Roadways set forth in the 
MDT Road Design Manual. 
 
In some cases there may be more than one way to perform a specific task in Geopak. Users 
are required to become familiar with tasks in this documentation and are encouraged to use 
alternate methods when feasible. When using any alternate method for a task not covered in 
this manual it is recommended that users contact EIS Cadd Support to insure that the 
method being used is accepted and that there is no known software issues with that method. 

 
Any Questions regarding the information within this document please contact the MDT EIS 
Cadd Suppport users listed below. 
 

John JJ Walsh  
(406)494-9615   
JOWALSH@MT.GOV 

Bob Mullenix 
(406)444-0813  
RMULLENIX@MT.GOV 
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3 File Management 
 

During Geopak sessions there are several files that are used and created when performing 
the various tasks for Geopak Road Design Projects. Some but not all of these files will need 
to be stored on DMS. It is up to the user to become familiar with these files and determine 
what files need to be uploaded to DMS.  

 
Note:       ***  = Geopak Job Number 
  ####### = MDT Uniform Project Number (UPN). 
 

JOB***.GPK  This is a binary file that contains all the data for the horizontal and 
vertical alignments.  The number used when creating this file 
should be related to the project UPN number.  

(i.e.  CN 1426, JOB# 142 OR 426). 

NAME***.IOC This is a text file that contains all the input commands used during 
a Geopak Cogo session.  This file can be used to recreate the 
horizontal alignments stored during Cogo sessions back into the 
.GPK file in the case the .GPK file becomes corrupted.  

(I = Input, OC = operator code) 

J***OOC.INP This is a text file that is created when an alignment is stored 
graphically or when storing profiles. This file can be used to 
recreate the horizontal alignments stored graphically and vertical 
profiles back into the .gpk file in the case the .gpk file becomes 
corrupted.  

 (OC = operator code) 

#######RDMAP001.DGN   This is the design file that contains the Horizontal and Vertical 
Alignments.   

#######RDXSF001.DGN This is the design file that contains the Working Cross-sections. 

#######RDLAY001.DGN This is the design file that contains the Working Cross-section 
Sheet’s that are used for plotting plan sets. 

#######RDPLP001.DGN 

Or 

#######RDPLN001.DGN 

This is the design file that contains the Plan Sheets Sheet’s that 
are used for plotting plan sets. 
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4 Starting Microstation/Geopak 
 

By default Geopak is installed on all MDT PC’s that have Microstation installed. Geopak is 
automatically loaded when Microstation is started but must be activated each time a 
Microstation session has been started. 

 

 

 
Step 1: 
 
For Geopak Criteria Projects Start Microstation using the 
installed Road Design v8i Shortcut located under: 

 
Windows>All Programs>Microstation> 
 
 
 
Note: 
 
Never double click Microstation DGN files in 
windows explorer to start Microstation. Geopak 
will not be available and users will receive 
unexpected results during Microstation sessions. 

 
 
Step 2: 

Open a valid Microstation DGN file or 
navigate and open the following file: 
 
C:\MDOH\MDT.DGN 

 

 
Step 3: 
 
Once Microstation has been started the Application pull down will be available on the main 
Microstation toolbar. To activate Geopak select Application>GEOPAK>Activate Geopak 
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After GEOPAK activates, all the available Geopak Design modules are now available under 
Applications> GEOPAK 

 

 
 

There are two options when using the GEOPAK ROAD module.  
 

• Use the Application>Geopak>Road pull-down menu (shown below) 
 

• Use the Application>Geopak>Road>Geopak Road Tools 
 

For this class we will be using the Geopak Road Tools option. To load the Road Tools 
frame, select Applications > GEOPAK >ROAD > ROAD Tools. 
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5 GEOPAK ROAD Tools frame 
 

As an alternative to the pull-down menus invoking various GEOPAK tools, tool frames and 
tool boxes are supported within Geopak. The Geopak tool frame is similar to the Microstation 
main tool frame. It is resizable and dock able but cannot be customized. The Geopak Road 
tools frame consists of 8 individual tool boxes. Of these eight, three are single item tool boxes, 
i.e., consisting of one icon. 
 
Each icon in the Road Tool Frame is a tool box that can be pulled out to become a "tool box." 
The individual tool boxes can be docked resized and can be customized. 

When the Geopak Road Tools Frame or any of the tool boxes within are opened when closing 
out of Microstation they will be reopened once Microstation and Geopak are restarted. 

 
 

 

 
If the function of an icon is not apparent, position the 
cursor on the icon. A detailed description is displayed in 
the status bar and a tool tip appears, as shown. 
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6 Setting User Preference 
 
To provide maximum flexibility to the designers, GEOPAK provides numerous system 
parameters to allow the user to easily set or change the number of decimal places for output files, 
station formatting, coordinate format, working units, etc. 
 

 

These parameters are utilized so the user can set the 
parameters to the most commonly used options 
which GEOPAK remembers each time GEOPAK is 
accessed. However, when a change is needed for a 
particular application, or the user wants to change 
the default settings, this can easily be accomplished 
using the User Preference dialog. 
 
 
Step 1: 
 
From the Applications pull-down  
 

• Select Geopak\Road\User Preferences. 
 
 
 

 
Set the User Preferences Options using the following settings shown. This is the current MDT 
Default Settings for Road Projects. 
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User Preferences 
 

 

 
 
 
Unit System = English 
Coordinates = NE 
Direction = Bearing 
Station = 12+34 
Distance = 99.12 
Station = 9+99(9).12 
Angle Seconds = 9^9’9.12” 
Working Directory  = C:\DGN 
 

 
 
Feature Preferences 
 

 
 

 
 
 
 
Feature Database = W:\GEOPAK\surveyeng.smd 
Apply Best Match Feature = True 
Use Shared Cells = False 
Plot Scale = 100.00 
Point Label Redraw = Position by SMD Settings 

 
Cogo Preferences 
 

 
 

 
 
 
 
Job(GPK) Open Mode = Query 
Job (GPK) Directory = C:\DGN 
COGO Input File Directory = C:\DGN 
COGO Output File Directory = C:\DGN 
Redefinition of Elements = Checked 
Force Redefinition Off COGO Activation = False 
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7 New Road Project 
 
The following covers the basic requirements for beginning any Geopak Road Design project. 
Please refer to the MDT CADD Standards Manual for additional information related to Survey 
CADD files and MDT CADD Design Standards. 
 
7.1 Download Survey Data Set 
 

When starting a new Geopak Project Design a completed survey data set of the project 
corridor must be completed and loaded onto DMS. The four files listed below are the 
minimum files needed to begin any Geopak Road Project. 

 
Download the following files from DMS for the appropriate project corridor. 

 
File Name File Description DMS Folder 
 
#######DIMAP001.DGN 
AND\OR 
#######PHMAP001.DGN  
    

 
This is the survey design file(s) that contains the 
Existing features within the surveyed corridor. 

 
DI 
 
PH 

 
#######DIDTM001.TIN  

 
This is the binary file that contains the data for the 
existing ground surface of the surveyed corridor 

 
DI 
 
PH 

 
#######SUCON001.IFT 
 

 
GPS Point Location File 
 

 
SU 

 
#######SUCON001.DES 

 
GPS Point Description File 
 

 
SU 

 
During the design phase additional Survey CADD files may be made available. Refer to the 
CADD Standards Chapter 2 Survey for additional information related to the various types 
of surveys encountered during the road design process.  

 
Note:  
 
The *.IFT & *.DES files are required in order to confirm that GPS control has been set. If 
these files do not exist than no design should be done until at which time the GPS control 
has been set. 
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7.2 Create Mapping Files 
 

When designing a Road project users are required to create a mapping file to be 
used for the project. The mapping file will consist of 2 models one (2D) where all 
the design elements will be placed by the users and the one (3D) model to be used 
for visualization existing and proposed DTM’s.  
 
Note: 
 
 MDT uses a custom macro that will assist the user in creating the file. 
 The file will need to be uploaded to DMS 

 
 

 

 
 
 
 
Step 1: 
 

From the Microstation Road pull down  
  

• Select Road\Mapping\Create Road Map 

 

 

 
Step 2: 
 

• Select the Survey DIMAP or PHMAP 
file Previously down loaded to the 
C:\DGN folder. This will be the seed 
file from which the Road Map Files 
will be created. 

 
Note: The UPN and Series number will be 
populated after the Survey File has been 
selected.  
 

• Select Apply 

Note:  
 
The size of the survey mapping file will determine how long it will take to create the Road Map 
File. The larger the survey mapping file the longer it will take to create the road map files.  
 

The file should now be created and located in the C:\DGN folder 
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7.3 Attach Raster’s 
 

Raster files are aerial photos formatted to be used during the design process. 
Raster files are available and can be downloaded in *.sid format and referenced to 
design files during the design phase of a project.  Raster can be downloaded from 
http://nris.mt.gov/nsdi/orthophotos/naip_2011.asp  

 
Note:  
 
Due to the large size of raster files it is up to the user to determine if they want to 
upload the raster files to DMS. By uploading raster files to DMS this will greatly 
increase the transfer time of the design files referencing the raster’s. 

 
 

 

 
 
Step 1: 
 
Open the RDMAP(RASTER) Model  
 
From the Microstation Road pull down 
 

• Select Road\Survey\Download Rasters 
 
 
 

 

 
 
 
 
 
Step 2: 
 

• Select the region from the State Map for 
which the project corridor is located. 

 

http://nris.mt.gov/nsdi/orthophotos/naip_2011.asp
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Step 3: 
 

• Select the photo from the map for which 
the project corridor is located, and save 
them to the C:\DGN folder 

 
 

 
 

 
 
 

Step 4: 
 

• Rename the downloaded 
*.SID files following 
current MDT naming 
standards. 

 
Note: 
 
This only needs to be done if the 
raster files will be uploaded to 
DMS 

 

 

 

 
Step 5: 
 
From the Microstation Road pull down  
 

• Select Road\Survey\Attach Rasters 
 
Or 
 
From the Microstation Primary Tools 
 

• Select Raster Manager>Attach 
 
 
This will load the Raster Manager 
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Step 6: 
 
From the Microstation Attributes Tools Box 
 

• Select Template>Roadway> Raster Aerial Photos  
 
This will set the level for the Raster files to be placed on 
when their attached. 

 

 

Step 7: 
 
From the Raster Tools 
 

• Select Attach  
 

  
 
 
 

 
 

 
 
 
 
 
Step 8: 
 

• Select the Rasters to Attach  
 

• Select Open 
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Step 9: 
 
To Attach the Rasters 
 

• Select Attach 
 
From the Microstation View tools 
 

• Select Fit View 
 
 

 

 
 

 
 
 
 
Step10: 
 
Right Click on each Raster 
 

• Select File Name 
 
Note: 
 
This only needs to be done if the 
raster files will be uploaded to DMS 

 
 

 
 

 
Add the workgroup Logical Prefix to the 
Raster attachment to be used with DMS. 
 

• Select OK 
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Step 11: 
 

• Right Click on each Raster 
 

• Select Bring To Front 
 

  

 

 
Step 12: 
 
From the Microstation View tools  
 

• Select Fit View 
 
Using the Microstation Place Shape Tool 
 

• Place a Shape around the surveyed 
corridor. 

 

 
 

 

 
 

 
 
Step 13: 
 

• Select the first Raster in the list 
 

• Select the Clip Raster Tool.  
 
 
 
 
 
 
 

• Set the Clip Method to Element  
 

• Select the Raster Clip boundary shape 
previously drawn in the DGN file. 
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Note:  
 
This will need to be performed on all Rasters 
that are attached 
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7.4 Attach References 
 
Attach any Additional Survey Mapping files to both the (2D) and (3D) files.  
 
Step 1: 
 
From the Microstation Road pull down select Road\Survey\Attach Survey’s 
 
 
Step 2: 
 
Select References at the Top of the Road Dialog 
 
Step 3: 
 
Select the References to Attach 
 
 
Note:  
 
Once all the references have been attached according to MDT standards move 
the references into the c:\dgn\ref folder. 
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7.5 Review Survey Data 
 

When beginning any road project users should perform the following task to check the 
survey CADD files for errors. This will save time during the design phase of a project if 
any errors can be caught and fixed before any design begins. 

 
7.5.1 Import Survey Control 

 
The Import Survey Control Tool is a MDT macro that has been developed to 
Import the GPS control and plot the control features in the RDMAP  (2D) and 
(3D) models. 
 
Note: 
 
The *.IFT & *.DES files are required in order to confirm that GPS control has 
been set. If these files do not exist than no design should be done until at which 
time the GPS control has been set. 

 
 

 
 

 
Step 1: 
 
Open the RDMAP(CMA) Model 
 
From the Microstation Road pull down  
 

• Select Road\Survey\Import Survey Control 
 

 

 

Step 2: 
 

• Select Point Number File 
 

• Select Point Description File 
 

• Select Visualize Points 
 
Note: 
 
To Delete the points select the X next to the Visualize 
button. 

 
The Survey control points should now be displayed in the DGN file. 
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7.5.2 Load DTM Features 
 

The Geopak DTM Tools are used to perform a wide range of task on Digital 
Terrain Models (DTM). DTM’s are binary files consisting of triangulated 
algorithms of the Existing Ground surface. DTM’s are currently generated by 
MDT’s survey Section, MDT’s Photogrammetry Section or by a Consultant. 

 
 

 
 

 
 
Step 1: 
 
Open the (3D) RDMAP(CMA) Model 
 
From the Geopak Road Tools 
 

• Select DTM Tools 

 
 

 
 
Step 2: 
 
From the DTM Tools 
 

• Select Load DTM Features 

 

Step 3: 
 
Copy the following file to the C:\DGN folder 
W:\Geopak\Preferences\DTM_EXISTING.LPF 
 
From The Load DTM Features Dialog 
 

• Select File Open 
 
From the DTM File Open dialog 
 

• Select the file 
C:\DGN\DTM_EXISTING.LPF 
 

• Select Open 
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Step 4: 
 

• Set Load File option to TIN 
 

• Select the TIN file for the project corridor. 
 
 
 

 

Step 5: 
 

• Set Display Feature to All Items On. 
 

• Select Contours Feature 
 

• Select Read 
 
Note: 
 
Take note of the elevation range of the TIN and 
adjust the contour Intervals accordingly.  
 
Step 6: 
 

• Select Load  
 

The DTM Features Should now be drawn in the DGN file. 
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7.5.3 Importing Existing Topog 
 
The Import Existing Topog Tool is a MDT macro that has been developed to extract cell 
features from survey files and plot the features in the (3D)RDCMA and (2D)RDXSF DGN files. 
 

 

 
Step 1: 
 
Open the (3D) RDMAP(CMA) file  
 
From the Microstation Road pull down  
 

• Select Road\Survey\Import Topog Features 
 

 

 
 

 
 
Step 2: 
 

• Select the Feature DGN File 
 

• Select the TIN File 
 

• Select the Feature Search option 
 
Note: 
 
The following Cell Feature Groups are supported. 
 
 Utility Features 
 Roadway Features 
 Natural Features 
 Drainage Features. 

 
• Select Apply 
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Step 3: 
 

• Select All Cells  
 

• Select 3D  
 
 
 
 
Step 4: 
 

• Check the Cell search setting and 
repeat for each additional Feature 
Group to Import. 

 
 
 

 
 

The 3D Cells should now be drawn in the (3D) RDMAP(CMA) DGN file 
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7.5.4 Importing Existing Drainage 
 
This Import Existing Drainage Tool is a MDT macro that has been developed to extract 
culverts from the survey files and plot them in the 3D and XS DGN files. 
 
Note: 
 
This process requires the survey crews to attach the culvert survey information as adhocs to the 
surveyed culvert points within the (3D) DIMAP file. 
 

 

Step 1: 
 
Open the (3D) RDCMA file  
 
From the Microstation Road pull down  
 

• Select  
Road\Survey\Import Drainage Features 

 

 

 
Step 2: 
 
 

• Select Drainage Survey File 
 
 
Step 3: 
 

• Select Import 
 
Note: 
 
Select the Convert Size to Inches if not already done 
in inches. 

 
 
Step 4: 
 

• Select 3D 
 

 
The Culverts should now be drawn in the 3D file 
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7.6 Create Geopak GPK File 

The Geopak GPK file is the binary file that contains all the Horizontal & Vertical Alignment 
information.  This file will need to be uploaded to DMS. 

 

 

 

Step 1: 
 
From the Geopak Road Tools Frame  
 

• Select COGO 

 

 

 

 

Step 2: 
 
Enter the information for the project. 
 

• For Project Name use the Project UPN 
• For Job Use the First 3 or last 3 values of 

the Project Control Number 
• For the Operator Code use OC 
• For Subject use RECON, OVERLAY, 

REHAB etc. 
 

• Select OK 
 

 
Step 3: 
 
A prompt to create the GPK will be displayed 
 

• Select Yes 
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8 Horizontal Alignments 
 
There are several ways to store horizontal alignments into Geopak. Horizontal alignments are 
stored as Chains consisting of points, lines, curves, and spirals and are stored as Cogo elements 
within the Geopak Coordinate Geometry database (GPK file). 
 

• Store Alignments in Geopak Coordinate Geometry. 
• Store Alignments from Graphics 
• Store Alignments with Microstation Geometry tools. 

 

 
 
 
There are several types of alignments that can be stored such as Existing Alignments, Design 
Alignments, Curb & Sidewalk Alignments, Ramp Alignments, Ditch Alignments, etc. Each type 
of alignment will have different design criteria that will need to be applied when storing that type 
of alignment such as, min curve radius, simple curves or spiral curves, deflection angles, etc. 
 
When storing Centerline alignments one must consider the sources of information available for 
laying out the alignment, and whether the alignment can be stored independently as a new 
alignment or if the alignment must follow the existing staked alignment. Most common sources 
of information are as-Builts and survey mapping files. 
 
The type of project will have a direct effect on the way the alignment will be stored in Geopak. 
For reconstruct projects the new alignment will be stored uncontrolled by the existing alignment 
for the exception of the beginning and ending connections of the project. Overlay & Rehab jobs 
will use the best fit method and follow the survey PTW and Asbuilt information as close as 
possible. 
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Existing Alignments: 
When storing Existing Alignments do not use as-built bearings, most likely the as-built basis of 
bearings were derived by solar observations or by assuming them. For that reason the most 
common method of storing the Existing Staked Alignment is the best fit method and should be 
used following the PTW feature in the survey mapping file. This is due to the fact that all new 
projects requiring survey are now tied by GPS. 
 
Design Alignments: 
When storing Design alignments provide additional tangent length when possible for 
connections at the beginning and end of the project and where projects begin at the beginning of 
a curve. 
 
Chain Names: 
MDT currently does not have a standard on Chain names, Chain names should be limited to 8 
characters.. 
 
Stationing: 
When storing an alignment the chain station will be determined by whether or not existing 
stationing needs to be used. Projects requiring stationing tied to existing station must calculate 
the beginning station based on a fixed surveyed feature with known asbuilt stationing. For all 
projects not requiring the existing stationing to be tied,  the stationing can begin at 0+00.00 
 
Bearings: 
When storing alignments all bearings should be rounded to current MDT standards set forth in 
the MDT Road Design Manual. Bearings should be rounded prior to notifying R/W that the 
alignment is available. In the event that the alignment changes R/W needs to be notified. 
 
Incorrect 

 
 
 
Correct 
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Points: 
MDT has adopted the following point naming convention for storing points in Geopak GPK files 
to help expedite the information to the construction crews. Below is a list of point place holders 
for each work group utilizing Geopak to store points during the design process.  
 

Min. req. pnts.                                                              Proposed range 
 

2000 Cadastral Survey  1-1999 
1000 Road Design 2000-2999 
4000 R/W 3000-6999 
1000 Placeholder for Traffic 7000-7999 
1000 Placeholder for HYD 8000-8999 
1000 Placeholder for Bridge 9000-9999 
10,000 R/W parcels 10,000-19,999 
1000 Placeholder for GEOTECH 20,000-20,999 
5000 Placeholder for ENVIRO. 21,000-25,999 
 Unused placeholder 26,000-49,999 
500,000 Pre-Survey (includes Constr.) 50,000-to end 

 
For complex projects that have multiple design chains such as urban projects users may also 
use an Alpha numeric point convention if they wish. This assists the user in identifying what 
chain the points belong to when reviewing GPK points. At this time it is at the user’s 
discretion to determine the alpha characters for their point names. As a recommendation and 
for consistency, users can use the Chain Name for the alpha character along with a point 
number for their workgroup placeholder listed above. 
 
Example:  (ChainName)(PointNumber) 
  DESIGN2000 
 
Note:  Geopak Point names are limited to 15 Characters 

   
When using an alpha Numeric point name other than the chain name users must be aware of 
any survey points that may have already used an alpha numeric point name for their project. 
Users need to be sure not to use single or double Alpha characters such as A, AA etc. as this 
format is already used by survey personal for control points. 
 
Below is a list of the current Survey Alpha Numeric points that are encountered. 

 
1) MDT Control points are currently numbered A+4 digit control number (A5764) thru ZZ 

+ 4 digit control number (ZZ5764). 
2) Existing old MDT Control that is still being used (milepost + alpha) that we convert to 

alpha-numeric.  
3) NGS Benchmarks are all over the board E.g. coppweld, 1JEB, W270. 
4) Photogrammetry uses 600-799 + 4 digit control number (6045764). 
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Curves: 
 

When storing curves, use the following naming convention for the curve names. This will 
help identify what curves belong to the chain when the chain is stored. By using different 
names for simple vs spiral curves this will help identifying what curves have spirals. 
 
Simple Curves 
Chain Name + _C1 
 
Example: DESIGN_C1 
 
Spiral Curves 
Chain Name + _S1 
 
Example: DESIGN_S1 
 

 
Alignment Coordinate Tables: 
 

When importing alignments into a data collector, the Point Of Beginning of the alignment 
defaults to the first station in the downloaded typicals.  This may not be the actual start of the 
project, sometimes the alignment starts before the project to allow for transitions.   
 
The following is a list of points that are required to be stored in all chains used for centerline 
alignments. These are critical points and must be stored for a seamless import to the Data 
collector. 
 

 Beg Alignment 

 Beg Prj. Transition 

 Project Beginning 

 Equations 

 Bridge Ends 

 Intersections 

 Beg Prj. End Transition 

 Project End 

 End Alignment 
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8.1 Coordinate Geometry Tools 

GEOPAK Coordinate Geometry tools calculate and store points, lines, curves, spirals, chains, 
parcels and profiles. In addition, it calculates roadway super elevation, bridge deck elevations, 
geometric relationships, intersections between alignments and many other functions. 

All the coordinate geometry is stored within a binary database, named job**.gpk, (where ** is a 
two or three digit alphanumeric code) which is compatible across all platforms.  

While computing coordinate geometry, GEOPAK's visualization mode displays the 
computations on the screen, so the designer can immediately see the results of the calculations. 
In addition to visualizing the computations, GEOPAK also builds an audit trail, which can be 
saved at the designer's option. If changes occur at a later time, the designer simply accesses the 
input file, makes the correction, and then stores the information again. 

 

 

Step 1: 
 
Open the (2D) RDMAP(Default) Model 
 
From the Geopak Road Tools frame  
 

• Select COGO 

 

 

 

Step 2: 
 
Enter the information for the project 

• For Project Name use the Project UPN 
• For Job Number Use the First 3 or last 3 

values of the Project control Number 
• For the Operator code use OC 
• For The subject use RECON, OVERLAY, 

REHAB etc. 
 
• Select OK 
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 Within the Coordinate Geometry Data base there are several ways to activate the 

cogo tools.  
 
 All tools are avaialble via the pull downs located at the top of the interface.  

 
 The Coordinate geometry interface is customizable and can be set to each users 

preference.  
 
 The interface supports a customizable frame to display links to all the tools 

available.  
 
 When using Cogo tools you must be in the  (2D)RDMAP(Default) Model 
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8.1.1 Store Points 
 
The store point tool is used to store points in the GPK file. 

 

 
Step 1: 
 
From the Cogo Tools pull down  
 

• Select Element>Point>Store 
 
Set the Point Name following the MDT Geopak 
point numbering standard. 
 

• Select Auto Increment 
 
Step 2: 
 

• Select the DP button and identify the point 
on the screen to set the coordinates of the 
point to be stored or input the known 
coordinates of the point in the Northing & 
Easting fields. 

 
Step 3: 
 

• Select Store Point 
 

In the Coordinate Geometry window, the information confirming the storing of the point will appear. 
 

 
 
Step 4: 
 

• Repeat steps 2 & 3 and store 3 more points. 
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8.1.2 Inverse Tool 
 

The inverse tool is used to check the Bearing & Distance between points. 
 
 

 

 
 
Step 1: 
 
From the Cogo Tools pull down  
 

• Select Tools > Inverse 
 
Enter the range of points to check the distance & 
bearing. 
 
Step 2: 
 

• Select Inverse 
 
In the Coordinate Geometry window, the information showing the bearing & distance between the points 
will appear. 
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8.1.3 Locate Points from Stored Points 
 

The Locate Traverse tool will locate and store points relative to points previously stored. 
 
 

 
 
 

Step 1: 
 
From the Cogo Tools pull down  

• Select Tools>Locate>Traverse 
 

• Set the Direction option to Bearing 
 

• Set the Distance option to Distance 
  
Step 2: 
 
Fill in the following 
Locate Point 
Start Point 
Direction (round to the nearest second  0^00’00”) 
Distance (Round to the nearest .01) 
 

• Select Locate 
 

 

In the Coordinate Geometry window, the information confirming the storing of the point will appear 
 

 
  

Step 3: 
 

• Repeat Step 2 for all additonal 
points 
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8.1.4 Store Simple Curve from points 
 

The Store Simple Curves Tool is used to store simple curves. 
 

 
 
 
Note:  
A Minimum of 3 points must be stored in  
the GPK file in to store a Simple Curve. 
 
 
 
 

 
Step 1: 
 
From the Cogo Tools pull down  
 

• Select Element>Curve>Store>By Tangents 
 

• Set the Back Tangent option to  
Point Back / PI Point 
 

• Set the Element option to Radius 
 

• Set the Ahead Tangent option to  
Point Ahead 
 

Step 2: 
 
Enter The following: 
Curve Name 
Point Back 
PI Point 
Radius 
Point Ahead 
 
Step 3: 
 

• Select Store Curve 
 
In the Coordinate Geometry window, the information confirming the storing of the curve will appear.   
 

 



Geopak Users Manual   1/29/2013 

 
 

36 

8.1.5 Store Spiral Curve Spiral from points 
 

The Store Spiral Curve Tool is used to store curves with spirals. 
 

 
 
Note:  
A Minimum of 3 points must be stored in  
the GPK file in to store a spiral curve. 
 
When spirals are stored they are stored as 3 
separate elements in Cogo, the Back Spiral the 
Simple Curve & the Ahead Spiral. Coordinate 
geometry will automatically add the suffix to the 
spiral names identifying them accordingly. 
 
Example: 
 
Spi = DESIGN_S1B 
Cur  = DESIGN_S1  
Spi = DESIGN_S1A 
 
Note: 
B = Back 
A = Ahead 
 

 
 
Step 1: 
 
From the Cogo Tools pull down  
 

• Select Element>Curve>Spiral>Store 
 

• Set the Back Tangent option to  
Point Back / PI Point 
 

• Set the Element options to  
Entry Length 
Radius 
Exit Length 
 

• Set the Ahead Tangent option to  
Point Ahead 

 
Step 2: 
 
Enter The following: 
Spiral Name 
Point Back 
PI Point 
Entry Length 
Radius 
Exit Length 
Point Ahead 
 
Step 3: 
 

• Select Store Curve 
 
 

In the Coordinate Geometry window, the information confirming the storing of the spiral curve spiral 
combination will appear.   
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8.1.6 Store Chain from Cogo Elements 
 

The Store Chains Tool allows you to create chains from elements that have been 
previously stored in the GPK.  
 

 
 
Note:  
 
When storing Spiral-Curve-Spiral Curves be 
sure to enter them as SCS “Curve Name”. 
This is the only way to get the PISCS to show 
in Alignment output file. 
 
DO NOT use the ADD button to store spiral 
curves. 
 
 

 
Step 1: 
 
From the Cogo Tools pull down  
 

• Select 
Element>Chain>Store>From Elements 

 
 
Step 2: 
 

• Enter the Chain Name 
 
 
Step 3: 
 

• Set the Beginning Station value. 

 

Step 4: 
 

• Set the element type option to correspond with the first element to be stored in the chain 
• Select ADD 
• Repeat this step for each element to be stored in the chain. 

 
Note:  
 
Points will not be displayed and are required to be input manually. 
 
 
Step 5: 
 

• Select Store Chain 
 
In the Coordinate Geometry window, the information confirming the storing of the chain will appear.   
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8.1.7 Store Chain from Graphics 
 

 
 

STEP 1: 
 
Open the (2D) RDMAP(Default) Model 
 
From the Geopak Road Tools 
 

• Select Store Graphics 
 

   

 

 
STEP 2: 
 
Enter the Following 

• Select Job 
• Enter Operator Code 
• Set Method to Chain 
• Enter Chain Name 
• Enter Beg Point Name 
• Enter Beg Station 
• Set Mode To Complex Chain 

 
 
 

STEP 3: 
 

• Select the ID Element button 
 

• Select the first element in the chain to be stored. Continue to accept the pieces of the 
alignment until the whole chain is highlighted and the STORE button is highlighted in 
dialog box. 

 
 
STEP 4: 
 

• Click STORE to store the alignment in the .GPK file. 
 
Note:  
 
This will give you a message telling you the chain was stored in the .GPK file and the commands 
were saved in an .inp file.  Keep this .inp file so that you can recreate the .GPK file if it becomes 
corrupt or lost. 
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8.2 Layout Existing Staked Alignment (Best Fit Method) 
 
For existing alignments establish a best fit alignment following the surveyed PTW feature using 
any Asbuilt curve data following steps below, 
 

STEP 1:  
 

Open the RDMAP(Default)  (2D) Model 
 
From the Attribute Templates  
• Select Roadway\Alignments\Alignment Layout.  

This will set the active symbology for alignment layouts. 
 

STEP 2:  
• Using basic Microstation lines place a line using the surveyed PTW points as 

reference points and establish the ahead tangent bearing from the beginning of 
the alignment to the approx PT of the first curve or POT 

 
STEP 3: 

• Next place a line using the surveyed PTW points as reference points and 
establish the ahead tangent bearing from the back POT or the PT of the first 
curve to the PC of the second curve or next POT. Intersect the elements to 
determine the PI location. Repeat the steps for each additional PI or POT 
along the chain being stored 

 

 
 

 
 

 

 
STEP 4: 
 
From the Geopak Road Tools Frame 
 

• Select Cogo 
 

 
 
Enter the information for the project. 

• For Project Name use the Project UPN 
• For Job Number Use the First 3 or last 3 

values of the Project control Number 
• For the Operator code use OC 
• For The subject use RECON, OVERLAY, 

REHAB etc. 
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STEP 5: 
 
From the Geopak Road Tools Frame 
 

• Select Store Graphics 
 

 
 

 
 
 
 
 
 
 
 
 

 
 

STEP 6: 
 
Enter the Following 

• Job 
• Operator Code 
• Method = Chain 
• Chain Name 
• Beg Point Name 
• Beg Station 
• Mode =Complex Chain 

 
 
STEP 7: 
 

• Select the ID Element button 
 

• Select the first element in the chain to 
be stored. Continue to accept the 
elements until the whole chain is 
highlighted and the STORE button is 
highlighted in dialog box. 

 
 
STEP 8: 
 

• Click STORE to store the Chain in 
the .GPK file. 
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STEP 9: 
 
To store the Chain in the GPK file. 
 

• Click OK  
 

 
In the Coordinate Geometry window, the information confirming the storing of the chain will 
appear.  Take note of the number of points that were stored with the chain. 
 

 
 
 

 

STEP 10: 
 
From the Geopak Cogo pull down  
 

• Select Tools>Inverse 
 
Type in the range of points  
 

• Select Inverse 

 

 
 
 
In the Coordinate Geometry window, the 
information showing the distance and 
bearing between all the points will appear. 
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STEP 11: 
 
From the Cogo Tools pull down  
 

• Select Tools>Locate>Traverse 
 

• Set the Direction option to Bearing 
 

• Set the Distance option to Distance 
 
Enter the following 

• Locate Point 
• Start Point 
• Direction (round to the nearest second  

0^00’00”) 
• Distance (Round to the nearest .01) 

 
• Select Locate 

 
 

In the Coordinate Geometry window, the information confirming the storing of the point will appear. 
 

 
 
Step 12: 
 

• Repeat Step 11 for all points along the chain. 
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Step 13: 
 
From the Geopak Cogo pull down  
 

• Select Tools>Inverse 
 

• Enter  the range of points  
 

• Select Inverse  
 
In the Coordinate Geometry window, the 
information showing the distance and 
bearing between all the points will appear. 
Confirm that the bearing have been rounded 
for all points. 
 

 
 

 

Step 14: 
 
From the Cogo Tools pull down 
 

• Select  
Element>Curve>Store>By Tangents 
 

• Set the Back Tangent option to  
Point Back / PI Point 
 

• Set the Element option to Radius 
 

• Set the Ahead Tangent option to  
Point Ahead 

 
Enter The following: 

• Curve Name 
• Point Back 
• PI Point 
• Radius 
• Point Ahead 

 
• Select Store Curve 

 
Step 17: 
 

• Repeat Step 14 for all curves along the alignment. 
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Step 18: 
 
From the Geopak Cogo pull down  
 

• Select 
Element>Chain>Store>From Elements 
 
 
Enter The following: 

• Chain Name 
• Begin Station 

 
 
Step 19: 
 

• Set the Element Type to point and type 
in the first point along the chain  

 
• Select ADD 

 
• Set the Element Type to the next 

element in the chain 
 

• Select ADD 
 
Do this for all elements that are to be stored 
in the chain. 
 
Step 20: 
 

• Select Store Chain  
 

 

Step 21: 
 
From the Geopak Cogo pull down  
 

• Select Element>Chain>Utility 
 

• Select the Chain  
 

• Select Describe Chain 
 
 
 

In the Coordinate Geometry window, the information showing all the alignment information for 
the chain will appear. 
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Step 22: 
 
From the Geopak Cogo pull down  
 

• Select File>Input File Utility 
 
 
 
 
 
 
 
 
 
 
 
 

• Set the option to Save  
 

• Input a file name, limit to 3 char. 
 
 

• Select Apply 
 

The Cogo input file should now be stored in the C:\DGN folder and you can now exit out of 
Geopak Coordinate Geometry. 
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8.3 Draw Horizontal Alignment - Design and Computation Manager 
 

The D&C manager is used to Draw Alignment features into design files. 
 

 

 
Step 1: 
 
Open the (2D) RDMAP(Default) Model 
 
From the Geopak Road Tools frame  
 

• Select the D&C Manager Tool 
 

 

 
 
Step 2: 
 
To draw the alignment in the design file. 
 

• Select Roadway>Alignments>AlnDsn 
 
 
 
Step 3: 
 

• Select the Design Tool 
 
 
 
 
 
 
 

 

 
 

 
Step 4: 
 

• Select Draw Plan & Profile  
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Step 5: 
 

• Select the Job(GPK) File 
 

 

 
 
Step 6: 
 

• Set the Label Scale to 100 
 

This will scale the alignment 
information to fit the scale of the 
drawing. 

 
 Rural = 100 
 Urban = 50 
 Detail = 20 
 Detail = 10 

 
 
Step 7: 
 

• Set the Element Type to Chains  
 

• Select the Chain in the list. 
 
Step 8: 
 

• Set the Element Type to Stationing 
 

• Select the Chain in the list. 
 
 

The alignment should now be annotated in the design file. 
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8.4 Export Alignment Information  
 

Exporting Alignment information is a Coordinate Geometry function and should be done 
for all Centerline alignments. 

 
 

 
 

 

 
STEP 1: 
 
From the Geopak Road Tools  
 

• Select Cogo 
 
 
 
 
Enter the information for the project. 

• For Project Name use the Project UPN 
 

• For Job Number Use the First 3 or last 
3 values of the Project control Number 

 
• For the Operator code use OC 

 
• For The subject use RECON, 

OVERLAY, REHAB etc. 
 

• Select OK 
 
 
 

 

 

 
Step 2: 
 
From the Geopak Cogo pull down  
 

• Select File>Input File Utility 
 

• Set the option to Load  
 

• Select the input file to load 
 

• Select Apply 
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Step 3: 
 
From the Cogo pull down  
 

• Select Edit>Read All 
 

 

 
 
 
 
Step 4: 
 
From the Cogo pull down  
 

• Select Element>Chain>Utility 
 
 

 

 
 

 
 
 
Step 5: 
 

• Select the Chain  
 

• Select Describe Chain 
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Step 6: 
 
From the Geopak Cogo pull down  
 

• Select File>Input File Utility 
 

• Set the option to Output 
 

• Input a file name, limit to 3 char. 
 

• Select Apply 
 

The Cogo output file should now be stored in the C:\DGN folder and you can now exit out of 
Geopak Coordinate Geometry. 
 
 

  



Geopak Users Manual   1/29/2013 

 
 

52 

9 Existing Ground Profile 
 
The Ground Profile Tool is used to extract the Existing Ground Profile along the Chain. 
 
9.1 Extract Existing Ground Profile 
 

 

 

Step 1: 
 
Open the (3D) RDMAP(CMA) Model 
 
Set the Active level to Level 1 
 
From the Geopak Road Tools Frame  
 

• Select Ground Profiles 

 

 

Step 2: 
 

• For the Existing Profile name use the 
Chain name and append _E to the name 

 
STKD_E 
 

• Select Job 
• Enter Operator Code = OC 
• Select Chain 
• Enter Offset  = 0 
• Check Station Range 
• Set Strip Grade to Even = 50 
• Select the TIN File 

 
• Select Apply 

 

 

 

Step 3: 
 

• Select OK 
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Step 4: 
 

• Select YES 

 

 

 

 
Step 5: 
 

• Select YES 
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9.2 Draw Existing Ground Profile 
 

 
 

Step 1: 
 
From the Geopak Road Tools frame  

• Select D&C Manager 
 
Criteria 
W:\GEOPAK\MDTENGLISH.DDB 
 
Roadway Designer 
W:\GEOPAK\Geopak_v8i\MDT_Standard.DDB 
 
 

 
 
 

 
Step 2: 
 

• Select the following feature to draw the 
Existing Ground profile in the design file. 

 
Roadway>Profiles>ProExst 

 
 
 
Step 3: 
 

• Select the Design Tool 
 

 
 
 

 

Step 4: 
 

• Select Draw Plan & Profile  Button 
 

 

 

 
Step 5: 
 

• Select the Job number 
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Step 6: 
 

• Select the Profile from the list 
 

 

 
The top of this dialog will show the information about 
the selected profile. 
 
Step 7: 
 
Plot Settings 

• Set Horiz Scale = 100 
• Set Vert scale = 10 
• Set Begin Sta to Beg the Beg. Sta. of the Profile 
• Set Ending Sta to End Sta. of the Profile 
• Leave Strip Grade Blank 

 
 
Profile Reference Point 

• Set Reference Station to Beg. Prof Sta 
• Set Reference Elev lower than Min Elevation 

Use a rounded elev. in increments of 10 
• Set DP for Profile Reference Point 
 

 
Profile Cell 

• Select the PGL Chain 
• Select Draw Cell at XY 

 
• Select OK 
 

 
The Existing Ground profile should now be drawn in the design file. 
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10 Plan & Profile Sheet Composition 
 
The Plan & Profile Sheet Composition tool is used for creating sheet files for plan sets. 
 

10.1 Layout Plan & Profile Sheets 
 

 

 

 
Step 1: 
 
Open the (2D) RDMAP File 
 
From the Geopak Road Tools frame  
 

• Select PlanProfile Sheet Composition Tool 
 
 

 
 

 
 

 

 
Step 2: 
 

• Select File>Sheet Library>Attach 
attach 
MDTPLANSHEETS-E.PSL. 
(w:\geopak\mdtplansheets-e.psl)  
if not already attached. 
 
 
Step 3: 
 

• Select the Sheet Option for the desired 
sheet configuration. 

 
Step 4: 
 

• Enter the Scale for your Sheets. 
 
Scales for Half Size Plans 

 100 for 1in = 100ft. 
 50 for 1in = 50ft. 
 20 for 1in = 20ft. 
 10 for 1in = 10ft. 
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Step 5: 
 

• Select Sheet Composition  
 
 
 
 
 
 
Step 6: 
 

• Set “By Station Range: Outside In” 
• Set Horizontal to 0 
• Set Vertical to 0 
 
Station Range should read  
 3000 for 100ft./in. 
 1500 for 50ft./in. 
 150 for 20ft./in. 
 30 for 10ft./in. 

 
 

Step 7: 
 

• Close the dialog 
 

 

 

 
Step 8: 
 

• Select Layout Sheets  
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Step 9: 
 

• Select Job 
• Select Multiple Sheets 

 
  
 
 
 
Step 10: 
 

• Double click the Plan Port and 
assign the Chain to the plan port 
Dependency 

 
 

 
 

 
 

 
 
 
 
 
Step 11: 
 

• Double click the Profile Port. 
Assign the profile location by 
selecting the Identify Cell button 
and identify the profile cell in the 
DGN file shown below left. 

 
 

• Select OK 
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Step 12: 
 

• Select Layout ** Sheets 

 
The Sheet clips should now be drawn in the design file on the plan and profile. 

 
10.2 Profile Stair Stepping 

 
Check the profile sheets to be sure that the profile falls within the boundary of the sheets. If the 
profile does not fall within the boundaries of the sheets, delete the sheets and follow the steps 
below. 
 

 
 

 

 
 

 

Step 1: 
 
From the Plan Sheet Layout Tools  
 

• Select Settings>Sheet Layout  
• Set Profile Stair Stepping to ON 

 
Step 2: 
 

• Select Layout ** Sheets 
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10.3 Modifying Plan & Profile Sheet Clips 
 
The Modify Sheet Clips Tool is used for adjusting the placement of the sheets in relation to the 
Chain stationing. This tool is used for adjusting the sheet clips to provide additional space on the 
first sheet for the Beginning Project Note.  
 
Note:  
This tool requires Sheet Clips to already be drawn on the Chain & Profile 
 

 

 
 
Step 1: 
 

• Select Modify Sheets 
 

 

Step 2: 
 

• Select the Slide Sheet Option  
Top Left 

• Select the ID button for the sheet 
shape and select the first sheet 
clip on the chain. 

• Check the Slide Following 
Sheets Option 

• Enter a negative value in the 
Extend option to adjust the Left 
Edge of the First plan sheet clip. 

 
• Select Apply 

 

 

Step 3: 
 

• Select the ID button for the sheet 
shape and select the first sheet 
clip on the profile. 

• Enter the same negative value 
used for the plan port in the 
Extend option to adjust the Left 
Edge of the first  profile sheet 
clip. 
 

• Select Apply 
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10.4 Clipping Plan & Profile Sheets 
 
The Clip Sheets Tool is used for creating and clipping the sheet clips into the design files used 
for the plan sets. 
 
Note:  
Before clipping sheets 
 

• Attach all additional reference files available UTMAP, PHMAP, ETC. 
 

• Turn On & Off the desired levels that are to be displayed in the Plan Sheets.  
 
This will eliminate the repetitive task of  Attaching additional reference files and turning 
levels on and off for each plan file that gets created. 

 

 
 

 

 
 
Step 1: 
 

• Select Clip sheets 
 
Step 2: 
 

• Set the Directory to C:\DGN 
• Enter the Sheet Name Prefix following 

MDT’s Naming standard for the type of 
sheet being created. 
 
Sheet File Options: 
#######RDPLP[001] 
#######RDPLN[001] 
#######RDDET[001] 

 
Note: 
Append [001] to the Sheet name, this 
will increment the file names when 
multiple files are created. 
 

• Set the Orientation to Rotate Reference 
• Set Sheets per File = 3 
• Set Model to Active 
• Set Sheet Range Begin & End 

 
Step 3: 
 

• Check Auxiliary Sheet Annotations 
and double click the Sample symbology 
preference box. 
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Step 4: 
 

• Set Level = Level 1 
• Set Color = ByLevel 
• Set Weight = ByLevel 
• Set Th: = 12.0 
• Set Tw: = 12.0 
• Set Justification = Upper Right 
• Set Ft = 15 STANDARD 
• Set Line Spacing = 0 
• Set Angle = 0 
• Set the Anchor Point Shift Values to 0 

 
• Select OK 

 

 

 
 
Step 5: 
 

• Select Process Sheets 
 
 
 

 
The Plan Sheets Should Now be created and located in the c:\DGN Folder 
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10.5 Attaching Plan & Profile Sheets to Geopak Clipped Sheet Files 
 
MDT uses a custom macro that will assist the user in attaching Sheet Borders to the plan files 
that were clipped by Geopak. This is due to the fact that Geopak does not have the capability to 
format the plan sheet files correctly to be used with Docuplot. 
 

 

Step 1: 
 
From the Road pull down  
 

• Select Road>Plan Sets>GPK Plan Sheets 

 

 
 
 

 
Step 2: 
 

• Select Sheet Attachment Option 
• Select Sheet Scale 
• Select the File(s) to be processed 
 
• Select Apply 
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11 Cross Sections 
 
Cross Sections are required on most Road project. Cross sections are a graphical representation 
of the existing & Proposed surfaces that are used to perform detailed tasks such as Earthwork 
calculations, Plotting Limits of Construction, Culvert Design, Approach and Irrigation Ditch 
Design etc. 
 
Users are required to create 2 files for Road projects requiring Cross Sections, one for 
performing design tasks the (RDXSF) Working XS File & one for plotting the (RDLAY) Cross 
Section Sheet Layout file.   
 
Note: 
 

• MDT uses a custom macro that will assist the user in Creating these files  
• These files will need to be uploaded to DMS 
• The (RDLAY) File is used For Plotting the XS Plan Sets only and should never be used 

for drawing any design features. 
 
Critical Cross Sections 
 

When importing XS into a data collector, the following XS are required for all centerline 
alignments. These are critical points and must be stored for a seamless import to the Data 
collector. 
 

• Beg Transitions 

• End Transitions 

• Horizontal Control Points 

• Vertical Control Points (Proposed Profiles Only) 

• Super Elevation Transitions (Proposed Shapes Only) 

• Horizontal Event Points (Proposed Surfaces Only) 

• Vertical Event Points (Proposed Surfaces Only) 
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11.1 Creating XS Files 
 

 

 
 
 
 
Step 1: 
 
From the Microstation Road pull down  
 

• Select Road\Cross Sections\Create XS Files 

 
 

 

 
Step 2: 
 

• Input UPN 
• Input File Series 
• Check Sheet Options 

 
• Select Apply 

 
 
 
 
The Cross Section files should now be created and located in the c:\dgn folder 
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11.2 Draw Pattern Lines By Station Range 
 
Pattern lines are drawn into a 2D plan-view design file, one for each desired cross section. 
Although not required by GEOPAK, it is useful for the designer if they are drawn into a 
MicroStation design file containing the alignment to be used to generate the XS. 
 

 

Step 1: 
 
Open the (2D) RDMAP File 
 
From the Geopak Road Tools Frame  
 

• Select Draw Pattern Lines by Station Range 

 
 
Note: 
 
Clicking DP to the right of each station gives 
the designer the option to graphically select the 
station by placing a data point on the screen. 

Step 2: 
 

• Select Job  
• Select Chain 
• Enter the Beginning Station  

Set the Offsets to 300 Feet for both left and right. 
• Enter the Ending Station  

Set the Offsets to 300 Feet for both left and right.  
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Used for Proposed Profiles Only 
 
 
 

 
 
Used for Proposed Shapes Only 
 
 

 
 
Note: 
 
This option is used to cut Cross sections at specified stations 
for Culverts, Approaches, Curb Returns etc. 

 
Step 3: 
 

• Set the Station Option to Even 
• Set the Station Placement value to 

Rural = 50 Feet 
Urban = 25 Feet 
 

Select Draw Pattern Lines 
 
 
Step 4: 
 

• Set the Station Option to 
Control Points Horizontal 

• Change Pattern Color to CO=4 
 
Select Draw Pattern Lines 
 
 
Step 5: 
 

• Set the Station Option to 
Control Points Vertical 

• Change Pattern Color to CO=5 
 
Select Draw Pattern Lines 
 
 
Step 6: 
 

• Set the Station Option to 
Super Elevation Transitions 

• Change Pattern Color to CO=6 
 
Select Draw Pattern Lines 
 
 
Step 7: 
 

• Set the Station Option to 
Once 

• Change Pattern Color to CO=7 
• Enter the Station 

 
Select Draw Pattern Line 
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11.3 Draw Cross Sections From Surfaces 

The Draw Cross Sections Using Surfaces tool draws existing ground lines or other surface lines 
(within a 2D MicroStation design file) utilizing a GEOPAK binary TIN file, DTM file, Site 
Object, or Site Model.  

 

Step 1: 
 
Open the RDXSF File 
 
From the Geopak Road Tools Frame  
 

• Select Draw Cross Sections from Surfaces 

 
 

 
 

 
Step 2: 
 

• Select Job Number 
• Select Chain 
• Select Pattern By DGN File 
• Select Design File 
• Set Pattern Level 
• Select Line Option 
• Set Horz Scale = 10 
• Set Vert Scale = 10 
• Set Horz Spacing = 1000 
• Set Vert Spacing = 500 
• Set Number of XS by Column = 50 
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Figure 11.3.1 

Step 3: 
 

• Select the Surfaces Tab 
 

• Set Details option to TIN File 
• Select TIN File 
• Set Method to Triangles 
• Set Type to Line String 
• Set Filter Tolerances 

Horz = 0.30 
Variance = 0.10 
 

• Set Display Settings To By Feature 
• Set Feature to EGRND 
• Check Void Option 

 
Note: 
 
Right Click on By Feature Symbology 
Select Copy 
 
Right Click on Void Symbology   
Select Paste 
 
Double Click on Void Symbology 
Change the color 
 

• Check Elevation and double click the 
symbology window. 

 
Note: 
 
Set the Symbology preference as show  in 

Figure 21.3.1 
  

 
• Select Add Surface 

 
• Select Draw 
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11.4 Cross Section Navigator 

The Cross Section Navigator tool is a quick and simple method of scanning through cross 
sections or locating specific sections. In addition, tools are supported to draw cross section lines 
and set active angles. 

 

Step 1: 
 
Open the RDXSF File 
 

From the Geopak Road Tools Frame  

• Select Cross Section Navigator 

 

 

XS Navigator Tools 

DP Offset Elevation 
 

 
 

 
DP Delta Distance Slope 
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11.5 Draw Ancillary Features 
 
11.5.1 Draw Linear Ancillary Features (GEOPAK) 

 
The Geopak Draw Ancillary Features tool enables the user to draw linear features such as right 
of way, utilities, and other ancillary data onto cross sections or profiles.  Ancillary features that 
cross the profile or pattern lines are drawn at the specified elevation on the Cross Sections or 
profile. 
 

 
 

Step 1: 
 
Open the RDXSF File 
 
Copy the following file to the c:\DGN folder 
W:\Geopak\Preferences\DTM_Existing.LPF 
 
 
 
From the Geopak Road Tools Frame  
 

• Select Draw Ancillary Features 

 

 
 

Step 2: 
 

• Select Job 
• Select Chain 
• Set View = Cross Section 
• Set Label Scale = 1.0 
• Set Station Range 

 
Step 3: 
 

• Select Element Type Feature 
• Set Intersecting Elements Settings 
• Set Display Settings 

 
• Select Draw 
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11.5.3 Draw Cell Ancillary Features (MDT MACRO) 
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11.6 Cross Section Sheets 

The GEOPAK sheet layout tool is an automated tool to draw cross section data in a format 
suitable for producing hard-copy cross section construction drawings. The input includes 
specifying sheet layout parameters as well as the graphic design file where the cross sections 
were originally created by GEOPAK. The output is a MicroStation design file which references 
the cross sections and contains labels such as station, offsets and elevation.  

 

 
 

Step 1: 
 
Open the RDLAY File 
 
From the Geopak Road Tools Frame  
 

• Select Cross Section Sheet Composition 
 

Note: 
Copy the file from the following location to the 
 
C:\DGN\ folder and rename it to the Project UPN. 
 
W:\GEOPAK\MDTXSEC.XSSL 
 

• Select File>Sheet Library>Attach 
• Select C:\DGN\5801000.XSSL 

 

 

 
 
Step 2: 
 
Set the Active Cross Section Sheet Option to 
 

• English for Rural 100 Scale 
• English Half Scale for Urban 50 Scale 

 

 

 
Step 3: 
 

• Set the Working Cross Section File 
 
Note: 
 
The chain and Station range should be filled in 
based on the XS available in the XSF file. 
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Step 4: 
 

• Select the Cross Section Layout File 
 
Note: 
 
If this is the first time Laying out the XS 
sheets then make sure to check off the 
Detach Existing Sheets before Processing. 
 

 

 
 

 
 
Step 5: 
 

• Check the settings shown left and 
make sure they are set accordingly. 

 

 
 

 
 
Step 6: 
 

• Set the XS Element search Level 
symbology to include all the levels 
that need to be shown for the XS. 

 
 

 
 
  



Geopak Users Manual   1/29/2013 

 
 

75 

 

 
 

 
 
Step 7: 
 

• Check the settings shown left and make 
sure they are set accordingly. 

 
 

 

 
 
Step 8: 
 

• Check the settings shown left and make 
sure they are set accordingly. 

 

 
 

 
 
Step 9: 
 

• Check the settings shown left and make 
sure they are set accordingly. 
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Step 10: 
 

• Check the settings shown left and 
make sure they are set accordingly. 

 

 
 

 
 
Step 11: 
 

• Check the settings shown left and 
make sure they are set accordingly.. 

 

 

 
 

 
 
Step 12: 
 

• Check the settings shown left and 
make sure they are set accordingly. 
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Step 13: 
 

• Check the settings shown left and 
make sure they are set accordingly. 

 

 
 

 
 
Step 14: 
 

• Check the settings shown left and 
make sure they are set accordingly. 

 

 

 
 
Step 15: 
 

• Check the settings shown left and 
make sure they are set accordingly. 

 
Step 16: 
 

• Select Layout Sheets 
 

Step 17: 
 

• Select File>Sheet Library>Save 
 
  



Geopak Users Manual   1/29/2013 

 
 

78 

11.6.1 Labeling Cross Section Sheet 
 

 

 

Step 1: 
 

From the MDT Pull down  

• Select Road Design 
• Select XS Sheets Tab 
• Select XS Sheets 

 

Step 19: 

• Select Place Project Information 
• Select Project File 
• Enter Design By 
• Enter Reviewed By 
• Enter Checked By 
• Set Prelim Stamp 
• Set XS Description 
• Check Fix XS Reference Logical Prefix 

 

• Select Apply 
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I. Microstation Models 
When you draw or place elements in a DGN file, you are creating a model. A model is a 
container for elements. It can be either 2D or 3D, and is stored as a discrete object within 
the DGN file. It may be helpful to think of a DGN file as a stack of cards, with each card 
being a model.  

When you first create a new DGN file from one of the seed files, this provides the empty 
container setup with a default model ready for you to create your design. If you use a 2D 
seed file, then the default setup is 2D, while a 3D seed file defaults to a 3D setup. In 
either case, you can create both 2D and 3D models in the open DGN file. 

Every model has its own set of eight views. The model whose views are displayed or 
available for display at a given time is the active model. 

Creating Models 
 

 

 

Step 1: 
 
From the Microstation Primary Tool 
 

• Select Models >Create a new Model 
 

 

 
 

Step 2: 
 

• Set Type = Design From Seed 
• Set Seed Modal = English2D/English3D 
 
 

 

Step 3: 
 

• Select the Default model from the seed file 
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• Set Name = Raster,3D etc. 
 

• Select OK 
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II. Viewing 3d Files 
 

When rotating views in 3D, an important point to consider is the axis about 
which you want the view to rotate. By default, the pivot point is the center of the 
view, at the active depth. If the active depth is far behind the elements in the 
view, then you can quickly rotate the geometry out of sight. You can, however, 
move the pivot point to another location prior to rotating the view.  

 
To dynamically rotate a view (Cube option)  

 
Step 1: 
Select the Rotate View control.   

  
     

 

Step 2: 

• Set Method to Dynamic. 
• In the extended settings, click the Cube icon.  
• Select Preserve World Up   

   

    
 
 

 

 

Step 3: 

Set the Z axis rotation point  

Enter a data point (away from the cross-hairs) in the 
view to rotate. 
Two white dots display in the view, a larger dot at the 
center of rotation and a smaller dot at the starting point 
of the rotation. 
As you move the screen pointer from this first data 
point, the view is rotated 

 
 

mk:@MSITStore:C:\Program Files\Bentley\MicroStation\Documentation\MicroStation.chm::/ustnhelp906.html
mk:@MSITStore:C:\Program%20Files\Bentley\MicroStation\Documentation\MicroStation.chm::/ustnhelp906.html#nowhere�
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To return to the default view, rotate the current 
view to the Top view.  

 
• Set the Method to Top 
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III. Geopak Adhocs 
 

Some surveyed features have additional information that is picked up at the time of 
survey. These features will have that information attached to the surveyed element when 
available. 

 

 

Step 1: 
 
To determine the adhoc attributes assigned to any 
MicroStation element 
  
From the Geopak Road Tools Frame  
 

• Select 3PC Adhoc Attribute Manager  
 

 

 

 
 
 
 
Step 2: 
 

• Click Identify at the top of the 
dialog, then select and accept 
any element.  
 

 
Note: 
If attributes are assigned, the list box 
within the dialog is automatically 
populated. 

 
If the selected element has no attributes, a prompt in the MicroStation message field indicates 
"No attributes." 
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IV. Geopak D&C Manager 
 
Design and Computation Manager Tools 
 

This document will show the function of the 1st 5 buttons on the D&C Manager Dialog. 
 

 

Switch to Toolbox Mode -  
D&C Manager is switched from Dialog Mode to Toolbox. Switch back by clicking icon 
on the far right. 
 

 
 

Identify Item -  
Clicking Id icon and then select an element in the design file. If the elements symbology 
is set to a feature defined in the D&C Manager, that feature will be selected in the item’s 
entry in the D&C Manager. For example clicking on a pattern line will show the 
following in the D&C Manager: 
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DisplayMode -  

 
Clicking Display opens another window in the D&C Dialog. This window shows what has been 
selected into a collection. To select items or groups of items, right-click the item and click Add 
to Collection. To remove from the Collection, simply double-click on the item in the Collection 
window. 

Also, another dialog opens showing four buttons  

 

Normal Display - the items of interest change from gray back to their 
original element symbology  

 

Highlight Selection - the desired elements are displayed in the current 
MicroStation highlight color, while any other elements remain unchanged. 

 

Hide Selection - the desired items are blanked from the screen, however all 
other elements are displayed. This is the reverse of the Display Only 
Selection tool. 

 

Display Only Selection - only the items in the collection box appear, while 
the rest are blanked from the screen.  

 While Display is on these buttons work on ANY entry that is highlighted within the D&C 
Manager. 
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Design -  
Clicking Design icon opens the DESIGN Dialog box 
 

 
The title on this box should match the name of the element that is highlighted in 
the D&C manager. 
The Place Influence tool on the Design and Computation Manager determines 
the level, symbology and attribute tags of MicroStation draw and manipulation 
functions. These level symbology and attribute tags are defined in the hierarchical 
database in terms of pay items and/or feature names.  
When the Place Influence tool is inactive, MicroStation commands draw 
elements at the active MicroStation level/symbology. However, when the Place 
Influence toggle is set, any element placement or copy function draws elements 
at the element symbology and attributes associated with the selected item on the 
Design and Computation Manager.  
It is not necessary to reselect the MicroStation command, nor is it necessary to 
toggle the Place Influence on again. Once the Influence is toggled on, it remains 
on until it is toggled off. If a generic MicroStation command without the 
Influence is desired, simply deactivate the toggle.  
If the Adhoc Attributes toggle is on, any adhoc attributes stored with the item are 
applied to the Place Influenced element.  If the Adhoc Attributes toggle is off, 
the element symbology of the Item is utilized, but no adhoc attributes are assigned 
or modified. 
If the New Element Only is toggled off, then the Place Influence is applied to any 
selected element, including those previously placed.  If toggled on, only elements 
being placed utilize the Place Influence. Any other selected element retains its 
original symbology.  

 

Set Mode -  
Clicking the Set icon opens another dialog box.  
 

 
Clicking on the Set button and then selecting an element in the design file will 
change that element’s symbology to the item highlighted in the D&C Manager. 
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V. Geopak Problem Resolution Steps 
 

The following suggestions are steps that may help when encountering a problem in Microstation 
or Geopak.  

 
1. When the initial problem is encountered the following steps should be done in the order 

described. 
a. Double check all dialog box entries to insure they are as expected. 
b. Double check all symbology selected to insure it is exactly what you need for the 

function you are attempting. 
 

2. If an error message is encountered: 
a. If an error is displayed, read it before continuing. If you understand it and can fix the 

problem, then fix the problem and restart the attempted function. 
b. If you do not understand the error or don’t know how to fix it, seek out help from 

your fellow team mates – one of them may have seen and/or resolved that error 
before. 
 

3. Initialize Geopak/Microstation: 
a. Run KILLTASK.BAT enter ‘Y’ and hit Enter when prompted. KILLTASK.bat 

should reside on your desktop. It is located on CADDSTD for copying. 
b. Restart Microstation/Geopak 
c. Reattempt the function that you were having problems with. 

 
4. Recreate .upf file 

a. Exit Microstation 
b. Go to C:\mdoh folder 
c. Highlight file U####V8.upf  (where # is your employee number) and rename it 

to SAVEU####V8.upf. This file contains your preferences for Microstation. 
d. Restart Microstation/Geopak – this will recreate the U####V8.upf file. You will 

notice that toolbars & menus may have changed from your preferred settings. 
e. Reattempt the function that you were having problems with. If this works you should 

delete the saved .upf file. 
 

5. Still no resolution send an email to U2894 that contains the following: 
• Computer Number Eg. MDTHLNRODC164 
• Project Number  
• GPK File 
• Pxsprj.inp (Proposed Cross Section Input File) 
• Proposed DGN file containing Patterns, Shapes and Profiles 
• Cross Section Drawing where sections are processed and you give me a reference to 

the problem cross section, if applicable. 
• Existing topo drawing – TIN file 
A DETAILED description of the problem or situation  
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VI. Fix Corrupt GPK 
 
Dealing with corrupt GPK or basic maintenance - From the Coordinate Geometry dialogue at the 
COGO key-in enter REBUILD DATABASE. 
 

 
Press Enter 
It may take several minutes to process the GPK. 
When complete the rebuilt statistics will be displayed. 
 

 
This should be done occasionally and definitely before zipping for the archive or posting to DMS 
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