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OVERVIEW 
This document provides a user focused overview of the MDT Enhanced MicroStation / Power 
GEOPAK V8i (SELECTseries10) workspace. 

Much of the workspace content referenced in this document is stored in a file called a DGNLIB. 
A DGNLIB is simply a MicroStation DGN file with the extension .DGNLIB, and is used for storing 
and distributing shared resources. DGNLIBs are placed in specific locations throughout the 
workspace folder structure, those folder locations are defined by the workspace configuration 
files and read by MicroStation when it loads.  

 
REFERENCES 
Docuplot User's Manual and Guides 

Plotting Coordinates 

Cross Referencing PCMS Project Directories 

Enhanced Workspace Macro Overview 

 

WORKSPACE CONTENTS  

PROJECT CONFIGURATION 
When starting MicroStation or Power GEOPAK, the user will select a discipline specific Project 
from the drop-down in MicroStation Manager.  

https://www.mdt.mt.gov/other/webdata/external/ESDC/library/MDT-DOCUPLOT_USERS_MANUAL.PDF
https://www.mdt.mt.gov/other/webdata/external/CADDResources/General/PlottingCoords.zip
https://www.mdt.mt.gov/other/webdata/external/ESDC/library/PCMS-Cross-Reference-PCMS-Directories.pdf
https://www.mdt.mt.gov/other/webdata/external/ESDC/library/EnhWSMacroOV.pdf


 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\WORKSPACE\CONFIG  

Consultant Workspace: 

C:\Montana_DOT\Workspace\Projects 

 

 

 

 

 



CELLS 
Cells are commonly used graphics that the user places repeatedly in the DGN. For example, 
graphics such as a legend, power pole, manhole, inlet, tables, north arrow, etc. Cells are stored 
in cell libraries that the user accesses from the Cell Library dialog and selecting File>Attach 
File from the menu bar at the top of the dialog. In the Attach Cell Library dialog, the folder 
listed below will be displayed: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\cell  

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\cell 

The libraries shown will have a prefix in the file name indicating which discipline they are for. 
The table below lists the prefix and the associated discipline. 

Discipline Naming Prefix 

Road RD_ 

Hydraulics HY_ 

Bridge BR_ 

ROW ROW_ 

Signing SI_ 

Survey SU_ 

Utility UT_ 

Electrical EL_ 

Shared MDT_ 

TEXT STYLES 
Text Styles are predefined text format settings such as the Font, Height, Width, Justification, 
Italic, Underline etc. that the user selects when placing Text or a Note. Text Styles are stored in 
a DGNLIB, however all user interaction with Text Styles will occur when selecting the desired 
style from the drop-down menu in Tool Settings, or from the Text Styles dialog.  

Text Styles are used in the following situations: 

• Text styles with an MDT prefix were developed to assist users in the application of 
MDT's standard fonts and text attributes for various features.  

• The Civil and XS text styles are in place for the software to make use of in automated 
processes 



Standard text style text sizes are detailed as follows. There may be exceptions where alternate 
text sizes must be applied. 

 Text Size 
File Type  Title/Plan Detail/Design X-Sect. Typ. 

11x17 Plot Scale  1”= 200’ 1”=100’ 1”=50’ 1”= 20’ 1”= 10’ 

Title 
(DETAIL) 

48 
(*.04) 

24 
(*) 

12 
(*) 

4.8 
(*) 

2.4 
(*) 

Title-Sub 
(INTERSECTION) 

24 
(*0.02) 

12 
(*) 

6 
(*) 

2.4 
(*) 

1.2 
(*) 

Heading (Description) 18 
(*0.015) 

9 
(*) 

4.5 
(*) 

1.8 
(*) 

0.9 
(*) 

Heading-Sub (NOTES:) 14 
(*1.16) 

7 
(*) 

3.5 
(*) 

1.4 
(*) 

0.7 
(*) 

Regular (10+00.00) 12 
(*.01) 

6 
(*) 

3 
(*) 

1.2 
(*) 

.6 
(*) 

Regular-Sub (SLOPE = -2%) 10  
(*.0083) 

5 
(*) 

2.5 
(*) 

1.0 
(*) 

0.5 
(*) 

 

*Text sizes noted in parentheses are equivalent text sizes with application of annotation scale. 
The 1”=200’ annotation scale size is used with all plan scales where the proper size will be 
observed with adjustment of the drawing scale when working in another sheet size such as 
Detail, Cross Section and Typical sheets as well as design map files. 

The Text Styles DGNLIBs are located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\dgnlib 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\dgnlib\Annotations 

  



DIMENSION STYLES 
Dimension Styles are predefined dimension format settings that the user selects when placing a 
dimension in the DGN. Dimension Styles are stored in a DGNLIB; however, all user interaction 
with Dimension Styles will be from selecting the desired style from the drop-down menu in Tool 
Settings and the Dimension Styles dialog.  

Dimension Styles are used in the following situations: 

• Road-E – The Road-E dimension style is primarily used for the typical sections but may 
be used for other purposes. 

• Civil – Dimension styles in place for the software to make use of in automated 
processes. 

The Dimension Styles DGNLIBs are located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\dgnlib 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\dgnlib\Annotations 

FONTS 
From the user’s perspective, all interaction with Fonts should be seamless. Fonts are assigned 
to Text Styles, and a user will select a Text Style prior to placing text in the DGN. The MDT 
Standard fonts Engineering Bold, Engineering Heavy, and Engineering Regular are true type 
fonts that have been adopted as MDT’s standard plans production fonts, and have been 
incorporated into all Text Styles, Dimension Styles, and Cell libraries.  

Fonts are located in the following folders: 

MDT Workspace: 

…\CaddStandards\Bentley\OpenRoads\OPENROADS\Resources  

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\fonts 

LEVELS 
Levels are used to organize elements placed in the DGN and can be used to determine the 
Attributes (Color, Weight, Line Style) of that element. In the MDT seed files, the Attributes are 
set to use “ByLevel”. When a user sets a Level as Active from the Attributes Toolbar, Level 
Manager, or Level Display, the symbology assigned to that level will become the active 
symbology, and any element placed will be assigned the “ByLevel” symbology settings. All 
levels are stored in a DGNLIB and will be loaded when MicroStation is launched with MDT’s 
workpace. All interaction with Levels will be from the Attributes Toolbar, Level Manager and 
Level Display dialogs.  



Note: The user only needs to assign an active level when placing MicroStation graphics and 
text. When using most of the OpenRoads tools, and selecting a Feature Definition, the level is 
assigned by the Element Template automatically with no additional interaction needed from the 
user. 

MDT’s standard level naming prefixes are listed below: 

• E_ (existing) 
• P_ (proposed) 
• S_ (sheet/standard) 
• C_ (construction) 
• DL_ (drafting) 
• ES_ (existing terrain) 
• PM_ (pavement marking) 
• PS_ (proposed surface) 
• TC_ (template component) 
• TL_ (template linear) 
• TM_ (template mesh) 
• XS_ (cross section) 

 
Levels in the MDT workspace are assigned properties in the DGNLIB where they reside. Level 
properties can be used to control settings such as Global Display, Freeze, Priority, ByLevel 
Symbology, etc. The image below shows the Level Properties dialog: 
 



 
 

• Priority* - Controls which levels are displayed in the front and which levels are displayed 
in the back within a dgn. 

• Transparency* - Controls if a level is transparent in the DGN. MDT’s plotting solution 
does not fully support transparency.  

• Global Display - If checked on, all elements placed on the level are displayed. 
• Global Freeze - If checked on, any elements on that level are not displayed and can’t be 

printed. 
• Plot* - If checked off, elements on that level won’t be printed even if displayed in the 

DGN. 
• Lock* - If checked on, elements on that level can’t be manipulated or modified. 
• Symbology: ByLevel - Where the default symbology for levels is set. When an element 

is placed using ByLevel symbology, it will be assigned the symbology set in this section. 
Changes to the symbology settings will automatically update all elements placed on that 
level when ByLevel symbology is used. 

• Symbology: Overrides - Where users can override the default symbology settings for 
each level. This is a view-dependent setting, and Level Overrides needs to be toggled 
on in the View Attributes dialog. 



 
 

*Note: Configuration variables are set that will prevent the user from changing the default 
settings for Priority, Transparency, Plot, and Lock from the Level Properties dialog accessed 
from Level Manager. However, a user can place an element and change those attributes at 
the element level.  

 

DGNLIBs that contain levels are located in the following folders: 

MDT Workspace: 

…\CaddStandards\Bentley\OpenRoads\OPENROADS\dgnlib 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\dgnlib 

CUSTOM LINE STYLES 
Custom Line Styles supplement the standard 0-7 dash dot Line Styles that are available in 
MicroStation. They are used to display features graphically such as Utilities, Pavement 



Markings, etc. that require exact distances with a dash/gap or a line with a combination of text 
and linework.   

MDT’s standard custom line style naming prefixes are listed below: 

• E_ (existing) 
• P_ (proposed) 
• PM_ (pavement marking) 
• PH_ (photogrammetry) 
• XS_ (cross section) 

 

Custom Line Styles are stored in RSC files located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\dgnlib\Linestyles\Resources  

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\symb\LineRSC 
 

Line Styles are sourced from the DGNLIB to be included into the workspace and are located in 
the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\dgnlib 

...\OPENROADS\dgnlib\Linestyles  

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\dgnlib 

C:\Montana_DOT\Workspace\Standards\dgnlib\Linestyles 
 

From the user’s perspective, Custom Line Styles are loaded when MicroStation is launched and 
are assigned to levels. Interaction with Custom Line Styles will occur when setting a level as 
active from Level Manager or Level Display to set the active Attributes with the desired 
Custom Line Style.  

  



SEED FILES 
Seed files are DGN files in the workspace that have preconfigured settings applied and are 
copied by the software when a new file is created. When a user creates a new DGN, the New 
File dialog will display. To select the Seed File, the user will click the Browse button to load the 
Select Seed File dialog and choose the appropriate Seed File.  

 



 

Note: The only time a user will use the MDT-Seed3D-Imperial.dgn is to create a new ETR 
(Existing Terrain Model) and PTR (Design Terrain Model). In all other instances, the MDT-
Seed2D-Imperial.dgn is used. 

RD, HY, and SA sheets can be created by using the Create DGN’s macro accessed from Road 
Tools > File Utilities > Create DGN’s 

.  

EL, GE and SI sheets can be created by using the Traffic Macros dialog accessed from Traffic 
> Traffic Macros. 

 

  



The following seed file parameters are recognized by the Enhanced workspace and Docuplot. 

• Design File Settings > Working Units. The working unit resolution must be set to 10000 
per Distance Foot. 
 

 
 

• OpenRoads_Readme model. All files used in the Enhanced workspace must include an 
OpenRoads_Readme model. 
 

 
 

Files having the resolution set to 1000 per Distance Foot and without the OpenRoads_Readme 
model are considered legacy workspace files and must not be used together with 10000 
resolution files on the same project. 

  



Seed Files are located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\Seed  

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\seed  

 
MDT Bridge seed files are located in the following folders:  

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\WORKGROUP\BRSTD\BR_DWG_SEED 

Consultant Workspace: 

C:\Montana_DOT\Workgroup\BRSTD\BR_DWG_SEED  

 
MDT ROW sheet seed files are located in the following folders:  

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\Seed\RW_Plans 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\seed\RW_Plans 

 
MDT UT sheet seed files are located in the following folders:  

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\Seed\UT_Plans 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\seed\UT_Plans 

PRINTING 
MDT uses an internally developed plotting solution called Docuplot when plotting plans for 
production use. Docuplot User’s Manual and Guides are available for review separately. 

The following provides basic information regarding some of Docuplot’s plotting functionality.  

There are occasions where alternate plotting methods are necessary. Users can print DGN’s by 
going to File>Print or by selecting Ctrl>P on the keyboard and loading the Print dialog. The 
user will select a PLT printer driver configuration file by selecting the magnifying glass icon 
indicated by the red arrow in the image.  



 

This will load the Select Printer Driver Configuration File Dialog, and the user will select a 
PLT file from the listing. There are a variety of plot drivers available. Selecting a plot driver will 
be dependent on the type of sheet being plotted and the desired results. The plot drivers are 
listed below for full/half size, monochrome/greyscale/color, and english/metric unit plotting. 
 

  



Greyscale Plotting 
All greyscale plot drivers are set up to plot elements using colors 32-47 (3rd color row) and 252-
254 with varying grey tone colors and white as follows: 
 
 32-47 – RGB 202, 202, 202 
 252 – RGB 200, 200, 200 
 253 – RGB 220, 220, 220 
 254 – RGB 255, 255, 255 

 
Full Size Paper Plotting 
Full size paper plot drivers are HP-GL/2 drivers. These drivers create plot files that can be 
copied to a printer using the command prompt. Full size paper plans production plot drivers are 
listed below: 

• ENGLISHFUL.plt 
• ENGLISHFULGS.plt 
• METRICFUL.plt 
• METRICFULGS.plt 

 

Half Size Paper Plotting 
Half size paper plot drivers are postscript drivers. These drivers create plot files that can be 
copied to a printer using the command prompt. Prolog files are used when creating the 
encapsulated postscript files. Half size paper plans production plot drivers and prolog files are 
listed below: 

• ENGLISHHLF.plt 
• ENGLISHHLFCLR.plt 
• ENGLISHHLFGS.plt 
• METRICHLF.plt 
• METRICHLFCLR.plt 
• METRICHLFGS.plt 
• 11X17PSCRIPTPLANS.PRO 

 

8.5x11 Paper Plotting 
Letter size paper plot drivers are windows drivers sending plots directly to a printer. Using 
windows plot drivers can’t guarantee a precise scale from printer to printer.  

• 8x11printgs.plt 
• 8x11print.plt 

 

PDF Plotting 
Half size pdf plot drivers are XML drivers creating a pdf file offering searchable text and 
measuring capabilities. Half size pdf plans production plot drivers are listed below: 

• EnglishHlfClrPdf.plt 
• EnglishHlfGsPdf.plt 
• EnglishHlfPdf.plt 
• MetricHlfClrPdf.plt 



• MetricHlfGsPdf.plt 
• MetricHlfPdf.plt 

 
8.5x11 PDF Plotting 

• TrafSignCalcsGsPdf.plt 
• TrafSignCalcsPdf.plt 

 
Sheet Fencing Coordinates 
Fencing coordinates are used to achieve proper position on the sheet when plotting depending 
on the type of sheet and size of sheet being plotted.  

Plotting Coordinates for use when plotting sheets without Docuplot are available separately. 

The printer PLT files are located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\WORKSPACE\PLOTTING  

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\plt 

PEN TABLES 
Pen Tables are used to re-symbolize elements when printed, such as gray scaling, and 
adjusting line weights. Interaction with Pen Tables, from the user’s perspective, will be minimal 
as they are loaded when a PLT file is loaded into the Print dialog.  

Note: Pen tables used for color plotting are configured to plot text and dimensions black 
regardless of file attribute settings. 

The Pen Tables are located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\WORKSPACE\PLOTTING 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\tables\pen 

  



SHEET SCALES 
Sheet seed files have a border set up at 3200’ x 2100’. When design files are referenced into a 
sheet border at 1:1, as in the case of a typical rural project, plotting a full size 34”x22” sheet at 
100 scale would result in a 1”=100’ scale plot. Sheets are plotted, as a standard, at “half size” to 
an 11”x17” sheet at 200 scale resulting in a 1”=200’ scale plot. See the figure below 
demonstrating the variety of supported scale scenarios. 

Scale Sheet Size Resulting 
Plot Scale 

Station Range Mapping Reference Scale 

100 34x22 100’=1” 3000’ 1:1 
 11x17 200’=1” 3000’ 1:1 
50 34x22 50’=1” 1500’ 2:1 
 11x17 100’=1” 1500’ 2:1 
20 34x22 20’=1” 600’ 5:1 
 11x17 40’=1” 600’ 5:1 
10 34x22 10’=1” 300’ 10:1 
 11x17 20’=1” 300’ 10:1 

Note: 25 scale not supported 

Some sheet files, such as detail and typical sheets, have smaller borders for preparing sheet 
annotations at scale. These smaller borders are referenced into the larger 3200’ x 2100’ border 
for plotting purposes. 

REFERENCE FILES 
A Reference file is an existing DGN that is attached to and displayed within another DGN. When 
a change is made in a referenced DGN, the changes will appear in the DGN it’s referenced to. 
This allows users to display content in DGN’s from other disciplines inside their current working 
file and share content with other users.  

A user will attach a reference by clicking the References icon on the Primary Tools tool bar 
and selecting Tools>Attach from the drop-down menu in the References dialog. Once the file 
is selected, the Reference Attachment Settings dialog will appear. Reference file attachment 
settings may be adjusted. Live Nesting isn’t supported by MDT’s Project Content Management 
System (PCMS) or plotting solution (Docuplot). 

A file name logical prefix will need to be added after the reference file is attached. This also 
applies to raster file attachments. 

  



The file name logical prefix is used by MDT’s Project Content Management System (PCMS) and 
plotting solution (Docuplot) to locate the attached reference files on the project file server. They 
also allow the workspace to consistently locate the reference files.  

Example: MTRD:9999001RDMAP001.DGN 

Project files that reference files from another project must have the project control number 
added to the file name logical prefix. Cross Referencing PCMS Project Directories is also 
available as additional guidance. 
Example: MTRD9999001:9999001RDMAP001.DGN 

Project files that reference files from the CADD Standards workspace must have a unique file 
name logical prefix added. 

Example: MTSTD:RDSHEET.REF 

 
Reference File Attachment File Name Logical Prefixes: 

PCMS Project Directory 

Directories Description Logical Prefix 

AB As-Builts MTAB: 
BR Bridge – Plans & Comps MTBR: 
CO Construction – Plans MTCO: 
CP Contract Plans MTCP: 
DI District – Working Plans, Survey Files MTDI: 
EL Traffic Electrical MTEL: 
EN Environmental – Plans and Documents MTEN: 
GE Traffic Geometrics MTGE: 
HY Hydraulics – Plans & Comps MTHY: 
IN Traffic Investigations MTIN: 
MA Materials Pavement etc. MTMA: 
MT Materials Geology MTMT: 
PH Photogrammetry MTPH: 
RD Road Design – Plans and Documents MTRD: 
RO Right of Way – Plans, Exhibits & Documents MTRO: 
SA Traffic Safety – Plans & Documents MTSA: 
SI Traffic Signing – Plans & Documents MTSI: 
SU Survey – Plans and Documents MTSU: 
UT Utility – Plans & Documents MTUT: 
VI Visualization – Plans MTVI: 

Reference File Attachment File Name Logical Prefixes for CADD Standards files: 



CADD Standards …Workgroup Directory 

Directories (including 
STDREF\legacy) Description Logical Prefix 

BRSTD Bridge Standards MTBRSTD: 
ELSTD Electrical Standards MTELSTD: 
HYSTD Hydraulic Standards MTHYSTD: 
RDSTD Road Design Standards (legacy only) MTRDSTD: 
ROSTD Right of Way Standards (legacy only) MTROSTD: 
SISTD Traffic Signing Standards (legacy only) MTSISTD: 
STDREF 
(including MT_Raster) 

Other Standards 
MTSTD: 

 

Note: The REF Check macro is available to assist with adding the file name logical prefixes to 
reference files. 

When MicroStation searches for reference file attachments, it will first search for files within the 
c:\dgn\ (or consultant workspace C:\Montana_DOT\DGN). If the file is not found, MicroStation 
will next search the c:\dgn\ref\ folder (or consultant workspace C:\Montana_DOT\DGN\Ref). 
Finally, it will search the workspace for standard reference files. If the file is not found, the ref 
attachment will be unavailable during the MicroStation session. 

The configuration files where the logical prefixes and paths are defined are in the following 
folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\WORKSPACE\CONFIG\ MDT_OPENROADS.ucf 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards\70_MDT_Workgroup_Settings.cfg 

ANNOTATION AND DRAWING SCALE 
Drawing Scale is used together with Annotation Scale Lock to set the size of Text, Dimensions, 
and Line Styles placed in the DGN. The size the user sets will typically match the size of the 
sheet border to be plotted. The MDT standard project sheet border is prepared at full size (3200’ 
x 2100’). The 1”=100’ drawing scale will maintain text, dimensions, and line styles at the proper 
size where annotation scale is applied.  

Drawing Scale is accessed by going to Settings on the drop-drown menu and selecting 
Drawing Scale. This will open the Drawing Scale dialog. From here the user will set the scale, 
and toggle on the Annotation Scale lock as shown in the image below: 



 

When Annotation Scale lock is on, all Text and Dimensions will be placed at the appropriate 
size for the scale selected. Line Styles will also be scaled accordingly. Using the Annotation 
Scale lock for elements placed in the project sheet files is not supported. 

When creating sheets for production, and referencing DGN’s, the reference scale is set to the 
applicable scale. The Attachment Settings dialog Global Line Style Scale is recommended to 
be set to Master and Use Active Annotation Scale to be on. The Drawing Scale in the 
“Master” file, or the file the user is referencing DGN’s into, will be honored to achieve the 
desired scale. The Scale Line Styles By Reference Scale will need to be adjusted depending 
on the reference scale. The Annotation Scale Lock may be toggled On or Off but will influence 
contour elevation text display size. 



  

FEATURE DEFINITIONS 
Feature Definitions are how the OpenRoads technology determines the display of features that 
represent real world objects such as centerline of road, edge of pavement, back of curb, 
sidewalk, etc. by setting the engineering properties and symbology of that feature. The user will 
assign a Feature Definition every time the OpenRoads geometry tools are used. A listing of 
Linear Feature Definitions can be seen either from the Feature Definition Toggle Bar or Tool 
Settings as shown in the images below: 

 



 

From the user’s perspective, the only interaction with Feature Definitions will be either selecting 
one from the listings shown above or changing the Feature Definition of a civil object.  

The feature definitions are sorted into folders but also named with a prefix that identifies their 
application as follows:  

• EFS – Existing Spot Feature 
• EFL – Existing Linear Feature 
• RW – Right-of-Way 
• WL – Wetlands 
• HA – Horizontal Alignments 
• DL – User Defined Feature Design Line 
• TC – Modeling Template Component 
• TL – Modeling Template Linear Feature 
• TD – Modeling Terrain Display 

The MDT Feature Definitions will load when the MDT Enhanced workspace is launched, and 
are stored in DGNLIB’s located in the following folders: 

 
MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\dgnlib 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\dgnlib 

 

CIVIL CELLS 



Civil Cells are self-contained OpenRoads objects that are used for repeatable design solutions 
and can be adjusted to fit varying situations. The MDT Enhanced workspace provides Civil Cells 
for standard approaches. User interaction with Civil Cells will occur when a user selects the 
Place Civil Cell tool from the Civil Cells tab on Tasks. Tool Settings will change to show a 
field with ellipses on the right side that the user will click to load the Pick Civil Cell dialog.  

 

The Pick Civil Cell dialog will display the contents of the MDT_STD_Approach V2.dgnlib as 
shown in the image below. 

 

The user will select a Civil Cell and place it in the DGN.  

The Civil Cell DGNLIB is located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\dgnlib\Civil_Cells 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\dgnlib\Civil_Cells 

  



DESIGN STANDARDS 
The user applies Design Standards to OpenRoads geometry. Design Standards are stored in a 
DGNLIB that is loaded when the MDT Enhanced workspace is launched, and from the user’s 
perspective, interaction with the Design Standards will be seamless. The available standards 
will be displayed when the user clicks on the drop-down arrow on the Design Standards 
toolbar as shown in the image below: 

 

The Design Standards DGNLIB is located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\Design_Standards 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\dgnlib\Other 

  



CIVIL REPORTS  
Under the Analysis & Reporting tab on the Task bar, the user can pull various reports on 
OpenRoads objects. When a report is pulled, the Civil Reports Browser dialog will load. The 
pane on the left will display all the available reports in the MDT Enhanced workspace. The 
user’s interaction with reports will be done through this interface as shown in the image below: 

 

Report content and formatting is driven by Style Sheets that are stored in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\en  

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\data\reports\en 

  



SUPERELEVATION 
Superelevation is applied by the user to an Alignment, and OpenRoads will calculate the 
superelevation transitions based on settings files that are available in the workspace that the 
user selects. When the user selects the Calculate Superelevation command from the Task 
bar, and selects the Superelevation Section, Tool Settings will change to display the options 
available. At the top where it says Standards File Name, the user can click on the ellipses at 
the right. 

 

This will open the Select File dialog where the user will select the .SEP file. 

 

  



Once the .SEP file is loaded the user can continue with calculating the superelevation. The 
.SEP files are located in the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\OPENROADS\Super 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\data\super 

TEMPLATES 
Templates are a “typical section” that is extruded along the horizontal and vertical alignment to 
create a corridor model. Templates are stored in a Template Library(.ITL). The MDT Enhanced 
workspace is delivered with the Template Library mdt_civil_templates_imperial_2018.itl that 
is located in the following folders: 

MDT Workspace: 

…\CaddStandards\Bentley\OpenRoads\OPENROADS\data\template_library 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\data\template_library 

The user will load the MDT standard itl by selecting the Create Template icon on the Corridor 
Modeling tab on the Tasks bar and selecting File>Open from the Create Template dialog.  

Note: The Create Project Settings Files (a\k\a Create GPK Project) macro can be used to 
create a unique project template file. If an itl file is saved to the c:\dgn (or consultant workspace 
C:\Montana_DOT\DGN) matching the project number of the open file, it will be automatically 
loaded in place of the default workspace itl. The first itl file found will be loaded where more than 
one exists in the working directory. 

MACROS 
From the user’s perspective, all interaction with macros and macro help documents occurs 
through the MDT APPS, Road Tools, Traffic and Survey pulldown menus within 
MicroStation/Power Geopak. Enhanced Workspace Macro Overview is available separately. 

Macro vba files are loaded from the following folders: 

MDT Workspace: 

...\CaddStandards\Bentley\OpenRoads\WORKSPACE\PROGRAMS\VBA\OPENROADS 

Consultant Workspace: 

C:\Montana_DOT\Workspace\Standards-OpenRoads\vba 
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