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1-1 Introduction 

1 Introduction 

GEOPAK is a comprehensive software package for the design and production of plans for 

roadway and site projects. The software is fully integrated with the MicroStation CAD system to 

permit true interactive design. 

For everyday design work map your W drive to the appropriate drive for all CADD 

support. 

You then need to log off and back on to re-access the drive. If your W: drive is not properly 

mapped the following text window may appear when attempting to initiate MicroStation: 

NOTE: Pictures depicted in this manual are from various samples and/or lab projects. 

Please double check all of your own dialogs to insure they represent what you want in your 

own project in order to have an accurate and trouble-free design. 

Maintenance suggestion: Once you have all of the preferences set up as you like then go to 

C:\mdoh and make a copy of your .UPF file. Just copy it into your U: drive or make a copy 

and rename it right in C:\mdoh. This way you will not lose your preferences should you 

need to delete the .UPF file.  (see below) 

file://mdtcaddstdsrv/caddstd
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2 File Management 
 

These are the Files that will need to be saved on DMS. 
The criteria used to determine if the file should be saved was, is it necessary to run the Geopak 

program and how easily the information can be recreated.  All the other files can easily be 

recreated either by Geopak or simple editing can be found in the w:\rdstd directory.  Because of 

the nature of computers in general, files will become corrupt from time to time.  To save work on 

recreating a corrupted file some but not all of the following files will need to be saved.  The 

following files are the only files you will need to save out on DMS.  When you are done using 

the files, delete any files not on this list.  

 

###zzDTM001.DAT This is an ASCII file that contains your survey data.  You will need to 

keep this file in case you need to recreate Cross-sections. 

JOB###.GPK  This is a binary file that contains all the information on your horizontal 

and vertical alignments.  The number used when creating this file in 

Coordinate Geometry should be related to the control number. (i.e.  CN 

1426,  JOB# 142 OR 426)  It is necessary to keep this file because Geopak 

uses it when you run its programs. 

NAME###.IOC You may create this file if you code your alignment into Coordinate 

Geometry.  This file can be used to recreate your .gpk file.  You will want 

to save this just in case your .gpk file becomes corrupted. (OC stands for 

operator code) Not everyone will create this file and you will not have to 

create it just to save it. 

J###OOC.INP  This file may be created if you store an alignment graphically or when you 

store your profile.  You will want to keep it for the same reason you save 

the NAME###.IOC file. (OC stands for operator code) 

###zzMAP001.DGN   This is the design file that contains your Horizontal and Vertical 

alignments.  You will want to save this file as you have previously. 

###zzXSF001.DGN This is the design file that contains your Working Cross-sections.  These 

should contain all the information you wish to have plotted.  You will 

want to make sure you save this file (or files if you have more than one). 

###zzEWK001.LOG This is the log file that is created when you do an earthwork run.  This file 

is used to create your mass diagram.  You will not want to save all of your 

EARTH.LOG files.  Keep only the original unmodified log file and the 

final log file you will use to create your mass diagram with.  Delete any 

other log files you have created. 

###zzEWK001.TXT This file is created when you do your earthwork run.  You will need to 

save this file to put your unadjusted volumes in your Cross-section Layout 

file.  When you put your Cross-sections into a file to be plotted this file 

needs to be present to put your unadjusted volumes on the Cross-sections. 

Note:  

 ####  = this is the project number see the Cadd Standards for file naming. 

 zz = this is the design area see Cadd Standards for file naming. 
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3 Geopak Road Tools Dialog 
 

Applications will automatically appear in the menu bar. 

 

Geopak may need to be activated if only one menu appears. 

 

After GEOPAK is activated, under Applications more menus and the Deactivate GEOPAK will be 

available.   

 

There are two options when using GEOPAK ROAD.  You can use the pull-down menu similar to the 

other menus or you can open a palette for most of the GEOPAK functions.   

 

 

To pull up the palette for GEOPAK go to APPLICATIONS-GEOPAK ROAD-GEOPAK 

ROAD Tools 

 
 

 

 

Project Manager Horizontal & Vertical Geometry 

Design & Computation Manager Plans Preparation 

DTM 3D Tools 

Cross Sections Utilities & Conversions 
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3.1 Project Manager 

 
The Project Manager toolbox is depicted above and has four icons.  The left tool invokes the Project 

Manager dialog as depicted below. (See Page 4.1) The second icon opens the Active Chain Control 

tool box.  The third tool is GPK Attribute tool and is utilized to identify the GEOPAK attributes 

assigned to an element, if any.  The fourth is 3PC AdHoc Manager. 

 

3.2 Design & Computation Manager 

 
 

3.3 DTM 

 
 

3.4 Cross Sections 
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3.5 Horizontal & Vertical Geometry 

 
  

3.6 Plans Preparation 

 
 

3.7 3D Tools 
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3.8 Utilities & Conversions 
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3.9 Geopak DTM Tools 

DTM Menu 

 

Stroking Options 

Extract Build 

Edit Drape 

Load Reports 

Analyze Utilities 

  

3.9.1  DTM Menu 

 
The DTM Menu tool box (first column, top box) is depicted above and is a single icon, which 

invokes the GEOPAK DTM menu bar as depicted below. 

 
 

3.9.2  Extract tool box 

 
  

3.9.3 Edit tool box 

 
 

3.9.4  Load tool box 
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3.9.5  Analyze tool box 

 
 

3.9.6  Stroking Options tool box 

 

 
 

 

3.9.7  Build tool box 

 
 

3.9.8  Drape tool box 

 
 



Geopak Users Manual  2/19/2015 

Road Tools Dialog 
 3-7 

3.9.9  Reports tool box 

 
 

3.9.10 Utilities tool box 
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4 Project Manager 
 

The Project Manager associates projects with their prospective job number, user, working 

directory, coordinate geometry, and the myriad of project files. This organization of the project 

keeps the user from having to maintain the different files and their locations associated with a 

particular project. In addition, many of the GEOPAK functions can be invoked by simply 

selecting the appropriate box from the dialog, which is set up in a workflow format. The dialog is 

depicted below. 

 

The Working Directory, User: & Job#: are set when you create a project, from the Project 

Manager Dialogs.  

 

 
The LARGE BLACK numbers on the dialog above correspond to the chapter covering that 

function. The small RED numbers correspond to the file created when that function’s 

dialog is saved in C:\DGN\geopm\projdbs\user\ folder. 

 

Setting up a project is shown in the following pages. 

 

When Selecting Buttons from the Project Manager you will be asked to Create or Rename the 

run information. See Section 6 
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4.1 Setting up a project for Project Manager 
Start Microstation and Geopak. 

Then Start the Project manager 

 
 

 
 

 
1. Fill-in Project Name (whatever you want) 

2. Working Directory (always C:\dgn) 

3. Job Number  (creates JOBnnn.GPK) 

4. Optional – Project Description 

5. Select Preferences 

6. Set Preferences for Project  

 Always set up as shown below 

 Geopak handles up to 12 decimal places 

 The Distance needs to be 4 decimals for 

doing the inverse process. 
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4.2 Setting up a User for the Project Manager 
Select Users > New 

 

 
 

1. Fill-in Name 

2. Full Name 

3. Operator Code – Always use OC (See file 

naming in Cadd Standards Manual) 

4. DO NOT Password Protect the User 

 

4.3 Setting up Feature Preference 

 
1) Set the SMD File , Directory is w:\Geopak\ US Customary = SURVEYENG.SMD  

2) Select OK to return to Geopak Preference then Select COGO Preference 

 

 

Directory Structure for User 

C:\dgn\GEOPM – contains .prj file for each project 

PROJDBS – contains .rpt file for each project 

DEFAULT – contains default entries for the RUN’s in a default project 

USER (your name) – contains entries for the RUN’s within your projects 
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4.4 Setting up COGO Preference 
For More information on COGO Preference see Geopak Help Online – Command Reference > User 

Preference Optional direct link to Help press F1 when dialog is active 

 

 
Job Open Mode - This is normally set to Query.  It can also be set to Create or No Create. 

When set to Query it will let you know if it is not finding the .gpk file when you open Coordinate 

Geometry.  

 

When it does not find a .gpk file with the correct control number it will tell you “Job number XXX 

does not exist. Do you wish to create job number XXX?” 

 

At this point you can create a new .gpk file if you wish by clicking on OK or cancel if you need to find 

out why it’s not finding the correct .gpk file. 

 

When set to Create it will automatically generate a new .gpk file if none is found in the working 

directory.  It will not give you any message that it is creating a new .gpk file. 

 

When set to No Create it will not allow a new .gpk file to be generated if no .gpk file is found. 

 

Select Redefinition of Elements 
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5 Setting Up Working Alignment 
 

The working Alignment is a place to keep track of or store all the information about your project, such 

as strip map file, working cross section file and symbology of the elements. You are able to create 

several working alignments for different alignments, such as mainline or detours. 

 

 
 

 
 

 

 

   To set up a Working alignment  

1) Select the Select Button 

2) At the Select Working Alignment Dialog 

Select Run > Modify 

 

3) Type in a name for your working alignment 

4) Type in a description 

5) Select OK 

6) At the Select Working Alignment Dialog 

select Ok 

The working alignment name should now appear 

in the Project Manager 
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5.1 Entering Working Alignment Define Information 
Select the DEFINE button from the Road Project Dialog and fill in the information as shown below. 

5.1.1 Plan View   

 
 

1) Set Design file to the file that 

contains the alignment. Most likely 

this will be your strip map. 

2) Set Chain to the alignment that 

will be used throughout the design 

process. You can delete C:\dgn\ 

from the Design File names to 

minimize name lengths. 

 

Note: This should be done after a 

design alignment has been created. 

This information is used in most of the 

dialogs 

5.1.2 Plan View > Pattern 
 

 

1) Set Button to By Design File 

2) Set Hor. Scale to 10 &Ver. Scale 

to 10. 

3) Set Design File to the file that 

contains the pattern lines. 

4) Set Symbology to  

Lv= P_Geopak_PatternLines_Design, 

Wt=0 & Style=0. Color and Type 

can be left blank. (See Cadd 

Standards Manual) 

5) Or you can use the 

RESET/MATCH buttons to set 

symbology. 

6) Setting the symbology in the 

placement is for drawing. 

5.1.3 Plan View > Shapes  

 

1) Set button to All In DGN 

2) Set Design File to the file that 

contains the super elevation shapes 

OR 

1) Set button to By Search Criteria 

2) Set Design File to the file that 

contains the super elevation shapes 

3) Select Lv Names then 

Reset/Match. Select a shape 

element. This should be: 

P_Geopak_SuperShapes_Design 

 

Note: This should be done after super 

shapes are drawn. 
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5.2 Profile View  

 

1) Set the Design File to the file that 

the profile is drawn in. 

 

2) Set Existing profile to the ground 

profile 

 

3) Set Proposed Profile to the design 

profile 

 

Note: This should be done after 

Existing ground profile is created and 

after a Design profile is created. 

 

5.2.1 Profile View > Location 

 

1) Set the DP Station to the beginning 

station of the alignment.  

Hint: Try to set it to an even station 

before your alignment. 

 

2) Set DP Elevation to an even 

elevation below the lowest point of 

the profiles 

 

3) Set DP X & Y: By DP. Click 

Identify Cell and select the cell 

containing the profiles. 

 

4) Set the scales to a 10:1 

exaggeration 

5.3 Cross Section View 

 

1) Set the XS DGN File to the 

working cross section file (the file 

the cross sections are drawn in) 

 

Note: This should be filled in after the 

working cross section file has been 

created. 
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5.3.1 Cross Section View > Existing Ground 

 
  

1) Set LV= 

E_Ground_XS_Delineation 

 

Note: This should be filled in after the 

working cross section file has been 

created or it can be filled in at the 

beginning of the project. 

 

Setting the Placement symbology is 

for drawing. 

5.3.2 Cross Section View > Proposed Finish Grade 

 
  

1) Set LV=  

P_Template_Design_Alignment_F

inishedGrade & 

P_Template_Design_Alignment_S

ubGrade 

 

Note: This should be filled in after the 

proposed surface is in the working 

cross section file or it can be filled in 

at the beginning of the project. 

 

5.4 DTM 

 

1) If you have a TIN file you may set 

the Existing ground & Port view 

TIN to that file 

 

2) Set the Scales to 1 & 1 or 10 & 10, 

either works. 

 

 

Note: This should be filled in after the 

DTM file has been created or it can be 

filled in at the beginning of the project. 

 

NOTE: Setting up the symbology in the Pattern & Existing Ground dialog entries will save 

those settings and default to that symbology every place they are drawn in the project. 
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6 Create or Rename a Run 
When Selecting Buttons from the Project Manager you will be asked to Create or rename the Run 

information. 

 
 

6.1 Creating a run 
1) Select Run > New 

 

 
 

2) Fill-in Run Name 

3) Description is optional 

4) Select Ok 

5) Select Ok From the Previous Dialog 

 

6.2 Renaming a Run 
1) Select Run > Modify 

information describing the run 
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2) Fill-in Run Name 

3) Description is optional 

4) Select Ok 

5) Select Ok From the Previous Dialog 

 

6.3 Copying a Run from one project to another 
 

Whenever you invoke a Button from the Project 

Manager Diagram you will be asked to Select a 

Run. You have the option of creating a new run or 

copying a run from a previous project. Shown here 

is an example of how to copy a run from the 

default project. 

 

1) Select Run > Copy > Project 

2) Select Default Project 

3) Select Default user 

4) Select the Run 

5) Rename the run for your project 
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7 Coordinate Geometry & Horizontal Alignment 
 

There are three ways to put an alignment into Geopak 

1) Use the information from survey or as-built and code the information into Coordinate Geometry 

(described below.) 

2) Store an existing alignment from the design file. (Section 33). 

3) Draw the Alignment graphically in a design file and store it. (Section 32). 

 

Before Starting any project in Geopak be sure to set up the Project Manager. See page 5-1 

 

7.1 Store Existing Alignment in Coordinate Geometry 
  

7.1.1 Geopak Coordinate Geometry Dialog 

 

Within the Project manager dialog 

select Coordinate Geometry, or from 

the Road Tools Menu or Applications 

> Geopak Road > Geometry > 

Coordinate Geometry 

 

Note: If you select COGO Button from 

the Road Tools Menu It does not Fill-

in the information in the next dialog.  

 
 

1) If you are using the Project manager the entire field 

should be filled in. See page 5-2. 

 a. It is required to type in JOB NUMBER (up to 3 

characters) & OPERATOR CODE (up to 2 

characters) 

 

 b. Project Name & Subject are optional and do 

not have to be filled in. 

 

 c. Click on OK  

 

The Geopak Coordinate Geometry dialog box will open. 

 

 

 
If the Navigator icon does not show – View > Icons > Customize > Tools > check Navigator 
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COGO Dialog Box  

Setting Temporary Visualization shows elements when highlighted in COGO. 

You will use this to store known points and create other elements needed to store a complete alignment.  

You may use all or only a few of the following dialog boxes to create your alignment. 

 

 
 

COGO Navigator: Use this  Dialog  to access the Store dialog boxes for Points, Curves, Spirals & Chains 

 
GEOPAK POINT NUMBERING assignments: 

Min. req. pnts.                                                                 Proposed range  

2000 Cad. Survey (Current 1-999) 1-1999 

1000 Road Design (confirm w/RD) 2000-2999 

4000 R/W 3000-6999 

1000 Placeholder for Traffic 7000-7999 

1000 Placeholder for HYD 8000-8999 

1000 Placeholder for Bridge 9000-9999 

10,000 R/W parcels 10,000-19,999 

1000 Placeholder for GEOTECH 20,000-20,999 

5000 Placeholder for ENVIRO. 21,000-25,999 

 Unused placeholder 26,000-49,999 

250,000 Pre-Survey (includes Constr.) 50,000-to end 
 

This only affects areas utilizing GEOPAK to store points; placeholders represent potential future usage. 



Geopak Users Manual  2/19/2015 

Coordinate Geometry & Horizontal Alignment 
 7-3 

7.1.2 To Store Points 
In the Navigator Dialog set ELEMENT to Point and Select the Add Element   

Or from COGO click ELEMENT>POINT>STORE 

This will open the store points dialog box.  This is needed to store your points. 

 

1. Fill in the following: 

 Point Number 

 Northing Value 

 Easting Value 

2. Fill in any other optional information and make 

sure the switch to the left is turned on. 

3. Click on Store Point. 

 

In the Coordinate Geometry window, the 

information confirming the storing of the point will 

appear. 

 

PCode is a value that identifies the point as a 

feature such as a power pole or edge of pavement. 

Cells can be associated with points and you can 

have Geopak place them using the Design and 

Computation Manager. 

 

Note:  Remember to hit return after filling in the fields.  If you forget, it remembers the last numbers that 

were entered and those are the numbers that will be entered when you hit APPLY.  Switches must be 

turned on to use any of the optional features or they will not register. 

Important: When entering points that will be used for the alignment (Beginning, Ending & PI points) 

the Bearing and distance will need to be rounded. Bearing to the nearest second (0^00’00”) and 

Distances to the nearest one hundredth of a foot (0.01). Use the inverse command in COGO to check 

the Bearing and Distance then use the Tools > Locate > Traverse command to adjust the points.  

Hint: Check each bearing and distance ahead after the point back has been corrected. For instance if you 

have 4 points stored check the bearing and distance between the first and second point and then correct 

the second point, then check the bearing and distance between the second and third point and correct the 

third and so on. 

 

7.1.3 Inverse Tool 
Go to Tools > Inverse 

This will open the Inverse Tool Dialog. 

 

Use Inverse to check the distance and bearing 

between point(s). 

Use the Locate  > Traverse to fix the points.  

If points will not inverse then delete all  

c:\program files\bentley\geopak\bin\*.rsc files from 

your local drive and retry. 
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7.1.4 To Locate Points From Stored Points 
Go to TOOLS > LOCATE > TRAVERSE 

This will open the Locate Traverse dialog box.  This will locate points relative to points already stored. 

 

 

1. Distance can be set to Value, Between two points 

or Radius of a curve and Direction can be set to 

Value, Bearing, Azimuth, or between two points. 

 

2. Fill in the following 

 Locate Point 

 Start Point 

 Distance (Round to the nearest .01) 

 Direction (round to the nearest second  

0^00’00”) 

 

3. It is optional to designate an offset distance left 

or right of centerline (Make sure Offset Distance 

switch is checked if you wish to use this). 

 

4. When all the information is entered, click on 

Locate button. 

 

In the Coordinate Geometry window, the information confirming the storing of the point will appear. 

 

There are a number of other LOCATE commands available.  For more information on other commands 

see Geopak Help Online – Command Reference > Geometry OR press F1 when dialog is active. 

 

7.1.5 To Store Simple Curves 
In the Navigator Dialog set ELEMENT to Curve and Select the Add Element    

Or Go to ELEMENT > CURVE > STORE > BY TANGENTS 

 

This opens the store curve dialog box which creates a curve using information that may be available.  

Curve names should not be the same as the alignment name and can be up to eight characters long. 

 

1. Fill in the Curve name 

2. Click the arrows on the back and ahead tangents 

until the diagram matches the type of information 

you have to enter. 

3. Element Reference can be set to Radius, Degree, 

Tangent or Length. 

4. Fill in the information asked for in the Back 

Tangent Reference, Element Reference, and Ahead 

Tangent Reference. 

5. Click on STORE CURVE. 
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In the Coordinate Geometry window, the information confirming the storing of the curve will appear.  

Information such as PC, PI, PT, and other curve data will be displayed. 

 

This is the most common dialog box you will use. For information on other methods of storing simple 

curves see Geopak Help Online – Command Reference > Geometry OR press F1 when dialog is active. 

 

7.1.6 To Store Curves with Spirals 
In the Navigator Dialog set ELEMENT to Point and Select the Add Element    

Or Go to ELEMENT > SPIRAL > STORE > BY TANGENTS 

 

 

1. Set the Spiral Type to SCS. 

2. Fill in the Spiral name 

3. Click the arrows on the back and ahead tangents 

until the diagram matches the type of information 

you have to enter. 

4. Entry Length and Exit Length should be set to 

the Spiral length. 

5. Element Reference can be set to Radius, Degree, 

Tangent or Length. 

6. Fill in the information asked for in the Back 

Tangent Reference, Element Reference, and Ahead 

Tangent Reference. 

7. Click on STORE SPIRAL. 

In the Coordinate Geometry window, the information confirming the storing of the curve will appear.  

Information such as PISCS, Total tangent, Total Length, Total Delta, CS, ST, TS, SC and other curve 

data will be displayed. 

 

This is the most common dialog box you will use.  For more information on other methods of storing 

spiral curves see Geopak Help Online – Command Reference > Geometry OR press F1 when dialog is 

active. 

 

Coordinate Geometry will make three separate elements with this command. 

 

These elements are spiral C1B, Curve C1, Spiral C1A 

 

The B stands for the spiral before the simple curve. 

The A stands for the spiral after the simple curve. 

 

Make sure any points you use to store these curves have already been stored or created in a previous 

command. 

 

See Appendix A:  Storing a Spiral with Master PI  
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7.1.7 To Store the Chain from the Elements 
In the Navigator Dialog set ELEMENT to Chain and Select the Add Element   

Or Go to ELEMENT > CHAIN > STORE > FROM ELEMENTS 

 

This will open the store chain dialog box.  This allows you to create alignments from elements that have 

been stored.  You may use alignment designations that you are familiar with such as G, A, B, etc. or 

names such as CL, ALT1, EXIST, etc. The only exception is if you are using RDS data, then the existing 

alignment has to be called G. 

 
1. Fill in Chain Name (up to 8 characters) 

2. The next box can be set to Station, Begin at 0+00 or As Is. 

3. Fill in beginning station if you choose this option 

4. You now have two options 

a. You can type the elements of the chain into the dialog box (This works best if you have 

several spiral curves. i.e. SCS c1 This element doesn't exist under element types). Make sure 

to put a space between all the labels and elements. 

Or 

 b. Use box next to Add button  

  1. Set to first element (i.e. curve) 

  2. Choose first element 

  3. Click on Add 

  4. Repeat steps 1-3 until all elements are listed 

5.  When all the elements are listed in the dialog box, click on Store Chain button to create chain. Eg. 
STORE CHAIN DESIGN 10 CUR C1 SCS C2 SCS C3 50 STATION 0+00 

 

After all the desired chains are saved and any necessary modifications such as equations (Section 30) are 

made, it is time to exit Coordinate Geometry.  If you wish to save the COGO commands for future use or 

modification, you should go to FILE SAVE.  Note: this is not necessary because all the elements have 

been saved in a .gpk file.  Element modification can be done without rerunning the commands. 
 

Rule of Thumb: If it is not easily recreated, such as having to type in commands, save the COGO file.  If 

the computer easily recreates it, don't save the COGO file.   
 

Important: When storing Spiral-Curve-Spiral Curves be sure to enter them as SCS cuvrename. 

This is the only way to get the Master PI and Total Spiral information to show in the Describe 

Chain command.   Eg. SCS SCS1 SCS SCS2 designates 2 spiral curves in a chain. 
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7.1.8 To Get a Printout of Alignment Information  
(This may be done any time after the chain has been created) 

 

In the Navigator Dialog set ELEMENT to Chain and Select the Print/Describe Element  

Or Go to ELEMENT > CHAIN > UTILITY 

This will open the Chain > Describe dialog box 

 

 

 

1. Highlight the chain you wish to see the information on. 

 

2. Click on Describe. The information will appear in the 

Coordinate Geometry window. 

 

 

 

 

Go to FILE > INPUT FILE UTILITY 

 

This will open a dialog box in which you can enter 

a file name, select OUTPUT from the drop-down 

box and hit Apply. 

 

You may now print this file from any file editor, 

such as NOTEPAD. 

 

Close COGO dialog box.  

 

Click NO to SAVE file. 

 

NOTE: The preferences > output accuracy > distance may be changed to 2 decimals for future processes. 

See page 4-2. 
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7.2 Draw Horizontal Alignment - Design and Computation Manager 
See Geopak Help Online – Command Reference > Design and Computation Manager 

Optional direct link to Help press F1 when dialog is active 

 

 

Select Design and Computation Manager from the Road Tools Menu 

 

The Default D&C manager database should be w:\geopak\mdtenglish.ddb 

 

 
 

 

 

1. Double Click on Roadway under Content. 

 

2. Double click on Alignments & Profiles. 

 

3. You can save any entry as a Favorite. 

                 
4. Select on (Design)AA Alignment 

Annotation  (or the option that best fits 

your situation) 

 

The Plan & Profile box should highlight at this 

point. 

 

5. Click on Draw Plan & Profile button. 

 

6. If you are using Project manager Geopak 

will go directly to Plan & Profile Draw, 

otherwise it will stop at this dialog. 

 

 
Enter the Job Number and select OK 
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1. Change Element Type: to Chains. 

 

2. Line Direction Label & Curve Data should 

be turned on. 

 

3. Click only once on the Alignment you 

wish to draw – the Line Direction Labels 

and Curve Data should appear on the strip 

map. 

 

4. Change Element Type: to Stationing 

See next dialog 

 

 

1. Tick Marks, Tick Marks Station & PC & 

PT & CS… labels should be turned on 

(PI’s are not placed on our strip map any 

longer). 

 

2. Click only once on the chain to be 

stationed. This draws in the items checked 

in the dialog box. 

 

3. Close this dialog 

 

Your Horizontal Alignment should now be drawn in your design file according to the Road 

Design and Cadd Standards Manual standards.  
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8 Draw Pattern 
8.1 Draw pattern lines 

 
 

 

1) Within the Project manager 

dialog select Draw Pattern  
 

Or 
 

2) Select Draw Pattern Lines by 

Station from the Road tool 

Menu 
 

If you are using Project manager you 

will need to Create or Rename a run. 

 

 
 

 
If pattern lines are within 3 ft of each other remove the 50 ft 

pattern lines. In some cases the first and last pattern line could 

be a 50 foot pattern line and a horizontal control point.  There 

may be two pattern lines at the same station; one of the pattern 

lines will need to be deleted. 

 
US Customary - LV=P_Geopak_PatternLines_Design 

 and/or  LV=P_Geopak_PatternLines_Approach 

 and/or  LV=P_Geopak_PatternLines_Detour 

 and/or  LV=P_Geopak_PatternLines_FrontRD 

 and/or  LV=P_Geopak_PatternLines_Ramp 

 

If you are using the Project manager 

the following will be filled in already 

a) Job  

b) Chain 

c) Stations 

Otherwise fill them in. 

 

Set the Offsets to 300 Feet both left 

and right. This should be sufficient for 

most designs. 

 

Set the Button to Increment and  

Rural = 50 Feet, Urban = 25 Feet. 

 

The symbology may have been set in 

the Project Manager DEFINE of the 

pattern working alignment definition. 

See page 5-2. If so, then it should be 

saved and default to this each time this 

dialog box appears. 

 

Set the Pattern Lines Symbology to 

Lv=(see levels to left), Wt=0, Style=0, 

Color is your preference.  

NOTE: Draw each type of pattern line 

a different color to be able to get a 

critical cross section report. 

 

If symbology levels you need do not 

show go to level manager and select 

GEOPAK filter. 

 

Select Draw Pattern Lines. The pattern 

lines will be drawn in your active file. 
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Options: 

Draw pattern lines at Horizontal 

Control points, Superelevation 

Transitions, and Bridge Ends.  

Use the ONCE option and specify the 

station in Beginning for one pattern 

line. 

 

This is required in order to get the 

needed information to the survey 

crews. The survey crew needs the 

critical cross section for the data 

collects to allow them to stake out the 

project.  

8.2 Draw Pattern Lines From Cross Sections 
 

  

Select Create Pattern lines from X-

sections from Road Tool Menu. 

 

Note: Be sure you are in the strip map 

before drawing the pattern lines. 

 

 
 

US Customary - LV=P_Geopak_PatternLines_Design 

 and/or  LV=P_Geopak_PatternLines_Approach 

 and/or  LV=P_Geopak_PatternLines_Detour 

 and/or  LV=P_Geopak_PatternLines_FrontRD 

 and/or  LV=P_Geopak_PatternLines_Ramp 

 

1. Check the Pattern Lines Symbology 

to Lv=(see levels to left), Wt=0, 

Style=0, Color is your preference. 

The symbology may have been set 

in the Project Manager DEFINE of 

the pattern working alignment 

definition. See page 5-2. If so, then 

it should be saved and default to this 

each time this dialog box appears. 

If required levels do not show in the 

symbology selection dialog box, then 

open the level manager and select 

GEOPAK as the level filter. 

 

2. Set the XS Dgn to the file you drew 

the cross sections in. (This is called 

the working cross section file) 

 

3. Select Draw Pattern Lines. The 

pattern lines will now be drawn in 

the active design file. 

 

Note: Be sure to set the pattern 

definition under working alignment 

definition. See Page 5-2 
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9 Existing Ground – DTM 
 

Survey/Photogrammetry generates the DTM (.tin) files so this chapter is to check that file and 

show what it contains. 

 

 

 

Go to Applications-

GEOPAK ROAD > DTM 

Tools, or DTM on the Road 

Tools Dialog or Click on 

Existing Ground button in 

Road Project. 

 

A TIN file, generated by 

Photogrammetry, should exist 

already for the project. This is 

the Digital Terrain Model file.  

The following may be done to 

check that file. 

 

9.1 Triangle Statistics 

 

Go to Reports TIN Statistics 

 

This will open a dialog box that 

gives information about 

triangulated file. 

 

 
 

This allows you to check and 

make sure that all your points 

are not at the same spot or any 

other mistakes that are obvious 

such as 1000-foot difference in 

elevations when you only have a 

max. 100 foot difference. 
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9.2 Display DTM Features 

 

Go to LOAD > DTM Feature 

This will open the Load DTM 

Feature dialog. 

 

- Click File > Open 

- Select W:\GEOPAK\ 

- DTMEXISTING.lpf or 

DTMPROPOSED.lfp or 

EROSION.lpf file that sets 

symbology for loaded 

features. (below) 
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1) Set Load File to TIN and 

use spy glass button to 

select the Tin file. 

 

2) Set the Feature to the feature 

you wish to display. 

 

3) If displaying contours be 

sure to click the READ 

button to get elevation 

information. 

 

4) Select Load button 

 

Notes: If displaying triangles, the triangles should now be displayed on the screen laid over your 

alignment. Now you can visually inspect the triangle file for any gaps that should not exist or if there 

are extra triangles that should not be there.  If there are, go back to Build-Triangles and adjust the 

side length until it looks right. A contour map may be created by using the macro: RD > Create 

DGNs > select Contour Map File, English and use the PH file as the Base Map > Create DGN’S  - 

creates ####RDCMA001.dgn. 
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10 Existing Ground Cross Sections 
 

10.1 Creating Ground Cross Sections  
 

Be sure you have a pattern line before you create cross sections.  

 

 

In Project manager Select Existing 

Ground Cross Sections. You will 

need to Create or Rename a run. 

 

Or  

 

Select Ground Cross Sections From 

DTM from the Geopak Road Tools 

Menu 

 

 

 
US Customary - LV=P_Geopak_PatternLines_Design 

 and/or    LV=P_Geopak_PatternLines_Approach 

 and/or    LV=P_Geopak_PatternLines_Detour 

 and/or    LV=P_Geopak_PatternLines_FrontRD 

 and/or    LV=P_Geopak_PatternLines_Ramp 

 

 

1) The following will be filled in already 

a. Tin file 

b. Job number 

c. Chain 

d. Scales 

e. Begin & end stations 

Otherwise you will need to fill them in. 

 

2) Set Button to Pattern By DGN file. 

 

3) Select the Design File using the spy glass. 

 

4) Check Levels then Match the Pattern lines 

in the design file drawing. These lines may 

be any of those listed in the left column. 

 

5) Select Surfaces Tab 

 

 



Geopak Users Manual  2/19/2015 

10-2  Existing Ground Cross Sections 

 
 

The symbology may have been set in the Project 

Manager DEFINE of the cross section. See page 5-4. 

If so, then it should be saved and default to this each 

time this dialog box appears. 

 

 

1) Select a .TIN file using the spy glass icon 

next to TIN FILE. 

 

2) Set Method to Triangles and Type to Line 

String. 

 

3) Display Settings: 
1) Select Feature 

2) Select D&C Manager (paintbrush icon)  

3) Select Roadway > XS > XS-EGRND 

      4) Select OK   (see below left) 

 

4) Set Void symbology, using COPY/PASTE 

from display settings. 

 

5) Change Void color to 0 (white). 

 

6) You must Add or Modify Surface before 

plotting cross sections. 

 

7) Generate Working XS dgn, if you haven’t 

yet. See section 10.2 below. 

 

8) Make sure you’re in the cross section file. 

Select Draw. This will plot the cross 

section in the active design file. (This is 

called the working cross section file)  

 

Note: Be sure to set the Cross section view & 

existing ground definition under working 

alignment definition. See page 5-3. 

 

10.2 Generate Existing Cross Section Drawing: 

 

 

 

Macro – Road Design > Create DGN > Select 

Working X-Sections and English > Create DGN’S 

This creates a ____RDXSF001.dgn file.   

 

This may be done at any time during this process 

before the DRAW button is selected.  
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11 Existing Ground Profile 
 

Open GROUND PROFILE dialog 

 

1) Within the Project manager dialog select Existing Ground Profile  

 

If you are using Project manager you will need to Create or Rename a run. 

 

1) If you are using the Project manager working 

alignment Define then the following will be filled 

in already. See page 5-3 

a. Job number 

b. Operator 

c. Chain 

d. Begin & end stations 

e. Tin File (from survey, district or photo) 

Otherwise you will need to fill them in. 

 

2) Set the Offset to 0.00 (for the centerline 

elevations) 

 

3) Set Increment to 5 or 10 depending how detailed 

the DTM data is. (Photogrammetry = 5, Data 

Collector = 10) 

 

4) Select Apply.  

 

 
 

1) Select OK. This will save the input data into the 

file selected 

 

Note: You may change the file name to a COGO Input 

to save the file as a backup. 

 

  
 

 

 

1) Press the YES button. This will store the 

profile in the GPK file. 

 

Note that the profile can be stored later if the NO 

button is selected using the input file stored above. 

Open the input file within COGO and process it to 

store the profile. 

 

2) Press the Yes button to remove the temporarily 

3D element use to create the profile. 

 

3) Close Ground Profile window and click YES 

to save settings. 
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11.1 Draw Vertical Alignment - Design and Computation Manager 

 

Select Design and Computation Manager 

from the Road Tools Menu 

 

Be sure you have the 

W:\GEOPAK\MDTENGLISH.DDB file 

loaded.  

 

 
 

 

1) Double Click on Roadway under Content. 

 

2) Double click on Alignment & Profiles 

under Content. 

 

3) Select on (DESIGN)EP Alignment - 

Existing Profile Grade Annotation 

 

4) Click on Draw Plan & Profile button. 

 

If you are using Project manager Geopak will 

go directly to Plan & Profile Draw, otherwise it 

will stop at this dialog. 

 

 
 

5)  Enter the Job Number and select OK 
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Open the design file ____RDMAP001.dgn 

you are working on. 

 

Select a space in your design file away from 

the current drawings. 

 

Horizontal & Vertical Axis Labels should be 

turned on for Existing Profile. 

 

Select the profile you wish to plot. 

 

The profile dialog will open. See below. 

 

The top of this dialog will give you 

information about the profile and allow you to 

set the scale, stations and increment. 

 

Leave the Strip grade Increment blank. 

 

The bottom of this dialog allows you to set the 

parameters of how the vertical alignment will 

be placed in the design file. 

 

The DP Station should be your beginning 

station of your reference grid. Use the closest 

even station before your alignment. 

 

DP Elevation is the lowest elevation of your 

reference grid. This should be below the 

minimum elevation of your profile. Use the 

closest 30 feet below the Minimum Elevation. 

 

DP X & DP Y set the location of the lower left 

corner of the reference grid. Hint: Draw cell 

At XY. This will allow easy recall of profile 

location. 

 

When everything is set to draw the vertical 

alignment, select OK. 
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12 Vertical Alignment 
 

 

 

1) Within the Project manager dialog select 

Vertical Alignment or select VPI Based 

Vertical Alignment Generator from the Road 

tool Menu 

 

2) If you are using Project manager you will need 

to Create or Rename a run. 

 

 

1) If you are using the Project manager 

working alignment Define then the 

following will be filled in already. See 

page 5-3. 

a. Job number 

b. Chain 

c. Reference Station (this is for reference 

grid) 

d. Reference Elevation (this is for reference 

grid) 

e. Horizontal Scale 

f. Vertical Scale 

Otherwise you will need to fill them in. 

2) Click Identify Cell then Tentative and 

Select the Profile Cell. This should fill in 

the above information. 

 

3) Select on OK 

 

User Preference for the profile Generator.  

 

Click File > Preferences on Profile Generator. 

If using the COGO Best Fit tool, make sure the 

Max Shot Distance preference is set correctly. 

This preference should be set so that no two 

points are farther apart than the distance specified 

in this preference. The program uses this Max 

Shot Distance when determining the order of the 

candidate points. 
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Insure the K Value Table being used is: 

W:\GEOPAK\Kvalues_2011english.kvl  

 

 
 

 
If you have a profile you wish to edit, go to FILE-LOAD.  This allows you to edit already 

created vertical alignments. 

 

If you are creating a new vertical, begin by entering your first station.  If you Select on dynamic, 

you will be able to place your VPI graphically or you may key-in the value. 

 

Note: If you are typing the Station, Elevation, Grade etc. be sure to select return to enter the 

numbers. 
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To create the 2nd VPI Select on INSERT-AFTER.  This will move you to the next VPI. 

 

The VPI in the center is always the one that you will be creating or editing. 

 

Clicking on DYNAMIC will allow you to graphically move and place VPI's.  Clicking on 

INSERT will always create new VPI's.  Clicking on NEXT or PREV will allow you to move 

back and forth between the VPI's. 

 

If you have a profile you wish to edit, go to FILE-LOAD.  This allows you to edit already 

created vertical alignments. 

 

Normal vertical entry process: 

1. Enter beginning VPI dynamically and place at starting elevation. 

2. Place next VPI at some multiple of 20’ and set elevation to nearest .05 of where you want 

it. 

3. Lock the elevation and go through setting the L (length) to a good round number. 

4. Adjust as needed to match your speed, length and sight distance. 

 

To create a vertical curve for the design speed, change the Speed to the desired speed.  Beware if 

a zero appears in the speed box it will kick you out and you will have to start over. This will give 

you the desirable length of curve for that speed in the Length box.  Round the length up to the 

nearest 50’ increment. 

 

Note: The Speed, Length, or K values can be entered to determine the vertical curve length.  The 

length should always be rounded up to the nearest 5 foot increment. 

 

Adjustments can be made to the station, elevation, forward or back grade.   When these are 

adjusted the vertical curve desirable length is adjusted automatically. 
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1. Go to FILE > SAVE PROFILE. 

 

 
2. Type in name of profile.  (Max. 5 characters)  like PROF 

 

This will append the input lines used to create the profile to the job input file created by Geopak. 

The file name will be call JjobOoc.inp. Where “job” is the Job Number and “oc” is the operator 

code. For example the file may be called j9RMOoc.inp. Shown below is an example of the input 

lines. 

 

Coordinate Geometry Input lines created by Profile Generator 
 

STORE PROFILE PROF 

VPI 1 S 1000.0000000000 E 2799.8800000000 

VPI 2 S 1200.0000000000 E 2799.9500000000 L 224.8275862073 

VPI 3 S 2224.6600000001 E 2809.1719400000    Bridge end 

VPI 4 S 2693.6000000001 E 2813.3924000000    Bridge end 

VPI 5 S 2786.1600000001 E 2814.2254400000 

END PROFILE 

 

3. Hit return and Select on OK. 

 

The next step is to draw the new profile over the existing ground profile. 

 

  



Geopak Users Manual  2/19/2015 

Vertical Alignment 
 12-5 

12.1 Draw Vertical Alignment - Design and Computation Manager 

 

 

Open Design and Computation Manager  

 

Be sure the you have the MDTENGLISH.DDB 

file loaded  

 

 
 

 

1) Double Click on Roadway under Content. 

 

2) Double click on Alignment & Profiles 

under content 

 

3) Double click on either Urban or Rural 

under Content 

 

4) Select on  (DESIGN) Alignment – 

Finished Profile Grade Annotation 

 

5) Click on Draw Plan & Profile button. 

 

If you are using Project manager Geopak will 

go directly to Plan & Profile Draw, otherwise it 

will stop at this dialog. 

 

 
 

7)  Enter the Job Number and select OK 
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VPI Labels, Horizontal & Vertical Axis 

Labels, V.C. Increment Elevations, V.C. 

Parameters & Grade Labels should be turned 

on for Design Profile. 

 

Click on the profile you wish to plot. 

 

The profile dialog will open. See below. 

 

Click Identify Cell and select the cell of that 

grid. This will fill in some needed information. 

 

The top of this dialog will give you 

information about the profile and allow you to 

set the scale, stations and increment. 

 

Leave the Strip grade Increment blank. 

 

The bottom of this dialog allows you to set the 

parameters of how the vertical alignment will 

be placed in the design file. 

 

The DP Station should be your beginning 

station of your reference grid. Use the closest 

even station before your alignment. 

 

DP Elevation is the lowest elevation of your 

reference grid. This should be below the 

minimum elevation of your profile. Use the 

closest 30 feet below the Minimum Elevation. 

 

DP X & DP Y set the location of the lower left 

corner of the reference grid. The grid should 

already be defined for existing profile 

 

When everything is set to draw the vertical 

alignment, select OK. 

 

You may now close all dialog boxes. 
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13 Calculate Superelevation 
 

13.1 Storing Superelevation rate on Curves 
 

NOTE:  Storing the Superelevation rates on the curves only needs to be done to get the super 

elevation on the curve data. 

 

Prior to creating the Superelevation file the Superelevation rates need to be stored in Coordinate 

Geometry for the curves. If you wish to have the super information appear in you curve data on your 

horizontal alignment, you will need to do this before you draw the alignment. 

 

 

1) Within the Project manager 

dialog select Coordinate 

Geometry  
Or 

2) Select Coordinate Geometry 

from the Road tool Menu 

 

If you are using Project manager 

you will need to Create or Rename 

a run. 

 

To determine the proper Superelevation rates see pages 9.3(3) (English) and 9.3(4) (Metric) in the Road 

Design Manual. 

 

 
 

1) Go to COGO Navigator 

 

2) Set Element to Curve 

 

3) Select the curve to change in the “e” column. Determine super rate for curve in table by radius and 

design speed.  If normal crown then leave e column blank. 

 

4) Type in the super rate (i.e. .03) 

 

5) For curves with spirals there is no need to store the super rate on the spirals. 
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After the Curves have the super rate stored on them you can draw the Horizontal alignment and the 

Super rate will appear in the curve data. See page 7-8 on how to draw the Horizontal Alignment. 

Important: The curve data will need to be edited for the super rate. Geopak places it as S = 0.06% it 

should be shown as S = 6%. 

 

14 Custom Line Styles 
 

Sometimes a line style defined in the D&C Manager is correct, but just doesn’t fit the purpose in 

your drawing. That’s when custom line styles can be used. Elements > Line Styles > Custom 

 

This shows the default line style (top) and scaled up line style (bottom). Many uses for this too 

 



Geopak Users Manual  2/19/2015 

 15-1 Generate Superelevation 

15 Generate Superelevation (SHAPES) 
 

 
 

 

 

 

 

 

 

 

 

 

1) Within the Project 

manager dialog select 

Calculate 

Superelevation  
Or 

2) Select Shape Manager 

from the Road tool 

Menu 

3) Click on Automated 

Superelevation (1
st
 

Icon) 

 

If you are using Project 

manager you will need to 

Create or Rename a run.  

 

 

 
       

 
 

See below for information on the 

Directories, Preference and 

symbology dialogs. 

 

Default Directory set by the 

system for the Geopak 

Superelevation setup files. 
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The _E file is used in this preference tab (e). 

 

 
The _L file is used in this preference tab (Runoff Length) 



Geopak Users Manual  2/19/2015 

 15-3 Generate Superelevation 

 
Then the corresponding preference file (.sep) is used in the superelevation dialog drop-down. 

 

 
 

 
 

 

Set Symbology: 

File > Level Symbology  

Double-click in black boxes to set 

each one. 

 

Dependant Shapes: 

  Level = (see levels at left), Co=6, 

Style=0, Wt=2 

 

Independent Shapes: 

  Level = (see levels at left), Co=1, 

Style=0, Wt=2  

 

Levels for US Customary: 

  P_Geopak_SuperShapes_Approach 

  P_Geopak_SuperShapes_Design 

  P_Geopak_SuperShapes_Detour 

  P_Geopak_SuperShapes_Frontage 

  P_Geopak_SuperShapes_Ramp 
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If you are using Working Alignment 

Define skip to step 5 

1) Fill in Job Number 

2) Fill in the Design Speed 

3) Fill in Chain 

4) Fill in Begin and End Station 

5) Set Preference File 

6) The following should be set 

automatically by Preference 

file. 

a) e Selection 

b) Facility 

c) L Selection 

If not set to defaults see 

Directory Setting above. 

 

Setting up the Left and Right shape 

clusters 

1) Fill in the profile to be used 

2) Select Quick entry 

      See dialog below 

3) Fill in name of super input file 

to be created. 

4) Select Generate Superelevation 

Transition and see 

Superelevation Text Editor 

Dialog . 
 

QUICK ENTRY 

 

 

 

 

 

1) Fill in Lane widths 

 

2) Fill in number of lanes 

 

3) Fill in nominal percent slope 

 

4) Select OK and return to dialog 

above. 
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This Dialog appears when you 

select Generate Superelevation 

Transition from the Automated 

Superelevation dialog. 

 

Review the super input file and 

once you are satisfied that it is 

correct then – File > Save 

 

NOTE: Using Save As ALWAYS 

attempts to save the file to C:\ 

thus it doesn’t show up in C:\dgn 

 

Click Create Superelevation 

Shapes to draw the shapes into the 

design file. 

 

15.1  Adjusting super transitions 
 

 

 

This new option in Geopak 

has replaced the option of 

using the _eop profile. 

 

If you have no 

superelevations calculated 

then there should be NO 

“A” profile generated. 

 

The “A” profile adjusts the 

profile for superelevations 

and stays on centerline. The 

design profile goes from 

centerline to inside edge of 

pavement on corners. 
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The following is only for 

example and should not be 

used unless changes are 

needed to the generated 

superelevations. 

 

After Generating 

Superelevation transitions 

change the transitions length 

in the Geopak text editor 

and save the changes.  

 
 

Before 
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After 

Be sure to save the changes.  

 

Draw the Super shapes and 

close the editor. 

 
 

If you changed the original 

superelevation file input file 

then click on the Recompute 

Adjusted Profile button. 

 

This updates the A profile 

file with the changes you 

entered in the generated 

superelevation input file. 

 

Don’t forget to keep the Working Alignment Definition up-to-date. (section 5). 
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16 Draw Transition Data 
 

Applications > GEOPAK > ROAD > Plans Preparation > DRAW TRANSISTION 

 

 
OR 

 

 
 

Open Draw Transition Dialog from the Geopak 

Tools Menu. 

 

 
 

If you are using Project manager the Job # and 

Chain will be filled-in.  

 

Fill in: 

1) Beginning Station 

2) Beginning Offset 

3) Ending Station 

4) Ending Station 

5) Select Apply 

Note: The Element that is drawn will be placed at 

the Active Symbology. 

 Geopak Help Online – Command Reference > Plans Preparations or F1 on active dialog 
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16.1 Draw Shoulder/Widening Areas 
This example: Add 2’ shoulders for entire project.  

 

 
 

Step One 

 

Select Paved Shoulder 

D&C Path = Roadway/Plan/RD Plan 

Surfacing/SHLD 

 

NOTE: Commonly used entries should 

be set up in your favorites. 

 
 

Step Two  

 

Check on Place Influence and Adhoc 

Attributes. 
 

 

Step Three 

 

Within the Adhoc Attribute setting 

window enter the appropriate values. 

 

Hint: This is the only place to enter the 

Inslope Widths. 

 

Note: For help select Question Mark 
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Step Four 

 

Draw a MicroStation Element that 

represents the shoulder.  

 

You may wish to use Draw Transition 

to place a line in the MicroStation map 

file that represents the shoulder of the 

new roadway.  

 

Change offsets to + for other side of 

centerline. 

 

This Example shows the Shoulder line that represents the shoulder point drawn 14’ from 

center line. 
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16.2 Curb & Gutter  
 

 

Requirements 
1) Graphical line that 

represents the Shoulder 

at the face of the curb 

and gutter. 

2) Graphical line that 

represents the Curb & 

Gutter. 
 

Step One 

 

Curb and Gutter  
D&C Path = Roadway/Plan/(609) Curbs 

& Gutters/(609) Pay_Items/(609) STD 

Curbs/609010200 

 

NOTE: Commonly used entries should 

be set up in your favorites. 

 

Step Two  
 

Check on Place Influence and Adhoc 

Attributes. 

 

 

Step Three 
 

Within the Adhoc Attribute setting 

window enter the appropriate values. 

 

Note: For help select Question Mark 
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Step Four 
 

Draw a Microstation Element that 

represents the Curb & Gutter. 

 

Hint: When Drawing the Right Curb & 

Gutter put the Stations in backwards. 

Or use “Change Direction” keyin to 

reverse the Curb & Gutter line. 

 

Step Five 
Draw a MicroStation Element that 

represents a Driving Lane. The Driving 

Lane line is required for the criteria to 

change from Asphalt to Concrete. 

 

 

 

Step Six 
Within the Adhoc Attribute setting 

window enter the appropriate values. 

 

Note: For help select Question Mark 

 

Draw a MicroStation Element that 

represents the Driving Lane. 
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This Example shows the Curb & Gutter line that represents the face of curb drawn 15 feet 

from center line. Shoulder line is also draw at face of curb. 

 

 
 

Completed process 
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16.3 Sidewalk 
 

 

Requirements 
1) Graphical line that 

represents the Curb & 

Gutter. 

2) Graphical line that 

represents the Driving 

Lane. 

3) Graphical line that 

represents the front and 

back of sidewalk 
 

Step One 
 

Select Sidewalk  
D&C Path = Roadway/Plan/(608) 
Sidewalks/ (608) Define_DGN/608-
SWE 

 

Step Two  
 

Check on Place Influence and Adhoc 

Attributes. 

 

Step Three 
 

Within the Adhoc Attribute setting 

window enter the appropriate values. 
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Step Four 
 

Draw a Microstation Element that 

represents the Sidewalk. 

 

Hint: Be sure to draw a line for front 

and back of sidewalk. 

 

Note: For help select Question Mark 

 
This Example shows the Curb & Gutter line that represents the face of curb drawn 15 feet 

from center line. Shoulder line is also draw at face of curb. 

 

 
Completed process example: 
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16.4 Guardrail and Guardrail Widening  
Requirements: 

1) Graphical line that represents the Widening. 

2) Graphical line that represents the Box Beam Guardrail. 
 

 
 

Step One 
 

Guardrail Widening  
D&C Path = Roadway/Plan/ (606)Guardrail & 

Conc. Barrier/ (606)Define_DGN/ (606)AGG 

Agg Shld Widening(Adhocs) 

 

 
 
Step Two  
 

Check on Place Influence and Adhoc Attributes. 

 

 

Step Three 
 

Within the Adhoc Attribute setting window enter 

the appropriate values. 

 

Note: For help select Question Mark 
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Initiate Draw Transition, if not active. 

 
 

Step Four 
 

Draw a Microstation Element that represents the 

Guardrail Widening. 

 

 

 
 

Step Five 
Box Beam Guardrail   
D&C Path = Roadway/Plan/ (606)Guardrail & 

Conc. Barrier/ (606)Pay_Items/ (606)Box Beam 

Rail/ 606010265 GUARD RAIL-BOX 

BEAM/BR APPR-SEC 

 
 

Step Six 
 

Check on Place Influence and Adhoc Attributes. 
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Step Seven 

Draw a MicroStation Element that represents the 

Guardrail. 
 

 

 

 
 

Example shows guardrail drawn on the 

shoulder and guardrail widening drawn 

1.5’ beyond the shoulder. 

 

 

Example shows cross-section with box 

beam guardrail and guard rail widening 

beyond shoulder. 
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17 Proposed Cross Sections 
 

Because of the complexity of this process only the simplest method will be explained. This 

Method requires that the Geopak Project Manager DEFINE is used. (see Chapter 5) 

 

 
 

In Project Manager Select Proposed Cross 

Sections  
 

  

XS DGN FILE: 

 

If you are using the Define Alignment 

this will fill-in the XS DGN File. This is 

file created for the existing cross sections. 

The tolerance defaults to .1, but should 

be changed to .001.  

Note: Sometimes a super XS shows as 

flat (0 slope). Changing this to 0.01 or 

0.015 may fix that problem. 

 

Example: Working Alignment 

Definition – Cross Section View 

  

PATTERN: 

 

Check "Use Working Alignment 

Definition" if you have defined this 

information. 
Or 

Fill-in The Chain, Scale & Design File. 

Lv=P_Geopak_PatternLines_Design 

 

Example: Working Alignment 

Definition – Plan View - Pattern 
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EXISTING GROUND: 

 

Check "Use Working Alignment 

Definition" if you have defined this 

information.  
Or 

Fill-in the Design File where cross 

sections are located. 

LV=E_Ground_XS_Delineation 

 

 

Example: Working Alignment 

Definition – Cross Section View – 

Existing Ground 

  

SHAPES: 

 

Check "Use Working Alignment 

Definition" if you have defined this 

information.  
Or 

Fill-in Design File where the Super 

Elevation shapes were drawn. 

Note: Existing features must always be 

run in shapeless mode. 

 

Example: Working Alignment 

Definition – Plan View - Shapes 
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SHAPE CLUSTERS: 
 

See Following Pages for 2 steps on filling 

out this dialog. 

 

Note: Steps 1 & 2 can be done manually 

without the help of the Dialogs. 

 

 

 

Shape Clusters Step 1 
1) Select the Scan button and the List of 

Clusters dialog box will open.  

 

2) Then select a shape cluster from the 

List of Cluster dialog. 

 

3) Select Add and the shape cluster will 

be added to the list to the left. 

 

4) Close The List of Clusters Dialog. 

 

Repeat for each Cluster until all clusters 

have been added. 

 

Shape Cluster Step 2 
 

1) Select one of the Clusters from the 

list 

2) Select Typical Button 

3) Within the Typical Section Dialog 

Select the Cell name of the Typical 

that best fits your typical section. 

(next page) 

4) Select range of application 

5) Select the Apply button 

6) For HELP click Description  
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7) Repeat for each Cluster 

 

Note: Thick button is no longer used. 

 

This fills in the Side Slope Condition for 

this Cluster and also Criteria Files for 

both the Left and Right Side Slope 

Condition 

 

NOTE: With criteria there are only 4 

typicals that may be used for English 

projects - x10’s – existing features, new 

pavement, overlay and topsoil & 

seeding. 

 

ANY OTHER SELECTION MAY 

CAUSE UNPREDICTABLE 

RESULTS! 

 

DEFINE DGN VARIABLES: 

 

Bypass Define DGN Variables. 

 

Note: Using the new Criteria files the 

widening area can be done with graphical 

elements in the Microstation map file. 

There is no need to define them.  

 

1) Select the variable to change.  

 

2) Type the new Value. 

 

3) Select Modify to change Value 

 

4) Enter all dgn files you have available 

for the project. 

 

5) Change English XS Text Size to 1.0 

or something that looks good with all 

of the text generated. An example of 

all the text generated is on page 16-7. 
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Setting the Draw Ditches to Feature 

DGN to ‘Y’ will result in drainage 

showing on the map and profile. 

 

 
 

Results shown in the map file 

 

Results shown on the profile. 
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1) Select the variable to change.  

 

2) Select Edit. 

 

3) Change the Value 

 

4) Select Save to update 

 

NOTE: The top surfacing layer can be either 

dirt or plant mix it does not matter to Geopak 

except in the way the criteria is set up.  If you 

only have one layer you must use the first 

layer otherwise it will not place the correct 

line at the bottom of the surfacing layer for 

Geopak to calculate it correctly in Earthwork. 

  

1) Set the XS Lines symbology to  
LV= Default 

 

2) Remove all the checks from the Plot area. 
 
3) CHECK Remove Skewed Effect* 
 
4) File > Save Settings 
 

5) File > Run 
 

A new entry is available – pavement shapes – 

this plots the proposed pavement lines – 

before these were always plotted, now you 

have the option to turn the pavement lines off. 

 

* You may not want to check remove skewed 

effect if you need actual calculated slopes to 

show. Not checking it may also cause an error 

– see next page - one of Geopak’s quirks. 
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*This is the error received when Remove 

Skewed Effect is causing the problem. If 

checked, uncheck it…If not checked, check 

it…Then run again. 

 

Click File > Save Settings then 

RUN 

 

Output to log file and Pause on each section. 

 

Check the first station and, if OK, remove 

pause check and continue. 

 

Completed Process Example: 

 

 
 

Text here is set to 1 via English XS Text Size in Definable Variables. 
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17.1 Review or Label Cross Sections 
 

17.1.1   Review Cross Sections 
 

 

Open Cross Section Navigator 

 

Use this dialog to move around 

within the working cross section 

file and find a specific cross 

section. 

 

When this dialog is opened it will automatically search for all the cross sections in the design file. 

 

The double arrows take you to the beginning and end stations 

 

The single arrows will take you forward or backward one cross section at a time. 

 

The small window Button will reset the navigator and returns the user to the first section. 

 

17.1.2   Cross Section Labeler 
 

 
 

Open the Cross Section Labeler 

 

1) Select Identify Element or DP 

 

2) Set the Parameters to place the Label or Open 

and select an existing Style. 

 

3) Place the Label 

 

Note: See the Geopak Help Online – Command 

Reference > Cross Sections 
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17.2 List all Stations with Working Cross Sections 
 

Open the cross section file for your project: XXXXRDXSF001.DGN 

Open D&C Manager and click the Design icon.  

 

 
 

Double click on Roadway > Special Applications > VBA-Create List of Working XS 

Brings up this dialog window so you can enter the job, chain and the output file you wish to 

create. 

    
 

Click Process and this window shows what results were found and the file created in c:\dgn. 
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18 Adhoc Attribute Manager 
 

 

Open Adhoc Attribute Manager From Application  

Menu. 

Note: It’s a good idea to close the D&C Manager 

while using the Adhoc Manager. Otherwise, your 

symbology may not be what you are expecting. 

 

 

Use the Adhoc Attribute Manager to change the 

“smart” lines. 

 

1) Make sure preferences are set to replace. 

  
 

2) Click Identify Element and select the line to 

be changed. 

 

3) Make changes as needed to the attributes 

 

4) Click Set Attributes 

 

18.1 Editing Adhoc Attributes  
 

 

 

On certain Design and Computation 

elements used by the criteria the user has 

the option of assigning AdHoc Attributes 

to the element in order to directly control 

the criteria. The Adhoc Attribute's options 

will become visible to the user when the 

Adhoc Attributes option is selected when 

drawing with D&C and using the D&C 

Tool Settings: 

NOTE: Entered attributes override any 

Redefinable Variables entered when doing 

proposed cross-sections. 
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18.2 Changing Adhoc Attributes 

 

Once an element has been drawn to the 

plan view using Design and Computation 

manager, it may be desirable to revise 

certain adhoc values. The following steps 

should be followed to change the 

attributes of an element already placed in 

the design file. 

 

 

1. On the MicroStation top menu, open 

APPLICATIONS > GEOPAK ROAD > 

GEOPAK 3PC ADHOC ATTRIBUTE 

MANAGER.  

This dialog will appear: 

 

 

2. From the File pull down menu select 

Preferences and change the Set Mode to 

Replace as shown in this dialog. 

 

 

3. Select the icon to identify the plan 

element that contains the AdHoc 

Attribute(s) to be revised. 

 

 

4. Select the plan element with a left 

mouse click and accept with a second 

mouse click to populate the dialog with 

the current adhoc attributes of the 

element. The dialog will now look 

something like this: 
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5. Revise the value of the adhoc(s) in the 

dialog to the new desired value by 

clicking on the current adhoc setting and 

type in a new value and press enter or tab 

to accept the change. 

 

 

 

6. Select the icon entitled "Set Attributes" 

and then left mouse click on the plan 

element(s) that require the change and left 

click a second time to accept the change. 

The attributes should now be changed. 

 

 

IMPORTANT: Design and 

Computation Manager's "Place Influence" 

MUST be turned OFF to be able to 

change adhoc attributes. 
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19 Earthwork 
 

19.1 Earthworks Dialog  
 

This Method will require that the Geopak Project Manager be used. 

 

 

In Project manager Select Earthwork  

 

After the Select Run Dialog opens copy the DEFAULT 

project and DEFAULT user to create a new run.  

For more information see page 6-2 

 

HINT: Because most of the information within these dialogs is standard it is much easier to copy the 

information from the DEFAULT Project and DEFAULT User within Project Manager. Doing 

this requires the Project Working Alignment Definition be up-to-date. (section 5). 

 

 
 

 
 

If you copied this run from the Default project all of the Dialog will be 

filled in. 

 

If you are using the Define 

Alignment this will fill-in 

the XS DGN File Baseline 

and the Begin and End 

Station. 
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1) Select Existing Ground 

 

2) Soil type is “Earth” 

 

3) Multi-Factors are all 1. 

 

4) Uncheck “Use Working 

Alignment Definition”  
 

5) Select level name  
E_Ground_XS_Delineation 

 

6) Click Modify to 

update. 

 

1) Select Proposed Finish 

Grade. 

 

2) Soil type is “Earth” 

 

3) Multi-Factor is 1.2 for 

Fill. 

 

4) Uncheck “Use Working 

Alignment Definition”  

 

5) Select level names 
P_Template_Design_Alignm

ent_FinishedGrade & 

P_Template_Design_Alignm

ent_SubGrade. 
 

6) Select Styles 2. 

 

7) Click Modify to update. 
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Using Proposed Undercuts may produce unpredictable results with the 

Cut/Fill of the Existing Ground and/or Proposed Finished Grade. 

Best practice is to delete them from the run. 

 

1) Select Proposed 

Undercut1. 

 

2) Soil type is “Pavement” 

 

3) Muli-Factors are all 1. 

 

4) Check “Do Not Include 

in Mass Ordinate”. 

 

5) Set Search Criteria as 

shown, set level to 
P_Template_Design_Alignm

ent_Subgrade. 
 

6) Set weight to 1 

 

7) Select Add for new or 

Modify to update 

 

 
 

You can do pavement and aggregate manually. (See road manual) 

But, if you must, the above shows how to use Undercuts. 

 

8) Select Proposed 

Undercut2. 

 

9) Soil type is “AggSurf” 

 

10) Multi-Factors are all 

1. 

 

11) Check “Do Not 

Include in Mass 

Ordinate”. 

 

12) Set Search Criteria 

as shown, set level to 
P_Template_Design_Alignm

ent_Subgrade. 
 

13) Set Style to 2 

 

14) Select Add for new 

or Modify to update 
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If you copied this run from 

the Default project all of the 

Dialog will be Filled in. 

 

If you want the shapes to 

show then check Draw 

Earthwork Shapes. 

 

 

If you copied this run from 

the Default project all of the 

Dialog will be Filled in. 

 

This dialog can be used to 

add additional quantities to 

the earthwork run. 

Select Process Add/Subtract 

Volumes for Topsoil, 

Digouts and/or Approaches. 

Make sure you add the 

stations where volumes are 

to be adjusted. 

 

If you copied this run from 

the Default project all of the 

Dialog will be Filled in. 
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If you copied this run from the 

Default project all of the 

Dialog will be Filled in. 

Skip Areas to be defined for 

the class project – this is the 

bridge area.  

Enter begin and end stations 

and click on Add. 

Click in the Process Skip 

Areas check box. 

 

If you copied this run from the 

Default project all of the 

Dialog will be Filled in. 

To be used for areas 

earthwork is to be ignored. 

 

Skip or Ignore – either works 

 
 

If you copied this run from the 

Default project all of the 

Dialog will be Filled in. 

Click the spy glass to find the 

correct earthwork text file. 

To combine quantities change 

the column #. 

 

From the Earthwork Dialog 

select Files > Run to process 

the earthwork run. 

Be sure to save a Log File. 

Pause on each section allows 

you to look at the earthwork 

on each cross section.  If you 

do not wish to pause, turn the 

switch off. 

After the earthwork has run to completion, go to EARTHWORKS. 

Applications > Geopak Road > Cross Sections > Earthworks 
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19.2 EarthWork Volumes  
 

 
 

Open Earthworks 

 

This dialog box will open empty. 

Go to FILE-LOAD and load the log file that was 

created from the Earthwork Run. 

 

This will bring up the buttons. 

The log file will let you draw the mass diagram.  This can also be edited using the EARTHWORKS 

program. 

 

You can draw the Mass Diagram to find out what the unadjusted volumes look like.  

 

You can add & subtract volumes, vary multiplication factors, and force balances. 

 

Calculating volumes will create a new .log file.  
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19.3 Drawing Mass Diagram 
 

 

 
 

Click on DRAW MASS DIAGRAM button 

 

 

Because to date we have no standards for how 

Mass Diagrams should be set up and Mass 

Diagrams are very individual by project, settings 

will be up to your discretion. 

 

User - opens dialog boxes for the settings of the 

elements on the mass diagram. 

 

The switches turn different elements on and off. 

 

Parameters - lists information about the earthwork. 

 

Stations and scale allows you to set the length and 

size of the diagram. 

 

DP - allows you to set beginning station, volume, 

and coordinate. 

 

 

USER > Preferences > Mass Diagram Preferences 

> More   Displays this window. 

 

Double-click black box 

Symbology Text size = 50 

Set Increment = 1000.00 

Justification - right 
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19.4 Add & Subtract Volume 
 

 

This dialog box allows you to add positive or 

negative volumes. 

 

If you make a mistake highlight the line and select 

delete. 

 

When you are done close the window using X.. 

 

19.5 Multifactor Table 

 

This dialog box will allow you to adjust 

multiplication factors by station. 

 

Simply highlight a line, type in the new station 

range and multiplication factor and hit Add.  This 

automatically adjusts the stations.  Now exit by 

selecting the X. 

When you are done adjusting the earthwork, click 

on CALCULATING VOLUMES. 

 

19.6 Calculating Volumes 
 

 

 

Make sure the output file name is different from 

the original .log file name. 

 

Click on calculate. Make sure you check the 

calculations from this process, as Bentley has 

logged a defect associated with this 10/29/10. 

 

When this is finished running, go back to FILE-

LOAD and load this new file. 

 

Go back to previous step desired such as drawing 

Mass Diagram. 

 



Geopak Users Manual  2/19/2015 

Limits of Construction 
 20-1 

20 Limits of Construction 
 

 

The cross section (XSF) file must be open. 

In Project manager Select Limits of 

Construction.  

OR  

Select Limits of Construction from the menu. 

Rename or create a new run (see page 6-1). 

 

If you are using the Define Alignment this will 

fill-in all of this dialog. 

See Define Cross Section View page 5-3 

Set Tolerance to .01 

Set Symbology: 

Existing Ground Line : 

E_Ground_XS_Delineation,  

 

Proposed Finish Grade: 

P_Template_Design_Alignment_FinishedGrade,  

P_Template_Design_Alignment_BackSlopeRoun

ding  

 

Note: You will need to set the Beg. And End 

Station to the limits of your proposed surfacing. 

Check Plot Parameters are set as needed below. 

Click Apply to process construction limits. 

The Limits of Construction will be drawn on the 

plan map file and MicroStation shows that. 

 

 

Set the following: 

Cut Symbology 

a) Level = see below 

b) Style = 2 

c) Weight = 2 

Fill Symbology 

a) Level = see below 

b) Style = 0 

c) Weight = 2 

Transition Symbology 

a) Level = see below 

b) Style = 1 

c) Weight = 2 

US Customary - LV=P_Construction_Limits_Approach 

 and/or    LV=P_Construction_Limits_Design   (normal alignment) 
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 and/or    LV=P_Construction_Limits_Detour 

 and/or    LV=P_Construction_Limits_FrontRd 

 and/or    LV=P_Construction_Limits_Ramp 

            and/or     LV=P_Template_Approach_Alignment_BackSlopeRounding 

 

Color is at your discretion. 

 

Tie Down Option = Outer Tie Downs 

 

Click Apply – Geopak scans the cross section file to find the construction limits and draws them, 

according to the symbology defined, into the map design file. The map file is then opened. 

An example appears below: 

 

 
Cut     Transition   Fill 

 

  
Skip over approaches is standard operating procedure. 

 

NOTE: Double check the symbology drawn as a defect has been found that shows 

Fill wherever backslope rounding occurs – these should show as Cut. 

This problem existed 5/23/2011-10/14/2011.
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21 Cross Sections Sheets 
 

 

This Method will require that the 

Geopak Project Manager be used. 

 

In Project manager Select Cross 

Section Sheets. 

 
OR 

Select Cross Section Sheet 

Composition from the menu. 

HINT: Because most of the information within these dialogs is standard, Select File > Sheet Library > 

Attach and Select W:\GEOPAK\MDTXSEC.XSSL. 

 

Create a .dgn file name 1234RDLAY001.DGN - use the Macro > ROAD DESIGN > Create DGN(S) > 

click Layout X-sections and English > Create DGN (See CADD Standards Manual) 

 

 

Select English and appropriate scale. 

You may need to set the Begin and 

End Station to the limits of your 

proposed surfacing. 

 

If you select MDTXSEC.XSSL, all 

of the Dialog will be Filled in. 
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Option: Select Detach Existing if you are replacing all the existing sheets. 

 

 
Include existing ground, finish & sub grade, backslope rounding and alignment annotation displayed. 

Note: This information is used to define the limits of the Reference File clip bounds, so you may need to 

select other levels as well in order to get what is needed in each cross section. 

Setting these levels off (cell, seeding, and alignment annotation undisplayed) in the working cross 

section file makes the others easier to select. 
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With Sheet Stack Columns you can offset the cross sections within the sheet cell.  

If you select MDTXSEC.XSSL, all of the Dialog will be Filled in. 

 

  
If you select MDTXSEC.XSSL, all of the Dialog will be Filled in.  

 

  
If you select MDTXSEC.XSSL, all of the Dialog will be Filled in. Reference in earthwork file. 
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If you select MDTXSEC.XSSL, all of the Dialog will be Filled in. 

 

  
 

To save the input data you must create a xssl file for your project. File > Sheet Library > Save As > 

Name the file what you want and insure it is saved to C:\dgn with file type of xssl. You can then 

reference it in next time you initiate this dialog box. 

 

Open XXXXRDLAY001.dgn then click Layout Sheets on the dialog box. 

 

 

Run MACRO to rename all XS 

references:  Road Design > XS Sheets > 

XS Sheets > Fix XS Reference 

Attachments 
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Check Fix XS Ref Logical Prefix 

 

Click Apply. 

 

This will update all of the attachments to 

insure they are associated with MTRD. 

 

If you need to do the other functions on 

this dialog box, run each function 

separately; otherwise, unpredictable 

results may occur. 

 

What if items are missing from your cross 

sections? 

 

1. Insure the levels are turned on in 

the cross section file for ALL 

elements you want shown. 

 

2. Insure XS Element Search Criteria 

will cover all elements you want 

shown - this determines height of 

each cross section drawn too. 
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22 Plan & Profile Sheets 
 

22.1 Setting up Plan & Profile sheets 
 

 

In Project manager Select Plan & Profile Sheets.  

OR Select Plan\Profile Sheet Composition from menu 

 

After the Select Run Dialog opens rename or create a run. For more 

information see page 6-1. Open RDMAP file. 

 

Below settings are for ENG Plan and Profile Sheets 100 ft./in. only.  

Other selections will have different settings… 

 

1) Select File > Sheet Library and attach  

MDTPLANSHEETS-E.PSL. 

(w:\geopak\mdtplansheets-e.psl)  

 

2) Select the type of sheets and enter the 

Scale for your plan – Full-size enter 

100 ft/in. 

 

 

1) Select Sheet Composition (1
st
 Icon) 

 
2) Set “By Station Range: Outside In” 

 

3) Set Horizontal to 0 

 

4) Set Vertical to 0 

 

5) Station Range should read 3000 for 

100ft./in. 

 

6) Close the window 
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1) Select Plan Sheet Layout: Layout 

Settings (second icon from the left). 

 
2) The appropriate ports will be filled in.  

Double-click Alignment and fill in the 

appropriate chain or profile. 

 

3) When selecting Profile: 

- Either select the profile name from the 

drop-down box OR 

- Click Identify Cell button then select 

the required profile cell on the design 

file. 

- Click OK 

 

4) The Begin and End Stations will fill 

in. You can use the Extend boxes to 

add length to the project for notes. 

 

5) Select Layout # Sheets.  This will 

place the sheet boxes in the map file.  

Drawn on P_Geopak_SheetClips.. 

 

6) Close the window. 
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1) Select Plan Sheet Layout: Clip Sheets

(third icon from the left).

2) Set c:\dgn\ for the Directory.

3) Set Sheet Name Prefix to proj. #

____RDPLP[001]. Brackets cause 
incremental files to be created. NOTE: 

Use PLP for PlanProfile. PLN for 

PlanDetail or DualPlan.

4) Set Orientation to Rotate Reference.

5) Set Sheets per File to 3.

6) Set Model to Active.

7) Sheet Range Begin and End should fill 
in automatically.

8) Check Auxiliary Sheet Annotations

9) Double-click symbology

10)Set Justification to upper Right.

11)Set Th. & Tw. To 20.00.

12)Set Ft to Arial.

13)Check Vertical to insure it has 0.000.  

14) Select OK on the Plot Parameters

dialog.

15) Select Process Sheets on the Clip

Sheets dialog box.  This will make the

plan sheets and plan sheet files.

16) Close the dialog windows.

NOTE: If referenced files do not appear in the PLP area as expected then: 

1. Detach the reference file and reattach using the Reference macro, OR

2. Copy a reference and change the properties to the reference that needs to be reattached.

file://mdtcaddstdsrv/caddstd/documentation/geopak/PLP_BUG.PDF
file://mdtcaddstdsrv/caddstd/documentation/geopak/PLP_BUG.PDF
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Use the MDT Macro to attach the sheet borders. 

 
NOTE: If the references do not show for the plan area as 

expected, then open the reference window, detach the 

references not showing and then use the REFERENCE macro 

to reattach those references. They should show as expected. 

 

If the grid comes in grey scaled then do the following for each 

referenced file: 

 Settings > Level Manager > Highlight all the levels 

 Click on one of the colors 

 Click override OFF 

 

1. File > Open > Select the new 

file(s) just created. Remember s/b 

PLN for plans only, PLP for 

plan/profile. 

 

2. Turn off the following levels: 

 Geopak profile cell 

 Pattern Lines 

 Super Shapes 

 P_Geopak_SheetClips – sheet 

border 

 Profile cell text 

 Any other levels you do not 

want to show in the plan & 

profile 

 

3. MDT > Road Design > Plan/Pro > 

GPK Attach Sheet. 

 

4. Sheet Options and Scale should be 

set according to your project. 

 

5. Select current Plan and Profile .dgn 

file and click on Apply. The sheet 

borders will be drawn onto the 

plan. 

WARNING: IF THIS MACRO DOES NOT WORK, THERE IS SOMETHING WRONG 

WITH THE DGN FILE AND/OR YOUR DGN FOLDER. PLEASE CHECK THE CADD 

INTRANET TROUBLESHOOTING PAGE. 

 

22.2 Sheet Clips Labeling 
 

 

Use the MDT Macros to label Cross 

Section Sheets or Plan and Profile 

Sheets. 

 

1. MDT > Road Design > Design 

Block. 

 

2. Enter Name or Initials. 

 

3. Select Sheets to label. 

 

4. Click on Apply. 
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23 Topsoil & Seeding 
 

23.1 Drawing Topsoil and Seeding onto Cross Sections 
 

 

First thing to do is delete the original seeding 

generated via the proposed cross section 

process.  

Select the two seeding levels in the element 

selection dialog and hit Delete. 

P_Template_Seeding_Area_One_Two 

P_Template_Seeding_Area_Three 

 

In Project Manager Select Proposed Cross 

Sections  
 

 
 

XS DGN FILE: 

 

If you are using the Define Alignment 

this will fill-in the XS DGN File. This is 

file created for the existing cross sections. 

The tolerance defaults to .1, but should be 

changed to .01.  

 

 

PATTERN: 

 

Check "Use Working Alignment 

Definition" if you have defined this 

information. 
Or 

Fill-in The Chain, Scale & Design File. 

Lv=P_Geopak_PatternLines_Design 
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EXISTING GROUND: 

 

Check "Use Working Alignment 

Definition" if you have defined this 

information.  
Or 

Fill-in the Design File where cross 

sections are located. 

LV=E_Ground_XS_Delineation 

 

 
 

SHAPES: 

 

Check "Use Working Alignment 

Definition" if you have defined this 

information.  
Or 

Fill-in Design File where the Super 

Elevation shapes were drawn. 

 

 

SHAPE CLUSTERS: 
 

See Following Pages for 2 steps on filling 

out this dialog. 

 

Note: Steps 1 & 2 can be done manually 

without the help of the Dialogs. 
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Shape Clusters Step 1 
1) Select the Scan button and the List of 

Clusters dialog box will open.  

 

2) Then select a shape cluster from the 

List of Cluster dialog. 

 

3) Select Add and the shape cluster will 

be added to the list to the left. 

 

4) Close The List of Clusters Dialog. 

 

Repeat for each Cluster until all clusters 

have been added. 

 
 

 

Shape Cluster Step 2 
 

1) Select one of the Clusters from the 

list 

 

2) Select Typical Button 

 

 

3) Within the Typical Section Dialog 

Select x10-Topsoil and Seeding 

 

4) Select range of application 

 

5) Select the Apply button 

 

6) For HELP click Description  
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DEFINE DGN VARIABLES: 

 

Bypass Define DGN Variables. 

 
 

DEFINE VARIABLES: 

1) Select the variable to change.  

 

2) Type the new Value. 

 

3) Select Modify to change Value 

 

4) Enter all dgn files you have available 

for the project. 

 

5) Change English XS Text Size to 1.0 

or something that looks good with all 

of the text generated. An example of 

all the text generated is on page 16-7. 
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PLOT PARAMETERS: 

 

1) Remove all the checks from the Plot 

area. 
 
2) File > Save Settings 
 

3) File > Run 
 
 

 
 

Output to log file and Pause on each 

section. 

 

Check the first station and, if OK, remove 

pause check and continue. 

 

 

 

Completed Process Example: 

This shows the seeding and topsoil 

elements drawn into the design file. 
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23.2 Calculating Topsoil from Proposed Surfacing 

 

Within the Project manager dialog select 

Reports & XS Quantities. 

 

Must be in the cross section file (XSF) to use 

cross section reports. 

 

Select Seeding. 

 

1) If you are using Project Manager the 

following will be filled-in 

a) Job Number 

b) Chain 

c) Begin & End Station 

d) Existing Ground Line Symbology   

Level = E_Ground_XS_Delineation 

e) Proposed Finish Grade Symbology  

Level =     

P_Template_Design_Alignment_FinishedGrade 

 

2) Set Candidate Seeding Elements: 

a) Level =        

P_Template_Design_Alignment_FinishedGrade 

b) Color = 2,3, 10-253   

 

This will pick up the Proposed Surfacing with 

the exception of the elements under the finish 

surfacing.  

 

3) Check Max. Allowable slope and set it to 

1:2 for topsoil reports 
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3) Set Sub Every to 3000. 

 

4) Set First Sub At to a station of your preference. This is where the 1
st
 subtotal is to appear. 

 

5) Enter a ASCII file name. 

 

6) Select Apply. 

 

See Geopak Help Online – Command Reference > Plans Preparations 

Optional direct link to Help press F1 when dialog is active 

 

23.3 Calculating Seeding to Right of Way 
 

The new way of calculating Seeding areas according to the memo from Carl S. Peil dated 

December 2, 1998 is to figure the total area within the NEW right-of-way limits and the total 

area within the construction permits and applicable easements. In order to allow Geopak to 

calculate the Area 1, 2 and 3 an element will need to be placed on the cross section then use the 

seeding report to calculate the quantities. 

 

What is needed to accomplish this are: 

 

1) Right of Way Strip map file with the New right-of-way drawn in it. Make note of the 

symbology where the right-of-way is drawn in this file.  

 

2) The working cross section files with the existing and proposed surface and subgrade draw 

on the cross sections. Make note of the symbology of the existing ground, proposed 

surface and subgrade surface.  

 

3) Geopak Project Manager.  

 

The seeding criteria file will start at the centerline at the finish grade elevation. Then trace down 

to the Proposed Finish Grade to the end of the top lift. At this point it will trace down the 

surfacing inslope to the bottom of the Bituminous Material. Then it will go down another 2 feet 

according to the Seeding Standards. At this point it will start drawing a line that represents the 

Area 3 Seeding. It will draw this line until the Horizontal distance is equal to 15 feet.  Then it 

will end the area 3 Seeding and start Area 1 & 2 seeding. It will trace the Proposed Surface to the 

Proposed Subgrade then trace this line to the Construction Limit. At this point it will trace the 

Existing Ground until it intercepts the New or Existing Right of Way.   
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23.4   Seeding Report 
 

Run this process from Project Manager > Reports & XS Quantities > Seeding to calculate the quantities 

you need.   

 

 

1) Proposed Finish Grade = 
P_Template_Design_Alignment_FinishedGrade 
AND E_Ground_XS_Delineation. 

This causes the process to search the entire 

XS width. See NOTE below. 

 

2) Set Candidate Seeding Elements Level = 

P_Template_Seeding_Area_One_Two   use only 

level name. 

 

3) Change the ASCII File name 

 

4) Select Apply 

 

5) Repeat above steps: 

Set Candidate Seeding Elements Level = 

 P_Template_Seeding_Area_Three. 

 

You can also calculate the Area 3 using the 

following formula. Length of the job X 30’ = area 

3 seeding (e.g. 2800 X 30 = 84000) either number 

will be close enough for the plans. 

 

NOTE: The Proposed Finish Grade search needs to include E_Ground_XS_Delineation for 

Seeding report in order to search the entire XS width. 

 

 
You can edit the file created in the previous step, changing “topsoil” to “seeding”, if desired. 

 

NOTE: If attempting to use Additional Distance and Subtotal Split Slope on the same run – the 

additional distance shows on each station but the calculated area does not include it because 

Geopak cannot determine if it is within the split slope criteria or not. The additional calculated 

area does show in the subtotals and final total.
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24 Port Viewer  
 

The Port Viewer is a tool which enables the user to view all three major aspects of a road design 

simultaneously, even though they are located in different files.  In addition, the user can draw 

into any of the views, by a simple data point to identify the active field, therefore the active file.  

The three views include: 

plan view layout 

 profile 

 cross sections 

 

As a prerequisite to invoking the Port Viewer, a working alignment must be defined and 

populated as outlined in section 5. 

 

 
The Port Viewer Navigator is the tool used to keep all views in sync. And show current 

positions.
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25 Help Description Files 
 

 

 
 

From Typical Sections, in the Proposed 

Cross Sections Process, - Click 

DESCRIPTION button to access NEW 

TYPICAL CRITERIA INFORMATION 

on the Intranet. 

 

 
 

From the Adhoc Attribute Dialog Box, 

used with the D&C Manager, - Click 

question mark to access adhoc 

descriptions and graphics pertaining to 

that specific adhoc item. 

Link to GEOPAK Help files in CADDSTD \GEOPAK\CRIT\COMMON\HTML 

Link to GEOPAK instruction videos in CADDTESTV8 \DOCUMENTATION\GEOPAKCRITERIA 
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26 Modifying Design and Computation Drawing Standards 
Important:  If you are using the Project manager the location of the profile can be defined first 

so that when this dialog is opened the location information is already filled in. It is a good idea to 

have this information defined in project manager so that it will always be the same for all 

profiles and will make it easier to draw your plan and profile sheets 

 

 

If you have exceptions to the standards layout 

you can set them by using Preferences (Box on 

upper right under Help, that says Design, click 

and drag to Preference). 

 

You can use this box to create a new category, 

create an item, modify an item or review 

settings on an item. 

 

In order to modify an item you will have to 

type in a password, MDT1. The password is 

case sensitive and must be typed in all caps. 

 

The reason for the password is so you will 

realize that you are changing the standards.  Do 

not save on exit when modifying an item! 

 

 

 

If you create new categories or items please 

send a copy to MDT CADD Administration so 

that it can be included in the standards for 

use by everyone. 

 

When you select Modify Item this dialog box 

opens. Click on review of the item you wish to 

modify. 

 

This will open dialog boxes containing the 

settings of each element item. 

 

To return to Drawing change Preference back 

to Design 
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27  Super Elevation Simple Curve Diagram 

 
A diagram is also available for a spiral curve. 
C:\dgn\9999RDMAP001.DGN  10/2/2008 1:14:15 PM
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28 GEOPAK Level Setup 
English 

 LV CO WT LC FT TX 

Levels to be used by the user  - working plan file 

Pattern lines 

P_Geopak_PatternLines_Approach 
P_Geopak_PatternLines_Design 
P_Geopak_PatternLines_Detour 

P_Geopak_PatternLines_FrontRD 
P_Geopak_PatternLines_Ramp 

 0 0   

Super Shapes 

P_Geopak_SuperShapes_Approach 
P_Geopak_SuperShapes_Design 
P_Geopak_SuperShapes_Detour 

P_Geopak_SuperShapes_Frontage 
P_Geopak_SuperShapes_Ramp 

     

Geopak Defaults – Working cross section file 

Existing Ground E_Ground_XS_Delineation  3 0   

Sub-grade elevation text P_Template_Design_Alignment_Annotation_Displayed 5 * 2  16 1 

Exist ground elevation text P_Template_Design_Alignment_Annotation_Displayed 2 * 1  16 1 

Cut, fill slope & ditch elev. text P_Template_Design_Alignment_Annotation_Displayed 13 * 0  16 1 

Ditch elevation text P_Template_Design_Alignment_Annotation_Displayed 14 * 0  16 1 

Catch point elevation text P_Template_Design_Alignment_FinishedGrade_Text 14 * 0  16 1 

Proposed Top Lifts lines P_Template_Design_Alignment_FinishedGrade # 0 0   

Proposed Sub-grade lines P_Template_Design_Alignment_Subgrade 0-9 3 2   

Sub-grade line outside hinge 
point 

P_Template_Design_Alignment_Subgrade 10 3 2   

Sub-grade cut slopes P_Template_Design_Alignment_Subgrade 11-19 3 2   

Sub-grade fill slopes P_Template_Design_Alignment_Subgrade 21-29 3 2   

Default, error & marked point 
text 

P_Template_Design_Alignment_Annotation_UnDisplayed 12 * 0*  16 2 

Cross slope text P_Template_Design_Alignment_Annotation_UnDisplayed 30 * 0*  16 .25 

Levels to be used by the users – Working cross section file 

Back slope rounding P_Template_Design_Alignment_BackslopeRounding  3 2   

Back slope rounding Text P_Template_Design_Alignment_BackslopeRounding_Text      

Drainage & grading items & 
notes 

E_DRAINAGE_Delineation  1  16 1 

Row, Permits, & easement 
cells 

E_ROW_Delineation    16 1 

Utilities cells P_UTILITES_*    16 1 

Optional surfacing: ** 
 Approach 
 Detour 
 FrontRD 
 Ramp 

P_Template_**_Alignment_Annotation_Displayed 
P_Template_**_Alignment_Annotation_Undisplayed 

P_Template_**_Alignment_BackSlopeRounding 
P_Template_**_Alignment_BackSlopeRounding_Text 

P_Template_**_Alignment_FinishedGrade 
P_Template_**_Alignment_FinishedGrade_Text 

P_Template_*_Alignment_Subgrade 

     

Geopak Defaults – Cross section layout file 

Offset labels P_XSection_Layout_Text 4 * 3  16 3 

Elevation labels P_XSection_Layout_Text 5 * 3  16 2 

Station labels P_XSection_Layout_Text 3 * 3  16 2 

Earthwork Quantities P_XSection_Layout_Text 4 0  16 1.5 

 

* Set as default in Geopak input files but can be changed 

# The color varies for each lift line. For sub-grade lines under the surfacing, the color is less than 10. Colors 10 and greater 
are for sub-grade line outside surfacing (used to calculate seeding and topsoil). 
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29 PDF from MICROSTATION 
 

 

There are actually multiple ways to 

go about it.  Defined here is the 

easiest method. 

 

Built in to basic MicroStation is a 

PDF plot driver that lets you create a 

PDF file from the standard File > 

Print option.  You just need to select 

the Bentley PDF.PLT plot driver and 

you will create a PDF document 

instead of printing to paper. 

 

Select File > Print which brings up 

this dialog box. 

 

Click the spy glass on the Printer and 

Paper Size entry. 

 

Select the PDF plot driver from the 

directory:  

W:\workspace\plotting\ 

 

There is one for black & white and 

one for color also. 

 

The Bentley driver is selected which 

changes the Dialog Box Heading and 

the Printer and Paper Size entries 

 

Fill out dialog box as needed. 

Click on Print icon  or 

Click File > Print 

 

A PDF file will be generated. 
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30 Geopak Project Manager 
This is a process used to save, restore and/or delete a project’s Geopm files. The archive process 

should be used on a monthly basis and at the end of a project. The others will be used as needed. 

 

 

30.1 Archive the Geopak Project 

Manager Files located in the 

GEOPM directory 
 

1) Select MDT > Road Design 

 

2 ) Select Geopak > Archive GPK Proj 

 

 

1) Select the Project to archive 

 

This program will search the GEOPM 

directory to find the Projects. * 

 

2) Select the user associated with the 

project 

 

This program will search the 

GEOPM\PROJDBS directory for the 

folders to find the Users.  

 

This will archive all the files shown in the 

“Files to Archive” list. 

 

3) Change the “Zip File Name” to 

correspond to your project. 

 

4) Select Archive Files. 

 

* This directory is defined by the System 

Configuration Variable 

“GPK_PROJMGR_PROJECTDIR” 

 

Successful completion creates the Zip file 

in the same directory as your DGN file. 

Check-in this file to DMS. 

This completes the archive process. 
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30.2 Restore the Project manager 

files to GEOPM Directory. 
 

 

1) Select existing Zip file 

 

2) Select the User to copy 

 

3) Select Restore 

 

This process will copy the files to the 

correct directory based on the System 

Configuration Variable 

“GPK_PROJMGR_PROJECTDIR” 

 

 

 
 

 

1. Locate the .prj file you just restored in 

C:\dgn\geopm. 

 

2. Remember the exact name, then delete 

the file. 

 

3. Create a new project using the exact 

same name as the one you just deleted. 

 

4. You should now be able to access the 

project’s Geopak information. 

 

This completes the restore process. 
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30.3 Delete the Project manager 

files from GEOPM Directory. 
 

1) Select the Project to archive.  

This program will search the GEOPM 

directory to find the Projects. * 

 

2) Select the user associated with the 

project.  

This program will search the 

GEOPM\PROJDBS directory for the 

folders to find the Users. 

 

3) Select Delete Files. 

This process will Delete the files from 

the directory based on the System 

Configuration Variable 

“GPK_PROJMGR_PROJECTDIR” 

The files are no longer available. 

 

This completes the delete process. 

 

30.4 Attach a link to your design file: 
How about adding a web link to your design file? That might be cool… 

 
1. Draw an element or attach a link to an existing element. 

2. Utilities > Connect Web Browser – this opens the browser and E-Links dialog box. 

3. Click on the 2
nd

 icon in the E-Links – Attach Engineering Link dialog box opens. 

4. In the browser find the web page, file or whatever it is you wish to show in the browser. 

5. Copy the URL (address line) from the browser and paste into the URL of Attach Engineering 

Link. Tentative and select the element this link is to relate to. 

6. Click Follow an Engineering Link 4
th

 icon on the E-Links dialog box and close all boxes. 

7. Whenever you select the related element the browser will open and display what was defined 

at that time.
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31 Storing Equations on a Chain 
 

 

Open Coordinate Geometry (COGO) 

 

Go to ELEMENT-CHAIN-STATION 

EQUATION 

 

This opens the Chain > Station Equation 

dialog box.  

 

The first box can be set to either Label Point 

or Back Station. 

 

 

 

 

1. Label Point or Back Station 

For Label Point you can type in the point 

you wish to equate with the ahead station or 

you can hit equate and choose the point (i.e. 

st c4a). 

For Back Station simply type in the back 

station you wish the equation at. 

 

2. Ahead Station 

Type in the ahead station in the equation. 

 

3. Tangent Point 

It is required that you name the point with a 

number.  Make sure the number has not 

already been used or you may change your 

chain. 
 

If you wish to have the rest of the chain restationed to the next equation turn the switch on. 

 

If there is no other equation present leave the switch off and the rest of the chain will be 

restationed. 

 

4. Choose the chain you wish to put the equation on. 

 

5. Click on Insert Station Equation. 

 

Note: Remember that for spirals the ST is always on 'curvename'A and the TS is always on 

'curvename'B. 
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32 Store Existing Alignment from Graphics 
 

 
 

 

Open Store Graphics dialog box 

 

Important: When using this option be sure the Bearing’s are rounded to the nearest Second 

(00^00’00”) and the Length’s are rounded to the nearest tenth (0.01). You may need to modify 

the alignment in Coordinate Geometry. This dialog box will allow you to store points, 

curves, chains or parcels. 

 

 

1.  Fill in the Job Number (limit 3 

characters) 

Operator Code (limit 2 characters) 

Chain Name 

Beginning Point 

Beginning Station 

2.  Click on ID Element 

 

3.  Tentative to the end of the 

alignment you wish to store and 

accept. 

 

This may be easier if you turn off all 

the levels except for the one 

with the alignment. 

 

4.  Continue to accept the pieces of the alignment until the whole chain is highlighted and the 

STORE button is highlighted in dialog box. 

 

5.  Click on STORE to store the alignment in the .gpk file. 

Note:  This will give you a message telling you the chain was stored in the .gpk file and the 

commands were saved in an .inp file.  Keep this .inp file so that you can recreate the .gpk file if 

it becomes corrupt or lost. 

 

If you need to store equations on your alignment go to section 30. 
 

6.  Once your alignment is stored in a .gpk file go to the SURVEY section of this manual to put 

your ground line into Geopak. 
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33 Drawing and Storing an Alignment 
 

Open LAYOUT ALIGNMENTS HORIZONTAL dialog box 

 

  

 

           

 
These palettes allow you to create alignments 

in conjunction with MicroStation commands. 

Tools provides the following: 

 

  

 
Important: When using this option be sure the Bearing’s are rounded to the nearest Second 

(00^00’00”) and the Length’s are rounded to the nearest tenth (0.01). You may need to modify 

the alignment in Coordinate Geometry. 
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To create the alignment: 

 

1.  Draw tangents using MicroStation Place Line command. 

 

2.  Curves can then be placed by choosing the command from the right on the bottom of the 

Lines/Curves palette or the first icon on the Spiral Combinations palette. 

 

 

 

Choosing the third command opens this 

dialog box. 

 

You can create simple curves by radius or 

degree. 

a.  Key-in radius or degree of curve and/or 

Length. 

b.  Data point on first tangent. 

c.  Data point on second tangent. 

d.  Accept if the curve is correct or reject if 

you need to try another curve. 

 

Repeat this process until all the simple curves have been created. 

Note:  Always choose tangents in increasing station order or you will have to transpose your 

curves when you create your chain. 

 

 

 

Choosing the first icon opens this dialog 

box to create curves with spirals by radius 

or degree. 

 

The various combinations available are SC, 

SCS, CS, SCSCS, and CSC. 

a.  Key-in length of spiral 

b.  Key-in radius or degree of simple curve 

portion 

c.  Data point on first tangent. 

d.  Data point on second tangent. 

e.  Accept if the curve is correct or reject if 

you need to try another curve. 

Repeat this process until all the spiral curves combinations have been created. 

Note:  Always choose tangents in increasing station order or you will have to transpose your 

curves when you create your chain. 
 

3.  When the alignment has been completely drawn go to section 31 for storing an alignment 

graphically. 

 

If you need to store equations on your alignment go to section 30. 

 

See Horizontal Alignment Generator Document in CADD Help Information 
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34 Convert English GPK to Metric GPK 
 

The information about this process is contained in Geopak Help Online- Command Reference > DTM 

Tools. 
 

This method will only be used to soft convert points such as PI's.  It will not be used by MDT to convert a 

surveyed alignment.  Surveyed ground line points can be put into the .gpk file and converted by this 

method, also, to obtain a digital terrain model. 
 

 

Open English/Metric Conversion (GPK Database) 

 

Select GPK File 

 

1) Set the Source Job Number to the English GPK 

file 

 

2) Set the Target Job Number to a new GPK file. 

 

3) Select Convert 

 

Metric to English: 

This uses 0.3048 as a conversion factor. You can 

set Conversion Factor to Custom and Enter 0.3048 

if needed. You will now have a new GPK file 

converted to metric. 

 

English to Metric: Use a factor of 3.28 
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35 Fix Corrupt GPK 
 

Dealing with corrupt GPK or basic maintenance - From the Coordinate Geometry 

dialogue at the COGO key-in enter REBUILD DATABASE. 

 

Press Enter 

It may take several minutes to process the GPK. 

When complete the rebuilt statistics will be displayed. 

 

 
This should be done occasionally and definitely before zipping for the archive or posting 

to DMS. 
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36 Existing Ground - DTM 

 

Go to Applications-GEOPAK 

ROAD > DTM Tools, or DTM 

on the Road Tools Dialog or 

Click on Existing Ground button 

in Road Project dialog box. 
 

Normally this process will not need to be done, as Photogrammetry will have already generated a 

TIN file for the project. 

This will open the following the DTM main menu. Then you will need to select Extract Graphics 

from one of the following menus. 

 

There are three options under the Extract option. 

1. Extract Graphics - this option will extract XYZ points to create a DTM from a design 

file.  Photogrammetry 3D file page 34-2.  Survey 2D file page 34-9. 

 
 

2. Extract DEM Data – this option use specialized Digital Elevation Models. 

 
3. Extract ASCII - this option will process and XYZ ASCII files into GEOPAK DTM 

Format. (See page 34-13)  

 

DTM Menu option will open the following dialog box. 
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Set Curve Stroke Tolerance to 0.3 and 

Minimum Linear Distance to 5.0 

 
 

36.1 Photogrammetry 3D file 
 

Start by opening a 3D Photogrammetry file. 

####PHDTPF01.DGN 

 

Make sure the file is 3D for this process. 

Otherwise, go to page 34-9 for 2D files. 

 

Step 1 

Open level display and set filter to PhotoDTM. 

Leave the Level Display open for use during 

the extract process. 

 

Hints: be sure that the whole map can be seen 

in the MicroStation Window (View 1) and after 

setting the Select Criteria be sure to select the 

apply button. 

 

Step 2 

Open Extract Graphics 

dialog 
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Step 3 

 

1) Choose from Files or type in 

####RDDTN001.DAT for file name.  This will 

create a file you can use to create a DTM. 

 

2) Set Decimal to 4 or greater 

 

3) File Type can be either ASCII or Binary. 

 

4) Set File Open to Create. The first extract 

should have Create set.  Additional points will 

be Added to this file by changing from Create 

to Append. 

 

5) Set Feature Type to Boundary. This is the line 

that is around the outside of all the 

information. 

 

6) Set Mode to Extraction 

 

7) In Level Display set all levels OFF except for 

E_Misc_DTM_Boundary 

 

8) Set Extract – View 1.  Be sure you can see the 

whole drawing in view 1 

 

9) Click on Apply. 
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Step 4 

 

1) Change File Open to Append. This will add 

the voids to the existing .dat file that was 

created in the previous step. 

 

2) Change Feature Type to Voids. These are 

the lines around the outside of buildings 

and areas that have heavy trees or brush 

where the ground information cannot be 

seen by the Photogrammetry unit. 

 

3) In Level Display turn all levels off except 

E_Misc_DTM_Obscure. 

 

4) Select Apply. This will add the void 

information to the existing dat file. 
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Step 5  (Optional) 

 

1) Perform this step only if elements exist on 

E_Misc_DTM_Island level. 

 

2) Change Feature Type to Island. These are 

actual islands in the middle of rivers and/or 

meadow areas in heavy timber as seen by 

the Photogrammetry unit. 

 

3) In Level Display turn all levels off except 

E_Misc_DTM_Island. 

 

4) Select Apply. This will add the void 

information to the existing dat file. 
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Step 6 

 

1) Change Feature Type to Breaks. These are 

the lines that show the edge of roads and 

ditches. These are needed to get a better tin 

of what the ground really looks like. 

 

2) Check stroking are Curve Stroke Tolerance 

to 0.3 and Minimum Linear Distance to 

5.0. 

 

3) In Level Display turn ALL levels ON 

except E_Misc_DTM_GroundShot. 

 

4) Select Apply. This will add the break 

information to the existing dat file. 
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Step 7 

 

1) Change Feature Type to Spots. These are 

the mass points defined by the 

Photogrammetry unit. 

 

2) In Level Display turn ALL levels OFF 

except E_Misc_DTM_GroundShot. 

 

3) Select Apply. This will add the spot 

information to the existing dat file. 

 

You have now created an XYZ file you can create 

a .tin file with. 
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36.2 Convert DTM to English 
 

For information only. Be sure to follow conversion procedures if converting your own DTM. 

 

   
 

 

1) Select Metric<->English from the DTM 

menu or the Icon from the Menus 

 

2) Set Source to existing DTM  

 

3) Set Target to new DTM 

 

4) Set Conversion Factor to Custom and 

3.280839895 

 

5) Press Convert 
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36.3  Survey file 2D  
 

 
 

 

Step 1 

1) Choose from Files or type in 

1234RDDTM001.dat for file name.  This 

will create a file you can use to create a 

DTM. 

 

2) Set Decimal to 4 or greater 

 

3) File Type can be either ASCII or Binary. 

 

4) Set File Open to Create. The first extract 

should have Create set.  Additional points 

can be Added to this file by changing from 

Create to Append. 

 

5) Set Feature to Spots. This will extract the 

mass point from the design file. In most 

cases they look like green dots. 

 

6) Set Mode to Extraction 

 

7) Select Criteria to match your elements to 

be extracted.  A quick method of matching 

is to use the match button and select your 

element. E_MISC_DTM_GROUNDSHOT 

 

8) Select Types to Text and Text Nodes and 

Set toggle to Content. This will read the 

Elevation text to get the Z information. 

Select OK 

 

9) Set Extract – View 1.  Be sure you can see 

the whole drawing in view 1 

 

10) Click on Apply. This will create the text 

file containing Spot elevation information. 
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Step 2 

 

1) Change the File Open to Append 

 

2) Change Feature to Breaks. Make sure 

stroking values have been set. 

 

3) Change Mode to Interpolation 

 

4) Select Criteria to match your elements to be 

extracted.  English levels below. 

 

5) Set Spot Criteria Type to Text and Text Node, 

Set Toggle to Content. In order to get the 

elevation of break line from a 2d file Geopak 

must read the Content of the elevation text.  

Geopak will only read the elevation text that is 

near the break lines 

 

6) Set Longitudinal Reference Criteria Level 

Mask to match your elements.  

 

7) Set tolerance to 0.01 

 

8) Select Apply. At this point Geopak will add the 

Break lines to the existing dat file. 
 

Be sure all criteria are set before you apply.      Levels to be used for English: 

E_MISC_DTM_GROUNDSHOT, E_MISC_DTM_BOUNDRY, 

E_MISC_DTM_GRADEBREAK, E_MISC_DTM_ISLAND, E_MISC_DTM_OBSCURE 

 

You have now created an XYZ file you can create a .tin file with. 
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36.4 3D Survey file from CAICE 
File name will be similar to this naming convention 1234DIDTM001.dgn 

 

Step 1 

1) Choose from Files or type in 

1234RDDTM001.dat for file name.  This 

will create a file you can use to create a 

DTM. 

2) File Type can be either ASCII or Binary. 

For ASCII set Decimal to 4 or greater. 

3) Set File Open to Create. The first extract 

should have Create set.  Additional points 

can be Added to this file by changing from 

Create to Append. 

4) Set Feature to Graphic Triangles. This will 

extract the triangles from the design file. In 

most cases they look like existing TIN. 

5) Set Mode to Extraction 

6) Set Levels for CASIE 3D file. Select 

Criteria to match your elements to be 

extracted.  A quick method of matching is 

to use the match button and select your 

element.  Select OK 

7) Set Extract – View 1.  Be sure you can see 

the whole drawing in view 1. 

8) Click on Apply. This will create the text 

file with the graphic triangle information. 

 

 

Step 2 

  

1) Change the File Open to Append 

 

2) Change Feature to Boundary 

 

3) Set Levels to match your elements to be 

extracted.  A quick method of matching is to 

use the match button and select your element.  

 

4) Select Apply. At this point Geopak will add the 

boundaries to the existing dat file. 

 

You have now created an XYZ file you can create 

a .tin file with. 
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36.5 Extract XYZ ASCII  

 

Extract ASCII Format option will open the following dialog box.  

 

This dialog will reformat the existing XYZ data file to a format that Geopak can create a DTM 

from.  GEOPAK requires the following information for each data point: Point Code, X-

coordinate, Y-coordinate and Z-coordinate.  Other informational items include Point 

Number, Linking Code, Chain, DTM, Zone, and combination Linking Code Point Code. 

For more information see the Geopak Help Online – Command Reference > DTM Tools 

 

 

1) Set the Input file name 

to the file that contains 

the XYZ data. An 

example of the first 

few lines of the data 

file will show in the 

Contents of File. 
 

2) Set the Output file to 

the file you wish to 

create. Use this format 

1234GRND.dat  

 

3) Set the Delimiter to space. If you have commas or some other delimiter you will need to set it 

to that. 

 

4) Select one line of data within the Contents of File area and the information from that line will 

appear below. 

 

5) At this point you will need to set the button below each number or text to the correct setting 

as shown in the example. In some cases you will not have a column for PCODE, this is ok 

but you will get a message that you have not defined the PCODE. Just Select OK if you get 

this message and Geopak will create the DTM input file.  

 

6) Select Process. This will convert the data file to a DTM input file that Geopak can create a 

DTM from. 

 

You have now created an XYZ file you can create a .tin file with. 
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36.6 Create Digital Terrain Model 
 

 

To create the .tin file go to BUILD-

TRIANGLES.  

 

1) Choose or Type in the name of the xyz data 

file created above. 

 

2) Choose or Type in the name of the tin file 

(triangle file). You are building or replacing 

this file. 

 

3) Choose None for Dissolve Option.   

Note: For RDS cross sections set 

Dissolve Option to Side and set distance 

slightly larger than your surveyed 

distance between cross sections or you 

will get improper triangles. 

 

4) Select on Process. 

 

You have now created the file necessary to create your cross-sections.  To check this file you can 

do the following two steps. 

 

36.6.1 Triangle Statistics 

 

 

Go to Reports > Triangle 

Statistics 

This will open a dialog box that gives information about triangulated file. 
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This allows you to check and make sure that all 

your points are not at the same spot or any 

other mistakes that are obvious such as 1000-

foot difference in elevations when you only 

have a max. 100 foot difference. 

 

I believe the report at left shows a file built in 

error. A rerun is required. 

36.6.2 Display DTM Features 

 

 

 
 

Go to LOAD > DTM Feature 

This will open the Load DTM Feature dialog. 

 

Select File > Open and select DTMEXISTING 

or DTMPROPOSED file that sets symbology 

for loaded features. 

 
 

1) Set Load File to TIN and use Files button to 

select the Tin file. 

 

2) Set the Feature to the feature you wish to 

display. 

 

3) Select Load button 

Hint: To set up the feature setting for Erosion 

control contours use the FILE menu from this 

dialog and OPEN the file 

w:\geopak\erosion.lpf. This will set the features 

as shown to the left. 
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The triangles should now be displayed on the screen laid over your alignment. Now you can 

visually inspect the triangle file for any gaps that should not exist or if there are extra triangles 

that should not be there.  If there are go back to Build-Triangles and adjust the side length until it 

looks right. A contour map may be created by using the macro: RD > Create DGNs > select 

Contour Map File, English and use the PH file as the Base Map > Create DGN’S - creates 

1234RDCMA001.dgn. 

 

36.7 Creating DTM input from existing cross section file 
 

 

Within the Project manager 

dialog select Reports & XS 

Quantities. 

 

Must be in the cross section 

file to use cross section 

reports. 

 

Select DTM Input. 
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1) If you are using Project Manager the 

following will be filled-in 

a) Job Number 

b) Chain 

c) Begin & End Station 

d) XS Element Symbology 

2) or Set the Following for XS Elements 

a) Level = 2 

b) Weight = 2 

c) Style = 0 

3) Enter a ASCII file name 

4) Select Apply 

 

You have now created an XYZ file you can create a .tin file with.  Go to section 5.6. 

See Geopak Help Online – Command Reference > Cross Sections Optional direct link to Help 

press F1 when dialog is active. 

 

36.7.1 View X-Sections profile from DTM 
 

 

 
 

Select Analysis > Profile from either the menu 

or icon ribbon. 

 

Selection 

1) Select TIN file 

 

2) You can set the symbology for the element 

   Right click on the line symbol 

 

3) Select Add 

 

4) Go to Profile tab 
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Profile 

1) Select the Select Element or Place Element 

button. 

2) Select the Element or place the line on the 

screen. 

3) The profile will appear in the dialog 

4) You can place this image on the design file 

if you wish. You may wish to set the 

preferences before placing this on the 

design file. 

 

Preference 

At this time there is not a standard. 
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36.8 Creating DTM input from Existing & Proposed Cross section file 

 

Select Reports & XS 

Quantities or From 

Road Tools Menu > XS 

Reports 
 

Must be in the cross 

section file to use cross 

section reports 

 

 

Select DTM Prop. 3D. 

 

 

1) If you are using Project Manager the 

following will be filled-in 

a) Job Number 

b) Chain 

c) Begin & End Station 

d) Existing Ground Line 

e) Proposed Finish Grade  

2) Set Search Criteria:  

    Existing Ground Line 

Level = E_Ground_XS_Delineation 

    Proposed Finish Grade 
Level = 

P_Template_Design_Alignment_Finished_Grade 

3) Enter a ASCII file name 

4) Select Apply 

You have now created a DTM file to be used to create a .tin file. 

See Geopak Help Online – Command Reference > Cross Sections Optional direct 

link to Help press F1 when dialog is active 
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37 Create Patterns from Existing Ground Cross Sections 
 

 
 

 

 

In Project manager Select Existing 

Ground Cross-Sections. You will 

need to Create or Rename a run. 

 

Or 

 

Select Ground Cross Sections From 

DTM from the Geopak Road Tools 

Menu 

 

1) Select the cross section file needed 

 

2) Select the chain (baseline). 

 

3) Set the symbology of the pattern 

lines. 

 

4) Make sure the map file is open. 

 

5) Click Draw Pattern Lines.  The 

new pattern lines will be drawn 

according to the cross sections. 
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38 Topography or Signing 
 

Placing Point Data 

 

 

Open DP Station/Offset dialog 

 

If you are using Project manager the Job # and 

Chain will be filled-in.  

Topo & Signing is done on the strip map file. 

 

1. Type in station location of point data. 

 

2. Type in offset from centerline. 

  A minus (-) sign represents offset left. 

  A plus (+) or no sign represents offset 

right. 

 

 3.  Choose MicroStation command for placing 

your specific type of point data. (For most 

topography and signs, this will be PLACE 

ACTIVE CELL.  Make sure to attach Cell 

Library before trying to place cells.) 

 

 4.  Click on DP. 

 

The point data you were placing should appear on your screen at the correct location. (You 

must have this part of your alignment on the screen to see the element.)   

 

 5. Repeat steps 1- 4 to continue placing point data. 
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39 Ancillary 
39.1 GEOPAK Ancillary Process (LINES) 
 

This process handles the lines from the design file – to process cells go to section 39.2.  

NOTE: There are standard files defined in CADDSTD\GEOPAK\*.afd. In order to use these 

copy and paste the required file into C:\dgn and rename to your project - nnnnRDADF001.afd 

 

 

  
 

Open the Draw Ancillary Features  

OR 

GEOPAK ROAD > Cross Sections > 

Draw Ancillary Features get the window. 

 

This is used to draw features such as 

underground utilities and Row on the 

working cross sections. 

 

 

 

1) If you copied a .afd file from 

CADDSTD, then File > Load > 

Select the file you copied. 

2) Select Job 

3) Select Chain 

4) Set View to Cross Section  

5) Select Intersecting Element Level 

Symbology or Feature. Match 

symbology from the actual file. 

6) Select the SPECIFIC file that 

contains the level symbology or 

feature you wish to look for. 
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7) Check on Extract Elevation. Use 

the existing Ground Cross sections. 

 

8) Set to Level Symbology or 

Feature. If looking at the cross 

section file with standard settings 

then Feature & XS-EGRND can 

be used as shown. Otherwise, use 

symbology and match as below. 

 

9) Set Search criteria to existing 

ground line on cross sections. 

 

10) Reset & Match element symbology. 

 

 

11) Change Display Settings to Cell 

 

12) Click spyglass and select cell from 

ancillary features list. You may 

have to File > Open to find the 

correct cell library 

W:\workgroup\RDSTD\cell\X-

SECTIONS.cell  
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13) Check drawing setting and set the 

Level, Color, and Weight you wish 

to place the cell on.  

 

 

14) Set Justification to Origin. 

 

15) ADD into dialog box. If changing 

an existing entry make sure to 

Modify that entry. 

 

16) You may do a File > Save As if you 

desire to save all this work. 

 

17) Click Draw button.  

 

The process should draw the selected cell 

into the designated file everywhere it finds 

matching intersecting elements in the 

designated design file. 

 

You may do one element at a time or add 

multiple elements into the dialog and draw 

them all at the same run. 
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39.2 MDT GPK Ancillary (CELLS) 
 

This process handles cells from the design file – to process lines go to section 38.1. 

 

 
 

Open the Road Design > XS File tab > 

GPK Ancillary 

 
 

1. Enter Job and Chain 

 

2. Select feature file 

 

3. Select TIN file 

 

4. Select cell feature from drop-down 

list 

 

5. The following dialog box appears – 

do step 7 & 8 

 

6. After performing the selection 

below, click on the road icon to 

perform the actual search. 

Go to step 9.  
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7. Select all or some features to search 

for. Use shift+click for a range or 

ctrl+click to select individual 

features. 

List of search selections for each 

feature shown below. 

 

8. Click OK to lock in the search 

selection. 

 

9. This dialog box shows all features 

selected. 

 

10. You can do many things using this 

box: 

a. Sort features 

b. Select features and draw 

cells onto the XS view 

c. Create a text table of the 

selected features 

d. Save a text file of the 

feature information 

 

11. Clicking the BACK button returns 

to the original dialog box. 

NOTE: Shared cells will NOT be found with this process. Select shared cells to be 

dropped. Convert the cells- Drop Elements > check Complex, Shared Cells [to Normal 

Cell] 

Select in the design area – all selected shared cells should be converted to normal and 

should now be found when performing the search above.
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MDT GPK Ancillary Features 
 

  
ANCILLARY FEATURES ENTRIES 

  TYPE CODE DESCRIPTION LEVEL CELL 

EX_UTILITY_FEATURES 
   

 
FH FIRE HYDRANT E_FH_XS E_FH_XS 

 
GM GAS METER E_GM_XS E_GM_XS 

 
GV GAS VALVE E_GV_XS E_GV_XS 

 
GUY GUY ANCHOR E_GUY_XS E_GUY_XS 

 
LP LIGHT POLE E_LP_XS E_LP_3D 

 
EMH MANHOLE E_EMH E_EMH_XS 

 
EMHE ELECTRICAL MANHOLE E_EMHE_XS E_EMHE_XS 

 
EMHSD STORM DRAIN MANHOLE E_EMHSD_XS E_EMHSD_XS 

 
EMHSS SAN SEWER MANHOLE E_EMHSS_XS E_EMHSS_XS 

 
EMHT TELEPHONE MANHOLE E_EMHT_XS E_EMHT_XS 

 
PP POWER POLE E_PP_XS E_PP_3D 

 
PB PULL BOX E_PB_XS E_PB_XS 

 
PPD POWER PEDASTAL E_PPD_XS E_PPD_XS 

 
TB TELEPHONE BOOTH E_TB_XS E_TB_XS 

 
TCP TELEGRAPH POLE E_TGP_XS E_TGP_XS 

 
TP TELEPHONE POLE E_TP_XS E_TP_XS 

 
TPD TELEPHONE PEDASTAL E_TPD_XS E_TPD_3D 

 
TOWER TOWER E_TOWER_XS E_TOWER_XS 

 
TL TRAFFIC SIGNAL E_TL_XS E_TL_XS 

 
CNTR SIGNAL CONTROLLER E_CNTR_XS E_CNTR_XS 

 
TT TRANSMISSION TOWER E_TT_XS E_TT_XS 

 
VALVE VALVE E_VALVE_XS E_VALVE_XS 

 
WH WATER HYDRANT E_WH_XS E_WH_XS 

 
WM WATER METER E_WM_XS E_WM_XS 

 
WV WATER VALVE E_WV_XS E_WV_XS 

 
WELL WELL E_WELL_XS E_WELL_XS 

EX_UTILITY_X-INGS 
   

 
UTXING UTILITY CROSSINGS E_UTXING_XS 

E_UTXING_3
D 

EX_ROADWAY_FEATURES 
   

 
MAIL MAIL BOX E_MAIL_XS E_MAIL_3D 

 
MILE MILE POST E_MILE_XS E_MILE_3D 

EX_NATURAL_FEATURES 
   

 
TREE TREE E_TREE_XS E_TREE_3D 

 
SHRUB SHRUB E_SHRUB_XS E_SHRUB_3D 

EX_DRAINAGE_FEATURES 
   

 
EDI DROP INLET E_EDI_XS E_EDI_3D 
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EDIR DROP INLET ROUND E_EDIR_XS E_EDIR_3D 

PR_PAYITEM_FEATURES 
   

 
P_REMIEMH REMOVE MANHOLE XS_DEFAULT XS_DEFAULT 

 
P_REMWVB REMOVE WATER VALVE BOXE XS_DEFAULT XS_DEFAULT 

 
P_REMIRR REMOVE IRRIGATION STRUCTURE XS_DEFAULT XS_DEFAULT 

 
P_REMCONCWALL REMOVE CONCRETE HEADWALL XS_DEFAULT XS_DEFAULT 

 
P_REMFH REMOVE FIRE HYDRANT XS_DEFAULT XS_DEFAULT 

 
P_REMINLET REMOVE INLET XS_DEFAULT XS_DEFAULT 

 
P_REMDI REMOVE DROP INLET XS_DEFAULT XS_DEFAULT 

 
P_REMCI REMOVE CURB INLET XS_DEFAULT XS_DEFAULT 

 
P_ABNEMH ABANDON MANHOLE XS_DEFAULT XS_DEFAULT 

 
P_ABNSUMP ABANDON SUMP XS_DEFAULT XS_DEFAULT 

 
P_ABNSEPTIC ABANDON SEPTIC TANK XS_DEFAULT XS_DEFAULT 

 
P_ADJMON ADJUST MONUMENT BOX XS_DEFAULT XS_DEFAULT 

 
P_ADJFH ADJUST FIRE HYDRANT XS_DEFAULT XS_DEFAULT 

 
P_ADJEMH ADJUST MANHOLES XS_DEFAULT XS_DEFAULT 

 
P_ADJDI ADJUST DROP INLET XS_DEFAULT XS_DEFAULT 

 
P_ADJMEDINLET ADJUST MEDIAN INLET XS_DEFAULT XS_DEFAULT 

 
P_ADJVALVE ADJUST VALVE XS_DEFAULT XS_DEFAULT 

 
P_ADJAIR ADJUST AIR RELIEF XS_DEFAULT XS_DEFAULT 

 
P_ADJCRBBOX ADJUST CURB STOP & BOX XS_DEFAULT XS_DEFAULT 

 
P_ADJSUMP ADJUST SUMP XS_DEFAULT XS_DEFAULT 

 
STREET STREET LIGHT P_STREET_XS P_STREET_3D 

 
P_TREE PROPOSED TREE P_TREE_XS P_TREE_3D 

 
P_SHRUB PROPOSED SHRUB P_SHRUB_XS P_SHRUB_3D 

 
P_MH PROPOSED SEWER NODE P_MH_XS P_MH_XS 

LAYDOWN_CURB_FEATURE 
   

 
LAYDOWN CURB LAYDOWN CURB LAYDOWN_CURB 

 GPK_LABELS 
   

 
GPKLBL GPK LABELS GPKLBL 

 CORE_HOLE_FEATURES 
   

 
CORE CORE HOLE CORE 

 CURB_RETURN_LOCATORS 
   

 
P_CURBRTNLOC CURB RETURN LOCATOR P_CURBRTNLOC 

 

     

     



GEOPAK Users Manual  2/19/2015 

 40-1 Existing ROW 

40 Draw Existing ROW on Cross Sections 

 

 

 

 

Pick the Job & Chain. 

Click View: Cross Section 

 

Click File > Load and select 

ROW.AFD file from the 

W:\GEOPAK folder. This will load 

the level symbology used to search 

the ROW file. 
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1. Use the DGN File spy glass 

icon to select the ROW map file. 

2. Check Extract Elevation and 

select TIN and TIN file using spy 

glass. 

3. In Display Settings select 

Cell drop-down box. 

4. Click on spyglass icon to 

get cell (see entry below). 

5. Set Scale to .1 and 

Justification to Center Bottom. 

6. After all entries are as 

required, click the Add or Modify 

Element Set to place in the dialog 

box window. 

7. Make sure a check is in the 

element type you wish to draw & 

click Draw 

 

CELL SELECTION 

 

Click File > Open 

Locate the XSCELLS.CEL file in 

W:\RDSTD\CELL. 

Select the cell you wish to place on 

the cross sections – Here 

E_RWEROW_XS cell is selected 

and it populates the display settings 

cell entry. 

 

This dialog provides options of 

what to do with previously drawn 

elements. 

 

Chose one and click Apply. 

 

The selected elements will be 

drawn onto the cross sections. 

 

 

Use the Navigator to insure the 

requested elements are drawn on 

the cross sections. 



GEOPAK Users Manual  2/19/2015 

 41-1 Boring Logs Process 

41 Boring Logs Process 
 

This process is used to insert boring logs into design and cross section files. 

Files needed: 

 Borehole location file (BHL), located on DMS in the GT directory, CSV format. 

 Borehole material file (BHM), located on DMS in the GT directory, CSV format. 

 GPK file 

 MAP file 

 XSF file 

 

1. Open the map file 

 

2. Start GEOPAK 

 

3. Load Project Manager 

 

4. Applications > 

GEOPAK ROAD > 

Utilities > Geotechnical 

 

5. The borehole navigator 

opens 

 

1. Click File > New 
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1. Name a new .GTD file 

according to standards. 

Example: 

4321RDCOR001 

 

2. OR highlight existing file 

if available. 

 

3. Click SAVE or OK 

 

 

1. Select and find GPK file 

for project. 

 

2. Click spyglass and select 

TIN file. 

 

3. Check Override user 

provided elevation. 

 

4. Click OK 

 

 
 

 

1. Open the boring log 

location .csv file in Excel. 

 

2. If x and y coordinates are 

provided – delete the 

station and offset columns 

completely. 

 

3. If x and y coordinates are 

NOT provided – Cut/Paste 

station and offset data into 

the x & y columns, 

leaving the headers. 

 

4. Save & close the location 

.csv file. 
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Import Location & Material 

CSV Information: 

1. Insure the .csv files are 

closed. 

 

2. File > Import > CSV > 

Borehole 

 

3. Change file type list to All 

Files (*.*) 

 

4. Select borehole (BHL) 

location .csv file  > OK 

 

5. Select borehole (BHM) 

material .csv file > OK 

 

All borehole information 

is now loaded into the 

Geotechnical Process. 

 

If the location file was 

imported using x and y 

coordinates the following is 

how you convert the x and y 

to station and offset.  If 

alignments change just re-

import the original location 

and material files, and 

convert to the new alignment.  

If station and offsets were 

provided skip the next frame. 
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Convert Coordinates to 

Station & Offset. 

1. Select Tools > Convert 

Coord to Sta/Off 

 

2. Convert Coord Dialog 

Box is Displayed. 

 

3. Highlight all boring 

entries, within the dialog 

box window, to be 

converted. 

 

4. Click Select button and 

select the correct chain 

from the Chain Selection 

Dialog Box. 

 

5. Click OK 

 

6. Click Convert  

 

7. The station and offset data 

should now be in the 

borehole navigator. 

 

Set Preferences File. 

1. Click File > Preferences – 

Displays Preferences 

Dialog. 

 

2. Click File and Select the 

preference file from 

W:\GEOPAK depending 

on the scale for the 

alignment and profile. 

 

3. Click OK twice. 
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Place Soil Boring Data on Plan View. 

 

 

1. Click Visualize Boreholes 

in Plan View – 1
st
 icon. 

 

2. Insure Mapping Scale is 

set to 1.00. 

 

3. Highlight all logs to be 

plotted onto the design 

file. 

 

4. Click Apply. 

 

5. All logs should be found 

on these levels: 
E_SoilData_Borehole 

E_SoilData_Borehole_Text 
 

Plotting stick logs in Profile view. 

 

 

 

1. Click Visualize Boreholes 

in Profile View – 2
nd

 icon. 

2. Select the appropriate 

chain in the drop-down 

box. 

3. Plot according to: 

Borehole Depth 

4. Always use Main Chain. 

5. Highlight all logs to be 

plotted onto profile. 

6. Select appropriate Profile 

from drop-down box. 

7. Click Define Profile 

Origin – displays dialog to 

left. 

8. Click ID Cell > Tentative 

> Accept profile cell on 

design file. 

9. Insure DP Station matches 

Beginning Station.  

10. Click OK. 

11. Click Apply - All stick 

logs that were highlighted 

should populate in the 

specified profile on the 

same levels as described 

above. 

12. Close the windows. 
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Plotting stick logs in Cross Section view. 

 

 

1. Open the XSF file, 

keeping geopak running, 

and the Borehole 

navigator open. 

2. Click Visualize Boreholes 

in Cross Section View – 

3
rd

 icon. 

3. Select appropriate Chain 

from drop-down box. 

4. Always use Main Chain. 

5. Highlight all bore logs to 

be plotted in XS. 

6. Station Range should be 

populated already. 

7. Project onto Nearest XS. 

8. Max projection distance is 

200.00. 

9. Always Project at 

Borehole Ground Elev. 

 

10. Click Symbology button. 

11. Match Lv Names only - 

existing ground cross 

section line. 

12. Close box. 

13. Click Apply. 

 

You may need to check out 

the information messages. 

These borings will not show 

on the design file. 

 

All logs should be found on 

these levels: 

E_SoilData_Borehole 

E_SoilData_Borehole_Text 
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42 Delete Duplicate Elements 
 

If you have duplicate elements in a design file and want to select or delete them you can do it by 

using the Utilities > Data Cleanup tool.  You can Select or Delete elements and use Element 

Type criteria or Match Criteria to select specific element types. Apply it and it will process your 

choices. If you use select, it will tell you at the bottom of the screen how many duplicate 

elements it located.  
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43 GEOPAK Problem Resolution Steps 
 

The following suggestions are steps that may help when encountering a problem in Microstation 

or Geopak. These steps have proven helpful, in prior situations, for getting the software 

operational again and/or overcoming a non-responsive operation. 
 

1. When the initial problem is encountered the following steps should be done in the order 

described. 

a. Double check all dialog box entries to insure they are as expected. 

b. Double check all symbology selected to insure it is exactly what you need for the 

function you are attempting. 

 

2. If an error message is encountered: 

a. If an error is displayed, read it before continuing. If you understand it and can fix the 

problem, then fix the problem and restart the attempted function. 

b. If you do not understand the error or don’t know how to fix it, seek out help from 

your fellow team mates – one of them may have seen and/or resolved that error 

before. 

 

3. Initialize Geopak/Microstation: 

a. Run KILLTASK.BAT enter ‘Y’ and hit Enter when prompted. KILLTASK.bat 

should reside on your desktop. It is located on CADDSTD for copying. 

b. Restart Microstation/Geopak 

c. Reattempt the function that you were having problems with. 

 

4. Recreate .upf file 

a. Exit Microstation 

b. Go to C:\mdoh folder 

c. Highlight file U####V8i.upf  (where # is your employee number) and rename it 

to SAVEU####V8i.upf. This file contains your preferences for Microstation. 

d. Restart Microstation/Geopak – this will recreate the U####V8i.upf file. You will 

notice that toolbars & menus may have changed from your preferred settings. 

e. Reattempt the function that you were having problems with. If this works you should 

delete the saved .upf file. 

 

5. Still no resolution send an email to MDT CADD Support that contains the following: 

 Computer Number  Eg. MDTHLNRODC164 

 Project Number  
 GPK File 

 Pxsprj.inp (Proposed Cross Section Input File) 

 Proposed DGN file containing Patterns, Shapes and Profiles 

 Cross Section Drawing where sections are processed and you give me a reference to 
the problem cross section, if applicable. 

 Existing topo drawing – TIN file 

 A DETAILED description of the problem or situation that needs to be fixed. 
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Appendix A:  Storing a Spiral with Master PI 
 

STORING A CHAIN WITH A SPIRAL TO INCLUDE MASTER PI 

First, store the spiral using the simple curve PI and Radius as shown below: 

         

 
<*       1   Store SCS STEST PB 10 PI 11 LS1 210 LS2 210 Radius 2700 PA 125                                              

                                                                                                                         

SCS STEST                                                                                                                

PISCS  STEST  N      1,004,194.433  E      1,875,766.406  STA      23+16.22                                              

Total Tangent  =           2,316.215                                                                                     

Total Length   =           3,914.823                                                                                     

Total Delta    =      78° 37' 07.62" (LT)                                                                                

Back Tangent   = S   1° 35' 31.11" E                                                                                     

Ahead Tangent  = S  80° 12' 38.73" E                                                                                     

Spiral Back                                                                                                              

Spiral STESTB             Type 1    Spiral Element                                                                       

                                                                                                                         

Angle       2° 13' 41.41" (LT) P              0.681   BK S   1° 35' 31.11" E                                             

LS              210.000        K            104.995   AH S   3° 49' 12.52" E                                             

R             2,700.000        LT           140.011   CB S   2° 20' 04.88" E                                             

YS                2.722        ST            70.010   Defl        0° 44' 33.77"                                          

XS              209.968        LC           209.986   Deg         2° 07' 19.44"                                          

                                                                                                                         

                                                                                                                         

                         Spiral Coordinates                                                                              

                        *------------------*                                                                             

Point           North                   East                  Station                                                    

-----    -------------------    -------------------     -------------------                                              

TS             1,006,509.755          1,875,702.058                 0+00.00                                              

PI             1,006,369.798          1,875,705.948                 1+40.01                                              

SC             1,006,299.943          1,875,710.612                 2+10.00                                              

CC             1,006,479.830          1,878,404.613                                                                      

Circular Section                                                                                                         

                                   Curve Data                                                                            

                                  *----------*                                                                           

Curve STEST                                                                                                              
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P.I.  Station            20+40.60  N       1,004,263.874  E       1,875,846.567                                          

Delta       =      74° 09' 44.80" (LT)                                                                                   

Degree      =       2° 07' 19.44"                                                                                        

Tangent     =           2,040.603                                                                                        

Length      =           3,494.823                                                                                        

Radius      =           2,700.000                                                                                        

External    =             684.385                                                                                        

Long Chord  =           3,255.911                                                                                        

Mid. Ord.   =             545.990                                                                                        

P.C.  Station             0+00.00  N       1,006,299.943  E       1,875,710.612                                          

P.T.  Station            34+94.82  N       1,003,839.002  E       1,877,842.449                                          

C.C.                               N       1,006,479.830  E       1,878,404.613                                          

Back        = S   3° 49' 12.52" E                                                                                        

Ahead       = S  77° 58' 57.32" E                                                                                        

Chord Bear  = S  40° 54' 04.92" E                                                                                        

Spiral Ahead                                                                                                             

Spiral STESTA             Type 2    Spiral Element                                                                       

                                                                                                                         

Angle       2° 13' 41.41" (LT) P              0.681   BK S  77° 58' 57.32" E                                             

LS              210.000        K            104.995   AH S  80° 12' 38.73" E                                             

R             2,700.000        LT           140.011   CB S  79° 28' 04.96" E                                             

YS                2.722        ST            70.010   Defl        0° 44' 33.77"                                          

XS              209.968        LC           209.986   Deg         2° 07' 19.44"                                          

                                                                                                                         

                                                                                                                         

                         Spiral Coordinates                                                                              

                        *------------------*                                                                             

Point           North                   East                  Station                                                    

-----    -------------------    -------------------     -------------------                                              

CS             1,003,839.002          1,877,842.449                 0+00.00                                              

PI             1,003,824.425          1,877,910.925                 0+70.01                                              

ST             1,003,800.620          1,878,048.897                 2+10.00                                              

CC             1,006,479.830          1,878,404.613                                                                      

SCS STEST stored           

 

 

When storing the chain with the spiral, the dialog box will show the spiral as STESTA 

&STESTB. 
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…..and if you clicked on Add, it would display like below. 

 

 

          
 

 

 

Edit out the SPI and replace with SCS. Also, edit out the A so it looks like below: 
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<*       2   Store Chain test 10 SCS STEST CUR C12 125 Station 10+00                                                

                                                                                                                         

Chain TEST redefined                        

 

Check to make sure the print out shows the Master PI for the chain, as show in bold below: 

 

<*       3   Describe Chain TEST                                                                                         

                                                                                                                         

Chain TEST contains:                                                                                                     

 10 SCS STEST CUR C12 125                                                        

                                                                                                                         

Beginning chain TEST description                                                                                         

=====================================================================

==========                                          

                                                                                                                         

Point 10              N    1,008,886.911 E    1,875,635.991 Sta      10+00.00                                            

                                                                                                                         

Course from 10 to TS STESTB S 1° 35' 31.11" E Dist 2,378.074                                                             

                                                                                                                         

SCS STEST found within chain TEST, contains:                                                                             

SPI STESTB CUR STEST  SPI STESTA                                                 

                                                                                                                         

PISCS  STEST  N      1,004,194.433  E      1,875,766.406  STA      56+94.29                                              

Total Tangent  =           2,316.215                                                                                     

Total Length   =           3,914.823                                                                                     

Total Delta    =      78° 37' 07.62" (LT)                                                                                

Back Tangent   = S   1° 35' 31.11" E                                                                                     

Ahead Tangent  = S  80° 12' 38.73" E                                                                                     

                                                                                                                         

Beginning SCS STEST description                                                                                          

------------------------------------------------------------------------------                                           

                                                                                                                         

Spiral Back                                                                                                              

Spiral STESTB             Type 1    Spiral Element                                                                       

                                                                                                                         

Angle       2° 13' 41.41" (LT) P              0.681   BK S   1° 35' 31.11" E                                             

LS              210.000        K            104.995   AH S   3° 49' 12.52" E                                             

R             2,700.000        LT           140.011   CB S   2° 20' 04.88" E                                             

YS                2.722        ST            70.010   Defl        0° 44' 33.77"                                          

XS              209.968        LC           209.986   Deg         2° 07' 19.44"                                          

                                                                                                                         

                                                                                                                         

                         Spiral Coordinates                                                                              

                        *------------------*                                                                             

Point           North                   East                  Station                                                    

-----    -------------------    -------------------     -------------------                                              

TS             1,006,509.755          1,875,702.058                33+78.07                                              

PI             1,006,369.798          1,875,705.948                35+18.09                                              

SC             1,006,299.943          1,875,710.612                35+88.07                                              

CC             1,006,479.830          1,878,404.613                                                                      
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Circular Section                                                                                                         

                                   Curve Data                                                                            

                                  *----------*                                                                           

Curve STEST                                                                                                              

P.I.  Station            56+28.68  N       1,004,263.874  E       1,875,846.567                                          

Delta       =      74° 09' 44.80" (LT)                                                                                   

Degree      =       2° 07' 19.44"                                                                                        

Tangent     =           2,040.603                                                                                        

Length      =           3,494.823                                                                                        

Radius      =           2,700.000                                                                                        

External    =             684.385                                                                                        

Long Chord  =           3,255.911                                                                                        

Mid. Ord.   =             545.990                                                                                        

P.C.  Station            35+88.07  N       1,006,299.943  E       1,875,710.612                                          

P.T.  Station            70+82.90  N       1,003,839.002  E       1,877,842.449                                          

C.C.                               N       1,006,479.830  E       1,878,404.613                                          

Back        = S   3° 49' 12.52" E                                                                                        

Ahead       = S  77° 58' 57.32" E                                                                                        

Chord Bear  = S  40° 54' 04.92" E                                                                                        

                                                                                                                         

Spiral Ahead                                                                                                             

Spiral STESTA             Type 2    Spiral Element                                                                       

                                                                                                                         

Angle       2° 13' 41.41" (LT) P              0.681   BK S  77° 58' 57.32" E                                             

LS              210.000        K            104.995   AH S  80° 12' 38.73" E                                             

R             2,700.000        LT           140.011   CB S  79° 28' 04.96" E                                             

YS                2.722        ST            70.010   Defl        0° 44' 33.77"                                          

XS              209.968        LC           209.986   Deg         2° 07' 19.44"                                          

                                                                                                                         

                                                                                                                         

                         Spiral Coordinates                                                                              

                        *------------------*                                                                             

Point           North                   East                  Station                                                    

-----    -------------------    -------------------     -------------------                                              

CS             1,003,839.002          1,877,842.449                70+82.90                                              

PI             1,003,824.425          1,877,910.925                71+52.91                                              

ST             1,003,800.620          1,878,048.897                72+92.90                                              

CC             1,006,479.830          1,878,404.613                                                                      

                                                                                                                         

------------------------------------------------------------------------------                                           

Ending SCS STEST description                                                                                             

                                                                                                                         

Course from ST STESTA to PC C12 S 82° 22' 47.85" E Dist 15,399.251                                                       

                                                                                                                         

                                   Curve Data                                                                            

                                  *----------*                                                                           

Curve C12                                                                                                                
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P.I.  Station           234+66.05  N       1,001,652.214  E       1,894,078.715                                          

Delta       =      15° 23' 02.00" (RT)                                                                                   

Degree      =       0° 59' 59.73"                                                                                        

Tangent     =             773.906                                                                                        

Length      =           1,538.502                                                                                        

Radius      =           5,730.000                                                                                        

External    =              52.027                                                                                        

Long Chord  =           1,533.885                                                                                        

Mid. Ord.   =              51.558                                                                                        

S. E.       =              0.040                                                                                         

P.C.  Station           226+92.15  N       1,001,758.631  E       1,893,312.161                                          

P.T.  Station           242+30.65  N       1,001,346.254  E       1,894,789.573                                          

C.C.                               N         996,083.062  E       1,892,524.246                                          

Back        = S  82° 05' 47.00" E                                                                                        

Ahead       = S  66° 42' 45.00" E                                                                                        

Chord Bear  = S  74° 24' 16.00" E                                                                                        

                                                                                                                         

Course from PT C12 to 125 S 66° 42' 45.00" E Dist 1,832.329                                                              

                                                                                                                         

Point 125             N    1,000,621.852 E    1,896,472.627 Sta     260+62.98                                            

                                                                                                                         

=====================================================================

==========                                          

Ending chain TEST description                                                                                                                                                                         
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 1  Appendix B 

Appendix B:  Civil Alignment Fix 
 

There are two things you can do that sometimes helps … 

 

 
 

 In the Key In Browser, 

you can keyin “Civil 

Display Browser”. It will 

take a few minutes to 

come up since it has to do 

some checking … but 

eventually a dialog comes 

up that looks like this:  

 

Click on the icon with 

the red cross … this will 

try to clean up any 

issues. 

 

 

.      Open the MicroStation 

Project Explorer dialog 

(File > Project Explorer) 

 

Select the LINKS tab, and 

set the option to Active 

Directory 

 

 

 

Right-click on Views and 

select Validate. 

 

 


